精华内容
下载资源
问答
  • H3C交换机配置命令大全
  • H3C交换机配置命令大全
  • h3c交换机命令大全,适合网管参考使用.
  • H3C交换机配置命令大全》,很全,适合大家学习。
  • H3C交换机配置命令大全【转载】

    千次阅读 2019-02-26 22:10:11
    H3C不但拥有全线路由器和以太网交换机产品,还在网络安全、IP存储、IP监控、语音视讯、WLAN、SOHO及软件管理系统等领域稳健成长。 在以太网领域,H3C经历多年的耕耘和发展,积累了大量业界领先的知识产权和专利,可...

    杭州华三通信技术有限公司(简称H3C), 致力于IP技术与产品的研究、开发、生产、销售及服务。H3C不但拥有全线路由器和以太网交换机产品,还在网络安全、IP存储、IP监控、语音视讯、WLAN、SOHO及软件管理系统等领域稳健成长。

    在以太网领域,H3C经历多年的耕耘和发展,积累了大量业界领先的知识产权和专利,可提供业界从核心到接入10多个系列上百款交换机产品。所有产品全部运行H3C自主知识产权的Comware软件,对外提供统一的操作命令接口,最大化的简化产品的配置。

    (在命令行界面,可以直接打“tab”键来补全命令)

    1、配置文件相关命令 
    [Quidway]display current-configuration         ;显示当前生效的配置 
    [Quidway]display saved-configuration           ;显示flash中配置文件,即下次上电启动时所用的配置文件 
    <Quidway>reset saved-configuration           ;檫除旧的配置文件 
    <Quidway>reboot                                    ;交换机重启 
    <Quidway>display version                          ;显示系统版本信息 

    2、基本配置 
    [Quidway]super password                                     ;修改特权用户密码 
    [Quidway]sysname                                     ;交换机命名 
    [Quidway]interface ethernet 0/1                            ;进入接口视图 
    [Quidway]interface vlan x                            ;进入接口视图,一般用于配置vlan1的管理地址,即inter vlan 1。 
    [Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0    ;配置VLAN的IP地址,即交换机管理地址 
    [Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2          ;静态路由=网关 

    3、telnet配置 
    [Quidway]user-interface vty 0 4                            ;进入虚拟终端 
    [S3026-ui-vty0-4]authentication-mode password                ;设置口令模式 
    [S3026-ui-vty0-4]set authentication-mode password simple 222  ;设置口令 
    [S3026-ui-vty0-4]user privilege level 3                      ;用户级别 

    4、端口配置(要先进入到相应的端口) 
    [Quidway-Ethernet0/1]duplex {half|full|auto}                ;配置端口工作状态 
    [Quidway-Ethernet0/1]speed {10|100|auto}                ;配置端口工作速率 
    [Quidway-Ethernet0/1]flow-control                      ;配置端口流控 
    [Quidway-Ethernet0/1]mdi {across|auto|normal}                ;配置端口平接扭接 
    [Quidway-Ethernet0/1]port link-type {trunk|access|hybrid}    ;设置端口工作模式 
    [Quidway-Ethernet0/1]undo shutdown                     ;激活端口(针对每个端口的具体配置时,必须要undo掉) 
    [Quidway-Ethernet0/2]quit                            ;退出系统视图 

    5、链路聚合配置

         链路聚合(Link Aggregation)又称Trunk,是指将多个物理端口捆绑在一起,成为一个逻辑端口,以实现出/ 入流量在各成员端口中的负荷分担,交换机根据用户配置的端口负荷分担策略决定报文从哪一个成员端口发送到对端的交换机。当交换机检测到其中一个成员端口的链路发生故障时,就停止在此端口上发送报文,并根据负荷分担策略在剩下链路中重新计算报文发送的端口,故障端口恢复后再次重新计算报文发送端口。链路聚合在增加链路带宽、实现链路传输弹性和冗余等方面是一项很重要的技术。 
    [DeviceA] link-aggregation group 1 mode manual     ;创建手工聚合组1 
    [DeviceA] interface ethernet 1/0/1                             ;将以太网端口Ethernet1/0/1加入聚合组1 
    [DeviceA-Ethernet1/0/1] port link-aggregation group 1

    “Can not specify a loopback-detection enable port as aggregation group member ! ”回环检测  
    [DeviceA -Ethernet1/0/1]undo loopback-detection enable

    [DeviceA-Ethernet1/0/1] port link-aggregation group 1  
    [DeviceA] interface ethernet 1/0/2              ;将以太网端口Ethernet1/0/2加入聚合组1 
    [DeviceA-Ethernet1/0/2] port link-aggregation group 1 
    [DeviceA] link-aggregation group 1 service-type tunnel # 在手工聚合组的基础上创建Tunnel业务环回组。 
    [DeviceA] interface ethernet 1/0/1      # 将以太网端口Ethernet1/0/1加入业务环回组。 
    [DeviceA-Ethernet1/0/1] undo stp 
    [DeviceA-Ethernet1/0/1] port link-aggregation group 1 

    6、端口镜像 
    [Quidway]monitor-port <interface_type interface_num>       ;指定镜像端口 
    [Quidway]port mirror <interface_type interface_num>    ;指定被镜像端口 
    [Quidway]port mirror int_list observing-port int_type int_num ;指定镜像和被镜像 

    7、VLAN配置 
    [Quidway]vlan 3                                  ;创建VLAN 
    [Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 ;在VLAN中增加端口 
    配置基于access的VLAN 
    [Quidway-Ethernet0/2]port access vlan 3          ;当前端口加入到VLAN          
    注意:缺省情况下,端口的链路类型为Access类型,所有Access端口均属于且只属于VLAN1 
    配置基于trunk的VLAN 
    [Quidway-Ethernet0/2]port link-type trunk                          ;设置当前端口为trunk 
    [Quidway-Ethernet0/2]port trunk permit vlan {ID|All}    ;设trunk允许的VLAN             
    注意:所有端口缺省情况下都是允许VLAN1的报文通过的 
    [Quidway-Ethernet0/2]port trunk pvid vlan 3    ;设置trunk端口的PVID 
    配置基于Hybrid端口的VLAN 
    [Quidway-Ethernet0/2]port link-type hybrid    ;配置端口的链路类型为Hybrid类型 
    [Quidway-Ethernet0/2]port hybrid vlan vlan-id-list { tagged | untagged };允许指定的VLAN通过当前Hybrid端口 
    注意:缺省情况下,所有Hybrid端口只允许VLAN1通过 
    [Quidway-Ethernet0/2]port hybrid pvid vlan vlan-id ;设置Hybrid端口的缺省VLAN                                    
    注意:缺省情况下,Hybrid端口的缺省VLAN为VLAN1 
    VLAN描述 
    [Quidway]description string                      ;指定VLAN描述字符 
    [Quidway]description                         ;删除VLAN描述字符 
    [Quidway]display vlan [vlan_id]                            ;查看VLAN设置 
    私有VLAN配置 
    [SwitchA-vlanx]isolate-user-vlan enable          ;设置主vlan 
    [SwitchA]Isolate-user-vlan <x> secondary <list>    ;设置主vlan包括的子vlan 
    [Quidway-Ethernet0/2]port hybrid pvid vlan <id>    ;设置vlan的pvid 
    [Quidway-Ethernet0/2]port hybrid pvid             ;删除vlan的pvid 
    [Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged ;设置无标识的vlan 
    如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。 
    所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged. 

    8、STP配置 
    [Quidway]stp {enable|disable}                               ;设置生成树,默认关闭 
    [Quidway]stp mode rstp                                         ;设置生成树模式为rstp 
    [Quidway]stp priority 4096                         ;设置交换机的优先级 
    [Quidway]stp root {primary|secondary}             ;设置为根或根的备份 
    [Quidway-Ethernet0/1]stp cost 200                ;设置交换机端口的花费 
    MSTP配置: 
    # 配置MST域名为info,MSTP修订级别为1,VLAN映射关系为VLAN2~VLAN10映射到生成树实例1上,VLAN20~VLAN30映射生成树实例2上。 
    <Sysname> system-view 
    [Sysname] stp region-configuration 
    [Sysname-mst-region] region-name info 
    [Sysname-mst-region] instance 1 vlan 2 to 10 
    [Sysname-mst-region] instance 2 vlan 20 to 30 
    [Sysname-mst-region] revision-level 1 
    [Sysname-mst-region] active region-configuration 

    9、MAC地址表的操作 
    在系统视图下添加MAC地址表项 
    [Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id  ;添加MAC地址表项  
    在添加MAC地址表项时,命令中interface参数指定的端口必须属于vlan参数指定的VLAN,否则将添加失败。 
    如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。 
    在以太网端口视图下添加MAC地址表项 
    [Quidway-Ethernet0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id 
    在添加MAC地址表项时,当前的端口必须属于命令中vlan参数指定的VLAN,否则将添加失败; 
    如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。 
    [Quidway]mac-address timer { aging age | no-aging }   ;设置MAC地址表项的老化时间 
    注意:缺省情况下,MAC地址表项的老化时间为300秒,使用参数no-aging时表示不对MAC地址表项进行老化。 
    MAC地址老化时间的配置对所有端口都生效,但地址老化功能只对动态的(学习到的或者用户配置可老化的)MAC地址表项起作用。 
    [Quidway-Ethernet0/2]mac-address max-mac-count count   ;设置端口最多可以学习到的MAC地址数量 
    注意:缺省情况下,没有配置对端口学习MAC地址数量的限制。反之,如果端口启动了MAC地址认证和端口安全功能,则不能配置该端口的最大MAC地址学习个数。 
    [Quidway-Ethernet0/2]port-mac start-mac-address    ;配置以太网端口MAC地址的起始值 
    在缺省情况下,E126/E126A交换机的以太网端口是没有配置MAC地址的,因此当交换机在发送二层协议报文(例如STP)时,由于无法取用发送端口的MAC地址, 
    将使用该协议预置的MAC地址作为源地址填充到报文中进行发送。在实际组网中,由于多台设备都使用相同的源MAC地址发送二层协议报文,会造成在某台设备的不 
    同端口学习到相同MAC地址的情况,可能会对MAC地址表的维护产生影响。 
    [Quidway]display mac-address       ;显示地址表信息 
    [Quidway]display mac-address aging-time         ;显示地址表动态表项的老化时间 
    [Quidway]display port-mac            ;显示用户配置的以太网端口MAC地址的起始值 

    10、GVRP配置 
    [SwitchA] gvrp      # 开启全局GVRP 
    [SwitchA-Ethernet1/0/1] gvrp     # 在以太网端口Ethernet1/0/1上开启GVRP 
    [SwitchE-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal }   #  配置GVRP端口注册模式    缺省为normal 
    [SwitchA] display garp statistics [ interface interface-list ]    ;显示GARP统计信息 
    [SwitchA] display garp timer [ interface interface-list ]       ;显示GARP定时器的值 
    [SwitchA] display gvrp statistics [ interface interface-list ]    ;显示GVRP统计信息 
    [SwitchA] display gvrp status                                             ;显示GVRP的全局状态信息 
    [SwitchA] display gvrp statusreset garp statistics [ interface interface-list ]    ;清除GARP统计信息 

    11、DLDP配置 
    [SwitchA] interface gigabitethernet 1/1/1        # 配置端口工作在强制全双工模式,速率为1000Mbits/s。 
    [SwitchA-GigabitEthernet1/1/1] duplex full 
    [SwitchA-GigabitEthernet1/1/1] speed 1000 
    [SwitchA] dldp enable       # 全局开启DLDP。 
    [SwitchA] dldp interval 15    # 设置发送DLDP报文的时间间隔为15秒。 
    [SwitchA]  dldp work-mode { enhance | normal }   # 配置DLDP协议的工作模式为加强模式。     缺省为normal 
    [SwitchA] dldp unidirectional-shutdown  { auto | manual }    # 配置DLDP单向链路操作模式为自动模式。  缺省为auto 
    [SwitchA] display dldp 1     # 查看DLDP状态。 
    当光纤交叉连接时,可能有两个或三个端口处于Disable状态,剩余端口处于Inactive状态。 
    当光纤一端连接正确,一端未连接时: 
    如果DLDP的工作模式为normal,则有收光的一端处于Advertisement状态,没有收光的一端处于Inactive状态。 
    如果DLDP的工作模式为enhance,则有收光的一端处于Disable状态,没有收光的一端处于Inactive状态。 
    dldp reset命令在全局下可以重置所有端口的DLDP状态,在接口下可以充值该端口的DLDP状态 

    12、端口隔离配置 
    通过端口隔离特性,用户可以将需要进行控制的端口加入到一个隔离组中,实现隔离组中的端口之间二层、三层数据的隔离,既增强了网络的安全性,也为用户 
    提供了灵活的组网方案。 
    [Sysname] interface ethernet1/0/2   # 将以太网端口Ethernet1/0/2加入隔离组。 
    [Sysname-Ethernet1/0/2] port isolate 
    [Sysname]display isolate port   # 显示隔离组中的端口信息 
    配置隔离组后,只有隔离组内各个端口之间的报文不能互通,隔离组内端口与隔离组外端口以及隔离组外端口之间的通信不会受到影响。 
    端口隔离特性与以太网端口所属的VLAN无关。 
    当汇聚组中的某个端口加入或离开隔离组后,本设备中同一汇聚组内的其它端口,均会自动加入或离开该隔离组。 
    对于既处于某个聚合组又处于某个隔离组的一组端口,其中的一个端口离开聚合组时不会影响其他端口,即其他端口仍将处于原聚合组和原隔离组中。 
    如果某个聚合组中的端口同时属于某个隔离组,当在系统视图下直接删除该聚合组后,该聚合组中的端口仍将处于该隔离组中。 
    当隔离组中的某个端口加入聚合组时,该聚合组中的所有端口,将会自动加入隔离组中。 

    13、端口安全配置 
    [Switch] port-security enable   # 启动端口安全功能 
    [Switch] interface Ethernet 1/0/1  # 进入以太网Ethernet1/0/1端口视图 
    [Switch-Ethernet1/0/1] port-security max-mac-count 80  # 设置端口允许接入的最大MAC地址数为80 
    [Switch-Ethernet1/0/1] port-security port-mode autolearn  # 配置端口的安全模式为autolearn 
    [Switch-Ethernet1/0/1] mac-address security 0001-0002-0003 vlan 1   # 将Host 的MAC地址0001-0002-0003作为Security MAC添加到VLAN 1中 
    [Switch-Ethernet1/0/1] port-security intrusion-mode disableport-temporarily   # 设置Intrusion Protection特性被触发后,暂时关闭该端口 
    [Switch]port-security timer disableport 30       # 关闭时间为30秒。 

    14、端口绑定配置 
    通过端口绑定特性,网络管理员可以将用户的MAC地址和IP地址绑定到指定的端口上。进行绑定操作后,交换机只对从该端口收到的指定MAC地址和IP地 
    址的用户发出的报文进行转发,提高了系统的安全性,增强了对网络安全的监控。 
    [SwitchA-Ethernet1/0/1] am user-bind mac-addr 0001-0002-0003 ip-addr 10.12.1.1   # 将Host 1的MAC地址和IP地址绑定到Ethernet1/0/1端口。 
    有的交换机上绑定的配置不一样 
    [SwitchA] interface ethernet 1/0/2 
    [SwitchA-Ethernet1/0/2] user-bind ip-address 192.168.0.3 mac-address 0001-0203-0405 
    端口过滤配置 
    [SwitchA] interface ethernet1/0/1      # 配置端口Ethernet1/0/1的端口过滤功能。 
    [SwitchA-Ethernet1/0/1] ip check source ip-address mac-address 
    [SwitchA] dhcp-snooping        # 开启DHCP Snooping功能。 
    [SwitchA] interface ethernet1/0/2       # 设置与DHCP服务器相连的端口Ethernet1/0/2为信任端口。 
    [SwitchA-Ethernet1/0/2] dhcp-snooping trust 
    在端口Ethernet1/0/1上启用IP过滤功能,防止客户端使用伪造的不同源IP地址对服务器进行攻击 

    15、BFD配置 
    Switch A、Switch B、Switch C相互可达,在Switch A上配置静态路由可以到达Switch C,并使能BFD检测功能。 
    # 在Switch A上配置静态路由,并使能BFD检测功能,通过BFD echo报文方式实现BFD功能。 
    <SwitchA> system-view 
    [SwitchA] bfd echo-source-ip 123.1.1.1 
    [SwitchA] interface vlan-interface 10 
    [SwitchA-vlan-interface10] bfd min-echo-receive-interval 300 
    [SwitchA-vlan-interface10] bfd detect-multiplier 7   
    [SwitchA-vlan-interface10] quit 
    [SwitchA] ip route-static 120.1.1.1 24 10.1.1.100 bfd echo-packet 
    # 在Switch A上打开BFD功能调试信息开关。 
    <SwitchA> debugging bfd event 
    <SwitchA> debugging bfd scm 
    <SwitchA> terminal debugging 
    在Switch A上可以打开BFD功能调试信息开关,断开Hub和Switch B之间的链路,验证配置结果。验证结果显示, 
    Switch A能够快速感知Switch A与Switch B之间链路的变化。 

    16、QinQ配置 
    Provider A、Provider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000,Provider B属于运营商网络的VLAN2000。 
    Provider A和Provider B之间,运营商采用其他厂商的设备,TPID值为0x8200。 
    希望配置完成后达到下列要求: 
    Customer A的VLAN10的报文可以和Customer B的VLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer A的VLAN20的报文可以 
    和Customer C的VLAN20的报文经过运营商网络的VLAN2000转发后互通。 
    [ProviderA] interface ethernet 1/0/1   # 配置端口为Hybrid端口,且允许VLAN10,VLAN20,VLAN1000和VLAN2000的报文通过,并且在发送时去掉外层Tag。 
    [ProviderA-Ethernet1/0/1] port link-type hybrid 
    [ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged 
    [ProviderA-Ethernet1/0/1] qinq vid 1000     # 将来自VLAN10的报文封装VLAN ID为1000的外层Tag。 
    [ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10 
    [ProviderA-Ethernet1/0/1-vid-1000] quit 
    [ProviderA-Ethernet1/0/1] qinq vid 2000    # 将来自VLAN20的报文封装VLAN ID为2000的外层Tag。 
    [ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20 
    [ProviderA] interface ethernet 1/0/2    # 配置端口的缺省VLAN为VLAN1000。 
    [ProviderA-Ethernet1/0/2] port access vlan 1000 
    [ProviderA-Ethernet1/0/2] qinq enable   # 配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID为1000的外层Tag。 
    [ProviderA] interface ethernet 1/0/3   # 配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。 
    [ProviderA-Ethernet1/0/3] port link-type trunk 
    [ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000 
    [ProviderA-Ethernet1/0/3] qinq ethernet-type 8200   # 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。 
    [ProviderB] interface ethernet 1/0/1   # 配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。 
    [ProviderB-Ethernet1/0/1] port link-type trunk 
    [ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000 
    [ProviderB-Ethernet1/0/1] qinq ethernet-type 8200   # 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。 
    [ProviderB-Ethernet1/0/1] quit 
    [ProviderB] interface ethernet 1/0/2   # 配置端口的缺省VLAN为VLAN2000。 
    [ProviderB-Ethernet1/0/2] port access vlan 2000 
    [ProviderB-Ethernet1/0/2] qinq enable   # 配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

    展开全文
  • H3C华为交换机配置命令大全
  • H3C路由器交换机配置命令大全1H3C路由器交换机配置命令大全1
  • H3C交换机常用配置命令大全
  • H3C交换机、路由器常用配置命令大全

    万次阅读 多人点赞 2015-01-05 10:32:35
    H3C交换机配置命令大全 1、system-view 进入系统视图模式 2、sysname 为设备命名 3、display current-configuration 当前配置情况 4、 language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 ...

     

     

    H3C交换机配置命令大全1、system-view 进入系统视图模式

    2、sysname 为设备命名

    3、display current-configuration 当前配置情况

    4、 language-mode Chinese|English 中英文切换

    5、interface Ethernet 1/0/1 进入以太网端口视图

    6、 port link-type Access|Trunk|Hybrid 设置端口访问模式

    7、 undo shutdown 打开以太网端口

    8、 shutdown 关闭以太网端口

    9、 quit 退出当前视图模式

    10、 vlan 10 创建VLAN 10并进入VLAN 10的视图模式

    11、 port access vlan 10 在端口模式下将当前端口加入到vlan 10中

    12、port E1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中

    13、port trunk permit vlan all 允许所有的vlan通过

    H3C路由器

    1、system-view 进入系统视图模式

    2、sysname R1 为设备命名为R1

    3、display ip routing-table 显示当前路由表

    4、 language-mode Chinese|English 中英文切换

    5、interface Ethernet 0/0 进入以太网端口视图

    6、 ip address 192.168.1.1 255.255.255.0 配置IP地址和子网掩码

    7、 undo shutdown 打开以太网端口

    8、 shutdown 关闭以太网端口

    9、 quit 退出当前视图模式

    10、 ip route-static 192.168.2.0 255.255.255.0 192.168.12.2 description To.R2 配置静态路由

    11、 ip route-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置默认的路由

    H3C S3100 Switch

    H3C S3600 Switch

    H3C MSR 20-20 Router

    ##########################################################################################

    1、调整超级终端的显示字号;

    2、捕获超级终端操作命令行,以备日后查对;

    3、 language-mode Chinese|English 中英文切换;

    4、复制命令到超级终端命令行, 粘贴到主机;

    5、交换机清除配置 :<H3C>reset save ;<H3C>reboot ;

    6、路由器、交换机配置时不能掉电,连通测试前一定要

    检查网络的连通性,不要犯最低级的错误。

    7、192.168.1.1/24 等同 192.168.1.1 255.255.255.0;在配置交换机和路由器时, 192.168.1.1 255.255.255.0 可以写成:

    192.168.1.1 24

    8、设备命名规则:地名-设备名-系列号例:PingGu-R-S3600

    ###########################################################################

    H3C华为交换机端口绑定基本配置2008-01-22 13:40

    1,端口 MAC

    a)AM命令

    使用特殊的AM User-bind命令,来完成MAC地址与端口之间的绑定。例如:

    [SwitchA]am user-bind mac-address 00e0-fc22-f8d3 interface Ethernet 0/1

    配置说明:由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允许PC1上网,而使用其他未绑定的MAC地址的PC机则无法上网。但

    是PC1使用该MAC地址可以在其他端口上网。

    b)mac-address命令

    使用mac-address static命令,来完成MAC地址与端口之间的绑定。例如:

    [SwitchA]mac-address static 00e0-fc22-f8d3 interface Ethernet 0/1 vlan 1

    [SwitchA]mac-address max-mac-count 0

    配置说明:由于使用了端口学习功能,故静态绑定mac后,需再设置该端口mac学习数为0,使其他PC接入此端口后其mac地址无法被学习。

    2,IP MAC

    a)AM命令

    使用特殊的AM User-bind命令,来完成IP地址与MAC地址之间的绑定。例如:

    [SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3

    配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定,即与绑定的IP地址或者MAC地址不同的PC机,在任何端口都无法上网。

    支持型号:S3026E/EF/C/G/T、S3026C-PWR、E026/E026T、S3050C、E050、S3526E/C/EF、S5012T/G、S5024G

    b)arp命令

    使用特殊的arp static命令,来完成IP地址与MAC地址之间的绑定。例如:

    [SwitchA]arp static 10.1.1.2 00e0-fc22-f8d3

    配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定。

    3,端口 IP MAC

    使用特殊的AM User-bind命令,来完成IP、MAC地址与端口之间的绑定。例如:

    [SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3 interface Ethernet 0/1

    配置说明:可以完成将PC1的IP地址、MAC地址与端口E0/1之间的绑定功能。由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允

    许 PC1上网,而使用其他未绑定的IP地址、MAC地址的PC机则无法上网。但是PC1使用该IP地址和MAC地址可以在其他端口上网。

    ###############################################################

    [S2016-E1-Ethernet0/1]mac-address max-mac-count 0;

    进入到端口,用命令mac max-mac-count 0(端口mac学习数设为0)

    [S2016-E1]mac static 0000-9999-8888 int e0/1 vlan 10;

    将0000-9999-8888绑定到e0/1端口上,此时只有绑定mac的pc可以通过此口上网,同时E0/1属于vlan 10

    就这样,ok了,不过上面两个命令顺序不能弄反,除非端口下没有接pc

    #################################################################

    dis vlan 显示vlan

    name text 指定当前vlan的名称

    undo name 取消

    [h3c] vlan 2

    [h3c-vlan2]name test vlan

    dis users 显示用户

    dis startup 显示启动配置文件的信息

    dis user-interface 显示用户界面的相关信息

    dis web users 显示web用户的相关信息。

    header login 配置登陆验证是显示信息

    header shell

    undo header

    lock 锁住当前用户界面

    acl 访问控制列表 acl number inbound/outbound

    [h3c]user-interface vty 0 4

    [h3c-vty0-4] acl 2000 inbound

    shutdown:关闭vlan接口

    undo shutdown 打开vlan接口

    关闭vlan1 接口

    [h3c] interface vlan-interface 1

    [h3c-vlan-interface] shutdown

    vlan vlan-id 定义vlan

    undo valn vlan-id

    display ip routing-table

    display ip routing-table protocol static

    display ip routing-table statistics

    display ip routing-table verbose 查看路由表的全部详细信息

    interface vlan-interface vlan-id 进入valn

    management-vlan vlan-id 定义管理vlan号

    reset ip routing-table statistics protocol all 清除所有路由协议的路由信息.

    display garp statistics interface GigabitEthernet 1/0/1 显示以太网端口上的garp统计信息

    display voice vlan status 查看语音vlan状态

    [h3c-GigabitEthernet1/0/1] broadcast-suppression 20 允许接受的最大广播流量为该端口传输能力的20%.超出部分丢弃.

    [h3c-GigabitEthernet1/0/1] broadcast-suppression pps 1000 每秒允许接受的最大广播数据包为1000传输能力的20%.超出部分丢弃.

    display interface GigabitEthernet1/0/1 查看端口信息

    display brief interface GigabitEthernet1/0/1 查看端口简要配置信息

    display loopback-detection 用来测试环路测试是否开启

    display transceiver-information interface GigabitEthernet1/0/50 显示光口相关信息

    duplex auto/full/half

    [h3c]interface GigabitEthernet1/0/1

    [h3c-GigabitEthernet1/0/1]duplux auto 设置端口双工属性为自协商

    port link-type access/hybrid/trunk 默认为access

    port trunk permit vlan all 将trunk扣加入所有vlan中

    reset counters interface GigabitEthernet1/0/1 清楚端口的统计信息

    speed auto 10/100/1000

    display port-security 查看端口安全配置信息

    am user-bind mac-addr 00e0-fc00-5101 ip-addr 10.153.1.2 interface GigabitEthernet1/0/1 端口ip绑定

    display arp 显示arp

    display am user-bind 显示端口绑定的配置信息

    display mac-address 显示交换机学习到的mac地址

    display stp 显示生成树状态与统计信息

    [h3c-GigabitEthernet1/0/1]stp instance 0 cost 200 设置生成树实例0上路径开销为200

    stp cost 设置当前端口在指定生成树实例上路径开销。instance-id 为0-16 0表cist 取值范围1-200000

    < h3c> display system-guard ip-record 显示防攻击记录信息.

    system-guard enable 启用系统防攻击功能

    display icmp statistics icmp流量统计

    display ip socket

    display ip statistics

    display acl all

    acl number acl-number match-order auto/config

    acl-number (2000-2999 是基本acl 3000-3999是高级acl为管理员预留的编号)

    rule deny/permit protocal

    访问控制

    [h3c] acl number 3000

    [h3c-acl-adv-3000]rule permit tcp source 129.9.0.0 0.0.255.255 destination 202.38.160.0 0.0.255.255 destination-port eq 80 (

    定义高级acl 3000,允许129.0.0/16网段的主机向202.38.160/24网段主机访问端口80)

    rule permit source 211.100.255.0 0.255.255.255

    rule deny cos 3 souce 00de-bbef-adse ffff-ffff-fff dest 0011-4301-9912 ffff-ffff-ffff

    (禁止mac地址00de-bbef-adse发送到mac地址0011-4301-9912且802.1p优先级为3的报文通过)

    display qos-interface GigabitEthernet1/0/1 traffic-limit 查看端口上流量

    端口速率限制

    line-rate inbound/outbound target-rate

    inbound:对端口接收报文进行速率限制

    outbound: 对端口发送报文进行速率限制

    target-rate 对报文限制速率,单位kbps 千兆口 inbound范围1-1000000 outbound范围20-1000000

    undo line-rate取消限速.

    [h3c]interface GigabitEthernet1/0/1

    [h3c-GigabitEthernet1/0/1]line-rate outbound 128 限制出去速率为128kbps

    display arp | include 77

    display arp count 计算arp表的记录数

    display ndp 显示交换机端口的详细配置信息。

    display ntdp device-list verbose 收集设备详细信息

    display lock

    display users

    display cpu

    display memory

    display fan

    display device

    display power

     

     

    展开全文
  • H3C华为交换机配置命令大全PDF格式,想要的快来下载哦!!
  • H 3 C 交 换 机 配 置 命 令 大 全 1system-view 进入系统视图模式 2sysname为设备命名 3displaycurrent-configuration 当前配置情况 4language-modeChinese|English 中英文切换 5interfaceEthernet1/0/1 进入以太网...

空空如也

空空如也

1 2 3
收藏数 50
精华内容 20
关键字:

h3c交换机配置命令大全