精华内容
下载资源
问答
  • 华为交换配置案例

    2018-04-22 21:26:00
    三层交换机组播配置.................................................................................................................41 中低端交换机DHCP-RELAY配置 ..........................................
  • 华为三层交换机配置案例
  • 很全面的华为交换机配置案例,避免了繁琐的命令介绍,跟着配置实例走
  • 华为组网实例:企业内部组网实例,三层交换机实现vlan间互通,DHCP中继,保留地址等 一、SW核心交换机的配置 vlan划分 VLAN配置IP 检查结果 二、路由器配置 开启DHCP 加入回执路由 创建各个vlan的地址池 三、配置...

    在这里插入图片描述

    一、SW核心交换机的配置

    vlan划分

    vlan batch 10 20 30 99
    
    int g0/0/1
    port link-type access 
    port default vlan 10
    q
    
    int g0/0/2
    port link-type access 
    port default vlan 20
    q
    
    int g0/0/3
    port link-type access 
    port default vlan 30
    q
    
    int g0/0/24
    port link-type access 
    port default vlan 99
    q
    
    

    VLAN配置IP

    interface Vlanif10   
    ip address 192.168.0.254 255.255.255.0
    q
    
    interface Vlanif20
     ip address 192.168.20.254 24
    q
     
    interface Vlanif30
     ip address 192.168.30.254 24
    q
     
    interface Vlanif99
    ip address 192.168.99.2 255.255.255.0
    q
    

    检查结果

    [hexin-sw]dis ip in b
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    The number of interface that is UP in Physical is 5
    The number of interface that is DOWN in Physical is 2
    The number of interface that is UP in Protocol is 5
    The number of interface that is DOWN in Protocol is 2
    
    Interface                         IP Address/Mask      Physical   Protocol  
    MEth0/0/1                         unassigned           down       down      
    NULL0                             unassigned           up         up(s)     
    Vlanif1                           unassigned           down       down      
    Vlanif10                          192.168.0.1/24       up         up        
    Vlanif20                          192.168.20.1/24      up         up        
    Vlanif30                          192.168.30.1/24      up         up        
    Vlanif99                          192.168.99.2/24      up         up
    

    二、路由器配置

    开启DHCP

    dhcp enable                 #全局模式下开启DHCP
    int g0/0/0
    ip add 192.168.99.254 24
    dhcp select global        #此接口选择全局的地址池给DHCP客户端使用
    q
    

    加入回执路由

    ip route-static 192.168.0.0 255.255.255.0 192.168.99.2
    ip route-static 192.168.20.0 255.255.255.0 192.168.99.2
    ip route-static 192.168.30.0 255.255.255.0 192.168.99.2
    

    创建各个vlan的地址池

    ip pool vlan10
     gateway-list 192.168.0.254
     network 192.168.0.0 mask 255.255.255.0 
     dns-list 114.114.114.114
    q
    
    ip pool vlan20
     gateway-list 192.168.20.254 
     network 192.168.20.0 mask 255.255.255.0 
     dns-list 114.114.114.114
    q
    
    ip pool vlan30
     gateway-list 192.168.30.254 
     network 192.168.30.0 mask 255.255.255.0 
     dns-list 114.114.114.114
    q
    
    ip pool vlan99
     gateway-list 192.168.99.254 
     network 192.168.99.0 mask 255.255.255.0 
     dns-list 114.114.114.114
    q
    

    检查结果

    [500m-route]dis ip pool 
      -----------------------------------------------------------------------
      Pool-name      : vlan10
      Pool-No        : 0
      Position       : Local           Status           : Unlocked
      Gateway-0      : 192.168.0.254   
      Mask           : 255.255.255.0
      VPN instance   : --
    
      -----------------------------------------------------------------------
      Pool-name      : vlan20
      Pool-No        : 1
      Position       : Local           Status           : Unlocked
      Gateway-0      : 192.168.20.254  
      Mask           : 255.255.255.0
      VPN instance   : --
    
      -----------------------------------------------------------------------
      Pool-name      : vlan30
      Pool-No        : 2
      Position       : Local           Status           : Unlocked
      Gateway-0      : 192.168.30.254  
      Mask           : 255.255.255.0
      VPN instance   : --
    
     IP address Statistic
        Total       :759   
        Used        :0          Idle        :759   
        Expired     :0          Conflict    :0          Disable   :0 
    

    三、配置DHCP中继

    SW核心交换机上配置DHCP中继

    dhcp enable
    
    interface Vlanif10
    dhcp select relay
    dhcp relay server-ip 192.168.99.254
    q
    
    interface Vlanif20
    dhcp select relay
    dhcp relay server-ip 192.168.99.254
    q
    
    interface Vlanif30
    dhcp select relay
    dhcp relay server-ip 192.168.99.254
    q
    
    interface Vlanif99
    dhcp select relay
    dhcp relay server-ip 192.168.99.254
    q
    

    检查一下

    interface Vlanif10
     ip address 192.168.0.254 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.99.254
     
    interface Vlanif20
     ip address 192.168.20.254 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.99.254
     
    interface Vlanif30
     ip address 192.168.30.254 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.99.254
     
    

    四、保留部分IP地址

    ip pool vlan10
    excluded-ip-address 192.168.0.200 192.168.0.253
    q
    
    ip pool vlan20
    excluded-ip-address 192.168.20.200 192.168.20.253
    q
    
    ip pool vlan30
    excluded-ip-address 192.168.30.200 192.168.30.253
    q
    

    五、重新获取和释放地址

    ipconfig /release   释放地址
    ipconfig /renew    重新获取地址
    
    展开全文
  • 通过与华为合作伙伴共同组织,现提供完整的华为 eNSP关于 路由器、交换机设备,配置单臂路由、链路聚合、三层交换机的实例,包含拓朴图、配置命令及详细设置,亲测可用。希望有需要的朋友下载,交流。
  • 华为交换机典型组网案例.rar www.ssno.cn
  • 拓扑结构图 ...Huawei>sys [Huawei]sysname SW2 [SW2]vlan batch 10 20 [SW2]int e0/0/2 [SW2-Ethernet0/0/2]port link-type access [SW2-Ethernet0/0/2]port default vlan 10 [SW2-Ethernet0/0/...

    拓扑结构图

    在这里插入图片描述

    实验步骤

    第一步:配置sw2交换机

    <Huawei>sys
    [Huawei]sysname SW2
    [SW2]vlan batch 10 20
    [SW2]int e0/0/2
    [SW2-Ethernet0/0/2]port link-type access 
    [SW2-Ethernet0/0/2]port default vlan 10
    [SW2-Ethernet0/0/2]un sh
    [SW2-Ethernet0/0/2]int e0/0/3
    [SW2-Ethernet0/0/3]port link-type access
    [SW2-Ethernet0/0/3]port default vlan 20
    [SW2-Ethernet0/0/3]un sh
    [SW2-Ethernet0/0/3]int e0/0/1
    [SW2-Ethernet0/0/1]port link-type trunk 
    [SW2-Ethernet0/0/1]port trunk allow-pass vlan all 
    [SW2-Ethernet0/0/1]un sh
    [SW2-Ethernet0/0/1]int g0/0/1
    [SW2-GigabitEthernet0/0/1]port link-type trunk	
    [SW2-GigabitEthernet0/0/1]port trunk allow-pass vlan all 
    [SW2-GigabitEthernet0/0/1]un sh
    

    第二步:配置sw3交换机

    <Huawei>sys
    [Huawei]sysname SW3	
    [SW3]vlan batch 10 20
    [SW3]int e0/0/2
    [SW3-Ethernet0/0/2]port link-type access 
    [SW3-Ethernet0/0/2]port default vlan 10
    [SW3-Ethernet0/0/2]un sh
    [SW3-Ethernet0/0/2]int e0/0/3
    [SW3-Ethernet0/0/3]port link-type access 	
    [SW3-Ethernet0/0/3]port default vlan 20
    [SW3-Ethernet0/0/3]un sh
    [SW3-Ethernet0/0/3]int e0/0/1
    [SW3-Ethernet0/0/1]port link-type trunk 
    [SW3-Ethernet0/0/1]port trunk allow-pass vlan all 
    [SW3-Ethernet0/0/1]un sh
    

    第三步:配置sw1三层交换机(向上指默认路由,向下指静态路由)

    <Huawei>sys
    [Huawei]sysname SW1
    [SW1]vlan batch 10 20 1000
    [SW1]int g0/0/1
    [SW1-GigabitEthernet0/0/1]port link-type trunk 
    [SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all 
    [SW1-GigabitEthernet0/0/1]un sh
    [SW1-GigabitEthernet0/0/1]int g0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type access
    [SW1-GigabitEthernet0/0/2]port default vlan 1000
    [SW1-GigabitEthernet0/0/2]un sh
    [SW1-GigabitEthernet0/0/2]quit
    [SW1]int vlanif 10
    [SW1-Vlanif10]ip add 192.168.10.1 24
    [SW1-Vlanif10]int vlanif 20
    [SW1-Vlanif20]ip add 192.168.20.1 24
    [SW1]int vlanif 1000
    [SW1-Vlanif1000]ip add 11.0.0.1 30
    [SW1-Vlanif1000]q
    [SW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.2
    

    第四步:配置R1路由器

    <Huawei>sys
    [Huawei]sysname R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 11.0.0.2 30
    [R1-GigabitEthernet0/0/0]un sh
    [R1-GigabitEthernet0/0/0]int loopback 0
    [R1-LoopBack0]ip add 1.1.1.1 30
    [R1-LoopBack0]q
    [R1]ip route-static 192.168.10.0 24 11.0.0.1
    [R1]ip route-static 192.168.20.0 24 11.0.0.1
    

    第五步:配置PC端IP地址及网关

    在这里插入图片描述

    第六步:测试全网互联互通

    在这里插入图片描述

    展开全文
  • type access port default vlan 200 创建用户和密码 aaa local-user root password cipher Huawei@123(用户root,密码Huawei@123) local-user root privilege level 3 local-user root service-type ...

    本来想以为玩会了ensp的基本套路,结果还是太天真了,这个例子就当做 建立dhcp、交换机与交换机、交换机与路由器,交换机与AC+AP配置的部分参考吧

    最终效果图

    在这里插入图片描述

    R1路由器的配置

    sys
    interface g 0/01
    ip add 192.168.10.1 24
    quit
    ip route-static 192.168.0.0 16 192.168.10.2
    

    核心交换机LSW1配置

    sys
    vlan 10
    ip add 192.168.10.2 24
    q
    inter g 0/0/1
    port link-type access(这里好像也可以trunk)
    port default vlan 10
    q
    ip route-static 0.0.0.0  0.0.0.0 192.168.10.2
    192.168.10.2可以换成 g 0/0/1 ,路由缺省值,必须配)
    
    vlan batch 11 12 4000
    
    dhcp enable
    inter vlanif 11
    ip add 192.168.11.254 24
    dhcp select interface
    dhcp dns-list 114.114.114.114 8.8.8.8
    q
    
    inter vlanif 12
    ip add 192.168.12.254 24
    dhcp select interface
    dhcp dns-list 114.114.114.114 8.8.8.8
    q
    
    inter g 0/0/2
    port link-type trunk
    port trunk allow-pass vlan 11 12 4000 
    q
    
    dis vlan(查看vlan的配置)
    

    配置交换机LSW2

    sys
    vlan batch 11 12
    q
    inter g 0/0/2
    port link-type trunk
    port trunk allow-pass vlan 11 12 
    q
    inter Ethernet 0/0/1
    port link-type access
    port default vlan 11
    q
    

    这时候开启PC1的dhcp,等一会ipconfig就有ip地址了

    配置AC1

    尝试ping路由器192.168.10.1(正常可以ping通)
    vlan batch 16 to 31
    vlan 10
    q
    inter vlan 10
    ip add 192.168.10.3 24
    ip route-static 192.168.16.0  20 192.168.10.3
    q
    
    dhcp enable
    inter vlan 16
    ip add 192.168.16.1 24
    dhcp select interface
    q
    vlan 20
    q
    inter vlan 20
    ip add 192.168.20.1 24
    dhcp select interface
    q
    
    inter g 0/0/4
    port link-type trunk
    port trunk all
    port trunk allow-pass vlan 16 to 31
    port trunk pvid vlan 20
    q
    capwap source interface vlanif 20
    指定与ap建立管理隧道的源接口
    

    配置AP的上线方式

    ap auth-mode no-auth
    (无认证方式,按需配置,比如:MAC认证mac-auth)
    

    回到核心交换机LSW1继续配置

    配置到AC1的回程路由
    ip route-static 192.168.16.0 20 192.168.10.3
    
    sys
    vlan batch 16 to 31
    inter g 0/0/4
    port link-type trunk
    port trunk allow-pass vlan 10 100  16 to 31
    q
    inter g 0/0/3
    port link-type trunk
    port trunk allow-pass vlan  16 to 31
    

    配置交换机LSW3

    sys
    vlan batch 11 12
    q
    inter g 0/0/2
    port link-type trunk
    port trunk allow-pass vlan 11 12  16 to 31
    q
    inter Ethernet 0/0/1
    port link-type access
    port default vlan 12
    q
    

    下面用web服务配置和管理AP,用云连接外网

    在AC1配置用于外网连接的网段

    sys
    vlan 200
    q
    inter vlan 200
    ip add 192.168.1.200(这里必须和外网网卡同一网段)
    q
    inter g 0/0/2
    portlink-type access
    port default vlan 200
    
    创建用户和密码
    aaa
    local-user root password cipher Huawei@123(用户root,密码Huawei@123
    local-user root  privilege level 3
    local-user root service-type http ssh telnet terminal tfp(开启的服务类型) 
    

    管理vlan配置

    AC1:

    vlan 4000
    q
    sys
    inter vlan 4000
    ip add 192.168.250.250 24
    

    核心交换机LSW1

    sys
    inter vlan 4000
    ip add 192.168.250.254 24
    

    交换机LSW2

    vlan 4000
    q
    sys
    inter vlan 4000
    ip add 192.168.250.2 24
    

    交换机LSW3

    vlan 4000
    q
    sys
    inter vlan 4000
    ip add 192.168.250.3 24
    

    最后配置云
    在这里插入图片描述
    测试连通性:
    在主机ping 192.168.1.200
    在AC ping 192.168.1.4(外网网卡地址)

    到浏览器输入:192.168.1.200,跳转到以下界面
    自己创建的账号:root 密码:Huawei@123
    默认的账号:admin 密码:admin@huawei.com
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    ---------->>> 勾完√,确定添加 <<<--------

    在这里插入图片描述
    在这里插入图片描述

    最终效果图

    在这里插入图片描述

    最后测试结果,啧,差强人意
    还有一点小问题没解决
    1、PC2的没有自动获取ip
    2、wifi连接上ip却获取不了

    上面是大致配置了,但一些小细节没处理好,就作为一个组网例子的失败对照参考吧
    .
    .
    .
    .
    按照下面视频进行的改动
    附上小破站视频地址
    https://www.bilibili.com/video/BV1oJ41117QX

    展开全文
  • 在第三届未来网络发展大会SDN/NFV技术与应用创新分论坛上中国银联电子商务与电子支付国家工程实验室周雍恺博士,发表了主题为《开放交换机组网技术和前沿进展》的主题演讲。 本次演讲内容主要有三大部分的内容,...

    在第三届未来网络发展大会SDN/NFV技术与应用创新分论坛上中国银联电子商务与电子支付国家工程实验室周雍恺博士,发表了主题为《开放交换机组网技术和前沿进展》的主题演讲。

    本次演讲内容主要有三大部分的内容,第一部分是开放交换机的前沿进展;第二部分介绍组网,尤其是云原生数据中心的组网;第三个部分是金融业对开放交换机所做一些研究以及验证。本文对第一、二部分内容做了整理。

    网络技术的堆栈

    周博士首先谈到了网络技术的堆栈,网络技术堆栈可以分成控制平面和数据平面,在控制平面有,北向接口有Neutron接口,还有K8S CNI接口,以及当前SDN界比较流行的IBN基于意图的声明式接口。开源的网络控制器有ODL和ONOS,商业版有思科ACI、华为AC等。南向接口最著名的是OpenFlow,还有最新的P4 runtime,当然传统设备厂商可能更倾向于BGP、NETCONF、OPFLEX等接口。

    再看数据平面,数据平面可以分成交换机操作系统、硬件抽象层和交换芯片。交换机操作系统是当前网络开源的竞争焦点,开源的系统包括SONiC、FBOSS等。对硬件抽象层,现在发展比较好的是SONiC的SAI层。交换芯片目前正在向可编程的方向发展。网络的开放应该还是大势所趋,上图中左侧红色字表示的都是开源项目,可以看到开源软件已经能够实现对网络堆栈的全覆盖,标准硬件加开源软件构成的开放交换机生态也逐渐成形。

    开放交换机的技术特征

    周博士将开放交换机的技术特征归纳为如下三点。第一是小交换机可以组大网,即相对于原来比较复杂的大框交换机,现在用标准的小盒子也能够扩展出一张非常大的网络。第二是标准硬件加上开放控制,也即在整个的硬件体系上,如何能够构建一个更可控、更精简的网络操作系统。第三是交换芯片的可编程,对于SDN来说,芯片可编程才是最彻底的SDN,因为它已经把软件定义的边界下沉到了转发流水线的层次。下面对这三点进行详细介绍。

    小交换机组大网

    在谈小交换机组大网之前,先介绍一下框式和盒式交换的差别,框式交换机通过背板交换连接多块线卡,其内部的连线也是CLOS的结构。因此,一个大框可以通过小交换机进行组合构建,用小交换机的好处有如下几点:1)小交换机比较便宜,可节约成本。2)架构可扩展,因为框式交换机一旦被设计出来,它的整个数量就完全确定了。3)可控性更高,但与此同时管理的难度也会逐渐增加。下图用于比较用框式和盒式堆三层网络,对于框式交换机如果只是组几千个节点,一台框式交换机就可以搞定了,但是如果是几万个节点,就需要框式堆框式,每一个框里面至少3块芯片,一路算下来,从一端到另外一端要经过11跳,而盒式交换机组成三层网络只需要5跳,所以在时延和跳数上是有优势的。

    当前盒式交换机单芯片的端口密度已经很大了,最高的12.8T(有128个100G的端口)都已经出来了,所以通过三层的CLOS就可以组一个很大的网。具体计算一下,一个2级CLOS构成基本单元POD,可以挂几千台机器,再扩展到三级CLOS,差不多可以无阻塞互联十万左右的服务器,这对于单个数据中心而言已经足够多了。三级CLOS组网的数量取决于中间层交换机的端口密度。

    今年OCP,Facebook发布了最新的数据中心网络设计——F16。他的前身是几年前经典的F4组网,该组网的基本单元有48个接入交换机,4个中间层交换机,差不多每个POD可以连接1000台服务器。然后最上层的Spine交换机通过CLOS互联可以扩展互联数万台服务器的规模,并且在任意两个服务器节点之间有多条冗余路径可以做负载分担。当前最新的F16,中间层改成了16*100G的互联,最顶层的Spine交换平面有36个。如果有六栋楼的话,这种互联方式还可以将六个AZ的交换机Fabric进行全互连。

    网络的开放控制

    在这一部分中,周博士首先谈到了路由控制,路由控制分两种传统的路由控制和SDN路由控制。对于传统的路由控制,周博士对开源网络操作系统SONiC和Stratum进行了比较。

    SONiC
    对于SONiC来说,下图是一个简单的架构图,控制平面仅实现了最核心的BGP协议以保障云数据中心大规模三层网络的互通。数据平面比较核心的是SAI层,这一层目前比较重要因为它的生态发展比较好,它下面支持的芯片非常多。用户既可以用Switch.p4这样纯可编程的芯片来支持SAI,也可以通过博通、盛科等的芯片来实现SAI的接口,最终映射到物理的Chip Target。

    开放交换机创新的技术中不得不提一下去堆叠技术。通常情况下,服务器为了保证高可用性,一般是双连到两台交换机上,如果有一个交换机宕机了,另外一个可以接上。上图中可以看到TOR1和TOR2之间有两条线,这两条堆叠线的作用是同步MAC、ARP等状态。为了达到高可用性,最极端的做法是把两台交换机虚拟成一台控制平面,当用户登上TOR1和TOR2时会发现它们的管理地址是一模一样的,这个虚拟程度是很高,但是额外复杂度、不稳定性也增加了。对此,阿里提出了一种比较创新的去堆叠的技术(VPC-lite),他们的想法是服务器bond口将ARP双发到两条链上,这样TOR1和TOR2就不用同步ARP表了。当链路断了,再显示地通告一下BGP。这种方式达到了原来同样的效果,但原来的堆叠线没有了,交换机也相互独立,实现方面也要简单很多。

    SONiC现在已经成为OCP的一大招牌,因为OCP基本上是以硬件为主,对于软件方面,现在主推SONiC,也是目前生态最成熟的一个开放交换机操作系统,这套操作系统是微软的华人工程师创建的,设计精简前卫,它里面很多组件的模块性都比较好。在使用案例方面,微软将SONiC部署到了全球44个region,领英当前40%的数据中心大规模在使用SONiC。此外,OCP也特意强调了中国对于SONiC的贡献,由阿里牵头ODCC(中国开放数据中心联盟)专门成立了一个凤凰项目,负责SONiC在中国的推广。阿里是SONiC生产应用最早的也是规模比较大的企业。腾讯、百度包括京东也正在开展密集的验证测试,而且不久也会正式生产上线。

    Stratum
    和SONiC相比,Stratum的理念更偏向计算机,它是以IT的方式来管理整个CT系统,也是比较有意思的。整个设计最顶层是远端的控制器,接口端主要分成三类,一个是P4ruetime,然后就是gOMI和gNOI。g代表gRPC,而不是传统网络设备所使用的NETCONF,这可以使得策略的下发效率提升很多。下图蓝色框内便是Stratum的覆盖范围。

    单独的Stratum是没有办法进行组网独立工作的,在上层它需要ONOS或者其他的控制器配合,下层是通过Trellis组件提供Fabric SDN的路由控制。这个系统是纯SDN选路,所以一旦链路端掉线,系统很快就能够响应,重新编制转发表项,由此也不存在去堆叠之类的麻烦。

    Stratum项目最早是由谷歌发起的,所以谷歌在内部肯定已经大规模使用了Stratum(但是谷歌的控制器不是ONOS),整个项目预计今年6月正式开源。国内在去年12月份左右,由腾讯牵头举办了一场Stratum Developer Day,同时 UCloud、阿里、锐捷也都在积极跟进或者密切关注。

    RDMA
    在网络的开放控制中SDN解决的是路由控制的问题,而RDMA要解决的是流量控制。要解决什么样的流量呢?首先看下图,如果是点对点两两互打的话,这个对交换机来说并没有什么太大的压力,每两点产生的流量再大,有线速保障的交换芯片都可以处理过来。但是如果碰到多打一的情况,交换机芯片再强大也处理不了。对这种情况只能从源端进行解决,把原来的大流量变成原来的三分之一,出口那边才可能扛住。在源端分流最常用的方法是从TCP的端侧流控,但这有一个缺点,速度比较慢,有可能对端反馈过来的时候在交换机里已经产生丢包了。于是有了RDMA,可以做端到端的全程流控,整个网络都可以参与流量拥塞的反压。
    这种多打一的情况经常出现在大数据训练场景下。另外对于25G和100G网络这种情况也非常突出,因为25G和100G网络速度太快了,它的交换机的缓存撑不了很长时间,一旦有拥塞,交换机缓存就会迅速溢出,所以RDMA技术基本上会运用在25G/100G网络中。

    下图是RDMA的技术实现,首先在网络侧需要优化配置PFC和ECN等参数,整个RDMA最难的就是这些参数该怎么配。智能网卡侧实现数据远程搬运,同时可以降低CPU的流控负担。最后,原有的TCP协议栈也要重新改写,替换为RoCEv2 verbs的接口。RDMA最终的目标是高吞吐、低时延和不丢包。

    RDMA技术最早应用于科学计算,是一套比较封闭而且价格比较昂贵技术。在以太网中,RDMA主要应用于大数据计算、分布式存储和深度学习网络等大吞吐量,低时延的场景。目前,RDMA的使用其实已经比较广泛了,最早是微软将其应用至云数据中心的场景,BAT等互联网公司主要用于为AI训练任务和分布式存储。华为也推出了AIFabric这种重量级的产品。值得一提的是,整个RDMA网络栈中,有一个单点,那就是迈络思(Mellanox)的智能网卡。迈络思对RDMA贡献很大,它本身就是InfiniBand与RDMA技术的主要发明者。今年3月,英伟达以69亿美金收购了这家以色列半导体公司,今后GPU内存中的数据就可以通过RDMA实现“远程搬运”了。在金融行业,招行和浦发已经分别有生产应用和深度验证,银联也在验证。

    可编程交换芯片

    最后是可编程芯片(Programmable Switch Chip)。可编程交换芯片有三个特点,首先它肯定是ASIC,第二要实现可编程的前提是性能不降级,第三要有特定的编程模型。

    在编程模型方面,以前的交换芯片普遍是固定的流水线,P4的编程模型是PISA,协议无关的交换流水线架构。下图是P4的一个流水线,从图中可以看到每一级都是长的一模一样的,中间是TM,用来缓冲入流水线和出流水线。它的核心仍然是高速交换、处理相关的数据,多了灵活匹配和灵活编辑,小容量的高速存储和查找功能。使用P4语言,用户可以自定义报文头、自定义表项,然后还可以通过控制流把它串起来。当然也有些功能是P4实现不了的,比如变长URL的匹配,新的Hash算法,还有做大容量的存储,这些都不可能在交换芯片上实现。

    从体系架构的视角来看,更高性能始终是体系架构永恒的追求。从最早的单核再到多核,如今摩尔定律已经到了极限,于是各种领域相关的芯片(例如GPU、TPU和FPGA)将发挥重要作用,体系架构也将迎来一个新的黄金时代。对于P4使能的交换芯片来说,它可以用于多节点分布式的协作,像原来的两两单播可以变成组播加速,还有就是服务器部分逻辑到可编程交换芯片等等。

    整个P4应用场景差不多可以归纳为四个虚拟的P4程序,第一个Telemetry是INT的功能,这个是当时P4的主打功能,还是很惊艳的。其次是NFV,然后是Cluster,它可以实现可编程SW+服务器集群的架构。最后一个是Fabric的P4,它可以做到服务和通信的卸载。

    P4的应用案例基本上是从去年P4 Summit上收集到的,用的最早的还是阿里,当时介绍的是负载均衡的应用,一个单片的Tofino芯片是相当于100台服务器的软LB的性能,而且已经接受了2018双十一场景的严酷考验。UCloud在P4方面挖掘得很深,主要场景是在云网关,或者说是vPC的网关,P2V网关,腾讯京东也有涉及。另外就是INT功能,普遍是用在SONIC的集群当中,实现流量的可视化。

    上述内容是周博士第一部分内容。下面介绍第二部分云原生时代的开放交换机组网。
    从2015年开始容器化、微服务等等就开始火了,随之云原生一词也渐渐传入大家耳中。云原生的目标是“业务”极速上线,这是整个的数据中心未来的一个发展方向。数据中心最早使用的是资源池化(Iaas的编排系统),对网络存储资源进行统一的管理。但是对于从应用的构建、部署的方式、弹性伸缩和高可用保障方面它并没有本质性的改变,所以当时很多大佬们就提出来了云原生的概念,就是说明原来的应用其实并不是原生的,所以说现在提出的Paas服务化的理念是什么呢?就是整个系统的能力都是下沉到平台级层面,应用主要关注业务逻辑,不再需要顾及负载均衡、弹性伸缩和高可用之类的运维能力。

    从七层网络架构来看云原生网络对组网的要求,周博士介绍了CNI接口和ServiceMesh(服务网格)。CNI接口是基础的二三层网络联通,它的接口非常简单,就是下图中列举的四个方法,主要就是要实现一个虚拟隔离的vPC网络。四到七层高级网络功能通过ServiceMesh(服务网格)实现,其中四到七层中的云原生更加强调以服务为中心的想法,就是把原来的实例IP给弱化了,更加关注服务的IP,其实就是一个虚IP或者是EIP。四到七层的网络还提供安全可靠灵活高效的服务间通信。

    周博士还举了3个云原生组网的案例,其中之一是Istio服务网格原生的K8S处理服务间通信主要是通过Iptables规则的概率匹配进行服务间的负载均衡,当规模一大iptables链式匹配会出现瓶颈,而且很多高级功能无法实现。Istio则是在一个POD里面加入了一个sidecar容器。sidecar将流量“劫持”后,就可以实现流量限制、熔断、AB发布、分布式追踪等一系列的高级功能。右上是整个Istio的控制平面,和前面的Stratum有点像,都有配置策略下发和搜集网络数据部分。整个Istio周围还有非常丰富的组件,用于监控的Prometheus+Grafana,用于分布式追踪的Kiali和Jaeger,可以构成一个完整的闭环功能非常强大。

    开放交换机的生态已经成型了,相关技术还是有非常大的创新活力。云原生将成为未来DC网络的重要驱动力。整个开放交换机市场成熟度还需要进一步打磨,企业用户有义务积极试用,创新更多的应用场景。
    以上内容是周博士演讲的内容,部分内容有删减。

    转载于:https://www.cnblogs.com/sdnlab1509/p/10954864.html

    展开全文
  • 三层交换机及路由组实例,有H3C的相关内容
  • 详细讲解多个华为交换机配置实例

    千次阅读 2017-09-15 17:15:01
    详细讲解多个华为交换机配置实例交换机的配置是网络管理员的基本技能,本文以华为S5700交换机为例,结合使用sNSP模拟器,详细阐述VLAN配置、VLAN之间通信、跨交换机VLAN配置、跨交换机VLAN之间通信等。(备注:以下...
  • 一、先根据拓扑配置全网互通 SW1的配置 创建vlan vlan batch 10 20 30 给vlan配置IP interface Vlanif10 ip address 192.168.10.254 255.255.255.0 interface Vlanif20 ip address 192.168.20.254 255.255.255.0 ...
  • 在第三届未来网络发展大会SDN/NFV技术与应用创新分论坛上中国银联电子商务与电子支付国家工程实验室周雍恺博士,发表了主题为《开放交换机组网技术和前沿进展》的主题演讲。 本次演讲内容主要有三大部分的内容,...
  • 案例是多年之前遇到的一个真实故障处理过程,之后回想整个过程觉得比较有意思,因此将故障排查记录下来,现在将其分享出来,在其中隐藏了部分敏感信息。由于当时主要是做华为的服务,客户报的故障为S7700交换机的...
  • 华为AC三层组网

    千次阅读 2019-04-07 12:17:55
    [AC6605-wlan-view] security-profile name huawei1 security wpa-wpa2 psk pass-phrase huawei aes SSID模板 [AC6605-wlan-view]ssid-profile name huawei1 ssid huawei1 创建VAP模板 [AC6605-wlan-view]vap-...
  • 华为路由器和交换机实例配置

    千次阅读 2010-03-12 11:25:34
    华为路由器和交换机实例配置命令 (文章转载有错误的地请指点,以便改正) 一. 端口: 路由器——ethernet(以太口)、Serial(串口)、loopback(虚拟端口) 交换机——ethernet、vlan、loopback 注意:交换机...
  • 使用华为存储配置FC-SAN(二)

    千次阅读 2020-04-25 20:41:20
    使用华为5300 V3配置FC-SAN 一、FC-SAN组网模式 直连 单交换交换 二、HBA卡WWN类型 WWNN 节点名字 WWPN 端口名字 在Linux上查询WWPN号:cat /sys/class/fc_host/host3/node_name 三、光纤交换机 3.1光纤...
  • 交换机配置(一)端口限速基本配置 华为3Com 2000_EI、S2000-SI、S3000-SI...华为交换机端口限速 2000_EI系列以上的交换机都可以限速! 限速不同的交换机限速的方式不一样! 2000_EI直接在端口视图下面输入LINE-R...
  • 华为研发

    万次阅读 2012-03-04 16:55:45
    华为研发 前言    如果有人问我“你在华为研发的日子里快乐吗?”,我会很负责任地告诉他“在华为研发工作的那段时间,是我一生中最快乐的时光。”而且这也是很多早期华为研发人员的共识。当年有人曾说“华为...
  • eNSP是图形化网络仿真平台,该平台通过对真实网络设备的仿真模拟,帮助广大ICT从业者和客户快速熟悉华为数通系列产品,了解并掌握相关产品的操作和配置、提升对企业ICT网络的规划、建设、运维能力,从而帮助企业构建...
  • 一般企业使用以太网交换机组网的情况主要分为两类,一是采用协议转换器把专线转成以太网接入交换机;二是直接租用裸光纤。 具体来讲,在三、四级网选择的三层交换机一般只能配置简单的动态路由协议、简单的策略路由...
  • 一、 总体说明 教学目标:通过本课程的学习,学生能够掌握网络基础知识,清晰地描述华为设备所支持的网络技术配置,华为路由器和以太网交换机,并且理解如何利用这些技术设计和利用网络操作系统搭建网络。...
  • 单核心网络配置实例(Ensp)

    千次阅读 2017-10-09 15:52:53
    基本了解单核心网络架构的问题。通过二层vlan和三层vlan实现全网通,路由器和交换机采用ospf,在后期的学习中自己可以加入备份、acl、nat等功能。
  • 华为交换机配置笔记

    2019-07-08 18:14:00
    交换机(Switch)是一种用于电信号转发的网络设备,它可以为接入交换机的任意两个网络节点提供独享的电信号通路,最常见的...交换机是一种交换式集线器,其基于MAC地址识别,能完成封装转发数据包功能的网络设备.交换机可...
  •  将交换机Switch1 上的1,2,3 三个端口依次加入port-group1 后我们可以看到,以on 方式加入一个组完全是强制性的,两端的交换机并不会通过交换LACP PDU 来完成汇聚,汇聚也是触发式的,当敲入将2 号端口加入port-...
  • 二层组网AP上线{案例一}

    千次阅读 2020-05-05 02:04:16
    0 0 因为默认华为的AC使用了mac地址对AP的上线进行认证,所以现在还不能看到AP,但是通过dis arp 可以看到AP的MAC [ccieh3c.com-AC6005]dis ap all All AP information(Normal-0,UnNormal-0): [AC6005]dis arp 可能...
  • 将交换机Switch1 上的1,2,3 三个端口依次加入port-group1 后我们可以看到,以on方式加入一个组完全是强制性的,两端的交换机并不会通过交换LACP PDU 来完成汇聚,汇聚也是触发式的,当敲入将2号端口加入port-group...
  • 华为MSTP排错

    2011-11-09 11:46:54
    交换机组网MSTP配置需要达到的效果 1、根选举是否正常 <QQT9F-B08-B-S6506-1>dis stp inst 0 -------[CIST Global Info][Mode MSTP]------- CIST Bridge :0.000f-e218-d...

空空如也

空空如也

1 2 3 4
收藏数 73
精华内容 29
关键字:

华为交换机组播案例