精华内容
下载资源
问答
  • 自己做的实验,网上找了好久没找到详细的,所以自己就传了个~共同学习!
  • 排除不参与自动分配的IP地址 (1)采用全局地址池时的配置 [HUAWEI] ip pool pool1 [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 24 [HUAWEI-ip-pool-pool1] gateway-list 10.1.1.1...[HUAWEI] dhcp enable [HUAWEI].
    1. 排除不参与自动分配的IP地址
      (1)采用全局地址池时的配置
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 24
      [HUAWEI-ip-pool-pool1] gateway-list 10.1.1.1
      [HUAWEI-ip-pool-pool1] excluded-ip-address 10.1.1.100 10.1.1.200
      (2)采用接口地址池时的配置
      [HUAWEI] dhcp enable
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] ip address 10.1.1.1 24
      [HUAWEI-Vlanif100] dhcp select interface
      [HUAWEI-Vlanif100] dhcp server excluded-ip-address 10.1.1.100 10.1.1.200
    2. 修改地址租期
      (1)采用全局地址池时的配置:
      system-view
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1] lease day 10
      (2)采用接口地址池时的配置:
      system-view
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] dhcp server lease day 10
      (3)在作为DHCP客户端的设备上,修改租期为10天(即864000秒)
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] dhcp client expected-lease 864000
      3.为客户端分配固定的IP地址
      (1)采用全局地址池时的配置:
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1]static-bind ip-address 10.1.1.100 mac-address dcd2-fc96-e4c0
      (2)采用接口地址池时的配置:
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100]dhcp server static-bind ip-address 10.1.1.100 mac-address dcd2-fc96-e4c0
      4.取消为客户端分配固定的IP地址
      (1)采用全局地址池时的配置:
      reset ip pool name pool1 10.1.1.5 //回收IP地址10.1.1.5
      解除静态绑定关系:
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1]undo static-bind ip-address 10.1.1.5
      (2)采用接口地址池时的配置:
      reset ip pool interface vlanif100 10.1.1.5 //回收IP地址
      解除静态绑定关系:
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100]undo dhcp server static-bind ip-address 10.1.1.5
    3. 查看已使用的IP地址
      display ip pool name pool1 used
    4. 清除冲突地址
      reset ip pool name pool1 conflict //采用全局地址池时的配置
      reset ip pool interface vlanif100 conflict //采用接口地址池时的配置
    5. 扩大地址池范围
      (1)如果没有分配出去:在作为DHCP服务器的设备上,缩小地址池的掩码长度,可以扩大地址池范围。
      采用全局地址池时的配置:
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1] undo network
      [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 24 //调整掩码长度
      采用接口地址池时的配置:
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] ip address 10.1.1.1 24 //调整掩码长度
      [HUAWEI-Vlanif100] dhcp select interface //重新使能接口地址池功能
      (2)如果已经分配出去:在作为DHCP服务器的设备上,按“回收IP地址(仅全局地址池时需要配置)—配置防止IP地址重复分配功能—调整地址池掩码长度”的步骤,扩大地址池范围。
      采用全局地址池时的配置:
      reset ip pool name pool1 all //回收所有的IP地址
      [HUAWEI] dhcp server ping packet 3 //配置防止IP地址重复分配功能
      [HUAWEI] dhcp server ping timeout 100 //配置防止IP地址重复分配功能
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1] undo network
      [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 24 //调整掩码长度
      采用接口地址池时的配置:
      [HUAWEI] dhcp server ping packet 3 //配置防止IP地址重复分配功能
      [HUAWEI] dhcp server ping timeout 100 //配置防止IP地址重复分配功能
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] ip address 10.1.1.1 24 //调整掩码长度
      [HUAWEI-Vlanif100] dhcp select interface //重新使能接口地址池功能
    6. 缩小地址池范围
      (1)如果没有分配出去:在作为DHCP服务器的设备上,扩大地址池的掩码长度,可以缩小地址池范围。
      采用全局地址池时的配置:
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1] undo network
      [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 25 //调整掩码长度
      采用接口地址池时的配置:
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] ip address 10.1.1.1 25 //调整掩码长度
      [HUAWEI-Vlanif100] dhcp select interface //重新使能接口地址池功能
      (2)如果已经分配出去:在作为DHCP服务器的设备上,按“回收IP地址(仅全局地址池时需要配置)—配置防止IP地址重复分配功能—调整地址池掩码长度”的步骤,缩小地址池范围。缩小地址池范围之后,拥有地址池范围之外IP地址的客户端,在租期到期后会重新申请IP地址。
      采用全局地址池时的配置:
      reset ip pool name pool1 all //回收所有的IP地址
      [HUAWEI] dhcp server ping packet 3 //配置防止IP地址重复分配功能
      [HUAWEI] dhcp server ping timeout 100 //配置防止IP地址重复分配功能
      [HUAWEI] ip pool pool1
      [HUAWEI-ip-pool-pool1] undo network
      [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 25 //调整掩码长度
      采用接口地址池时的配置:
      [HUAWEI] dhcp server ping packet 3 //配置防止IP地址重复分配功能
      [HUAWEI] dhcp server ping timeout 100 //配置防止IP地址重复分配功能
      [HUAWEI] interface vlanif 100
      [HUAWEI-Vlanif100] ip address 10.1.1.1 25 //调整掩码长度
      [HUAWEI-Vlanif100] dhcp select interface //重新使能接口地址池功能
    7. 防止从仿冒的DHCP服务器获取IP地址:在二层网络的接入设备或第一个DHCP中继上,配置DHCP Snooping功能防止从仿冒的DHCP服务器获取IP地址
      (1)全局下的配置。
      [HUAWEI] dhcp enable
      [HUAWEI] dhcp snooping enable
      (2)连接DHCP客户端侧接口的配置。所有连接DHCP客户端的接口都需要配置,以接口GE 1/0/1为例。
      [HUAWEI-GigabitEthernet1/0/1] dhcp snooping enable
      (3)连接DHCP服务器侧接口的配置。
      [HUAWEI-GigabitEthernet1/0/2] dhcp snooping trusted
      对于二层接入设备来说,1、2和3都是必选步骤,请按照以下顺序配置。对于DHCP中继设备来说,仅需配置步骤1和2。
    8. 关闭DHCP服务
      [HUAWEI] undo dhcp enable
    展开全文
  • 华为交换机配置DHCP

    千次阅读 2020-10-08 23:45:55
    [Huawei]sysname DHCP Server [DHCP Server]vlan batch 10 20 [DHCP Server]dhcp enable [DHCP Server]ip pool vlan10 [DHCP Server-ip-pool-vlan10]gateway-list 10.0.0.254 [DHCP Server-ip-pool-vlan1

    DHCP Server

    DHCP有区分全局地址池与基于接口的地址池,本篇主要介绍基于接口的DHCP配置

    网络拓扑

    在这里插入图片描述

    DHCP Server配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]sysname DHCP Server
    [DHCP Server]vlan batch 10 20
    [DHCP Server]dhcp enable
    [DHCP Server]ip pool vlan10
    [DHCP Server-ip-pool-vlan10]gateway-list 10.0.0.254
    [DHCP Server-ip-pool-vlan10]network 10.0.0.0 mask 24
    [DHCP Server-ip-pool-vlan10]excluded-ip-address 10.0.0.240 10.0.0.253  #限制IP范围
    [DHCP Server-ip-pool-vlan10]lease day 2  #有效期
    [DHCP Server-ip-pool-vlan10]dns-list 114.114.114.114
    [DHCP Server-ip-pool-vlan10]quit
    [DHCP Server]ip pool vlan20
    [DHCP Server-ip-pool-vlan20]gateway-list 10.1.1.254 
    [DHCP Server-ip-pool-vlan20]network 10.1.1.0 mask 24
    [DHCP Server-ip-pool-vlan20]excluded-ip-address 10.1.1.240 10.1.1.253
    [DHCP Server-ip-pool-vlan20]lease day 2
    [DHCP Server-ip-pool-vlan20]dns-list 114.114.114.114
    [DHCP Server-ip-pool-vlan20]quit
    [DHCP Server]interface vlanif 10
    [DHCP Server-Vlanif10]ip address 10.0.0.254 24
    [DHCP Server-Vlanif10]dhcp select global 
    [DHCP Server-Vlanif10]quit
    [DHCP Server]interface vlanif 20
    [DHCP Server-Vlanif20]ip address 10.1.1.254 24
    [DHCP Server-Vlanif20]dhcp select global 
    [DHCP Server-Vlanif20]quit
    [DHCP Server]interface g0/0/1
    [DHCP Server-GigabitEthernet0/0/1]port link-type trunk
    [DHCP Server-GigabitEthernet0/0/1]port trunk allow-pass vlan 10
    [DHCP Server-GigabitEthernet0/0/1]quit
    [DHCP Server]inter g0/0/2
    [DHCP Server-GigabitEthernet0/0/2]port link-type trunk
    [DHCP Server-GigabitEthernet0/0/2]port trunk allow-pass vlan 20
    

    sw1配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]vlan batch 10 20
    [Huawei]dhcp enable
    [Huawei]inter e0/0/1
    [Huawei-Ethernet0/0/1]port link-type trunk 
    [Huawei-Ethernet0/0/1]port trunk allow-pass vlan 10
    [Huawei-Ethernet0/0/1]quit
    [Huawei]inter e0/0/2
    [Huawei-Ethernet0/0/2]port link-type access 
    [Huawei-Ethernet0/0/2]port default vlan 10
    [Huawei-Ethernet0/0/2]quit
    

    sw2配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]dhcp enable
    [Huawei]sysname sw2
    [sw2]vlan 20
    [sw2-GigabitEthernet0/0/1]inter e0/0/1
    [sw2-Ethernet0/0/1]port link-type trunk 
    [sw2-Ethernet0/0/1]port trunk allow-pass vlan 20
    [sw2-Ethernet0/0/1]inter e0/0/2
    [sw2-Ethernet0/0/2]port link-type access 
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]quit
    [sw2]inter e0/0/2
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]quit
    

    查看客户端地址

    PC2的IP
    在这里插入图片描述
    PC3的IP

    在这里插入图片描述
    从PC2 (10.0.0.239)ping PC3(10.1.1.239)
    在这里插入图片描述
    查看地址池
    在这里插入图片描述

    展开全文
  • 华为交换机配置DHCP服务器

    万次阅读 2018-04-28 19:42:01
    1.开启交换机DHCP服务。[huawei]dhcp enable2.配置地址池。[huawei]ip pool 8 [huawei-ip-pool-8]network 192.168.8.0 mask 255.255.255.0 [huawei-ip-pool-8]dns-list 223.5.5.5 223.6.6.6 [huawei-ip-pool-8]...
    1.开启交换机的DHCP服务。
    
    
    [huawei]dhcp enable
    2.配置地址池。
    [huawei]ip pool 8
    [huawei-ip-pool-8]network 192.168.8.0 mask 255.255.255.0
    [huawei-ip-pool-8]dns-list 223.5.5.5 223.6.6.6
    [huawei-ip-pool-8]gateway-list 192.168.8.1
    3.进入vlan接口开启该vlan dhcp功能
    [huawei]interface vlanif 10
    [huawei]dhcp select global
    4.查看配置信息。
    [huawei]display ip pool name 8


    展开全文
  • 华为交换机基础DHCP配置

    万次阅读 2018-05-06 13:48:57
    配置两个地址池:192.168.1.0/24和192.168.2.0/24配置两个VLAN:10和20将...步骤:[DHCP]DHCP enable打开DHCP功能 [DHCP]vlan batch 10 20[DHCP]ip pool vlan10[DHCP]gateway-list 192.168.1.254[DHCP]network 192...

    图片.png

    图片.png

    配置两个地址池:192.168.1.0/24和192.168.2.0/24

    配置两个VLAN:10和20

    将四台主机分别加入VLAN

    自动获取IP地址,确保全网互通。

    步骤:

    [DHCP]DHCP enable

    打开DHCP功能

     

    [DHCP]vlan batch 10 20

    [DHCP]ip pool vlan10

    [DHCP]gateway-list 192.168.1.254

    [DHCP]network 192.168.1.0 mask 255.255.255.0

    [DHCP]lease day 3

    [DHCP]dns-list 8.8.8.8/

    [DHCP]ip pool VLAN 20

    [DHCP]gateway-list 192.168.2.254

    [DHCP]network 192.168.2.0 mask 255.255.255.0

    [DHCP]lease day 3

    [DHCP]dns-list 8.8.8.8/

     

    在服务器上创建VLAN10;20;IP地址池VLAN 10和IP地址池 VLAN 20.

     

    [DHCP]interface vlanif10

    [DHCP]ip address 192.168.1.254 255.255.255.0

    [DHCP]dhcp select global

    [DHCP] interface vlanif20

    [DHCP]ip address 192.168.2.254 255.255.255.0

    [DHCP]dhcp select global

    给VLAN10,VLAN20配置IP/

    [DHCP]interface gi0/0/1

    [DHCP]port link-type trunk

    [DHCP]port trunk allow-pass all

    [DHCP]interface gi0/0/2

    [DHCP]port link-type trunk

    [DHCP]port trunk allow-pass all

    给DHCP服务器1口和2口配置trunk链路

    [SW1]vlan batch 10 20

    [SW1]interface gi0/1

    [SW1]port link-type access

    [SW1]port default vlan 10

    [SW1]interface gi0/2

    [SW1]port link-type access

    [SW1]port default vlan 10

    [SW1]interface gi0/3

    [SW1]port link-type trunk

    [SW1]port trunk allow-pass all

    在交换机一上把端口1;2加入VLAN 10;端口3设置成trunk链路

    [SW1]DHCP enable

    打开DHCP功能。///

    交换机二也做相同操作;


    验证测试保存


    展开全文
  • 华为交换机dhcp snooping 功能配置

    千次阅读 2021-01-26 21:50:43
    华为核心交换机:S5720S-36C-EI-AC 管理IP:172.30.5.1华为桌面交换机:S5700S...如下图所示:核心交换机配置:(华为交换机dhcp server配置:DHCP配置)接入层交换机配置:[SW_ACC_5.10]dhcp enable[SW_ACC_5.10]dhcp ...
  • 华为交换机配置dhcp中继 两个步骤: 一、配置核心交换机(图中LSW1) (1).接口配置: int gig0/0/1 port link-type access port default vlan 10 int gig0/0/2 port link-type access port default vlan 20...
  • [Huawei]dhcp enable [Huawei]vlan 20 [Huawei]interface Vlanif 20 [Huawei-Vlanif20]ip address 192.168.20.1 24 [Huawei-Vlanif20]dhcp select interface [Huawei-Vlanif20]dhcp server dns-list 10.19.1.3 ...
  • 华为交换机配置DHCP, NAT, 互联vlan

    千次阅读 2020-02-17 15:05:17
    华为交换机配置DHCP, NAT, 互联vlan Ⅰ: 网络拓扑图 Ⅱ:配置部分 PC1-2-3-4: 地址获取选择DHCP SW2: sysname Huawei undo info-center enable vlan batch 10 20 interface Eth-Trunk0 port link-type trunk ...
  • 文章目录前言:一、DHCP中继原理1、DHCP中继应用场景2、DHCP中继原理1、实验括扑图2、设备配置2.1、交换机配置2.2、路由器R1配置2.3、路由器R2配置2.4、路由器R3配置2.5、五台PC配置三、进行试验验证1、获取地址2、...
  • 说明:里面有2个VLAN,一个VLAN 2一个VLAN3,用二层交换机连接,然后在连接三层交换机,三层交换机上面配置DHCP服务,一个用基于全局的方式,一个用基于接口的方式,来了解华为DHCP的配置。 1、二层交换机初始化,...
  • 华为交换机DHCP snooping

    万次阅读 2019-01-11 13:54:19
    配置思路 1.使能DHCP Snooping功能。...4.使能根据DHCP Snooping绑定表生成接口的静态MAC表项功能,以防止非DHCP用户攻击。 5.使能对DHCP报文进行绑定表匹配检查的功能,防止仿冒DHCP报文攻击。 6.配...
  • 其中常见的六个词汇是:动态IP、静态IP、手设IP、DHCP分配、固定IP、非固定IP等静态IP地址是长期分配给一台计算机或网络设备使用的IP地址。一般来说,采用专线上网的计算机才拥有固定的Internet IP地址。二、企业...
  • 华为交换机DHCP配置

    2021-04-08 15:57:28
    华为交换机DHCP配置 设备型号:华为交换机–S3700 时间:2021.3.19 环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动...
  • DHCP Relay即DHCP中继,它是为解决服务器和...华为5700交换机dhcp配置方法请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上应用场景:用户侧网段与DHCP服务器处于不同网段SwitchA为DHCP中继的配置思路在Sw...
  • 交换机配置DHCP中继

    千次阅读 2020-12-24 11:23:43
    华为S2700/S3700/S5700/S9300二三层交换机配置DHCP中继DHCP中继DHCP Relay即DHCP中继,它是为解决服务器和客户端不在同一个网段而提出来的,它提供了对DHCP广播报文的透明传输功能,能够把DHCP客户端的广播报文透明...
  • 华为交换机DHCP固定分配

    千次阅读 2020-04-12 00:08:47
    ip pool name 1 #指定要做静态分配的地址池static-bind ip-address 172.16.1.11 mac-address 0017-6110-C599 #将172.16.1.11固定分配给0017-6110-C599本文链接地址: 华为交换机DHCP固定分配...
  • 华为5700交换机DHCP基础配置案例

    千次阅读 2019-10-22 15:53:14
    华为5700交换机DHCP基础配置案例 配置两个地址池:192.168.1.0/24和192.168.2.0/24 配置两个VLAN:10和20 将四台主机分别加入VLAN 自动获取IP地址,确保全网互通。 步骤: DHCP交换机上 在DHCP交换机上...
  • 华为交换机DHCP Server释放IP

    千次阅读 2020-04-13 12:49:52
    reset ip pool name vlan40 172.16.4.254用户视图下有效。本文链接地址: 华为交换机DHCP Server释放IP
  • 华为交换机或路由器释放DHCP已分配的地址: ip pool userdhcp recycle 192.168.1.253 recycle后面可写多条地址,写完该命令后重启报错的端口即可。 若遇到Error:The IP address's status is error.也可这样解决...
  • 三层交换机LSW14为PC5 PC6 PC7 PC8动态分配IP;pc5、pc6属于vlan100,pc7 pc8属于vlan200 步骤 1、在LSW上开启VLAN 100 200 2、将LSW的g0/0/2 和 g0/0/3配置为trunk口,允许vlan100 200通过(这里配置为access应该也...
  • 华为网关交换机开启DHCP server服务

    千次阅读 2018-09-20 22:44:00
    华为网关交换机可以配置基于全局地址池的DHCP服务器,也可以配置基于接口地址池的DHCP服务器,本人比较倾向于配置基于接口地址池的DHCP服务器,因此在这里只介绍后者。 第一步:开启DHCP功能 [SwitchA] dhcp ...
  • 华为交换机 DHCP中继全局不同网段配置

    万次阅读 多人点赞 2018-07-02 17:06:02
    1、DHCP作为公司汇聚交换机,在上面配置DHCP全局地址池,然后接入交换机根据不同vlan会获取到不同网段IP地址。 2、网络拓扑 二、操作步骤 1、客户端 1)创建DHCP服务器组,并为DHCP服务器组添加DHCP服务器对应...
  • 交换机的配置: <Huawei>sysname SW2 [SW2]vlan batch 10 20 [SW2]interface e0/0/1 [SW2-Ethernet0/0/1]port link-type access [SW2-Ethernet0/0/1]port default vlan 10 [SW2-Ethernet0/0/1]q [SW2]...
  • 华为5700_dhcp配置实例

    2020-03-29 17:39:59
    华为三层交换机的 5700_dhcp配置实例,华为三层交换机DHCP配置教程,说明很详细,易懂!易学!易会!

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,724
精华内容 1,489
关键字:

华为交换机关闭dhcp