精华内容
下载资源
问答
  • 华为汇聚交换机链路聚合配置命令

    千次阅读 2020-12-20 00:23:30
    华为汇聚交换机链路聚合配置命令为了增加带宽和网络连接的安全性,一般汇聚交换机都会具备链路聚合的功能。华为汇聚交换机也不例外,本文主要介绍华为汇聚交换机S6500/S8500、S7800、S9300系列的链路聚合数据配置:...

    华为汇聚交换机链路聚合配置命令

    为了增加带宽和网络连接的安全性,一般汇聚交换机都会具备链路聚合的功能。华为汇聚交换机也不例外,本文主要介绍华为汇聚交换机S6500/S8500、S7800、S9300系列的链路聚合数据配置:

    一 S6500/S8500系列交换机

    以S8508为例:

    [S8508]link-aggregation group 1 mode manual

    [S8508]interface GigabitEthernet1/1/1

    [S8508-GigabitEthernet1/1/1]port link-aggregation group 1

    [S8508]interface GigabitEthernet1/1/2

    [S8508-GigabitEthernet1/1/2]port link-aggregation group 1

    后续相关配置只需在其中一个光口或链路聚合组中操作即可,数据会自动复制到其他成员端口上。

    二 S7800系列交换机

    以S7806为例:

    1 链路聚合组

    [S7806] interface Bridge-Aggregation1

    [S7806-Bridge-Aggregation1] port link-type trunk

    [S7806-Bridge-Aggregation1]undo port tr permit vlan 1

    [S7806-Bridge-Aggregation1]port tr permit vlan 100

    2 物理光口1

    [S7806]interface GE1/0/0

    [S7806-GigabitEthernet1/0/0]speed 1000

    [S7806-GigabitEthernet1/0/0]duplex full

    [S7806-GigabitEthernet1/0/0]port trunk permit vlan 100

    [S7806-GigabitEthernet1/0/0] port link-aggregation group 1

    3 物理光口2

    [S7806]interface GE2/0/0

    [S7806-GigabitEthernet2/0/0]speed 1000

    [S7806-GigabitEthernet2/0/0]duplex full

    [S7806-GigabitEthernet2/0/0]port trunk permit vlan 100

    [S7806-GigabitEthernet2/0/0] port link-aggregation group 1

    三 S9300系列交换机

    1 链路聚合组

    interface Eth-Trunk1

    port hybrid tagged vlan

    2 物理光口1

    [S9306]interface GE1/0/5

    eth-trunk 1

    undo negotiation auto

    3 物理光口2

    [S9306]interface GE1/0/6

    eth-trunk 1

    undo negotiation auto

    四 三种系列交换机链路聚合配置区别

    华为上述几种系列的汇聚交换机的链路聚合数据配置比较简单,三者之间区别:

    1 S7800系列交换机链路聚合后,添加或删除数据只能在interface Bridge-Aggregation1下配置,不允许在物理端口下配置,否则会业务阻断,(详见华为交换机S7806数据配置应注意的问题),只需在逻辑端口下配置即可,数据会自动复制到物理端口下。

    2 S8500/S6500系列交换机直接在其中一个成员端口下配置即可。

    3 S9300系列交换机只在逻辑端口下配置数据,物理光口下只要加入逻辑端口即可,无需配置。

    =================================================================================================

    备注:华为交换机S7806数据配置应注意的问题

    华为交换机S7806主要面向电信运营商的汇聚层(IP城域网或语音承载网),也可作为大型校园网或企业网的核心节点,其性能很强大,尤其在电信运营商使用时,一般都是启用链路聚合双上行至上层设备(BRAS或语音承载网),但在其上行链路使用链路聚合后,需要注意一个问题,那就是在启用链路聚合后,如果在物理端口上做操作时会造成设备中断,下面看个具体的例子:

    一台S7806的两个光口启用链路聚合,具体配置分别为:

    interface GigabitEthernet2/0/1

    port link-type trunk

    undo port trunk permit vlan 1

    port trunk permit vlan 100 to 200

    speed 1000

    duplex full

    port link-aggregation group 1

    #

    interface GigabitEthernet2/0/2

    port link-type trunk

    undo port trunk permit vlan 1

    port trunk permit vlan 100 to 200

    speed 1000

    duplex full

    port link-aggregation group 1

    #

    interface Bridge-Aggregation1

    port link-type trunk

    undo port trunk permit vlan 1

    port trunk permit vlan 100 to 200

    #

    如现需在端口上透传vlan 201,在S8508上可在以上三个端口中任意一个下进行透传,但S7806不行,必须在interface Bridge-Aggregation1下透传,而不能在interface GigabitEthernet2/0/1或interface GigabitEthernet2/0/2上透传,否则会造成S7806整台设备中断,后果很严重。

    展开全文
  • 如图,配置以三层太网端口汇聚交换机备份功能 2. 三层交换机配置步骤 (1)配置接口IP地址 在SW1和SW2上分别创建VLAN1的三层地址10.1.1.1/30和10.1.1.2/30。 (2)配置汇聚的端口属性 在配置端口汇聚之前...

    1. 组网及功能实现

    如图,配置以三层太网端口汇聚和交换机备份功能

    2. 三层交换机配置步骤

    (1)配置接口IP地址

    在SW1和SW2上分别创建VLAN1的三层地址10.1.1.1/30和10.1.1.2/30。

    (2)配置汇聚的端口属性

    在配置端口汇聚之前,首先要保证Sw1和Sw2所有汇聚的端口必须工作在全双工方式下,而且必须工作在相同的速率下(不能工作于自协商模式,自协商模式容易导致网络工作于半双工或速率不匹配造成的网络瘫痪)。

    (3)配置端口汇聚和vlan通过情况

    3. 配置参数参考

    (1)交换机Sw1的配置:

    [SW1]interface Vlan-interface 1

    [SW1-Vlan-interface1]ip add 10.1.1.1255.255.255.252

    [SW1-Ethernet0/1]undo negotiation auto

    [SW1-Ethernet0/1]speed 100

    [SW1-Ethernet0/1]duplex full

    [SW1-Ethernet0/1]port link-type trunk

    [SW1-Ethernet0/1] port trunk allow-pass vlan all

    [SW1-Ethernet0/2]speed 100

    [SW1-Ethernet0/2]duplex full

    [SW1-Ethernet0/1]port link-type trunk

    [SW1-Ethernet0/1] port trunk allow-pass vlan all

    (2)交换机SW2的配置:                                                                              

    [SW2]interface Vlan-interface 1

    [SW2-Vlan-interface1]ip add 10.1.1.2255.255.255.252

    [SW2-Ethernet0/1]speed 100

    [SW2-Ethernet0/1]duplex full

    [SW2-Ethernet0/1]port link-type trunk

    [SW2-Ethernet0/1] port trunk allow-pass vlan all

    [SW2-Ethernet0/2]speed 100

    [SW2-Ethernet0/2]duplex full

    [SW2-Ethernet0/1]port link-type trunk

    [SW2-Ethernet0/1] port trunk allow-pass vlan all

    4. 结果验证

    (1)检查配置的正确性

    分别在SW1和SW2上显示当前配置,在SW1的系统视图执行display current-configuration,结果显示

    #

    sysname SW1

    #

    cluster enable

    ntdp enable

    ndp enable

    #

    drop illegal-mac alarm

    #

    diffserv domain default

    #

    drop-profile default

    #

    aaa

     authentication-scheme default

     authorization-scheme default

     accounting-scheme default

     domain default

     domain default_admin

     local-user admin password simple admin

     local-user admin service-type http

    #

    interface Vlanif1

     ip address 10.1.1.1 255.255.255.252

    #

    interface MEth0/0/1

    #

    interfaceGigabitEthernet0/0/1

     undo negotiation auto

     shutdown

     port link-type trunk

     port trunk allow-pass vlan 2 to 4094

    #

    interfaceGigabitEthernet0/0/2

     undo negotiation auto

     port link-type trunk

     port trunk allow-pass vlan 2 to 4094

    同样,在SW2上检查配置正确性

    (2)检查两个三层交换机的互通

    分别在SW1、SW2上执行ping 10.1.1.2/1,显示网络联通

    (3)验证端口汇聚的互为备份这个特性。

    首先在SW1上用display mac-address命令检查MAC地址表,查看目前SW2的Interface Vlan 1的MAC地址在E0/1还是E0/2,SW2的Interface Vlan 1的MAC地址可以通过在SW2上利用命令Display Interface Vlan 1观察到。

    1) [SW1]display mac-address
    MAC address table of slot 0:
    -------------------------------------------------------------------------------
    MAC Address    VLAN/       PEVLAN CEVLAN Port            Type      LSP/LSR-ID  
                   VSI/SI                                              MAC-Tunnel  
    -------------------------------------------------------------------------------
    4c1f-ccd5-61b6 1           -      -      GE0/0/1         dynamic   0/-         
    -------------------------------------------------------------------------------
    Total matching items on slot 0 displayed = 1 

    2) [SW2]display interface vlan
    Vlanif1 current state : UP
    Line protocol current state : UP
    Last line protocol up time : 2018-01-10 16:06:13 UTC-08:00
    Description:
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is 10.1.1.2/30
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 4c1f-ccd5-61b6
    Current system time: 2018-01-10 19:01:41-08:00
        Input bandwidth utilization  : --
        Output bandwidth utilization : --

    由上述输出可以知道,目前Sw1将要转发到Sw2的interface vlan1数据帧是通过GE0/0/1转发的。为了检验汇聚组中GE0/0/2是否能够备份E0/0/1,我们只要手工关闭E0/0/1在检查SW1和SW2之间的可通性即可。

    3)关闭 GE0/0/1

    [SW1-GigabitEthernet0/0/1]shutdown

    [SW1-GigabitEthernet0/0/1]
    Jan 10 2018 19:04:17-08:00 SW1 %%01PHY/1/PHY(l)[0]:    GigabitEthernet0/0/1: cha
    nge status to down
    Jan 10 2018 19:04:18-08:00 SW1 %%01PHY/1/PHY(l)[1]:    GigabitEthernet0/0/1: cha
    nge status to down

    4) 检查交换机的备份性能

    <SW2>ping 10.1.1.1

      PING10.1.1.1: 56  data bytes, press CTRL_C to break

        Reply from 10.1.1.1:bytes=56 Sequence=1 ttl=254 time = 13 ms

        Reply from 10.1.1.1:bytes=56 Sequence=2 ttl=254 time = 10 ms

        Reply from 10.1.1.1:bytes=56 Sequence=3 ttl=254 time = 8 ms

        Reply from 10.1.1.1:bytes=56 Sequence=4 ttl=254 time = 9 ms

        Reply from 10.1.1.1:bytes=56 Sequence=5 ttl=254 time = 10 ms

      --- 10.1.1.1ping statistics ---

        5 packet(s)transmitted

        5 packet(s) received

        0.00% packet loss

        round-trip min/avg/max = 8/10/13ms

    5)确认现在利用SW1利用GE0/0/2进行连接

    [SW1]display mac-address
    MAC address table of slot 0:
    -------------------------------------------------------------------------------
    MAC Address    VLAN/       PEVLAN CEVLAN Port            Type      LSP/LSR-ID  
                   VSI/SI                                              MAC-Tunnel  
    -------------------------------------------------------------------------------
    4c1f-ccd5-61b6 1           -      -      GE0/0/2         dynamic   0/-         
    -------------------------------------------------------------------------------
    Total matching items on slot 0 displayed = 1 


    结语:到目前为止,已经完成了三层交换机的汇聚功能,并验证了交换机备份的正确性










    展开全文
  • 华为交换机端口聚合使用实例,华为交换机命令配置使用
  • 华为交换机SVF

    2018-10-25 10:17:48
    SVF(Super Virtual Fabric)可以将接入、汇聚等不同层次的交换机虚拟成一台逻辑交换机,进行集中管理。
  • 华为系列的交换机,支持使用MQC流分类的方式查看IP,VLAN,MAC的报文流量,也支持简化的ACL的简化流策略的方式查看流量统计,甚至可以直接查看接口流量。 主要命令 traffic classifier traffic behavior traffic ...

    华为系列的交换机,支持使用MQC流分类的方式查看IP,VLAN,MAC的报文流量,也支持简化的ACL的简化流策略的方式查看流量统计,甚至可以直接查看接口流量。

    主要命令
    traffic classifier
    traffic behavior
    traffic policy
    traffic-policy

    操作实例:
    使用流策略进行限速

    根据 IP 地址进行限速

    对IP地址为192.168.1.10的PC限速,带宽限制为4M。
    system-view
    [HUAWEI] acl 2000
    [HUAWEI-acl-basic-2000] rule permit source 192.168.1.100.0.0.0
    [HUAWEI-acl-basic-2000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 2000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] car cir 4096
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound

    acl 3001
    rule permit ip destination 1.1.1.1 0.0.0.0
    rule permit ip source 1.1.1.1 0.0.0.0

    对某网段设备进行限速

    对IP地址为192.168.1.0网段设备进行限速,带宽限制为50M。
    system-view
    [HUAWEI] acl 2000
    [HUAWEI-acl-basic-2000] rule permit source 192.168.1.00.0.0.255
    [HUAWEI-acl-basic-2000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 2000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] car cir 51200
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound

    根据 IP 地址和协议进行限速

    限制192.168.1.0网段设备访问Internet的HTTP(端口号为80)流量不超过10Mbps。
    system-view
    [HUAWEI] acl 3000
    [HUAWEI-acl-adv-3000] rule permit tcp destination-port eq 80 source192.168.1.0 0.0.0.255
    [HUAWEI-acl-adv-3000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 3000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] car cir 10240
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound

    使用流策略对报文进行过滤
    禁止指定主机访问网络

    禁止IP地址为192.168.1.10的PC访问网络。
    system-view
    [HUAWEI] acl 2000
    [HUAWEI-acl-basic-2000] rule deny source 192.168.1.10 0.0.0.0
    [HUAWEI-acl-basic-2000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 2000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] deny
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound

    禁止指定网段所有设备访问网络

    禁止192.168.1.0网段所有设备访问网络。
    system-view
    [HUAWEI] acl 2000
    [HUAWEI-acl-basic-2000] rule deny source 192.168.1.00.0.0.255
    [HUAWEI-acl-basic-2000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 2000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] deny
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound

    过滤指定应用协议报文

    l 禁止TCP目的端口号为25的报文( SMTP)通过。
    l 禁止TCP目的端口号为110的报文( POP3)通过。
    l 禁止TCP目的端口号为80的报文( HTTP)通过。
    system-view
    [HUAWEI] acl 3000
    [HUAWEI-acl-adv-3000] rule deny tcp destination-port eq 25
    [HUAWEI-acl-adv-3000] rule deny tcp destination-port eq 110
    [HUAWEI-acl-adv-3000] rule deny tcp destination-port eq 80
    [HUAWEI-acl-adv-3000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 3000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] deny
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound

    使用流策略配置流量统计
    配置指定主机的统计信息

    配置对源MAC为0000-0000-0003的报文进行流量统计。
    system-view
    [HUAWEI] acl 4000
    [HUAWEI-acl-L2-4000] rule permit source-mac 0000-0000-0003ffff-ffff-ffff
    [HUAWEI-acl-L2-4000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 4000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] statistic enable
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 outbound

    配置对 ICMP 报文进行统计

    system-view
    [HUAWEI] acl 3000
    [HUAWEI-acl-adv-3000] rule 0 permit icmp source 192.168.1.1 0destination 192.168.2.1 0
    [HUAWEI-acl-adv-3000] rule 5 permit icmp source 192.168.2.1 0destination 192.168.1.1 0
    [HUAWEI-acl-adv-3000] quit
    [HUAWEI] traffic classifier c1
    [HUAWEI-classifier-c1] if-match acl 3000
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] statistic enable
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy p1
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [HUAWEI-trafficpolicy-p1] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 inbound
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy p1 outbound

    配置对 ARP 报文进行统计

    统计接口发送的ARP报文和回应的ARP报文。
    system-view
    [HUAWEI] traffic classifier arp-request
    [HUAWEI-classifier-arp-request] if-match l2-protocol arp
    [HUAWEI-classifier-arp-request] if-match source-mac1111-1111-1111
    [HUAWEI-classifier-arp-request] if-match destination-macffff-ffff-ffff
    [HUAWEI-classifier-arp-request] quit
    [HUAWEI] traffic classifier arp-reply
    [HUAWEI-classifier-arp-reply] if-match l2-protocol arp
    [HUAWEI-classifier-arp-reply] if-match source-mac2222-2222-2222
    [HUAWEI-classifier-arp-reply] if-match destination-mac1111-1111-1111
    [HUAWEI-classifier-arp-reply] quit
    [HUAWEI] traffic behavior b1
    [HUAWEI-behavior-b1] statistic enable
    [HUAWEI-behavior-b1] quit
    [HUAWEI] traffic policy arp-request
    [HUAWEI-trafficpolicy-arp-request] classifier arp-request behaviorb1
    [HUAWEI-trafficpolicy-arp-request] quit
    [HUAWEI] traffic policy arp-reply
    [HUAWEI-trafficpolicy-arp-reply] classifier arp-reply behaviorb1
    [HUAWEI-trafficpolicy-arp-reply] quit
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy arp-requestinbound
    [HUAWEI-GigabitEthernet0/0/1] traffic-policy arp-replyoutbound

    查看报文统计信息
    配置通过流策略对报文进行统计之后,可以使用如下命令查看报文统计信息。
    显示全局入方向应用流策略后基于匹配规则的报文统计信息。
    display traffic policy statistics interface GigabitEthernet 0/0/1inbound verbose rule
    base
    Interface: GigabitEthernet0/0/1
    Traffic policy inbound: arp-request
    Rule number: 1
    Current status: OK!
    Statistics interval: 300
    Classifier: arp-request operator and
    Behavior: b1
    if-match l2-protocol arp
    if-match source-mac 1111-1111-1111
    if-match destination-mac ffff-ffff-ffff
    Board : 0
    Passed | Packets: 0
    | Bytes: 0
    | Rate(pps): 0
    | Rate(bps): 0
    Dropped | Packets: 0
    | Bytes: 0
    | Rate(pps): 0
    | Rate(bps): 0

    基于简化ACL简化流策略配置流量统计

    基于MQC方式配置流量统计时,虽然分类丰富多样,但是比较繁琐。因此,交换机提供ACL简化流策略的方式进行。在全局,VLAN或者接口下配置traffic-statistic,对匹配ACL的报文进行统计
    system-view
    [HUAWEI]interface gigabitethernet 0/0/1
    [HUAWEI-gigabitethernet 0/0/1]traffic-statistic inbound acl 3000rule 1
    配置完成后通过display traffic-statistic 命令查看

    展开全文
  • 配置指南-以太网 2-16 华为所有和机密 版权所有 ©华为技术有限公司 文档版本 03 (2009-09-21) interface Ethernet0/0/2 eth-trunk 1 # interface Ethernet0/0/3 eth-trunk 1 # return 2.5.2配置静态LACP 模式链路...

    该楼层疑似违规已被系统折叠 隐藏此楼查看此楼

    2.5 配置举例

    介绍了两种模式下的典型应用场景举例。

    2.5.1配置手工负载分担模式链路聚合示例

    2.5.2配置静态LACP 模式链路聚合示例

    2.5.1配置手工负载分担模式链路聚合示例

    2 LACP 配置

    组网需求

    如图2-4 所示,S-switch-A和S-switch-B为两台S-switch设备,它们之间的链路为某城

    域网骨干传输链路之一,要求S-switch-A 和S-switch-B 之间的链路有较高的可靠性,并

    在S-switch-A 和S-switch-B 之间实现数据流量的负载分担。

    配置思路

    采用如下的思路配置负载分担链路聚合:

    1. 创建Eth-Trunk。

    2. 加入Eth-Trunk 的成员接口。

    说明

    创建Eth-Trunk 后,缺省的工作模式为手工负载分担模式,所以,缺省情况下,不需要配置

    其模式为手工负载分担模式。如果当前模式已经配置为其它模式,可以使用mode命令更

    改。

    数据准备

    为完成此配置例,需准备的数据:

    l 链路聚合组编号。

    l Eth-Trunk 的成员接口类型和编号。

    配置步骤

    1. 创建Eth-Trunk

    # 配置S-switch-A。

    system-view

    [Quidway] sysname S-switch-A

    [S-switch-A] interface eth-trunk 1

    [S-switch-A-Eth-Trunk1] quit

    # 配置S-switch-B。

    system-view

    [Quidway] sysname S-switch-B

    [S-switch-B] interface eth-trunk 1

    [S-switch-B-Eth-Trunk1] quit

    2. 加入Eth-Trunk 的成员接口

    # 配置S-switch-A。

    [S-switch-A] interface Ethernet0/0/1

    [S-switch-A-Ethernet0/0/1] eth-trunk 1

    [S-switch-A-Ethernet0/0/1] quit

    [S-switch-A]interface Ethernet0/0/2

    [S-switch-A-Ethernet0/0/2] eth-trunk 1

    [S-switch-A-Ethernet0/0/2] quit

    [S-switch-A] interface Ethernet0/0/3

    [S-switch-A-Ethernet0/0/3] eth-trunk 1

    [S-switch-A-Ethernet0/0/3] quit

    # 配置S-switch-B。

    [S-switch-B-] interface Ethernet0/0/1

    [S-switch-B-Ethernet0/0/1] eth-trunk 1

    [S-switch-B-Ethernet0/0/1] quit

    [S-switch-B] interface Ethernet0/0/2

    [S-switch-B-Ethernet0/0/2] eth-trunk 1

    [S-switch-B-Ethernet0/0/2] quit

    [S-switch-B] interface Ethernet0/0/3

    [S-switch-B-Ethernet0/0/3] eth-trunk 1

    [S-switch-B-Ethernet0/0/3] quit

    3. 验证配置结果

    在任意视图下执行display trunkmembership 命令,检查Eth-Trunk1 是否创建成

    功,及成员接口是否正确加入,以S-switch-A 为例。

    [S-switch-A] display trunkmembership eth-trunk 1

    Trunk ID: 1

    used status: VALID

    TYPE: ethernet

    Working Mode : Normal

    Working State: Normal

    Number Of Ports in Trunk = 3

    Number Of UP Ports in Trunk = 3

    operate status: up

    Interface Ethernet0/0/1, valid, selected, operate up,weight=1,

    standby interface NULL

    Interface Ethernet0/0/2, valid, selected, operate up,weight=1,

    standby interface NULL

    Interface Ethernet0/0/3, valid, selected, operate up,weight=1,

    standby interface NULL

    配置文件

    l S-switch-A 的配置文件

    #

    sysname S-switch-A

    #

    interface Eth-Trunk1

    #

    interface Ethernet0/0/1

    eth-trunk 1

    #

    interface Ethernet0/0/2

    eth-trunk 1

    #

    interface Ethernet0/0/3

    eth-trunk 1

    #

    return

    l S-switch-B 的配置文件

    #

    sysname S-switch-B

    #

    interface Eth-Trunk1

    #

    interface Ethernet0/0/1

    eth-trunk 1

    #

    2 LACP 配置

    Quidway S3300 系列以太网交换机

    配置指南-以太网

    2-16 华为所有和机密

    版权所有 ©华为技术有限公司

    文档版本 03 (2009-09-21)

    interface Ethernet0/0/2

    eth-trunk 1

    #

    interface Ethernet0/0/3

    eth-trunk 1

    #

    return

    2.5.2配置静态LACP 模式链路聚合示例

    组网需求

    如图2-5 所示,在两台S-switch设备上配置静态LACP 模式链路聚合组,提高两设备之

    间的带宽与可靠性,具体要求如下:

    l M 条活动链路具有负载分担的能力。

    l 两设备间的链路具有N 条冗余备份链路,当活动链路出现故障链路时,备份链路替

    代故障链路,保持数据传输的可靠性。

    配置思路

    采用如下的思路配置静态LACP 模式链路聚合:

    1. 在S-switch 设备上创建Eth-Trunk,配置Eth-Trunk为静态LACP 模式。

    2. 将成员接口加入Eth-Trunk。

    3. 配置接口Eth-Trunk 处理BPDU 报文。

    4. 配置系统优先级确定主动端。

    5. 配置活动接口上限阈值。

    6. 配置接口优先级确定活动链路。

    数据准备

    为完成此配置例,需准备如下的数据:

    l 两端S-switch 设备链路聚合组编号。

    l S-switch-A 系统优先级。

    l 活动接口上限阈值。

    l 活动接口LACP 优先级。

    配置步骤

    1. 创建编号为1 的Eth-Trunk,配置它的工作模式为静态LACP 模式

    # 配置S-switch-A。

    system-view

    [Quidway] sysname S-switch-A

    [S-switch-A] interface eth-trunk 1

    [S-switch-A-Eth-Trunk1] mode lacp-static

    [S-switch-A-Eth-Trunk1] quit

    # 配置S-switch-B。

    system-view

    [Quidway] sysname S-switch-B

    [S-switch-B] interface eth-trunk 1

    [S-switch-B-Eth-Trunk1] mode lacp-static

    [S-switch-B-Eth-Trunk1] quit

    2. 将成员接口加入Eth-Trunk

    # 配置S-switch-A。

    [S-switch-A] interface ethernet 0/0/1

    [S-switch-A-Ethernet0/0/1] eth-trunk 1

    [S-switch-A-Ethernet0/0/1] quit

    [S-switch-A] interface ethernet 0/0/2

    [S-switch-A-Ethernet0/0/2] eth-trunk 1

    [S-switch-A-Ethernet0/0/2] quit

    [S-switch-A] interface ethernet 0/0/3

    [S-switch-A-Ethernet0/0/3] eth-trunk 1

    [S-switch-A-Ethernet0/0/3] quit

    # 配置S-switch-B。

    [S-switch-B] interface ethernet 0/0/1

    [S-switch-B-Ethernet0/0/1] eth-trunk 1

    [S-switch-B-Ethernet0/0/1] quit

    [S-switch-B] interface ethernet 0/0/2

    [S-switch-B-Ethernet0/0/2] eth-trunk 1

    [S-switch-B-Ethernet0/0/2] quit

    [S-switch-B] interface ethernet 0/0/3

    [S-switch-B-Ethernet0/0/3] eth-trunk 1

    [S-switch-B-Ethernet0/0/3] quit

    3. 配置接口Eth-Trunk 处理BPDU 报文

    # 配置S-switch-A。

    [S-switch-A] interface eth-trunk 1

    [S-switch-A-Eth-Trunk1] bpdu enable

    [S-switch-A-Eth-Trunk1] quit

    # 配置S-switch-B

    [S-switch-B] interface eth-trunk 1

    [S-switch-B-Eth-Trunk1] bpdu enable

    [S-switch-B-Eth-Trunk1] quit

    4. 在S-switch-A 上配置系统优先级为100,使其成为LACP 主动端

    [S-switch-A] lacp priority 100

    5. 在S-switch-A 上配置活动接口上限阈值M 为2

    [S-switch-A] interface eth-trunk 1

    [S-switch-A-Eth-Trunk1] max bandwidth-affected-linknumber2

    [S-switch-A-Eth-Trunk1] quit

    2 LACP 配置

    说明

    由于S-switch-A 为主动端,所以S-switch-B 不需要配置活动接口上限阈值,步骤 6 中配置接

    口优先级同样只需要在主动端S-switch-A 上配置即可。

    6. 在S-switch-A 上配置接口优先级确定活动链路

    [S-switch-A] interface ethernet 0/0/1

    [S-switch-A-Ethernet0/0/1] lacp priority 100

    [S-switch-A-Ethernet0/0/1] quit

    [S-switch-A] interface ethernet 0/0/2

    [S-switch-A-Ethernet0/0/2] lacp priority 100

    [S-switch-A-Ethernet0/0/2] quit

    7. 验证配置结果

    # 查看各S-switch 设备的Eth-Trunk信息,查看链路是否协商成功。

    [S-switch-A] display eth-trunk 1

    Eth-Trunk1's state information is:

    Local:

    LAG ID: 1 WorkingMode: STATIC

    Preempt Delay: Disabled Hash arithmetic: According to MAC

    System Priority: 100 System ID: 0077-7777-7777

    Least Active-linknumber: 1 MaxBandwidth-affected-linknumber: 2

    Operate status: up Number Of Up Port In Trunk: 2

    --------------------------------------------------------------------------------

    ActorPortName Status PortType PortPri PortNo PortKeyPortState Weight

    Ethernet0/0/1 Selected 100M 100 1 289 11111100 1

    Ethernet0/0/2 Selected 100M 100 2 289 11111100 1

    Ethernet0/0/3 Unselect 100M 32768 3 289 11100000 1

    Partner:

    --------------------------------------------------------------------------------

    ActorPortName SysPri SystemID PortPri PortNo PortKeyPortState

    Ethernet0/0/1 32768 0001-0168-0182 32768 1 289 11111100

    Ethernet0/0/2 32768 0001-0168-0182 32768 2 289 11111100

    Ethernet0/0/3 32768 0001-0168-0182 32768 3 289 11100000

    [S-switch-B] display eth-trunk 1

    Eth-Trunk1's state information is:

    Local:

    LAG ID: 1 WorkingMode: STATIC

    Preempt Delay: Disabled Hash arithmetic: According to MAC

    System Priority: 32768 System ID: 0001-0168-0182

    Least Active-linknumber: 1 Max Bandwidth-affected-linknumber:8

    Operate status: up Number Of Up Port In Trunk: 2

    --------------------------------------------------------------------------------

    ActorPortName Status PortType PortPri PortNo PortKeyPortState Weight

    Ethernet0/0/1 Selected 100M 32768 1 289 11111100 1

    Ethernet0/0/2 Selected 100M 32768 2 289 11111100 1

    Ethernet0/0/3 Unselect 100M 32768 3 289 11100000 1

    Partner:

    --------------------------------------------------------------------------------

    ActorPortName SysPri SystemID PortPri PortNo PortKeyPortState

    Ethernet0/0/1 100 0077-7777-7777 100 1 289 11111100

    Ethernet0/0/2 100 0077-7777-7777 100 2 289 11111100

    Ethernet0/0/3 100 0077-7777-7777 32768 3 289 11100000

    通过以上显示信息可以看到,S-switch-A 的系统优先级为100,高于S-switch-B的

    系统优先级。Eth-Trunk 的成员接口中Ethernet 0/0/1、Ethernet0/0/2 成为活动接

    口,处于“Selected”状态,接口Ethernet 0/0/3 处于“Unselect”状态,同时实现M

    条链路的负载分担和N 条链路的冗余备份功能。

    配置文件

    l S-switch-A 的配置文件

    #

    sysname S-switch-A

    #

    lacp priority 100

    #

    interface Eth-Trunk1

    bpdu enable

    mode lacp-static

    max bandwidth-affected-linknumber 2

    #

    interface Ethernet0/0/1

    eth-trunk 1

    lacp priority 100

    #

    interface Ethernet0/0/2

    eth-trunk 1

    lacp priority 100

    #

    interface Ethernet0/0/3

    eth-trunk 1

    #

    return

    l S-switch-B的配置文件

    #

    sysname S-switch-B

    #

    interface Eth-Trunk1

    bpdu enable

    mode lacp-static

    #

    interface Ethernet0/0/1

    eth-trunk 1

    #

    interface Ethernet0/0/2

    eth-trunk 1

    #

    interface Ethernet0/0/3

    eth-trunk 1

    #

    return

    展开全文
  • 华为)802.1x认证点部署在汇聚交换机,接入交换机管理地址免认证配置 802.1x dot1x 二层透传
  • 1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无...
  • 在企业中,通常会有这样的组网方式存在,核心交换机下面级联了数个接入交换机,但是管理员需要通过Telnet等方式进行远程管理,对各类交换机进行配置。 众所周知,各个交换机至少要有一个管理IP地址来方便我们去管理...
  • 思科6509核心交换机和各种二层汇聚交换机路由器网络配置实例大全,HSRP、OSPF、EIGRP等。
  • TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高...
  • 8500从1250以后的版本开始支持跨板聚合 =============================================================================== 华为自研X3 X7系列交换机聚合 手工聚合 操作步骤 1.创建Eth-Trunk # 创建Eth-Trunk 1。 &...
  • 华为三层交换机配置案例
  • SW1----(左边交换机) system-view                        /进入系统视图(默认用户视图) [Huawei]sysname SW1                   /更改设备名字 [SW1]          ...
  • 华为路由器、交换机典型配置实例,包含华为路由器模拟器,一些简单的配置实例。
  • 华为交换机端口聚合(☆亲测)

    千次阅读 2021-07-11 12:53:20
    1.含义 端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条...3. 汇聚类型 3.1人为配置 手工聚合和静态lacp聚合
  • Portal认证一般适用于用户分散且流动性较大的场景 1.配置网络互通 (1)配置终端IP地址 (2)创建WLAN并允许通过vlan,保证网络畅通 [LSW1]vlan batch 11 12 [LSW1-Vlanif11]ip add 10.1.11.1 24 ...
  • 华为交换机链路聚合命令

    万次阅读 2020-12-20 00:22:41
    华为交换机链路聚合命令配置链路聚合1、创建聚合组sysinterface eth-trunk 22、配置聚合模式为手工模式interface eth-trunk 2mode manual load-balance 表示手工模式mode lacp lacp模式,可以自动检测链路是否错误;...
  • 华为S5700交换机链路聚合配置

    千次阅读 2019-04-27 21:44:19
    其实原理很简单,使两楼交换机之间能互相通信就行了;(一根网线就行);那又为什么要用配链路聚合呢(应为一根网线不够用啊) 原来的运行方式:2台S5700分别配置Eth-Trunk1 分别将需要通信的3条线路的端口加入Eth-...
  • 1.配置网络互通 (1)配置终端IP地址 (2)创建WLAN并允许通过vlan,保证网络畅通 [LSW1]vlan batch 11 12 [LSW1-Vlanif11]ip add 10.1.11.1 24 [LSW1-Vlanif12]ip add 10.1.12.1 24 [LSW1-GigabitEthernet0/0/1]...
  • 华为交换机端口的批量配置命令

    千次阅读 2021-02-11 20:38:21
    华为交换机端口的批量配置命令如何在华为交换机上进行批量管理端口呢,例如同时将多个端口加入到一个vlan中,下面yjbys为大家介绍华为交换机批量管理端口的方法!欢迎参考学习!首先在S5700交换机上创建一个端口组...
  • ...affect operation by wrong use, please carefully use it with HUAWEI engineer's  direction. [YQ-H5748-c-a-hidecmd] 转载于:https://blog.51cto.com/hellab/1258823
  • 华为三层交换机配置实例一例网络技术2008-07-2506:08:28阅读243评论0字号:大中小订阅华为三层交换机配置实例一例服务器1双网卡,内网IP:192.168.0.1,其它计算机通过其代理上网PORT1属于VLAN1PORT2属于VLAN2PORT3...
  • 华为交换机基本配置命令详解

    千次阅读 2020-12-24 08:24:45
    『组网需求』 增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚数据配置步骤 【SwitchA交换机配置】 (1)进入端口E0/1 [SwitchA]interface Ethernet 0/1 (2)汇聚端口必须工作在全双工模式...
  • 现在公司购买了两台华为的S5700系列的交换机,为了提高交换机之间链路带宽以及可靠性,您需要在交换机上配置链路聚合功能。 操作步骤 步骤一以太网交换机基础配置 华为交换机接口默认开启了自协...
  • 华为交换机详细堆叠教程

    千次阅读 多人点赞 2021-05-03 18:20:19
    汇聚层——>核心层均采用的堆叠技术,逻辑设备少,网络拓扑变的更加简化,打破二层环路,引起的广播风暴 各种采用的ETH-Trunk(链路聚合技术)负载分担算法灵活,链路利用率大大提高 堆叠技术+ETH-Trunk
  • 华为路由器交换机实现OSPFv3的配置

    千次阅读 2020-04-14 18:03:28
    配置接口所属VLAN # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置...HUAWEI> system-view [HUAWEI] sysname SwitchA [SwitchA] vlan 10 [SwitchA-vlan10] quit [SwitchA] interface gigabitethernet 0/0/3 [Sw...
  • 华为交换机 ARP 相关命令

    万次阅读 2019-09-18 21:46:07
    display arp all #查看ARP表 arp static ip地址 MAC地址 #手工配置静态ARP映射 arp-porxy enable #开启代理ARP功能
  • 1华为三层交换机配置实例一例服务器1双网卡,内网IP:,其它计算机通过其代理上网PORT1属于VLAN1PORT2属于VLAN2PORT3属于VLAN3VLAN1的机器可以正常上网配置VLAN2的计算机的网关为:配置VLAN3的计算机的网关为:即可...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,299
精华内容 919
关键字:

华为汇聚交换机