精华内容
下载资源
问答
  • 无效的目标发行版

    2019-04-16 16:16:45
    Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project apollo-server: Fatal error compiling: 无效的目标发行版: 1.8 ->Help ...

    项目打包遇到以下报错,gradle和maven都不行
    Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project apollo-server: Fatal error compiling: 无效的目标发行版: 1.8 ->Help 1]

    /etc/profile中的jdk版本都是1.8的
    .m2/settings.xml中也改成1.8

    <profile>
          <id>jdk-1.8</id>
          <activation>
            <activeByDefault>true</activeByDefault>
            <jdk>1.8</jdk>
          </activation>
          <properties>
            <maven.compiler.source>1.8</maven.compiler.source>
            <maven.compiler.target>1.8</maven.compiler.target>
            <maven.compiler.compilerVersion>1.8</maven.compiler.compilerVersion>
          </properties>
        </profile>
    

    能想到的地方都想到了 but maven和gradle的版本还是不对

    upsmart@upsmart-12:~$ java -version
    java version "1.8.0_144"
    Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
    Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)
    
    upsmart@upsmart-12:~$ mvn -version
    Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 21:51:28+0800)
    Maven home: /usr/lib/mvn/apache-maven-3.0.5
    Java version: 1.7.0_79, vendor: Oracle Corporation
    Java home: /home/upsmart/dev/jdk-7u79/jre
    Default locale: zh_CN, platform encoding: UTF-8
    OS name: "linux", version: "4.2.0-42-generic", arch: "amd64", family: "unix"
    
    upsmart@upsmart-12:~$ gradle -version
    
    ------------------------------------------------------------
    Gradle 3.1
    ------------------------------------------------------------
    
    Build time:   2016-09-19 10:53:53 UTC
    Revision:     13f38ba699afd86d7cdc4ed8fd7dd3960c0b1f97
    
    Groovy:       2.4.7
    Ant:          Apache Ant(TM) version 1.9.6 compiled on June 29 2015
    JVM:          1.7.0_79 (Oracle Corporation 24.79-b02)
    OS:           Linux 4.2.0-42-generic amd64
    

    最后将profile中变量配置移到.bashrc中就好了

    #set Java env
    export JAVA_HOME=/home/upsmart/dev/jdk1.8.0_144
    #export JAVA_HOME=/home/upsmart/dev/jdk-7u79
    export JRE_HOME=${JAVA_HOME}/jre
    export CLASSPATH=.:${JAVA_HOME}/lib:${JRE_HOME}/lib
    export PATH=${JAVA_HOME}/bin:$PATH
    
    #set Maven environment
    export  MAVEN_HOME=/usr/lib/mvn/apache-maven-3.0.5
    export PATH=$MAVEN_HOME/bin:$PATH
    
    #Jmeter
    export PATH=/opt/apache-jmeter-3.0/bin/:$PATH
    
    #gradle
    export GRADLE_HOME=/home/upsmart/gradle/gradle-3.1
    export PATH=$GRADLE_HOME/bin:$PATH
    
    #zookeeper
    export ZOOKEEPER_HOME=/home/upsmart/software/zookeeper-3.4.10
    export PATH=$ZOOKEEPER_HOME/bin:$PATH
    
    upsmart@upsmart-12:~$ java -version
    java version "1.8.0_144"
    Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
    Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)
    upsmart@upsmart-12:~$ 
    upsmart@upsmart-12:~$ mvn -version
    Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 21:51:28+0800)
    Maven home: /usr/lib/mvn/apache-maven-3.0.5
    Java version: 1.8.0_144, vendor: Oracle Corporation
    Java home: /home/upsmart/dev/jdk1.8.0_144/jre
    Default locale: zh_CN, platform encoding: UTF-8
    OS name: "linux", version: "4.2.0-42-generic", arch: "amd64", family: "unix"
    upsmart@upsmart-12:~$ gradle -version
    
    ------------------------------------------------------------
    Gradle 3.1
    ------------------------------------------------------------
    
    Build time:   2016-09-19 10:53:53 UTC
    Revision:     13f38ba699afd86d7cdc4ed8fd7dd3960c0b1f97
    
    Groovy:       2.4.7
    Ant:          Apache Ant(TM) version 1.9.6 compiled on June 29 2015
    JVM:          1.8.0_144 (Oracle Corporation 25.144-b01)
    OS:           Linux 4.2.0-42-generic amd64
    

    我也不知道为什么。。。。。

    展开全文
  • 之前编译项目的时候报错: 网上搜了下,好多都只说了 无效的源发行版的解决方法。其实有两个错误,一个是目标...无效的目标发行版 原因:编译器的JDK版本不符 设置编译器版本。 File -> Settings… 这个要与你安

    之前编译项目的时候报错:
    在这里插入图片描述
    在这里插入图片描述
    网上搜了下,好多都只说了 无效的源发行版的解决方法。其实有两个错误,一个是目标发行版,一个是源发行版。

    无效的源发行版

    原因:编译的JDK版本与发布版本不一致

    Ctrl + Shift + Alt + S 快捷键
    File -> Project Structure ->Project Settings 其中三处保持一致。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    然后就没问题了。

    无效的目标发行版

    原因:编译器的JDK版本不符

    设置编译器版本。

    File -> Settings…
    在这里插入图片描述
    这个要与你安装的编译器版本一致。

    然后就没问题了。

    展开全文
  • 遇到问题如java: 警告: 源发行版 11 需要目标发行版 11或者java: 无效的目标发行版: 11,根因是本机JDK版本与语言级别不一致。 对此,需要检查以下3个地方 File>Project Structure>Project File>...

    遇到问题如java: 警告: 源发行版 11 需要目标发行版 11或者java: 无效的目标发行版: 11,根因是本机JDK版本与语言级别不一致。
    对此,需要检查以下3个地方

    • File>Project Structure>Project
      在这里插入图片描述

    • File>Project Structrure>Modules
      在这里插入图片描述
      在这里插入图片描述

    • File>Settings>Java Compiler
      在这里插入图片描述
      解决方法来自这篇文章那篇文章。

    展开全文
  • Error:java: 无效的目标发行版: 11

    万次阅读 多人点赞 2020-03-17 21:05:13
    我们在使用Idea开发中如果遇到你的JDK版本有“无效的目标发行版: 11”冲突时,要修改以下JDK版本 1 2 3 以上的设置必须保证是同一JDK的版本才可以

    我们在使用Idea开发中如果遇到你的JDK版本有“无效的目标发行版: 11”冲突时,要修改以下JDK版本
    1
    在这里插入图片描述
    2
    在这里插入图片描述
    3
    在这里插入图片描述
    以上的设置必须保证是同一JDK的版本才可以

    展开全文
  • IDEA导入外部项目报Error:java: 无效的目标发行版: 11的解决方法错误展示:Information:java: Errors occurred while compiling module 'employee-managemen'Information:javac 1.8.0_144 was used to compile java ...
  • IDEA中报错:无效的目标发行版本

    千次阅读 2020-09-01 18:05:18
    报错提示 Error:java: 无效的目标发行版: 11 分析 编译时,使用的是java 11版本,实际上编译依赖的却不是jdk 11版本。 解决 修改编译目标版本为自己Jdk版本。
  • 无效的目标发行版:5

    2021-02-06 13:52:42
    Error:java: 错误: 无效的目标发行版:5 问题提描述: idea 使用maven构建项目时,target bytecode version经常自动变化 即便通过 Preferences 窗口修改后依然恢复原来的错误 解决方法有2种 注意:⚠️ 版本号根据...
  • 主要介绍了IDEA导入外部项目报Error:java: 无效的目标发行版: 11,本文给大家介绍的非常详细,对大家的学习或工作具有一定的参考借鉴价值,需要的朋友可以参考下
  • 一、报错问题分析问题1.Error:java:无效的目标发行版问题2.Information:javac 1.8.0_181 was used to compile java sources(翻译: " 信息: jdk 1.8.0 181版本已经被用于编译java源代码 ")小编的遇到问题如图所示:...
  • 解决:javac: 无效的目标发行版: 10
  • 修改了语言等级依然抛无效的目标发行版` 修改了语言等级还是抛错 最后发现是pom里面可能被自动加了
  • 我们在使用Idea开发中如果遇到你的JDK版本有“无效的目标发行版: 11”冲突时,要修改以下JDK版本
  • 出现问题: Error:java: 无效的目标发行版: 1.8 解决方法: file-setting--
  • 转来学习下)此刻我怀着沉重心情,写下这个恶心了我4个多小时解决办法:maven编译时候报错误如下:[INFO] BUILD FAILURE[INFO] ------------------------------------------------------------------------[INFO] ...
  • [javac] Compiling 1 source file to E:\mf\saas_20190906\build\dist\saasapi\WEB-INF\classes [javac] javac: 无效的目标发行版: 1.8 [javac] 用法: javac <options> <source files> [javac] -...
  • 在使用使用maven命令打包时报错:无效的目标发行版:13.0.1 原因 可能是使用的jdk版本和maven中配置的jdk版本不一致 解决 在命令行中使用以下命令查看jdk版本,我的是1.8版本 java -version 在apache-maven-...
  • IDEA Error:java: 无效的目标发行版: 11 将JDK SDK版本设为同一版本 1. File -->Project Structure -->Project 2. File -->Project Structure -->Modules 3. File -->Settings -->Java ...
  • Fatal error compiling: 无效的目标发行版: 1.8 -> [Help 1]解决Fatal error compiling: 无效的目标发行版: 1.8 -> [Help 1]报错解决方法 解决Fatal error compiling: 无效的目标发行版: 1.8 -> [Help 1]...
  • [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project java: Fatal error compiling: 无效的目标发行版: 3.1 -&gt; [Help 1]   修改...
  • idea运行项目时发现Error:java: 无效的目标发行版: 11 需要修改以下JDK版本 File>>Project Structure【CTRL+ALT+SHIFT+S】 File>>Settings【CTRL+ALT+S】 以上的设置必须保证是同一JDK的版本...
  • 【JAVA】Fatal error compiling: 无效的目标发行版: 1.8

    千次阅读 热门讨论 2018-04-10 08:05:04
    前言  之前小编的Eclipse和Idea使用的jdk版本一直... Eclipse:Fatal error compiling: 无效的目标发行版: 1.8  Idea:Error:java: 无效的源发行版: 1.8 解决方法 小编总结了一下几种解决方法,可以按照...
  • 根据昨天在各种设置的时候,发现先后出现了:无效的目标发行版本5,和无效的目标发行版本11的错误, 经检查,都是和IDEA的maven设置有关,第一次出现错误的时候,查看IDEA默认使用的编译版本是11,但是实际使用的并...
  • ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.3:compile (default-compile) on project nutzbook: Fatal error compiling: 无效的目标发行版: 1.8 -> [Help 1] [ERR...
  • Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project shendu-qiyeweixin: Fatal error compiling: 无效的目标发行版: 11 -> [Help 1] 原因: ...

空空如也

空空如也

1 2 3 4 5 ... 14
收藏数 265
精华内容 106
关键字:

无效的目标发行版