精华内容
下载资源
问答
  • 浮动静态路由

    2019-10-06 23:00:09
    浮动静态路由的管理距离大于另一个静态或动态路由的管理距离。当为主链路提供备用链路时,它们非常有用,如图所示。 默认情况下,静态路由的管理距离为 1,因此它们优先于通过动态路由协议获知的路由。例如,一些...


    实验涉及命令以及知识补充

    • 浮动路由简介

    浮动静态路由的管理距离大于另一个静态或动态路由的管理距离。当为主链路提供备用链路时,它们非常有用,如图所示。

    默认情况下,静态路由的管理距离为 1,因此它们优先于通过动态路由协议获知的路由。例如,一些常见动态路由协议的管理距离如下:

    EIGRP = 90
    
    IGRP = 100
    
    OSPF = 110
    
    IS-IS = 115
    
    RIP = 120

    静态路由的管理距离可以增加,以便使另一个静态路由或通过动态路由协议获取的路由优先于该路由。这样,静态路由将会“浮动”,当有管理距离更好的路由处于活动状态时,则不使用该路由。但是,如果首选路由丢失,浮动静态路由可以接管,而且流量可以通过此备用路由发送。

    • 配置命令

    ip route ip-address subnet-mask ip-address distance

    • 如何查看备用路由是否工作

    禁用主线路由的退出接口

    转载于:https://www.cnblogs.com/Coeus-P/p/9126839.html

    展开全文
  • 一、静态路由 命令格式:ip route-static 目的网段 ...二、浮动静态路由 路由优先级:总范围0-255 比较原则:越小越优 静态路由默认的优先级:60 以下配置是在以上静态路由的基础上增加的配置。 1、拓扑图:...

     

    一、静态路由

    命令格式:ip route-static 目的网段 目的网段的掩码 下一跳具体IP地址

    1、拓扑图:

    2、R1配置:

    3、R2配置:

    4、R3配置:

    5、ping通测试:

    二、浮动静态路由

    路由优先级:总范围0-255

    比较原则:越小越优

    静态路由默认的优先级:60

    以下配置是在以上静态路由的基础上增加的配置。

    1、拓扑图:

    2、AR1增加配置:

    3、AR2增加配置:

    4、AR3增加配置:

    5、线路正常追踪路由:

    6、线路故障:

    7、线路故障追踪路由:

    转载于:https://www.cnblogs.com/liang-chen/p/11527331.html

    展开全文
  • 等价静态路由、浮动静态路由、缺省静态路由的配置 等价静态路由 等价静态路由:只有下一跳地址不一样的N条路由。 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。 等价路由的配置实验:  ...

    等价静态路由、浮动静态路由、缺省静态路由的配置


    等价静态路由

    • 等价静态路由:只有下一跳地址不一样的N条路由。
    • 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。


      等价路由的配置实验:
      在这里插入图片描述
            根据该图,此实验R3与R2需要配置等价静态路由,R1与R4需要配置两条静态路由。
      R3路由的配置:
    interface  fa0/0
    no shutdown
    ip address 17.3.3.1 255.255.255.252
    exit
    interface fa1/0
    no shutdown
    ip address 17.3.3.14 255.255.255.252
    exit
    interface fa2/0
    no shutdown
    ip address 17.3.3.64 255.255.255.192
    exit
    ip route 17.3.3.128 255.255.255.192 17.3.3.2
    ip route 17.3.3.128 255.255.255.192 17.3.3.13
    show ip route
    

    上述配置过程中:
    ip route 17.3.3.128 255.255.255.192 17.3.3.2
    ip route 17.3.3.128 255.255.255.192 17.3.3.13
         例如该两条路由只有下一跳地址不相同,目的网络地址与子网掩码都相同的路由——称为等价路由。
    等价路由由于优先级相同,所以在转发数据时随机选择通过路由。

    R3路由配置结果:
    在这里插入图片描述
    由图可以看出有三条直连路由,一条静态路由,但含有两个不同的下一跳地址。

    浮动(备份)静态路由

    • 在一个链路中,优先级高的叫主静态路由,优先级低的叫浮动静态路由。
    • 浮动路由配置成功后,在路由表中查看时只显示主路由。
    • 当主路由失效(有故障)时,浮动路由加入路由表并起数据转发作用。
    • 数值越小,优先级越高

    缺省路由

    • 目的网络地址,子网掩码都是0的特殊路由
    • 缺省路由配置时,注意只有一个出口时可以配缺省路由,多出口不可以配缺省路由。
    • 如果报文的目的地址无法匹配路由表中任何一项,路由表将按照缺省路由转发。
    • 全0网络地址为 全网地址


      缺省路由的配置实验
      在这里插入图片描述
      R2路由配置代码:
    interface fa0/0 
    no shutdown
    ip address 10.0.12.1 255.255.255.0
    exit
    interface fa1/0
    no shutdown
    ip address 192.186.4.1 255.255.255.0
    exit
    ip route 0.0.0.0  0.0.0.0  10.0.12.2
    show ip route
    

    R2路由配置结果:
    在这里插入图片描述
        有图可以看出,有一条缺省路由S*,优先级为1。

    展开全文
  • 浮动静态路由和bfd联动实现路由自动更新一.什么是浮动静态路由静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。...

    浮动静态路由和bfd联动实现路由自动更新

    一.什么是浮动静态路由

    静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑结构,便于设置正确的路由信息。在一个支持DDR(Dial-on-Demand Routing)的网络中,拨号链路只在需要时才拨通,因此不能为动态路由信息表提供路由信息的变更情况。在这种情况下,网络也适合使用浮动静态路由。

    二.什么是bfd

    BFD即双向转发检测,是一种实现网络可靠性的机制,可被用于快速检测网络中的链路状况、IP可达性。其可以与多种协议或机制进行联动,如与静态路由、OSPF、IS-IS、 BGP、VRRP、PIM及MPLS LSP等进行联动。

    三.实验步骤

    (1).实验网络拓扑图

    (2).实验配置

    PC1 ip address:192.168.1.3 255.255.255.0

    SW1 ip address:192.168.1.2.255.255.255.0

    PC2 ip address:10.0.0.2 255.255.255.0

    AR1

    Interface G0/0/0

    Ip address 1.1.1.1 24

    Quit

    Interface vlan 1

    Ip add 192.168.1.1

    Quit

    Bfd

    quit

    bfd a bind peer-ip 1.1.1.2

    discriminator local 10

    discriminator remote 20

    commit

    Quit

    AR2

    Interface g0/0/0

    Ip address 1.1.1.2 24

    Quit

    Interface vlan 1

    Ip add 10.0.0.1 24

    Quit

    Bfd

    quit

    bfd b bind peer-ip 1.1.1.1

    discriminator local 20

    discriminator remote 10

    commit

    quit

    绑定bfd

    ip route-static 0.0.0.0 0.0.0.0 1.1.1.2 track bfd-session a

    ip route-static 192.168.1.0 24 1.1.1.1

    完成上述配置后,AR1与AR2便会进行BFD报文的交互。可在AR2查看BFD状态

    四.实验测试

    可以通过display ip routing-table 命令查看路由状态。浮动静态路由和bfd联动实现路由自动更新实验完成。

    展开全文
  • 浮动静态路由原理当网络中存在多条相同路由前缀时,会优先选取AD值(路由可信度,值越小,路由越优先)小的路由为主用路由,AD值大的路由为备份路由。当主用路由的下一跳不可达时,主用路由消失,备用路由生效切换为主...
  • 配置浮动静态路由和路由负载均衡

    千次阅读 2019-06-23 10:26:21
    配置浮动静态路由和路由负载均衡 静态路由虽然是管理员静态配置在路由表中,但不代表静态路由完全没有动态性,当静态路由在下一跳不可达或者出接口失效时,将会被从路由表中删除,去查看是否有去往目标网络的备用...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 504
精华内容 201
关键字:

浮动静态路由