精华内容
下载资源
问答
  • vlan配置实例详解_网工知识角|MUXVLAN技术详解,基本原理一篇搞定
    2020-12-12 18:20:03

    7e530ebfc4c9af3adb48e626ab7f6909.png

    学网络,就在IE-LAB

    国内高端网络工程师培养基地


    MUX VLAN(Multiplex VLAN )提供了一种通过VLAN进行网络资源控制的机制。通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间的互访是隔离的。

    b97e0a22ae47a8bb596372f071633f69.png

    为了实现报文之间的二层隔离,用户可以将不同的端口加入不同的VLAN,但这样会浪费有限的VLAN资源。采用端口隔离功能,可以实现同-VLAN内端口之间的隔离。

    在安全性要求较高的网络中,交换机可以开启端口安全功能,禁止非法MAC地址设备接入网络;当学习到的MAC地址数量达到上限后不再学习新的MAC地址,只到MAC地址的设备通信。

    1、MUX VLAN:

    对于企业来说。希望企业内部员工之间可以互相访问,而企业外来访客之间是隔离的,可通过配置每个访客使用不同的VLAN来实现。但如果企业拥有大量的外来访客员工,此时不但需要耗费大量的VLAN ID,还增加了网络维护的难度。

    MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间的互访是隔离的。

    MUX VLAN分为主VLAN和从VLAN,从VLAN又分为隔离型从VLAN和互通型从VLAN。

    主VLAN(PrincipalVLAN):Principal port可以和MUX VLAN内的所有接口进行通信。

    隔离型从VLAN(SeparateVLAN):Separate port只能和Principal port进行通信,和其他类型的接口实现完全隔离。

    每个隔离型从VLAN必须绑定一个主VLAN。

    互通型从VLAN(Group VLAN):Group port可以和Principalport进行通信,在同一组内的接口也可互相通信,但不能和其他组接口或Separate port通信。每个互通型从VLAN必须绑定一个主VLAN。

    2、端口隔离

    端口隔离分为二层隔离三层互通和二层三层都隔离两种模式:

    如果用户希望隔离同一VLAN内的广播报文,但是不同端口下的用户还可以进行三层通信,则可以将隔离模式设置为二层隔离三层互通;

    如果用户希望同一vlan不同端口下用户彻底无法通信,则可以将隔离模式配置为二层三层均隔离;

    端口隔离技术也有缺点,一是计算机之间共享不能实现;二是隔离只能在一台交换机上实现,不能在堆叠交换机之间实现,如果是堆叠环境,只能改成交换机之间级连。

    3、端口安全

    如果说网络中存在非法用户时,可以使用端口安全技术保证网络的安全。一般使用在如下场景:

    ①应用在接口层设备:通过配置端口安全可以防止仿冒用户从其他端口攻击;

    ②应用在汇聚层设备,通过配置端口安全可以控制接入用户的数量。

    端口安全(Port Security),从基本原理上讲,PortSecurity特性会通过MAC地址表记录连接到交换机端口的以太网MAC地址,并只允许某个MAC地址通过本端口通信。其他MAC地址发送的数据包通过此端口时,端口安全特性会阻止它。

    使用端口安全特性可以防止未经允许的设备访问网络,并增强安全性。另外,端口安全特性也可用于防止MAC地址泛洪造成MAC地址表填满。

    端口安全的类型:

    端口安全( Port Security )通过将接口学习到的动态MAC地址转换为安全MAC地址(包括安全动态MAC、安全静态MAC和Sticky MAC )阻止非法用户通过本接口和交换机通信,从而增强设备的安全性。

    1、接口使能端口安全功能时,接口上之前学习到的动态MAC地址表项将被删除,之后学习到的MAC地址将变为安全动态MAC地址。

    2、接口使能Sticky MAC功能时,接口上的安全动态MAC地址表项将转化为StickyMAC地址,之后学习到的MAC地址也变为StickyMAC地址。

    3、接口去使能端口安全功能时,接口上的安全动态MAC地址将被删除,重新学习动态MAC地址。

    4、接口去使能Sticky MAC功能时,接口上的StickyMAC地址会转换为安全动态MAC地址。

    超过安全MAC地址限制后得到的动作:

    接口上安全MAC地址数达到限制后,如果收到源MAC地址不存在的报文,端口安全则认为有非法用户攻击,就会根据配置的动作对接口做保护处理。缺省情况下,保护动作是restrict。

    Restrict:丢弃源MAC地址不存在的报文并上报警。推荐使用该动作。 注:设备收到非法MAC地址的报文时,每30s至少警告1次,至多警告2次。

    Protect:只丢弃源MAC地址不存在的报文,不上告报警。

    Shutdown:接口状态被置为error-down,并上报告警。 默认情况下,接口关闭后不会自动恢复,只能由管理员手动恢复。

    IE-LAB有优质雄厚师资力量支撑,全面的学习平台和完善的教学服务,我们培养了一批又一批的HCIE/CCIE学员,加入我们,成就未来。

    61f8dac98e4c33bf82e9bc7816f0343a.png

    往期【网工知识角】技术回顾:

    关于ESXi的基本介绍及其五大优点,网工知识角

    网工知识角|网络内部漏洞如何解决?有802.1X协议不用怕

    网络端口镜像技术三分钟详细总结一篇搞定,就在网工知识角

    网工知识角|温故知新之关于语音你不得不知的PSTN协议详解

    网工知识角|关于会话初始协议 SIP超详细介绍,建议收藏

    网工知识角|一分钟记熟NFV网络功能虚拟化技术介绍

    网工知识角|IPSec协议是如何确保网络安全的?

    网工知识角|华为认证配置指南之SSL协议知多少

    网工知识角|快速掌握华为认证交换机配置之端口安全机制

    网工知识角|掌握这四种方式完成垃圾邮件过滤,守护网络安全

    IPSec协议超详细解读网络安全协议的重要性就在网工知识角

    光纤通信技术知多少?WDM技术原理概述就在网工知识角

    网工知识角|你不得不了解的VRRP负载均衡技术详解

    乘SDN的热潮,NETCONF协议“重出江湖”,五大优点总结就在网工知识角

    网工请戳!交换机配置指南半分钟即可掌握关于SSL配置的内容

    热门无线技术中这个知识点你知多少?WLAN WDS技术详解一篇搞定

    MSDP协议的三个优点你知多少,就在网工知识角

    VLAN攻击如何有效防范?搞定虚拟局域网就在网工知识角

    一分钟掌握NFV基本概念,就在网工知识角

    三分钟掌握热点路由技术之DLSW,技术详解就在网工知识角

    避免引起网络安全问题,6步完成华为设备风暴控制的配置,网工知识角

    关于OSPF协议重点学习笔记之OSPFv3和OSPFv2的区别

    思科路由协议IGRP和EIGRP超详细总结,了解它们之间的关联和区别

    网工知识角|NAT64基本原理概述,它的局限性又有哪些?

    快速掌握网络通讯流量资源浪费的环路解决方法,网工知识角

    新网工技术一分钟解读Openflow工作原理,网工知识角

    网工知识角|用于管理和控制IPv6组播组的MLDsnooping技术详解

    网工知识角|快速理解FTP和TFTP的区别,实用收藏

    新网工都要了解的无线技术,你却连Mesh网络是什么都不知道?

    网工知识角|零基础入门学网络,三分钟掌握DTP协议的五种接口模式

    网工知识角|思科全新EI及无线方向你必须要去了解的WLAN漫游技术

    网工知识角|基础入门务必掌握这两个常用协议,快速攻克面试难关

    网工知识角|技术大牛自检时间到,关于MLD技术你知多少?

    网工知识角|不可忽略的三个关键点,确保端口安全配置无误

    网工知识角|一分钟搞定802.1x认证配置,了解三种授权模式的区别

    快速完成华为IPSG配置一分钟看完即会,网工知识角每天进步一点点

    网工知识角|一分钟轻松掌握Mac地址漂移使用的场景

    网络工程师技术难点分析MTU和PMTU是什么?就在网工知识角

    华为网络初级工程师快速掌握基于MAC地址的VLAN划分实用收藏

    网工知识角|华为网络技术面试题详解QOS流量整形令牌桶机制和规则

    这样总结隧道Tunnel技术工作原理更容易记住 网络工程师还不收藏?

    你知道NAC网络准入控制的5大功能5种类型和3重优点吗?

    网工知识角|什么是虚拟化?史上最全云计算基础虚拟化技术各种概念高薪面试必备

    网工知识角|网络工程师快收下这份华为MUXVLAN的原理和配置,华为HCIP数通网络实用技术

    网工知识角|华为HCIE数通认证基础必学之GVRP协议是什么

    网工知识角|CCIE网络工程师安全基础之AAA认证的三个基本组件

    网工知识角|EI CCIE企业网软定义中的VxLAN分布式网关两种部署方式

    网工知识角|关于OSPF V3你了解吗?不懂没关系,收下这份配置

    纯干货网工知识角|入门IT网络工程师收下这份关于NTP网络时间协议解读

    学思科和华为都需要掌握之网络安全技术防火墙的4种分类,网工知识角

    网工知识角|信息安全入门反病毒技术全面解说5种传播途径

    网工知识角|没人会告诉你的网络SDN软定义技术中VXLAN的4个特点

    网工知识角|你不可不知的WLAN的安全技术体系

    网工知识角|什么是思科软件定义接入(SD-Access)? 新一代网工必学的自动化技术

    网工知识角|什么是华为CSS 集群?简单易懂,面试收藏

    网工知识角|三分钟了解QOS的处理流程和分类

    网工知识角|Qos的基本原理

    网工知识角|LACP技术详解

    网工知识角|802.1X协议介绍

    网工知识角|OpenFlow协议简介

    网工知识角|MSTP协议详解

    网工知识角|快速了解IGMP协议

    网工知识角|快速了解和掌握HSRP协议简介和配置

    网工知识角|1分钟了解GRE协议浅析

    网工知识角|DHCP服务详解和基于eNSP DHCP配置

    网工知识角|P2P协议简介

    网工知识角|OSPFv3技术概述

    网工知识角|防火墙双机热备三大协议(VRRP-VGMP-HRP)简述

    网工知识角|一分钟了解交换机的堆叠技术

    网工知识角|简单了解Cisco PVST协议

    网工知识角|MPLS LDP简介

    网工知识角|GLBP网关负载均衡协议原理

    网工知识角|Cisco VTP解析

    网工知识角|DLDP技术简述

    网工技术分享|Cisco策略路由PBR详解

    网工技术分享|Cisco CEF浅析

    ca6c4a3789c438a64ef6f2b546a39d7d.gif

    CCIE备考交流QQ群:134074975

    思科华为免费公开课QQ群:134403299

    每日打卡一个技术点,关注IE-LAB哔哩哔哩:370947524

    每日下午4点准时直播,关注IE-LAB抖音:135654500 

    IE-LAB官网:http://www.ie-lab.cn

    分享给更多网工同伴一起进步

    2b5f97614f0019d49e8d6a7b13411b23.png关注本订阅号,点个““”在看

    更多相关内容
  • 静态VLAN配置实例详解

    千次阅读 2022-01-14 21:50:28
    文章目录1 VLAN的概念及优势2 VLAN的种类2.1 VLAN的范围2.2 静态VLAN和动态VLAN3 静态VLAN配置4 Trunk介绍与配置5 实例 1 VLAN的概念及优势 物理分隔。将网络从物理上划分为若干个小网络,然后使用能隔离广播的...

    1 VLAN的概念及优势

    • 物理分隔。将网络从物理上划分为若干个小网络,然后使用能隔离广播的路由设备将不同的网络连接起来实现通信。
    • 逻辑分隔。将网络从逻辑上划分为若干个小的虚拟网络,即VLAN(Virtual Local Area Network,虚拟局域网)。VLAN工作在OSI参考模型的数据链路层,一个VLAN就是一个交换网络,其中的所有用户都在同一个广播域中,各VLAN通过路由设备的连接实现通信。
    • 作用:划分广播域,控制广播消息传递范围

    VLAN的优势

    • 节约一定的带宽资源
    • 实际项目:缩小排错的范围
    • 控制广播(防止交换机接口同时广播造成网络风波)
    • 增强网络安全性(分割出的广播域不用影响其他广播域;提供了一定的安全性:默认情况下两个不同的VLAN不允许相互通信
    • 简化网络管理(划分广播域的类型,更加方便,简易,好管理)

    2 VLAN的种类

    2.1 VLAN的范围

    Cisco交换机最多能够支持4096个VLAN,不同型号的交换机支持的VLAN数目不同。例如:Catalyst 2960最多能够支持255个VLAN,Catalyst 3560最多能够支持1024个VLAN。

    VLAN id范围范围用途
    0,4095保留仅限系统使用,
    用户不能查看和使用这些VLAN
    1正常Cisco默认VLAN,
    用户能够使用该VLAN,但不能删除它
    2-1001正常用于以太网的VLAN,
    用户可以创建、使用和删除这些VLAN
    1002-1005正常用于FDDI和令牌环的Cisco默认VLAN
    用户不能删除这些VLAN
    1006-1024保留仅限系统使用
    用户不能查看和使用这些VLAN
    1025-4094扩展仅用于以太网VLAN

    2.2 静态VLAN和动态VLAN

    静态VLAN:基于端口划分静态VLAN,应用最多

    配置静态VLAN的步骤:

    1. 创建VLAN
    2. 将交换机的端口加入到相应的VLAN中
    3. 验证VLAN的配置

    动态VLAN:基于MAC地址划分动态VLAN(计算机可模仿,安全性不高)

    3 静态VLAN的配置

    <Huawei>sys
    [Huawei]undo info e   #取消信息提示
    [Huawei]vlan 10       #新建vlan10
    [Huawei-vlan10]q
    [Huawei]display vlan      #查看vlan
    [Huawei]undo vlan 10  #删除vlan10
    [Huawei]display vlan
    [Huawei]vlan batch 10 20 30  #批量创建vlan
    [Huawei]display vlan
    
    #将端口加入vlan中
    [SW1]int e0/0/1    #进入端口
    [SW1-Ethernet0/0/1]port link-type access 
    #指明vlan类型我只让我设置vlan10 通过
    [SW1-Ethernet0/0/1]port default vlan 10   #加入vlan
    [SW1-Ethernet0/0/1]display this         #查看本接口的信息
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    return
    
    #将端口从vlan删除
    [SW1-Ethernet0/0/1]undo port default vlan   
    [SW1-Ethernet0/0/1]display this     #查看本接口的信息
    #
    interface Ethernet0/0/1
     port link-type access
    #
    return
    

    恢复VLAN状态和定义端口组

    [SW1-Ethernet0/0/1]port link-type hybrid   #恢复默认vlan状态
    
    华为的命令,要想把多个端口加入到一个vlan里面,有两种方法,
    1、建立一个组,在组里面加vlan,配置方法
    [Huawei]port-group 1   #同时将多个端口加入VLAN 
    #定义端口组
    [Huawei- port-group- 1]group-member Ethernet 0/0/1  to Ethernet 0/0/20 
    #( 组1的成员是e0/0/1到e0/0/20)不连续的 只能一个一个添加
    [Huawei -port-group- 1]port link-type access
    [Huawei-port-group-1]port default vlan 30
    
    [Huawei]clear configuration interface e0/0/1
    #端口恢复默认配置,注意,执行完命令后,接口会被shutdown
    
    2、直接在vlan下面加端口即可,但是这种方法的基础就是端口模式必须是access模式,而华为的交换机默认是hybrid模式
    vlan 10
    port GigabitEthernet 0/0/1 to 0/0/24
    
    [Huawei]dis vlan 10       #查看指定VLAN信息
    

    4 Trunk介绍与配置

    Trunk(中继)类型端口:可以允许多个vlan通过,可以接收和发送多个vlan 报文,一般用于交换机与交换机相关的端口。
    Trunk(干道、中继)的作用:使同一个VLAN能够跨交换机通信,即使用一条线路使得不同交换机的相同VLAN相互通信。

    #定义二层端口为trunk模式
    [SW1-Ethernet0/0/1]port link-type trunk
    
    #允许所有vlan通过
    [SW2-Ethernet0/0/3]port trunk allow-pass vlan all
    

    5 实例

    要求:在交换机上配置vlan,使pc1和pc3可以ping通,pc2和pc4可以ping通,但是pc1和pc3无法ping通pc2和pc4

    拓扑图
    在这里插入图片描述
    第一步:手动配置主机的IP地址以及子网掩码

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    第二步:修改交换机名称SW1,新建VLAN 10,VLAN 20,查看VLAN信息

    在这里插入图片描述
    第三步:进入端口,设置端口工作模式为access,指定端口为VLAN 10

    在这里插入图片描述

    第四步:配置0/0/3端口为trunk模式,并允许所有VLAN通过

    在这里插入图片描述
    第五步:配置交换机SW2,同交换机

    在这里插入图片描述

    第六步:配置交换机SW2的0/0/3端口为trunk模式,并允许所有VLAN通过

    在这里插入图片描述
    第七步:主机1 ping 主机2、主机3、主机4

    在这里插入图片描述

    展开全文
  • Cisco思科VLAN配置(详细)

    万次阅读 多人点赞 2020-12-13 15:06:41
    思科CiscoVLAN配置 一、拓扑图 1.VLAN的理解 交换机可以划分成很多个vlan,将局域网划分成很多个网段,来减少广播域和冲突域,默认情况下交换机各个接口接的都是vlan1,我们可以进入vlan数据库(database)...

    思科(Cisco)VLAN在配置

    思路:
    一.配置好DHCP、DNS、web服务器(在这文章的第三)
    二.先配置两个交换机的vlan
    三.配置路由器
    四.检查设备的互通情况
    每一步操作都有详细解析哦

    拓扑图结构

    在这里插入图片描述
    1.VLAN的理解
    交换机可以划分成很多个vlan,将局域网划分成很多个网段,来减少广播域和冲突域,默认情况下交换机各个接口接的都是vlan1,我们可以进入vlan数据库(database)增加vlan。
    具体操作:

    一、两个交换机的vlan

    // 第一个交换机里的相关操作
    每一步操作都有详细解析哦
    Switch>enable                
    Switch#                // enable用来进入特权模式Switch#      
    Switch#vlan database       //进入vlan数据库
    % Warning: It is recommended to configure VLAN from config mode,
      as VLAN database mode is being deprecated. Please consult user
      documentation for configuring VTP/VLAN in config mode.
    
    Switch(vlan)#
    Switch(vlan)#vlan 2 name v2          //添加一个名字为v2的vlan2
    VLAN 2 added:
        Name: v2
    Switch(vlan)#vlan 3 name v3           //添加一个名字为v3的vlan3
    VLAN 3 added:
        Name: v3
    Switch(vlan)#exit
    Switch#
    Switch(config)#interface f0/1           //进入interface f0/1 这个接口
    Switch(config-if)#switchport mode access          //把连接交换机的电脑改为access模式(也就是电脑模式)
    Switch(config-if)#switchport access vlan 2         //让这个电脑接入vlan 2    这样我们就把interface f0/1这个接口划分到了vlan2、下面就是把各口进行分
    Switch(config-if)#exit
    Switch(config)#interface f0/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 3
    Switch(config-if)#exit
    Switch(config)#interface f0/3
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#exit
    Switch(config)#interface f0/22      //这是交换机连接交换机的口
    Switch(config-if)#switchport mode trunk//注意啦注意啦交换机连交换机的口要改为trunk模式意思是vlan数据包都可以经过
    Switch(config-if)#exit
    >>>>>>>>                       //类似操作这里小编就不演示啦  不会可以私聊我哦                            
    Switch#show vlan brief       //show vlan brief查看我们vlan数据库的vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                    Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                    Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                    Fa0/18, Fa0/19, Fa0/20, Fa0/21
    2    v2                               active    Fa0/1, Fa0/3, Fa0/4, Fa0/5        //看我们已经把这些接口都接入vlan2啦
                                                    Fa0/24
    3    v3                               active    Fa0/2, Fa0/23
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    Switch#
    
    // 第二个交换机里的相关操作
    Switch>enable
    Switch#vlan database
    % Warning: It is recommended to configure VLAN from config mode,
      as VLAN database mode is being deprecated. Please consult user
      documentation for configuring VTP/VLAN in config mode.
    
    Switch(vlan)#vla
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to
    Switch(vlan)#vlan 2 name v2
    VLAN 2 added:
        Name: v2
    Switch(vlan)#vlan 3 name v3
    VLAN 3 added:
        Name: v3
    Switch(vlan)#
    Switch(vlan)#exit
    Switch#conf t
    Switch(config)#interface f0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#exit
    Switch(config)#interface f0/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 3
    Switch(config-if)#exit
    Switch(config)#interface f0/3
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 3
    Switch(config)#interface f0/22      //这是交换机连接交换机的口
    Switch(config-if)#switchport mode trunk//注意啦注意啦交换机连交换机的口要改为trunk模式意思是vlan数据包都可以经过
    

    说明:access模式意指电脑连接、trunk模式是不管vlan几的数据包都可以通过
    二、配置路由器的相关操作
    路由器可以粗略的就是将不同的vlan连接在一起

    // 路由器的相关操作
    Router>
    Router>
    Router>enable
    Router#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#interface FastEthernet0/0
    Router(config-if)#ip address 192.168.1.254 255.255.255.0
    Router(config-if)#no shutdown
    
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    Router(config-if)#
    Router(config-if)#exit
    Router(config)#interface FastEthernet0/1
    Router(config-if)#ip address 192.168.2.254 255.255.255.0
    Router(config-if)#no shutdown
    
    %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    Router(config-if)#
    Router(config-if)#ip help
    Router(config-if)#ip helper-address 192.168.1.1          //建立vlan2和vlan3的连接
    Router(config-if)#
    

    三、一些相关DHCP、DNS、web的操作如图:
    1.DHCP
    在这里插入图片描述
    在这里插入图片描述
    2.web
    在这里插入图片描述
    在这里插入图片描述
    3.DNS
    在这里插入图片描述
    在这里插入图片描述
    四、利用无线设备访问web
    在这里插入图片描述
    了解远程登录交换机可点击:https://blog.csdn.net/hanhanT/article/details/111029757

    了解远程登录路由器请点击:https://blog.csdn.net/hanhanT/article/details/111032851

    喜欢的的朋友可以点赞关注可以私聊问问题哦!不足之处请大家批评指正!

    展开全文
  • 单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应一个vlan。在每个子接口的数据在物理链路上传递都要标记封装。Cisco设备支持ISL和802.1q(dot1Q)协议。华为只支持802.1q
  • 思科交换机VLAN,DHCP配置模拟实例

    千次阅读 2020-10-10 15:15:04
    1.要求: 左边的电脑自动获取IP为192.168.1.1段 右边的电脑自动获取IP为192.168.2.1段 2.开始准备工作,f0/1接...4.建立 vlan 10并分配IP地址 Switch> Switch>enable Switch#conf t Enter configuration command

    1.要求:
    左边的电脑自动获取IP为192.168.1.1段
    右边的电脑自动获取IP为192.168.2.1段
    在这里插入图片描述
    2.开始准备工作,f0/1接左边交换机,f0/2接右边交换机,实际工作中,一定要接这个口,你要是接反了或者接到其他口去,获取的IP就不对了
    在这里插入图片描述

    3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960)
    在这里插入图片描述
    4.建立 vlan 10并分配IP地址
    Switch>
    Switch>enable
    Switch#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface vlan 10
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#
    在这里插入图片描述
    5.配置DHCP地址池和相应参数(实际运用中你可能上不去网,改下DNS地址就行了)
    Switch(config)#ip dhcp pool 10 (建立名为 10 的地址池)
    Switch(dhcp-config)#network 192.168.1.0 255.255.255.0(网络地址)
    Switch(dhcp-config)#dns-server 192.168.1.1(DNS 地址)
    Switch(dhcp-config)#default-router 192.168.1.1(默认网关)
    Switch(dhcp-config)#exit
    Switch(config)#ip dhcp excluded-address 192.168.1.1(设置保留不分配的 IP地址)
    Switch(config)#exit
    Switch#
    在这里插入图片描述
    6.进入端口 f0/1 ,并把端口加入vlan 10
    Switch(config)#interface f0/1
    Switch(config-if)#switchport access vlan 10 (打完这个还要按一次回车,如图)
    附:删除vlan和多个端口加入vlan,这个我没有试
    在这里插入图片描述
    在这里插入图片描述
    7.查看电脑端是否能自动获取IP
    在这里插入图片描述
    在这里插入图片描述
    8.再加两台电脑,依旧正常获取IP,左边设置完成在这里插入图片描述
    9.设置右边交换机,重复456即可,依旧在最上面那个交换机里设置,全命令如下
    Switch>enable
    Switch#conf t
    Switch(config)#interface vlan 20
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#ip dhcp pool 20
    Switch(dhcp-config)#network 192.168.2.1 255.255.255.0
    Switch(dhcp-config)#dns-server 192.168.2.1
    Switch(dhcp-config)#default-router 192.168.2.1
    Switch(dhcp-config)#exit
    Switch(config)#ip dhcp excluded-address 192.168.2.1
    Switch(config)#exit

    Switch#conf t
    Switch(config)#interface f0/2
    Switch(config-if)#switchport access vlan 20
    在这里插入图片描述
    在这里插入图片描述
    10.模拟实验完成。
    注:vlan 10和 vlan 20 是不能互通的,互通要额外的设置,这个还不会,哪天学会了补上来

    展开全文
  • 1、VLAN基础知识 VLAN(Virtual Local Area Network)的中文名为:“虚拟局域网”,注意和'VPN'(虚拟专用网)进行区分。 VLAN是一种将局域网设备从逻辑上划分(不是从物理上划分)成一个个网段,从而实现虚拟...
  • 之前的文章就使用了华为ENSP模拟软件对VLAN的原理与配置,通过抓包数据分析进行了学习,接下来就使用思科的设备查看VLAN的原理。 实验拓扑如下: (1)在PC上配置相关IP信息; (2)在交换机Switch0上配置命令如下...
  • VLAN设置实例全程解读

    2020-04-26 16:29:52
    VLAN设置实例全程解读 什么是三层交换和VLAN? 要回答这个问题我们还是先看看以太网的工作原理。以太网的工作原理是利用二进制位形成的一个个字节组合成一帧帧的数据(其实是一些电脉冲)在导线中进行传播。首先,...
  • 创建vlansw1#vlan database 进入vlan数据库sw1(vlan)#vlan 2 name jishu 创建名为:技术的vlanVLAN 40 modified:Name: jishusw1(vlan)#vlan 3 name caiwu 创建名为:财务的vlanVLAN 41 modified:Name: caiwusw2#vlan...
  • cisco nexus7K qinq配置

    2018-09-29 09:31:08
    介绍cisco nexus7K系列交换机关于QINQ 配置 dot1q-tunnnel vlan配置
  • VRRP配置及多备份VRRP配置实例1 VRRP概念介绍VRRP全称是虚拟路由器冗余协议(Virtual Router Redundancy Protocol)。为了理解VRRP,首先需要确定下列术语:●VRRP路由器:运行VRRP协议的路由器。该路由器可以是一个或...
  • 配置Ciscovlan生成树PVST

    千次阅读 2020-12-12 12:58:48
    作为cisco的私有生成树协议,PVST的应用范围受到了一定程度的限制,只有思科的交换机才能配置使用。 原理是给交换机环路中的每一个vlan生成一棵树用来阻塞环路达到解决广播风暴和备份链路的作用,通过给不同的vlan...
  • 一、思科交换机基本配置命令 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名 ...
  • 详解VLAN ACL及配置实例

    千次阅读 2010-07-15 19:29:00
    VACL详解  有些刚接触ACL(Access Control Lists)的朋友听到VACL可能有些陌生,本文将对VACL在Cisco COS和IOS版本的交换机上的使用,进行一个比较全面的描述。  VACL(VLAN ACL)和定时访问列表、动态...
  • 单臂路由:实现不同VLAN之间的通信。路由器的物理接口可以分化为多个逻辑子接口,每个子接口对应一个vlan网段的网关 链路类型 交换机连接主机的端口为access链路 交换机连接路由器的端口为Trunk链路 原理: 路由器...
  • 1、VLAN基础知识 VLAN(Virtual Local Area Network)的中文名为'虚拟局域网',注意不是'VPN'(虚拟专用网)。VLAN是一种将局域网设备从逻辑上划分(注意,不是从物理上划分)成一个个网段,从而实现虚拟...
  • 文章目录一、QinQ概述二、QinQ运行原理三、QinQ类型四、QinQ实例配置讲解(重点!)五、QinQ配置命令(灵活QinQ) 一、QinQ概述 现在以太网技术在网络中进行了大量的部署,网络中有着各种各样的需求,如果我们利用产...
  • BFD配置实例

    千次阅读 2021-09-08 19:31:10
    今天给大家带来一系列BFD的配置实例。本文使用华为eNSP模拟器,完成了BFD的一系列配置实例,包括BFD与静态路由、VRRP、OSPF、IS-IS、BGP等协议的联动。看完这篇文章,相信您一定会了解BFD在现网中的使用方法了。 ...
  • VLAN网络的配置实例

    2009-09-15 14:25:00
    VLAN网络的配置实例 为了给大家一个真实的配置实例学习机会,下面就以典型的中型局域网VLAN配置为例向各位介绍目前最常用的按端口划分VLAN的配置方法。 某公司有100台计算机左右,主要使用网络的部门有:生产部(20...
  • VLAN的划分和网络的配置实例 1、VLAN基础知识 VLAN(Virtual Local Area Network)的中文名为:“虚拟局域网”,注意和'VPN'(虚拟专用网)进行区分。 VLAN是一种将局域网设备从逻辑上划分(不是从物理上划分)成...
  • vlan原理详解

    2020-09-29 23:01:21
    1.为什么需要VLAN 1.1什么是VLANVLAN(Virtual LAN),翻译成中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的...
  • 汇聚层:实现Vlan间通信,广播域的划分,并且定义了控制类型通信(路由更新、汇总、vlan间通信、地址聚合、访问控制、路由重分布)的策略。 核心层:快速转发。 Vlan的类型: 默认vlan:...
  • VLAN聚合通过定义Super-VLAN和Sub-VLAN,使Sub-VLAN只包含物理接口,负责保留各自独立的广播域;Super-VLAN不包含物理接口,只用来建立三层VLANIF接口。然后再通过建立Super-VLAN和Sub-VLAN间的映射关系,把三层VLAN...
  • 路由器交换机VLAN配置实例 解决桥接中路由器配置IP参数问题 局域网中代理服务器、路由器的配置案例 局域网中代理路由器的配置 路由器NAT功能配置简介(1) 路由器备份配置(1) 路由器的NAT的原理及配置 路由器的工作...
  • Cisco单臂路由配置,图文实例详解

    万次阅读 多人点赞 2015-11-18 19:56:49
    Cisco单臂路由配置    单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应一个vlan。在每个子接口的数据在物理链路上传递都要标记封装。Cisco设备支持ISL和802.1q(dot1Q)协议。华为只支持802.1q。
  • 计算机网络技术的发展犹如戏剧舞台,你方唱罢我登台。从传统的以太网(10Mb/s)发展到快速以太网(100Mb/s)和千兆以太网(1000Mb/s...现在,网络业界对“三层交换”和VLAN这两词已经不感到陌生了。 一、什么是三...
  • 一、为什么需要VLAN 1.1、什么是VLAN? VLAN(Virtual LAN),翻译成中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器...
  • VLAN原理详解

    万次阅读 多人点赞 2019-05-31 09:47:54
    同样,C发送广播信息时,只会被转发给其他属于蓝色VLAN的端口,不会被转发给属于红色VLAN的端口。   就这样,VLAN通过 限制 广播帧转发的范围 分割 了广播域。上图中为了便于说明,以红、蓝两色识别不同的...
  • trunk:主要是为了不同交换机的相同vlan相互通信配置静态VLAN的步骤:************************************1.创建VLAN1)VLAN数据库配置模式: Switch#vlan databaseSwitch(vlan)#vlan vlan-id [na...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 836
精华内容 334
关键字:

思科vlan配置实例详解