精华内容
下载资源
问答
  • 如果在一个使用链路状态路由的互连网络中有5个路由器和六个网络,那么存在多少个链路状态数据库答:1多个进程对信号量S进行了6次P操作,2次V操作后,现在信号量的值是-3,与信号量S相关的处于阻塞状态的进程有几个()...

    如果在一个使用链路状态路由的互连网络中有5个路由器和六个网络,那么存在多少个链路状态数据库

    答:1

    多个进程对信号量S进行了6次P操作,2次V操作后,现在信号量的值是-3,与信号量S相关的处于阻塞状态的进程有几个()

    答:3个

    在Word操作中,选定文本块后,鼠标指针变成箭头形状,__________拖动鼠标到需要处即可实现文本块的移动

    答:无需按键

    高智商并不等于高创造。()

    答:√

    在人直立或坐位时,胸膜腔的最低处

    答:肋膈隐窝

    “六法”的第二法是“骨法用笔”。

    答:对

    使用“表格样式”命令,能够完成对表格各项参数设置

    答:√

    教授们是站在什么样的立场上和希特勒发生联系

    答:右翼保守

    In Michael’s perspective, you’d better express your creative ideas in the way that is clearly and ______________delivered.

    答:chronologically

    The poem “Night Rain” by Xu Zaisi (《夜雨》徐再思) implies the poet’s _________ on the rainy autumn night.

    答:sadness

    智慧职教: 个人信用信息基础数据库中最重要的信息是? ? ?。

    答:个人与银行之间的信贷交易信息

    同一物质的最大吸收波长相同

    答:√

    The revolution of 1688 meant three of the following things except:

    答:the Restoration of monarchy

    工程法学研究内容的特点是其主体内容的,客体内容的,以及行为内容的

    答:多样性、专业性、复杂性

    如果道德的发展不足以应对个体行为的失范,那么社会成员在面对上述违背道德的手段时就往往选择优选考虑个人利益( )

    答:对

    按表观密度为时称为重混凝土

    答:>2600kg/m3。

    一个账户的借方发生额合计数与其贷方发生额合计数总是相等的

    答:×

    头脑风暴法不需要热身活动

    答:×

    描写边地征人困苦生活的《突厥三台》是( )的诗歌作品?

    答:盛小丛

    开创了中国写意画的先河的是下面哪位?()

    答:徐渭

    对侧疏忽综合征患者的注意出现哪些异常?

    答:对脑损伤侧线索过度注意 对脑损伤对侧目标注意困难

    展开全文
  • OSPF链路状态更新

    2021-04-06 08:05:53
    一个 LSU 数据包可能包含11类型的链路状态通告 (LSA),术语“链路状态更新 (LSU)”和“链路状态通告 (LSA)”之间的差异有时较难分清。有时,它们可以互换使用。一个 LSU 包含一个或多个 LSA,这两个术语中的任何一个...

    链路状态更新 (LSU) 数据包用于 OSPF 路由更新。一个 LSU 数据包可能包含11类型的链路状态通告 (LSA),术语“链路状态更新 (LSU)”和“链路状态通告 (LSA)”之间的差异有时较难分清。有时,它们可以互换使用。一个 LSU 包含一个或多个 LSA,这两个术语中的任何一个都可用于表示由 OSPF 路由器传播的链路状态信息。

    以下是LAS的11种类型:

    6f8f3dda8b5d8aeab1d9bf0469c2c026.png

    OSPF算法

    每台 OSPF 路由器都会维持一个链路状态数据库,其中包含来自其它所有路由器的 LSA。一旦路由器收到所有 LSA 并建立其本地链路状态数据库,OSPF 就会使用 Dijkstra 的最短路径优先 (SPF) 算法创建一个 SPF 树。随后,将根据 SPF 树,使用通向每个网络的最佳路径填充 IP 路由表。

    管理距离:OSPF的管理距离(AD)是“110”。

    身份验证:

    与对其它路由协议一样,OSPF 也可进行身份验证配置。对传输的路由信息进行身份验证是好的做法。此做法可确保路由器仅接受配置有相同的口令和身份验证信息的其它路由器所发来的路由信息。

    OSPF基本配置

    Router ospf 命令:

    process-id 是一个介于 1 和 65535 之间的数字,由网络管理员选定。process-id仅在本地有效,这意味着路由器之间建立相邻关系时无需匹配该值。

    配置方法:

    R1#conf t

    R1(config)#router ospf 1

    R1(config-router)#

    Network 命令

    OSPF 中的 network 命令与其它 IGP 路由协议中的 network 命令具有相同的功能:

    l 路由器上任何符合 network 命令中的网络地址的接口都将启用,可发送和接收 OSPF 数据包。

    l 此网络(或子网)将被包括在 OSPF 路由更新中。

    Router(config-router)#network network-address wildcard-mask areaarea-id

    area area-id 指 OSPF 区域。OSPF 区域是共享链路状态信息的一组路由器。相同区域内的所有 OSPF 路由器的链路状态数据库中必须具有相同的链路状态信息,这通过路由器将各自的链路状态泛洪给该区域内的其它所有路由器来实现。(“ 0”为骨干区域)

    OSPF路由器ID

    确定路由器 ID

    OSPF 路由器 ID 用于唯一标识 OSPF 路由域内的每台路由器。Cisco 路由器按下列顺序根据下列三个条件确定路由器 ID:

    l 使用通过 OSPF router-id 命令配置的 IP 地址。

    l 如果未配置 router-id,则路由器会选择其所有环回接口的最高 IP 地址。

    l 如果未配置环回接口,则路由器会选择其所有物理接口的最高活动 IP 地址。

    OSPF router-id 命令

    Router(config)#router ospf process-id //进入OSPF配置模式

    Router(config-router)#router-id ip-address //配置Router-id

    修改路由器 ID

    使用:Router#clear ip ospf process 命令来重启OSPF进程,然后去修改你想要的Router-id。

    重复的路由器 ID

    当同一个 OSPF 路由域内的两台路由器具有相同的路由器 ID 时,将无法正常路由。如果两台相邻路由器的路由器 ID 相同,则无法建立相邻关系。当出现重复的 OSPF 路由器 ID 时,IOS 将显示一条类似下列的消息:

    %OSPF-4-DUP_RTRID1:Detected router with duplicate router ID

    验证Router-id:使用show ip protocols来验证。

    验证OSPF

    show ip ospf neighbor 命令可用于验证 OSPF 相邻关系并排除相应的故障。此命令为每个邻居显示下列输出:

    l Neighbor ID — 该相邻路由器的路由器 ID。

    l Pri — 该接口的 OSPF 优先级。

    l State — 该接口的 OSPF 状态。FULL 状态表明该路由器和其邻居具有相同的 OSPF 链路状态数据库。

    l Dead Time — 路由器在宣告邻居进入 down(不可用)状态之前等待该设备发送 Hello 数据包所剩余的时间。此值在该接口收到 Hello 数据包时重置。

    l Address — 该邻居用于与本路由器直连的接口的 IP 地址。

    l Interface — 本路由器用于与该邻居建立相邻关系的接口。

    l

    在下列情况下,两台路由器不会建立 OSPF 相邻关系:

    l 子网掩码不匹配,导致该两台路由器分处于不同的网络中。

    l OSPF Hello 计时器或 Dead 计时器不匹配。

    l OSPF 网络类型不匹配。

    l 存在信息缺失或不正确的 OSPF network 命令。

    其它功能强大的 OSPF 故障排除命令包括:

    show ip protocols

    可用于快速验证关键 OSPF 配置信息,其中包括 OSPF 进程 ID、路由器 ID、路由器正在通告的网络、正在向该路由器发送更新的邻居以及默认管理距离

    show ip ospf

    命令也可用于检查 OSPF 进程 ID 和路由器 ID,此外,还可显示 OSPF 区域信息以及上次计算 SPF 算法的时间。

    路由器每次收到有关拓扑的新信息时,必须重新运行 SPF 算法,SPF 算法会占用很多 CPU 资源。以下信息是使用show ip ospf的输出。

    Initial SPF schedule delay 5000 msecs

    Minimum hold time between two consecutive SPFs 10000 msecs

    Maximum wait time between two consecutive SPFs 10000 msecs

    状态在 up 和 down 之间来回变化的网络称为链路不稳。链路不稳会导致区域内的 OSPF 路由器持续重新计算 SPF 算法,从而无法正确收敛。为尽量减轻此问题,路由器在收到一个 LSU 后,会等待 5 秒(5000 毫秒)才运行 SPF 算法。这样可以防止路由器持续运行 SPF 算法,还存在一个 10 秒(10000 毫秒)的保留时间。路由器运行完一次 SPF 算法后,会等待 10 秒才再次运行该算法。

    show ip ospf interface

    此命令用于检验 Hello 间隔和 Dead 间隔的最快方法。Cost就是开销值。

    检查路由表

    使用show ip route 命令可用于检验路由器是否正在通过 OSPF 发送和接收路由。每条路由开头的 O 表示路由来源为 OSPF。

    OSPF度量

    OSPF 度量称为开销RFC 2328 中有下列描述:“开销与每个路由器接口的输出端关联。系统管理员可配置此开销。开销越低,该接口越可能被用于转发数据流量。”

    Cisco IOS 使用从路由器到目的网络沿途的传出接口的累积带宽作为开销值。

    图示为各种接口的默认 OSPF 开销。

    b5241713db95345a9a87cd8eb6d555ae.png

    参考带宽

    参考带宽默认为 10 的 8 次幂,即 100,000,000 bps,亦即 100 Mbps。这使带宽等于或大于 100 Mbps 的接口具有相同的 OSPF 开销 1。

    可使用 OSPF 命令 auto-cost reference-bandwidth 修改参考带宽值。如果需要使用此命令,则建议同时用在所有路由器上,以使 OSPF 路由度量保持一致。

    OSPF 累计开销

    OSPF 路由的开销为从路由器到目的网络的累计开销值。(就是说源地址到目的地址中间经过的所有路径的开销值进行相加)

    修改链路的开销

    bandwidth 接口命令或 ip ospf cost 接口命令都可用于达到此目的 — 使 OSPF 在确定最佳路由时使用准确的值。(要该就要两端都要改)

    Router(config-if)#bandwidth bandwidth-kbps //修改接口的带宽参数。

    Router(config-if)# ip ospf cost “加数字”//命令则直接将链路开销设置为特定值并免除了计算过程。

    展开全文
  • 开放式最短路径优先OSPF是IETF组织开发的一个机遇链路状态的内部网关协议(Interior Gateway Protocol);其中开放式代表公有协议,不受厂商的限制,在任意设备上使用,应用最广泛的协议。版本:IPV2/IPV3,本文的...

    一、OSPF的基本概念

    1、OSPF简介
    开放式最短路径优先OSPF是IETF组织开发的一个机遇链路状态的内部网关协议(Interior Gateway Protocol);其中开放式代表公有协议,不受厂商的限制,在任意设备上使用,应用最广泛的协议。版本:IPV2/IPV3,本文的OSPF均为OSPF IPV2协议。
    2、OSPF的优点
    作为基于链路状态的协议,除了能够解决RIP所面临的诸多问题以外,还有以下四点优点:
    ①、OSPF采用组播形式收发协议报文,组播地址是:224.0.0.5(.5代表OSPF内所有的路由器)/244.0.0.6(代表OSPF指定路由器DR);
    ②、支持无类型域间选路;
    ③、支持对等价路由器进行负载分担:路径开销相等的情况下,相等的两条路都可以选择;
    ④、支持报文认证。
    3、Router-ID
    ①、OSPF的术语是Router-ID,一台路由器指定唯一的Router-ID。一旦设定无法更改。若想更改需要重启OSPF进程,但是重启的风险:网络需要重新收敛,重新计算,数据传输有风险;
    ②、Router-ID的设定可以通过手工配置,用32位点分十进制表示的。一般指的就是回环地址(loopback 0),因为loopback 0属于虚拟主机,接口不会断掉,从而保证了协议的稳定性。
    4、OSPF Cost
    ①、OSPF使用cost“开销”作为路由度量值;
    ②、OSPF接口cost=100M/接口宽带,其中100M为OSPF的参考带宽,可以修改。数值取整,并非四舍五入;
    ③、每一个激活OSPF的接口都有一个cost值
    ④、一条OSPF路由的cost由该路由从起源一路到达本地所有入接口cost值得总和,具体含义看下图。
    在这里插入图片描述
    R1:cost=1;R2:cost=50;R3:cost=1
    R1–R2的cost值=50+1;
    R1–R3的cost值=50+1+1

    二、OSPF邻居关系建立过程

    1、OSPF的三张表
    ①、邻居表(peer):是一种可靠的路由协议,需要先建立OSPF邻居关系之后才能发送hello报文,建立邻接关系(全毗邻的邻居关系),网络收敛,形成邻居表;
    OSPF邻居关系:直连的路由器是邻居
    邻接关系:全毗邻的邻居关系
    ②、链路状态数据库(LSDB)
    OSPF是由LSA(链路状态通告)来描述网络拓扑信息的,用LSDB存储网络的LSA,运行OSPF时LSDB表必须同步
    ③、OSPF路由
    基于LSDB进行SPF(Dijkstra算法是Dijkstra发明的)计算,得出路由表
    2、OSPF五种报文
    OSPF Hello报文:邻居到邻接关系,中间发送hello报文,到网络收敛之后,仍会发送hello报文,周期性是10s,为了确认邻居仍然存在,若40s没有响应(down),即4倍的周期性时间,就重新寻找邻居(发的组播是255.0.0.5);
    OSPF DD报文:描述LSDB,相当于携带LSA头部信息,一个摘要;
    OSPF LSR报文:链路状态请求。用于向对方请求所需的LSA,会携带具体的信息;
    OSPF LSU报文:用于向对方发送其所需要的LSA,LSA是承载在LSU报文里面的,注意:抓包时只能发现LSU;
    OSPF LSAck报文:确认报文。对收到的LSA进行确认。
    3、OSPF邻居关系的建立
    那么报文从宏观和细节两个方面了解:
    ①、宏观(四步)
    在这里插入图片描述
    第一步:建立关系R1发送hello包,R1的route-id会记录进去,R2收到hello信息,只有R1的1.1的信息,R2会再记录1.2,这时R2再回hello包给R1时,就建立了关系;
    第二步:首先协商主(master)/从(slave)关系,为了选择谁先发送DD报文;发送DD报文,交互LSA头部摘要信息;
    第三步:包含LSR(请求)、LSU(发送LSA)、LSAck(确认);
    第四步:同步之后进入OSPF全毗邻的邻接关系。
    ②、细节(即OSPF邻居关系的建立有七种状态)
    down状态:时间很短,开启了OSPF协议,还没有收到hello包;
    INT状态:OSPF协议启动之后立马发送hello包,R2刚收到R1的hello包,在R1里面只建立了自己的ip,还没有R2的信息,没有双向建立,对于R2来说把R1置于INT状态,在R2里面去设置;
    Two-way状态:R2发送自己的ip,把邻居设为R1,双向关系建立之后R1就是Two-way状态;MA网络会选举DR(指定路由器)、BDR(备份指定路由器)(这两个名词后面会做详解);
    Ex-start状态(就绪状态):发送DD报文,产生序列号(Seq=x),route-id 大的为主,选择主从关系的时候,DD报文是不携带LSA头部关系的,标志位:I、M、MS
    I=1:正在协商主从,I=0:确认主从;
    M=1:代表还有DD报文要发送 ,M=0:表示发送DD报文是最后一个;
    MS=1:表示报文是主(master)发的,MS=0,表示报文是从(slave)发的;
    **Exchange状态:**交换信息,确定主从,开始携带(LSA头部信息)摘要,I=0,MS=0置为从,master发送DD报文11,slave就用原来的DD报文,也是11,这时主再发,主需要+1,DD报文就是12。周而复始,是交互的过程,等到R1和R2都没有了,就进入下一个阶段;
    **Loading状态:**发LSR请求–收到全部的信息发送LSU信息–LAck ,R1和R2都是Loading;
    **FULL状态:**交换结束

    三、OSPF的基本工作机制

    1、DR、BDR的特性
    在上面提到OSPF邻居关系的建立的Two-way状态时,MA网络会选举DB、BDR,下面详细讲解下概念以及工作原理:
    1)选举规则:先优先级大的,若优先级相同,选routeid大的,默认优先级:1,可选范围是0-255,若没有0则不参加选取;
    2) 没有抢占性
    DR:指定路由器
    BDR:备份指定路由器

    在这里插入图片描述
    在OSPF系统中,建立邻居关系之后,会存在DR和BDR,若DR坏了,BDR承载,当DR恢复正常之后,不会变成BDR,不存在抢占
    DR BDR监听组播地址224.0.0.6
    DRother 监听组播地址 224.0.0.5
    路由器除了被定于为DR和BDR,其余都是DRother。
    2、LSA的泛洪
    仍看上图
    路由器R3用224.0.0.6通知DR及BDR–DR、BDR监听224.0.0.6这一组播地址–DR向组播地址224.0.0.5发送更新以通知其他路由器–所有的OSPF路由器监听224.0.0.5这一组播地址–路由器收到包含变化后的LSA的LSU后–更新自己的LSDB,过一段时间(SPF延迟)-对更新链路状态数据库执行SPR算法–更新路由表
    3、OSPF area(区域)的概念
    ①、单区域的问题:
    LSA泛洪严重,OSPF路由器的负担很大;
    区域内部动荡会引起全网络路由器的SPF计算;
    LSDB庞大,资源消耗过多,设备性能下降,影响数据转发;
    每台路由器都需要维护的路由表越来越大,但区域内路由无法汇总
    那么就要划分多区域
    ②、OSPF多区域的优点:
    ※减少了LSA洪泛的范围,有效的把拓扑图变化控制在区域内,达到网络优化的目的;
    ※在区域边界可以做路由汇总,减少了路由表
    ※充分利用OSPF特殊区域的特性,进一步减少了LSA泛洪,从而优化路由
    ※多区域提高了网络扩展性,有理由组件大规模的网络
    area 0位骨干区域,负责在非骨干区域之间中专有“区域边界路由”贵大的链路状态通告信息。area 0 是骨干区域,是必须要有的区域,有且只有一个,若存在多区域,每个区域都要跟area 0相连,area1/2 标准区域
    在这里插入图片描述
    在这里插入图片描述
    除了骨干区域,还可以配置一下四种区域类型:
    stub 末梢区域:后面没有路由器设备 R5
    totally 完全末梢区域:只有一条默认路由出去,R4
    nssa 非完全末梢区域:完全的不够彻底,R3–R4这一段在OSPF的末梢,但是后面还连着起亚区域,就叫非完全末梢区域,跑的就是7类LSA,不会泛洪到其他区域
    totally nssa 完全非完全末梢区域
    ③、路由器的角色名称:
    IR:区域内路由器
    ABR:区域边界路由器ABR
    BR:骨干路由器
    ASBR:AS边界路由器
    4、OSPF网络类型(此点仅做了解即可):
    在这里插入图片描述

    四、了解OSPF的基础配置

    1、OSPF的基础配置
    先配置各接口ip
    再设置loopback 0 ip地址
    进入全局配置ospf

    ospf 1 创建OSPF进程号
    ospf 1 router-id 1.1.1.1 指定OSPF路由地址
    area 0  配置骨干区域
    network 192.168.1.0  0.0.0.255 在骨干区域配置特定接口
    ospf cost 9 进接口配置cost值
    

    2、OSPF的查看及验证

    display ospf brief  查看ospf协议相关运行参数
    display ospf per    查看ospf邻居表
    display ospf lsdb   查看lsdb表
    display ospf routing 查看ospf路由
    ospf dr-priority 255  修改OSPF DR的优先级
    

    五、OSPF六类LSA与链路状态数据库

    OSPF使用LSA(链路状态通告)来在网络中的路由器之间交换网络拓扑信息。LSA详尽地描述了网络的拓扑,OSPF总共有LSA-1、LSA-2、LSA-3、LSA-4、LSA-5、LSA-7共6类LSA他们分别拥有不同的职能

    1、Type-1 LSA:Router LSA
    又称:LSA1或者type-1 LSA,每一台运行OSPF的设备都会产生LSA-1;

    • 传播范围:只能在本区域传播,不能跨越ABR
    • 宣告者:每个OSPF路由器
    • 内容:直连接口的网段信息和cost,即路由和拓扑信息
    • 查看方法:dis ospf lsdb router 1.1.1.1
      Link-id为Router-id,ADV为通告者
      注意,在LSA-1中看不到掩码,掩码信息需要在LSA-2中查看

    2、Type-2 LSA: Network LSA
    只在多路访问MA网络中存在

    • 传播范围:只能在本区传播,不能跨越ABR
    • 宣告者:DR(通告一共有多少台路由器运行)
    • 内容:描述有多少成员以及掩码信息,直连接口的网段信息和cost值
    • 查看方法:dis ospf lsdb network
      1类2类小结:
      借助一个区域内所泛洪的Type-1LSA及Type2,该区域中的所有路由器能够还原出区域的完整拓扑,并在此基础上计算出到达区域内各个网段的最佳、无环路由

    3、Type-3LSA: Summary LSA
    汇总LSA,可通过操作拦截

    • 传播范围:整个OSPF域
    • 通告者:ABR(本区域边界路由器,可能发生改变)
    • 内容:域间路由,LSA-3穿越多个ABR时,通告者改变;数据汇总到area0中,归纳汇总的作用
    • 查看方法:dis ospf lsdb summary

    4、Type-4 LSA:ASBR Summary LSA
    告诉其他区域ASBR所在的位置,根据LSA-5而来

    • 传播范围:除ASBR所在区域外的整个OSPF区域
    • 宣告者:ABR(穿越多个ABR时改变)
    • 内容:ASBR的Router-id
    • 查询方法:dis ospf lsdb asbr

    5、Type-5 LSA:External LSA
    外部LSA,描述外部信息,不属于任何一个区域

    • 传播范围:整个OSPF域;
    • 宣告者:ASBR(只有引入了外部路由并且重分发动作执行后才会成为ASBR,通告在穿过多个区域时一直不改变);
    • 内容:外部路由,在路由表中标记为“O-ASE”;
    • 查询方法:dis ospf lsdb ase
      LSA-4和LSA-5通常是一起出现的,LSA-5讲述的是外部路由,而LSA-4则是说ASBR的位置,所以是先有LSA-5再有LSA-4

    6、Type-7 LSA: NSSA LSA
    与LSA-5只是称呼的不同,都是关于域外路由的

    • 传播范围:整个NSSA区域;
    • 宣告者:ASBR(穿过多个区域时一直不改变);
    • 内容:外部路由,会出现在NSSA区域,不允许进入到其他Area,
    • 查询方法:dis ospf lsdb nssa
      NSSA的ABR在收到Type-7 LSA后,负责将其转换成Type-5 LSA,然后注入到Area0中,进而传播到整个OSPF域。

    Type-5 LSA和Type-7 LSA都有两种度量值Type1和Typ2,将外部路由引入OSPF是,如果为指定该外部路由的度量值类型,则缺省为Type2,且路由的外部cost缺省为1。

    7、配置命令

    [R4]ospf 1	进入ospf进程 
    [R4-ospf-1]import-route rip 1 type 2 cost 1   别人注入到OSPF时需要配置cost值
    [R4]rip 1        进入rip进程
    [R4-rip-1]import-route ospf 1  注入到rip进程 
    需注意:入注是双向的
    
    import-route direct 引入直连路由
    import-route static 引入静态路由
    default-route-advertise always 引入默认路由
    

    查看各类信息

    dis ospf routing 查看ospf的全局路由表
    dis ospf ladb router 1.1.1.1  1类
    dis ospf lsdb network 2类
    dis ospf lsdb summary 3类
    dis ospf lsdb asbr 4类
    dis ospf lsdb ase  5类
    dis ospf lsdb nssa  7类
    

    六、实验要求:给路由器配置OSPF,并让PC1和PC2互通

    在这里插入图片描述

    R1
    [r1]sys R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 12.0.0.2 24
    [R1-GigabitEthernet0/0/1]q
    [R1]int loo	
    [R1]int LoopBack 0
    [R1-LoopBack0]ip add 1.1.1.1 32
    [R1]ospf 1     创建OSPF进程号为1
    [R1-ospf-1]ospf 1 router-id 1.1.1.1  指定OSPF路由地址1.1.1.1
    [R1-ospf-1]area 0  配置骨干区域
    [R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255 在骨干区域配置特定接口
    [R1-ospf-1-area-0.0.0.0]network 12.0.0.0 0.0.0.255
    R2
    [Huawei]sys R2
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.1 24
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 23.0.0.2 24
    [R2-GigabitEthernet0/0/1]1
    [R2]int loop	
    [R2]int LoopBack 0
    [R2-LoopBack0]ip add 2.2.2.2 32
    [R2-LoopBack0]q
    [R2]ospf 1
    [R2-ospf-1]ospf 1 router-id 2.2.2.2	
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 12.0.0.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 23.0.0.0 0.0.0.255
    R3
    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]i add 23.0.0.1 24
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 192.168.2.254 24
    [R3-GigabitEthernet0/0/1]q
    [R3]int l	
    [R3]int LoopBack 0
    [R3-LoopBack0]ip add 3.3.3.3 32
    [R3]ospf 1
    [R3-ospf-1]ospf 1 router-id 3.3.3.3	
    [R3-ospf-1-area-0.0.0.0]network 23.0.0.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    

    配置之前
    在这里插入图片描述
    验证可以看一下路由器

    display ospf per
    

    在这里插入图片描述

    dis ip routing-table
    

    在这里插入图片描述

    展开全文
  • oracle 数据库链路

    2021-05-04 03:59:22
    Oracle数据库链路的建立和使用一、数据库链路的建立:1、数据库链路的建立语法一般是:CREATE DATABASE LINK[db_link_name] CONNECT TO[user_name] IDENTIFIED BY [password] USING ‘[tns_name]‘;其中:[DB_LINK_...
  • oracle数据库链路的建立和使用一、数据库链路的建立:1、数据库链路的建立语法一般是:CREATE DATABASE LINK[db_link_name] CONNECT TO[user_name] IDENTIFIED BY [password] USING '[tns_name]';其中:[DB_LINK_NAME...
  • OSPF(链路状态)

    2021-02-01 16:18:39
    RIP是距离矢量算法,传的是路由表; OSPF传的数据库(详细描述了接口的IP地址等信息);就是这个协议不知道你在哪里,但是知道想去哪里找你就OK...在不同的邻居状态发不同的包; 先进行宣告网段;之后用组播进行发送helllo包;
  • 链路状态路由协议:OSPF 前言: 动态路由的分类1.按工作原理可以分为:距离矢量协议,链路状态协议 2.按工作范围可以分为:内部网关协议IGP,外部网关协议EGP 3.按路由更新时是否携带子网掩码可以分为:有类路由...
  • 链路状态路由----ospf...链路状态数据库,用于存放LSA SPF算法(最短路径算法) 使用算法算出到达目标的最优路径 维护路由表 根据spf算法将路由加入路由表 ospf基本特点 ①采用组播发送报文,224.0.0.5(DRother监听
  • 4.5.2 OSPF协议与链路状态算法
  • 这里写目录标题OSPF简介OSPF基本特点OSPF COST三张表邻居表链路状态数据库(LSDB)OSPF路由表报文类型OSPF网络类型 OSPF简介 开放式最短路径优先PSPF的IETF组织开发的一个基于链路状态的内部网关协议。 目前针对IPv4...
  • 路由选择算法可分为:全局式路由选择算法:所有路由器掌握完整的网络拓扑和链路费用信息,例如链路状态(LS)路由算法分散式路由选择算法:路由器只掌握物理相连的邻居以及链路费用,例如距离向量(DV...
  • LSDB(链路状态数据库):包含了该路由器在本区域所有的链路状态信息,并实时同步 路由表:根据SPF算法算出的路由放在ospf路由表中 OSPF的五种报文 hello报文:用于建立邻居关系 DD报文:对LSDB的汇总(仅发送LSA...
  • 基于链路状态数据库的外部网关协议 B. 基于链路状态数据库的内部网关协议 C. 基于距离向量的外部网关协议 D. 基于距离向量的内部网关协议 OSPF协议是 ( B ) A. 基于链路状态数据库的外部网关协议 B. 基于链路状态...
  • 路由1.0-OSPF协议

    2021-08-03 18:41:18
    文章目录简介一些基本概念区域概念分不同区域的原因路由器类型IRBRABRASBR指定路由器...OSPF同一区域中的每台路由器都有相同的链路状态数据库,(一个包含每台路由器可用接口和可达邻居的列表),也就是说,每台路由器
  •   基于已有代码框架,实现路由器生成和处理mOSPF Hello/LSU消息的相关操作,构建一致性链路状态数据库 运行网络拓扑(topo.py) 在各个路由器节点上执行disable_arp.sh, disable_icmp.sh, disable_ip_forward.sh),...
  • 一、内部网关协议和外部网关协议 1、AS 自治系统(Autonomous System),即AS,它是指一组通过统一的路由政策或路由协议互相... 链路状态路由协议 路由器对拓扑完全了解,,是“传信的路由”,例如:A将消息放入信里
  • 外部通信量(External Traffic) 三、OSPF路由器类型 ABR区域边界路由器: ASBR自治系统边界路由器: IR内部路由器 四、OSPF区域类型 五、链路状态数据库的组成 六、末梢区域和完全末梢区域的作用 七、OSPF链路状态...
  • 问个问题,IS-IS协议有必要了解吗?感觉IS-IS使用场景比较少。。。可以说较为小众,相关概念应该和OSPF差别不大吧? ...OSPF 【RFC1147】Open Shortest Path First 开放最短路径优先 ...区域内OSPF是一种链路...
  • 所有区域中的路由器共享相同的链路状态数据库,并且具有整个网络的完整图像。 无需主干区域。 使用多区域 OSPF,仅一个区域内的路由器共享相同的链路状态数据库。对一个区域中的网络拓扑的更改不会影响其他区域,这...
  • 刚刚过去的6月1日,蚂蚁金服宣布 Oceanbase 分布式数据库 3.0 版本正式开源。这将成为OceanBase从闭源软件售卖迈出了开源商业模式变革的关键一步。OceanBase ...
  • OSPF协议及链路状态算法 这个感觉不是太懂,完了应该还会补充 OSPF协议 定义: 叫做开放最短路径优先OSPF协议:"开放"表明OSPF协议不是受某一家厂商所控制,而是公开发表的;"最短路径优先"是因为使用了最短路径算法...
  • 二.OSPF工作过程 工作过程:邻居列表,链路状态数据库,路由表 建立邻接关系,学习链路状态信息,链路状态数据库(LSDB),通过SPF算法 ,最短路径树,路由表 OSPF区域:为了适应大型的网络,OSPF在AS内划分多个区域...
  • 于目前存在的路由选择协议可以按照距离矢量和链路状态进行分类, 可以说距离矢量和链路状态两种采用的是不同的算法,也有着不同的特性和区别,所以,在学习路由选择协议之前,了解它们怎么的特性和区别是非常有必要...
  • (hello包会携带RID) DBD包 作用:是一个数据库描述报文,描述LSDB(数据链路状态数据库-----存储LSA信息),LSDB相当于携带的是一个“数据库的目录”,避免重复浪费 LSR包----链路状态请求报文----作用:基于DBD包...
  • MySQL 自身在性能监测方面很不给力、这是令许多 MySQL DBA 夜夜辗转难眠、幸运的是、通过 Cacti 监测(注意是监测而非监控)MySQL 数据库状态借助 cacti+rrdtool 强大的绘图功能、加上专用的 mysql 模板、能够灵活快速...
  • OSPF总结

    2021-07-27 13:41:20
    OSPF:开放式最短路径优先协议 动态路由协议: 1.按照适用范围进行分类: IGP :AS内 BGP:AS外 AS—自治系统 2.按照协议的算法特点进行分类 距离矢量型(DV):路由信息 RIP EIGRP ...1.OSPF 是一种典型的链路状态
  • Python3.7pycharmMySQL 8.0.13阿里云服务器 windows server 2016Navicat一、远程数据库的配置1、在云服务器系统上配置MySQL数据库安装方法与本地数据库配置方法相同配置完毕后登入MySQL数据库,并且修改初始密码2、...
  • 一起谈.NET技术,Visual Studio 2008单元测试_数据库测试我们开发一个系统必须与数据库打交道,需要写N个SQL、存储过程、自定义函数、视图等,那么能否使用Visual Studio 2008进行数据库测试吗?当然是可以的,下面...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 49,496
精华内容 19,798
关键字:

链路状态数据库表