精华内容
下载资源
问答
  • 2014-07-08 10:41:42

    两层交换机工作在链路层 ,一般情况下两层交换机均允许支持vlan划分;但由于不支持端口的IP地址划分(需要网络层才支持IP地址,需要三层交换机才能满足相关功能),只能通过将交换机地址设置为hybird模式才能实现不同vlan之间的数据通信,

    例:将两层交换机划分为vlan1、vlan2、vlan3、vlan4四个子网,其中vlan2、vlan3、vlan4三个子网互不相同;vlan1与vlan2、vlan3、vlan4均联通:

    1. 创建VLAN2 
    [Quidway]vlan 2 
    2. 创建VLAN3 
    [Quidway-vlan2]vlan 3 
    3. 创建VLAN4 
    [Quidway-vlan3]vlan 4 
    4. 进入端口Ethernet1/0/1 
    进入端口Ethernet1/0/1 
    [Quidway-vlan4] interface Ethernet1/0/1  
    5. 将端口设置为hybrid模式 
    [Quidway-Ethernet1/0/1]port link-type hybrid 
    6. 设置端口pvid为1 
    [Quidway-Ethernet1/0/1]port hybrid pvid vlan 1  
    7. 允许VLAN1,2,3,4不打标签通过 
    [Quidway-Ethernet1/0/1]port hybrid vlan 1 to 4 untagged 
    8. 进入端口Ethernet1/0/2 
    [Quidway-Ethernet1/0/1]interface Ethernet1/0/2 
    9. 将端口设置为hybrid模式  
    [Quidway-Ethernet1/0/2]port link-type hybrid
    10.设置端口pvid为2 
    [Quidway-Ethernet1/0/2]port hybrid pvid vlan 2  
    11. 允许VLAN1,2不打标签通过 
    [Quidway-Ethernet1/0/2]port hybrid vlan 1 to 2 untagged  
    12. 进入端口Ethernet1/0/3 
    [Quidway-Ethernet1/0/2]interface Ethernet1/0/3  
    13. 将端口设置为hybrid模式 
    [Quidway-Ethernet1/0/3]port link-type hybrid  
    14. 设置端口pvid为3 
    [Quidway-Ethernet1/0/3]port hybrid pvid vlan 3 
    15. 允许VLAN1,3不打标签通过 
    [Quidway-Ethernet1/0/3]port hybrid vlan 1 3 untagged  
    16. 进入端口Ethernet1/0/4 
    [Quidway-Ethernet1/0/3]interface Ethernet1/0/4 
    17. 将端口设置为hybrid模式  
    [Quidway-Ethernet1/0/4]port link-type hybrid 
    18. 设置端口pvid为4 
    [Quidway-Ethernet1/0/4]port hybrid pvid vlan 4  
    19. 允许VLAN1,4不打标签通过 
    [Quidway-Ethernet1/0/4]port hybrid vlan 1 4 untagged  
    四、配置关键点: 
    1. 利用交换机以太网端口的Hybrid特性,可以实现PVLAN的功能。  

    2. 采用Hybrid属性实现的PVLAN功能和PVLAN的工作机制存在较大差异,上述情况只适用于网络流量,网络用户较少的应用。



    更多相关内容
  • 1 ,实验名称:二层交换机不同VLAN实现互通 (华为)2,实验环境:(1)PC1 PC2(2)二层交换机两台(3)三层交换机一台(路由功能)3,实验拓扑:2 配置步骤:(1)配置PC1:IP :192.168.10.1子网掩码:255.255.255.0网关:192...

    1 ,实验名称:二层交换机不同VLAN实现互通 (华为)

    2,实验环境:

    (1)PC1 PC2

    (2)二层交换机两台

    (3)三层交换机一台(路由功能)

    3,实验拓扑:

    2 配置步骤:

    (1)配置PC1:

    IP :192.168.10.1

    子网掩码:255.255.255.0

    网关:192.168.10.254

    (2)配置PC2

    IP :192.168.20.1

    子网掩码:255.255.255.0

    网关:192.168.20.254

    3.配置三层交换机

    注: 用户视图下输入system-view进入系统视图

    [Huawei]系统视图

    [Huawei-GigabitEthernet0/0/1]接口视图

    [Huawei]vlan 10

    [Huawei]interface vlan 10

    [Huawei-Vlanif10]ip address 192.168.10.254 255.255.255.0

    [Huawei]interface gi0/0/1

    [Huawei-GigabitEthernet0/0/1]port link-type access

    [Huawei-GigabitEthernet0/0/1]port default vlan 10

    [Huawei-GigabitEthernet0/0/1]undo shutdown

    [Huawei]vlan 20

    [Huawei]interface vlan 20

    [Huawei-Vlanif20]ip address 192.168.20.254 255.255.255.0

    [Huawei]interface gi0/0/2

    [Huawei-GigabitEthernet0/0/1]port link-type access

    [Huawei-GigabitEthernet0/0/1]port default vlan 20

    [Huawei-GigabitEthernet0/0/1]undo shutdown

    4 ,验证及测试:在PC机上进行ping命令

    5, 配置思路:

    (1)配置两台PC主机

    (2)配置三层交换机创建VLAN 10 VLAN20

    (3)验证及测试

    (4)结论:二层交换机不同VLAN实现互通

    展开全文
  • 版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。 ... 一、试验拓扑 ...PC1和PC3属于VLAN 10 ,PC2和PC四属于VLAN 20,实现不同VLAN之间的相互通讯 三、试验过程...

    版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
    本文链接:https://blog.csdn.net/weixin_39379203/article/details/90209153
     

    一、试验拓扑

    二、试验需求

    PC1和PC3属于VLAN 10 ,PC2和PC四属于VLAN 20,实现不同VLAN之间的相互通讯

    三、试验过程

    配置三层交换机SW1

    [Huawei]sysname S1
    [S1]SYS S1
    [S1]vlan b 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S1]int vlan 10
    [S1-Vlanif10]ip add 192.168.10.1 24
    [S1-Vlanif10]int vlan 20
    [S1-Vlanif20]ip add 192.168.20.1 24
    [S1-Vlanif20]int g0/0/1
    [S1-GigabitEthernet0/0/1]port link-type trunk
    [S1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20
    [S1-GigabitEthernet0/0/1]quit
    [S1]int g0/0/2
    [S1-GigabitEthernet0/0/2]port link-type trunk
    [S1-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20
    [S1-GigabitEthernet0/0/2]quit

    1、 首先,在三层交换机上新建vlan10、vlan20,然后分别为vlan10和vlan20配置IP。

    2、其次,设置g0/0/1、g0/0/2端口为trunk模式,这两trunk端口用于连接两个二层交换机,并且允许vlan10和vlan20通过。(g0/0/1为1000Mb/s告诉口,E0/0/1为10Mb/s低速口)。

    配置二层交换机SW2

    <Huawei>undo ter m
    Info: Current terminal monitor is off.
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]vlan b 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port link-type trunk
    [Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20 
    [Huawei-GigabitEthernet0/0/1]int e0/0/1
    [Huawei-Ethernet0/0/1]port link-type access
    [Huawei-Ethernet0/0/1]port default vlan 10
    [Huawei-Ethernet0/0/1]int e0/0/2
    [Huawei-Ethernet0/0/2]port link-type access
    [Huawei-Ethernet0/0/2]port default vlan 20
    [Huawei-Ethernet0/0/2]qu
    

    首先配置g0/0/1高速口为trunk模式,并且允许vlan10、vlan20的通过,该高速口用于连接三层交换机用。

    其次在二层交换机上指定e0/0/1口为access模式,并将该口划归为vlan10,用于连接PC1(连接的电脑的地址须和vlan10的地址在一个网段内);指定e0/0/2口为access模式,并将该口划归为vlan20,用于连接PC2。

    配置二层交换机SW3

    <Huawei>undo ter m
    Info: Current terminal monitor is off.
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port link-type trunk
    [Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20
    [Huawei-GigabitEthernet0/0/1]quit
    [Huawei]int e0/0/3
    [Huawei-Ethernet0/0/3]port link-type access
    [Huawei-Ethernet0/0/3]port default vlan 10
    [Huawei-Ethernet0/0/3]qu
    [Huawei]int e0/0/4
    [Huawei-Ethernet0/0/4]port link-type access
    [Huawei-Ethernet0/0/4]port default vlan 20
    [Huawei-Ethernet0/0/4]q
    

    首先配置g0/0/1高速口为trunk模式,并且允许vlan10、vlan20的通过,该高速口用于连接三层交换机用。

    其次在二层交换机上指定e0/0/3口为access模式,并将该口划归为vlan10,用于连接PC3(连接的电脑的地址须和vlan10的地址在一个网段内);指定e0/0/4口为access模式,并将该口划归为vlan20,用于连接PC4。

    配置pc

            PC1

            PC2

            PC3

            PC4

    四、测试

                   pc1 ping pc2

            pc1 ping pc3

        

            pc1 ping pc4

    试验成功,实现VLAN间通讯还可以通过路由器接口的下的子接口实现以及通过单臂路由实现。

    展开全文
  • 1.只使用Vlan的trunk接口和access接口实现两个二层交换机上属于不同Vlan的PC互通 port trunk pvid vlan 10 提前配置好IP地址及端口地址 LSW10配置: # sysname LSW10 # vlan batch 10 to 20 100 # interface ...

    实验拓扑图如下

    1.只使用Vlan的trunk接口和access接口实现两个二层交换机上属于不同Vlan的PC互通

    备注:需要使用到port trunk pvid vlan xx 等实现该功能。

    提前配置好IP地址及端口地址

    LSW10配置:

    #
    sysname LSW10
    #
    vlan batch 10 20 100
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 100
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 20
    #
    interface Ethernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 10 20 100
    #
    

    LSW11配置:

    #
    sysname LSW11
    #
    vlan batch 10 20 100
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 100
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 20
    #
    interface Ethernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 10 20 100
    #

    pc17 与 pc20 互通

     pc18 与 pc21 互通

     pc19 与 pc22 互通

    结果:pc17 与 pc20 互通, pc18 与 pc21 互通, pc19 与 pc22 互通,其它相互ping不通。

    若想让PC17ping通pc22需在LSW10接口Ethernet0/0/4上添加port trunk pvid vlan 10,

    再LSW11接口Ethernet0/0/4上添加port trunk pvid vlan 20 。

    同理:PC19ping通pc20需在LSW10接口Ethernet0/0/4上添加port trunk pvid vlan 20,

    再LSW11接口Ethernet0/0/4上添加port trunk pvid vlan 10 。

    本实验应该应用两交换机,两个pc较为准确。

    实验二:

    2. 使用hybrid的端口实现两个二层交换机上属于不同Vlan的PC互通

    提前配置好ip及端口地址 

    LSW12配置:

    #
    sysname LSW12
    #
    vlan batch 10 20
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1    //华为交换机默认port link-tyep hybrid 
     port hybrid untagged vlan 10 20
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 20
    #
    interface Ethernet0/0/3    //华为交换机默认port link-tyep hybrid 
     port hybrid pvid vlan 20
     port hybrid tagged vlan 10 20
    #
    
    

    LSW13配置:

    #
    sysname LSW13
    #
    vlan batch 10 20
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1     //华为交换机默认port link-tyep hybrid
     port hybrid untagged vlan 10 20  
    #
    interface Ethernet0/0/2
    #
    interface Ethernet0/0/3    //华为交换机默认port link-tyep hybrid
     port hybrid pvid vlan 20
     port hybrid tagged vlan 10 20
    #
    

    各pc23,pc24,pc25互ping

     

    结果: pc25可以ping通pc23,24,而pc23不能ping通pc24。

    实验三:

    3. 使用hybrid的端口实现二层交换机上属于不同Vlan的PC互通

    提前配置好端口ip地址

    LSW2配置:

    [Huawei]vlan batch 10 20 30 
    [Huawei]interface e0/0/1
    [Huawei-Ethernet0/0/1]port link-type hybrid  //华为交换机默认配置
    [Huawei-Ethernet0/0/1]port hybrid pvid vlan 10
    [Huawei-Ethernet0/0/1]port hybrid untagged vlan 10 20 30
    [Huawei-Ethernet0/0/1]quit
    [Huawei]interface e0/0/2 
    [Huawei-Ethernet0/0/2]port link-type hybrid //华为交换机默认配置
    [Huawei-Ethernet0/0/2]port hybrid pvid vlan 20
    [Huawei-Ethernet0/0/2]port hybrid untagged vlan 10 20
    [Huawei-Ethernet0/0/1]quit 
    [Huawei]interface e0/0/3
    [Huawei-Ethernet0/0/3]port link-type hybrid //华为交换机默认配置
    [Huawei-Ethernet0/0/3]port hybrid pvid vlan 30
    [Huawei-Ethernet0/0/3]port hybrid untagged vlan 10 30
    [Huawei-Ethernet0/0/3]quit

    实验结果:

    pc1可以ping通pc2和pc3,pc2和pc3不能互通。

    展开全文
  • 交换机配置 [sw1]vlan 10 [sw1-vlan10]vlan 20 [sw1-vlan20]port g1/0/2 [sw1-vlan20]vlan 10 [sw1-vlan10]port g1/0/1 [sw1-vlan10]int g1/0/3 [sw1-GigabitEthernet1/0/3]port link-type trunk [sw1-...
  • eNSP两台三层交换机不同VLAN互通

    千次阅读 2021-08-20 10:26:26
    拓扑图如上 1. PC设置IP PC15:192.168.10.10/24 网关:10.1 PC19:192.168.20.10/24 网关: 20.1 ...# vlan batch 10 20 # inter face vlanif 10 ip address 192.168.10.1 24 ip address 192.168.20.1...
  • 小白必看:三层交换机实现VLAN互通实验(图文并茂) 一.实验环境 实验需要GNS3和c2691路由器 .实验图 三.实验步骤 首先我们对sw-2进行设置。我们先添加vlan10和vlan20,操作如图。 接下来将接口分配到对应的vlan。...
  • 二层交换机vlan单臂路由的配置

    千次阅读 2019-11-26 09:46:01
    2、熟练掌握二层交换机vlan路由的定义。 3、熟练掌握二层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和二层交换机,并最终验证网络的连通性。 三、实验...
  • 二层交换机VLAN配置实验

    万次阅读 2019-05-13 21:32:34
    二层交换机VLAN配置实验 如图所示:交换机SW1的端口fa0/1 和端口fa0/2属于vlan 10的access 端口;fa0/1连接PC A,fa0/2连接PC B。交换机SW1的端口fa0/3和端口fa0/4属于vlan 20的access 端口;fa0/3连接PC D,fa0/...
  • 1. 三层交换机是带有三层路由功能的交换机,也就是这台交换机的端口既有三层路由功能,也具有二层交换功能。三层交换机端口默认为二层口,如果需要启用三层功能就需要在此端口输入no switchport命令。 2. 三层交换机...
  • 在学习华为云计算IP-SAN存储这一块时,碰到了VLAN间路由,特地再次复习 一、实验拓扑 、实验需求 PC1和PC3属于VLAN 10 ,PC2和PC四属于VLAN...1、配置三层交换机SW1 SW1: sys sys sw1 vlan b 10 20  int vla...
  • 通过三层交换机实现vlan互通

    万次阅读 2017-11-21 21:34:21
    一、配置思科2960交换机 创建vlan Switch> Switch>enable Switch#vlan database Switch(vlan)#vlan 10 name vlan10 VLAN 10 added:  Name: vlan10 Switch(vlan)#vlan 20 name vlan20 VLAN 20 added:  
  • 在华为三层交换机上进行VLAN间路由的配置,主要就是创建VLAN,端口划分,三层VLAN接口地址配置,静态路由或是RIP协议配置
  • 路由器划分VLAN,是将路由器配置为各VLAN的网关,实现VLAN间路由,也就是所说的单臂路由。 路由器配置VLAN,不能将物理端口划分到VLAN中,...第一步:在交换机上建立VLAN,并将交换机的各端口按照你的意愿划分到你所
  • 思科交换机不同vlan互通

    千次阅读 2022-01-10 15:03:37
    交换机实现不同vlan相互通信,基础网络知识
  • 华为交换机:三层交换机实现vlan间通信 实验环境介绍 一、划分vlan并将相应的接口加入VLAN swh1配置 swh2配置 swh3配置 、配置trunk并允许所有vlan通过 三、核心交换机swh4的配置 四、验证结果 实验环境介绍 一、...
  • 使用三层交换机实现不同vlan互通

    千次阅读 2018-09-29 17:29:00
    如下拓扑图所示,要实现vlan10(192.168.10.0/24)与vlan 20...三层交换机配置: 创建vlan:Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit 创建vl...
  • 二层交换机实现不同vlan通信

    千次阅读 2019-09-18 05:16:31
     实验需求:PC1属于vlan10PC2属于vlan20实现PC1与pc2互通实验拓扑: 实验过程: 第一种实现方式:sw1:vlan batch 10 20interface GigabitEthernet0/0/1port link-type accessport default vlan 10interface ...
  • 层交换机实现VLAN通信

    千次阅读 2021-03-14 21:07:43
     在这个流中的多个数据包,其中只有第一个数据包是由三层交换机的三层引擎来处理的,处理的方式是软件方式,与路由器相同,三层引擎获取了新的二层封装信息后,路由转发这个数据包。  在第一个数据包转发完成..
  • 之后在交换机1与交换机2之间vlan3不能通信,交换机2与交换机3之间vlan4不能通信。写出配置并解释 2012-12-26 12:11 上传 下载附件 (31.39 KB) 2.看下面的图,分析哪几个pc可能通信,那几个不能通信,并解释。 ...
  • 作为企业的网络管理员,您需要在三层交换机配置VLANIF接口的三层功能,使得如上所示拓扑图中的网络能够实现VLAN间通信。 操作步骤 步骤一实验环境准备 为了保证实验结果的准确性,确保设备以空配置启动。...
  • 思科三层交换机实现不同VLAN间互相访问配置案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间提供路由,为了解决这一问题,就必须增加思科路由器或思科三层交换机之类的路由设备。我们这里选择增加一...
  • 层交换机不同vlan通讯

    千次阅读 2017-01-17 11:52:21
    不同vlan,只有两层交换机,需要不同vlan通讯 可以加线…但是不可以加设备 首先分析,必须要同网段第一种方法arp解析 pc0 - f0/1 (标签sw1-vlan10),f0/3(标签sw1-vlan10广播出去) sw2vlan(标签sw2-vlan10)-pc...
  • [SW1]display current-configuration#sysname SW1#undo info-center enable#vlan batch 10 to 12 20#cluster enablentdp enablendp enable#drop illegal-mac alarm#diffserv domain default#drop-profile default#aa...
  • 交换机属于二层设备,只能通过MAC地址表进行转发且转发范围受VLAN限制 若我们想跨VLAN进行通信,通常方法有两种 利用路由器实现单臂路由 通过三层交换机的虚拟接口Vlanif进行转发,Vlanif接口编号必须与VLAN编号...
  • 1.创建二层交换机和三层交换机已经三台pc机。 2.配置pc机的ip地址和网关。 3.配置交换机,关闭路由功能,划分vlan10,20,30,查看vlan。 4.进入接口,设置接口模式,将接口添加进vlan。 5.将与三层...
  • 需求一:实现一个交换机多个不同的网段(VLAN)可以互相通信。 例如:三个网段**192.168.10. – 192.168.11. – 192.168.12.-- ** 实现3个网段互通。 第一步:设置三个VLAN #进入交换机配置界面 system-view # 简写...
  • H3C交换机VLAN间互访设置详解

    千次阅读 2020-12-19 10:52:35
    H3C交换机VLAN间互访设置详解H3C CAS云计算管理平台可以为企业...一、组网需求PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,路由器设置VLAN接口20的IP地址为20.1.1....
  • 时可以利用hybrid属性定义分属于不同的vlan的端口之间的互访,这是access和...1.先创建业务需要的vlan[SwitchA]vlan10[SwitchA]vlan20[SwitchA]vlan30[SwitchA]vlan40[SwitchA]vlan502.每个端口,都配置为hybrid状...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,874
精华内容 2,349
关键字:

二层交换机vlan互通