精华内容
下载资源
问答
  • 华为交换机 DHCP中继全局不同网段配置

    万次阅读 多人点赞 2018-07-02 17:06:02
    1、DHCP作为公司汇聚交换机,在上面配置DHCP全局地址池,然后接入交换机根据不同vlan会获取到不同网段IP地址。 2、网络拓扑 二、操作步骤 1、客户端 1)创建DHCP服务器组,并为DHCP服务器组添加DHCP服务器对应...

    一、组网需求

    1、DHCP作为公司汇聚交换机,在上面配置DHCP全局地址池,然后接入交换机根据不同vlan会获取到不同网段IP地址。

    2、网络拓扑

    二、操作步骤

    1、客户端

    1)创建DHCP服务器组,并为DHCP服务器组添加DHCP服务器对应网段的网关IP

    <Huawei>system-view 
    [Huawei]sysname Client
    [Client]dhcp server group dhcp1
    [Client-dhcp-server-group-dhcp1]dhcp-server 192.168.1.1
    [Client-dhcp-server-group-dhcp1]q
    
    [Client]dhcp server group dhcp2
    [Client-dhcp-server-group-dhcp2]dhcp-server  192.168.2.1
    [Client-dhcp-server-group-dhcp2]q

    2)创建vlan

    [Client]vlan batch 10 20

    3)使能全局DHCP功能

    [Client]dhcp enable

    4)开启vlanif中继功能并配置接口IP,指定DHCP服务器。

    [Client]interface  Vlanif 10
    [Client-Vlanif10]dhcp select relay 
    [Client-Vlanif10]ip address  192.168.1.2 24
    [Client-Vlanif10]dhcp relay server-select  dhcp1
    [Client-Vlanif10]q
    
    [Client]interface  Vlanif  20
    [Client-Vlanif20]dhcp select relay 
    [Client-Vlanif20]ip address  192.168.2.2 24
    [Client-Vlanif20]dhcp relay  server-select  dhcp2
    [Client-Vlanif20]q

    5)配置接口

    [Client]interface  GigabitEthernet  0/0/1
    [Client-GigabitEthernet0/0/1]port link-type trunk 
    [Client-GigabitEthernet0/0/1]port trunk  allow-pass vlan all 
    [Client-GigabitEthernet0/0/1]q
    
    [Client]interface  GigabitEthernet  0/0/2
    [Client-GigabitEthernet0/0/2]port link-type access  
    [Client-GigabitEthernet0/0/2]port default  vlan  10
    [Client-GigabitEthernet0/0/2]q
    
    [Client]interface  GigabitEthernet  0/0/3
    [Client-GigabitEthernet0/0/3]port link-type access  
    [Client-GigabitEthernet0/0/3]port default  vlan  20
    [Client-GigabitEthernet0/0/3]q

    2、DHCP服务器

    1)使能DHCP

    <Huawei>system-view 
    [Huawei]sysname DHCP 
    [DHCP]dhcp enable 

    2)创建vlan,配置IP地址,并让vlan接口下的客户端从全局地址池中获取IP

    [DHCP]vlan batch 10 20
    	
    [DHCP]interface  Vlanif 10
    [DHCP-Vlanif10]ip address  192.168.1.1 24
    [DHCP-Vlanif10]dhcp select global 
    [DHCP-Vlanif10]q
    
    [DHCP]interface Vlanif 20
    [DHCP-Vlanif20]ip address  192.168.2.1 24
    [DHCP-Vlanif20]dhcp select global 
    [DHCP-Vlanif20]q

    3)配置全局地址池

    [DHCP]ip pool 1
    [DHCP-ip-pool-1]network 192.168.1.0 mask  24
    [DHCP-ip-pool-1]gateway-list 192.168.1.1
    [DHCP-ip-pool-1]lease day 1
    [DHCP-ip-pool-1]q
    
    [DHCP]ip pool 2
    [DHCP-ip-pool-2]network 192.168.2.0 mask  24
    [DHCP-ip-pool-2]gateway-list  192.168.2.1 
    [DHCP-ip-pool-2]lease day 1
    [DHCP-ip-pool-2]q

    4)配置接口

    [DHCP]interface  GigabitEthernet  0/0/1
    [DHCP-GigabitEthernet0/0/1]port link-type trunk 
    [DHCP-GigabitEthernet0/0/1]port trunk allow-pass vlan  all 
    [DHCP-GigabitEthernet0/0/1]q

    3、验证

    1)PC设置自动获取IP

    2)ping测试

     

     

    展开全文
  • 交换机的配置: <Huawei>sysname SW2 [SW2]vlan batch 10 20 [SW2]interface e0/0/1 [SW2-Ethernet0/0/1]port link-type access [SW2-Ethernet0/0/1]port default vlan 10 [SW2-Ethernet0/0/1]q [SW2]...

    条件设置:eNSP版本:1.2.00.500

                       VMware  Workstation 版本:15.5.0 build-14665864

                       电脑操作系统 : Win 7 64位

                       虚拟机安装系统:windows server 2008

    本教程虚拟机安装系统过程略,搭建DHCP服务器略。

    注意:

    最近重新模拟有发现交换机ping不通虚拟机的情况,解决办法:

     1> eNSP 依赖 WinPCAP 4.1.3; 新版 Wireshark 默认安装 npcap 作为 PCAP 驱动, 必须手动卸载 npcap 后自行安装 WinPCAP 4.1.3 才可以识别主机物理&虚拟网卡;

    ​ 2> VMware 在更新重新安装后 Wireshark & WinPCAP 无法识别新虚拟网卡, 必须重新卸载 & 安装 WinPCAP 才可以识别虚拟网卡;

    第一步:设置   VMware  Workstation;

                  

         

                 

     

    第二步:安装虚拟机   略,

                  设置虚拟机网络;

                  

     

               

     

    第三步:设置DHCP服务器IP地址,并关闭防火墙;

                

               

    第四步:设置主机虚拟网卡IP地址

              

    第五步:eNSP新建拓扑图,并设置Colud;

             

             

            

    第六步:网络连接测试;

            

             设置PC1,IP地址

            

            ping 192.168.20.200(虚拟机IP地址)

            

            能ping通,才能进行下一步。

      第七步:配置交换机;

                

    <Huawei>system-view
    [Huawei]sysname SW1
    [SW1]vlan batch 10 20
    [SW1]dhcp enable
    [SW1]interface Vlanif 10
    [SW1-Vlanif10]ip address 192.168.10.254 24
    [SW1-Vlanif10]q
    [SW1]interface Vlanif 20
    [SW1-Vlanif20]ip address 192.168.20.254 24
    [SW1-Vlanif20]q
    [SW1]interface GigabitEthernet 0/0/1
    [SW1-Ethernet0/0/1]port link-type access
    [SW1-Ethernet0/0/1]port default vlan 20
    [SW1-Ethernet0/0/1]q
    [SW1]interface GigabitEthernet 0/0/2
    [SW1-Ethernet0/0/1]port link-type access
    [SW1-Ethernet0/0/1]port default vlan 10
    [SW1-Ethernet0/0/1]q
    [SW1]dhcp server group 0
    [SW1-dhcp-server-group-0]dhcp-server 192.168.20.200
    [SW1-dhcp-server-group-0]q
    [SW1]interface Vlanif 10
    [SW1-Vlanif10]dhcp select global
    [SW1-Vlanif10]dhcp select relay
    [SW1-Vlanif10]dhcp relay server-select 0

    第八步:PC1设置自动获取,并查看IP地址

    展开全文
  • 同时因为涉及到跨网段的DHCP,还需要在三层交换机上配置DHCP中继。 我是T型人小付,一位坚持终身学习的互联网从业者。喜欢我的博客欢迎在csdn上关注我,如果有问题欢迎在底下的评论区交流,谢谢。 文章目录操作...

    最近在给部门的Windows DHCP服务器配置主从热备,这里记录下操作过程以及一些坑和解决方法。同时因为涉及到跨网段的DHCP,还需要在三层交换机上配置DHCP中继。

    我是T型人小付,一位坚持终身学习的互联网从业者。喜欢我的博客欢迎在csdn上关注我,如果有问题欢迎在底下的评论区交流,谢谢。

    操作环境

    • 主DHCP(Windows server 2012 R2, 172.29.56.133)
    • 备DHCP(Windows server 2012 R2, 172.29.56.141)
    • DHCP中继三层交换机华为S6720-32C-SI-AC

    主备的两种模式

    • 热备模式(hot backup)
      这种模式下,只有主机器提供DHCP服务,同时会将分配的地址同步到备机。如果主机器发生故障,会由备机来继续提供服务。

    • 负载均衡模式(load balance)
      这种模式下,两台机器同时提供服务,按照配置的权重来决定各自有多少IP可以使用。如果有一台发生故障,另一台单独提供服务。

    如果负载不是很高,可以选择热备模式,备机的配置不用很高,应急使用即可。如果负载很高,可以选择第二种模式,两台机器协同合作。

    主从热备操作步骤

    我的操作环境是英文,但是中文系统操作应该也类似

    这里省略了配置DHCP服务的过程,基本全程下一步即可,两台机器上完全相同的操作。直接从配置作用域开始。

    在主DHCP上配置作用域

    作用域只是在主DHCP上添加,在配置完备机以后会自动同步到备机上去。

    右击IPv4,选择New Scope
    0-1-scope.png

    给这个作用域取一个名字
    0-2-name.png

    给这个域配置一个地址池供分配给用户
    0-3-pool.png

    还可以去除某些不能分配出去的ip,例如单独的DNS服务器等等
    0-4-exclude.png

    配置一个默认网关
    0-5-gateway.png

    以及DNS
    0-6-DNS.png

    然后将这个作用域激活即可。

    我这边已经创建了3个作用域,对应着3个不同的IP段。注意,如果ip地址池和DHCP不在同一网段,需要在路由器上设置DHCP中继,见下面

    给作用域配置故障转移

    如下图,主DHCP上配置了3个作用域
    1-master.png

    而在备机上没有配置任何作用域
    2-slave.png

    在主DHCP上选择一个作用域,右键选择Configure Failover
    3-failover.png

    这里配置备机的ip
    4-ip.png

    如果在这里出现权限报错,见下面的解决方法

    如果两台机器时间没有同步还会提醒你先进行时间同步
    5-time.png

    这里就可以选择上面说的两种模式了,我这里选择Hot standby。这里如果要进行消息验证还要配置一个密码。
    6-standby.png

    这样就配置完成了
    7-finish.png

    看到主DHCP的一些配置都同步到了对端,就说明成功了。如果去备机上查看应该有了该作用域和主DHCP上一样的配置。
    8-success.png

    主备配置权限报错解决

    如果你和我的环境一样,两台机器都没有加入域控当中,很有可能在上面配置备机IP那一步出现如下错误

    You do not have permissions to perform this operation on the remote DHCP server
    

    9-1-error.png

    这是因为主DHCP需要在备机上同步配置,所以需要有访问备机的权限,而在没有域控的情况下会使用当前管理员的用户名和密码去尝试访问备机。如果主备两台机器管理员用户的用户名或者密码不一样就会造成上面的报错

    按照下面的方法修改一下主DHCP机器上的管理员密码即可。

    打开控制面板,选择Change account type
    9-2-control.png

    找到Administrator用户
    9-3-user.png

    修改一下密码即可
    9-4-change.png

    交换机DHCP中继配置

    如果是跨网段去做DHCP,需要在三层交换机上的网段接口配置DHCP中继。

    还是以上面的那个网段为例:

    • DHCP网段 172.29.56.x/24
    • 待分配ip网段 172.29.62.x/24

    因为三层交换机没有直接提供DHCP功能,所以需要给172.29.62.1配置DHCP中继。下面的操作基于华为S6720

    首先配置DHCP服务器的group,并加入主备的两个ip。这里ip后面的0和1是索引号

    dhcp server group dhcp_test
    dhcp-server 172.29.56.141 0
    dhcp-server 172.29.56.133 1
    

    然后是在接口上使用这个group做为中继

    dhcp enable
    interface vlanif 100
    ip address 172.29.62.1 24
    dhcp select relay
    dhcp relay server-select dhcp_test
    quit
    
    展开全文
  • 求助:小弟菜鸟一枚,ENSP实验将S1作为dhcp服务器,S3作为dhcp中继,S1、S2、S3之间运行ospf协议,现在PC2无法获取到地址,配置如下,万分感谢sysname S1#vlan batch 10 20 30#cluster enablentdp enablendp enable#...

    求助:小弟菜鸟一枚,ENSP实验将S1作为dhcp服务器,S3作为dhcp中继,S1、S2、S3之间运行ospf协议,现在PC2无法获取到地址,配置如下,万分感谢

    sysname S1

    #

    vlan batch 10 20 30

    #

    cluster enable

    ntdp enable

    ndp enable

    #

    drop illegal-mac alarm

    #

    dhcp enable

    #

    diffserv domain default

    #

    drop-profile default

    #

    ip pool pool1

    gateway-list 10.2.1.1

    network 10.2.1.0 mask 255.255.255.0

    #

    ip pool pool2

    gateway-list 10.1.1.1

    network 10.1.1.0 mask 255.255.255.0

    #

    interface Vlanif1

    #

    interface Vlanif10

    ip address 192.168.20.1 255.255.255.0

    #

    interface Vlanif30

    ip address 10.1.1.1 255.255.255.0

    dhcp select global

    #

    interface MEth0/0/1

    #

    interface GigabitEthernet0/0/1

    port link-type access

    port default vlan 10

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 30

    #

    interface NULL0

    #

    interface LoopBack0

    ip address 172.25.195.1 255.255.255.255

    #

    ospf 1 router-id 172.25.195.1

    import-route direct

    area 0.0.0.0

    network 192.168.20.0 0.0.0.255

    network 172.25.195.1 0.0.0.0

    #sysname S2

    #

    vlan batch 10 20

    #

    cluster enable

    ntdp enable

    ndp enable

    #

    drop illegal-mac alarm

    #

    diffserv domain default

    #

    drop-profile default

    #

    interface Vlanif1

    #

    interface Vlanif10

    ip address 192.168.20.2 255.255.255.0

    #

    interface Vlanif20

    ip address 192.168.30.1 255.255.255.0

    #

    interface MEth0/0/1

    #

    interface GigabitEthernet0/0/1

    port link-type access

    port default vlan 10

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 20

    #

    interface LoopBack0

    ip address 172.25.195.2 255.255.255.255

    #

    ospf 1 router-id 172.25.195.2

    import-route direct

    area 0.0.0.0

    network 192.168.20.0 0.0.0.255

    network 192.168.30.0 0.0.0.255

    network 172.25.195.2 0.0.0.0

    #

    sysname S3

    #

    vlan batch 20 30

    #

    cluster enable

    ntdp enable

    ndp enable

    #

    drop illegal-mac alarm

    #

    dhcp enable

    #

    diffserv domain default

    #

    drop-profile default

    #

    interface Vlanif1

    #

    interface Vlanif20

    ip address 192.168.30.2 255.255.255.0

    #

    interface Vlanif30

    ip address 10.2.1.1 255.255.255.0

    dhcp select relay

    dhcp relay server-ip 10.1.1.1

    #

    interface MEth0/0/1

    #

    interface GigabitEthernet0/0/1

    port link-type access

    port default vlan 20

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 30

    #

    #

    interface LoopBack0

    ip address 172.25.195.3 255.255.255.255

    #

    ospf 1 router-id 172.25.195.3

    import-route direct

    area 0.0.0.0

    network 172.25.195.3 0.0.0.0

    network 192.168.30.0 0.0.0.255

    #

    user-interface con 0

    user-interface vty 0 4

    WWWWW.jpg

    (11.62 KB)

    2018-3-1 15:04

    分享至:

    展开全文
  • 华为 dhcp中继配置: 思路:1、配置 DHCP 客户端确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1# 创建 VLAN 10 , 20# 将相关的端口,放入到对应的 VLAN ;# 配置交换机之间的互联链路 - Trunk ;3、配置 SW2# ...
  • Software Version V200R008C00SPC500#sysname HUAWEI#vlan batch 2 to 7 100#dhcp enable#dhcp snooping enable#aaaauthentication-scheme defaultauthorization-scheme defaultaccounting-scheme defaultdomain de....
  • 配置之前,我们要值的注意的地方,不同的vlan从DHCP服务器上获的IP,我们要在交换机上使用DHCP relay也就是中继。再者就是要开启DHCPsnooping trusted端口信任,否你的DHCP包会被交换机丢弃,丢弃的意思懂吗?就...
  • DHCP Relay即DHCP中继,它是为解决服务器和...华为5700交换机dhcp配置方法请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上应用场景:用户侧网段与DHCP服务器处于不同网段SwitchA为DHCP中继的配置思路在Sw...
  • 华为ensp三层交换机DHCP中继代理配置

    千次阅读 2020-09-07 11:31:21
    三层交换机DHCP中继代理配置 使用三层交换机做DHCP的中继代理 拓扑图如图所示 R1的配置如下 sysname R1 # dhcp enable # ip pool dhcp1 gateway-list 192.168.2.1 network 192.168.2.0 mask 255.255.255.0 ...
  • 一、本节主要知识点:DHCP 中继:DHCP中继用于在DHCP服务器和客户端之间转发DHCP报文。当DHCP服务器与客户端不在同一个网段时,需要配置DHCP中继。对于DHCP客户端来说,DHCP中继就是DHCP服务器;对于DHCP服务器来说,...
  • 关于华为交换机配置教程搜集整理了一下,从基础组网,对接防火墙、多种方式的设备登录开始,一直到安全认证、故障处理,内容比较全面细致。近期更新一下,更新完了之后做一个汇总。有需要的可以关注一下。交换机在...
  • 一、网络拓扑图二、思路:将交换机作为三层交换机配置,vlan2,3的网关放在交换机上,路由器配置DHCP服务器vlan 2,3的网关上配置DHCP中继。可以实现不同VLAN通过DHCP获取不同网段的IP三、配置交换机,命令如下:...
  • 华为交换机在使用的时候,很多情况下我们需要在三层交换机上配置一下DHCP中继服务,用以为下面的客户机提供DHCP中继服务,就是说三层交换机上可以为DHCP端口转发数据到指定的DHCP服务器上;而不会因为是跨VLAN就导致...
  • f99b4cbdf76d478393de658f5c53f6ca-300x220.jpg (8.78 KB, 下载次数: 22)华为S7706交换机DHCP Server 配置不成功问题2016-6-10 14:22 上传问题描述如下图所示:S7706交换机作为DHCP服务器,S5700作为接入交换机连接...
  • system-view[Quidway] dhcp server group dhcpgroup1# 为...[Quidway-dhcp-server-group-dhcpgroup1] dhcp-server 100.10.10.1[Quidway-dhcp-server-group-dhcpgroup1] quit在VLANIF接口下使能DHCP中继功能。# 创...
  • 华为交换机DHCP中继

    2012-02-27 09:10:47
    配置DHCP中继示例 组网需求 如图1,DHCP客户端所在的网段为10.100.0.0/16,而DHCP服务器所在的网段为202.40.0.0/16。需要通过带DHCP中继功能的设备中继DHCP报文,使得DHCP客户端可以从DHCP服务器上申请到IP地址等...
  • 自己做的实验,网上找了好久没找到详细的,所以自己就传了个~共同学习!
  • 华为S2700/S3700/S5700/S9300二三层交换机配置DHCP中继DHCP中继DHCP Relay即DHCP中继,它是为解决服务器和客户端不在同一个网段而提出来的,它提供了对DHCP广播报文的透明传输功能,能够把DHCP客户端的广播报文透明...
  • 在确认需要清除DHCP中继的统计信息后,请在用户视图下执行reset dhcp relay statistics命令。使用命令display dhcp server statistics查看DHCP服务器的统计信息。使用命令display ip pool name ...
  • 文章目录前言:一、DHCP中继原理1、DHCP中继应用场景2、DHCP中继原理1、实验括扑图2、设备配置2.1、交换机配置2.2、路由器R1配置2.3、路由器R2配置2.4、路由器R3配置2.5、五台PC配置三、进行试验验证1、获取地址2、...
  • 三层交换机 = 二层交换机 + 三层路由模块1.4 疑问?问:我们学习了VLAN技术,导致不同部门vlan不能通信,今天又学习了三层交换技术实现不同VLAN间通信?请问是吃饱撑的么?为什么?答:不是吃饱撑的。 因...
  • 说明:里面有2个VLAN,一个VLAN 2一个VLAN3,用二层交换机连接,然后在连接三层交换机,三层交换机上面配置DHCP服务,一个用基于全局的方式,一个用基于接口的方式,来了解华为DHCP的配置。 1、二层交换机初始化,...
  • 关于华为交换机常用的配置方法,今天汇总一下,大家可以参考。1、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,比如vlan 2就是编号为2的vlan,只是一个...

空空如也

空空如也

1 2 3 4 5 6
收藏数 118
精华内容 47
关键字:

华为交换机dhcp中继