精华内容
下载资源
问答
  • 华为交换机配置dhcp中继
    千次阅读
    2021-11-27 20:31:10

    华为交换机配置dhcp中继
    在这里插入图片描述
    两个步骤:
    一、配置核心交换机(图中LSW1)
    (1).接口配置:

       int gig0/0/1
       port link-type access
       port default vlan 10
       
       int gig0/0/2
       port link-type access
       port default vlan 20
    
       int gig0/0/3
       port link-type access
       port default vlan 50
    

    (2).dhcp 中继配置:

    	[Sw1] dhcp enable                 //开启全局
    	[Sw1] dhcp server group yukong    //创建dhcp服务器组 yukong
    	[Sw1-dhcp-server-group-yukong] dhcp-server 10.3.50.50  //绑定服务器地址
    	
    	[Sw1]int vlan 10
    	       ip add 10.0.0.1 24
    	       dhcp select relay    //dhcp服务器选择 转发模式
               dhcp relay server-select yukong  //选择转发 dhcp的服务器
    	[Sw1]int vlan 20
    	       ip add 20.0.0.1 24
    	       dhcp select relay
               dhcp relay server-ip 10.3.50.50            //server-select 和 server-ip  都可以
    

    二、配置dhcp服务器(图中AR1)

    (1).配置dhcp地址池
    	ip pool vlan10
           gateway-list 10.0.0.1 
           network 10.0.0.0 mask 255.255.255.0 
           dns-list 114.114.114.114
        ip pool vlan20
           gateway-list 20.0.0.1 
           network 20.0.0.0 mask 255.255.255.0 
           dns-list 114.114.114.114
       
    (2).开启dhcp功能并调用
        [R1]dhcp enable
        [R1]int gig 0/0/0
              ip add 10.3.50.50 24
              dhcp select global
              
    (3).配置路由
    	ip router-static 10.0.0.0 24 10.3.50.1
    	ip router-static 20.0.0.0 24 10.3.50.1
    
    更多相关内容
  • 华为交换机DHCP配置

    千次阅读 2021-04-08 15:57:28
    华为交换机DHCP配置 设备型号:华为交换机–S3700 时间:2021.3.19 环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动...

    华为交换机DHCP配置

    设备型号:华为交换机–S3700
    时间:2021.3.19

    环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动获取网段为192.168.20.0/24的IP地址。

    拓扑:
    在这里插入图片描述

    DHCP配置:
    <Huawei>system-view -----进入配置模式

    [Huawei]dhcp enable -----开启DHCP服务

    [Huawei]vlan 10 -----创建vlan10

    [Huawei-vlan10]quit -----退出

    [Huawei]vlan 20 -----创建vlan20

    [Huawei-vlan20]quit -----退出

    [Huawei]port-group 1 -----创建端口组

    [Huawei-port-group-1]group-member Ethernet 0/0/1 to Ethernet 0/0/10 -----加入端口组成员

    [Huawei-port-group-1]port link-type access -----端口组成员配置为access

    [Huawei-port-group-1]port default vlan 10 -----端口组成员划为vlan10

    [Huawei-port-group-1]quit -----退出

    [Huawei]port-group 2 -----创建端口组

    [Huawei-port-group-2]group-member Ethernet 0/0/11 to Ethernet 0/0/20 -----加入端口组成员

    [Huawei-port-group-2]port link-type access -----端口组成员配置为access

    [Huawei-port-group-2]port default vlan 20 -----端口组成员划为vlan20

    [Huawei-port-group-2]quit -----退出

    [Huawei]ip pool 1 -----创建地址池

    [Huawei-ip-pool-1]network 192.168.10.0 mask 24 -----配置地址池

    [Huawei-ip-pool-2]gateway-list 192.168.20.1 -----配置地址池网关

    [Huawei-ip-pool-1]dns-list 114.114.114.114 -----配置地址池DNS

    [Huawei-ip-pool-1]lease day 3 -----配置地址池租约

    [Huawei-ip-pool-1]quit -----退出

    [Huawei]ip pool 2 -----创建地址池

    [Huawei-ip-pool-2]network 192.168.20.0 mask 24 -----配置地址池

    [Huawei-ip-pool-2]gateway-list 192.168.20.1 -----配置地址池网关

    [Huawei-ip-pool-2]dns-list 114.114.114.114 -----配置地址池DNS

    [Huawei-ip-pool-2]lease day 3 -----配置地址池租约

    [Huawei-ip-pool-2]quit -----退出

    [Huawei]int vlan 10 -----进入vlan10

    [Huawei-Vlanif10]ip address 192.168.10.1 255.255.255.0 -----配置vlan10IP地址

    [Huawei-Vlanif10]dhcp select global -----配置vlan10中PC从全局地址池中 获取IP地址

    [Huawei-Vlanif10]int vlan 20 -----进入vlan20

    [Huawei-Vlanif20]ip address 192.168.20.1 255.255.255.0 -----配置vlan20地址

    [Huawei-Vlanif20]dhcp select global -----配置vlan20中PC从全局地址池中 获取IP地址

    [Huawei-Vlanif20]return -----返回用户视图

    <Huawei>save -----保存

    总结:本实验用一个简单的例子,来描述如何为使用交换机配置DHCP。在本例子中演示的是为多个vlan配置DHCP,当只有一个vlan时,只用配置一个地址池就好了。

    展开全文
  • 华为交换机配置dhcp详细配置

    千次阅读 2022-05-06 17:49:34
    [Huawei]dhcp enable 开启dhcp服务 配置防止IP地址重复分配功能 dhcp snooping enable 在全局模式开启dhcp监听功能 (在可以接口配置) [Huawei] dhcp server ping packet 3 ping 3次包 [Huawei] dhcp server ping ...

    <Huawei>system-view   -- 进去配置模式
    [Huawei]dhcp enable 开启dhcp服务
    配置防止IP地址重复分配功能
    dhcp snooping enable 在全局模式开启dhcp监听功能 (在可以接口配置)
    [Huawei] dhcp server ping packet 3   ping 3次包
    [Huawei] dhcp server ping timeout 100  超时100毫秒
    Info: The operation may take a few seconds. Please wait for a moment.done. --操作可能需要几秒钟


    配置地址池
    ip pool vlan10 创建地址池名字是vlan10
     gateway-list 192.168.1.254 地址池网关
     network 192.168.1.0 mask 255.255.255.0  地址池下发网段
     static-bind ip-address 192.168.1.1 mac-address 5489-9825-19cd dhcp全局下发IP地址和Mac绑定
     excluded-ip-address 192.168.1.9 192.168.1.253 地址不下发范围
     dns-list 192.168.1.254 dns服务
    lease day 3 租期为3天


    ip pool vlan20 创建地址池名字是vlan20
     gateway-list 192.168.2.254 地址池网关
     network 192.168.2.0 mask 255.255.255.0   地址池下发网段
     static-bind ip-address 192.168.2.1 mac-address 5489-9848-51B1 dhcp下发IP地址和Mac绑定
     excluded-ip-address 192.168.2.9 192.168.2.253 地址不下发范围
     dns-list 192.168.2.254 配置dns服务
    lease day 3 租期为3天


    配置vlan 10 启用dhcp
    interface Vlanif10  配置vlan 10 IP地址
     ip address 192.168.1.254 255.255.255.0
     dhcp select global 在vlan 10 启用dhcp服务(全局选择dhcp)
    dhcp client expected-lease 259200 修改租期为3天(3天=259200 s)
    dhcp server static-bind ip-address 192.168.1.254 mac-address 5489-9825-19cd 在vlan10下配置dhcp下发IP地址和Mac绑定
    配置vlan 20 启用dhcp
    interface Vlanif20 配置vlan 20 IP地址
     ip address 192.168.2.254 255.255.255.0
     dhcp select global 在vlan 20 启用dhcp服务(全局选择dhcp)
    dhcp client expected-lease 259200 在修改租期为3天(3天=259200 s)
    dhcp server static-bind ip-address 192.168.2.254 mac-address  5489-9848-51B1 在vlan10下配置dhcp下发IP地址和Mac绑

    配置接口接入vlan

    interface GigabitEthernet0/0/1 进入接口
     port link-type access 配置acces模式
     port default vlan 10 加入vlan10 

    interface GigabitEthernet0/0/2 进入接口
     port link-type access 配置acces模式
     port default vlan 20 加入vlan20

    查看地址池ip使用情况

    dis ip pool name vlan10 used 

    回收地址
    <Huawei> reset ip pool name pool1 192.168.2.1 回收IP地址192.168.2.1
    <Huawei> reset ip pool name pool1 192.168.1.1 回收IP地址192.168.1.1
    <Huawei> reset ip pool name pool1 all //回收所有的IP地址

    关闭DHCP服务
    [Huawei] undo dhcp enable
     

    展开全文
  • 华为交换机配置DHCP

    千次阅读 2020-10-08 23:45:55
    DHCP Server配置 <Huawei>u t m <Huawei>system-view [Huawei]sysname DHCP Server [DHCP Server]vlan batch 10 20 [DHCP Server]dhcp enable [DHCP Server]ip pool vlan10 [DHCP Server-ip-pool-vlan...

    DHCP Server

    DHCP有区分全局地址池与基于接口的地址池,本篇主要介绍基于接口的DHCP配置

    网络拓扑

    在这里插入图片描述

    DHCP Server配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]sysname DHCP Server
    [DHCP Server]vlan batch 10 20
    [DHCP Server]dhcp enable
    [DHCP Server]ip pool vlan10
    [DHCP Server-ip-pool-vlan10]gateway-list 10.0.0.254
    [DHCP Server-ip-pool-vlan10]network 10.0.0.0 mask 24
    [DHCP Server-ip-pool-vlan10]excluded-ip-address 10.0.0.240 10.0.0.253  #限制IP范围
    [DHCP Server-ip-pool-vlan10]lease day 2  #有效期
    [DHCP Server-ip-pool-vlan10]dns-list 114.114.114.114
    [DHCP Server-ip-pool-vlan10]quit
    [DHCP Server]ip pool vlan20
    [DHCP Server-ip-pool-vlan20]gateway-list 10.1.1.254 
    [DHCP Server-ip-pool-vlan20]network 10.1.1.0 mask 24
    [DHCP Server-ip-pool-vlan20]excluded-ip-address 10.1.1.240 10.1.1.253
    [DHCP Server-ip-pool-vlan20]lease day 2
    [DHCP Server-ip-pool-vlan20]dns-list 114.114.114.114
    [DHCP Server-ip-pool-vlan20]quit
    [DHCP Server]interface vlanif 10
    [DHCP Server-Vlanif10]ip address 10.0.0.254 24
    [DHCP Server-Vlanif10]dhcp select global 
    [DHCP Server-Vlanif10]quit
    [DHCP Server]interface vlanif 20
    [DHCP Server-Vlanif20]ip address 10.1.1.254 24
    [DHCP Server-Vlanif20]dhcp select global 
    [DHCP Server-Vlanif20]quit
    [DHCP Server]interface g0/0/1
    [DHCP Server-GigabitEthernet0/0/1]port link-type trunk
    [DHCP Server-GigabitEthernet0/0/1]port trunk allow-pass vlan 10
    [DHCP Server-GigabitEthernet0/0/1]quit
    [DHCP Server]inter g0/0/2
    [DHCP Server-GigabitEthernet0/0/2]port link-type trunk
    [DHCP Server-GigabitEthernet0/0/2]port trunk allow-pass vlan 20
    

    sw1配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]vlan batch 10 20
    [Huawei]dhcp enable
    [Huawei]inter e0/0/1
    [Huawei-Ethernet0/0/1]port link-type trunk 
    [Huawei-Ethernet0/0/1]port trunk allow-pass vlan 10
    [Huawei-Ethernet0/0/1]quit
    [Huawei]inter e0/0/2
    [Huawei-Ethernet0/0/2]port link-type access 
    [Huawei-Ethernet0/0/2]port default vlan 10
    [Huawei-Ethernet0/0/2]quit
    

    sw2配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]dhcp enable
    [Huawei]sysname sw2
    [sw2]vlan 20
    [sw2-GigabitEthernet0/0/1]inter e0/0/1
    [sw2-Ethernet0/0/1]port link-type trunk 
    [sw2-Ethernet0/0/1]port trunk allow-pass vlan 20
    [sw2-Ethernet0/0/1]inter e0/0/2
    [sw2-Ethernet0/0/2]port link-type access 
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]quit
    [sw2]inter e0/0/2
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]quit
    

    查看客户端地址

    PC2的IP
    在这里插入图片描述
    PC3的IP

    在这里插入图片描述
    从PC2 (10.0.0.239)ping PC3(10.1.1.239)
    在这里插入图片描述
    查看地址池
    在这里插入图片描述

    展开全文
  • 华为交换机dhcp snooping 功能配置

    千次阅读 2021-01-26 21:50:43
    华为核心交换机:S5720S-36C-EI-AC 管理IP:172.30.5.1华为桌面交换机:S5700S...如下图所示:核心交换机配置:(华为交换机dhcp server配置:DHCP配置)接入层交换机配置:[SW_ACC_5.10]dhcp enable[SW_ACC_5.10]dhcp ...
  • 为什么要开启,因为可以防止其他设备如路由器接入后开启DHCP会导致合法用户获得该DHCP分配的不合法IP,从而可能不能正常上网。总之作用是屏蔽接入网络中的非法的 DHCP 服务器。即开启 DHCP Snooping 功能后,网络中的...
  • 华为交换机DHCP固定分配

    千次阅读 2020-04-12 00:08:47
    ip pool name 1 #指定要做静态分配的地址池static-bind ip-address 172.16.1.11 mac-address 0017-6110-C599 #将172.16.1.11固定分配给0017-6110-C599本文链接地址: 华为交换机DHCP固定分配...
  • 华为交换机 DHCP配置查看

    千次阅读 2012-10-25 08:44:29
    【命令】expired { day day [ hour hour ... 【视图】DHCP 地址池视图  【参数】day day:表示天数,取值范围0~365。hour hour:表示小时数,取值范围0~23。minute minute:表示分钟数,取值范围0~59。unlimite
  • 华为交换机 DHCP中继全局不同网段配置

    万次阅读 多人点赞 2018-07-02 17:06:02
    1、DHCP作为公司汇聚交换机,在上面配置DHCP全局地址池,然后接入交换机根据不同vlan会获取到不同网段IP地址。 2、网络拓扑 二、操作步骤 1、客户端 1)创建DHCP服务器组,并为DHCP服务器组添加DHCP服务器对应...
  • 华为交换机常见DHCP操作

    千次阅读 2021-10-25 21:22:29
    排除不参与自动分配的IP地址 (1)采用全局地址池时的配置 [HUAWEI] ip pool pool1 [HUAWEI-ip-pool-pool1] network 10.1.1.0 mask 24 [HUAWEI-ip-pool-pool1] gateway-list 10.1.1.1...[HUAWEI] dhcp enable [HUAWEI].
  • DHCP Relay即DHCP中继,它是为解决服务器和...华为5700交换机dhcp配置方法请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上应用场景:用户侧网段与DHCP服务器处于不同网段SwitchA为DHCP中继的配置思路在Sw...
  • 华为交换机基础DHCP配置

    万次阅读 2018-05-06 13:48:57
    配置两个地址池:192.168.1.0/24和192.168.2.0/24配置两个VLAN:10和20将...步骤:[DHCP]DHCP enable打开DHCP功能 [DHCP]vlan batch 10 20[DHCP]ip pool vlan10[DHCP]gateway-list 192.168.1.254[DHCP]network 192...
  • 华为s5700交换机配置全局地址池dhcp服务器system-view?(进入全局模式)[Huawei]sysname?SW1?(?设备命名)[SW1]dhcp?enable?(使用DHCP功能)[SW1]ip?pool?10?(创建全局地址池,同时进入全局地址池视图)[SW1-ip-pool-10]...
  • 华为设备DHCP配置命令

    千次阅读 2022-02-03 19:32:43
    华为设备DHCP配置命令
  • 1、回收已经分配出去的IP(确保这个IP不会再被分配) <Huawei> reset ip pool interface Vlanif45 192....3、进入地址池,将接口地址池中的IP地址与DHCP客户端MAC地址绑定 [Huawei] interface Vlanif 45 ...
  • 华为5700交换机DHCP基础配置案例

    千次阅读 2019-10-22 15:53:14
    华为5700交换机DHCP基础配置案例 配置两个地址池:192.168.1.0/24和192.168.2.0/24 配置两个VLAN:10和20 将四台主机分别加入VLAN 自动获取IP地址,确保全网互通。 步骤: DHCP交换机上 在DHCP交换机上...
  • 现网DHCP配置实现
  • 华为5700_dhcp配置实例

    2020-03-29 17:39:59
    华为三层交换机的 5700_dhcp配置实例,华为三层交换机DHCP配置教程,说明很详细,易懂!易学!易会!
  • 华为交换机配置DHCP服务器

    万次阅读 2018-04-28 19:42:01
    1.开启交换机DHCP服务。[huawei]dhcp enable2.配置地址池。[huawei]ip pool 8 [huawei-ip-pool-8]network 192.168.8.0 mask 255.255.255.0 [huawei-ip-pool-8]dns-list 223.5.5.5 223.6.6.6 [huawei-ip-pool-8]...
  • 华为DHCP配置以及DHCP中继

    千次阅读 2020-12-28 21:47:18
    华为 dhcp及中继配置: 思路:1、配置 DHCP 客户端确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1# 创建 VLAN 10 , 20# 将相关的端口,放入到对应的 VLAN ;# 配置交换机之间的互联链路 - Trunk ;3、配置 SW2# ...
  • [Huawei]dhcp enable [Huawei]vlan 20 [Huawei]interface Vlanif 20 [Huawei-Vlanif20]ip address 192.168.20.1 24 [Huawei-Vlanif20]dhcp select interface [Huawei-Vlanif20]dhcp server dns-list 10.19.1.3 ...
  • DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段lP地址范围,客户机登录服务器时就可以自动获得服务器分配的lP地址和子网掩码。默认情况下,DHCP作为Windows Server的一个服务组件不会被...
  • 华为交换机DHCP snooping

    千次阅读 2021-02-27 11:08:27
    配置思路1.使能DHCP Snooping功能。2.配置接口的信任状态,以保证客户端从合法的服务器获取IP地址。3.使能ARP与DHCPSnooping的联动功能,保证DHCP用户在异常下线时实时更新绑定表。...6.配置DHCP报...
  • 华为DHCP配置命令

    千次阅读 2022-04-06 09:54:58
    华为DHCP配置大全
  • 华为交换机路由器常见开局配置指导 目 录 1 如何登陆管理设备 .......................................................... 5 1.1 通过Console登录设备 .................................................. 5 1.2 ...
  • LSW5三层交换机配置: # sysname LSW5 # vlan batch 10 20 # dhcp enable # ip pool 1 gateway-list 192.168.1.254 network 192.168.1.0 mask 255.255.255.0 dns-list 8.8.8.8 # ip pool 2 gateway-list 192....
  • 华为交换机在使用的时候,很多情况下我们需要在三层交换机上配置一下DHCP中继服务,用以为下面的客户机提供DHCP中继服务,就是说三层交换机上可以为DHCP端口转发数据到指定的DHCP服务器上;而不会因为是跨VLAN就导致...
  • 交换机配置: <Huawei>sysname SW2 [SW2]vlan batch 10 20 [SW2]interface e0/0/1 [SW2-Ethernet0/0/1]port link-type access [SW2-Ethernet0/0/1]port default vlan 10 [SW2-Ethernet0/0/1]q [SW2]...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,942
精华内容 1,576
关键字:

华为交换机dhcp配置