精华内容
下载资源
问答
  • 不通VLAN 之间通信
    2017-11-10 23:32:00

     不通VLAN 之间通信

    一、任务与目的

    1. 实验任务:

    (1) 掌握和完成设置不同vlan间通过路由器互通的方法;

    (2) 完成同vlan间计算机的测试。

    2. 实验目的:

    (1) 进一步熟悉交换机vlan间互通的配置方法;

    (2) 熟悉和掌握不同vlan间互通的测试方法。

    二、原理(条件)

    1.相关知识: (1) Vlan的工作原理; (2) 交换机与路由器的配置相关命令。

    2.实验条件:(1) cisco pt软件。(2)1个路由器,1个二层交换机,4台pc。

    三、实验拓扑图

    swith0 上f0/1-12 属于VLAN 20

    swith0 上f0/13-24 属于VLAN 30

    线路连接:pc1 <---> switch f0/1

              pc2 <---> switch f0/2

              pc3 <---> switch f0/23

              pc4 <---> switch f0/24

    switch0 f0/12 <---> router0 f0/0

    switch0 f0/13 <---> router0 f0/1

    wKiom1R2mFuy0u2mAATiRngJXJI672.jpg

    四、二层交换机配置

    Switch>enable 
    Switch#vlan database 
    Switch(vlan)#vlan 20 name sys
    Switch(vlan)#vlan 30 name edit
    Switch(vlan)#exit
    Switch#configure terminal 
    Switch(config)#interface range fastEthernet 0/1-12 
    Switch(config-if-range)#switchport mode access 
    Switch(config-if-range)#switchport access vlan 20
    Switch(config-if-range)#no shutdown 
    Switch(config-if-range)#exit 
    Switch(config)#interface range fastEthernet 0/13-24
    Switch(config-if-range)#switchport mode access 
    Switch(config-if-range)#switchport access vlan 30
    Switch(config-if-range)#no shutdown
    Switch(config-if-range)#end
    Switch#write memory 

    五、路由器配置

    Router>enable 
    Router#configure terminal 
    Router(config)#interface fastEthernet 0/0
    Router(config-if)#ip address 192.168.1.254 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit 
    Router(config)#interface fastEthernet 0/1
    Router(config-if)#ip address 192.168.2.254 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit 
    Router(config)#end
    Router#write memory 

    六、总结

     不同VLAN之间通信,相当于不同网段之间通信,需要通过路由选路。






          本文转自独弹古调  51CTO博客,原文链接:http://blog.51cto.com/hunkz/1583131,如需转载请自行联系原作者






    更多相关内容
  • 三层交换机有很多值得学习的地方,这里我们主要介绍三层交换机在VLAN通信中的作用,VLAN主要建立在交换机的基础上,但在没有三层交换机的情况下,如何利用路由器来解决VLAN之间通信的问题呢?本文通过实际案例进行了...
  • 通过在SW100 来创建VLAN 100 ,sw2 上创建VLAN 200,因为VLAN100和VLAN200因为业务上的关系,需要两台PC之间相互通信,保证不同VLAN之间可以互相访问。 本实验将给您详细阐述实现方法,将用到诸多交换知识点
  • 主要介绍了Docker基于macvlan实现跨主机容器通信,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友可以参考下
  • 实现不同VLAN之间通讯

    1.同一交换机,不同VLAN下的两台计算机无法Ping通

    Switch>en

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#vlan 10

    Switch(config-vlan)#vlan 20

    Switch(config-vlan)#exit

    Switch(config-if)#interface f0/1

    Switch(config-if)#switchport access vlan 10

    Switch(config-if)#exit

    Switch(config)#interface f0/2

    Switch(config-if)#switchport access vlan 20

    Switch(config-if)#end

    Switch#

    %SYS-5-CONFIG_I: Configured from console by console

    2.如何实现不同VlAN之间通讯

    使用三层交换机,在三层交换机上配置SVI接口地址,各VlAN中主机将三层交换机上相应VlAN的SVI接口地址作为本VLAN网关,数据到达三层交换机后利用路由功能转发到其他VLAN。

    1.先把两个端口划分给两个VLAN,主机配置好IP地址等
    2.配置SVI
    Switch#conf
    Switch#configure t
    Switch#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#inter
    Switch(config)#interface vlan 10
    
    Switch(config-if)#ip adde
    Switch(config-if)#ip addr
    Switch(config-if)#ip address  192.168.10.1 255.255.255.0
    Switch(config-if)#no s
    Switch(config-if)#no shu
    Switch(config-if)#no shutdown 
    
    Switch(config-if)#exit
    Switch(config)#inter
    Switch(config)#interface  vlan 20
    Switch(config-if)#ip add
    Switch(config-if)#ip address 192.168.20.1
    % Incomplete command.
    Switch(config-if)#ip address 192.168.20.1 255.255.255.0
    Switch(config-if)#no shut
    Switch(config-if)#no shutdown 
    Switch(config-if)#ip routing (对于思科要启用路由功能)
    Switch(config)#

    ping一下就能Ping通了。

    3.如图所示,两台主机能否ping通

     不能,因为端口f0/24属于本帧VLAN1,需要配置一个trunk

    Switch>en
    Switch#conf
    Switch#configure  t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#interf
    Switch(config)#interface f0/24
    Switch(config-if)#switch
    Switch(config-if)#switchport mode t
    Switch(config-if)#switchport mode trunk 
    
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
    
    Switch(config-if)#
    Switch(config-if)#no shut
    Switch(config-if)#no shutdown 
    Switch(config-if)#end 
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    

    再ping一下就通了。

     

     

    展开全文
  • VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动...
  • 因为市场部和人事部因为业务上的关系,需要两台服务器相互通信,所在还需要在3550上配置VLAN间相互通信
  • 不同之间Vlan通信

    2022-01-04 09:27:58
    vlan间路由:通过三层设备路由,使得不同vlan间可以互相通信。 仅仅允许单播通信 vlan间路由方式:1、 SVI(交换虚接口)(三层交换机) 或 2、vlanif口 单臂路由(路由器) vlan间路由:SVI :switch virtual ...

    Vlan间路由

    vlan:相当于把交换机变成一共虚拟路由器

    vlan间路由概述

    vlan间路由:通过三层设备路由,使得不同vlan间可以互相通信。
    仅仅允许单播通信
    vlan间路由方式:1、 SVI(交换虚接口)(三层交换机) 或 2、vlanif口 单臂路由(路由器)

    vlan间路由:SVI :switch virtual interface
    在这里插入图片描述
    sw1:
    vlan batch 10 20
    int g0/0/1
    port link-type access
    port default vlan 10
    int g0/0/2
    port link-type access
    port default vlan 20

    int vlanif 10 创建交换机虚拟接口vlanif 10 (SVI)
    ip add 192.168.10.1 24 配置ip地址作为vlan10网关
    int vlanif 20
    ip add 192.168.20.1 24
    注意:可以将三层交换机抽象成一台路由器,vlanif接口就是路由器的接口
    核心层交换机查看路由表转换标签值。

    两层架构 SVI配置:
    在这里插入图片描述

    sw2: 
    vlan batch 10 30 
    interface Ethernet0/0/1 
    port link-type trunk 
    port trunk allow-pass vlan 2 to 4094 
    #
    interface Ethernet0/0/2 
    port link-type access 
    port default vlan 10 
    #
    interface Ethernet0/0/3 
    port link-type access 
    port default vlan 30 
    sw3:vlan 20 
    interface Ethernet0/0/1 
    port link-type trunk 
    port trunk allow-pass vlan 2 to 4094 
    #
    interface Ethernet0/0/2 
    port link-type access 
    port default vlan 20 
    sw1: 
    vlan batch 10 20 30 
    interface Vlanif10 
    ip address 192.168.10.1 255.255.255.0 
    #
    interface Vlanif20 
    ip address 192.168.20.1 255.255.255.0 
    #
    interface Vlanif30 
    ip address 192.168.30.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1 
    port link-type trunkport trunk allow-pass vlan all 
    #
    interface GigabitEthernet0/0/2 
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    
    接入层:接pc口划分成access口,接核心交换划分成trunk口
                     vlan batch 10 20                 int  g/0/0/2
                      int g/0/0/1                          port link-type
                      port link-type  access         port  trunk  allow-passed vlan all
                      port default vlan 10
                       
    核心层:vlan  batch  10 20
                     int  vlan 10
                     ip add 1.1.1.1 24
    
    查看配置:dis  ip interface  brief
            dis  ip  routing-table(核心交换机上)
    

    vlan件路由:单臂路由(一根线和交换机相连)
    在这里插入图片描述

    交换机:划分vlan g/0/0/2,配置trunkg/0/0/1
    vlan batch  10 20          
    int g0/0/2
    port link-type  access
    port  default  vlan 10
    interface Ethernet0/0/3
    port link-type access
    port default vlan 20 
    
    int  g0/0/1
    port link-type trunk
    port  trunk  allow-pass  vlan all
    
    路由器:
    int g0/0/0.10    进入逻辑子接口
    dotlq   termination  vid  10   报文封装采用802.1Q封装,同时给报文打上tag
    ip add  192.168.10.1 24
    arp broadcast enable    开启arp广播
    
    interface Ethernet0/0/0.20 
    dot1q termination vid 20 
    ip address 192.168.20.1 255.255.255.0 
    arp broadcast enable
    

    注释:arp broadcast enable命令用来使能子接口的ARP广播功能。缺省情况下,子接口没有使能ARP广播功能。子接口不能转发广播报文,在收到广播报文后它们直接把该报文丢弃。为了允许子接口
    能转发广播报文,可以通过在子接口上执行此命令
    工作原理:当数据包进入路由器时,路由器首先根据目标地址结合自己的路由表将标签转换,然后从相应的子接口发出。
    注意:从子接口发出报文会给报文嵌入相应标签!
    在这里插入图片描述

    sw2: 
    vlan 30 
    int e0/0/1 
    port link-ty access 
    port defau vlan 30 
    int e0/0/2 
    port link-ty access 
    port defau vlan 30 
    R2: 
    ip route-static 192.168.10.0 255.255.255.0 12.1.1.1 
    ip route-static 192.168.20.0 255.255.255.0 12.1.1.1 
    #
    R1: 
    ip route-s 192.168.30.0 24 12.1.1.2 
    缺点:对于部分网络,vlan间数据传输的效率过低。
    
    展开全文
  • VLAN(Virtual Local Area Network)的中文名为“虚拟局域网”。VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。这一新兴技术主要应用于交换机和路由器中,但主流应用还是...
  • 这是三层交换机跨Vlan通信实验的Cisco Packet Tracer文件。实验包括有两个vlan,两个二层交换机,一个三层交换机。
  • VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。那么如何实现同一路由器不同vlan之间的通信?下面就详情来看看vlan配置方式了解下
  • 不同VLAN之间的通信

    2021-11-13 16:08:35
    为了实现不同VLAN间的通信,除了使用hybrid外,我们还可以使用单臂路由实现不同VLAN间的通信。当然我们也可以通过三层交换机来实现。 1、单臂路由实现不同VLAN间的通信 1.1、单臂路由的工作原理 单臂路由是指在...

    目录

    前言

    1、单臂路由实现不同VLAN间的通信

       1.1、单臂路由的工作原理

       1.2、单臂路由的配置实例

    2、三层交换机实现不同VLAN间的通信

       2.1、三层交换机的工作原理

       2.2、三层交换机的配置实例  


    目录

    前言

    1、单臂路由实现不同VLAN间的通信

       1.1、单臂路由的工作原理

       1.2、单臂路由的配置实例

    2、三层交换机实现不同VLAN间的通信

       2.1、三层交换机的工作原理

       2.2、三层交换机的配置实例  

    结语


    前言

    为了实现不同VLAN间的通信,除了使用hybrid外,我们还可以使用单臂路由实现不同VLAN间的通信。当然我们也可以通过三层交换机来实现。

    1、单臂路由实现不同VLAN间的通信

       1.1、单臂路由的工作原理

    单臂路由是指在路由器的一个接口上通过配置子接口(或"逻辑接口",并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通

       1.2、单臂路由的配置实例

    使用单臂路由技术实现不同VLAN间的通信

     

    AR1的配置:

    <Huawei>undo terminal monitor 

    <Huawei>system-view 

    [Huawei]sysname AR1

    [AR1]user-interface console 0

    [AR1-ui-console0]idle-timeout 0 0 

    [AR1]vlan batch 10 20

    [AR1]int g0/0/0.1                                 进入子接口

    [AR1-GigabitEthernet0/0/0.1]dot1q termination vid 10      配置封装协议及VLAN标签

    [AR1-GigabitEthernet0/0/0.1]ip add 192.168.10.1 24        配置IP地址

    [AR1-GigabitEthernet0/0/0.1]arp broadcast enable           开启ARP广播

    [AR1]int g0/0/0.2

    [AR1-GigabitEthernet0/0/0.1]dot1q termination vid 20

    [AR1-GigabitEthernet0/0/0.1]ip add 192.168.20.1 24

    [AR1-GigabitEthernet0/0/0.1]arp broadcast enable 

    [AR1]int g0/0/0 

    [AR1-GigabitEthernet0/0/0]un sh                                  激活接口

    LSW1的配置:

    <Huawei>undo terminal monitor          

    <Huawei>system-view                         

    [Huawei]sysname LSW1                     

    [LSW1]user-interface console 0

    [LSW1-ui-console0]idle-timeout 0 0    

    [LSW1]vlan batch 10 20                    

    [LSW1]int e0/0/1                                

    [LSW1-Ethernet0/0/1]port link-type access         

    [LSW1-Ethernet0/0/1]port default vlan 10           

    [LSW1-Ethernet0/0/1]undo shutdown               

    [LSW1-Ethernet0/0/1]int e0/0/2           

    LSW1-Ethernet0/0/2]port link-type trunk        

    [LSW1-Ethernet0/0/2]port trunk allow-pass vlan 10 20          

    [LSW1-Ethernet0/0/1]undo shutdown                

    [LSW1-Ethernet0/0/2]int g0/0/1        

    [LSW1-GigabitEthernet0/0/1]port link-type trunk      

    [LSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20   

    [LSW1-Ethernet0/0/1]undo shutdown                

    LSW2的配置:

    <Huawei>undo terminal monitor          

    <Huawei>system-view                         

    [Huawei]sysname LSW2                     

    [LSW2]user-interface console 0

    [LSW2-ui-console0]idle-timeout 0 0    

    [LSW2]vlan batch 10 20                    

    [LSW2]int e0/0/1                                

    [LSW2-Ethernet0/0/1]port link-type access         

    [LSW2-Ethernet0/0/1]port default vlan 10           

    [LSW2-Ethernet0/0/1]undo shutdown               

    [LSW2-Ethernet0/0/1]int e0/0/2           

    LSW2-Ethernet0/0/2]port link-type trunk        

    [LSW2-Ethernet0/0/2]port trunk allow-pass vlan 10 20          

    [LSW2-Ethernet0/0/1]undo shutdown                

    PC1:

     PC2:

    测试:

    PC1:

    PC2:

    2、三层交换机实现不同VLAN间的通信

       2.1、三层交换机的工作原理

    一次路由,多次交换
    一次路由:传输的第一个数据包,有三层引擎,MAC重新封装,路由转发
    多次交换:三层交换,硬件转发,基于FIB(转发数据库),邻接关系表。
    FIB包括:邻接主机和vlanid
    邻接关系表:包括邻接主机MAC地址
    通过查询FIB和邻接关系表重新封装数据中,从相应端口转发数据

       2.2、三层交换机的配置实例  

    使用三层交换技术实现不同VLAN间的通信

    LSW1的配置:

    <Huawei>undo terminal monitor          

    <Huawei>system-view                         

    [Huawei]sysname LSW1                     

    [LSW1]user-interface console 0

    [LSW1-ui-console0]idle-timeout 0 0    

    [LSW1]vlan batch 10 20 

    [LSW1]int vlan 10                                         进入虚拟接口

    [LSW1-Vlanif10]ip add 192.168.10.1 24      配置ip

    [LSW1-Vlanif10]int vlan 20

    [LSW1-Vlanif20]ip add 192.168.20.1 24

    [LSW1-Vlanif20]quit

    [LSW1]int g0/0/1

    [LSW1-GigabitEthernet0/0/1]port link-type access

    [LSW1-GigabitEthernet0/0/1]port default vlan 10

    [LSW1-GigabitEthernet0/0/1]int g0/0/2

    [LSW1-GigabitEthernet0/0/2]port link-type access

    [LSW1-GigabitEthernet0/0/2]port default vlan 20

    PC1:

    PC2:

    测试:

    PC1:

    PC2: 

    结语

    只有二层交换机,用二层交换机+路由器,通过单臂路由技术实现不同VLAN间的路由通信。

    有三层交换机,用三层交换技术实现不同VLAN的路由通信。

    展开全文
  • 最近实习,在学习cisco路由器和交换机相关知识。这篇PPT是我自己根据所学知识,并上网查阅...主要讲述了同一VLAN间数据包传输过程和不同VLAN间数据包如何传输。涉及到三层交换机相关知识。因为初学,有不足地方请指正。
  • 利用 trunk实现跨交换机VLAN通信
  • 实现VLAN通信方法

    千次阅读 2019-03-26 17:14:22
    使用路由器实现VLAN通信时,路由器与交换机的连接方式有两种。第一种通过路由器的不同物理接口与交换机上的每个VLAN分别连接。第二种通过路由器的逻辑子接口与交换机的各个VLAN连接。 1、通过路由器的不同物理...
  • 两台主机之间的通信,但是VLAN不一样,这是就需要跨vlan通信了,这个实验报告就详细的介绍了跨vlan的通信
  • 通过配置三层交换机或路由器实现VLAN间的通信,通过路由器实现vlan通信(单臂路由)在路由器与交换机的端口上配置子接口,每个子接口的IP地址是每个VLAN的网关地址(也可以理解为下一跳地址),并在子接口上封装802....
  • 跨设备VLAN通信

    千次阅读 2020-07-15 20:50:34
    在SW1上创建两个VLAN:10及20(分别将这两个VLAN分配给技术部与会计部),然后将GE0/0/1和GE0/0/2接口加入VLAN 10,那么这两个接口所连接的PC(PC1、PC2)也就加入了VLAN 10,并且它们属于同一个广播域。 将GE0/0/3加入...
  • 同一路由不同vlan通信

    2014-05-19 11:48:46
    详细配置请看http://blog.csdn.net/lihuozhiling0101/article/details/26215345 博客中有说明 哈哈
  • Macvlan工作原理: Macvlan是Linux内核支持的网络接口。要求的Linux内部版本是v3.9–3.19和4.0+;通过为物理网卡创建Macvlan子接口,允许一块物理网卡拥有多个独立的MAC地址和IP地址。虚拟出来的子接口将直接暴露在...
  • 三层交换技术就是二层交换技术加三层路由转发技术,传统的交换技术在数据链路... 了解了三层交换技术,我们下面通过交换机的VTP技术来实现不同Vlan、网络间的通信,之所以使用VTP技术主要原因在于大大减轻了我们对Vlan
  • VLAN通信的三种方法

    千次阅读 2020-08-08 14:42:44
    解决VLAN通信的三种方法: 二层交换机+一台路由器实现VLAN通信(多臂路由) 单臂路由的方式实现VLAN通信 现网中实际运用vlanif逻辑接口来实现VLAN之间通信(三层交换) 多臂路由: 优点:原理简单 缺点:当...
  • VLAN工作原理VLAN通信原理详解.doc
  • VLAN通信的两种方法

    千次阅读 2020-04-01 16:21:29
    相同VLAN内的设备可以直接进行二层通信,而不同VLAN间不能直接通信,需借助三层设备(具备路由的设备),例如:路由器、三层交换机等 一、通过子接口实现VLAN间路由 也称单臂路由 #在该场景中,路由器基于物理接口...
  • 华为hcie示例,已通过。 使用ensp打开即可。 有修改均已在示例中注明。
  • 交换实验 利用三层交换机实现不同VLAN通信 实验名称VLAN通信 实验目的通过三层交换机实现不同VLAN间互相通信理解三层交换机功能以及特点 功能描述为了隔离广播域而划分了VLAN但不同的VLAN之间需要通信本实验将...
  • 通信行业 MTK vlan配置

    2022-04-13 09:05:41
    路由器 mtk平台vlan相关配置
  • hybrid实现相同网段不同VLAN通信

    千次阅读 2020-12-01 16:32:23
    PVID实现二层VLAN通信 实验工具:华为eNSP模拟器 网络拓扑图: 实验说明:本次实验使用三台PC,三台PC配置为同一网段,划分为三个不同VLAN,通过PVID实现vlan30和vlan20能够互相通信,其余vlan不能通信。 交换机(LSW...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 39,343
精华内容 15,737
关键字:

不通vlan通信方法