精华内容
下载资源
问答
  • 思科VTP协议及其配置

    2020-11-11 14:03:54
    VTP技术: 在Trunk链路上传递同步VLAN信息的技术 ...VTP配置实例 a)VTP模式(必须) b)VTP domain(必须) c)Vtp Password (选配) d)VTP版本号 (选配) SW1配置 配置接口为trunk模式 inter

    VTP技术:

    在Trunk链路上传递同步VLAN信息的技术

    VTP模式

    a)Client
    b)Server(默认模式)
    c)Trans
    创建添加修改VLAN 同步VLAN信息 能不能转发VLAN的同步信息 vlan信息是否能存储
    Server 能 能 能 能
    Client 否 能 能 否
    Trans 能 不能 能 能

    VTP配置实例

    a)VTP模式(必须)
    b)VTP domain(必须)
    c)Vtp Password (选配)
    d)VTP版本号 (选配)
    在这里插入图片描述

    SW1配置 配置接口为trunk模式
    interface Ethernet0/0
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/3
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet1/0
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
    SW2配置 配置接口为trunk模式
    interface Ethernet0/0
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/2
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/3
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet1/0
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
    SW3配置 配置接口为trunk模式
    interface Ethernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/2
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
    SW4配置 配置接口为trunk模式
    interface Ethernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/2
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
    SW1配置
    Switch(config)#vtp domain cisco   //设置vtp域名为cisco
    Switch(config)#vtp mode server    //设置vtp模式为server
    SW2配置
    Switch(config)#vtp domain cisco   //设置vtp域名为cisco
    Switch(config)#vtp mode  client    //设置vtp模式为client 
    SW3配置
    Switch(config)#vtp domain cisco   //设置vtp域名为cisco
    Switch(config)#vtp mode client    //设置vtp模式为client 
    SW4配置
    Switch(config)#vtp domain cisco   //设置vtp域名为cisco
    Switch(config)#vtp mode client     //设置vtp模式为client 
    

    结果测试:

    在SW1上创建valn10和20
    Switch(config)#vlan 10,20
    在SW2,34上均能看到创建的valn10和20
    Switch#show vlan b       
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Et1/1, Et1/2, Et1/3
    10   VLAN0010                         active    
    20   VLAN0020                         active    
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    
    展开全文
  • 思科VTP

    2019-09-18 07:08:54
    VTP技术:在Trunk链路上传递同步VLAN信息的技术VTP模式a)Clientb)Server(默认模式)c)Trans 创建添加修改VLAN 同步VLAN信息 能...不能 能 能3.VTP配置a)VTP模式(必须) b)VTP domain(必须)c)Vtp Passwor...

    VTP技术:
    在Trunk链路上传递同步VLAN信息的技术
    VTP模式
    a)Client
    b)Server(默认模式)
    c)Trans
      创建添加修改VLAN 同步VLAN信息 能不能转发VLAN的同步信息 vlan信息是否能存储
    Server 能 能 能 能
    Client 否 能 能 否
    Trans 能 不能 能 能
    3.VTP配置
    a)VTP模式(必须)
    b)VTP domain(必须)
    c)Vtp Password (选配)
    d)VTP版本号 (选配)
    如果Client(客户端)的Configuration Revision(vlan数量)比Server(服务端)高,那么客户端将会把服务端的vlan刷掉(建议先改为透明模式在改为客户端)
    查看VTP命令:
    show vtp status
    show vtp password

    扩展VLAN,VLAN-POE:
    1-1001普通vlan
    1006-40 扩展vlan
    配置扩展vlan必须把vtp模式改为透明模式
    语音vlan(voice vlan)
    数据vlan (Data vlan)
    POE(Power over ethernet 以太网供电,1236传输数据)
    POE供电标准:IEEE 802.3af
    show power inline
    power inline (auto|never)
    auto:自适应
    never:不供电

    展开全文
  • 思科交换机VTP配置

    2015-04-09 12:06:09
    通常情况下,我们需要在整个园区网或者企业网中的一组的交换机中保持VLAN数据库...如果仅凭网络工程师手工配置的话是一个非常大的工作量,并且也不利于日后维护——每一次添加修改或删除VLAN都需要在所有的交换机上...

    通常情况下,我们需要在整个园区网或者企业网中的一组的交换机中保持VLAN数据库的同步,以保证所有交换机都能从数据帧中读取相关的VLAN信息进行正确的数据转发,然而对于大型网络来说,可能有成百上千台交换机,而一台交换机上都可能存在几十乃至数百个VLAN,如果仅凭网络工程师手工配置的话是一个非常大的工作量,并且也不利于日后维护——每一次添加修改或删除VLAN都需要在所有的交换机上部署。在这种情况下,我们引入了VTP(VLAN Trunking Protocol)

     

     

     

     

    配置交换机的VTP模式

    三种模式server client transparent(透明模式)

    switch(config)# vtp mode server | client | transparent

    配置VTP口令

    switch (config) # vtp password PASSWORD

    配置VTP修剪

    switch (config) # vtp pruning

    配置VTP版本

    switch (config) # vtp version 2(默认是版本1)

    查看VTP配置信息

    switch# show vtp status

    有关思科OS系统,如下配置

    switch>〔enable〕set vtp mode server 其他配置参考此模式

    在三层交换机加了一块二层档板时,命令环境改变。

    比如原来需要在全局配置模式下输入vtp命令,而此时需要在vlan database模式下输入了。

    配置方法折叠

    进入Vlan //3640配置

    Switch#vlan database

    现在可以在全局模式下直接配置

    switch(config)#

    建立VTP域

    Switch(vlan)#vtp domain name

    修改交换机vtp的模式

    Switch(vlan)#vtp{client|server|transparent}

    配置vtp密码

    Switch(vlan)#vtp password ……

    配置VTP修剪

    switch (vlan) # vtp pruning

    查看VTP运行状态

    Switch#show vtp status

    查看交换机收到和发出广告的数目

    Switch#show vtp counters

    故障排查折叠

    很多时候按照常规配置完毕后,并不能学习到VLAN信息,通过show vtp status命来查看往前设备与VTP Server角色的交换机对比,请重点排查以下点:

    SW#show vtp status

    VTP Version : 2 //VTP的版本是否一致,如果不一致需配置一下

    Configuration Revision : 0

    Maximum VLANs supported locally : 255

    Number of existing VLANs : 5

    VTP Operating Mode : Client //确认当前交换机的工作角色

    VTP Domain Name : cisco //交换机所在域是否和Server模式的交换机一致

    VTP Pruning Mode : Disabled

    VTP V2 Mode : Disabled

    VTP Traps Generation : Disabled

    MD5 digest : 0xAA 0xB9 0x0C 0xCD 0xD7 0xE8 0xA6 0xE0 //交换机密码是否与Server模式的交换机一致,如果不一致请确认后重新配置

    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

    确认以上信息一致后,再确认交换机之间的互联链路是否为Trunk模式,通过命令来查看:

    SW#show int trunk

    Port Mode Encapsulation Status Native vlan

    Fa0/1on802.1q trunking 1

    Port Vlans allowed on trunk

    Fa0/1 1-1005

    Port Vlans allowed and active in management domain

    Fa0/1 1

    Port Vlans in spanning tree forwarding state and not pruned

    Fa0/1 none

    SW#

    如果异常请用以下命令来配置:

    SW#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    SW(config)#int f0/1

    SW(config-if)#sw mo trunk

    SW(config-if)#exit

    SW(config)#

    至此,仍然不能学习到VLAN信息,请首先关闭互联的Trunk链路

    SW#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    SW(config)#int f0/1

    SW(config-if)#shutdown

    清理VTP同步计数:

    Switch#clear vtp counters

    再打开互联的Trunk链路,即可正常学习到VLAN信息。    

    转载于:https://blog.51cto.com/18125387/1630442

    展开全文
  • 思科模拟器上怎么配置交换机VTPVTP 被组织成管理域(VTP Domain),VTP 可以分为三种模式:服务器模式(Server),客户机模式(Client),透明模式,下面我们来看看配置方法
  • 思科VTP域统一管理VLAN

    2017-10-23 14:37:23
    VTP统一管理VLAN,跨交换机同一VLAN通信配置SW1SW1#SW1#vlan databaseSW1(vlan)#vtp domain benet //VTP域名Changing VTP domain name from NULL to benetSW1(vlan)#vtp server //VTP服务模式Device mode already VTP...

    baaf1b33489ca1d003c3c7c153f5ad58.png

    VTP统一管理VLAN,跨交换机同一VLAN通信

    配置SW1

    SW1#

    SW1#vlan database 

    SW1(vlan)#vtp domain benet  //VTP域名

    Changing VTP domain name from NULL to benet

    SW1(vlan)#vtp server      //VTP服务模式

    Device mode already VTP SERVER.

    SW1(vlan)#vtp password dayong  //VTP密码

    Setting device VLAN database password to dayong.

    SW1(vlan)#vlan 2   

    VLAN 2 added:

        Name: VLAN0002

    SW1(vlan)#exit

    APPLY completed.

    Exiting....

    SW1#conf t 

    Enter configuration commands, one per line.  End with CNTL/Z.

    SW1(config)#int f0/0

    SW1(config-if)#switchport mode trunk 

    SW1(config-if)#no sh

    SW1(config-if)#int f0/1

    SW1(config-if)#switchport access vlan 2

    SW1(config-if)#no sh

    SW1(config-if)#exit

    SW1(config-if)#ip add 10.10.10.10 255.255.255.0

    SW1(config-if)#no sh

    SW1(config)#do sh vlan-s br


    VLAN Name                             Status    Ports

    ---- -------------------------------- --------- -------------------------------

    1    default                           active    Fa0/2, Fa0/3, Fa0/4,                                               Fa0/5  Fa0/6, Fa0/7,                                               Fa0/8, Fa0/9  Fa0/10,                                               Fa0/11, Fa0/12, Fa0/13

                                                Fa0/14, Fa0/15

    2    VLAN0002                          active    Fa0/1

    1002 fddi-default                         active    

    1003 token-ring-default                     active    

    1004 fddinet-default                       active    

    1005 trnet-default                        active    

    SW1(config-if)#do sh ip int br

    Interface                IP-Address      OK? Method Status                Protocol

    FastEthernet0/0            unassigned      YES unset  up                    up      

    FastEthernet0/1            unassigned      YES unset  up                    up      

    FastEthernet0/2            unassigned      YES unset  up                    down    

    FastEthernet0/3            unassigned      YES unset  up                    down    

    FastEthernet0/4            unassigned      YES unset  up                    down    

    FastEthernet0/5            unassigned      YES unset  up                    down    

    FastEthernet0/6            unassigned      YES unset  up                    down    

    FastEthernet0/7            unassigned      YES unset  up                    down    

    FastEthernet0/8            unassigned      YES unset  up                    down    

    FastEthernet0/9            unassigned      YES unset  up                    down    

    FastEthernet0/10           unassigned      YES unset  up                    down    

    FastEthernet0/11           unassigned      YES unset  up                    down    

    FastEthernet0/12           unassigned      YES unset  up                    down    

    FastEthernet0/13           unassigned      YES unset  up                    down    

    FastEthernet0/14           unassigned      YES unset  up                    down    

    FastEthernet0/15           unassigned      YES unset  up                    down    

    Ethernet1/0              unassigned      YES unset  administratively down down    

    Ethernet1/1              unassigned      YES unset  administratively down down    

    Ethernet1/2              unassigned      YES unset  administratively down down    

    Ethernet1/3              unassigned      YES unset  administratively down down    

    Vlan1                  unassigned      YES unset  up                    up      

    Vlan2                  10.10.10.10      YES manual up                    up      

    SW1(config-if)#do sh vtp st      显示vtp状态信息

    VTP Version                     : 2

    Configuration Revision              : 1

    Maximum VLANs supported locally        : 256

    Number of existing VLANs             : 6

    VTP Operating Mode                 : Server

    VTP Domain Name                   : benet

    VTP Pruning Mode                  : Disabled

    VTP V2 Mode                      : Disabled

    VTP Traps Generation                : Disabled

    MD5 digest                      : 0x02 0x1E 0x53 0xC7 0x7D 0x02 0xC0 0xD4 

    Configuration last modified by 0.0.0.0 at 3-1-02 00:02:12

    配置SW2

    SW2#

    SW2#vlan database

    SW2(vlan)#vtp domain benet

    Changing VTP domain name from NULL to benet

    SW2(vlan)#vtp client             //VTP客户模式

    Setting device to VTP CLIENT mode.

    SW2(vlan)#vtp password dayong

    Setting device VLAN database password to dayong.

    SW2(vlan)#vlan 2

    VLAN 2 added:

        Name: VLAN0002

    SW2(vlan)#exit 

    In CLIENT state, no apply attempted.

    Exiting....

    SW2#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    SW2(config)#int f0/0

    SW2(config-if)#switchport mode trunk 

    SW2(config-if)#no sh 

    SW2(config-if)#int f0/1

    SW2(config-if)#switchport access vlan 2

    SW2(config-if)#no sh

    SW2#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    SW2(config)#int vlan 2

    SW2(config-if)#ip add 10.10.10.10 255.255.255.0

    SW2(config-if)#no sh 

    SW2#sh vlan-s br          //显示vlan摘要信息


    VLAN Name                             Status    Ports

    ---- -------------------------------- --------- -------------------------------

    1    default                          active    Fa0/2, Fa0/3, Fa0/4, 

                                               Fa0/5,Fa0/6, Fa0/7,                                                Fa0/8, Fa0/9,Fa0/10,                                              Fa0/11, Fa0/12, Fa0/13

                                               Fa0/14, Fa0/15

    2    VLAN0002                          active    Fa0/1

    1002 fddi-default                        active    

    1003 token-ring-default                    active    

    1004 fddinet-default                      active    

    1005 trnet-default                        active    

    SW2(config-if)#do sh ip int br                

    Interface                IP-Address      OK? Method Status                Protocol

    FastEthernet0/0            unassigned      YES unset  up                    up      

    FastEthernet0/1            unassigned      YES unset  up                    up      

    FastEthernet0/2            unassigned      YES unset  up                    down    

    FastEthernet0/3            unassigned      YES unset  up                    down    

    FastEthernet0/4            unassigned      YES unset  up                    down    

    FastEthernet0/5            unassigned      YES unset  up                    down    

    FastEthernet0/6            unassigned      YES unset  up                    down    

    FastEthernet0/7            unassigned      YES unset  up                    down    

    FastEthernet0/8            unassigned      YES unset  up                    down    

    FastEthernet0/9            unassigned      YES unset  up                    down    

    FastEthernet0/10           unassigned      YES unset  up                    down    

    FastEthernet0/11           unassigned      YES unset  up                    down    

    FastEthernet0/12           unassigned      YES unset  up                    down    

    FastEthernet0/13           unassigned      YES unset  up                    down    

    FastEthernet0/14           unassigned      YES unset  up                    down    

    FastEthernet0/15           unassigned      YES unset  up                    down    

    Ethernet1/0              unassigned      YES unset  administratively down down    

    Ethernet1/1              unassigned      YES unset  administratively down down    

    Vlan2                  10.10.10.10      YES manual up              up  

    SW2#sh vtp s

    VTP Version                   : 2

    Configuration Revision            : 1

    Maximum VLANs supported locally      : 256

    Number of existing VLANs           : 6

    VTP Operating Mode               : Client

    VTP Domain Name                 : benet

    VTP Pruning Mode                : Disabled

    VTP V2 Mode                    : Disabled

    VTP Traps Generation              : Disabled

    MD5 digest                      : 0x02 0x1E 0x53 0xC7 0x7D 0x02 0xC0 0xD4 

    Configuration last modified by 0.0.0.0 at 3-1-02 00:02:12   

    f27e91a8075bb4f374c640894c674e39.png



    转载于:https://blog.51cto.com/guochenyong/1975232

    展开全文
  • VTP配置

    2019-07-26 23:38:07
    学习思科私有协议VTP配置方法,观察VTP三种工作模式的通信方式 【知识点】 VTP的工作原理,VTP的工作模式 【实验场景】 三台交换机串联,其中一个作为sever模式,通过VLAN配置信息,一个作为transparent模式,一个...
  • 我们会需要这样一个问题,一个三层网络基本结构,有很多的交换机,而基本上每个交换机上面都需要配置相同的VLAN进行互通,在VLAN很多的情况下,这样的工作量是非常大的,那么就延伸出今天所说的VTP协议(这是思科的...
  • VTP+单臂路由+动态路由配置R1R1#R1#conf tEnter configuration commands, one per line. End with CNTL/Z.R1(config)#int e0/1R1(config-if)#no shR1(config-if)#int e0/1.1R1(config-subif)#encapsulation dot1Q .....
  • CISCO交换机 VTP配置

    千次阅读 2019-01-23 16:13:06
    VTP配置 VTP协议 VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP ...
  • VTP简单介绍介: 一般来说,在大型的企业中,交换机的数量非常...为了配置与管理方便,实现在单个控制点上管理整个网络,Cisco公司开发了VTP(VLAN Trunk protocol)——虚拟局域网中继协议,通过使用VTP协议,交换...
  • 一、配置交换机vtp SW1: SW1>enable SW1#config t Enter configuration commands, one per line. End with CNTL/Z. SW1(config)#hostname SW1 SW1(config)#vlan 10 SW1(config-vlan)#exit SW1(config)#vlan 20 ...
  • 思科VTP

    2018-05-10 14:46:00
     使用VTP,能使配置在一个或多个交换机上被改变时,那些改变会自动传送给在同一个VTP域中的其他交换机。 2.VTP模式:  服务器模式(Server),客户机模式(Client),透明模式。 3.实验:  拓扑图:     s1 ...
  • 思科Cisco 交换机 VTP负载均衡的配置

    千次阅读 2015-07-07 19:09:05
    思科Cisco 交换机 VTP负载均衡的配置 3560三层交换机配置: int ran fa0/23 - fa0/24 sw trunk encapsolution dot1q sw mode trunk exit vlan 10 vlan 20 vlan 30 int vlan 10 ip address 172.16....
  • 基础的VTP配置

    2009-12-14 16:31:28
    VLAN中继协议(Vlan Trunk Protocol,VTP),思科私有协议。 作用:十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置VTP Server, 其余交换机配置VTP Client,这样他们可以自动学习...
  • 功能:1.router 2901作为DHCP服务器 2.sw1核心交换机作为vtp的server。 3.vlan10 agent ,vlan20 backoffice ,vlan30 admsw1: interfacegigabitEthernet0/2 switchporttrunkenca...
  • 思科交换机:vtp协议

    2020-10-30 20:30:14
    作用十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置VTP Server, 其余交换机配置VTP Client,这样他们可以自动学习到server 上的VLAN 信息,若考虑安全因素可将接入层交换机配为...
  • 文章目录思科期末实验考试IP地址划分静态路由RIP配置(路由器)OSPF配置HTTP服务器配置DNS配置FTP(交换机备份)TFTP(路由器备份)vtp配置路由登陆密码telnet配置(交换机 / 路由器) IP地址划分 指定网管 划分...
  • vtp配置

    千次阅读 2014-05-12 21:57:48
     1.配置VTP服务器 ...//设置该交换机为VTP服务器模式,考试时选默认是透明模式,但思科是默认为服务器模式。 S1(vlan)#vtp domain domain-name  //设置VTP管理域名称 S1(vlan)#vtp pruning  /
  • 思科 交换机的vtp模式

    2020-01-23 21:37:17
    实验目的 ·了解vtp模式的作用:快速的建立和修改VLAN使他们保持同样的...第二步:配置交换机vtp三种模式 SW0: 设置成域名为A,服务器模式(server) SW1:设置成域名为A,客户机(client) SW2:设置成域名为A,透...
  • 交换机vtp功能配置

    2020-04-08 18:33:26
    思科的交换机上,可以通过vtp功能的配置,来减少管理员的重复操作。 那么,如何来实现这一过程呢? 第一步,我们需要用一个交换机来用作标杆,也就是把这个交换机设置为服务端模式:server模式 在服务交换机上: ...
  • 这篇文章介绍的是使用思科模拟器理解VLAN Trunk VTP协议及配置,需要解决的问题: 1.根据拓扑图进行物理连接,清除交换机的原有配置并重新启动。 2.在Cisco 3560和2960上分别用两种不同的方法创建3个VLAN:VLAN 10...
  • 深入学习思科VTP的功能与配置,学会通过VTP简化VLAN配置、优化VLAN流量。
  • VTP基本配置

    2016-04-20 16:57:33
    VTPVTP(VLAN中继协议/虚拟局域网干道协议 VLAN Trunking Protocol),它是思科私有协议。在稍微大型一点的网络中,会有多个交换机,同时也会有多个VLAN,如果在每个交换机上分别把VLAN创建一遍,这会是一个工作量很大...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 158
精华内容 63
关键字:

思科vtp配置