精华内容
下载资源
问答
  • 华为 PPPoE

    千次阅读 多人点赞 2020-09-15 13:57:38
    文章目录一、PPPoE会话建立过程二、PPPoE协议报文三、拓扑四、配置全局地址池pool五、配置用于PPPOE认证的方式及认证用户六、PPPOE-Client客户端配置 PPPoE协议通过在以太网上提供点到点的连接,建立PPP会话,使得...

    PPPoE协议通过在以太网上提供点到点的连接,建立PPP会话,使得以太网中的主机能够连接到远端的宽带接入服务器上。PPPoE具有适用范围广、安全性高、计费方便等特点。

    一、PPPoE会话建立过程

    分三个阶段: ① 发现阶段;② 会话阶段;③ 会话终结阶段。

    发现阶段: 获取对方以太网地址,以及确定唯一的PPPoE会话。

    会话阶段: 包含两部分:PPP协商阶段和PPP报文传输阶段。

    会话终结阶段: 会话建立以后的任意时刻,发送报文结束PPPoE会话

    二、PPPoE协议报文

    PADI: PPPoE发现初始报文
    PADO: PPPoE发现提供报文
    PADR: PPPoE发现请求报文
    PADS: PPPoE发现会话确认报文
    PADT: PPPoE发现终止报文

    三、拓扑

    在这里插入图片描述

    四、配置全局地址池pool

    [AR-1] ip pool a    //创建用于给PPPOE客户端协商配置地址的地址池
    [AR-1-ip-pool-a] network 192.168.10.0 mask 255.255.255.0
    [AR-1-ip-pool-a] gateway-list 192.168.10.1
    [AR-1-ip-pool-a] quit
    

    五、配置用于PPPOE认证的方式及认证用户

    基于本地AAA的PPPOE认证

    1、使用默认的认证domain(域),即PPPOE认证用户和设备管理认证采用默认的认证策略

    [AR-1-aaa]local-user hcia password cipher 1008611  //创建认证用户为hcia,密码1008611
    [AR-1-aaa]local-user hcia service-type ppp         //指定此认证用户专属为PPP认证服务,不能用户其他认证
    [AR-1-aaa]quit 
    

    2、创建专属认证domain,配置专属的认证授权方式与策略

    (1)制定认证策略
    (2)制定授权策略
    (3)创建认证域—将认证与授权策略组合
    (4)创建认证域关联的用户

    [AR-1]aaa 		
    [AR-1-aaa]authentication-scheme rz                                  //创建名称为“rz”的认证策略
    [AR-1-aaa-authen-rz]authentication-mode loca                        //此认证策略采用本地认证的方式
    [AR-1-aaa-authen-rz]quit 
    [AR-1-aaa]authorization-scheme sq                                   //创建名称为“sq”的授权策略
    [AR-1-aaa-author-sq]authorization-mode local                        //此授权策略采用本地授权的方式
    [AR-1-aaa-author-sq]quit 
    [AR-1-aaa]domain local                                              //创建名称为loacl的认证域
    [AR-1-aaa-domain-local]authorization-scheme sq                      //关联名称为“sq”的授权策略
    [AR-1-aaa-domain-local]authentication-scheme rz                     //关联名称为“rz”的认证策略
    [AR-1-aaa-domain-local]quit 
    [Client-aaa]local-user hcia-1@local password cipher 1008611 	
    [Client-aaa]local-user hcia-1@local service-type ppp 
    [Client-aaa]quit	
    [Client]interface Virtual-Template 1                                //创建并进入虚拟接口配置模板 
    [Client-Virtual-Template1]ip add 192.168.2.1 24                     //配置次虚拟接口的ip地址为192.168.2.1
    [Client-Virtual-Template1]ppp authentication-mode chap domain local //配置当进行ppp协商认证采用本设备的名称为local域下的认证策略与用户 
    [Client-Virtual-Template1]remote address pool ccc                   //ppp协商用户的地址从本地名称为ccc的地址池里下发
    [Client-Virtual-Template1]ppp ipcp dns 114.114.114.114              //向ppp协商通过的用户下发dns地址为114.114.114.114
    [Client-Virtual-Template1]quit 
    [Client]int G0/0/2
    [Client-GigabitEthernet0/0/2]pppoe-server bind virtual-template 1   //虚拟接口模板1与本接口的pppoe-sever进程绑定	
    [Client-GigabitEthernet0/0/2]quit 
    

    六、PPPOE-Client客户端配置

    1、设定拨号规则

    [AR-1]dialer-rule                //进入拨号规则编辑器
    [AR-1-Dialer1]dialer-rule 1 ip   //设定拨号规则1 所有ip流量都可以触发拨号	
    [[AR-1-Dialer1]quit 
    

    2、创建拨号器

    [AR-1]int Dialer 1                             //创建虚拟拨号进程1
    [AR-1-Dialer1]dialer user ar-1                 //指定对端设备用户名(本地有效,必须配置)
    [AR-1-Dialer1]dialer bundle 1                  //此拨号器绑定拨号策略编号1
    [AR-1-Dialer1]dialer-group 1                   //此拨号器划归进拨号编组1
    [AR-1-Dialer1]link-protocol ppp                //指定此拨号器的链路层协议为ppp协议(默认为ppp协议)
    [AR-1-Dialer1]ppp chap user hcie               //设定用户ppp协商的用户名为hcie
    [AR-1-Dialer1]ppp chap password cipher 1008611 //设定用户ppp协商的密码为1008611 
    [AR-1-Dialer1]ip address ppp-negotiate         //设定ppp协商完成后IP地址的获得通过协商获得
    [AR-1-Dialer1]quit 
    

    3、挂接拨号器

    [AR-1]int G0/0/2
    [AR-1-GigabitEthernet0/0/2]pppoe-client dial-bundle-number 1  //本物理接口的pppoe的客户端进程与虚拟拨号组1绑定
    [AR-1-GigabitEthernet0/0/2]quit 
    

    4、配置静态默认路由

    [AR-1]ip route-static 0.0.0.0 0.0.0.0 Dialer 1  //访问公网路由直接指定出接口为dialer 1发出
    

    5、配置基于pppoe拨号的NAT

    [AR-1]int Dialer 1 
    [AR-1-Dialer1]nat outbound 2000                 //NAT也在虚拟拨号进程下完成。
    [AR-1-Dialer1]quit 
    

    在这里插入图片描述

    我是艺博东!欢迎你和我一起讨论,我们下期见。

    展开全文
  • 华为pppoe拨号配置

    千次阅读 2019-04-28 15:25:01
    server配置: [hw-server]ip pool pppoe //建立地址pool池 [hw-server-ip-pool-pppoe]network 112.1.1.0 mask 24 //定义地址池范围 [hw-server-ip-pool-pppoe]gateway-list 112.1.1.1 ...

                               

    server配置:

    [hw-server]ip pool pppoe      //建立地址pool池

    [hw-server-ip-pool-pppoe]network 112.1.1.0 mask 24      //定义地址池范围

    [hw-server-ip-pool-pppoe]gateway-list 112.1.1.1          //网关地址=pppoe server 地址

    当前pool的配置:

    [hw-server-ip-pool-pppoe]display this 
    [V200R003C00]
    #
    ip pool pppoe
     gateway-list 112.1.1.1 
     network 112.1.1.0 mask 255.255.255.0 
    #
    return
    [hw-server-ip-pool-pppoe]

    [hw-server-aaa]local-user pppoe password cipher pppoe    //创建用于pppoe-client拨入的账号密码

    [hw-server-aaa]local-user pppoe service-type ppp    //设置用于pppoe-client拨号的服务类型

    [hw-server]interface Virtual-Template 100                 //创建虚拟接口模板

    [hw-server-Virtual-Template100]ppp authentication-mode chap    //定义pppoe-client的ppp的验证方式

    [hw-server-Virtual-Template100]remote address pool pppoe        //定义为pppoe-client分配的地址池

    [hw-server-Virtual-Template100]ip address 112.1.1.1 24       //添加虚拟接口地址(等于pool网关地址)

    [hw-server]interface GigabitEthernet 0/0/0                        //进入接口

    [hw-server-GigabitEthernet0/0/0]pppoe-server bind virtual-template 100   //将虚拟接口模板绑定到物理接口(与Virtual-Template 100  一致)

    client配置:

    [hw-client]dialer-rule                     //创建拨号访问规则

    [hw-client-dialer-rule]dialer-rule 10 ip permit     //定义用于触发pppoe会话建立的流量类型,一般是ip

    [hw-client]interface Dialer 0     //创建拨号接口模板

    [hw-client-Dialer0]link-protocol ppp    //定义链路层协议类型

    [hw-client-Dialer0]ppp chap user pppoe   //配置用于chap验证的用户名

    [hw-client-Dialer0]ppp chap password cipher pppoe   //配置用于chap验证的密码

    [hw-client-Dialer0]ip address ppp-negotiate   //定义地址获取方式

    [hw-client-Dialer0]dialer user pppoe    //改命令必须配置,否则不能配置后续命令(用户名任意)

    [hw-client-Dialer0]dialer bundle 1  //定义拨号接口捆绑编号,用于绑定到物理接口

    [hw-client-Dialer0]dialer-group 10  //定义拨号访问规则 (匹配dialer-rule)

    [hw-client-Dialer0]mtu 1400   //设置mtu

    当前接口配置如下:

    [hw-client-Dialer0]display this 
    [V200R003C00]
    #
    interface Dialer0
     link-protocol ppp
     ppp chap user pppoe
     ppp chap password cipher %$%$|`6AGem[=V0~{O-{~S[;,&V)%$%$
     mtu 1400
     ip address ppp-negotiate
     dialer user pppoe
     dialer bundle 1
     dialer-group 10
    #
    return
    [hw-client-Dialer0]

    [hw-client]interface GigabitEthernet 0/0/0   //进入接口模式下

    [hw-client-GigabitEthernet0/0/0]pppoe-client dial-bundle-number 1   //将拨号接口绑定到物理接口(与dialer bundle 1 一致)

    当前接口配置信息:

    [hw-client-GigabitEthernet0/0/0]display this 
    [V200R003C00]
    #
    interface GigabitEthernet0/0/0
     pppoe-client dial-bundle-number 1 
    #
    return
    [hw-client-GigabitEthernet0/0/0]

    验证是否配置成功:

    [hw-client]display interface Dialer 0
    Dialer0 current state : UP                               //接口是UP 说明已经启动
    Line protocol current state : UP (spoofing)
    Description:HUAWEI, AR Series, Dialer0 Interface
    Route Port,The Maximum Transmit Unit is 1400, Hold timer is 10(sec)
    Internet Address is negotiated, 112.1.1.254/32   //有地址说明已经配置成功
    Link layer protocol is PPP
    LCP initial
    Physical is Dialer
    Current system time: 2019-04-28 15:17:03-08:00
        Last 300 seconds input rate 0 bits/sec, 0 packets/sec
        Last 300 seconds output rate 0 bits/sec, 0 packets/sec
        Realtime 0 seconds input rate 0 bits/sec, 0 packets/sec
        Realtime 0 seconds output rate 0 bits/sec, 0 packets/sec
        Input: 0 bytes
        Output:0 bytes
        Input bandwidth utilization  :    0%
        Output bandwidth utilization :    0%
    Bound to Dialer0:0:
    Dialer0:0 current state : UP ,
    Line protocol current state : UP

    Link layer protocol is PPP
    LCP opened, IPCP opened
    Packets statistics:
      Input packets:0,  0 bytes
      Output packets:0, 0 bytes
      FCS error packets:0
      Address error packets:0
      Control field control error packets:0


    [hw-client]

     

    查看接口信息:

    [hw-client]display ip interface brief 
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    The number of interface that is UP in Physical is 4
    The number of interface that is DOWN in Physical is 2
    The number of interface that is UP in Protocol is 3
    The number of interface that is DOWN in Protocol is 3

    Interface                         IP Address/Mask      Physical   Protocol  
    Dialer0                           112.1.1.254/32       up         up(s)     
    GigabitEthernet0/0/0              unassigned           up         down      
    GigabitEthernet0/0/1              unassigned           down       down      
    NULL0                             unassigned           up         up(s)     
    Serial1/0/0                       unassigned           up         up        
    Serial1/0/1                       unassigned           down       down      
    [hw-client]

     

     

     

     

     

     

     

     

    展开全文
  • 华为PPPoE简单实验

    千次阅读 2018-03-31 22:32:06
    一、PPPoE协议是基于C/S架构的一种网络拨号协议。分为客户端和服务器两部分,它的建立过程分为discovery和session两个阶段。本次实验的目标:掌握PPPoE拨号技术; 实验拓扑: 1、基本的IP配置如图所示; 2、...

    一、PPPoE协议是基于C/S架构的一种网络拨号协议。分为客户端和服务器两部分,它的建立过程分为discovery和session两个阶段。本次实验的目标:掌握PPPoE拨号技术;

    实验拓扑:

    1、基本的IP配置如图所示;

    2、配置虚拟模板用来承载多种同层协议:

    [pppoe-server]interface Virtual-Template1                //创建虚拟模板,编号为1
    ppp authentication-mode chap          //PPP认证为chap
    remote address pool test                    //指定使用地址池名为test

    ip address 192.168.10.1 255.255.255.0  //配置作为用户上网的网关IP

    3、创建地址池:

    ip pool test                                                             //创建地址池test
    gateway-list 192.168.10.1                                        //配置网关地址
    network 192.168.10.0 mask 255.255.255.0                //配置给用户分配的ip网段
    excluded-ip-address 192.168.10.200 192.168.10.254   //排除地址
    lease day 8 hour 0 minute 0 

    dns-list 202.104.10.150                                                 //DNS地址

    4、创建PPPoE用户:

     local-user user1 password cipher huawei123            //创建用户user1
     local-user user1 service-type ppp
     local-user user2 password cipher huawei321             //创建用户user2
     local-user user2 service-type ppp

    5、将虚拟模板接口与物理接口绑定提供服务:

    interface GigabitEthernet0/0/0

    pppoe-server bind Virtual-Template 1                    //将虚拟模板1绑定在物理接口上

    至此,服务器端的配置基本完成,如果想对PPPoE的访问流量进行控制,还可以配置ACL。

    二、实验检验:本次实验我们使用一台win7虚拟机来进行拨号到PPPoE服务器;

    同时,我们还可以切换user2用户进行登陆,密码必须与服务器端一致;

    由于水平有限,整个实验到这里就结束了,希望对大家有所帮助!!!

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    展开全文
  • 华为PPPoe拨号上网实验

    千次阅读 2018-06-16 21:53:07
    华为配置pppoe #sysname Server //配置设备名字#aaa authentication-scheme default authorization-scheme default accounting-scheme default domain default domain default_admin local-user admin ...
    华为配置pppoe
     


    #
    sysname Server //配置设备名字
    #
    aaa 
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default 
     domain default_admin 
     local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
     local-user admin service-type http
     local-user xiaoming password cipher xiaoming //配置PPPOE客户的用户名和密码
     local-user xiaoming service-type ppp //配置用户的接入类型为PPP
    #
    interface Virtual-Template0 //进入虚模板接口
     ppp authentication-mode chap //配置ppp认证的类型为chap
     remote address 100.0.0.2 //配置客户的地址
     ip address 100.0.0.1 255.255.255.255 //配置本接口的地址
    #
    interface GigabitEthernet0/0/0
     pppoe-server bind Virtual-Template 0 //将虚模板和接口关联在一起
    #




    PPPOE client 
     
    #
     sysname client
    #
    interface Dialer0 //进入拨号口
     link-protocol ppp //配置链路配置为ppp
     ppp ipcp default-route //通过IPCP自动获取默认路由
     ppp chap user xiaoming //配置ppp用户名
     ppp chap password cipher xiaoming //配置ppp密码
     ip address ppp-negotiate //地址为自动协商
     dialer user xiaoming //配置为共享拨号中心
     dialer bundle 1 //配置拨号捆绑接口为1
    #
    interface GigabitEthernet0/0/0
     pppoe-client dial-bundle-number 1 //通过拨号捆绑接口1关联本接口
    #




    测试
     
    已经获取到IP地址。


     


    获取到默认路由





    欢迎加入QQ群:792810619

    展开全文
  • 华为PPPOE的配置

    万次阅读 多人点赞 2016-07-08 22:50:44
    session 1 pppoe协议  pppoe是ppp over EthnerII的技术,将PPP报文封装进以太网中进行传输,因为ISP即需要一台设备连接多个客户终端(以太网和交换机最合适),又需要对用户进行控制,如计费、认证等(PPP协议最...
  • 华为PPPOE的配置方法

    2020-07-27 09:32:45
    PPPoE是在以太网上实现PPP封装的协议,它利用以太网将大量主机接入网络,通过一个远端接入设备连入因特网,并对接入的每一个主机实现控制、计费等功能。 与传统的接入方式相比,pppoe具有较高的性能价格比,它在包括...
  • session 1 pppoe协议 pppoe是ppp over EthnerII的技术,将PPP报文封装进以太网中进行传输,因为ISP即需要一台设备连接多个客户终端(以太网和交换机最合适),又需要对用户进行控制,如计费、认证等(PPP协议最适合),...
  • 一、 配置pppoe服务器 1.将AR2配置为pppoe服务器 <Huawei> sys Enter system view, return user view with Ctrl+Z. [Huawei]sysn SERVER [SERVER]ip pool pool1 //配置一个地址池pool1 Info: It's ...
  • 华为pppoe认证配置

    2014-05-26 13:41:03
    authentication-scheme pppoe  authentication-mode local-radius domain pppoe  authentication-scheme pppoe  accounting-scheme pppoe  radius-server group jltele  portal-server 123.173.127.35  portal...
  • 本实验主要介绍了WAN网络中的PPP/MP、IP-Trunk和PPPoE技术。希望通过完成本实验能够掌握PPP/MP的原理与配置、IP-Trunk的原理与配置以及PPPoE技术的原理与配置。
  • 公司总部通过PPPOE拨号与专线与运营商连接能够访问互联网 需求: 配置ISP的两台设备使之能够提供PPPOE拨号与专线服务 ISP的PPPOE采用动态地址池向公司提供专线服务 ISP的专线通过PPP的链路绑定向公司提供专线...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 141
精华内容 56
关键字:

华为pppoe