精华内容
下载资源
问答
  • 2022-04-16 14:12:15

    maven报错:不再支持源选项5。请使用6或更高版本

    maven报错:不再支持源选项5。请使用6或更高版本的解决方法:

    在pom.xml文件中加入该配置

    <properties>
            <!--<project.build.sourceEncoding>编码格式</project.build.sourceEncoding>-->
            <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
            <!--<maven.compiler.source>jdk版本号</maven.compiler.source>-->
            <maven.compiler.source>11</maven.compiler.source>
            <!--<maven.compiler.target>jdk版本号</maven.compiler.target>-->
            <maven.compiler.target>11</maven.compiler.target>
        </properties>
    
    更多相关内容
  • 在构建某个maven项目的时候发生了异常,遇到以下错误,理论上是由于没有指定...- [ERROR] 不再支持源选项 5。请使用 6 或更高版本。。。 - [ERROR] 不再支持目标选项 1.5。请使用 1.6 或更高版本。。。解决方案如下:

    问题描述

    在构建某个maven项目的时候发生了异常,遇到以下错误,理论上是由于没有指定JAVA版本导致的。

    • [ERROR] 不再支持源选项 5。请使用 6 或更高版本。
    • [ERROR] 不再支持目标选项 1.5。请使用 1.6 或更高版本。
    D:\software\jdk10\bin\java.exe "-Dmaven.multiModuleProjectDirectory=D:\workspace\idea with spring\cqs" "-Dmaven.home=D:\software\IntelliJ IDEA Community Edition\plugins\maven\lib\maven3" "-Dclassworlds.conf=D:\software\IntelliJ IDEA Community Edition\plugins\maven\lib\maven3\bin\m2.conf" "-javaagent:D:\software\IntelliJ IDEA Community Edition\lib\idea_rt.jar=60907:D:\software\IntelliJ IDEA Community Edition\bin" -Dfile.encoding=UTF-8 -classpath "D:\software\IntelliJ IDEA Community Edition\plugins\maven\lib\maven3\boot\plexus-classworlds-2.5.2.jar" org.codehaus.classworlds.Launcher -Didea.version=2018.2 clean compile package
    [INFO] Scanning for projects...
    [INFO]                                                                         
    [INFO] ------------------------------------------------------------------------
    [INFO] Building CertQuerySystem Maven Webapp 3.2
    [INFO] ------------------------------------------------------------------------
    Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
    Downloaded: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom (0 B at 0.0 KB/sec)
    Downloading: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/maven-metadata.xml
    Downloaded: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/maven-metadata.xml (668 B at 0.8 KB/sec)
    Downloading: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/2.3-SNAPSHOT/maven-metadata.xml
    Downloading: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/3.1-SNAPSHOT/maven-metadata.xml
    Downloading: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/3.2-SNAPSHOT/maven-metadata.xml
    Downloading: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/3.3-SNAPSHOT/maven-metadata.xml
    Downloading: http://maven.aliyun.com/nexus/content/groups/public/com/jfinal/jfinal/3.4-SNAPSHOT/maven-metadata.xml
    [INFO] 
    [INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ CertQuerySystem ---
    [INFO] Deleting D:\workspace\idea with spring\cqs\target
    [INFO] 
    [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ CertQuerySystem ---
    [INFO] Using 'UTF-8' encoding to copy filtered resources.
    [INFO] Copying 3 resources
    [INFO] 
    [INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ CertQuerySystem ---
    [INFO] Changes detected - recompiling the module!
    [INFO] Compiling 17 source files to D:\workspace\idea with spring\cqs\target\classes
    [INFO] -------------------------------------------------------------
    [ERROR] COMPILATION ERROR : 
    [INFO] -------------------------------------------------------------
    [ERROR] 不再支持源选项 5。请使用 6 或更高版本。
    [ERROR] 不再支持目标选项 1.5。请使用 1.6 或更高版本。
    [INFO] 2 errors 
    [INFO] -------------------------------------------------------------
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD FAILURE
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 7.702 s
    [INFO] Finished at: 2018-08-02T22:53:45+08:00
    [INFO] Final Memory: 13M/50M
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project CertQuerySystem: Compilation failure: Compilation failure:
    [ERROR] 不再支持源选项 5。请使用 6 或更高版本。
    [ERROR] 不再支持目标选项 1.5。请使用 1.6 或更高版本。
    [ERROR] -> [Help 1]
    [ERROR] 
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR] 
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
    
    Process finished with exit code 1
    
    

    解决方案

    pom.xml文件中增加maven编译的java.version jdk版本设置,以及maven.compiler.source 资源编译jdk版本设置和maven.compiler.target 资源构建jdk版本设置

    For JAVA6~8,一般都是1.6,1.7,1.8的写法。至于1.9用的人少,我也不知道写1.9还是9。

         <properties>
            <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
            <maven.compiler.encoding>UTF-8</maven.compiler.encoding>
            <java.version>1.8</java.version>
            <maven.compiler.source>1.8</maven.compiler.source>
            <maven.compiler.target>1.8</maven.compiler.target>
        </properties> 
    

    For JAVA≥10,例如10以上,都是直接写10,11,12,13,14的。

    <properties>
            <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
            <maven.compiler.encoding>UTF-8</maven.compiler.encoding>
            <java.version>14</java.version>
            <maven.compiler.source>14</maven.compiler.source>
            <maven.compiler.target>14</maven.compiler.target>
    </properties>
    
    展开全文
  • Settings,找到Java Compiler项,确认其中的版本是11,而不是5. 第二步,通过File->Project Structure,进入到另外一个配置页面。 首先确认Project里的版本是11. 再确认Modules里的也是11. 问题...

    我在IDEA开发时,遇到了这个问题,解决以后,就写了这篇文章来记录下解决方法,供大家参考。

    第一步,点File ->Settings,找到Java Compiler项,确认其中的版本是11,而不是5.

     

    第二步,通过File->Project Structure,进入到另外一个配置页面。

    首先确认Project里的版本是11.

    再确认Modules里的也是11.

     

    问题就解决了。

     

     

    展开全文
  • Maven [ERROR] 不再支持源选项 5。请使用 7 或更高版本 首先,我是看的尚硅谷的视频学习的Eclipse&IDEA中Maven和Git快速配置及使用。不过这个视频讲解maven比较少,没有实战演练???? 刚刚学Maven,当我点击...

    Maven [ERROR] 不再支持源选项 5。请使用 7 或更高版本

    首先,我是看的尚硅谷的视频学习的Eclipse&IDEA中Maven和Git快速配置及使用。不过这个视频讲解maven比较少,没有实战演练😂

    刚刚学Maven,当我点击test时
    在这里插入图片描述

    就出现了这两个错误:

    [ERROR] 不再支持源选项 5。请使用 7 或更高版本。
    [ERROR] 不再支持目标选项 5。请使用 7 或更高版本。
    

    后来在看到这篇文章

    原来是我看视频的时候,因为老师用的是jdk1.8,且生成了一个profile信息,而我没有去配值这个

    在这里插入图片描述

    其实在maven里的conf的setting.xml中已经写清楚了:(这里是jdk1.4了)所以如果不配可能就是默认低版本的
    在这里插入图片描述

    解决办法一 在settings.xml文件中指定jdk版本

    大家可以根据自己的jdk来配置

    <profile>  
         <id>jdk-13</id>  
         <activation>  
             <activeByDefault>true</activeByDefault>  
             <jdk>13</jdk>  
         </activation>
         <properties>
             <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
             <maven.compiler.source>13</maven.compiler.source>  
             <maven.compiler.target>13</maven.compiler.target> 
    		 <maven.compiler.compilerVersion>13</maven.compiler.compilerVersion> 
         </properties>   
    </profile>  
    

    同时也可以在idea自带的maven插件里配一下这个。

    解决办法二 在项目的pom.xml文件中指定jdk版本

    这个我就没有试了,因为我只用了一个jdk。类似这样吧:

    <properties>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
        <maven.compiler.source>13</maven.compiler.source>
        <maven.compiler.target>13</maven.compiler.target>
    </properties>
    


    最后的话,我觉得还是要补充一下。还是很建议使用jdk1.8(我后面又切换回1.8了,感觉部署到服务器什么的,用jdk1.8还是好些)。记得切换回jdk1.8后,还要改这里的maven配置。
    展开全文
  • Error:java: 不再支持源选项 5。请使用 6 或更高版本。 这里需要确保项目的以下几个地方与我们本地的java版本一致 一劳永逸的解决方法 https://blog.csdn.net/qq_42583206/article/details/108375173 ...
  • maven编译失败可能会出现【ERROR】 不再支持源选项 1.5。请使用 1.6 或更高版本。【ERROR】 不再支持目标选项 1.5。请使用 1.6 或更高版本。这是因为没有配置jdk版本号 解决方法1:在pom文件中指定jdk版本......
  • Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project blog2: Compilation failure: Compilation failure:不再支持源选项 5。请使用 7 或更高版本。这...
  • 解决第一次运行Maven时,出现“不再支持源选项 5,请使用 7 或更高版本”的问题 编译时遇到的问题 当电脑第一次使用mvn compile命令时,会先下载需要的jar文件,下载完成后,编译出现了问题如下: [ERROR] ...
  • maven 不再支持源选项5

    千次阅读 2018-11-28 17:48:09
    Maven 执行mvn -package 时提示error 百度到解决方案: 传送门 复制到配置文件中又出现了另一个错误:(我用notepad++编辑的) ...大意是不能识别的代码,应该是编码问题,所以在notepad中选择将文件转为UTF-8再...
  • 解决方案:在项目pom.xml中指定JDK版本 我的jdk版本是11.0.2 所以写的是11 根据你自己的jdk版本写 1.7/1.8~~~~ <properties>元素时根元素<project>的子元素 <properties>...project.build.source...
  • 错误: 在maven的配置文件settings.xml中对profiles标签中的属性进行配置,将其配置成本地电脑中的java版本,比如我的是java14.
  • [ERROR] 不再支持源选项 5。请使用 6 或更高版本。 [ERROR] 不再支持目标选项 1.5。请使用 1.6 或更高版本。 这个问题的原因有以下几点: 1.你的电脑中安装了多个版本的jdk,导致maven不知道该用哪个 2.没有在pom....
  • 不再支持源选项 5。请使用 6 或更高版本。 等提示。 解决方法:idea -> file ->Project Structure 。 将project内的project SDK和project language level改为你的jdk。 将Modules内的Source选项卡的...
  • jdk版本过高,原本是12.0.2版本的jdk 安装jdk1.8后解决此问题 安装后修改idea中的jdk 1. 2.上下保持一致 3. 4. 重新运行成功
  • [ERROR] 不再支持源选项 5。请使用 7 或更高版本。 [ERROR] 不再支持目标选项 5。请使用 7 或更高版本。 [INFO] 2 errors [INFO] ------------------------------------------------------------- [INFO] ------...
  • NO1.点击File--->Project Structure NO2.点击左侧栏Modules-->找到对应的language level NO3.保存以上修改,点击File-->Settings 以上操作即可解决idea报的此类错误
  • Error:java: 不再支持源选项 5 请使用 6 或更高版本 在使用别人的配置的时候老是会报这钟错误,记录一下免得每次都得去找 先试一下这个操作 再pom.xml文件添加这个 根据自己的版本号哦 记得改!! <properties&...
  • 不再支持源选项 5。请使用 6 或更高版本。 不再支持目标选项 1.5。请使用 1.6 或更高版本。 在项目pom.xml文件中增加maven编译的jdk版本设置,maven.compiler.source和maven.compiler.target: <properties...
  • 解决办法1(暂时性解决) 在pom.xml文件中添加jdk版本说明,我的jdk版本是1.8,所以添加时根据自己的jdk版本进行修改。 <properties> <project.build.sourceEncoding>UTF-8</project.build.source...
  • 我选的jdk版本是11,改成自己的版本即可。 1:修改maven的conf目录下的maven settings.xml 中的数据 2:检查idea 配置 在setting中找到 3:在maven项目pom.xml中制定jdk版本 <.../maven.
  • 报错信息如下 解决办法一 在settings.xml文件中指定jdk版本 既可以修改全局的settings.xml文件(C:\Program Files\apache-maven-3.6.0\conf\settings.xml) 也可以修改用户的settings.xml文件(~\.m2\settings....
  • 错误信息 [INFO] ------------------------------------------------------------- [ERROR] COMPILATION ERROR : [INFO] ----------------------------------------...[ERROR] 不再支持源选项 5。请使用 6 或更高版...
  • Error : java 不支持发行版本5 或者是 Error:java: 不再支持源选项 5。请使用 6 或更高版本。 实在忍受不了,这里写篇文章记录一下,不想每次都上网搜解决办法了。 (1)首先,点settings,然后找到图中目录,这里的...
  • 出现Error:java: 不再支持源选项 5。请使用 6 或更高版本。 解决方法:pom.xml中添加maven编译的jdk版本设置,maven.compiler.source和maven.compiler.target,另外java.version最好也加上 <...
  • 错误: 不再支持源选项 6。请使用 7 或更高版本
  • 在使用eclipse搭建uiautomator自动化测试环境时,碰到了ant编译报错问题:不再支持源选项 1.5,请使用 1.6 或更高版本。 网上各种查找都是maven编译错误:不再支持源选项 1.5,请使用 1.6 或更高版本。要添加JDK...
  • 报错信息如下: [ERROR] COMPILATION ERROR : [INFO] --------------------------------------------------- [ERROR] Failure executing javac, but could not parse the error: 错误: 不再支持源选项 6。...
  • 今天在maven中编译时出现如下信息 [INFO] ------------------------------------------------------------- [ERROR] COMPILATION ERROR :  [INFO] ----------------------------------------...[ERROR] 不再支持源...
  • 这里 记录下 这个问题的解决方案: 1:修改maven settings.xml 中的数据 这里的版本要对应现在使用的jdk版本 2:检查idea 配置 图中2块区域要一致 检查这块地方对应了自己的jdk版本没有 ......

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 396,336
精华内容 158,534
关键字:

不再支持源选项5