精华内容
下载资源
问答
  • 动态路由协议 RIP(路由信息协议)

    千次阅读 2019-12-02 20:08:04
    路由或拓扑 RIPV2 2、扩展配置 手工汇总—在更新源路由器上所有更新发出的接口上配置 认证 明文加密 密文认证 静默接口—只接收不发送路由协议信息,拥有同用户相连的接口 加快协议收敛速度—修改计时器 30s 180s ...

    动态路由协议 RIP(路由信息协议)

    什么是路由? 当一个路由器(或者其他三层设备)获得一个数据包,会查看数据包中的报头的IP地址,并在自己的路由表中进行查看,匹配最佳路径,最优路由,并将数据包扔给该路由的下一跳或者出接口。

    一、路由协议的分类

    1. 直连路由:路由器直连接口所在的网络,当接口的Protocol和 Physical都为UP时自动学习到路由表
    2. 静态路由:根据数据访问需要管理员手工配置路由条目
    3. 动态路由:各台路由器之间运行了一定的算法之后,相互学习沟通产生的路由条目,并且当拓扑进行变化时可以自动进行收敛。
      在这里插入图片描述

    二、动态路由协议

    动态路由协议:各台路由器之间运行了一定的算法之后,相互学习沟通产生路由条目,从而达到全网可达的目的。其本质就是算法。

    1、动态路由的优点:

    1. 配置管理方便 :路由器之间可以通过算法自动学习的方法获取未知网段。
    2. 适用于中大型网络
    3. 针对拓扑的变化可以自动重新收敛:新增或减少网段,拓扑可以自动重新收敛计算获取新的路径。
      动态路由的优点反之也是静态路由的缺点。

    2、动态路由的缺点:

    1. 安全:易被终端伪装的路由器欺骗,造成数据的不安全通信。
    2. 容易造成选路不佳:由于只是用固定的算法学习,容易在大型网络中出现数据的不同步现象,最严重的情况可能会出现环路的情况。
    3. 占用硬件资源:为保持协议之间的通信,动态路由会占用硬件的资源,严重的情况会占用满整个带宽资源,以至于上网的带宽都没有。(带宽,CPU,内存都是硬件资源)

    3、衡量动态路由协议好坏的标准:

    1. 选路佳
    2. 收敛速度快:可降低出环的概率
    3. 占用资源小

    4、动态路由的分类:

    1. 根据AS进行分类(AS为自治系统,ASN: 0-65535)
      IGP:内部网关协议,负责AS内部的沟通 IGP协议:RIP OSPF EIGRP ISIS
      EGP:外部网关协议,负责AS间的沟通 EGP协议:EGPV1 EGPV2 BGPV1~4 BGPV4+
      AS号的1~64511为公有AS号,65412 ~65535为私有AS号。
      IGP的分类-----根据更新时是否携带子网掩码:
      有类别路由协议—不携带掩码 只能是A类,B类,C类等
      无类别路由协议—携带掩码 我的掩码是多少我就是多少

    2. 根据工作特点(更新内容)
      DV型—距离矢量型路由协议 RIP EIGRP BGP
      LS型—链路状态型路由协议 OSPF ISIS

    三、RIP:路由信息协议

    1、RIP协议的基本

    RIP 路由信息协议-------标准的距离矢量型路由协议,更新时直接共享路由表,更新内容为路由条目,默认仅存在更新包,Pre为100(思科管理距离120),以跳数作为度量。基于UDP520端口工作。RIP版本有 RIPv1 RIPv2(IPV4)、RIPNG(IPV6)三个。采用异步更新的方法防止广播风暴(广播或组播),更新间隔范围25.5-30s之间。
    协议算法:贝尔曼–福特算法
    协议封装:基于UDP封装,UDP端口号,IPV4为520,IPV6为521
    跳数:经过路由器的个数
    周期更新:保活、确认 30s
    触发更新:根据拓扑的变化进行自动重新收敛
    距离矢量型路由协议:邻居之间共享路由表,通过查看对方的路由表来判断对方能到哪里,最后再写入自己的路由之中。

    2、RIPV1,RIPV2的区别

    RIPV1RIPV2
    有类别路由协议—不带掩码更新—不支持VLSM无类别路由协议—携带子网掩码—支持VLSM—支持CIDR—不支持超网
    不支持手工认证支持手工认证(邻居间的身份核实)
    使用广播地址,更新地址为255.255.255.255使用组播地址,更新地址为224.0.0.9

    3、RIP的工作原理


    最初的网络:直连网络直接写入路由表
    AR1:最开始学习到直连网段1.1.1.0/24和12.1.1.0/24,cost值都为0
    AR2:最开始学习到直连网段12.1.1.0/24和23.1.1.0/24,cost值都为0
    AR3:最开始学习到直连网段23.1.1.0/24和3.3.3.0/24,cost值都为0

    接下来:AR2将自己的路由表发给AR1和AR3,那么AR1的路由表增加23.1.1.0/24网段,cost值为1,AR3的路由表增加12.1.1.0/24网段,cost值为1。AR1同时将自己的路由表发给AR2,AR2增加1.1.1.0/24网段,cost值为1,AR3也将自己的路由表发给AR2,AR2增加3.3.3.0/24网段。,cost值为1。

    然后:AR2继续将自己的路由表发给AR1和AR3。AR1增加3.3.3.0/24网段,cost值为2,AR3增加1.1.1.0/24网段,cost值为2。

    此时,它们就有了整个拓扑的路由,也就收敛完成了。

    4、RIP的度量值

    在这里插入图片描述
    RIP以条数作为度量值,实际上是有不科学性的。例如,上图中,对于RIP来说,cost=2的路径会被选择,但是链路带宽低。而链路带宽大的却没有被RIP选择。
    在这里插入图片描述

    5、环路的产生

    在这里插入图片描述
    由于RIP的周期更新时间为30s,并且每一台路由器不是同时更新的。
    如果AR3的环路突然down了,在它自己的30s时间为0时,它将这一条消息给了AR2,这个时候AR2的时间还没有30s,即路由表中还有3.3.3.0/24网段,那么AR2就会将这个网段发给AR1和AR3,AR3中就会出现3.3.3.0/24网段,cost值为2,此时AR1也学习到3.3.3.0/24网段了,那么就会出现,AR1把3.3.3.0/24网段发给AR2,AR2给AR1和AR3,AR3又给AR2。如此的循环下去。

    6、RIP的破环机制

    1. 水平分割:从此口进不从此口出
      仅用于直线型拓扑和星型拓扑下的防环
      核心作用—消除重复更新量; MA网络中的重复更新量
      点到点:在一段网络当中只能存在两个节点
      点到多点 MA:网络中节点数量不受限制
    2. 跳数限制:最大15跳,16跳标记不可达
    3. 毒性逆转水平分割
      触发更新:当有路由器断开了某个网段时,该路由器会发送更新包,更新包中包含断开的网段和16跳的跳数,来告诉其它路由器此网段已不可达。收到的路由器作为回应需要将这条更新包再发送给发给自己的路由器,来作为确认自己收到了。这才是破环机制的核心机制。
    4. 抑制计时器
      计时器:
      更新时间30s
      失效时间180s
      抑制计时器180s,可能down掉
      刷新时间240s

    三、RIP的配置

    1、基本配置

    RIPV1
    在这里插入图片描述
    1#启动rip协议,也可直接rip,不用写1
    2#选择rip为版本1,若不进行选择,默认为版本1
    3#宣告
    Network:宣告—只支持主类网宣告
    宣告的作用:1.激活接口(使接口拥有收发更新的能力) 2.路由或拓扑

    RIPV2
    在这里插入图片描述

    2、扩展配置

    1. 手工汇总—在更新源路由器上所有更新发出的接口上配置
      在这里插入图片描述

    2. 认证
      明文加密
      在这里插入图片描述
      密文认证
      在这里插入图片描述

    3. 静默接口—只接收不发送路由协议信息,拥有同用户相连的接口
      在这里插入图片描述

    4. 加快协议收敛速度—修改计时器 30s 180s 180s
      修改时建议维持原有的倍数关系,且不易修改的过小
      在这里插入图片描述

    5. 缺省路由—边界路由器上配置
      在这里插入图片描述
      注:此时边界路由器还需要静态缺省指向ISP

    6. V1和V2兼容问题
      规则:默认版本1仅收发V1信息,版本收发V2信息,升级版本1,收1/2发1;
      在这里插入图片描述
      在这里插入图片描述

    7. 控制RIP选路–偏移列表–在控制层面更新进出的接口上,人为加大度量;可以叠加
      在这里插入图片描述

    8. RIPV1连续子网问题
      RIPV1可以在连续性子网环境下正常工作;若未实现连续子网环境,可以使用第二地址
      在这里插入图片描述

    展开全文
  • 路由信息协议是基于距离向量的路由协议,通常利用跳数来作为计量标准,是一种内部网关协议,是使用范围最广泛的路由协议,在网关与主机之间交换路由选择信息的标准,而RIP 是一种内部网关协议
  • RIP----路由信息协议

    千次阅读 2019-01-09 15:15:10
    一、RIP版本以及区别 组播相对广播的好处: 1、广播:同一网段内所有的主机都需要接收(相当于目的地址是所有的主机/接口)...按固定的时间间隔交换路由信息,例如,每隔 30 秒。 RIP 协议中的“距离”也称为“...

    一、RIP版本以及区别

    组播相对广播的好处:

    1、广播:同一网段内所有的主机都需要接收(相当于目的地址是所有的主机/接口);

    2、组播:只有运行RIP的主机(接口)才接收;节省了带宽,提升了效率;

    二、RIP特点

    仅和相邻路由器交换信息。
    交换的信息是当前本路由器所知道的全部信息,即自己的路由表。
    按固定的时间间隔交换路由信息,例如,每隔 30 秒。
    RIP 协议中的“距离”也称为“跳数”(hopcount),因为每经过一个路由器,数就加 1。

    三、RIP工作原理

    1、rip是一个存在于在路由器中的进程;处于udp协议之上,所接受的路由信息封装在UDP协议的数据报中,RIP在520号UDP端口上接受邻居路由器的路由信息。

    2、rip协议主要负责从网络系统中,其他路由器接收路由信息,来进行维护更新本地ip层路由表。同时还负责将本地的路由信息,通知相邻路由器作相应的修改。

    3、每个启动(假设A)RIP协议的端口以广播/单播为目标地址,发送请求报文(RIP request message),其它(邻居)路由器接收到请求后,发送他所知道的路由表信息作为响应(RIP response message)。

    4、路由器(假设的A)接收到了(邻居的)响应路由信息后,更新本地的路由表。同时再向邻居路由器发送最新的路由信息。

    5、RIP每隔30s向邻居发送(广播/组播)自己的路由信息(也是 response message),(邻居)路由器接口收到后进行对其路由表维护更新。更新定时器到时间后,再通过启动了rip协议的接口广播/组播发送路由信息(response message)。

    四、RIP2协议报文格式

    命令:1代表请求(向邻居请求全部/部分路由信息);2代表应答(可以是对请求的应答,也可以是主动的更新);

    通常在路由器刚接到网络上或者路由器有一些表项超时的时候发出RIP请求报文。

    版本:1代表RIPv1,2代表RIPv2;

    地址家族标识:该RIP报文所携带的地址类型;若是IP地址的话,  Address Family Identifier 为2;对于Request报文,此字段值为0;

    路由标记:填入自治系统的号码,这是考虑使RIP有可能收到本自治系统以外的路由选择信息;

    再后面指出到达某个网络地址(ip address)、该网络的子网掩码、下一跳路由器地址以及到此网络的距离。

    下一跳地址:收到的RIP 回复报文中,next hop全0的表示发布这个报文的路由器(接口)是去往这个网段的最优下一跳(说明路由器自己与去往的网段是直连的);字段为非0.0.0.0时,作为路由表中的下一跳地址。说明该非0地址比通告路由器的地址更优(即:通过某个网段的地址,不是和我直连的。走这个非0的地址,会比我这个接口地址更优)。

    Metric:到达ip address的距离(跳数),对于Request报文,此字段值为16;(邻居一看Metric是16,就不会再学该条路由信息,则不在转发此条信息了,即:请求只到邻居,还是利用的ttl=1的方式只发送到邻居?)

    注意:RIP最大一次只能传25个路由条目.如果超过25个就要分多个数据包进行传递,加上8字节的UDP头部,所以RIP的最大报文为512字节 (4个字节的rip首部+20*25字节的路由部分);
    如果当开启验证的时候会拿20的字节出来存放验证字段.此时就只能传24个路由条目了;

    RIP2带有认证的报文格式

    如果在报文中最初路由项Address Family Identifier域的值是0xFFFF,路由项的剩余部分就是认证;

    五、RIP环路问题与收敛:

    1、水平分割:路由器从端口X学习到的路由信息(I),则通过X端口发送更新的路由表,不包含路由信息(I)。

    2、毒性逆转:路由器从端口X学习到的路由信息(I),则通过X端口发送更新的路由表,包含路由信息(I),但是到 I 的距离设置为16。邻居路由器从接口Y接收到此信息后,发现距离是16,意味着,从Y出去,不能到达I。

    3、假设现在有 B(路由器)-----A(路由器)---d(网段),d的网段与A直连,B从A中学到其到d的路由信息。若采用水平分割的防止环路方法,B不会告诉A他到Y网段的路由信息。但是当d网段一旦出现故障(断开),则A每隔30s的情况下,发送自己的路由更新信息给B,然后由于这个更新路由信息中d网段的路由已经不存在了。需要180s后,B才能知道Y网段的可能出现故障,不能到达了。

    4、还是假设 B(路由器)-----A(路由器)---d(网段),此时若采用毒性逆转的方式进行防止环路。假设一切正常,B从A学到到网段的d的路由信息。B告诉A,我到d网段的距离是16(不可达);由于此时A和Y网段是直连的(下一跳直连/无),即使他收到了B到d网段的路由信息,但他和自己本身的路由信息一比较,本身的更好,不做更新。所以这个B告诉A,他到d网段的距离是16,对A来说,可以忽略,无意义。但是假设网段d一旦出现故障(断开),则A还是每隔30s的情况下,发送自己的路由更新信息给B,由于此时路由器用的是毒性逆转方式,他发送给B的最新的路由信息,还是要包含网段d的,只是到d的距离设置成16.此时B,收到路由信息后,立即都知道了他到Y网段也不能到达了(不需要再等180s了,加快了收敛)。能立即更新自己的路由信息,然后到时间再次发送了。

    5、其中,利用毒性逆转存在两大弊端。一个是 不是直连的拓扑(比如三角或者环形等拓扑)的时候,由于各个路由器的更新定时器时间不一致,还是会存在环路的(利用触发更新更加快度量值达到无穷大,然后宣告所涉及的网络无法访问),二个是 即使是(无环路/直连拓扑)知道了链路发生了故障,更新了路由信息,还要等到更新定时器到时的时候(30s)才能发送出去,这样收敛比较慢。可以采用触发更新,加快收敛,一但监测到链路发生了故障,则立即更新路由表,(某个度量值改变后)立即进行发送相应的更新信息,不用再等到更新定时器的时间到时,加快收敛。触发更新并不改变路由器上的源更新定时器,触发更新不是发送区域内所有的路由信息,只发送本地路由表中有变化的路由信息。

    6、这几种方法也不是万能的,在某些极端情况下,可能会出现定期发出的报文比触发更新的报文晚到的情况。也就是会出现微循环(环路)。

    抑制定时器:当RIP收到目的网络A的度量值为16的路由表更新,对应路由进入抑制状态,并启动抑制定时器,默认为180S,这时,为了防止路由震荡,在抑制定时器超时之前,即使收到对端(目的网络A)度量小于16的更新,也不接受,当抑制定时器超时后,重新允许接受对端发送的路由更新报文。此也是防止类似于上图样式的环路现象的存在。

    六、距离向量算法流程

    七、RIP工作过程分析:

    1、更新计时器

    默认情况下(没有触发更新),路由器都是每隔30s来发送一次路由信息更新;为了避免同一时间网络中充斥着大量的RIP广播或RIP报文,路由器不严格以30s为周期发送RIP报文,而是在该时间的基础上关联一个随机的细小的偏移量(加/减0~5s)。

    2、触发更新:

    当路由表发送变化时,更新报文立即发送给所有的邻居路由器,而不是等到30s时间到时候才更新。同样,当一个路由器刚启动RIP时,他发送请求报文。收到请求报文的邻居路由器立即应答一个更新报文,而不是等到下一个更新周期。这样能快速的收敛,减少环路。

    3、老化(超时)计时器:

    每一条RIP路由表项都关联两个计时器,老化计时器便是其中之一。一个路由表项添加或者更新到路由器上后,开启定时,180秒内,如果路由器收到该表项的更新报文,则重置自己的更新定时器和老化定时器。

    4、垃圾回收定时器:

    180s内,如果没有路由器没有收到该变现的更新报文;则将到底该表现中距离的度量值修改成16。让邻居都知道这条路由不可用;同时,垃圾回收定时器;如果120s内,还没有收到该表项目的可达的路由信息,则直接删除此路由表项;

     

    RIPv2路由聚合:

    路由聚合的原理是,同一个自然网段内的不同子网的路由在向外(其它网段)发送时聚合成一个网段的路由发送。

    • RIPv2支持路由聚合,因为RIPv2报文携带掩码位,所以支持子网划分。在RIPv2中进行路由聚合可提高大型网络的可扩展性和效率,缩减路由表。
    • 基于RIPv2进程的有类聚合即实现自动聚合。
    • 基于接口的聚合即实现手动聚合。
    • 如果被聚合路由携带了Tag,那么路由聚合发生之后,Tag信息将被清除。

    路由聚合有两种方式:

    基于RIP进程的有类聚合:

    聚合后的路由使用自然掩码的路由形式发布。比如,对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,会聚合成自然网段路由10.0.0.0/8(metric=2)。RIP–2聚合是按类聚合的,聚合得到最优的metric值。

    基于接口的聚合:

    用户可以指定聚合地址。比如,对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,可以在指定接口上配置聚合路由10.1.0.0/16(metric=2)来代替原始路由。

    RIP故障排除流程:

    1. 检查接口是否在RIP中使能:使用display rip process-id interface 可以查看运行rip的接口;
    2. 检查对方发送版本号和本地接口接收的版本号是否匹配:缺省情况下,接口只发送RIPv1报文,但可以接收RIPv1和RIPv2报文。当入接口与收到的RIP报文使用不同的版本号时,有可能造成RIP路由不能被正确的接收;
    3. 检查在RIP中是否配置了策略,过滤掉收到的RIP路由:如果被路由策略过滤掉,则需修改路由策略;
    4. RIP使用的端口520是否被禁用;
    5. 检查接口是否配置了undo rip input/output或者rip metricin设置度量值过大;
    6. 检查接口是否配置了抑制接口;
    7. 检查路由度量值是否大于16;
    8. 检查链路两端是否配置了认证,认证的配置是否正确。
    展开全文
  • RIP路由信息协议总结

    千次阅读 2017-04-30 20:00:24
    目的:一种基于距离矢量的路由协议,以跳数为度量值。用于同步不同网络路由器中的路由表项。 层次:采用UPD端口号520的应用层协议。 适用环境:比较小型的网络环境。 2、报文格式 大小:4+20*n(n 1)...

    一、RIP路由信息协议

    1、简介

    RIP(Routing information protocol):路由信息协议。

    RFC:1058.

    目的:一种基于距离矢量的路由协议,以跳数为度量值。用于同步不同网络路由器中的路由表项。

    层次:采用UPD端口号520的应用层协议。

    适用环境:比较小型的网络环境。

    2、报文格式

    大小:4+20*n(n<=25)

    1)     命令字段:

    1、2表示请求和应答全部或部分路由表。

    3、4废弃不用。

    5、6非正式的命令,轮询或轮询表项。

    2)     版本字段

    1或2.

    以下为路由信息:每条20字节。最多25条。

    3)     地址系列

    IP地址为2

    4)     度量

    以跳数为度量值。最大为15。16表示不可达。

    5)     报文的最大容量

    最大携带25条路由。20*25+4=504,保证了小于512字节。

    6)     特殊报文

    地址系列字段为0,度量值为16.表示请求另一端完整路由表的特殊请求报文。

    3、交互流程

    1)     初始化

    在所有端口(点对点)或者广播(支持广播的链路,以太网)请求报文。

    2)     接收到请求

    若请求全部,则返回完整路由表。否则,返回指定项,若存在,则度量值为对应值,否者为16.

    3)     接收到响应

    更新路由表、增加路由表、修改路由表、删除路由表。

    4)     定期更新

    更新周期30秒。所有或部分路由器将其完整路由表发送给相邻路由器。

    5)     路由老化

    若6个周期(3分钟)未更新,则度量置为16,标注为删除。再过60,从本地删除路由。

    4、弊端

    1)     无子网的概念

    2)     度量值单一

    只是用跳数作为度量值,忽略了一些其他元素。

    3)     收敛时间长

    路由器或链路故障后,需要很长时间恢复(几分钟)。建立阶段,还可能造成路由环路。

    4)     限制为小网络环境

    度量值为15及以内,限制了使用RIP的网络大小(小自治系统中)。

    二、RIP2

    1、简介

    RFC:1388

    RIP2不改变协议本身,而是利用协议中为必须为0的字段来传递一些额外的信息。如果RIP忽略这些字段,那么RIP和RIP2可以互操作,也就是两者互通兼容。

    2、报文格式


    3、改进

    1)路由域

    RIP选路守护进程的标注。可以实现为多个RIP实例。

    2)路由标记

    用于支持外部网管协议。携带一个EGP、BGP的自治系统号。

    3)子网掩码

    4)下一跳地址

    为特殊值0时表示发送RIP报文的系统(默认,也就是和RIP1相同)。

    5)鉴别机制

    地址类型为0xffff,路由标记为2,随后的16字节是一个明文口令。

    6)支持多播

    除广播外,增加支持多播(组播)。减少了不收听RIP2报文的主机的负载。

    三、其他

    以接口来区分从不同网络同步来的RIP路由表项,广播的时候,只广播除本端口外其他的端口路由表项。

    也就是以接口来划分管理路由表项。例如,轮询接口,若在该接口下的路由表项符合,则从该接口转发报文。
    展开全文
  • 路由信息协议RIP(学习总结)

    千次阅读 2018-12-03 16:07:20
    1.路由信息协议RIP 管理距离:衡量路由 值越小,越优先选择(不同路由器要先选择一条最优路径发送,人为确定) 2.浮动静态路由(不对称的情况下,负载均衡不适合使用,此时让较差路由作为备份路径):通过修改管理...

    1.路由信息协议RIP
    管理距离:衡量路由 值越小,越优先选择(不同路由器要先选择一条最优路径发送,人为确定)
    在这里插入图片描述

    2.浮动静态路由(不对称的情况下,负载均衡不适合使用,此时让较差路由作为备份路径):通过修改管理距离来实现
    ip route 1.1.1.0 255.255.255.0 21.1.1.1 10(管理距离)
    环回接口(虚拟接口):
    interface loopback +数字(一般由0开始)
    a.测试抵达路由器的连通性
    b.建立稳定的邻居关系(外部动态路由,跨越多个路由器作为建联的地址)
    c.用来作为Route-id(动态路由要标识每个路由器)
    d.用来虚拟隧道连接

    3.环回接口
    环回网卡:创建虚拟网卡(防止影响物理网卡)
    动态路由协议:每人把自己的直连路由共享,相互交换
    维护路由表(出现变更,删除等,要更新)
    自制系统:内部路由协议(内部连接IGP)/外部路由协议(由外部连接,建立EGP,只有一个)
    EGP,IGP是两种类别,不是两种协议
    自制系统:一个管理域下的网络集合

    4.路由协议的种类:
    距离矢量型:方向(接口),距离(度量:同一路由协议的衡量标准得到的数值)不能考虑每个线路上的具体情况。
    链路状态型:通告给邻居的一些链路状态。传递的数据量较大。
    通过路由协议是否支持无类路由:
    有类路由协议(不支持无类路由的协议):根据路由协议的类别区分,再路由通告中不包括子网掩码,需要掩码的一致。
    无类路由协议:在路由通告中包含掩码,支持可变长子网掩码,可以手工控制(汇总路由)

    5. 路由信息协议RIP
    现在可使用版本:RIPv1 RIPv2 RIPng
    其中RIPv1和RIPv2使用在IPV4网络环境,RIPng用于IPV6
    RIPv1:有类距离矢量型路由协议
    RIPv2:无类距离矢量型路由协仪
    RIPV1使用广播更新,更新地址为255.255.255.255
    RIPV2使用组播更新,更新地址为224.0.0.9

    RIP报文结构
    RIP基于UDP工作,端口号为520。由于使用UDP这种没有可靠机制的传输层协议,RIP无法保证路由通告的可靠性,所以使用了周期性更新机制,每30s发送一次更新。
    RIP工作原理
    路由器通过周期性发送路由表给邻居路由器并累加度量值。
    IGP邻居:在同一AS内部启动相同的内部网关协议的直连路由器。
    RIP使用跳数作为度量。

    Route Tag:路由标记字段,32位,仅在v2版本以上需要,第一版本不用,为0。用于路由器指定属性,必须通过路由器保存和重新广告。路由标志是分离内部和外部 RIP 路由线路的一种常用方法(路由选择域内的网络传送线路),该方法在 EGP或IGP都有应用。
    IP Address:目标IP地址字段,IPv4地址为32位。
    Subnet Mask:子网掩码字段,IPv4子网掩码地址为32位。它应用于IP地址,生成非主机地址部分。如果为0,说明该入口不包括子网掩码。也仅在v2版本以上需要,在RIPv1中不需要,为0。
    Next Hop:下一跳字段。指出下一跳IP地址,由路由入口指定的通向目的地的数据包需要转发到该地址。
    Metric:跳数字段。表示从主机到目的地获得数据报过程中的整个成本。

    等开销负载均衡:两条以及两条以上的度量值一样
    当出现两个或两个以上抵达相同目的网段的度量值一致的路由时(前提是这些路由通过同一动态路由协议获得),会出现等开销负载均衡,即到达该网段有多条路径并同时使用的状况。
    RIP默认支持4条,最大6条,IOS版本12.4以上支持16条。

    6.RIPv1配置:
    R1(config)#ip route
    R1(config-route)#version 1(通告路由,激活接口,告诉别人有这个段,同时从这个接口发RIP报文)
    R1(config-router)#network 1.0.0.0
    R1(config-router)#network 12.0.0.0(有类路由)
    RIP收敛:所有的数据收集完成
    RIP防环机制
    1.水平分割;(自身出去的路由,不从那收)
    2。毒性逆转水平分割;(发动毒性16跳路由,删除不可用路由)
    3.最大跳数限制;(180不可用,240直接删除)
    4.抑制计时器(180+80没有更优路由时,不添加,可能出现环路)

    7.RIPV1和RIPV2的区别:
    RIPV1不携带掩码不能支持VLSM/CIDR
    RIPV2携带掩码支持VLSM/CIDR 不支持超网
    RIPV1周期广播更新 255.255.255.255
    RIPV2周期组播更新 224.0.0.9

    8.RIPv2配置
    创建/进入RIP进程
    R1(config)#router rip
    选择版本2
    R1(config-router)#version 2
    关闭自动汇总
    R1(config-router)#no auto-summary(汇总成A.B.C…类地址)
    R1(config-router)#network 1.0.0.0
    R1(config-router)#network 12.0.0.0
    RIP扩展配置

    9.扩张配置
    1.手工汇总
    在需要向外发出更新的接口进行汇总
    R2(config)#interface serial 1/0
    R2(config-if)#ip summary-address rip 172.16.0.0 255.255.252.0
    2.认证
    明文认证(发hash值,检验hash值)
    先配置钥匙链
    R1(config)#key chain R1-R2(钥匙链,支持在不同的时间段使用不同的密钥)
    R1(config-keychain)#key 1(密钥)
    R1(config-keychain-key)#key-string cisco123
    再调用在接口中
    R1(config)#interface serial 1/1
    R1(config-if)#ip rip authentication key-chain R1-R2
    认证双方的key-id以及king-string必须一致,默认情况下只调用编号最小的密钥
    密文认证(HMAC:数据加密码一起变成hash值)
    先做明文认证
    再修改认证模式
    R2(config)#interface s1/0
    R2(config-if)#ip rip authentication mode md5
    3、被动接口
    被置为被动接口的接口只接收但不发送RIP更新。
    R1(config)#router rip
    R1(config-router)#passive-interface e0
    4、加快收敛速度
    R1(config)#router rip
    R1(config-router)#timers basic 15(更新时间) 90(失效时间) 90(抑制器计时器) 120(刷新时间)
    5、缺省路由
    配置位置:边界路由器(即连接ISP设备)
    R2(config)#router rip
    R2(config-router)#default-information originate
    再在边界路由器上写一条静态缺省路由指向ISP
    R2(config)#ip route 0.0.0.0 0.0.0.0 23.1.1.3

    展开全文
  • Rip(路由信息协议)实验

    千次阅读 2018-05-12 16:26:00
    主机连接设备使用Access,分别加入到各自的vlan,配置IP网关,查路由表2、设备与设备之间使用Trunk链路类型,放行所有vlan3、进入创建的vlanif接口,创建IP地址,也就是直连路由网关4、配置rip:rip---&...
  • RIP是一种分布式的基于距离向量的路由选择协议,其最大的优点时简单。RIP协议只能以“跳数”来定义路由开销。所谓跳数,就是到达目的网络需要经过路由器的个数。每经过1个路由器,跳数就加1。RIP认为好的路由就是...
  • RIP路由信息协议

    2017-05-21 09:22:31
    RIP路由信息协议是动态路由选择协议下的一种子协议,首先先了解一下Internet中的路由选择协议有哪些,在路由选择协议中有内部网关协议(Interior Gateway Protocol,IGP)和外部网关协议(Exterior Gateway ...
  • 路由、默认路由与RIP(路由信息协议),配置路由器文档
  • 基于思科网络仿真软件的实验报告,核心内容是验证路由信息协议,对于正在学习网络技术的人员有很大帮助
  • 路由信息协议RIP:是内部网关协议中得到最先广泛使用的协议,是一种分布式的基于距离向量的路由选择协议路由信息协议RIP要求网络中的每一个路由器都要维护一个从它自己到目的网络的距离记录,这里的距离指的是...
  • 常见路由协议的分析、比较

    千次阅读 2019-08-08 21:46:41
    RIP RIP“路由信息协议(Route ...RIP是一个距离矢量路由协议,最大跳数为16跳,16跳以及超过16跳的网络则认为目标网络不可达。此协议通常用在网络架构较为简单的小型网络环境.现在分为RIPv1和RIPv2两个版本,后者...
  • RIP 路由协议实验

    千次阅读 2019-03-25 17:49:15
    掌握查看通过动态路由协议RIP学习产生的路由; 熟悉广域网线缆的连接方式; 二、实验背景 假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园...
  • 【路由知识】静态路由协议

    千次阅读 2020-05-30 18:49:25
    [Huawei]ip route-static 3.3.3.0 24 12.0.0.2 [Huawei]ip route-static 3.3.3.0 24 13.0.0.2 preference 70 上方链路宕掉后,第二条备份路由开始加表(此前这条路由信息并未加表),走第二条路线; 七.负载均衡...
  • 路由协议的总结

    千次阅读 2018-01-15 15:04:09
    (一)路由协议总述 是网络协议里面的一个重要组成部分,一般工作在第三层(即网络层),常见的设备是路由器。 该层的特点是:一般我们只知道IP,不知道具体的Port,也不关系上层是TCP还是UDP。 路由协议有很多,...
  • RIP路由协议配置

    千次阅读 2020-05-07 21:45:03
    掌握RIP动态路由协议的配置、诊断方法。 实验要求: 1、配置RIP动态路由协议,使得3台Cisco路由器模拟远程网络互联。 2、对运行中的RIP动态路由协议进行诊断。 二、实验原理:(写,该实验对应哪些协议?应用哪些...
  • 路由协议之RIP

    千次阅读 2018-11-22 08:07:44
    RIP协议是一种内部网关协议(IGP),底层是贝尔曼福特算法,是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量...
  • 静态路由&rip协议&ospf路由协议

    千次阅读 2020-06-13 14:51:13
    rip和ospf路由协议rip路由协议简介信息协议历史信息原理版本RIPv1RIPv2rip和rip2区别rip-1rip-2RIPng协议分层常考题ospf路由协议概述实现过程opsf分组优点缺点实验:rip路由协议实验ospf路由协议 rip路由协议 简介 ...
  •   RIP(Routing Information Protocol)是内部网关协议IGP中最先得到广泛使用的协议,它的中文名字叫做路由信息协议,但很少被使用。RIP是一种分布式的基于距离向量的路由选择协议,是互联网的标准协议,其最大的...
  • IGRP即内部网关协议,是一种动态距离向量路由协议,它由Cisco公司80年代中期设计。使用组合用户配置尺度,包括延迟、带宽、可靠性和负载。缺省情况下,IGRP每90秒发送一次路由更新广播,在3个更新周期内(即270秒)...
  • 华为设备--动态路由rip协议配置

    千次阅读 2020-06-21 21:40:01
    分别配置三台路由器:R1ripv1版本,R3ripv2版本,R2兼容模式,调整R2端口rip协议版本让三台路由器能互相学习路由表 二、实验环境 在华为ENSP中建立如图所示拓扑图 在R1中设置 [R1]interface g0/0/0 ##配置接口ip [R1...
  • 实验一:RIP动态路由协议实验

    千次阅读 2019-09-22 16:14:31
    实验报告一:RIP动态路由协议实验 实验拓扑: Requirment: 某网络整体结构如果所示,在Router1上有3个回环口,IP地址如图,Router3连接两台主机,现要求通过使用路由协议实现全网互联。 在各路由器上配置静态路由...
  • AODV路由协议详解

    千次阅读 多人点赞 2020-04-04 20:03:46
    移动Ad Hoc网络(Mobile Adhoc Network,MANET)是一种无线自组织的...AODV(Ad Hoc On-Demand Distance Vector)路由协议是专门为移动Ad Hoc网络设计的路由协议,它是一个按需路由协议,只要当需要建立到目的节点的路
  • 1.掌握静态路由协议的配置; 2.掌握RIP协议特点和其配置方式; 3.掌握OSPF协议的特点和其配置方式; 二、实验要求 1.掌握静态路由协议的配置; (1) 配置一个互联网络,可如下图所示:(或自行设置,包括至少3个路由器...
  • 路由选择协议

    千次阅读 2018-06-05 14:54:10
    边界网关协议(BGP)是运行于 TCP 上的一种自治系统的路由协议。BGP是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。BGP 构建在 EGP 的经验之上。BGP 系统的...
  • 0 引言  根据是否在一个自治域内部使用,动态路由协议分为内部网关协议(IGP)和...这类协议的例子有OSPF,RIP等路由协议,通过提供共享路由选择信息的机制来支持被动路由协议。路由选择协议消息在路由器之间传送。路
  • 分布式路由协议

    千次阅读 2016-11-16 14:39:28
    分布式路由协议在常用在控制平面。网络中的涉及转发的每一个节点通过分布式算法计算推断各自的转发表。 这些分布式协议基于两个原则: 1、每个节点向它的邻居节点报告自己的路由信息; 2、一旦受到信息,每个...
  • 路由信息协议(RIP)的防环机制

    千次阅读 2016-03-15 23:38:14
    防环机制 1-记数最大值(maximum hop count):定义最大跳数(最大为15跳),当跳数为16跳时,目标为不可达。...3-路由毒化(route posion):当拓扑变化时,路由器会将失效的路由标记为possibly down状态,并分配
  • 文章目录OSPF动态路由协议常见的路由协议RIP距离矢量型路由协议RIP的度量值与更新时间RIP v1和RIP v2的区别内部网关协议和外部网关协议OSPF的基本概念和工作过程AS(autonomous system,自治系统)IGP(Interior ...
  • TCP/IP协议和路由协议

    千次阅读 2019-05-12 22:46:39
    TCP/IP协议和IP地址 起源: 特点: ⑴ 开放的协议标准: 可以免费使用,并且独立于特定的 计算机硬件与操作系统。 ⑵ 独立于特定的网络硬件: 可以运行在局域网、广域网 ,更适用于互联网中。 ⑶ 统一的网络...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 312,251
精华内容 124,900
关键字:

路由信息协议