精华内容
下载资源
问答
  • 不同vlan间通信

    千次阅读 2017-09-27 16:02:04
    Vlan间通信:   可通过路由器进行通信------用到的技术叫做单臂路由 可通过交换机进行通信------用到的技术叫做创建虚拟接口SVI并设置对应vlan中的计算机的网关为vlan的虚拟接口地址   网络拓扑: -----通过...

    Vlan间通信:

     

    可通过路由器进行通信------用到的技术叫做单臂路由

    可通过交换机进行通信------用到的技术叫做创建虚拟接口SVI并设置对应vlan中的计算机的网关为vlan的虚拟接口地址

     

    网络拓扑:

    -----通过路由器


     

    实验配置:

    交换机1:

    Switch>en

    Switch#conf t

    Enter configuration commands, one per line. End withCNTL/Z.

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#switchport access vlan 2

    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/3

    Switch(config-if)#switchport access vlan 3

    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode trunk         //将1口设置为trunk链路

    交换机2:

    Switch>en

    Switch#conf t

    Enter configuration commands, one per line. End withCNTL/Z.

    Switch(config)#vlan 4

    Switch(config-vlan)#exit

    Switch(config)#vlan 5

    Switch(config-vlan)#exit

    Switch(config)#interface fastEthernet 0/23

    Switch(config-if)#switchport access vlan 4

    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/22

    Switch(config-if)#switchport access vlan 5

    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/24

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#end

    Switch#show running-config

    Building configuration...

     

    Current configuration : 1052 bytes

    !

    version 12.1

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Switch

    !

    !

    !

    spanning-tree mode pvst

    !

    interface FastEthernet0/1

    !

    ………

    interface FastEthernet0/4

    ……….

    interface FastEthernet0/9

    ……

    !

    interface FastEthernet0/22

    switchport access vlan 5

    !

    interface FastEthernet0/23

    switchport access vlan 4

    !

    interface FastEthernet0/24

    switchport mode trunk

     

     

    路由器配置:

    接口0/0命令清单

    Router>enable

    Router#conf t

    Enter configuration commands, one per line. End withCNTL/Z.

    Router(config)#interface fastEthernet 0/0

    Router(config-if)#no ip address

    Router(config-if)#exit

    Router(config)#interface fastEthernet 0/0.2

    Router(config-subif)#encapsulation dot1Q 2

    Router(config-subif)#ip address 192.168.2.1 255.255.255.0

    Router(config-subif)#exit

    Router(config)#interface fastEthernet 0/0.3

    Router(config-subif)#encapsulation dot1Q 3

    Router(config-subif)#ip address 192.168.3.1 255.255.255.0

    Router(config-subif)#exit

    Router(config)#interface fastEthernet 0/0

    Router(config-if)#noshutdown

     

    接口0/1命令清单

    Router(config)#interface fastEthernet 0/1

    Router(config-if)#no ip address

    Router(config-if)#exit

    Router(config)#interface fastEthernet 0/1.4

    Router(config-subif)#encapsulation dot1Q 4

    Router(config-subif)#ip address 192.168.4.1255.255.255.0

    Router(config-subif)#exit

    Router(config)#interface fastEthernet 0/1.5

    Router(config-subif)#encapsulation dot1Q 5

    Router(config-subif)#ip address 192.168.5.1255.255.255.0

    Router(config-subif)#exit

    Router(config)#interfacefastEthernet 0/1

    Router(config-if)#noshutdown

     

     

    验证:

    PC>ping 192.168.3.100

     

    Pinging 192.168.3.100 with 32 bytes of data:

     

    Reply from 192.168.3.100: bytes=32 time=0ms TTL=127

    Reply from 192.168.3.100: bytes=32 time=13ms TTL=127

    Reply from 192.168.3.100: bytes=32 time=14ms TTL=127

    Reply from 192.168.3.100: bytes=32 time=13ms TTL=127

     

    Ping statistics for 192.168.3.100:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 14ms, Average = 10ms

     

    PC>ping 192.168.4.100

     

    Pinging 192.168.4.100 with 32 bytes of data:

     

    Request timed out.

    Reply from 192.168.4.100: bytes=32 time=0ms TTL=127

    Reply from 192.168.4.100: bytes=32 time=12ms TTL=127

    Reply from 192.168.4.100: bytes=32 time=0ms TTL=127

     

    Ping statistics for 192.168.4.100:

    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

    Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 12ms, Average = 4ms

     

    PC>ping 192.168.5.100

     

    Pinging 192.168.5.100 with 32 bytes of data:

     

    Request timed out.

    Reply from 192.168.5.100: bytes=32 time=13ms TTL=127

    Reply from 192.168.5.100: bytes=32 time=13ms TTL=127

    Reply from 192.168.5.100: bytes=32 time=14ms TTL=127

     

    Ping statistics for 192.168.5.100:

    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

    Approximate round trip times in milli-seconds:

    Minimum = 13ms, Maximum = 14ms, Average = 13ms

     

    为各个配置IP时记得配上网关!

    补充:所谓单臂路由就是指使用IEEE 802.1Q来启动一个路由器上的子接口成为干道模式,实现vlan间的通信

     

    本实验到此成功。(交换机的配置下次上传)

    展开全文
  • 我们《计算机网络设计》利用三层交换机实现不同vlan间通信的实验指导 我们《计算机网络设计》利用三层交换机实现不同vlan间通信的实验指导 我们《计算机网络设计》利用三层交换机实现不同vlan间通信的实验指导
  • 单臂路由是一种实现不同VLAN间通信的技术,其方法是在虚拟机内接口上配置虚拟子接口。 该技术是一种应急技术,仅仅用于网络预算不足,无力购买三层交换机,或者网络规模很小的情况下使用。一、实验 路由器只需要一个...

    单臂路由是一种实现不同VLAN间通信的技术,其方法是在虚拟机内接口上配置虚拟子接口。

    该技术是一种应急技术,仅仅用于网络预算不足,无力购买三层交换机,或者网络规模很小的情况下使用。

    一、实验

    路由器只需要一个端口和交换机(二层)连接。将交换机和路由器连接的端口设置vlan模式为Trunk,并配置路由器端口的子端口的vlan信息。单臂路由图解如下。

    1631a1e8a4605157e370ec1b07ce0152.png

    目前,vlan1中的PC机无法ping通vlan2中的PC机,我们通过单臂路由的方式让vlan1和vlan2通信。

    switchport的配置:

    Switch1(config)#int e0/0 ##进入e0/0端口

    Switch1(config-if)#switchport trunk encapsulation dot1q ##配置trunk的封装模式为dot1q

    Switch1(config-if)#switchport mode trunk ##指派端口vlan模式为trunk

    Switch1(config-if)#switchport trunk allowed vlan all ##允许该端口trunk模式下接收所有vlan线路信息

    Router配置:

    Router1(config)#int ethernet0/0 ##进入e/0端口

    Router1(config-if)#no shutdown ##开启e/0端口

    Router1(config-if)#int e0/0.1 ##进入e/0的子端口e/0.1

    Router1(config-subif)#encapsulation dot1Q 1 ##对子端口e/0.1进行802.1q协议封装,并侦听vlan号为1的传输数据

    Router1(config-subif)#ip address 172.25.10.254 255.255.255.0 ##配置子端口的ip和子网掩码

    Router1(config-subif)#no shutdown ##启动子端口e/0.1

    Router1(config-subif)#exit ##退出

    Router1(config-if)#int e0/0.2

    Router1(config-subif)#encapsulation dot1Q 2

    Router1(config-subif)#ip address 172.25.20.254 255.255.255.0

    Router1(config-subif)#no shutdown

    配置完之后,查看路由信息,如下图。

    7f11c596f7ddb1b0d1fae667bcfdb14e.png

    二、验证

    用vlan1中的PC-1去ping vlan2中的两台PC机,发现能够ping通,如下图。完成了不同vlan间的通信。

    85c2d0bfabbc632a92a493fbaa3f5e41.png
    展开全文
  • 交换机不同vlan间通信

    2020-10-31 17:41:51
    有两台二层交换机SwitchA和SwitchB, 一台路由器Gw,网络拓扑如图4-...主机PC1、PC2、 PC3、PC4的IP地址及所属VLAN如图4-27所示, 对四台主机、交换机及路由器进行恰当的配置,实现跨交换机相同VLAN内通信和VLAN间通信
  • **eNSP三层交换机不同vlan间通信**一、实验题目二、实验拓扑图三、实验内容四、实验总结 一、实验题目 三台交换机(其中一台交换机为三层交换机),四台PC,实现不同vlan之间的通信。 二、实验拓扑图 实验中使用的...

    一、实验题目

    三台交换机(其中一台交换机为三层交换机),四台PC,实现不同vlan之间的通信。

    二、实验拓扑图

    实验中使用的交换机型号均为S3700,其中SW3我们选用成为三层交换机,其它两个交换机均为二层交换机
    在这里插入图片描述

    三、实验内容

    1. 配置确定
    VLAN:
      VLAN:PC1 PC3
      VLAN:PC2 PC4
    网段:
      192.168.1.0/24
      192.168.2.0/24
    
    1. 主机配置
    PC1:192.168.1.1 255.255.255.0 192.168.1.254
    PC2:192.168.2.1 255.255.255.0 192.168.2.254
    PC3:192.168.1.2 255.255.255.0 192.168.1.254
    PC4:192.168.2.2 255.255.255.0 192.168.1.254
    
    1. 配置二层交换机(SW1,SW2)
    [Huawei]sysname SW1
    [SW1]vlan batch 10 20
    [SW1]int e0/0/1
    [SW1-Ethernet0/0/1]port link-type access 
    [SW1-Ethernet0/0/1]port default vlan 10
    [SW1-Ethernet0/0/1]int e0/0/2
    [SW1-Ethernet0/0/2]port link-type access
    [SW1-Ethernet0/0/2]port default vlan 20
    [SW1-Ethernet0/0/2]int e0/0/3
    [SW1-Ethernet0/0/3]port link-type trunk 
    [SW1-Ethernet0/0/3]port trunk allow-pass vlan 10 20
    ---------------------------------------------------------
    [Huawei]sysname SW2
    [SW2]vlan batch 10 20
    [SW2]int e0/0/1
    [SW2-Ethernet0/0/1]port link-type access 
    [SW2-Ethernet0/0/1]port default vlan 10
    [SW2-Ethernet0/0/1]int e0/0/2
    [SW2-Ethernet0/0/2]port link-type access
    [SW2-Ethernet0/0/2]port default vlan 20
    [SW2-Ethernet0/0/2]int e0/0/3
    [SW2-Ethernet0/0/3]port link-type trunk 
    [SW2-Ethernet0/0/3]port trunk allow-pass vlan 10 20
    
    1. 配置三层交换机(SW3)
    [Huawei]sysname SW3
    [SW3]vlan batch 10 20
    [SW3]int vlanif 10
    [SW3-Vlanif10]ip add 192.168.1.254 24
    [SW3-Vlanif10]int vlanif 20
    [SW3-Vlanif20]ip add 192.168.2.254 24
    [SW3-Vlanif20]int e0/0/1
    [SW3-Ethernet0/0/1]port link-type trunk 
    [SW3-Ethernet0/0/1]port trunk allow-pass vlan 10 20
    [SW3-Ethernet0/0/1]int e0/0/2
    [SW3-Ethernet0/0/2]port link-type trunk
    [SW3-Ethernet0/0/2]port trunk allow-pass vlan 10 20
    
    1. 测试不同vlan间连通性
      在这里插入图片描述最后不同vlan间可以联系,说明配置成功。

    四、实验总结

    我们本次实验运用到的知识有:

    1. vlan的配置
    2. 通过三层交换机实验不同vlan之间的通信
    3. 需要掌握以下指令
    vlan batch 10 20 		//批量创建vlan
    port link-type trunk 	//配置trunk干线,实现不同设备之间的通信
    int vlanif 10			//进入vlan端口配置,实现不同vlan之间的配置
    
    展开全文
  • ENSP配置 实例一 不同VLAN间通信

    千次阅读 2020-06-19 11:31:22
    不同VLAN间通信 SW1 [SW1]vlan batch 10 20 [SW1]interface g0/0/1 [SW1-GigabitEthernet0/0/1]port link-type access [SW1-GigabitEthernet0/0/1]port default vlan 10 [SW1-GigabitEthernet0/0/1]int g0/0/2 [SW1...

    ENSP配置 实例一 不同VLAN间通信

    在这里插入图片描述
    SW1
    [SW1]vlan batch 10 20
    [SW1]interface g0/0/1
    [SW1-GigabitEthernet0/0/1]port link-type access
    [SW1-GigabitEthernet0/0/1]port default vlan 10
    [SW1-GigabitEthernet0/0/1]int g0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type access
    [SW1-GigabitEthernet0/0/2]port default vlan 20
    [SW1-GigabitEthernet0/0/1]int g0/0/3
    [SW1-GigabitEthernet0/0/3]port link-type trunk
    [SW1-GigabitEthernet0/0/3]port trunk allow-pass vlan all
    SW2
    [SW2]vlan b 10 20
    [SW2]int g0/0/1
    [SW2-GigabitEthernet0/0/1]p l a
    [SW2-GigabitEthernet0/0/1]p d v 10
    [SW2-GigabitEthernet0/0/1]int g0/0/2
    [SW2-GigabitEthernet0/0/2]p l a
    [SW2-GigabitEthernet0/0/2]p d v 20
    [SW2-GigabitEthernet0/0/2]int g0/0/3
    [SW2-GigabitEthernet0/0/3]p l t
    [SW2-GigabitEthernet0/0/3]p t a vlan all
    在SW1上设置网关
    [SW1]int vlan 10
    [SW1-Vlanif10]ip add 192.168.1.254 24
    [SW1-Vlanif10]int vlan 20
    [SW1-Vlanif20]ip add 192.168.2.254 24

    拓展:不同vlan之间通信
    vlan是二层中不能互相通信的,所以我们要经过三层才能相互通信。
    vlan设置IP就像是虚拟端口设置IP

    展开全文
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信 二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。 三层交换机 vlanif ...
  • 实现不同VLAN间通信——单臂路由

    千次阅读 2019-07-17 17:54:14
    单臂路由是一种实现不同VLAN间通信的技术,其方法是在虚拟机内接口上配置虚拟子接口。 该技术是一种应急技术,仅仅用于网络预算不足,无力购买三层交换机,或者网络规模很小的情况下使用。 一、实验 路由器只...
  • 实现不同交换机上不同vlan间通信 要求 1、根据实验要求配置实验拓扑如下图所示(注意同一个vlanif 下的 不同交换机的网关地址必须一样,不然不能通信,LSW1 和 LSW2 的vlan10的网关地址都是192.168.1.1,图片经供...
  • 华为三层交换机实现不同vlan间通信

    千次阅读 2018-01-04 23:49:25
    实验名称:华为三层交换机实现不同vlan间通信实验目的:pc1/pc2/pc3实现通信实验拓扑:实验步骤:1.配置PC机2.配置三层交换机<huawei>syste-mview[huawei]sysname gateway[gateway]vlan batch 10 20 30...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。三层交换机vlanif 接口up 条件...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。三层交换机vlanif 接口up 条件...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。三层交换机vlanif 接口up 条件...
  • 利用三层交换机实现不同VLAN间通信

    千次阅读 2014-09-25 21:33:58
    【实验名称】利用三层交换机实现不同VLAN间通信 【实验目的与要求】 目的: 通过三层交换机实现VLAN间通信 要求: 1、在二层交换机S2126上建立虚拟局域网vlan30;在三层交换机S3550-24上建立虚拟局域网vlan10 ...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。三层交换机vlanif 接口up 条件...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信 二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。 三层交换机 vlanif ...
  • 阐述了虚拟局域网(VLAN)技术的工作原理及特点,针对不同VLAN之间通信问题,设计出了通过单臂路由、路由接口和三层交换路由功能实现不同VLAN之间通信的三种实验方案,让学生能够从理论上和实践上更好地掌握VLAN技术...
  • 当只有二层交换机时,又要实现不同vlan间通信时,需要用到单臂路由技术 交换机命令: 路由器命令: 三层交换技术 三层交换机可以配置vlanif接口,通过vlanif接口可以配置ip地址,成为不同vlan对应的网关,从而实现...
  • 1,实验名称:华为三层交换机实现不同vlan间通信实验目的:pc1/pc2/pc3实现通信实验拓扑:2,配置三层交换机<huawei>system-view[huawei]sysname gateway[gateway]vlan batch 10 20 30[gateway]interface vlan...
  • 1,实验名称:思科三层交换机不同vlan间通信实验目的:pc1/pc2/pc3实现通信实验拓扑: 2,实验步骤:(1)配置PC:PC1:192.168.10.1 255.255.255.0 192.168.10.254PC2:192.168.20.1 255.255.255.0 192.168.20.254...
  • Hybrid接口实现不同VLAN间通信

    千次阅读 2020-06-22 19:20:21
    华为交换机的接口默认设为hybrid,hybrid接口介于access和trunk接口之间,通过加标签和脱标签的方式可以实现不同vlan间通信,hybrid接口是华为设备的特殊的二层接口模式,可以类似于VLAN和trunk接口,可以对数据帧...
  • 注意:1)多VLAN间通信必须在每个交换机上创建所有需要互通pc所属的VLAN的PVID(标识符)2)多VLAN间的通信用trunk模式的链路类型连接相邻的交换机,允许所有VLAN通过;连接客户端用access模式,将端口加入对应的VLAN...
  • 拓扑图: W1配置: <Huawei>system-view [Huawei]vlan batch 10 20 ...[Huawei-Vlanif10]interface vlanif 20 [Huawei-Vlanif20]ip address 192.168.2.1 24 [Huawei-Vlanif20]quit [Huawei]interface g
  • [Huawei]vlan batch 10 20 [Huawei]interface GigabitEthernet 0/0/1 [Huawei-GigabitEthernet0/0/2]port link-type access [Huawei-GigabitEthernet0/0/2]port default vlan 10 [Huawei-GigabitEthernet0/0/2]quit...
  • 今天通过介绍两种常用的方法实现不同VLAN间进行通信。方法一:单臂路由实现不同VLAN之间互通什么是单臂路由呢?其实单臂路由就是指在路由器的一个接口上通过配置子接口的方式,实现原来相互隔离的不同VLAN之间互通。...
  • SVI实现不同vlan间通信

    千次阅读 2013-06-29 16:27:13
     通过三层网络设备实现vlan间通信有三种方法:  1. 利用SVI的方式实现,使用三层交换机,具有速度高,无冲突影响等优点  2. 通过路由接口方式实现,需要每一个路由接口连接一个vlan,需要的路由接口数量较多  ...
  • 实验任务:(1) 掌握和完成设置不同vlan间通过路由器互通的方法;(2) 完成同vlan间计算机的测试。2. 实验目的:(1) 进一步熟悉交换机vlan间互通的配置方法;(2) 熟悉和掌握不同vlan间互通的测试方法。二、原理(条件)1....
  • 不同VLAN间通信的配置-ZTE中兴交换机

    千次阅读 2019-11-12 16:27:23
    一、实验目的及要求: 1、掌握vlan的基本概念、作用、工作原理及配置方法。 2、掌握TP的基本概念、作用、工作...6、掌握路由器的基本配置,实现不同vlan间通信。 二、实验设备: 1、中兴二层交换机(2950) 两...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 903
精华内容 361
关键字:

不同vlan间通信