精华内容
下载资源
问答
  • 路由原理

    2021-04-05 13:18:26
    路由原理路由器1.路由2.路由器的工作原理3.路由表4.静态路由5.路由器转发数据包的封装过程另附三道实验练习题及配置1.静态路由+默认路由2.静态路由+浮动路由3.全网互通 路由器 1.路由 路由器是一种连接多个网络或...

    路由器

    1.路由

    路由器是一种连接多个网络或网段的网络设备,工作在网络层,作用是隔离广播域和为数据包选择最佳路径,最终送达目的地,其中选择路径的过程被称为路由

    2.路由器的工作原理

    在这里插入图片描述

    (1)PC1发送数据给PC2,因为两台PC不在同一网段,所以PC1会将数据包发送给路由器AR1
    (2)AR1收到数据包,首先会查看数据包中的目的IP地址,再查看自己的路由表,数据包中的目的IP地址是192.168.2.1/24,属于2.0网段,路由器发现自己路由表中记录了2.0网段转发接口是g0/0/0,于是将数据包从g0/0/0接口转发出去
    (3)网络中每个路由器都是这样转发数据,直到到达最后一个路由器AR2,路由器发现自己路由表中记录了2.0网段转发接口是g0/0/1,于是将数据包从g0/0/1接口转发出去,最终PC2接收到PC1发来的数据

    如果路由表中没有对应的网段信息,路由器会根据配置转发到默认接口,或者给用户返回 “目标地址不可达” 的信息

    3.路由表

    路由表是在路由器中维护的路由条目,路由器根据路由表做路径选择。路由表的形成需要从直连网段和非直连网段来理解
    (1)直连网段:在路由器的接口上配置了IP,且接口状态UP时,路由表会出现直连路由选项
    在这里插入图片描述
    (2)非直连路由:AR1的路由表中并没有出现192.168.2.0网段的路由,此时就需要我们手动配置静态路由或者动态路由让其学习了
    在这里插入图片描述

    4.静态路由

    (1)静态路由是管理员手动配置的,不会发生变化
    (2)静态路由是单向的
    (3)静态路由可以对路由的行为进行精确的控制
    (4)静态路由缺乏灵活性,当网络拓扑更新时,管理员必须重新配置该静态路由
    (5)默认路由:是一种特殊的静态路由,当路由表中没有与数据包中目的地址匹配的网段时路由器选择默认接口

    5.路由器转发数据包的封装过程

    PC1向PC2发送数据
    在这里插入图片描述

    源IP 目的IP 源MAC 目的MAC
    PC1到AR1 192.168.1.1 192.168.2.1 54-89-98-6D-4F-03 00e0-fc77-29cd
    AR1到AR2 192.168.1.1 192.168.2.1 00e0-fc77-29cc 00e0-fcfa-2da3
    AR2到PC2 192.168.1.1 192.168.2.1 00e0-fcfa-2da4 54-89-98-58-53-1D

    另附三道实验练习题及配置

    1.静态路由+默认路由

    实验要求:R1配置默认路由,R2、R3配置静态路由,使PC1和PC2可以访问server1
    在这里插入图片描述

    (1)R1配置

    interface GigabitEthernet0/0/0
     ip address 192.168.1.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.2.1 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.10.1 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.10.2
    

    (2)R2配置

    interface GigabitEthernet0/0/0
     ip address 192.168.10.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.20.1 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 10.0.0.0 255.0.0.0 192.168.20.2
    ip route-static 192.168.1.0 255.255.255.0 192.168.10.1
    ip route-static 192.168.2.0 255.255.255.0 192.168.10.1
    

    (3)R3配置

    interface GigabitEthernet0/0/0
     ip address 192.168.20.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.0.0.1 255.0.0.0 
    #
    interface NULL0
    #
    ip route-static 192.168.0.0 255.255.0.0 192.168.20.1
    

    (4)检验
    在这里插入图片描述
    在这里插入图片描述
    PC1、PC2可以ping通 server1

    2.静态路由+浮动路由

    实验要求:1、配置浮动路由,实现PC1到PC2互通
    2、断掉R1和R2之间的链路,观察路由表变化,PC1到PC2任然互通

    在这里插入图片描述
    (1)R1配置

    interface GigabitEthernet0/0/0
     ip address 12.0.0.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.10.254 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     ip address 13.0.0.1 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 192.168.20.0 255.255.255.0 12.0.0.2
    ip route-static 192.168.20.0 255.255.255.0 13.0.0.2 preference 70
    #
    

    (2)R2配置

    interface GigabitEthernet0/0/0
     ip address 12.0.0.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.20.254 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     ip address 23.0.0.1 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 192.168.10.0 255.255.255.0 23.0.0.2 preference 70
    ip route-static 192.168.10.0 255.255.255.0 12.0.0.1
    #
    

    (3)R3配置

    interface GigabitEthernet0/0/0
     ip address 13.0.0.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 23.0.0.2 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 192.168.10.0 255.255.255.0 13.0.0.1
    ip route-static 192.168.20.0 255.255.255.0 23.0.0.1
    #
    

    (4)查看链路正常路由表,查看通信状态

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    (5)断开R1.R2间的链路,查看路由表和通信状态
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    3.全网互通

    在这里插入图片描述

    (1)R1配置

    interface GigabitEthernet0/0/0
     ip address 12.0.0.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 13.0.0.1 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.10.254 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 192.168.20.0 255.255.255.0 12.0.0.2
    ip route-static 192.168.30.0 255.255.255.0 13.0.0.2
    #
    

    (2)R2配置

    interface GigabitEthernet0/0/0
     ip address 192.168.20.254 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.2 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 13.0.0.0 255.255.255.0 12.0.0.1
    ip route-static 192.168.10.0 255.255.255.0 12.0.0.1
    ip route-static 192.168.30.0 255.255.255.0 12.0.0.1
    

    (3)R3配置

    interface GigabitEthernet0/0/0
     ip address 13.0.0.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.30.254 255.255.255.0 
    #
    interface NULL0
    #
    ip route-static 12.0.0.0 255.255.255.0 13.0.0.1
    ip route-static 192.168.10.0 255.255.255.0 13.0.0.1
    ip route-static 192.168.20.0 255.255.255.0 13.0.0.1
    

    (4)检验
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 可能很多人对策略路由原理还不是特别的了解,这里我们主要分析了策略路由原理的详细知识。传统的策略路由原理都是使用从路由协议派生出来的路由表,根据目的地址进行报文的转发。在这种机制下,路由器只能根据报文的...
  • 主要介绍了Laravel 框架路由原理与路由访问,结合实例形式分析了Laravel 框架路由的基本概念、原理、路由访问方法及操作注意事项,需要的朋友可以参考下
  • 路由原理路由(一)——路由原理及静态路由一、路由原理路由的工作原理最优路由的选择二、路由表简介路由表的形成三、路由协议分类四、静态路由默认路由浮动路由静态路由的优点、缺点及建议五、静态路由实例总结 ...

    路由(一)——路由原理及静态路由


    一、路由原理

    路由是指分组从源到目的地时,决定端到端路径的网络范围的进程 。路由工作在OSI参考模型第三层——网络层的数据包转发设备。

    路由器通过转发数据包来实现网络互连。路由器通常连接两个或多个由IP子网或点到点协议标识的逻辑端口,至少拥有1个物理端口。路由器根据收到数据包中的网络层地址以及路由器内部维护的路由表决定输出端口以及下一跳地址,并且重写链路层数据包头实现转发数据包。路由器通过动态维护路由表来反映当前的网络拓扑,并通过网络上其他路由器交换路由和链路信息来维护路由表。

    路由的工作原理

    路由器利用网络寻址功能使路由器能够在网络中确定一条最佳的路径。IP地址的网络部分确定分组的目标网络,并通过 IP 地址的主机部分和设备的 MAC 地址确定到目标节点的连接。

    路由器的某一个接口接收到一个数据包时,会查看包中的目标网络地址以判断该包的目的地址在当前的路由表中是否存在。
    如果发现包的目标地址与本路由器的某个接口所连接的网络地址相同,那么马上数据转发到相应接口;如果发现包的目标地址不是自己的直连网段,路由器会查看自己的路由表,查找包的目的网络所对应的接口,并从相应的接口转发出去;如果路由表中记录的网络地址与包的目标地址不匹配,则根据路由器配置转发到默认接口,在没有配置默认接口的情况下会给用户返回目标地址不可达的 ICMP 信息。

    简单来说,路由有两个主要功能:一是将数据包转发到正确目的地,二是在转发过程中选择最佳的路径。

    最优路由的选择

    • 子掩网码长度最长的优先匹配
    • 选取理由协议中优先级最小的优先匹配
    • 相同协议下,选取metric值最小的优先匹配
    • 如果以上都没有路由匹配上,就匹配默认路由

    注释:路由表中的metric下的数字为路由指定所需跃点数的整数值(范围是1~9999),它用来在路由表里的多个路由中选择与转发包中的目标地址最为匹配的路由。所选的路由具有最少的跃点数。

    二、路由表

    简介

    在计算机网络中,路由表(routing table)或称路由择域信息库(RIB, Routing Information Base),是一个存储在路由器或者联网计算机中的电子表格或类数据库。

    路由表存储着指向特定网络地址的路径(在有些情况下,还记录有路径的路由度量值)。路由表中含有网络周边的拓扑信息。路由表建立的主要目标是为了实现路由协议和静态路由选择。

    简单解释:路由表就是路由器中维护的路由条目的集合,路由器是通过路由表来做路径的选择。

    路由表的形成

    1. 直通网段

    • 配置IP地址
    • 端口处于up状态
    • 形成直连路由

    2. 非直通网段
    需要静态路由或者动态路由,将网段手动添加到路由表中

    三、路由协议分类

    路由协议分为两大类:静态路由和动态路由。

    静态路由 管理员手动配置路由
    动态路由 路由间自动学习

    依照路由器与其他自治系统的关系,有许多种类的路由协定:
    主要为两大类:内部网关路由协议(IGP)和外部网关协议(EGP)。

    • 内部网关路由协议(IGP)
      IGP是负责一个路由域(在一个管理域内运行同一种路由协议的域,称为一个路由域)内路由的路由协议。主要分为距离矢量路由协议和链路状态路由协议。
    分类 包括
    距离矢量路由协议 RIP、EIGRP等
    链路状态路由协议 OSPF、IS-IS等
    • 外部网关路由协议(EGP)
      EGP负责在自治系统之间或域间完成路由和可到达信息的交互,主要用于传递路由,目前的主要协议有BGPv4。

    四、静态路由

    静态路由(Static routing),一种路由的方式,路由项由手动配置,而非动态决定。

    与动态路由不同,静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。

    一般来说,静态路由是由网络管理员逐项加入路由表。

    默认路由

    默认路由是静态路由的一种特殊形式,它属于静态路由的一种,使用时有条件的,一般用于末梢/末节网络。

    出现默认路由的原因:路由得查看路由表而决定怎么转发数据包,用静态路由一个个的配置,繁琐易错。如果路由器有个邻居知道怎么前往所有的目的地,可以把路由表匹配的任务交给它,省了很多事。

    浮动路由

    浮动路由指的是配置两条静态路由,默认选取链路质量优(带宽大)的作为主路径,当主路径出现故障时,由带宽较小的备份路由顶替,保持网络的不中断。

    静态路由的优点、缺点及建议

    静态路由
    适用环境 适用于小规模的企业网络,大规模企业网络用动态路由
    优点 配置灵活,管理员手动配置,节省链路开销
    缺点 当拓扑发生改变是,需要管理员去每台路由器上修改路由设置
    建议 五条以内的外部路由用静态路由协议,五条以上的用动态路由协议

    五、静态路由实例

    在这里插入图片描述
    R4:

    The device is running!
    
    <Huawei>undo ter mo
    Info: Current terminal monitor is off.
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R4
    [R4]int e0/0/0
    [R4-Ethernet0/0/0]ip add 10.1.1.2 24
    [R4-Ethernet0/0/0]q	
    [R4]int LoopBack 0
    [R4-LoopBack0]ip add 192.168.1.10 24
    [R4-LoopBack0]q	
    [R4]ip route-static 10.1.2.0 24 10.1.1.3	
    [R4]ip route-static 172.16.1.0 24 10.1.1.3
    Info: The destination address and mask of the configured static route mismatched
    , and the static route 172.16.1.0/24 was generated.
    

    R2:

    The device is running!
    
    <Huawei>undo ter mo
    Info: Current terminal monitor is off.
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysn	
    [Huawei]sysname R2
    [R2]int e0/0/0
    [R2-Ethernet0/0/0]ip add 10.1.1.3 24
    [R2-Ethernet0/0/0]int e0/0/1
    [R2-Ethernet0/0/1]ip add 10.1.2.3 24
    [R2-Ethernet0/0/1]q	
    [R2]ip route-static 192.168.1.0 24 10.1.1.2
    Info: The destination address and mask of the configured static route mismatched
    , and the static route 192.168.1.0/24 was generated.
    [R2]ip route-static 172.16.1.0 24 10.1.2.4
    Info: The destination address and mask of the configured static route mismatched
    , and the static route 172.16.1.0/24 was generated.
    

    R3

    The device is running!
    
    <Huawei>undo ter mo
    Info: Current terminal monitor is off.
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysn R3
    [R3]int e0/0/0
    [R3-Ethernet0/0/0]ip add 10.1.2.4 24
    [R3-Ethernet0/0/0]q
    [R3]int loopb 0
    [R3-LoopBack0]ip add 172.16.1.10 24
    [R3-LoopBack0]q	
    [R3]ip route-static 10.1.1.0 24 10.1.2.3
    [R3]ip route-static 192.168.1.0 24 10.1.2.3
    Info: The destination address and mask of the configured static route mismatched
    , and the static route 192.168.1.0/24 was generated.
    

    R3与R4的环回口间的通信:
    R4

    [R4]ping -a 192.168.1.10 172.16.1.10
      PING 172.16.1.10: 56  data bytes, press CTRL_C to break
        Reply from 172.16.1.10: bytes=56 Sequence=1 ttl=254 time=60 ms
        Reply from 172.16.1.10: bytes=56 Sequence=2 ttl=254 time=30 ms
        Reply from 172.16.1.10: bytes=56 Sequence=3 ttl=254 time=60 ms
        Reply from 172.16.1.10: bytes=56 Sequence=4 ttl=254 time=50 ms
        Reply from 172.16.1.10: bytes=56 Sequence=5 ttl=254 time=60 ms
    
      --- 172.16.1.10 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/52/60 ms
    

    R3

    [R3]ping -a 172.16.1.10 192.168.1.10
      PING 192.168.1.10: 56  data bytes, press CTRL_C to break
        Reply from 192.168.1.10: bytes=56 Sequence=1 ttl=254 time=100 ms
        Reply from 192.168.1.10: bytes=56 Sequence=2 ttl=254 time=50 ms
        Reply from 192.168.1.10: bytes=56 Sequence=3 ttl=254 time=60 ms
        Reply from 192.168.1.10: bytes=56 Sequence=4 ttl=254 time=60 ms
        Reply from 192.168.1.10: bytes=56 Sequence=5 ttl=254 time=70 ms
    
      --- 192.168.1.10 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 50/68/100 ms
    

    总结

    熟悉路由的工作原理及静态路由的优缺点,对于熟悉网络层的数据传输方面有一定的作用。

    展开全文
  • 单臂路由原理

    万次阅读 多人点赞 2019-04-24 23:06:39
    单臂路由原理 路由, 单臂, 原理 众多中小企业内部网络结构都很简单,仅仅是用一台交换机将所有员工机以及服务器连接到一起,然后通过光纤访问internet而已。当然为了保证部分主机的安全性以及分割内部广播包...

    单臂路由原理

    路由, 单臂, 原理

    众多中小企业内部网络结构都很简单,仅仅是用一台交换机将所有员工机以及服务器连接到一起,然后通过光纤访问internet而已。当然为了保证部分主机的安全性以及分割内部广播包提高网络传输速度,采取诸如划分VLAN,分配不同子网的方法来实现。通过划分VLAN可以让在同一台交换机不同端口的客户机不能互相访问,有效的隔离了网络

      通过VLAN划分网络固然可以解决安全和广播风暴的频繁出现,但是对于那些既希望隔离又希望对某些客户机进行互通的公司来说,划分VLAN的同时为不同VLAN建立互相访问的通道也是必要的。

    ( C$ }# d/ d# s' X, b
    众所周知可以使用三层交换机来实现,但是大多数情况企业网络搭建初期购买的仅仅是二层可管理型交换机,如果要购买三层交换机实现VLAN互通功能的话,以前的二层设备将被丢弃。这样就造成了极大的浪费。那么有没有什么办法在仍然使用二层设备的基础上,实现三层交换机的功能呢?

      一、三层交换机的原理:

      在告诉各位读者解决方法前我们需要首先了解三层交换机的工作原理。理论上讲一台三层交换机可以看做是一个二层交换机+一个路由模块,实际使用中各个厂商也是通过将路由模块内置于交换机中实现三层功能的。在传输数据包时先发向这个路由模块,由其提供路由路径然后再由交换机转发相应的数据包。

      二、单臂路由原理:

      既然仍然要使用以前的二层设备,那么我们可以通过添加一台路由器解决上面提到的企业网络升级问题。这台路由器就相当于三层交换机的路由模块,只是我们将其放到了交换机的外部。具体原理拓扑图如下:

    图1:网络拓朴结构

      router路由器

      连接线路(负责多个vlan之间的的通信)

      switch交换机

      大家可以看出在router路由器与交换机之间是通过外部线路连接的,这个外部线路只有一条,但是他在逻辑上是分开的,需要路由的数据包会通过这个线路到达路由器,经过路由后再通过此线路返回交换机进行转发。所以大家给这种拓扑方式起了一个形象的名字--单臂路由。说白了,单臂路由就是包从哪个口进去,又从哪个口出来,而不象传统网络拓扑中数据包从某个接口进入路由器又从另一个接口离开路由器。

      那么什么时候要用到单臂路由呢?在企业内部网络中划分了VLAN,当VLAN之间有部分主机需要通信,但交换机不支持三层交换,这时候可以采用一台支持802.1Q的路由器实现VLAN的互通。我们只需要在以太口上建立子接口,并分配IP地址作为该VLAN的网关,同时启动802.1Q协议即可。

      小提示:

      一个物理接口当成多个逻辑接口来使用时,往往需要在该接口上启用子接口。通过一个个的逻辑子接口实现物理端口以一当多的功能。

     

    展开全文
  • 静态路由原理

    2020-10-26 16:46:31
    静态路由原理一、路由概述二、路由器的工作原理 一、路由概述 路由:从源主机到目标主机的转发过程 路由器:能够将数据包转发到正确的目的地,并在转发的过程中选择最佳路径的设备 二、路由器的工作原理 ...

    一、路由概述

    路由:从源主机到目标主机的转发过程
    路由器:能够将数据包转发到正确的目的地,并在转发的过程中选择最佳路径的设备

    二、路由器的工作原理

    在这里插入图片描述

    在这里插入图片描述
    根据路由表转发数据

    三、路由表的工作原理

      1.  路由器中维护的路由条目的集合
           路由器根据路由表做路路径选择
      2.路由表的形成
      直连网段:配置IP地址,端口UP状态,形成直连路由
      非直连网段:没有跟路由器直接连接的网段
    (路由器的每一个端口,都代表一个网段;有多少个端口,就有多少个不同网段,即多少个直连网段) 
    

    可以这么理解:对每一个路由器而言,长在路由器自己身上的,就是直连网段,没有长在自己身上,就是非直连网段
    3.对于非直连的网段,就需要静态路由或者动态路由,将网段添加到路由表中
    手动配上去的就是静态路由
    4.静态路由
    由管理员手工配置的,是单向的
    缺乏灵活性
    5.默认路由
    在这里插入图片描述
    当有且只有一条通往其他路由的路径,就是默认路由
    6.路由的优先级
    当路由表中同时存在静态路由和默认路由的时候,静态路由优先级最高,匹配上了就立刻进行转发;
    如果没有匹配上静态路由,则按照默认路由进行转发

    四、路由器转发数据包的封装过程

    在这里插入图片描述
    1.主机A不知道路由器A的E0端口网卡号,数据无法封装,所以此时主机A发送ARP广播帧给路由A的E0接口(广播帧的源IP和源MAC都是主机A,目标IP是路由A的E0端口的IP,目标MAC是FF-FF-FF-FF-FF-FF);
    2.路由A通过E0端口接收到广播帧,发现目标MAC是FF-FF-FF–FF-FF-FF,便会拆开MAC头部,发现目标IP是自己,便会对这个广播帧进行反馈,即以单播的形式发单播帧(源IP地址是192.168.1.1,源MAC地址:00-11-12-21-22-22(以下简称22)目标IP地址192.168.1.2,目标MAC是11)给主机A,并且把主机A的MAC地址记录在自己的MAC表中,主机A接受到了MAC地址,便满足四要素,把路由A的E0MAC地址记录在自己的MAC表中,可以开始进行数据帧的传输。主机A把目标MAC地址补上,发送给路由A;
    3.路由A从E0端口接收到这个数据帧,查看目标MAC发现是自己,便会拆开MAC头部,露出IP地址,查看目标IP所在网段,与自己的路由表对比,找到对应的接口E1,开始进行MAC封转发,源IP地址主机A,源MAC地址是路由A的E1端口的MAC地址00-11-12-21-33-33(以下简称33),目标IP是主机B,目标MAC是路由B的E1端口的MAC地址;但是因为第一次连接,路由A的mac地址表并没有路由B的E1端口的MAC地址,也就没有相应的目标地址,所以会丢弃这次的数据;
    4.路由A此时察觉到自己没有路由B的E1接口的MAC地址,便会主动对其发送ARP广播,广播帧中源IP和源MAC地址是自己,目标IP是路由B的E1接口的IP地址,目标MAC是FF-FF-FF-FF-FF-FF。路由B收到这个广播帧,发现目标MAC是FF-FF-FF-FF-FF-FF,便会对MAC头部进行拆开,并学习记录源MAC地址(即路由A的E1端口的MAC地址),发现里面的目标IP地址是自己,便会对这个广播帧进行反馈,即以单播的形式发单播帧(源IP地址是10.1.1.2,源MAC地址:00-11-12-21-33-33(以下简称33)目标IP地址10.1.1.1,目标MAC是00-11-12-21-33-33)发给路由A的E1端口;
    5.路由A此时查看广播帧,得到了路由B的E1接口的MAC地址,便会记录在自己的MAC表中。这时主机A发送的第二个PING包又发了过来,因为此时路由A知道了路由B的E1接口的MAC地址,满足四要素,会很顺畅的发送到路由B的E1端口。路由B的E1接口查看目标MAC是自己,便会拆开,露出目标IP地址。路由B将IP地址192.168.2.2对照自己的路由表得出对应得网段接口为E0,变会对数据进行封装处理;因为是第一次连接,所以路由B并不知道主机B的MAC地址,所以操作无法执行,第二个PING包便会在这里被丢弃;
    6.路由B为了以后可以正常通信便会发送广播帧(源IP地址是192.168.2.1,源MAC地址:00-11-12-21-55-55,目标IP地址192.168.2.2,目标MAC地址FF-FF-FF-FF-FF-FF)给主机B,主机B接收到这个广播帧,记录源MAC地址,还会把MAC头部拆掉,发现目标IP地址是自己,便会单播发出一个单薄帧(源IP地址是192.168.2.2,源MAC地址:00-11-12-21-66-66目标IP地址192.168.2.1,目标MAC是00-11-12-21-55-55)回应。
    7.路由B此时接收到单播帧,便会记录源MAC地址,即主机B的MAC地址,此时第三个PING也到了,路由B此时满足四要素,便可以把PING包转发给主机B,主机B接收到在发回去,便互联互通了。

    在这里插入图片描述

    五、静态路由和默认路由的配置

    在这里插入图片描述

    展开全文
  • 目录前言一、路由原理1.1 路由器的工作原理1.2 路由表的形成二、静态路由和默认路由2.1 静态路由2.2 默认路由2.3 浮动路由(备份路由)2.4 路由器转发数据包的封装过程.三、静态路由和默认路由的配置 前言 路由表...
  • 静态路由原理与配置 文章目录静态路由原理与配置一、 路由1.路由原理2.路由器的工作原理3.路由表的形成二、静态路由和默认路由1.静态路由2.默认路由3.路由转发数据包的原理4.交换与路由对比三、静态路由和默认路由的...
  • es文档路由原理

    2020-05-16 19:19:44
    es文档路由原理
  • 03、路由原理

    2020-02-28 22:39:36
    路由原理一、路由器与路由1、路由器2、路由二、路由原理1、路由表概述2、路由表路由条目的类型3、(自带路由类型)路由优先级与管理值4、与路由表相关的指令5、路由原理6、路由环路7、浮动路由 一、路由器与路由 1、...
  • vue前端路由原理

    2021-03-04 10:31:34
    前言:看完此文章,让你对前端路由原理有一个比较深的了解,必能掌握路由原理,面试必过 路由实现原理 通过改变URL,在不重新请求页面的情况下,更新页面视图 前端路由的两种模式 Hash------默认值,利用 URL 中...
  • 文章目录一、路由原理1.路由的概述二、路由器的工作原理三、路由表的形成 1.路由表 2.路由表的形成四、静态路由和默认路由1.静态路由2.默认路由五、路由器转发数据包的封装过程 一、路由原理 1.路由的概述 路由:...
  • 静态路由原理与配置

    2021-03-09 19:46:12
    这里静态路由原理与配置一、路由原理1、路由器的工作原理2、路由表的形成二、静态路由和默认路由1、静态路由2、默认路由3、路由器转发数据包的封装过程三、静态路由和默认路由的配置1、静态路由配置命令2、静态路由...
  • 前端路由原理

    2019-09-16 20:37:59
    前端路由原理 1.什么是路由 简单来说,假如我们有一台提供 Web 服务的服务器的网络地址是:10.0.0.1,而该 Web 服务又提供了三个可供用户访问的页面,其页面 URI 分别是: http://10.0.0.1/ http://10.0.0.1/about ...
  • 1.路由原理 1)什么是路由 数据从一个网络到另外一个网络的路径 路由的设备是路由器 路由器可以选择最佳路径来路由数据包 2)路由器工作原理 根据路由表转发数据包 Destination/Mask NextHop Interface 路由条目 ...
  • 文章目录前言单一链路存在的问题HSRP是思科的私有协议HSRP (热备份路由选择协议)介绍VRRP浮动路由原理Master路由器选举原理浮动路由原理实验详解实验目的实验过程主机设置交换机设置LSW1三层交换机配置LSW2配置...
  • 主要介绍了thinkphp5框架路由原理与用法,结合图文与实例形式详细分析了thinkPHP5框架路由的相关原理、使用方法及操作注意事项,需要的朋友可以参考下

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,772
精华内容 4,708
关键字:

路由原理