精华内容
下载资源
问答
  • H3C VRRP配置案例

    2012-12-11 11:29:18
    主机A把路由器A和路由器B组成的VRRP备份组作为自己的缺省网关,访问Internet上的主机B。
  • VRRP的基本配置(以H3C模拟器为例)

    万次阅读 2017-01-03 20:34:04
    VRRP的基本配置: ...[H3C]sys S1 [S1]vlan 10 [S1-vlan10]port g1/0/1 [S1-vlan10]vlan 20 [S1-vlan20]port g1/0/2 [S1-vlan20]vlan 30 [S1-vlan30]port g1/0/3 [S1-vlan30]vlan 40 [S1-vlan40]port g

    VRRP的基本配置:

     

    S1:

    <H3C>sys

    [H3C]sys S1

    [S1]vlan 10

    [S1-vlan10]port g1/0/1

    [S1-vlan10]vlan 20

    [S1-vlan20]port g1/0/2

    [S1-vlan20]vlan 30

    [S1-vlan30]port g1/0/3

    [S1-vlan30]vlan 40

    [S1-vlan40]port g1/0/4

    [S1-vlan40]int range g1/0/5 to g1/0/6

    [S1-if-range]port link-type trunk

    [S1-if-range]port trunk permit vlan all

    [S1-if-range]qu

    S2:

    [S2]vlan 10

    [S2-vlan10]vlan 20

    [S2-vlan20]vlan 30

    [S2-vlan30]vlan 40

    [S2-vlan40]int vlan 10

    [S2-Vlan-interface10]ip ad 192.168.10.1 24

    [S2-Vlan-interface10]vrrp vrid 10 virtual-ip 192.169.10.254

    [S2-Vlan-interface10]vrrp vrid 10 priority 110

    [S2-Vlan-interface10]vrrp vrid 10 preempt-mode delay 5

    [S2-Vlan-interface10]int vlan 20

    [S2-Vlan-interface20]ip ad 192.168.20.1 24

    This subnet overlaps with another interface!

    [S2-Vlan-interface20]vrrp vrid 10 virtual-ip 192.169.20.254

    [S2-Vlan-interface20]vrrp vrid 10 priority 110

    [S2-Vlan-interface20]vrrp vrid 10 preempt-mode delay 5

    [S2-Vlan-interface20]int vlan 30

    [S2-Vlan-interface30]ip ad 192.168.30.1 24

    [S2-Vlan-interface30]vrrp vrid 10 virtual-ip 192.169.30.254

    [S2-Vlan-interface30]vrrp vrid 10 priority 100

    [S2-Vlan-interface30]vrrp vrid 10 preempt-mode delay 5

    [S2-Vlan-interface30]int vlan 40

    [S2-Vlan-interface40]ip ad 192.168.40.1 24

    [S2-Vlan-interface40]vrrp vrid 10 virtual-ip 192.169.40.254

    [S2-Vlan-interface40]vrrp vrid 10 priority 100

    [S2-Vlan-interface40]vrrp vrid 10 preempt-mode delay 5

    [S2-Vlan-interface40]qu

    验证vrrp冗余网关是否配置成功

    [S2]dis vrrp

    IPv4 Virtual Router Information:

     Running mode      : Standard

     Total number of virtual routers : 4

     Interface          VRID  State        Running Adver   Auth     Virtual

                                           Pri     Timer   Type        IP

     ---------------------------------------------------------------------

     Vlan10             10    Initialize   110     100     None     192.169.10.254

     Vlan20             10    Initialize   110     100     None     192.169.20.254

     Vlan30             10    Initialize   100     100     None     192.169.30.254

     Vlan40             10    Initialize   100     100     None     192.169.40.254

    S3:

    <H3C>sys

    [H3C]sys S3

    [S3]vlan 10

    [S3-vlan10]vlan 20

    [S3-vlan20]vlan 30

    [S3-vlan30]vlan 40

    [S3-vlan40]int vlan 10

    [S3-Vlan-interface10]ip ad 192.168.10.2 24

    [S3-Vlan-interface10]vrrp vrid 10 virtual-ip 192.169.10.254

    [S3-Vlan-interface10]vrrp vrid 10 priority 100

    [S3-Vlan-interface10]vrrp vrid 10 preempt-mode delay 5

    [S3-Vlan-interface10]int vlan 20

    [S3-Vlan-interface20]ip ad 192.168.20.2 24

    [S3-Vlan-interface20]vrrp vrid 10 virtual-ip 192.169.20.254

    [S3-Vlan-interface20]vrrp vrid 10 priority 100

    [S3-Vlan-interface20]vrrp vrid 10 preempt-mode delay 5

    [S3-Vlan-interface20]int vlan 30

    [S3-Vlan-interface30]ip ad 192.168.30.2 24

    [S3-Vlan-interface30]vrrp vrid 10 virtual-ip 192.169.30.254

    [S3-Vlan-interface30]vrrp vrid 10 priority 110

    [S3-Vlan-interface30]vrrp vrid 10 preempt-mode delay 5

    [S3-Vlan-interface30]int vlan 40

    [S3-Vlan-interface40]ip ad 192.168.40.2 24

    [S3-Vlan-interface40]vrrp vrid 10 virtual-ip 192.169.40.254

    [S3-Vlan-interface40]vrrp vrid 10 priority 110

    [S3-Vlan-interface40]vrrp vrid 10 preempt-mode delay 5

    [S3-Vlan-interface40]qu

    [S3]dis vrrp

    IPv4 Virtual Router Information:

     Running mode      : Standard

     Total number of virtual routers : 4

     Interface          VRID  State        Running Adver   Auth     Virtual

                                           Pri     Timer   Type        IP

     ---------------------------------------------------------------------

     Vlan10             10    Initialize   100     100     None     192.169.10.254

     Vlan20             10    Initialize   100     100     None     192.169.20.254

     Vlan30             10    Initialize   110     100     None     192.169.30.254

     Vlan40             10    Initialize   110     100     None     192.169.40.254

     

    展开全文
  • 7506E与CISCO交换机MSTP协议对接配置 一、 组网需求: 安徽某客户要求我司75E交换机与CISCO交换机MSTP协议对接,并具备防环和链路备份功能。...目前2台75E和FW插卡没有开启STP协议,3台CISCO交换机运行PVST协议

    7506E与CISCO交换机MSTP协议对接配置

    一、 组网需求:

    安徽某客户要求我司75E交换机与CISCO交换机MSTP协议对接,并具备防环和链路备份功能。

    二、 组网图:
    在这里插入图片描述

    客户网络架构如下图,两台75E各配置一块安全插卡,所有PC网关设置在FW插卡上,安全插卡划分子接口方式。两台75E作为网络核心交换机,通过vlan-interface Vlan100三层接口与3750互联。通过trunk方式与接入层2960交换机互联。目前2台75E和FW插卡没有开启STP协议,3台CISCO交换机运行PVST协议。

    图片

    三、 配置步骤:

    75E-1设备:

    //开启STP协议,并将STP配置为mstp模式

    stp enable

    stp mode mstp

    //配置MSTP实例,在这台交换机上将instance 0 设置为主

    stp region-configuration

    region-name h3c

    revision-level 1

    instance 0 vlan 1 to 4094

    active region-configuration

    stp instance 0 root primary

    //配置与CISCO设备对接时需要修改的参数

    stp bpdu-protection

    stp pathcost-standard dot1t

    stp timer-factor 1

    stp no-agreement-check

    stp config-digest-snooping

    //接口基本配置,并开启摘要侦听功能

    interface GigabitEthernet5/0/1

    port link-mode bridge

    port access vlan 100

    stp config-digest-snooping

    interface GigabitEthernet5/0/4

    port link-mode bridge

    port link-type trunk

    port trunk permit vlan all

    stp config-digest-snooping

    interface GigabitEthernet5/0/5

    port link-mode bridge

    port link-type trunk

    port trunk permit vlan all

    speed 1000

    duplex full

    stp config-digest-snooping

    75E-2设备:

    //开启STP协议,并将STP配置为mstp模式

    stp enable

    stp mode mstp

    //配置MSTP实例,在这台交换机上将instance 0 设置为备

    stp region-configuration

    region-name h3c

    revision-level 1

    instance 0 vlan 1 to 4094

    active region-configuration

    stp instance 0 root secondary

    //配置与CISCO设备对接时需要修改的参数

    stp bpdu-protection

    stp pathcost-standard dot1t

    stp timer-factor 1

    stp no-agreement-check

    stp config-digest-snooping

    //接口基本配置,并开启摘要侦听功能

    interface GigabitEthernet5/0/1

    port link-mode bridge

    port access vlan 100

    stp config-digest-snooping

    interface GigabitEthernet5/0/4

    port link-mode bridge

    port link-type trunk

    port trunk permit vlan all

    stp config-digest-snooping

    interface GigabitEthernet5/0/5

    port link-mode bridge

    port link-type trunk

    port trunk permit vlan all

    speed 1000

    duplex full

    stp config-digest-snooping

    安全插卡:

     因为安全插卡运行在三层模式,所以不需要开启STP协议。
    

    3750配置:

    //将STP配置mst模式,并将pathcost配置long

    spanning-tree mode mst

    spanning-treee pathcost method long

    //配置mst实例

    spanning-tree mst configuration

    name h3c

    revision 1

    instance 0 vlan 1-4094

    //接口基本配置,并配置MST开销值为20000

    interface g1/0/27

    switchport access vlan 100

    switchport mode access

    spanning-tree mst 0 cost 20000

    interface g1/0/28

    switchport access vlan 100

    switchport mode access

    spanning-tree mst 0 cost 20000

    2960-1配置:

    //将STP配置mst模式,并将pathcost配置long

    spanning-tree mode mst

    spanning-treee pathcost method long

    //配置mst实例

    spanning-tree mst configuration

    name h3c

    revision 1

    instance 0 vlan 1-4094

    //接口基本配置,并配置MST开销值为20000

    interface g1/0/49

    switchport trunk allowed vlan 2,10

    switchport mode trunk

    spanning-tree mst 0 cost 20000

    interface g1/0/51

    switchport access vlan 100

    switchport mode access

    spanning-tree mst 0 cost 20000

    2960-2配置:

    //将STP配置mst模式,并将pathcost配置long

    spanning-tree mode mst

    spanning-treee pathcost method long

    //配置mst实例

    spanning-tree mst configuration

    name h3c

    revision 1

    instance 0 vlan 1-4094

    //接口基本配置,并配置MST开销值为20000

    interface g1/0/49

    switchport trunk allowed vlan 2,10

    switchport mode trunk

    spanning-tree mst 0 cost 20000

    interface g1/0/51

    switchport access vlan 100

    switchport mode access

    spanning-tree mst 0 cost 20000

    四、 配置关键点:

    配置3750交换机为MST模式后,G1/0/27端口转发数据,G1/0/28端口处于阻塞状态,MSTP协议运行正常。当配置2960-1交换机为MST模式后,2960-1交换机上联到75E的两个端口都会处于阻塞状态。拔掉其中一根网线后,剩余一个端口还是处于阻塞状态。将2960-2交换机配置为mst模式或者关闭stp协议,2960-1两端口状态就正常了,一个转发数据,一个处于阻塞状态。当网络中有多台cisco交换机,并且都是通过trunk方式说核心互联时,要先将运行PVST的cisco设备隔离或者关闭STP协议,然后逐一配置为mst模式。因为CISCO交找机运行mst模式时收到pvst BPDU报文时会将收到此报文的端口置于阻塞状态。此案例中3750与75E是三层互联,3750收不到PVST BPDU报文,所以3750不会被2960交换机PVST报文影响。

    S8500交换机和Cisco交换机的MSTP对接注意事项

    一、各自支持的STP协议种类

    我司S8500交换机支持的STP协议:

    S8500交换机支持标准的STP、RSTP和MSTP,其中MSTP在不启用多实例时基本等同与RSTP。

    Cisco支持的STP协议:

    Cisco支持PVST、PVST+、MISTP和MSTP。

    二、MSTP互连对接测试

    S8500交换机可以与Cisco的PVST+和MSTP进行对接,其它几个协议不能对接。但是由于Cisco的MSTP实现不规范,S8500上需要特别的配置,说明如下:

    按照协议规定,stp region-configuration的配置通过MD5摘要算法得到一个值,交换机之间通过比较这个值来确定是否属于同一个域。

    如果stp region-configuration的配置完全一致,则结果必然一致,属于同一个域。

    由于cisco的MD5算法与协议规定的不一致,导致相同的stp region-configuration配置与H3C设备的结果不一致。

    可以通过配置下面2条命令分别在全局和与cisco相连接的端口下来达到mstp的互通。

    [S1]stp config-digest-snooping

    [S1]int e8/1/1

    [S1-Ethernet8/1/1]stp config-digest-snooping

    展开全文
  • 备受业界关注,备受无数读者殷切期待的,我的2012年新作——《Cisco/H3C交换机高级配置与管理技术手册》,经过一年的艰辛编写,现终于胜利封笔。现应许多热心读者的要求,把本书的原始目录和前言发布如下,本书将于...

    备受业界关注,备受无数读者殷切期待的,我的2012年新作——《Cisco/H3C交换机高级配置与管理技术手册》,经过一年的艰辛编写,现终于胜利封笔。现应许多热心读者的要求,把本书的原始目录和前言发布如下,本书将于2012年3月份出版上市,敬请关注与支持!

    目前该书已可在当当网上预订了:http://product.dangdang.com/product.aspx?product_id=22621538

    目录

    第一篇 交换机高可用性配置与管理 1
    第1章 Cisco IOS交换机 集群配置与管理 2
    1.1  Cisco IOS交换机集群基础 3
    1.1.1  Cisco交换机集群基础 3
    1.1.2  Cisco交换机集群命令和备用命令交换机特征 4
    1.1.3  候选交换机和集群成员交换机特征 5
    1.2  Cisco IOS交换机集群规划 5
    1.2.1  集群候选交换机和成员的自动发现方案规划 5
    1.2.2  HSRP和备用集群命令交换机规划 9
    1.2.3 交换机集群的IP地址规划 11
    1.2.4  交换机集群的主机名规划 12
    1.2.5  交换机集群的密码规划 12
    1.2.6  交换机集群和交换机堆叠的比较 13
    1.3 使用CLI配置Cisco IOS交换机集群 14
    1.3.1 通过CLI创建和管理Cisco IOS交换机集群 14
    1.3.2 通过CLI创建命令交换机备用组 18
    1.3.3  通过CLI添加成员交换机到备用组 20
    1.4 使用CMS配置Cisco IOS交换机集群 20
    1.4.1  用集群管理程序创建集群 21
    1.4.2  通过CMS向交换机集群中添加成员交换机 28
    1.5 Cisco IOS交换机集群管理 31
    1.5.1 通过CMS管理集群的基本设置 32
    1.5.2 通过CMS改变集群管理VLAN 34
    1.5.3 通过CMS监控和配置端口 35
    1.5.4 通过CMS显示集群VLAN成员 39
    1.5.5 更新集群中的交换机系统软件 40
    1.5.6 通过CLI管理交换机集群 43
    1.5.7 通过CLI恢复失效的命令交换机 44
    第2章 Cisco IOS交换机HSRP和VRRP配置与管理 46
    2.1理解HSRP 48
    2.1.1 HSRP概述 48
    2.1.2 HSRP工作原理 49
    2.1.3 MHSRP 51
    2.1.4 HSRP认证 52
    2.1.5 HSRP消息和状态 52
    2.1.6 HSRP的ICMP重定向支持 53
    2.2 Cisco IOS交换机HSRP配置与管理 55
    2.2.1 默认HSRP配置和配置指南 55
    2.2.2 启用HSRP 56
    2.2.3 HSRP优先级和接口跟踪配置 58
    2.2.4 用于负载分担的MHSRP配置 61
    2.2.5 HSRP认证和计时器配置 62
    2.2.6 HSRP ICMP重定向配置 65
    2.2.7 HSRP备份组和集群配置 67
    2.3 Cisco IOS交换机VRRP基础 68
    2.3.1 VRRP基本特性 68
    2.3.2 主要VRRP特性概述 69
    2.3.3 VRRP基本工作原理 70
    2.4 Cisco IOS交换机VRRP配置与管理 71
    2.4.1 启用VRRP 71
    2.4.2 VRRP组基本属性配置与管理 74
    2.4.3 VRRP认证配置与管理 75
    2.4.4 VRRP对象跟踪配置 76
    2.5 Cisco IOS交换机VRRP配置示例 78
    2.5.1 VRRP综合配置示例 78
    2.5.2 对象跟踪配置示例 79
    2.5.3 VRRP认证配置示例 80
    第3章 H3C交换机集群配置与管理 81
    3.1  H3C以太网交换机的集群配置与管理 82
    3.1.1  H3C以太网交换机集群简介 82
    3.1.2 H3C交换机在集群中的交换机角色 84
    3.1.3  H3C交换机集群配置任务 86
    3.2 H3C集群管理交换机配置 86
    3.2.1  NDP的启用 87
    3.2.2 NDP参数配置 87
    3.2.3 NTDP的启用 88
    3.2.4 NTDP参数配置 89
    3.2.5交换机集群功能启用 91
    3.2.6  H3C交换机集群参数配置 91
    3.2.7  H3C交换机集群内外交互配置 95
    3.2.8集群管理网管接口配置 96
    3.3 H3C交换机集群成员交换机配置 96
    3.4 H3C交换机集群管理 98
    3.4.1 H3C交换机集群基本管理操作 98
    3.4.2  H3C交换机集群信息管理 101
    3.5 H3C交换机集群配置示例 107
    第4章 H3C交换机VRPP 配置与管理 111
    4.1 H3C交换机VRRP基础 113
    4.1.1 VRRP简介 113
    4.1.2 VRRP的路由器标识、控制报文、认证和Master选举 114
    4.1.3 VRRP工作原理 115
    4.1.4 VRRP的两种应用模式 116
    4.1.5 VRRP与HSRP的比较 118
    4.2 H3C交换机的VRRP负载均衡模式 118
    4.2.1  负载均衡模式下的虚拟MAC地址分配 119
    4.2.2  负载均衡模式下的虚拟转发器 120
    4.2.3  VRRP负载均衡模式的报文 122
    4.3  H3C交换机VRRP配置 123
    4.3.1 VRRP工作模式配置 123
    4.3.2 H3C交换机VRRP基本功能配置 124
    4.3.3 H3C交换机VRRP高级功能配置 126
    4.4 H3C交换机VRRP管理 131
    4.5 H3C交换机VRRP配置示例 135
    4.5.1 简单主备备份模式的VRRP应用配置示例 135
    4.5.2 综合主备备份模式的VRRP应用配置示例 137
    4.5.3  负载分担模式VRRP应用配置示例 139
    4.5.4  VRRP负载均衡模式配置示例 142
    第二篇 ACL和QoS配置与管理 150
    第5章 Cisco IOS交换机 ACL配置与管理 151
    5.1  Cisco ACL基础 152
    5.1.1  ACL概述 152
    5.1.2  ACL的应用 153
    5.1.3  Cisco IOS交换机中ACL的应用类型 154
    5.2  Cisco IOS交换机基于列表号的ACL创建 157
    5.2.1 Cisco IOS交换机ACL配置原则和经验 157
    5.2.2 基于列表号的标准IPv4 ACL创建 158
    5.2.3 基于列表号的扩展IPv4 ACL创建 161
    5.3  基于名称的Cisco IOS交换机IPv4 ACL创建 165
    5.3.1  基于名称的标准IPv4 ACL创建 165
    5.3.2  基于名称的扩展IPv4 ACL创建 167
    5.3.3  基于名称的扩展MAC ACL创建 167
    5.4 Cisco IOS交换机上的ACL应用 170
    5.4.1 应用IPv4 ACL到终端线路 170
    5.4.2 应用IPv4 ACL到接口 171
    5.4.3  应用MAC ACL到二层接口 173
    5.4.4 IPv4 ACL的注释功能 174
    5.4.5 IPv4 ACL配置综合示例 174
    5.5 Cisco IOS交换机VACL配置 176
    5.5.1  VACL简介 176
    5.5.2  VACL的创建和删除 177
    5.5.3  应用VACL到VLAN中 180
    5.5.4  检验VACL配置 181
    5.5.5 Cisco IOS交换机VACL配置示例 182
    5.5.6 VLAN间访问控制ACL与VACL配置比较示例 184
    5.6  Cisco基于时间的ACL及配置 185
    5.6.1  Cisco基于时间的ACL语法格式 185
    5.6.2  Cisco基于时间的ACL配置示例 186
    5.7 PACL、RACL和VACL的交互作用 188
    5.7.1 PACL、RACL和VACL交换作用规则 188
    5.7.2 PACL、RACL和VACL交互作用的典型情形 189
    第6章 Cisco IOS交换机QoS配置与管理 192
    6.1 QoS基础 194
    6.1.1 QoS简介 194
    6.1.2 基本的QoS模型 195
    6.2 QoS的通信流分类原理 196
    6.2.1 QoS通信流的优先级 196
    6.2.2 QoS分类流程 199
    6.2.3 基于QoS ACL的分类 201
    6.2.4 基于分类映射和策略映射的分类 202
    6.3 QoS的流量监管和标记原理 203
    6.3.1 物理接口上的监管和标记 203
    6.3.2 SVI接口上的监管和标记 205
    6.3.3 QoS令牌桶的工作原理 206
    6.4 QoS的列队和调度原理 208
    6.4.1 活动队列管理 209
    6.4.2 QoS拥塞管理技术 210
    6.4.3 QoS拥塞避免技术 211
    6.4.3 QoS SRR流量整形原理 213
    6.4.5 QoS中的队列和调度流程 214
    6.5 Cisco IOS交换机QoS的启用 215
    6.5.1 在全局/端口上启用QoS 216
    6.5.2 在物理端口上启用基于VLAN的QoS 216
    6.5.3 全局启用QoS后的默认配置 218
    6.6 Cisco IOS交换机的DSCP映射配置 221
    6.6.1 配置CoS到DSCP的映射 221
    6.6.2 配置IP优先级到DSCP的映射 222
    6.6.3 配置监管DSCP映射 223
    6.6.4 配置DSCP到CoS映射 224
    6.6.5 配置DSCP到DSCP转换映射 225
    6.7 使用端口信任状态配置流分类 227
    6.7.1 配置QoS域内的端口信任状态 227
    6.7.2 为端口配置默认CoS值 229
    6.7.3 启用交换机的DSCP透明模式 230
    6.7.4 在QoS域边界端口上配置DSCP信任状态 231
    6.8 Cisco IOS交换机QoS策略配置 233
    6.8.1 Cisco IOS交换机QoS配置指南 233
    6.8.2 使用分类映射来进行流分类 234
    6.8.3 使用策略映射在物理端口上分类、监管和标记流 236
    6.8.4 通过分级策略映射在SVI接口上分类、监管和标记流 240
    6.8.5 使用聚合监管器分类、监管和标记流 244
    6.8.5 通过使用分类映射进行流分类和IPv6流 246
    6.9 入口队列特性配置 248
    6.91映射DSCP或者CoS值到入口队列,并设置WTD阈值 248
    6.9.2 为入口队列分配缓存空间 249
    6.9.3 为入口队列分配带宽 249
    6.9.4 入口优先级队列和最低保证带宽权重配置 250
    6.10 出口队列特性配置 250
    6.10.1为出口队列集分配缓存空间,设置WTD阈值 251
    6.10.2 映射DSCP或者CoS值到出口队列和阈值 253
    6.10.3出口队列上的SRR整形和共享权重配置 254
    6.10.4 出口加速队列配置 256
    6.10.5 出口带宽限制(端口限速)配置 257
    6.11 Cisco IOS交换机自动QoS配置 257
    6.11.1  自动QoS配置的生成 257
    6.11.2 VoIP设备的自动QoS配置 260
    6.11.3  增强版本自动QoS配置 261
    6.11.4 自动QoS配置指南 261
    6.11.5 启用自动QoS 262
    6.11.6 全局自动QoS配置 263
    第7章 H3C交换机ACL 配置与管理 267
    7.1  H3C以太网交换机上的ACL基础 269
    7.1.1  H3C交换机上的ACL分类和编号/命名规则 269
    7.1.2 H3C交换机上的ACL规则匹配顺序 270
    7.2 H3C交换机上的ACL配置 271
    7.2.1 ACL生效时间段配置 272
    7.2.2  IPv4基本ACL配置 274
    7.2.3 IPv4高级ACL配置 276
    7.2.4  二层ACL配置 281
    7.2.5  定义用户自定义ACL配置 284
    7.2.6 ACL复制配置 287
    7.2.7 ACL的应用配置 287
    7.3 H3C交换机ACL配置管理 291
    7.4 H3C交换机ACL配置示例 296
    7.4.1  S7500系列交换机的基本ACL典型配置示例 296
    7.4.2  S7500系列交换机的高级ACL配置示例 297
    7.4.3  S7500系列交换机的二层ACL配置示例 297
    7.4.4  S7500系列交换机的用户自定义ACL配置示例 298
    第8章 H3C交换机QoS配置与管理 299
    8.1 H3C交换机QoS配置基础 301
    8.1.1 H3C交换机QoS配置方式 301
    8.1.2 QoS策略配置方式的基本配置流程 301
    8.1.3  定义流分类 302
    8.1.4  定义流行为 305
    8.1.5  定义QoS策略 306
    8.1.6  配置QoS策略应用 307
    8.1.7 QoS策略显示和维护 310
    8.2 H3C交换机报文优先级配置与管理 317
    8.2.1 H3C交换机报文优先级 317
    8.2.2 优先级映射配置 320
    8.2.3 优先级映射配置管理 321
    8.2.4  端口优先级应用配置示例 322
    8.3 H3C交换机流量监管、流量整形和端口限速配置与管理 323
    8.3.1流量监管、流量整形和端口限速简介 324
    8.3.2  流量监管配置 325
    8.3.3  流量整形配置 327
    8.3.4  端口限速配置 328
    8.3.5 流量整形和端口限速配置管理 329
    8.4 H3C交换机拥塞管理的配置与管理 329
    8.4.1  H3C交换机拥塞管理中的队列调度算法 330
    8.4.2  SP队列配置与管理 331
    8.4.3  WRR队列配置与管理 332
    8.4.4 WFQ队列调度配置与管理 334
    8.4.5 SP+WRR队列调度配置与管理 336
    8.5 H3C交换机拥塞避免配置与管理 337
    8.5.1 拥塞避免的丢包策略简介 337
    8.5.2 WRED策略下的拥塞避免配置与管理 338
    8.5.3  WRED配置信息的管理 340
    8.6 H3C交换机流量过滤配置与管理 341
    8.6.1 流量过滤配置与管理 342
    8.6.2  流量过滤配置示例 343
    8.7 H3C交换机重标记配置与管理 343
    8.7.1  优先级重标记简介 343
    8.7.2  通过报文颜色重标记优先级的配置与管理 344
    8.7.3 重标记本地优先级的配置示例 347
    8.7.4  重标记QoS本地ID的配置示例 349
    8.7.5  优先级映射表和重标记综合配置示例 350
    8.8 H3C交换机全局CAR策略配置与管理 352
    8.8.1  聚合/分层CAR策略简介 353
    8.8.2 聚合CAR策略的配置与管理 353
    8.8.3 分层CAR策略配置与管理 355
    8.8.4   聚合CAR配置示例 357
    8.8.5  And模式分层CAR配置示例 358
    8.8.6  Or模式配置示例 360
    8.9 H3C交换机流量统计配置与管理 361
    8.9.1 流量统计配置与管理 361
    8.9.2  流量统计配置示例 362
    8.10 H3C交换机数据缓冲区配置与管理 363
    8.10.1  缓冲资源的分配 364
    8.10.2  通过Burst功能配置数据缓冲区 365
    8.10.3  手工配置数据缓冲区 365
    第三篇 IP组播配置与管理 370
    第9章 IP组播基础 371
    9.1 IP组播基础 373
    9.1.1 IP网络的三种数据传输方式 373
    9.1.2 IP组播中的角色和主要应用 375
    9.1.3  典型IP组播模型 375
    9.1.4  IP组播地址 376
    9.2  IP组播原理 378
    9.2.1IP组播协议简介 379
    9.2.2  IP组播转发的RPF检查机制 380
    9.2.3 RPF检查在IP组播转发中的应用 381
    9.3  IGMP的三个版本及各自工作原理 383
    9.3.1  IGMPv1工作原理 384
    9.3.2  IGMPv2工作原理 385
    9.3.3  IGMPv3工作原理 387
    9.4 PIM工作原理 388
    9.4.1 PIM的两个版本及三种工作模式 388
    9.4.2 PIM –DM模式及工作原理 390
    9.4.3 PIM-SM模式及工作原理 392
    9.4.4 Bidir-PIM模式及工作原理 396
    9.4.5  PIM-SSM模式及工作原理 401
    9.5  MSDP工作原理 402
    9.5.1  MSDP对等体 402
    9.5.2 通过MSDP对等体实现域间组播 403
    9.5.3 SA消息的RPF检查规则 404
    9.5.4 通过任播RP实现负载分担和RP冗余 406
    9.6  IGMP Snooping 407
    9.6.1  IGMP Snooping基础 407
    9.6.2 IGMP Snooping工作原理 409
    9.6.3 组播VLAN 410
    第10章 Cisco IOS交换机IGMP和IGMP Snooping配置与管理 412
    10.1 Cisco IOS交换机IGMP配置 414
    10.1.1 IGMP特性的默认配置 415
    10.1.2 改变IGMP版本 415
    10.1.2 配置交换机作为组播组成员 416
    10.1.3 IP组播组的访问控制 418
    10.1.4 编辑IGMP主机查询消息发送时间间隔 419
    10.1.5 改变IGMPv2查询超时设置 420
    10.1.6 改变IGMPv2最大查询响应时间 420
    10.1.7 配置交换机作为静态连接组播成员 421
    10.1.8 使用扩展ACL控制SSM网络的访问 422
    10.2 Cisco IOS交换机IGMP代理配置 424
    10.2.1 UDLR简介 424
    10.2.2 IGMP代理 424
    10.2.3 IGMP代理配置 426
    10.2.4 IGMP代理配置示例 429
    10.3 Cisco IOS交换机IGMP管理 430
    10.4 Cisco IOS交换机IGMP Snooping配置 433
    10.4.1 IGMP snooping基础知识回顾 433
    10.4.2 Cisco IOS交换机上的IGMP snooping的启用与禁用 434
    10.4.3 IGMP snooping组播组嗅探配置 434
    10.4.4 主机静态加入到一个组播组 435
    10.4.5 启用IGMP立即离开功能 437
    10.4.6 IGMP离开计时器配置 438
    10.5.7 Cisco IOS交换机IGMP Snooping TCN相关配置 438
    10.4.8 IGMP Snooping查询器配置 439
    10.5 Cisco IOS交换机IGMP Snooping信息管理 441
    第11章 Cisco IOS交换机PIM组播配置与管理 444
    11.1 基本IP组播路由配置 445
    11.2带自动RP功能的PIM-SM组播配置 448
    11.2.1自动RP简介 448
    11.2.2带自动RP功能的PIM-SM组播配置与管理 449
    11.3 带任播RP功能的PIM-SM组播配置 455
    11.3.1 任播RP简介 455
    11.3.2 带任播RP功能的PIM-SM组播配置与管理 456
    11.3.3 带任播RP功能的PIM-SM组播配置示例 457
    11.4 带自举路由器的PIM-SM组播配置 458
    11.4.1 BSR基础知识回顾 459
    11.4.2 带BSR的PIM-SM组播配置与管理 459
    11.4.3 带BSR的PIM-SM组播配置示例 461
    11.5 带单一静态RP的PIM-SM组播 461
    11.5.1 RP基础知识回顾 461
    11.5.2 带单一静态RP的PIM-SM组播配置与管理 462
    11.5.3 带单一静态RP的PIM-SM组播配置示例 463
    11.6 PIM-SSM组播配置 463
    11.6.1 PIM-SSM基础知识回顾 463
    11.6.2 PIM-SSM组播配置与管理 464
    11.6.3 PIM-SMM组播配置示例 465
    11.7 Bidir-PIM组播配置 466
    11.7.1 Bidir-PIM组播配置与管理 466
    11.7.2 Bidir-PIM组播配置示例 467
    第12章 H3C交换机IGMP和 IGMP Snooping配置与管理 468
    12.1 H3C交换机三层IP组播的基本配置 470
    12.2 H3C交换机IGMP配置与管理 473
    12.2.1  启动IGMP 475
    12.2.2  IGMP运行版本配置 475
    12.2.3配置接口静态加入组播组或组播源 476
    12.2.4 配置接口加入的组播组过滤器 477
    12.2.5  配置接口允许加入的组播组数量限制 477
    12.2.6  IGMP查询和响应配置 478
    12.2.7  IGMP SSM映射配置 481
    12.2.8 IGMP代理配置 483
    12.2.9 IGMP管理 485
    12.2.10  H3C交换机IGMP基本功能配置示例 495
    12.2.11  IGMP SSM映射功能配置示例 496
    12.2.12  IGMP代理功能配置示例 499
    12.3  H3C交换机IGMP Snooping基本功能配置 501
    12.3.1  启动IGMP Snooping 501
    12.3.2  IGMP Snooping版本配置 502
    12.3.3  静态组播MAC地址表项配置 502
    12.4 H3C交换机IGMP Snooping端口功能配置 503
    12.4.1  IGMP Snooping相关定时器配置 503
    12.4.2  静态端口配置 505
    12.4.3  静态端口配置示例 506
    12.4.4  禁止端口成为动态路由器端口 509
    12.4.5 模拟主机加入配置 510
    12.5  H3C交换机IGMP Snooping查询器配置 511
    12.5.1  启用IGMP Snooping查询器 511
    12.5.2  IGMP查询报文发送时间间隔和最大响应时间配置 511
    12.5.3  IGMP查询报文源IP地址配置 513
    12.5.4  IGMP Snooping查询器配置示例 514
    12.6  H3C交换机IGMP Snooping代理配置 516
    12.6.1 IGMP Snooping代理配置 516
    12.6.2  IGMP Snooping代理配置示例 517
    12.7  H3C交换机IGMP Snooping策略配置 520
    12.7.1 组播组过滤器配置 520
    12.7.2  组策略及模拟主机加入配置示例 521
    12.7.3  组播数据报文源端口过滤配置 522
    12.7.4  丢弃未知组播数据报文配置 523
    12.7.5  端口加入的组播组最大数量配置 524
    12.7.6  IGMP报文的802.1p优先级配置 524
    12.7.7  组播用户控制策略配置 525
    12.7.8  组播源与组播用户控制策略配置示例 526
    12.8  H3C交换机IGMP Snooping配置管理 530
    第13章 H3C交换机PIM组播配置与管理 531
    13.1  H3C交换机PIM公共特性配置 533
    13.1.1 组播数据过滤器配置 533
    13.1.2  Hello报文过滤器配置 534
    13.1.3  Hello报文选项配置 534
    13.1.4 剪枝延迟时间配置 537
    13.1.5  PIM公共定时器配置 537
    13.1.6  PIM配置管理 539
    13.2  H3C交换机PIM-DM组播网络配置 540
    13.2.1 启动PIM-DM 540
    13.2.2  PIM-DM配置示例 541
    13.3 H3C交换机PIM-SM组播网络配置与管理 543
    13.3.1  启动PIM-SM 544
    13.3.2  PIM-SM域RP配置 545
    13.3.3  PIM-SM域BSR配置 548
    13.3.4  PIM-SM管理域配置 551
    13.3.5 PIM-SM域组播源注册配置 554
    13.3.6 禁止SPT切换 555
    13.3.7  非管理域机制PIM-SM配置示例 556
    13.3.8  管理域机制下的PIM-SM配置示例 562
    13.4  H3C交换机双向PIM与管理 567
    13.4.1 双向PIM与PIM-SM配置的主要区别 569
    13.4.2 非管理域机制下的双向PIM配置示例 570
    13.5 H3C交换机PIM-SSM配置 575
    13.5.1  启用PIM-SM 575
    13.5.2  SSM组播组范围配置 575
    13.5.3  PIM-SSM配置示例 576
    第四篇 交换机端口监控和安全管理 579
    第14章 Cisco IOS交换机端口镜像配置与管理 580
    14.1  SPAN/RSPAN基础 581
    14.1.1  SPAN监控原理 581
    14.1.2  SPAN术语 582
    14.1.3  SPAN和RSPAN关键特性 584
    14.1.4  本地SPAN和远程SPAN概述 586
    14.1.5  本地SPAN和RSPAN会话 587
    14.1.6  监控通信 588
    14.2  Catalyst Express 500中的SPAN配置 588
    14.3  Catalyst 2900XL/3500XL交换机的SPAN配置 590
    14.4  Catalyst 8500交换机的SPAN配置 591
    14.5  CatOS系统交换机上的SPAN配置 592
    14.5.1  本地SPAN配置 592
    14.5.2  中继端口上的本地SPAN的配置 595
    14.5.3  多个并发本地SPAN会话的配置 597
    14.5.4  远程SPAN的配置示例 599
    14.5.5  功能汇总和限制 601
    14.6  中低端IOS系统交换机上的SPAN配置 602
    14.6.1  Catalyst 2940/2950/2955交换机的SPAN配置 602
    14.6.2  Catalyst 2950/2955交换机的RSPAN配置 605
    14.6.3  Catalyst 2960/2970/3560/3560/3750等系列交换机的SPAN配置 607
    14.6.4  Catalyst 2960/2970/3560/3750等系列交换机的RSPAN配置 611
    14.6.5  Catalyst 3550交换机的SPAN配置 616
    14.6.6  Catalyst 3550交换机的RSPAN配置 620
    14.7  IOS系统Catalyst 4000/4500/6500/6000系列交换机上的SPAN配置 624
    14.7.1  IOS系统Catalyst 4000/4500系列交换机的SPAN配置 624
    14.7.2  IOS系统Catalyst 4000/4500系列交换机的RSPAN配置 628
    14.7.3  IOS系统Catalyst 6500/6000系列交换机本地SPAN和RSPAN配置 632
    第15章 Cisco IOS交换机基于端口的安全配置与管理 636
    15.1 Cisco IOS交换机端口保护功能及其配置 637
    15.1.1 端口保护功能简介 637
    15.1.2 端口保护功能配置 637
    15.2 Cisco IOS交换机端口阻塞功能及配置 638
    15.3 Cisco IOS交换机端口安全配置与管理 639
    15.3.1 端口安全功能简介 639
    15.3.2 端口安全配置注意事项 641
    8.3.3 在访问端口上配置端口安全 643
    15.3.4 在PVLAN端口上配置端口安全 647
    15.3.5 在中继端口上配置端口安全 650
    15.3.6 端口模式改变对端口安全配置的影响 652
    15.4 Cisco IOS交换机上的端口安全配置管理 653
    第16章 Cisco IOS交换机基于交换机的安全配置与管理 657
    16.1 阻止未授权用户访问你的交换机 659
    16.1.1特权模式访问保护配置 659
    16.1.2配置多个特权级别 663
    16.2 TACACS+基础 665
    16.2.1 TACACS+简介 665
    16.2.2 TACACS+工作原理 666
    16.3 Cisco IOS交换机上的TACACS+配置与管理 668
    16.3.1 标识TACACS+服务器主机,设置认证密钥 668
    16.3.2 TACACS+登录认证配置 669
    16.3.3 为特权模式访问和网络服务配置TACACS+授权 671
    16.3.4 启用TACACS+计费 672
    16.3.5 TACACS+配置信息管理 672
    16.4 RADIUS基础 673
    16.4.1 RADIUS简介 673
    16.4.2 RADIUS工作原理 674
    16.5 Cisco IOS交换机RADIUS配置与管理 676
    16.5.1 标识RADIUS服务器主机 676
    16.5.2  RADIUS登录认证配置 678
    16.5.3 定义RADIUS AAA服务器组 679
    2.5.4 用户特权访问和网络服务RADIUS授权配置 681
    16.5.5 启用RADIUS计费 682
    16.5.6 RADIUS服务器的公共属性配置 683
    16.5.7 Cisco IOS交换机RADIUS服务器配置示例 683
    16.6 Cisco IOS交换机RADIUS服务器负载均衡配置 685
    16.6.1 RADIUS服务器负载均衡原理 685
    16.6.2 RADIUS服务器负载均衡配置 686
    16.6.3 RADIUS服务器负载均衡故障排除 689
    16.6.4 RADIUS服务器负载均衡配置示例 691
    第17章 Cisco IOS交换机IEEE 802.1X认证配置与管理 695
    17.1 理解IEEE 802.1x基于端口认证 697
    17.1.1 IEEE 802.1x认端证设备角色 697
    17.1.2 IEEE 802.1x认证初始化和消息交换 698
    17.1.3 IEEE 802.1x认证证流程 699
    17.1.4 IEEE 802.1x主机模式 701
    17.1.6 使用MAC移动特性 703
    17.1.7 使用MAC替换特性 704
    17.1.8 使用带VLAN分配功能的IEEE 802.1x 704
    17.1.9 为来宾VLAN使用IEEE 802.1x 705
    17.1.10 使用带MAB的IEEE 802.1x 705
    17.1.11 使用基于Web认证的IEEE 802.1x 707
    17.1.12 使用带临界认证的IEEE 802.1x 707
    17.2 Cisco IOS交换机IEEE 802.1x基于端口认证基本配置 707
    17.2.1 启用IEEE 802.1x认证 708
    17.2.2 配置交换机与RADIUS服务器之间的通信 712
    17.2.3 IEEE 802.1x认证主机模式配置 713
    17.2.4 IEEE 802.1x认证违例行为模式配置 716
    17.2.5 IEEE 802.1x认证MAC移动特性配置 717
    17.2.6 IEEE 802.1x认证MAC替换特性配置 718
    17.2.7 带来宾VLAN的IEEE 802.1x配置 719
    17.2.8 带MAB认证的IEEE 802.1x配置 722
    17.2.9 带临界认证的IEEE 802.1x配置 724
    17.2.10 启用后退认证 727
    17.2.11 启用周期性重认证 731
    17.2.12 启用多主机认证模式 733
    17.2.13 修改静止等待周期 734
    17.2.14 修改交换机到客户端的帧重传时间间隔和重传次数 735
    第18章 H3C交换机端口镜像配置与管理 737
    18.1  H3C以太网交换机的端口镜像基础 739
    18.1.1 H3C交换机端口镜像简介 739
    18.1.2 H3C交换机端口镜像原理 740
    18.2 H3C交换机本地端口镜像配置 742
    18.2.1 本地端口镜像配置步骤 742
    18.2.2  本地端口镜像配置示例 745
    18.3 H3C交换机二层远程端口镜像配置 746
    18.3.1二层远程端口镜像配置任务 746
    18.3.2 低端H3C交换机远程端口镜像的配置步骤 748
    18.3.3 中高端H3C交换机二层远程端口镜像的配置步骤 752
    18.3.4  利用远程镜像VLAN实现本地镜像支持多个目的端口的配置步骤 755
    18.3.5 低端H3C交换机远程端口镜像配置示例 757
    18.3.6  中高端H3C交换机二层远程端口镜像配置示例 759
    18.3.7  利用远程镜像VLAN实现本地镜像支持多个目的端口典型配置示例 760
    18.5  H3C交换机三层远程端口镜像配置 761
    18.5.1 三层远程端口镜像的配置步骤 761
    18.5.2  三层远程端口镜像配置示例 765
    18.6 H3C交换机端口镜像管理 767
    第19章 H3C交换机端口安全和MAC地址认证配置与管理 770
    19.1 H3C交换机端口安全基础 772
    19.1.1  H3C交换机端口安全特性和模式 772
    19.1.2 详解端口安全模式工作原理 774
    19.2 H3C交换机端口安全配置与管理 778
    19.2.1 启用端口安全功能 779
    19.2.2  端口最大安全MAC地址数 779
    19.2.3 端口安全模式配置 780
    19.2.4 安全MAC地址配置 781
    19.2.5  端口安全的相关特性配置 783
    19.2.6  macAddressOrUserLoginSecure安全模式下来宾VLAN支持的配置 785
    19.2.7  不应用RADIUS服务器下发的授权信息的配置 786
    19.2.8  端口安全配置管理 787
    19.3  H3C交换机端口安全配置示例 790
    19.3.1  autolearn模式的端口安全配置示例 790
    19.3.2 macAddressWithRadius模式的端口安全配置示例 791
    19.3.3  userLoginWithOUI模式的端口安全配置示例 792
    19.3.4  macAddressElseUserLoginSecureExt模式端口安全配置示例 793
    19.3.5  macAddressOrUserLoginSecure模式来宾VLAN配置示例 794
    19.4 H3C交换机MAC地址认证基础 796
    19.4.1 两种MAC地址认证方式 796
    19.4.2  MAC地址认证定时器 797
    19.4.3  与MAC地址认证配合使用的特性 797
    19.5  H3C交换机MAC地址认证配置与管理 798
    19.5.1 基本MAC地址认证功能配置 798
    19.5.2  MAC地址认证域配置 801
    19.5.3  MAC地址认证来宾VLAN配置 802
    19.5.4  MAC地址认证管理 803
    19.5.5  本地MAC地址认证配置示例 805
    19.5.6  使用RADIUS服务器进行MAC地址认证的配置示例 806
    第20章 H3C交换机AAA安全访问配置与管理 808
    20.1 H3C交换机AAA基础 810
    20.1.1 AAA简介 810
    20.1.2  ISP域简介 810
    20.1.3  HWTACACS简介 811
    20.1.4 H3C交换机配置AAA配置任务 813
    20.2  H3C交换机本地用户配置与管理 813
    20.2.1 本地用户属性 813
    20.2.2 本地用户属性配置 814
    20.2.3 用户组属性配置 819
    20.2.4 本地用户及本地用户组管理 820
    20.3 H3C交换机RADIUS方案配置与管理 822
    20.3.1 创建RADIUS方案 822
    20.3.2 RADIUS认证/授权服务器服务器 823
    20.3.3 RADIUS计费服务器及相关参数配置 824
    20.3.4 RADIUS报文的共享密钥配置 827
    20.3.5 RADIUS服务器报文发送的最大尝试次数配置 827
    20.3.6配置支持的RADIUS服务器的类型 828
    20.3.7 RADIUS服务器状态配置 828
    20.3.8 发送给RADIUS服务器的数据相关属性配置 830
    20.3.9 发送RADIUS报文使用的源地址配置 831
    20.3.10发送RADIUS报文使用的备份源地址配置 832
    20.3.11  RADIUS服务器的定时器配置 832
    20.3.12 RADIUS的Trap功能配置 833
    20.3.13 启用监听端口 834
    20.3.14  RADIUS方案管理 834
    20.4  H3C交换机HWTACACS方案配置与管理 839
    20.4.1 创建HWTACACS方案 840
    20.4.2 HWTACACS服务器配置 840
    20.4.3 HWTACACS报文共享密钥配置 842
    20.4.4 发送给HWTACACS服务器的数据相关属性配置 843
    20.4.5 置发送HWTACACS报文使用的源地址配置 843
    20.4.6 HWTACACS服务器的定时器配置 844
    20.4.7 HWTACACS方案管理 845
    20.5  在H3C交换机ISP域中配置实现AAA的方法 847
    20.5.1  创建ISP域 848
    20.5.2  ISP域属性配置 848
    20.5.3  ISP域的AAA认证方法配置 850
    20.5.4  ISP域的AAA授权方法配置 853
    20.5.5  ISP域的AAA计费方法配置 856
    20.5.6 强制切断用户连接配置 859
    20.5.7 配置设备作为RADIUS服务器 860
    20.6  H3C交换机AAA配置示例 862
    20.6.1  Telnet用户的local认证、HWTACACS授权、RADIUS计费配置 862
    20.6.2  SSH用户的RADIUS认证和授权配置示例 864
    20.6.3  802.1X用户的RADIUS认证、授权和计费配置示例 866
    20.6.4  Telnet用户的HWTACACS认证、授权、计费配置示例 870
    20.6.5  设备作为RADIUS服务器对Telnet用户进行接入认证的配置示例 871
    第21章 H3C交换机IEEE 802.1x 和Portal认证配置与管理 873
    21.1 H3C交换机IEEE 802.1X基础 875
    21.1.1 IEEE 802.1X的体系结构 875
    21.1.2 IEEE 802.1X的认证方式 875
    21.1.3 IEEE 802.1X端口状态及接入控制方式 876
    21.1.4 H3C交换机中与IEEE 802.1X配合使用的特性 876
    21.2 H3C交换机IEE 802.1X配置与管理 878
    21.2.1  开启802.1X特性 879
    21.2.2 IEEE 802.1X认证方法配置 880
    21.2.3  端口授权状态的配置 881
    21.2.4  端口接入控制方式配置 881
    21.2.5 端口允许同时接入的用户最大数配置 882
    21.2.6  IEEE 802.1X定时器参数配置 883
    21.2.7  交换机向客户端发送认证请求的最大次数配置 884
    21.2.8  开启组播和单播触发功能 885
    21.2.8 端口的强制认证域配置 885
    21.2.9  来宾VLAN配置 886
    21.2.10 认证失败VLAN配置 887
    21.2.11 IEEE 802.1X认证管理 887
    21.2.12  H3C交换机IEEE 802.1X认证配置示例 890
    21.2.13 带来宾VLAN和VLAN下发功能的IEEE 802.1X认证配置示例 892
    21.3 H3C交换机IEEE 802.1X支持EAD快速部署配置与管理 893
    21.3.1  IEEE 802.1X支持EAD快速部署的实现机制 893
    21.3.2 EAD快速部署配置 894
    21.3.3  EAD规则的老化超时时间配置 894
    21.3.4  EAD快速部署配置示例 895
    21.4 H3C交换机Portal认证基础 896
    21.4.1 Portal认证简介 896
    21.4.2  二层Portal认证方式 898
    21.4.3 三层Portal认证方式 899
    21.4.4  Portal认证的双机热备和多实例支持 901
    21.5 H3C交换机Portal认证配置与管理 902
    21.5.1 配置准备 903
    21.5.2  指定Portal服务器 904
    21.5.3  本地Portal认证Web页面自定义配置 905
    21.5.4 本地Portal服务器配置 908
    21.5.5 启用Portal认证 909
    21.5.6  Portal用户接入控制配置 910
    21.5.7  Portal认证的认证失败VLAN配置 913
    21.5.7 接口发送RADIUS报文的相关属性配置 914
    21.5.8 接口发送Portal报文使用的源地址配置 915
    21.5.9  配置Portal支持双机热备 916
    21.5.10  指定Portal用户认证成功后认证页面的自动跳转目的网站地址 918
    21.5.11  Portal探测功能配置 919
    21.5.12  强制Portal用户下线 922
    21.5.13  Portal认证管理 922
    21.5.14  二层Portal认证配置示例 923
    21.5.15  Portal直接认证配置举例 925

                                                     前  言

       如果你一直不清楚还有哪些高级交换机配置与管理技能需要学习,本书将给你一个全面、系统的答案;
        如果你一直在寻找像QoS/IP组播/HSRP/VRRP/安全管理等高级技能学习资料,本书是你惟一的选择;
        如果你想在竞争IT经理位置时凭借高超的设备配置与管理技能力压群雄,本书是你取胜的法宝;
        如果你想实现有朝一日实现进军大中型企业,甚至电信级企业的梦想,本书是你必修的功课;
        如果你想面试时凭借侃侃而谈的高级设备配置与管理能力表现成功脱颖而出,请选择本书;
        如果你还没阅读《Cisco/H3C交换机配置与管理完全手册》(第2版),请不要阅读本书;
        如果你对自己将长期工作在薪酬较低的中小型企业并不在意,请不要选择本书;
        如果你认为交换机配置与管理很容易,没什么好学的,请不要选择本书;
        如果你从来没想过要在网络设备方面学得太深,请不要选择本书。

    艰巨的历史使命

        一直以来,在我的十几个读者QQ群中,经常有读者问哪里有QoS、HSRP/VRRP、IEEE 802.1x、AAA等这类系统、深入的学习资料或图书。笔者也尝试过从网上和网上书店搜索,但比较失望,不要说中文的,就连英文的这方面的系统学习资料或图书都几乎没有,基本上都是零碎的、个别案例的文章,根本不可能凭借这些网上的资料系统、全面、深入地学习这些高级交换机配置与管理技能。作为一位有着上百万读者信任、支持的老IT图书作者,看到这些,无名中感受到前所未有的责任感和使命感。于是,在众多读者朋友的殷切期待中,一年前亦然决定暂时放弃本来要进行原来《网管员必读》系列改版的图书编写计划,在完成《Cisco/H3C交换机配置与管理完全手册》(第2版)的基础上,再写一本在《Cisco/H3C交换机配置与管理完全手册》(第2版)中还没有包括的许多高级交换机配置与管理技能的图书,作为送给百万支持我的海内外读者朋友的2012年新年礼物。当时,当我在群中公布我将写这样一本图书时,就得到了无数读者朋友的支持和热切期待。在这一年的写作过程中也总有不少热心的读者朋友非常关心这本图书的编写进程,纷纷向我打听这本书什么时候可以上市,有许多读者还早早地在我这里登记预订了;就在最近我在微博中发布了我即将完成这本图书的编写工作时,许多读者急不可待地想对新书目录一睹为快。真是非常感谢这些一直支持我的读者朋友!这或许就是一位作者最大的欣慰和成就感吧,因为还有那么多读者朋友需要。
        说句实话,要写这样一本书对我个人来说都是一次极大的挑战,因为笔者虽然以前对这些方面也懂得一些,但的确没有总结过,对是否可以把这些非常高级,非常复杂的知识技能非常系统地总结出来,并没有十分的把握。但就像将军接受了军令一样,再难也要把任务完成好,不能让那么多支持、信任我的读者朋友失望,只能迎难而上。尽管最终的结果可能不那么完美,但一定要尽自己最大的能力,付出最大的努力来做这项具有历史性的工作,为国内的网管职业奉献自己一点微薄的贡献。于是自一年前开始,在边写、边学、边做实验的基础上开始了这本书历史性巨著的创作。在这其中所遇到的困难是常人难以想象的,因为这本书的技术相对来说都非常复杂,特别一些技术原理,往往要涉及到许多基层的协议工作原理,不是看产品手册就可以看得明白的。当然在这里要特别说明的是,在写过程中借鉴了Cisco和H3C的产品手册,在这里要特别表示最由衷的感谢!但是,仅靠这些产品手册是远远不够的,因为不仅要从这浩瀚的产品文档中总结出通用的配置方法和思路,还要对不同系列,甚至不同机型对功能的支持,配置不同加以区别,还要辅以大量自己的个人经验和借鉴其他资料,最终才可能使这本书的每章的内容都是那么翔实,那么有针对性。自己是一位追求完美的人,所以如果自己已在图书内容中发现了问题,或者不够完美的地方,我一定会尽全力去解决的,不惜多花许多时间和精力。有时因一个原理性的问题,反复地捉摸,反复地实验,反复地查找各方面的资料来印证,远不是一个产品手册就可以全面解决的。虽然我自己都十分清楚,这样下来,花在这本书上的写作时间可能会很长,但我觉得这是十分值得的,因为对于技术类图书来说往往是作者多花十分钟,可能最终为读者节约一个小时,甚至更长的时间。那么多读者,这样节省下来的时间就相当可观了。

    迫切的时代要求
     

       对于交换机,许多初级网管朋友往往认为没什么好学的,无非是些交换机系统映像、以太网端口、VLAN、STP之类的配置,这当然是非常片面的。现在的交换机大多数已具有OSI/RM三层功能,所以现在一些中端以上,甚至低端的交换机都是三层交换机,具备许多原来只有在路由器,甚至防火墙设备中才具有的功能,这就决定了交换机配置和管理的复杂性。
        对于小型的企业网络,可能用不到企业级网络设备,基本上都是宽带级路由器,二层可网管,甚至非网管的傻瓜型交换机。但是随着这么年来小型企业的不断发展,越来越多原来的小型企业已成长为中型,甚至大型企业,所以目前国内对高级网络设备管理人员的需求是越来越大,这是我们网络管理员实现职业晋级的一个绝好机会。但同时我们又要看到,随着网络技术和网络应用的发展,企业用户对我们网络管理人员的设备配置和管理能力也在不断提高,特别是一些互联网运营商企业。这不仅体现在网络设备本身的管理上,更集中体现在对网络用户、网络应用和网络设备本身的安全访问控制和灵活的管理策略配置上。所以说,现在对网络管理人员的技能要求与十年前的网管真是不可同日而语,我们不仅应该看到这大好的形势,同时又要充分意识到时代对我们网管人员的要求更高了。 
        本书所介绍的技术绝大多数适用于大中型企业,或者电信运营商企业,可能将成为你进军大中型企业,甚至电信级企业的有力资本。本书把目前最主要的两个企业网络设备厂商Cisco和H3C的以太网交换机高级配置与管理内容集中在一起了,可以更好地以对比的方式进行学习。如本书第一篇介绍的是交换机高可用性方案中介绍的交换机集群、HSRP和VRRP方案中,就是为了解决单一交换机性能不足,或容易出现单点故障而设计的,第二篇介绍的ACL和QoS技术则又是为了解决通信流控制、用户访问控制和为不同类型通信提供不同等级服务质量而设计的;第三篇介绍的IP组播技术则是为了满足当前越来越多的像远程音/视频会议、远程教学、远程会诊、音/视频点播等新型互联网应用而设计的;第四篇介绍的交换机端口监控和安全管理中所介绍的各种端口镜像、端口安全管理(如端口安全技术、MAC地址认证)和交换机安全访问控制(如特权用户密码保护、用户特权级别划分、IEEE 802.1x认证、Portal认证和AAA访问控制方案等)技术,则是出于对网络通信流量监控、用户对交换机,或者对网络资源访问权限的控制而设计。无论你学会了这其中的哪一项技能,都可能成为你傲视群雄的资本,当然如果你能把这些技能全部掌握,那你在交换机领域绝对是相权威的,这或许将使你成就更好的职业,或者出任更高职位的致胜法宝。

    本文转自王达博客51CTO博客,原文链接http://blog.51cto.com/winda/701363如需转载请自行联系原作者


    茶乡浪子

    展开全文
  • NAT等等各大网络公司对网络工程师的必备要求就是:会配置主要型号的交换机和路由器,不熟悉的设备能够独立查资料配置。 然而,在学习这件事上,是没有捷径的。想要完全吃透一个交换机的功能配置,需要花费很多时间...

    其实对网工来说,懂得交换机是啥,真的远远不够。NAT等等各大网络公司对网络工程师的必备要求就是:会配置主要型号的交换机和路由器,不熟悉的设备能够独立查资料配置。


    然而,在学习这件事上,是没有捷径的。想要完全吃透一个交换机的功能配置,需要花费很多时间,还要有机会实操才可以。

    欢迎关注微信公众号【厦门微思网络】。www.xmws.cn专业IT认证培训19周年
    主要课程:思科、华为、红帽、ORACLE、VMware、CISP、PMP等认证培训及考试

    如果你正在学习交换机,比较建议你从以下四点入手学习,逐一攻破:
     

    1. 彻底弄懂交换机的工作原理

    2. 掌握交换机端口的配置(工作模式、速率)

    3. 掌握VLAN的配置(通常是基于端口的VLAN)

    4. 生成树协议的配置和优化(主要是协议类型和根桥交换机的控制)

    如果掌握上述的四点内容,基本操作对你来说应该是没问题的。再往上走,你需要继续提升技能,学习更多的内容,比如路由操作、协议工作原理、隧道介意等等。

    今天就不过多展开叙述,主要跟大家分享一下思科、华为、H3C和锐捷的交换机基本配置命令大合集,(章节篇幅较长,建议收藏慢慢消化)希望可以帮到大家。

     

    01  进入特权模式enable

    图片

    switch>enable

    switch#

    02  进入全局配置模式configure terminal

    图片

    switch>enable

    switch#configure terminal

    switch(conf)#

    03 交换机命名hostname aptech2950以aptech2950为例

    图片

    switch>enable

    switch#configure terminal

    switch(conf)#hostname aptch-2950

    aptech2950(conf)#

    04 配置使能口令enable password cisco以cisco为例

    图片

    switch>enable

    switch # c onfigure terminal

    switch(conf)#hostname aptch2950

    aptech2950(conf)# enable password cisco

    05 配置使能密码enable secret ciscolab以cicsolab为例

    图片

    switch>enable

    switch # c onfigure terminal

    switch(conf)#hostname aptch2950

    aptech2950(conf)# enble secret ciscolab

    06 创建多个VLAN

    图片

    switch>enable                      (进入特权模式)

    switch#vlan data                  (进入VLAN配置模式)

    switch(vlan)#vlan 10 name IT      (划分VLAN 10,名称为IT)

    switch(vlan)#vlan 20 name HR    (划分VLAN20,名称为HR)

    switch(vlan)#vlan 30 name FIN    (划分VLAN30,名称为FIN)

    switch(vlan)#vlan 40 name LOG   (划分VLAN40,名称为LOG)

    switch(vlan)#exit

    07 设置VLAN 1

    图片

    switch>enable

    switch # configure terminal

    switch(conf)#hostname aptch2950

    aptech2950(conf)# interface vlan 1

    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0

    配置交换机端口IP和子网掩码

    aptech2950(conf-if)#no shut

    aptech2950(conf-if)#exit

    aptech2950(conf)#ip default-gateway 192.168.254    设置网关地址

    08 进入交换机某一个端口interface fastehernet 0/17以17为例

    图片

    switch>enable

    switch # configure terminal

    switch(conf)#hostname aptch2950

    aptech2950(conf)# interface fastehernet 0/17

    aptech2950(conf-if)#

    09 查看命令show

    图片

    switch>enable

    switch# show version

    查看系统中的所有版本信息

    show interface vlan 1

    查看交换机有关IP协议的配置信息

    show running-configure

    查看交换机当前起作用的配置信息

    show interface fastethernet 0/1

    查看交换机1接口具体配置和统计信息

    show mac-address-table

    查看MAC地址表

    show mac-address-table aging-time

    查看MAC地址表自动老化时间

    10 交换机恢复出厂默认命令

    图片

    switch>enable

    switch # erase startup-configure

    switch # reload

    11 双工模式设置

    图片

    switch> enable

    switch # c onfigure terminal

    switch2950(conf)#hostname aptch-2950

    aptech2950(conf)# interface fastehernet 0/17

    aptech2950(conf-if)#duplex full/half/auto

    有 full、half、auto三个选项

    12

     cdp相关命令

    图片

    switch> enable

    switch# show cdp   查看设备的cdp全局配置信息

    show cdp interface fastethernet 0/17

    show cdp traffic      查看有关cdp包的统计信息

    show cdp nerghbors     列出与设备相连的cisco设备

    13

    交换机telnet远程登录设置

    图片

    switch>enable

    switch # configure terminal

    switch(conf)#hostname aptech-2950

    aptech2950(conf)#enable password cisco

    aptech2950(conf)#interface fastethernet 0/1

    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0

    aptech2950(conf-it)#no shut

    aptech2950(conf-if)#exit

    aptech2950(conf)line vty 0 4 设置0-4个用户可以telnet远程登录

    aptech2950(conf-line)#password edge 以edge为远程登录的用户密码

    主机设置:

    IP  192.168.1.2 主机的IP必须和交换机端口的地址在同一个网络段

    metmask 255.255.255.0

    gate-way 192.168.1.1     网关地址是交换机端口地址

    运行:

    telent 192.168.1.1

    进入telnet远程登录界面

    password:edge

    aptech2950>en

    password:cisco

    aptech#

     

    01

    常用命令视图

    图片

    图片


     

    02

    创建VLAN

    图片

    <Huawei>    //用户视图,一般display命令查看信息比较多。

    <Huawei>system-view   //准备进入系统视图。

    [Huawei]vlan 100   //创建vlan 100。

    [Huawei-vlan100]quit   //退回系统视图。

    03

    将端口加入到vlan中

    图片

    [Huawei] interface GigabitEthernet2/0/1  //(10G光口) 

    [Huawei- GigabitEthernet2/0/1] port link-type access  //定义端口传输模式 

    [Huawei- GigabitEthernet2/0/1] port default vlan 100  //将端口加入vlan100 

    [Huawei- GigabitEthernet2/0/1] quit    //回到接口视图 

    [Huawei] interface GigabitEthernet1/0/0    //进入1号插槽上的第一个千兆网口接口视图中。0代表1号口 

    [Huawei- GigabitEthernet1/0/0] port link-type access  //定义端口传输模式 

    [Huawei- GigabitEthernet2/0/1] port default vlan 10  //将这个端口加入到vlan10中 

    [Huawei- GigabitEthernet2/0/1] quit 

    04

    将多个端口加入到VLAN中

    图片

    <Huawei>system-view 

    [Huawei]vlan 10 

    [Huawei-vlan10]port GigabitEthernet 1/0/0 to 1/0/29  //将0到29号口加入到vlan10中 

    [Huawei-vlan10]quit

    05

    警惕第二波疫情

    图片

    [Huawei] interface Vlanif100   // 进入vlan100接口视图与vlan 100命令进入的地方不同 

    [Huawei-Vlanif100] ip address 192.168.1.1 255.255.255.0   // 定义vlan100管理IP三层 交换网关路由 

    [Huawei-Vlanif100] quit    //返回视图

    06

    配置默认网关

    图片

    [Huawei]ip route-static 0.0.0.0 0.0.0.0 192.168.1.254 //配置默认网关。

     07  交换机保存设置和重置命令

    <Huawei>save    //保存配置信息 

    <Huawei>reset saved-configuration   //重置交换机的配置 

    <Huawei>reboot   //重新启动交换机

    07

    交换机保存设置和重置命令

    图片

    <Huawei>save    //保存配置信息 

    <Huawei>reset saved-configuration   //重置交换机的配置 

    <Huawei>reboot   //重新启动交换机

    08

    交换机常用的显示命令

    图片

    用户视图模式下:

    <Huawei>display current-configuration   //显示现在交换机正在运行的配置明细 

    <Huawei>display device    //显示各设备状态 

    <Huawei>display interface xxx  //显示个端口状态,用?可以查看后边跟的选项 

    <Huawei>display version   //查看交换机固件版本信息 

    <Huawei>display vlan xxx   // 查看vlan的配置信息

     

    01

    基本配置

    图片

    <H3C>      //用户直行模式提示符,用户视图

    <H3C>system-view    //**进入系统视图** 

    [H3C] sysname xxx   //设置主机名成为xxx这里使用修改特权用户密码

    02

     用户配置

    图片

    <H3C>system-view

    [H3C]super password H3C     //设置用户分级密码

    [H3C]undo superpassword     //删除用户分级密码

    [H3C]localuser bigheap 1234561     //Web网管用户设置,1为管理级用户

    [H3C]undo localuser bigheap    //删除Web网管用户

    [H3C]user-interface aux 0     //只支持0

    [H3C-Aux]idle-timeout 250     //设置超时为2分50秒,若为0则表示不超时,默认为5分钟

    [H3C-Aux]undoidle-timeout     //恢复默认值

    [H3C]user-interface vty 0     //只支持0和1

    [H3C-vty]idle-timeout 250     //设置超时为2分50秒,若为0则表示不超时,默认为5分钟

    [H3C-vty]undoidle-timeout     //恢复默认值

    [H3C-vty]set authentication password123456     //设置telnet密码,必须设置

    [H3C-vty]undo set authentication password   //取消密码

    [H3C]displayusers     //显示用户

    [H3C]displayuser-interface     //用户界面状态

    03

     vlan配置

    图片

    [H3C]vlan 2         **//创建VLAN2**

    [H3C]undo vlan all     //删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除

    [H3C-vlan2]port Ethernet 0/4 to Ethernet0/7     //将4到7号端口加入到VLAN2中,此命令只能用来加access端口,不能用来增加trunk或者hybrid端口

    [H3C-vlan2]port-isolate enable    //打开VLAN内端口隔离特性,不能二层转发,**默认不启用该功能**

    [H3C-Ethernet0/4]port-isolate uplink-portvlan 2    //设置4为VLAN2的**隔离上行端口**,用于转发二层数据,只能配置一个上行端口,若为trunk,则建议允许所有VLAN通过,隔离不能与汇聚同时配置

    [H3C]display vlan all     //**显示所有VLAN的详细信息**

    [H3C]user-group 20     //创建user-group 20,默认只存在user-group 1

    [H3C-UserGroup20]port Ethernet 0/4 toEthernet 0/7     //**将4到7号端口加入到VLAN20中,**初始时都属于user-group 1中

    [H3C]display user-group 20     //显示user-group 20的相关信息

    04

    交换机IP配置

    图片

    [H3C]vlan 20        //**创建vlan**

    [H3C]management-vlan 20     //管理vlan

    [H3C]interface vlan-interface 20      //**进入并管理vlan20**

    [H3C]undo interface vlan-interface 20      //删除管理VLAN端口

    [H3C-Vlan-interface20]ip address192.168.1.2 255.255.255.0    //**配置管理VLAN接口静态IP地址**

    [H3C-Vlan-interface20]undo ipaddress      //删除IP地址

    [H3C-Vlan-interface20]ip gateway 192.168.1.1      //指定缺省网关(默认无网关地址)

    [H3C-Vlan-interface20]undo ip gateway

    [H3C-Vlan-interface20]shutdown     //**关闭接口**

    [H3C-Vlan-interface20]undo shutdown      //开启

    [H3C]display ip      //显示管理VLAN接口IP的相关信息

    [H3C]display interface vlan-int

    erface20      //查看管理VLAN的接口信息

    <H3C>debugging ip      //开启IP调试功能

    <H3C>undo debugging ip

    05

    DHCP客户端配置

    图片

    [H3C-Vlan-interface20]ip address dhcp-alloc     // 管理VLAN接口**通过DHCP方式获取IP地址**

    [H3C-Vlan-interface20]undo ip address dhcp-alloc     // 取消

    [H3C]display dhcp     //显示DHCP客户信息

    <H3C>debugging dhcp-alloc      //开启DHCP调试功能

    <H3C>undo debugging dhcp-alloc

    06

     端口配置

    图片

    [H3C]interface Ethernet0/3       //进入端口

    [H3C-Ethernet0/3]shutdown      //关闭端口

    [H3C-Ethernet0/3]speed 100      //速率可为10,100,1000和auto(缺省)

    [H3C-Ethernet0/3]duplexfull      //**双工,可**为half,full和auto,光口和汇聚后不能配置

    [H3C-Ethernet0/3]flow-control     //**开启流控,默认为关闭**

    [H3C-Ethernet0/3]broadcast-suppression 20      //设置抑制广播百分比为20%,可取5,10,20,100,缺省为100,同时组播和未知单播也受此影响

    [H3C-Ethernet0/3]loopback internal      //内环测试

    [H3C-Ethernet0/3]port link-type trunk      //设置链路的**类型为trunk**

    [H3C-Ethernet0/3]port trunk pvid vlan 20      //设置20为该trunk的缺省VLAN,默认为1(trunk线路两端的PVID必须一致)

    [H3C-Ethernet0/3]port access vlan 20      //将当前**access端口加入指定的VLAN**

    [H3C-Ethernet0/3]port trunk permit vlan all      //允许**所有的VLAN通过当前的trunk端口,**可多次使用该命令

    [H3C]link-aggregation Ethernet 0/1 to Ethernet 0/4      //**将1-4口加入汇聚组,**1为主端口,两端需要同时配置,设置了端口镜像以及端口隔离的端口无法汇聚

    [H3C]undo link-aggregation Ethernet 0/1   //删除该汇聚组

    [H3C]link-aggregation mode egress      //配置端口汇聚模式为根据目的MAC地址进行负荷分担,可选为 ingress,egress和both,缺省为both

    [H3C]monitor-port Ethernet 0/2      //**将该端口设置为镜像端口**,必须先设置镜像端口,删除时必须先删除被镜像端口,而且它们不能同在一个端口,该端口不能在汇聚组中,设置新镜像端口时,新取代旧,被镜像不变

    [H3C]mirroring-port Ethernet 0/3 toEthernet 0/4 both      //将**端口3和4设置为被镜像端口**,both为同时监控接收和发送的报文,inbound表示仅监控接收的报文,outbound表示仅监控发送的报文

    [H3C]display mirror

    [H3C]display interface Ethernet 0/3

    <H3C>resetcounters      //**清除所有端口的统计信息**

     

    01

    基础命令

    图片

    >Enable    //进入特权模式

    #Exit      //返回上一级操作模式

    #End      //返回到特权模式

    #copy running-config startup-config  //保存配置文件

    #del flash:config.text  //删除配置文件(交换机及1700系列路由器)

    #erase startup-config  //删除配置文件(2500系列路由器)

    #del flash:vlan.dat  //删除Vlan配置信息(交换机)

    #Configure terminal  //进入全局配置模式

    (config)# hostname switchA  //配置设备名称为switchA

    (config)#banner motd &    //配置每日提示信息 &为终止符

    (config)#enable secret level 1 0 star  //配置远程登陆密码为star

    (config)#enable secret level 15 0 star  //配置特权密码为star

    Level 1为普通用户级别,可选为1~15,15为最高权限级别;0表示密码不加密

    (config)#enable services web-server //开启交换机WEB管理功能

    Services 可选以下:web-server(WEB管理)、telnet-server(远程登陆)等

    02

    查看信息

    图片

    #show running-config    //查看当前生效的配置信息

    #show interface fastethernet 0/3  //查看F0/3端口信息

    #show interface serial 1/2   //查看S1/2端口信息

    #show interface        //查看所有端口信息

    #show ip interface brief     //以简洁方式汇总查看所有端口信息

    #show ip interface     //查看所有端口信息

    #show version        //查看版本信息

    #show mac-address-table    //查看交换机当前MAC地址表信息

    #show running-config    //查看当前生效的配置信息

    #show vlan         //查看所有VLAN信息

    #show vlan id 10     //查看某一VLAN (如VLAN10)的信息

    #show interface fastethernet 0/1  //查看某一端口模式(如F 0/1)

    #show aggregateport 1 summary  //查看聚合端口AG1的信息

    #show spanning-tree   //查看生成树配置信息

    #show spanning-tree interface fastethernet 0/1  //查看该端口的生成树状态

    #show port-security   //查看交换机的端口安全配置信息

    #show port-security address   //查看地址安全绑定配置信息

    #show ip access-lists listname  //查看名为listname的列表的配置信息

    03

    端口基本配置

    图片

    (config)#Interface fastethernet 0/3     //进入F0/3的端口配置模式

    (config)#interface range fa 0/1-2,0/5,0/7-9   //进入F0/1、F0/2、F0/5、F0/7、F0/8、F0/9的端口配置模式

    (config-if)#speed 10   //配置端口速率为10M,可选10,100,auto

    (config-if)#duplex full   //配置端口为全双工模式,可选full(全双工),half(半双式),auto(自适应)

    (config-if)#no shutdown          //开启该端口

    (config-if)#switchport access vlan 10   //将该端口划入VLAN10中,用于VLAN

    (config-if)#switchport mode trunk   //将该端口设为trunk模式,可选模式为access , trunk

    (config-if)#port-group 1   //将该端口划入聚合端口AG1中,用于聚合端口

    04

    端口聚合配置

    图片

    (config)# interface aggregateport 1   //创建聚合接口AG1

    (config-if)# switchport mode trunk   //配置并保证AG1为 trunk 模式

    (config)#int f0/23-24

    (config-if-range)#port-group 1     //将端口(端口组)划入聚合端口AG1中

    05

    生成树

    图片

    配置多生成树协议:

    switch(config)#spanning-tree          //开启生成树协议

    switch(config)#spanning-tree mst configuration   //建立多生成树协议

    switch(config-mst)#name ruijie           //命名为ruijie

    switch(config-mst)#revision 1      //设定校订本为1

    switch(config-mst)#instance 0 vlan 10,20   //建立实例0

    switch(config-mst)#instance 1 vlan 30,40   //建立实例1

    switch(config)#spanning-tree mst 0 priority 4096  //设置优先级为4096

    switch(config)#spanning-tree mst 1 priority 8192  //设置优先级为8192

    switch(config)#interface vlan 10

    switch(config-if)#vrrp 1 ip 192.168.10.1 //此为vlan 10的IP地址

    switch(config)#interface vlan 20

    switch(config-if)#vrrp 1 ip 192.168.20.1 //此为vlan 20的IP地址

    switch(config)#interface vlan 30

    switch(config-if)#vrrp 2 ip 192.168.30.1 //此为vlan 30的IP地址(另一三层交换机)

    switch(config)#interface vlan 40

    switch(config-if)#vrrp 2 ip 192.168.40.1 //此为vlan 40的IP地址(另一三层交换机)

    06

    vlan的基本配置

    图片

    (config)#vlan 10    //创建VLAN10

    (config-vlan)#name vlanname   // 命名VLAN为vlanname

    (config-if)#switchport access vlan 10   //将该端口划入VLAN10中

    某端口的接口配置模式下进行

    (config)#interface vlan 10     //进入VLAN 10的虚拟端口配置模式

    (config-if)# ip address 192.168.1.1 255.255.255.0   //为VLAN10的虚拟端口配置IP及掩码,二层交换机只能配置一个IP,此IP是作为管理IP使用,例如,使用Telnet的方式登录的IP地址

    (config-if)# no shutdown    //启用该端口
     

    07

    端口安全

    图片

    (config)# interface fastethernet 0/1    //进入一个端口

    (config-if)# switchport port-security   //开启该端口的安全功能

    (1)配置最大连接数限制

    (config-if)# switchport port-secruity maxmum 1 //配置端口的最大连接数为1,最大连接数为128

    (config-if)# switchport port-secruity violation shutdown

    //配置安全违例的处理方式为shutdown,可选为protect (当安全地址数满后,将未知名地址丢弃)、restrict(当违例时,发送一个Trap通知)、shutdown(当违例时将端口关闭,并发送Trap通知,可在全局模式下用errdisable recovery来恢复)

    (2)IP和MAC地址绑定

    (config-if)#switchport port-security mac-address xxxx.xxxx.xxxx ip-address 172.16.1.1

    //接口配置模式下配置MAC地址xxxx.xxxx.xxxx和IP172.16.1.1进行绑定(MAC地址注意用小写)

    08

     三层路由功能(针对三层交换机)

    图片

    (config)# ip routing      //开启三层交换机的路由功能

    (config)# interface fastethernet 0/1   

    (config-if)# no switchport  //开启端口的三层路由功能(这样就可以为某一端口配置IP)

    (config-if)# ip address 192.168.1.1 255.255.255.0 

    (config-if)# no shutdown

    09 三层交换机路由协议

    图片

    (config)# ip route 172.16.1.0 255.255.255.0 172.16.2.1  //配置静态路由

    注:172.16.1.0 255.255.255.0     //为目标网络的网络号及子网掩码

    172.16.2.1 为下一跳的地址,也可用接口表示,如ip route 172.16.1.0 255.255.255.0 serial 1/2(172.16.2.0所接的端口)

    (config)# router rip   //开启RIP协议进程

    (config-router)# network 172.16.1.0   //宣告本设备的直连网段信息

    (config-router)# version 2    //开启RIP V2,可选为version 1(RIPV1)、version 2(RIPV2) 

    (config-router)# no auto-summary  //关闭路由信息的自动汇总功能(只有在RIPV2支持)

    (config)# router ospf  //开启OSPF路由协议进程(针对1762,无需使用进程ID)

    (config)# router ospf 1  //开启OSPF路由协议进程(针对2501,需要加OSPF进程ID)

    (config-router)# network 192.168.1.0 0.0.0.255 area 0  

     //宣告直连网段信息,并分配区域号(area0为骨干区域)

    干货分享到这就结束咯,好了,看完就好好休息,准备迎接下一周的战斗吧,加油!

    欢迎关注微信公众号【厦门微思网络】。www.xmws.cn专业IT认证培训19周年
    主要课程:思科、华为、红帽、ORACLE、VMware、CISP、PMP等认证培训及考试

     

     

    展开全文
  • 史上最具人气、最受好评的网络设备图书领域“四大金刚”的全新升级版本再现江湖了,他们分别是:《Cisco交换机配置与管理完全手册》(第二版)、《H3C交换机配置与管理完全手册》(第二版)、《Cisco路由器配置与...
  • 我们有许多客户开始逐渐考虑国内替品,如H3C、锐捷……不论他们性能如何,价格与货期真的有优势的。 正因为此部分项目也遇到一些小问题,比如思科与H3C互联对接丢包、不通等。 常见问题 1. Trunk互联不通
  • 一、华为交换机基础配置命令 1、创建vlan: <Quidway> //用户视图,也就是在Quidway模式下运行命令。 <Quidway>system-view //进入配置视图 [Quidway] vlan 10 //创建vlan 10,并进入vlan10配置视图,...
  • 华为交换机基础配置命令 常用命令视图 常用视图名称 进入视图 视图功能 用户视图 用户从终端成功登录至设备即进入用户视图,在屏幕上显示:<HUAWEI ...
  • 经典案例:企业H3C组网实例

    千次阅读 2017-11-02 19:34:00
    随着企业信息化不断的深入,对网络设备和链路的可靠性、安全性、可管理型提出了更高的要求,本案例通过一个企业网总部及分支的拓扑和配置,列出了当前构建中小型企业网络的主流技术,涉及网关备份、链路冗余、...
  • 华为路由器实现VRRP简单应用

    万次阅读 多人点赞 2016-07-21 14:00:26
    session 1 VRRP VRRP(Virtual Router Redundancy Protocol):虚拟路由冗余协议 跟HSRP的区别 1、公有标准网关冗余协议 2、虚拟ip地址可以使用接口真实ip地址,虚拟MAC地址是0000.5e00.01XX,其中XX是VRRP组号 ...
  • 要会配置主要型号的交换机和路由器,不熟悉的设备能够独立查资料配置。 然而,学习这件事情上,是完全没有捷径可言的。想要完全吃透一个交换机的功能配置,需要花费很多时间,还要有机会实操才行。 如果你正对着...
  • H3C Quidway S 3526E (2 台 ) 4.   配置命令及注意事项: 4.1  配 ip+ 启动 gvrp ( vlan 同步) + 做通道 + 启动 STP 配基本 ip [R14]int s1 [R14-Serial1]ip add 192.168.1.2 24 [R14-...
  • H3C路由器动态NAT配置步骤全解析

    万次阅读 2013-08-21 07:46:16
    3C路由器所支持的动态NAT地址转换主要包括:NAPT、NOPAT、EASY IP这三种模式。...但要注意:有些H3C设备还支持仅仅通过判断流出接口报文的源地址,而不使用ACL的方式来实现出接口报文的动态地址转换。
  • H3CSE园区-VRRP协议

    2018-03-05 20:34:56
    PS:本篇仅挑选作者认为重要的模块,并不全面仅供复习参考,具体请自行查阅相关书籍。设有H3CNE-H3CTE学习博客专栏,...通过VRRP(虚拟路由冗余协议,Virtual Router Redundancy Protocol,是一个标准协议)可以避免...
  • 华为和H3c--交换技术

    2020-09-30 17:54:40
    华为和H3c– 交换技术 一、VLAN的作用和交换网络链路类以及VLAN封装 1、VLAN的作用和优势 1)VLAN的作用 隔离广播域 2)VLAN的优势 降低广播网络占用带宽资源 安全性强屏蔽VLAN间访问 增强设备的稳定性 2、隔离广播...
  • 企业H3C组网实例

    2017-09-06 09:56:50
    企业H3C组网实例随着企业信息化不断的深入,对网络设备和链路的可靠性、安全性、可管理型提出了更高的要求,本案例通过一个企业网总部及分支的拓扑和配置,列出了当前构建中小型企业网络的主流技术,涉及网关备份、...
  • VRRP配置与维护手册-1

    2016-04-06 14:35:00
    VRRP简介< xmlnamespace prefix ="o" ns ="urn:schemas-microsoft-com:office:office" /> 1.1 VRRP(Virtual Router Redundancy Protocol) 在VRRP...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 402
精华内容 160
关键字:

h3c交换机vrrp配置实例