精华内容
下载资源
问答
  • 2021-05-22 14:23:04

    通过枚举寻找目录下的所有子目录和所有文件。

    387e649d81d245fd7735075a117d034e.png

    寻找文件官方文档

    调用格式: 〈无返回值〉 赋值 (通用型变量/变量数组 被赋值的变量或变量数组,通用型数组/非数组 用作赋于的值或资源) - 系统核心支持库->变量操作

    英文名称:set

    将指定的常数、常数集、常量、资源、对象或者变量赋于到指定的变量或变量数组中去。运算符号为“=”。本命令为初级命令。

    参数<1>的名称为“被赋值的变量或变量数组”,类型为“通用型(all)”,提供参数数据时只能提供变量及变量数组。

    参数<2>的名称为“用作赋于的值或资源”,类型为“通用型(all)”,提供参数数据时可以同时提供数组或非数组数据。

    操作系统需求: Windows、Linux、Unix

    -------------------

    调用格式: 〈通用型〉 相加 (通用型 被加数或文本或字节集,通用型 加数或文本或字节集,... ) - 系统核心支持库->算术运算

    英文名称:add

    运算符号为“+”,用途为:1、返回两个数值的和;2、将两个文本首尾连接起来,返回连接后的文本;3、将两个字节集首尾连接起来,返回连接后的字节集。本命令为初级命令。命令参数表中最后一个参数可以被重复添加。

    参数<1>的名称为“被加数或文本或字节集”,类型为“通用型(all)”。

    参数<2>的名称为“加数或文本或字节集”,类型为“通用型(all)”。

    操作系统需求: Windows、Linux、Unix

    视频教程源码

    .版本 2

    .支持库 shell

    .程序集 窗口程序集_启动窗口

    .子程序 _按钮1_被单击, , , 寻找文件

    .局部变量 目录, 文本型

    列表框1.清空 ()

    目录 = 浏览文件夹 (“请选择寻找文件的目录”, )

    ' F:\511遇见教程

    .如果 (取文本右边 (目录, 1) ≠ “\”)

    目录 = 目录 + “\”

    .否则

    .如果结束

    编辑框1.内容 = 目录

    查找文件或目录 (目录)

    .子程序 查找文件或目录

    .参数 文件夹, 文本型

    .局部变量 文件, 文本型

    处理事件 ()

    .如果 (取文本右边 (文件夹, 1) ≠ “\”)

    文件夹 = 文件夹 + “\”

    .否则

    .如果结束

    ' 默认为搜寻除子目录外的所有文件。第一次调用

    文件 = 寻找文件 (文件夹 + “*.*”, )

    .判断循环首 (文件 ≠ “”)

    列表框1.加入项目 (文件夹 + 文件, )

    ' 再一次调用本命令,且不要提供欲寻找文件名参数,第二次调用

    文件 = 寻找文件 (, )

    .判断循环尾 ()

    文件 = 寻找文件 (文件夹 + “*.*”, #子目录) ' 文件就变成了新的文件夹了

    .判断循环首 (文件 ≠ “”)

    .如果真 (文件 ≠ “.” 且 文件 ≠ “..”)

    查找文件或目录 (文件夹 + 文件) ' 在寻找新的文件夹,递归的方法就是调用了自己本身

    .如果真结束

    文件 = 寻找文件 (, #子目录)

    .判断循环尾 ()

    更多相关内容
  • 易语言浏览文件夹高级模块源码,浏览文件夹高级模块,浏览文件夹_高级,CoTaskMemFree,SHGetPathFromIDList,SHBrowseForFolder,SHGetSpecialFolderLocation,SHGetFolderPath,SHGetFolderLocation
  • 易语言API浏览文件夹模块源码 系统结构:选择文件夹,对话框消息处理,对话框消息处理2,取文档位置,取窗口标题,取标题,现行选中项,置句柄,打开对话框_,取打开文件名_,改变窗口_,发送消
  • 易语言源码易语言浏览文件夹高级模块源码.rar 易语言源码易语言浏览文件夹高级模块源码.rar 易语言源码易语言浏览文件夹高级模块源码.rar 易语言源码易语言浏览文件夹高级模块源码.rar 易语言源码易语言浏览...
  • 易语言源码易语言浏览文件夹源码.rar 易语言源码易语言浏览文件夹源码.rar 易语言源码易语言浏览文件夹源码.rar 易语言源码易语言浏览文件夹源码.rar 易语言源码易语言浏览文件夹源码.rar 易语言源码易语言浏览...
  • 易语言浏览文件夹源码
  • 易语言高级浏览文件夹模块源码,高级浏览文件夹模块,浏览文件夹_高级,A2U,U2A,CoTaskMemFree,SHGetPathFromIDList,SHBrowseForFolder,SHGetSpecialFolderLocation,SHGetFolderPath,SHGetFolderLocation,...
  • 易语言浏览文件夹高级模块源码
  • 易语言浏览网络文件夹源码,浏览网络文件夹,GetBrowseNetworkShare,GetBrowseNetworkWorkstation,TrimNull,取字节长度_,从列表id取路径_,浏览文件夹对话框_,获取特别文件夹位置_,释放分配内容_,取内存变量地址3_
  • 易语言对象浏览文件夹源码,对象浏览文件夹
  • 浏览文件夹模块易语言核心支持库中没有浏览文件夹功能,要另外加操作系统界面功能支持库,不好用~而且功能较少,所以用api重新打造了一个浏览文件夹的函数接口。 易语言学习网
  • 浏览文件夹模块源码和调用例程 打开一个对话框,浏览系统中存在的所有文件夹,返回被选定文件夹的路径名,如果未选中任何文件夹,则返回空文本。本命令为初级命令。 易语言在线自学
  • 易语言高级浏览文件夹模块源码
  • 易语言对象操作文件夹源码,对象操作文件夹
  • 源码运用API来实现了浏览文件夹功能。 三叶易语言自学网
  • 易语言远程浏览文件夹源码系统结构:发送数据包,处理数据,机器信息,文件服务,机器信息,CPU_取型号,硬盘_取容量,文件服务,文件_取盘符,发送数据包,处理数据,API_GetProcessHeap,GetProcessHeap
  • 易语言源码易语言远程浏览文件夹源码.rar 易语言源码易语言远程浏览文件夹源码.rar 易语言源码易语言远程浏览文件夹源码.rar 易语言源码易语言远程浏览文件夹源码.rar 易语言源码易语言远程浏览文件夹源码.rar ...
  • 易语言浏览网络文件夹源码
  • 易语言对象浏览文件夹源码
  • 易语言浏览文件

    2020-07-22 17:53:01
    易语言浏览文件源码,浏览文件
  • 易语言源码易语言浏览网络文件夹源码.rar 易语言源码易语言浏览网络文件夹源码.rar 易语言源码易语言浏览网络文件夹源码.rar 易语言源码易语言浏览网络文件夹源码.rar 易语言源码易语言浏览网络文件夹源码.rar ...
  • 易语言模块浏览文件夹.rar 易语言模块浏览文件夹.rar 易语言模块浏览文件夹.rar 易语言模块浏览文件夹.rar 易语言模块浏览文件夹.rar 易语言模块浏览文件夹.rar
  • 易语言源码易语言对象浏览文件夹源码.rar 易语言源码易语言对象浏览文件夹源码.rar 易语言源码易语言对象浏览文件夹源码.rar 易语言源码易语言对象浏览文件夹源码.rar 易语言源码易语言对象浏览文件夹源码.rar ...
  • 易语言远程浏览文件夹源码
  • 易语言源码易语言API浏览文件夹源码.rar
  • 易语言源码新浏览文件夹模块.rar 易语言源码新浏览文件夹模块.rar 易语言源码新浏览文件夹模块.rar 易语言源码新浏览文件夹模块.rar 易语言源码新浏览文件夹模块.rar 易语言源码新浏览文件夹模块.rar易语言源码...

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 260
精华内容 104
关键字:

易语言浏览文件夹