精华内容
下载资源
问答
  • 2022-03-20 16:55:28

    [Quidway]discur;显示当前配置
    [Quidway]displaycurrent-configuration;显示当前配置
    [Quidway]displayinterfaces;显示接口信息
    [Quidway]displayvlanall;显示路由信息
    [Quidway]displayversion;显示版本信息
    [Quidway]superpassword;修改特权用户密码
    [Quidway]sysname;交换机命名
    [Quidway]interfaceethernet0/1;进入接口视图
    [Quidway]interfacevlanx;进入接口视图
    [Quidway-Vlan-interfacex]ipaddress10.65.1.1255.255.0.0;配置VLAN的IP地址
    [Quidway]iproute-static0.0.0.00.0.0.010.65.1.2;静态路由=网关
    [Quidway]rip;三层交换支持
    [Quidway]local-userftp
    [Quidway]user-interfacevty04;进入虚拟终端
    [S3026-ui-vty0-4]authentication-modepassword;设置口令模式
    [S3026-ui-vty0-4]setauthentication-modepasswordsimple222;设置口令
    [S3026-ui-vty0-4]userprivilegelEVEl3;用户级别
    [Quidway]interfaceethernet0/1;进入端口模式
    [Quidway]inte0/1;进入端口模式
    [Quidway-Ethernet0/1]duplex{half|full|auto};配置端口工作状态
    [Quidway-Ethernet0/1]speed{10|100|auto};配置端口工作速率
    [Quidway-Ethernet0/1]flow-control;配置端口流控
    [Quidway-Ethernet0/1]mdi{acROSs|auto|normal};配置端口平接扭接
    [Quidway-Ethernet0/1]portlink-type{trunk|access|hybrid};设置端口工作模式
    [Quidway-Ethernet0/1]portaccessvlan3;当前端口加入到VLAN
    [Quidway-Ethernet0/2]porttrunkpermitvlan{ID|All};设trunk允许的VLAN
    [Quidway-Ethernet0/3]porttrunkpvidvlan3;设置trunk端口的PVID
    [Quidway-Ethernet0/1]undoshutdown;激活端口
    [Quidway-Ethernet0/1]shutdown;关闭端口
    [Quidway-Ethernet0/1]quit;返回
    [Quidway]vlan3;创建VLAN
    [Quidway-vlan3]portethernet0/1;在VLAN中增加端口
    [Quidway-vlan3]porte0/1;简写方式
    [Quidway-vlan3]portethernet0/1toethernet0/4;在VLAN中增加端口
    [Quidway-vlan3]porte0/1toe0/4;简写方式
    [Quidway]monitor-port;指定镜像端口
    [Quidway]portmirror;指定被镜像端口
    [Quidway]portmirrorint_listobserving-portint_typeint_num;指定镜像和被镜像
    [Quidway]descriptionstring;指定VLAN描述字符
    [Quidway]description;删除VLAN描述字符
    [Quidway]displayvlan[vlan_id];查看VLAN设置
    [Quidway]stp{enable|disable};设置生成树,默认关闭
    [Quidway]stppriority4096;设置交换机的优先级
    [Quidway]stproot{primary|secondary};设置为根或根的备份
    [Quidway-Ethernet0/1]stpcost200;设置交换机端口的花费
    [Quidway]link-aggregatione0/1toe0/4ingress|both;端口的聚合
    [Quidway]undolink-aggregatione0/1|all;始端口为通道号
    [SwitchA-vlanx]isolate-user-vlanenable;设置主vlan
    [SwitchA]isolate-user-vlansecondary;设置主vlan包括的子vlan
    [Quidway-Ethernet0/2]porthybridpvidvlan;设置vlan的pvid
    [Quidway-Ethernet0/2]porthybridpvid;删除vlan的pvid
    [Quidway-Ethernet0/2]porthybridvlanvlan_id_listuntagged;设置无标识的vlan
    如果包的vlanid与PVId一致,则去掉vlan信息.默认PVID=1。
    所以设置PVID为所属vlanid,设置可以互通的vlan为untagged.

    华为路由器交换机配置命令:路由器命令
    [Quidway]displayversion;显示版本信息
    [Quidway]displaycurrent-configuration;显示当前配置
    [Quidway]displayinterfaces;显示接口信息
    [Quidway]displayiproute;显示路由信息
    [Quidway]sysnameaabbcc;更改主机名
    [Quidway]superpasswrod123456;设置口令
    [Quidway]interfaceserial0;进入接口
    [Quidway-serial0]ipaddress;配置端口IP地址
    [Quidway-serial0]undoshutdown;激活端口
    [Quidway]link-protocolhdlc;绑定hdlc协议
    [Quidway]user-interfacevty04
    [Quidway-ui-vty0-4]authentication-modepassword
    [Quidway-ui-vty0-4]setauthentication-modepasswordsimple222
    [Quidway-ui-vty0-4]userprivilegelEVEl3
    [Quidway-ui-vty0-4]quit
    [Quidway]debugginghdlcallserial0;显示所有信息
    [Quidway]debugginghdlcEVEntserial0;调试事件信息
    [Quidway]debugginghdlcpacketserial0;显示包的信息

    华为路由器交换机配置命令:静态路由:
    [Quidway]iproute-static{interfacenumber|nexthop}[value][reject|blackhole]
    例如:[Quidway]iproute-static129.1.0.01610.0.0.2
    [Quidway]iproute-static129.1.0.0255.255.0.010.0.0.2
    [Quidway]iproute-static129.1.0.016Serial2
    [Quidway]iproute-static0.0.0.00.0.0.010.0.0.2

    华为路由器交换机配置命令:动态路由:
    [Quidway]rip;设置动态路由
    [Quidway]ripwork;设置工作允许
    [Quidway]ripinput;设置入口允许
    [Quidway]ripoutput;设置出口允许
    [Quidway-rip]network1.0.0.0;设置交换路由网络
    [Quidway-rip]networkall;设置与所有网络交换
    [Quidway-rip]peerip-address;
    [Quidway-rip]summary;路由聚合
    [Quidway]ripversion1;设置工作在版本1
    [Quidway]ripversion2multicast;设版本2,多播方式
    [Quidway-Ethernet0]ripsplit-horizon;水平分隔
    [Quidway]routeridA.B.C.D;配置路由器的ID
    [Quidway]ospfenable;启动OSPF协议
    [Quidway-ospf]import-routedirect;引入直联路由
    [Quidway-Serial0]ospfenablearea;配置OSPF区域

    华为路由器交换机配置命令:标准访问列表命令格式如下:
    acl[match-orderconfig|auto];默认前者顺序匹配。
    rule[normal|special]{permit|deny}[sourcesource-addrsource-wildcard|any]
    例:[Quidway]acl10
    [Quidway-acl-10]rulenormalpermitsource10.0.0.00.0.0.255
    [Quidway-acl-10]rulenormaldenysourceany

    华为路由器交换机配置命令:扩展访问控制列表配置命令
    配置TCP/UDP协议的扩展访问列表:
    rule{normal|special}{permit|deny}{tcp|udp}source{|any}destination|any}
    [operate]
    配置ICMP协议的扩展访问列表:
    rule{normal|special}{permit|deny}icmpsource{|any]destination{|any]
    [icmp-code][logging]

    华为路由器交换机配置命令:扩展访问控制列表操作符的含义
    equalportnumber;等于
    greater-thanportnumber;大于
    less-thanportnumber;小于
    not-equalportnumber;不等
    rangeportnumber1portnumber2;区间

    华为路由器交换机配置命令:扩展访问控制列表举例
    [Quidway]acl101
    [Quidway-acl-101]ruledenysouceanydestinationany
    [Quidway-acl-101]rulepermiticmpsourceanydestinationanyicmp-typeecho
    [Quidway-acl-101]rulepermiticmpsourceanydestinationanyicmp-typeecho-reply
    [Quidway]acl102
    [Quidway-acl-102]rulepermitipsource10.0.0.10.0.0.0destination202.0.0.10.0.0.0
    [Quidway-acl-102]ruledenyipsourceanydestinationany
    [Quidway]acl103
    [Quidway-acl-103]rulepermittcpsourceanydestination10.0.0.10.0.0.0destination-portequalftp
    [Quidway-acl-103]rulepermittcpsourceanydestination10.0.0.20.0.0.0destination-portequalwww
    [Quidway]firewallenable
    [Quidway]firewalldefaultpermit|deny
    [Quidway]inte0
    [Quidway-Ethernet0]firewallpacket-filter101inbound|outbound

    华为路由器交换机配置命令:地址转换配置举例
    [Quidway]firewallenable
    [Quidway]firewalldefaultpermit
    [Quidway]acl101;内部指定主机可以进入e0
    [Quidway-acl-101]ruledenyipsourceanydestinationany
    [Quidway-acl-101]rulepermitipsource129.38.1.10destinationany
    [Quidway-acl-101]rulepermitipsource129.38.1.20destinationany
    [Quidway-acl-101]rulepermitipsource129.38.1.30destinationany
    [Quidway-acl-101]rulepermitipsource129.38.1.40destinationany
    [Quidway-acl-101]quit
    [Quidway]inte0
    [Quidway-Ethernet0]firewallpacket-filter101inbound
    [Quidway]acl102;外部特定主机和大于1024端口的数据包允许进入S0
    [Quidway-acl-102]ruledenyipsourceanydestinationany
    [Quidway-acl-102]rulepermittcpsource202.39.2.30destination202.38.160.10
    [Quidway-acl-102]rulepermittcpsourceanydestination202.38.160.10destination-portgreat-than
    1024
    [Quidway-acl-102]quit
    [Quidway]ints0
    [Quidway-Serial0]firewallpacket-filter102inbound;设202.38.160.1是路由器出口IP。
    [Quidway-Serial0]natoutbound101interface;是Easyip,将acl101允许的IP从本接口出时变换源地址。

    华为路由器交换机配置命令:内部服务器地址转换配置命令(静态nat):
    natserverglobal[port]insideport[protocol];global_port不写时使用inside_port
    [Quidway-Serial0]natserverglobal202.38.160.1inside129.38.1.1ftptcp
    [Quidway-Serial0]natserverglobal202.38.160.1inside129.38.1.2telnettcp
    [Quidway-Serial0]natserverglobal202.38.160.1inside129.38.1.3wwwtcp
    设有公网IP:202.38.160.101~202.38.160.103可以使用。;对外访问(原例题)
    [Quidway]nataddress-group202.38.160.101202.38.160.103pool1;建立地址池
    [Quidway]acl1
    [Quidway-acl-1]rulepermitsource10.110.10.00.0.0.255;指定允许的内部网络
    [Quidway-acl-1]ruledenysourceany
    [Quidway-acl-1]intserial0
    [Quidway-Serial0]natoutbound1address-grouppool1;在s0口从地址池取出IP对外访问
    [Quidway-Serial0]natserverglobal202.38.160.101inside10.110.10.1ftptcp
    [Quidway-Serial0]natserverglobal202.38.160.102inside10.110.10.2wwwtcp
    [Quidway-Serial0]natserverglobal202.38.160.1028080inside10.110.10.3wwwtcp
    [Quidway-Serial0]natserverglobal202.38.160.103inside10.110.10.4smtpudp
    华为路由器交换机配置命令:PPP设置:[Quidway-s0]link-protocolppp;默认的协议

    华为路由器交换机配置命令:PPP验证:
    主验方:pap|chap
    [Quidway]local-userq2password{simple|cipher}hello;路由器1
    [Quidway]interfaceserial0
    [Quidway-serial0]pppauthentication-mode{pap|chap}
    [Quidway-serial0]pppchapuserq1;pap时,没有此句

    华为路由交换机配置命令:pap被验方:
    [Quidway]interfaceserial0;路由器2
    [Quidway-serial0]ppppaplocal-userq2password{simple|cipher}hello

    华为路由器交换机配置命令:chap被验方:
    [Quidway]interfaceserial0;路由器2
    [Quidway-serial0]pppchapuserq2;自己路由器名
    [Quidway-serial0]local-userq1password{simple|cipher}hello;对方路由器名
    帧中继frame-relay(二分册6-61)
    [q1]frswitching
    [q1]ints1
    [q1-Serial1]ipaddress192.168.34.51255.255.255.0
    [q1-Serial1]link-protocolfr;封装帧中继协议
    [q1-Serial1]frinterface-typedce
    [q1-Serial1]frdlci100
    [q1-Serial1]frinarp
    [q1-Serial1]frmapip192.168.34.52dlci100
    [q2]ints1
    [q2-Serial1]ipaddress192.168.34.52255.255.255.0
    [q2-Serial1]link-protocolfr
    [q2-Serial1]frinterface-typedte
    [q2-Serial1]frdlci100
    [q2-Serial1]frinarp
    [q2-Serial1]frmapip192.168.34.51dlci100

    华为路由器交换机配置命令:帧中继监测
    [q1]displayfrlmi-info[]interfacetypenumber]
    [q1]displayfrmap
    [q1]displayfrpvc-info[serialinterface-number][dlcidlci-number]
    [q1]displayfrdlci-switch
    [q1]displayfrinterface
    [q1]resetfrinarp-info
    [q1]debuggingfrall[interfacetypenumber]
    [q1]debuggingfrarp[interfacetypenumber]
    [q1]debuggingfrEVEnt[interfacetypenumber]
    [q1]debuggingfrlmi[interfacetypenumber]

    华为路由器交换机配置命令:启动ftp服务:
    [Quidway]local-userftppassword{simple|cipher}aaaservice-typeftp
    [Quidway]ftpserverenable

    更多相关内容
  • 华为交换机如何配置重定向实现策略路由
  • 华为交换机策略路由配置.docx华为交换机策略路由配置.docx华为交换机策略路由配置.docx华为交换机策略路由配置.docx华为交换机策略路由配置.docx华为交换机策略路由配置.docx华为交换机策略路由配置.docx华为交换机...
  • 华为交换机策略路由配置.pdf华为交换机策略路由配置.pdf华为交换机策略路由配置.pdf华为交换机策略路由配置.pdf华为交换机策略路由配置.pdf华为交换机策略路由配置.pdf华为交换机策略路由配置.pdf华为交换机策略路由...
  • 华为交换机静态路由配置Word版.docx华为交换机静态路由配置Word版.docx华为交换机静态路由配置Word版.docx华为交换机静态路由配置Word版.docx华为交换机静态路由配置Word版.docx华为交换机静态路由配置Word版.docx...
  • 华为交换机静态路由配置Word版.pdf华为交换机静态路由配置Word版.pdf华为交换机静态路由配置Word版.pdf华为交换机静态路由配置Word版.pdf华为交换机静态路由配置Word版.pdf华为交换机静态路由配置Word版.pdf华为...
  • 详细介绍华为交换机的单臂路由配置方法(附图)
  • 华为交换机配置策略路由

    千次阅读 2020-06-19 18:57:39
    https://support.huawei.com/enterprise/zh/doc/EDOC1000069432?section=j00f 工作繁重,时间紧迫,先留图流链接。待来日有时间再整理。

    学习链接:https://support.huawei.com/enterprise/zh/doc/EDOC1000069432?section=j00f

     

    策略路由与路由策略(Routing Policy)存在以下不同:

    • 策略路由的操作对象是数据包,在路由表已经产生的情况下,不按照路由表进行转发,而是根据需要,依照某种策略改变数据包转发路径。
    • 路由策略的操作对象是路由信息。路由策略主要实现了路由过滤和路由属性设置等功能,它通过改变路由属性(包括可达性)来改变网络流量所经过的路径。

    目的

        传统的路由转发原理是首先根据报文的目的地址查找路由表,然后进行报文转发。但是目前越来越多的用户希望能够在传统路由转发的基础上根据自己定义的策略进行报文转发和选路。配置策略路由可以将到达接口的三层报文重定向到指定的下一跳地址。

    前置任务

    在配置策略路由前,需要完成以下任务:

    • 配置相关接口的IP地址和路由协议,保证路由互通。

    • 如果使用ACL作为策略路由的流分类规则,配置相应的ACL。

     

    背景信息

    早先已经对接了一个BGP网络,故交换机已经配置了一个默认网关;

    现因业务需要,新增了一段电信IP。

    BGP网络和电信网络分别是通过不同内网IP互联互通,简单的默认路由没办法同时配置两段公网。

    所以想到用策略路由方式:源IP为电信IP段的数据包,重定向到电信网络的内网互联IP。

    配置思路

    采用重定向方式实现策略路由,进而提供差分服务,具体配置思路如下:

    1. 创建VLAN并配置各接口,实现公司和外部网络设备互连。
    2. 配置ACL规则,匹配源IP地址为电信IP段的报文。
    3. 配置流分类,匹配规则为上述ACL规则,使设备可以对报文进行区分。
    4. 配置流行为,使满足电信数据包规则的报文重定向到上联运营商172.16.5.137。
    5. 配置流策略,绑定上述流分类和流行为,并应用到接口vlan if 901的入方向上,实现策略路由。

    操作步骤

    #先创建vlan 用于电信网络
    <Nxera-YC> system-view
    [Nxera-YC] sysname Switch
    [Nxera-YC] vlan 901
    
    #创建VLANIF901,并配置各虚拟接口IP地址。
    [Nxera-YC] int vlan 901                                                                                                   [Nxera-YC-vlan901] ip addr 1XX.1XX.2XX.1 24
    [Nxera-YC-vlan901] quit
    
    #在Switch上创建编码为3002的高级ACL,规则允许源IP地址为1XX.1XX.2XX.0/24的报文通过。
    [Nxera-YC] acl 3002
    [Nxera-YC-acl-adv-3002] rule permit ip source 1XX.1XX.2XX.0 0.0.0.255
    [Nxera-YC-acl-adv-3002] quit
    
    #在Switch上创建流分类c2,匹配规则ACL 3002。
    [Nxera-YC] traffic classifier c2 operator or
    [Nxera-YC-classifier-c2] if-match acl 3002
    [Nxera-YC-classifier-c2] quit
    
    #在Switch上创建流行为b2,指定重定向到172.16.5.137的动作。
    [Nxera-YC] traffic behavior b2
    [Nxera-YC-behavior-b2] redirect ip-nexthop 172.16.5.137
    [Nxera-YC-behavior-b2] quit
    
    # 在Switch上创建流策略p2,将流分类和对应的流行为进行绑定。
    [Nxera-YC] traffic policy p2
    [Nxera-YC-trafficpolicy-p1] classifier c2 behavior b2
    [Nxera-YC-trafficpolicy-p1] quit
    
    # 将流策略p2应用到接口vlan if 901的入方向上。
    [Nxera-YC] int vlan 901
    [Nxera-YC-vlan901] traffic-policy p2 inbound
    [Nxera-YC-vlan901] return

     

    验证配置结果(可以参考官文中的验证方法)

    # 查看ACL规则的配置信息。
    <Switch> display acl 3001
    Advanced ACL 3001, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.100.0 0.0.0.255 (match-counter 0)
    <Switch> display acl 3002
    Advanced ACL 3002, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.101.0 0.0.0.255 (match-counter 0)
    
    
    # 查看流分类的配置信息。
    <Switch> display traffic classifier user-defined
      User Defined Classifier Information:
        Classifier: c2
         Precedence: 10
         Operator: OR
         Rule(s) :if-match acl 3002
            
        Classifier: c1
          Precedence: 5
          Operator: OR
          Rule(s) : if-match acl 3001
    
    Total classifier number is 2  
    
    
    # 查看流策略的配置信息。
    <Switch> display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c1
        Operator: OR
         Behavior: b1
          Redirect: no forced
            Redirect ip-nexthop
            10.1.20.1
       Classifier: c2
        Operator: OR
         Behavior: b2
          Redirect: no forced
            Redirect ip-nexthop
            10.1.30.1

     

    展开全文
  • 华为交换机配置静态路由

    千次阅读 2019-10-29 11:07:33
    处于不同交换机下(不同网段)的PC机,相互进行通信 配置思路 采用如下的思路配置IPv4静态路由: 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。 在各主机上配置IP缺省...

    组网需求:

    处于不同交换机下(不同网段)的PC机,相互进行通信

    配置思路

    采用如下的思路配置IPv4静态路由:

    1. 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。
    2. 在各主机上配置IP缺省网关,在各台Switch上配置IPv4静态路由或者静态缺省路由,实现不配置动态路由协议,使不同网段的任意两台主机之间能够互通

    路由信息:

    SW1:
    
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.2
    
    SW2:
    ip route-static 10.1.1.0 255.255.255.248 10.2.4.1
    ip route-static 10.1.2.0 255.255.255.248 10.2.4.6
    ip route-static 10.1.3.0 255.255.255.248 10.2.4.10
    SW3:
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.5
    SW4:
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.9

    SW1配置,其它类似:

    [SW1] sysname SW1

    [SW1] vlan batch 10 30

    [SW1] interface Vlanif 10

    [SW1] ip address 10.2.4.1 255.255.255.252

    [SW1] dhcp enable

    [SW1] interface Vlanif 30

    [SW1] ip address 10.1.1.1 255.255.255.248

    [SW1] port-group vlan30

    [SW1] group-member GigabitEthernet0/0/1 to GigabitEthernet0/0/5

    [SW1] port link-type access

    [SW1] port default vlan 30

    [SW1] interface Eth-Trunk 1

    [SW1] mode lacp-static

    [SW1] trunkport GigabitEthernet 0/0/23 to 0/0/24

    [SW1] port link-type trunk

    [SW1] port trunk allow-pass vlan 10

    [SW1] ip route-static 0.0.0.0 0.0.0.0 10.2.4.2

    <SW1>save

     

    测试:

    查看SW2路由表:

    <SW2>dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           10.1.1.0/29  Static  60   0          RD   10.2.4.1        Vlanif10
           10.1.2.0/29  Static  60   0          RD   10.2.4.6        Vlanif20
           10.1.3.0/29  Static  60   0          RD   10.2.4.10       Vlanif40
           10.2.4.0/30  Direct  0    0           D   10.2.4.2        Vlanif10
           10.2.4.2/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.2.4.4/30  Direct  0    0           D   10.2.4.5        Vlanif20
           10.2.4.5/32  Direct  0    0           D   127.0.0.1       Vlanif20
           10.2.4.8/30  Direct  0    0           D   10.2.4.9        Vlanif40
           10.2.4.9/32  Direct  0    0           D   127.0.0.1       Vlanif40
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    

    SW1配置文件:

    [SW1]dis current-configuration 
    #
    sysname SW1
    #
    vlan batch 10 30
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    dhcp enable
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
    
    Oct 29 2019 10:42:51-08:00 SW1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 26, the ch
    ange loop count is 0, and the maximum number of records is 4095. local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif10
     ip address 10.2.4.1 255.255.255.252
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.248
     dhcp select interface
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
    #
    interface GigabitEthernet0/0/20
    #
    interface GigabitEthernet0/0/21
    #
    interface GigabitEthernet0/0/22
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.2
    #
    user-interface con 0
    user-interface vty 0 4
    #
    port-group vlan30
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
     group-member GigabitEthernet0/0/3
     group-member GigabitEthernet0/0/4
     group-member GigabitEthernet0/0/5
    #
    return

    SW2配置文件:

    [SW2]dis current-configuration 
    #
    sysname SW2
    #
    vlan batch 10 20 40
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif10
     ip address 10.2.4.2 255.255.255.252
    #
    interface Vlanif20
     ip address 10.2.4.5 255.255.255.252
    #
    interface Vlanif40
     ip address 10.2.4.9 255.255.255.252
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10
     mode lacp-static
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 20
     mode lacp-static
    #
    interface Eth-Trunk3
     port link-type trunk
     port trunk allow-pass vlan 40
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface GigabitEthernet0/0/3
    #
    interface GigabitEthernet0/0/4
    #
    interface GigabitEthernet0/0/5
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
     eth-trunk 2
    #
    interface GigabitEthernet0/0/20
     eth-trunk 2
    #
    interface GigabitEthernet0/0/21
     eth-trunk 3
    #
    interface GigabitEthernet0/0/22
     eth-trunk 3
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 10.1.1.0 255.255.255.248 10.2.4.1
    ip route-static 10.1.2.0 255.255.255.248 10.2.4.6
    ip route-static 10.1.3.0 255.255.255.248 10.2.4.10
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return

    SW3配置文件:

    [SW3]dis current-configuration 
    #
    sysname SW3
    #
    vlan batch 20 50
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    dhcp enable
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif20
     ip address 10.2.4.6 255.255.255.252
    #
    interface Vlanif50
     ip address 10.1.2.1 255.255.255.248
     dhcp select interface
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 20
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
    #
    interface GigabitEthernet0/0/20
    #
    interface GigabitEthernet0/0/21
    #
    interface GigabitEthernet0/0/22
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.5
    #
    user-interface con 0
    user-interface vty 0 4
    #
    port-group vlan50
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
     group-member GigabitEthernet0/0/3
     group-member GigabitEthernet0/0/4
     group-member GigabitEthernet0/0/5
    #

    SW4配置文件:

    [SW4]dis cur
    #
    sysname SW4
    #
    vlan batch 40 60
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    dhcp enable
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif40
     ip address 10.2.4.10 255.255.255.252
    #
    interface Vlanif60
     ip address 10.1.3.1 255.255.255.248
     dhcp select interface
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 40
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
    #
    interface GigabitEthernet0/0/20
    #
    interface GigabitEthernet0/0/21
    #
    interface GigabitEthernet0/0/22
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.9
    #
    user-interface con 0
    user-interface vty 0 4
    #
    port-group vlan60
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
     group-member GigabitEthernet0/0/3
     group-member GigabitEthernet0/0/4
     group-member GigabitEthernet0/0/5
    #
    return

     

     

     

     

     

     

    展开全文
  • 华为交换机怎么配置静态路由?公司的华为交换机想要配置静态路由,因为把交换机当做路由使用,该怎么设置呢?下面我们就来看看详细的教程,需要的朋友可以参考下
  • pdf文档,使用华为交换机实现简单路由功能
  • 在核心交换机上设置策略路由,使核心交换机根据预先设置好的ACL流的匹配来决定将数据库丢往三个出口的其中一个。简单配置步骤如下: 一、网络说明 设备管理地址: 核心交换机:型号Quidway S8508,IP 192.168.0....

    网络中有VLAN用户若干,有三条出口。在核心交换机上设置策略路由,使核心交换机根据预先设置好的ACL流的匹配来决定将数据库丢往三个出口的其中一个。

    简单配置步骤如下:

    一、网络说明

    设备管理地址:
    核心交换机:型号Quidway S8508,IP 192.168.0.254(vlan1)
    楼层交换机:型号Quidway 3600-28TP-SI,IP 192.168.0.20 – 192.168.0.28(vlan1)

    内网VLAN及IP地址:
    192.168.0.0/24,vlan1,服务器及用户A段IP
    192.168.1.0/24,vlan2,用户B段IP
    192.168.2.0/24,vlan3,用户C段IP
    192.168.3.0/24,vlan4,用户D段IP
    10.8.0.0/24,vlan5,用户E段IP

    三个出口设备内网IP地址:
    外网1出口防火墙内网IP地址:192.168.0.11,所在核心交换机端口:inter gig 3/3/1
    外网2出口防火墙内网IP地址:192.168.0.12,所在核心交换机端口:inter gig 3/3/2
    外网3出口防火墙内网IP地址:192.168.0.13,所在核心交换机端口:inter gig 3/3/3

    分布:
    楼宇A:所在核心交换机端口:inter gig 6/1/1,存在vlan:vlan1、vlan3、vlan5
    楼宇B:所在核心交换机端口:inter gig 6/1/2,存在vlan:vlan1、vlan4、vlan5
    楼宇C:所在核心交换机端口:inter gig 6/1/3,存在vlan:vlan1、vlan2、vlan4、vlan5
    楼宇D:所在核心交换机端口:inter gig 6/1/4,存在vlan:vlan1、vlan2、vlan3、vlan5
    网络中心服务器群:所在核心交换机端口:inter gig 3/1/1,存在vlan:vlan1

    网络拓扑图:

    二、实现功能

    1、当楼宇A、B、C、D中vlan1、vlan2及vlan3的用户电脑访问网络时从外网1也就是核心交换机的gig 3/3/1端口上出去
    2、当这些楼宇中的vlan4的用户电脑访问网络时从外网2出口出去
    3、当这些楼宇的vlan5中的用户电脑访问网络时从外网3出口出去
    4、所有vlan均能访问vlan1的服务器群网段

    三、配置步骤

    思路:首先建立一个普通的三层网络,在核心交换机上利用默认路由将楼宇交换机来的数据包全部丢到核心的192.168.0.11上也就是外网1出口上,然后在接楼宇端口上利用核心交换机的traffic-redirect功能通过源地址acl流匹配将vlan4和vlan5的数据包丢到192.168.0.12(外网2)或192.168.0.13(外网3)上。

    1、在核心上建立三层网络,并配置好各楼宇交换机,这里略过。然后在核心交换机上添加一条默认路由,这样所有的数据包就都从外网1出口出去:

    ip route-static 0.0.0.0 0.0.0.0 192.168.0.11 preference 60

    2、因为在接楼宇端口上应用traffic-redirect后数据包就直接丢到外网的内网口了,这样vlan4和vlan5访问vlan1的服务器群就有问题了。所以我们先在端口上做acl。

    建立acl:

    [center] acl number 3001
    [center acl number 3001] rule 0 permit ip source 192.168.3.0 0.0.0.255 destination 192.168.0.0 0.0.0.255
    [center acl number 3001] rule 1 permit ip source 10.0.8.0 0.0.0.255 destination 192.168.0.0 0.0.0.255

    下发楼宇A端口:

    [center] inter gig 6/1/1
    [center-GigabitEthernet6/1/1] packet-filter inbound ip-group 3001

    其他楼宇端口下发方法相同,这里略过。另外,对于是vlan1属性的inter gig 3/1/1,因为端口下只有一个vlan,所以就不需要做策略路由。在下发顺序上也是应该也下发acl规则,然后再下发策略路由。这样就可以先匹配内网的访问需求了。

    3、在连接楼宇交换机的核心交换机端口上做策略路由

    建立vlan4的acl流匹配规则:

    [center] acl number 3002
    [center-acl number 3002] rule 0 permit ip source 192.168.3.0 0.0.0.255

    建立vlan5的acl流匹配规则:

    [center] acl number 3003
    [center-acl number 3003] rule 0 permit ip source 10.8.0.0 0.0.0.255

    下发针对vlan4的楼宇A端口的下一跳路由:

    [center] inter gig 6/1/1
    [center-GigabitEthernet6/1/1] traffic-redirect inbound ip-group 3002 next-hop 192.168.0.12

    下发针对vlan5的楼宇A端口的下一跳路由:

    [center] inter gig 6/1/1
    [center-GigabitEthernet6/1/1] traffic-redirect inbound ip-group 3003 next-hop 192.168.0.13

    这样配置后,vlan1至vlan3仍然从核心交换机的默认路由192.168.0.11外网1出口出去。如果源地址为192.168.3.0网络地址进入核心交换机的连接楼宇的端口后,针对源地址为192.168.3.0的acl规则3002就被匹配,这样就被路由至192.168.0.12的外网2出口上。同理如果是源地址为10.8.0.0网络的地址流入核心交换机的端口上则根据端口定义好的下一跳路由它将被送往192.168.0.13的外网3网络上。

    最后附上核心交换机的完整配置:

    #
    sysname center
    #
    radius scheme system
    server-type huawei
    primary authentication 127.0.0.1 1645
    primary accounting 127.0.0.1 1646
    user-name-format without-domain

    domain system
    radius-scheme system
    access-limit disable
    state active
    idle-cut disable
    self-service-url disable

    domain default enable system
    #
    local-server nas-ip 127.0.0.1 key huawei
    #
    Xbar load-single
    #
    temperature-limit 3 10 65
    temperature-limit 4 10 50
    temperature-limit 5 10 50
    temperature-limit 6 10 65
    #
    dot1x
    #
    acl number 3001
    rule 0 permit ip source 10.10.6.0 0.0.0.255 destination 192.168.0.0 0.0.0.255
    rule 0 permit ip source 192.168.3.0 0.0.0.255 destination 192.168.0.0 0.0.0.255
    acl number 3002
    rule 0 permit ip source 192.168.3.0 0.0.0.255
    acl number 3003
    rule 0 permit ip source 10.8.0.0 0.0.0.255
    #
    vlan 1
    description bangong_and_server
    #
    vlan 2
    description user_a
    #
    vlan 3
    description user_b
    #
    vlan 4
    description user_c
    #
    vlan 5
    description user_d
    #
    interface Vlan-interface1
    description bangong_and_server
    ip address 192.168.0.254 255.255.255.0
    #
    interface Vlan-interface2
    description user_a
    ip address 192.168.1.254 255.255.255.0
    #
    interface Vlan-interface3
    description user_b
    ip address 192.168.2.254 255.255.255.0
    #
    interface Vlan-interface4
    description user_c
    ip address 192.168.3.254 255.255.255.0
    #
    interface Vlan-interface5
    description user_d
    ip address 10.8.0.254 255.255.255.0
    #
    interface Aux4/0/1
    #
    interface M-Ethernet4/0/0
    #
    interface GigabitEthernet3/1/1
    description to_server-group
    #
    interface GigabitEthernet3/1/2
    #
    interface GigabitEthernet3/1/3
    #
    interface GigabitEthernet3/1/4
    #
    interface GigabitEthernet3/2/1
    #
    interface GigabitEthernet3/2/2
    #
    interface GigabitEthernet3/2/3
    #
    interface GigabitEthernet3/2/4
    #
    interface GigabitEthernet3/3/1
    description to_waiwang1
    #
    interface GigabitEthernet3/3/2
    description to_waiwang3
    #
    interface GigabitEthernet3/3/3
    description to_waiwang3
    #
    interface GigabitEthernet3/3/4
    #
    interface GigabitEthernet6/1/1
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 1
    packet-filter inbound ip-group 3001 rule 1 system-index 2
    traffic-redirect inbound ip-group 3002 rule 0 system-index 3 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 4 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/1/2
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 5
    packet-filter inbound ip-group 3001 rule 1 system-index 6
    traffic-redirect inbound ip-group 3002 rule 0 system-index 7 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 8 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/1/3
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 9
    packet-filter inbound ip-group 3001 rule 1 system-index 10
    traffic-redirect inbound ip-group 3002 rule 0 system-index 11 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 12 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/1/4
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 14
    packet-filter inbound ip-group 3001 rule 1 system-index 15
    traffic-redirect inbound ip-group 3002 rule 0 system-index 16 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 17 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/2/1
    #
    interface GigabitEthernet6/2/2
    #
    interface GigabitEthernet6/2/3
    #
    interface GigabitEthernet6/2/4
    #
    interface GigabitEthernet6/3/1
    #
    interface GigabitEthernet6/3/2
    #
    interface GigabitEthernet6/3/3
    #
    interface GigabitEthernet6/3/4
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.0.11 preference 60
    #
    snmp-agent
    snmp-agent local-engineid 80507DBD05757576F5DD55A46877
    snmp-agent community write jsisaa
    snmp-agent sys-info version all
    #
    user-interface con 0
    user-interface aux 0
    user-interface vty 0 4
    user privilege level 3
    set authentication password simple winsaaa
    #
    return

    展开全文
  • 华为交换机与路由器远程登录配置。authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处...
  • 需求:将指定的网络流量转发到指定的下一...acl number 3000 #使用ACL匹配需要进行策略路由的网络流量 rule 10 permit ip source 10.198.245.100 0 des 10.1.0.0 0.0.255.255 traffic classifier TO-60M #使用分类器
  • 华为三层交换机上进行VLAN间路由的配置,主要就是创建VLAN,端口划分,三层VLAN接口地址配置,静态路由或是RIP协议配置
  • 华为MIB库【华为交换机路由MIB】

    热门讨论 2012-12-18 23:15:48
    资源包含华为私有的MIB库,主要为华为交换机和华为路由的MIB库文件。
  • 华为交换机常见命令总结 ,内包含交换命令 学习阶段可以使用到路由交换的hcie阶段。更新时间2020年2月8日。pdf文件可以自己可以修改。
  • 华为交换机实现VLAN间路由实例

    千次阅读 2020-12-29 03:51:57
    Cisco 三层交换机实现VLAN间路由华为三层交换机VLAN间路由配置: (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3; (2)将二层交换机与三层交换机相连的端口F0/1都定义为trunk模式; (3)在...
  • 华为交换机策略路由命令: acl number 3999 #创建ACL(高级3000以上) rule 10 permit ip source any # 所有流量都进行策略路由(或者写需要管控的网段)如果客户有生产办公请不要写any 例如:rule permit I...
  • 展开全部如下是修改NE40E 各路由优先级:1.bgp[HUAWEI] bgp 100[HUAWEI-bgp] ipv4-family unicast[HUAWEI-bgp-af-ipv4] preference 20 200 200命令格式preference { external internal local | route-policy route-...
  • 华为路由交换机、防火墙最新的学习指南
  • 华为交换机配置动态路由OSPF

    千次阅读 2019-09-11 21:20:51
    -拓扑图 -操作 R1: <Huawei> system-view #进入系统视图 [Huawei...
  • 华为单臂路由配置

    2021-01-09 10:05:57
    [Huawei]sysname SW-1 //修改主机名 [SW-1]vlan batch 10 20 //创建vlan 10 20 [SW-1]interface e0/0/1 //进接口 [SW-1-Ethernet0/0/1]port link-type access //配置工作模式为access  [SW-1-Ethernet0/0/1]...
  • 华为交换机技术白皮书,包含各个模块的技术说明,背景、命令行、场景分析等。包含各个系列配置说明指导总计9700多页
  • 华为路由器交换机实验手册【100页+40个实验】,内容非常丰富
  • 华为交换机配置OSPF动态路由.docx华为交换机配置OSPF动态路由.docx华为交换机配置OSPF动态路由.docx华为交换机配置OSPF动态路由.docx华为交换机配置OSPF动态路由.docx华为交换机配置OSPF动态路由.docx华为交换机配置...
  • 华为交换机配置OSPF动态路由.pdf华为交换机配置OSPF动态路由.pdf华为交换机配置OSPF动态路由.pdf华为交换机配置OSPF动态路由.pdf华为交换机配置OSPF动态路由.pdf华为交换机配置OSPF动态路由.pdf华为交换机配置OSPF...
  • 史上最全华为路由器交换机配置命令大合集(辛苦整理),史上最全华为路由器交换机配置命令大合集(辛苦整理)
  • 利用三层交换机实现rip动态路由配置。有详细的拓扑图和命令

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,328
精华内容 4,531
关键字:

华为交换机添加路由