精华内容
下载资源
问答
  • 网上搜索到了相对应的whl文件之后,利用pip install 安装whl文件,结果报错。例子如图。 这种情况是第一种情况,是因为安装的不是对应python版本的库。我机器使用的是python3.6版本,我所下载的文件为python2.7版本...

    第一种情况:

    最近在参加比赛的时候,碰到了以pip install xxx这种方式安装模块,却出现错误的问题。官方给的方法是通过whl文件重新安装。网上搜索到了相对应的whl文件之后,利用pip install 安装whl文件,结果报错。例子如图。
    在这里插入图片描述
    这种情况是第一种情况,是因为安装的不是对应python版本的库。我机器使用的是python3.6版本,我所下载的文件为python2.7版本的库,也就是cp27。
    假如我要成功安装,则需要下载cp36版本。

    第二种情况:

    另一种情况我没有遇到过,搜索得到的。
    方法:
    1、AMD64
    在shell中输入
    import pip._internal
    print(pip._internal.pep425tags.get_supported())
    可以获取到pip支持的文件名还有版本。
    在这里插入图片描述
    通过这里可以发现,如果你的文件名格式不符合以上文件名命名规则,则无法安装。可以手动修改whl文件名称成功安装。
    如whl文件名原名称为numpy-1.16.3-cp35-cp35m-win_amd64.whl
    修改为numpy-1.16.3-cp36-none-win_amd64.whl即可成功安装。
    (意思即为横线连接部分需要在这里面寻找到)

    2、WIN32
    在shell中输入
    import pip
    print(pip.pep425tags.get_supported())
    同理,由于我不是32位,所以没图~

    (参考帖子网址:https://blog.csdn.net/qq_33733970/article/details/80503022,http://www.cnblogs.com/nice-forever/p/5371906.html)

    展开全文
  • 咱们这里话接上一篇文章“python3安装wordcloud库出错及其解决办法(使用命令行安装)”,看到安装成功的提示欢天喜地,准备要一展身手,结果引入wordcloud报错 赶紧用pip list查看wordcloud是否安装成功了,安装...

    咱们这里话接上一篇文章“python3安装wordcloud库出错及其解决办法(使用命令行安装)”,看到安装成功的提示欢天喜地,准备要一展身手,结果引入wordcloud报错

     赶紧用pip list查看wordcloud是否安装成功了,安装成功了啊,怎么用不了啊

     再进入项目的第三方库查看一下是否有wordcloud,点击File-Settings打开,结果居然找不到

     本想查看一下到底wordcloud安装到哪里去了,不知道命令,那就先删除了吧,pip uninstall wordcloud,仔细一看居然有安装目录

    那咋把这个插件引入到自己的项目中呢,直接copy,把 wordcloud-1.8.1.dist-info和wordcloud文件夹直接copy到自己项目的venv-Lib-sit-packages目录下,再看wordcloud已经可以正常使用了

     开心,问题解决啦😄

    展开全文
  • pip install tensforflow 不能正常安装,通过本地下载whl文件后进行安装: 1.下载whl链接为: ... 2.下载完成后,通过pip进行安装: (base) E:\ProgramData\

    pip install tensforflow 不能正常安装,通过本地下载whl文件后进行安装:

    1.下载whl链接为:

    https://files.pythonhosted.org/packages/2f/45/68e41b073b17c49dc9f02648acfd43b029072786a229465c27e9554c993e/tensorflow-2.4.0-cp37-cp37m-win_amd64.whl

    2.下载完成后,通过pip进行安装:

    (base) E:\ProgramData\Anaconda3\Scripts>pip install C:\Users\Administrator\Downloads\tensorflow-2.4.0-cp37-cp37m-win_amd64.whl

    安装过程中,提示如下错误信息:

    Cannot uninstall 'wrapt'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

     如图所示:

    后手动安装 wrapt进行处理:

    pip install -U --ignore-installed wrapt enum34 simplejson netaddr

    tensorflow安装完成。

     

    验证tensorflow是否正常安装:

    首先验证tensorflow包是否正常安装:
     

    pip list|findstr "tensorflow"

    结果表明已正常安装。

    进入到python环境,输入 import tensorflow as tf 进行验证,报错如下:

    表明应该是缺少对应的dll动态库。

    手动下载对应的dll动态库,放入到C:\windows\system32下,下载链接:

    https://www.ijinshan.com/filerepair/cudart64_110.dll.shtml

    然后再次运行 导入命令:

    可以看到没有错误提示,已经成功。

     

    展开全文
  • conda安装本地whl文件

    2021-07-28 15:51:08
    conda安装本地whl文件(opencv, pytorch, torchvision等) 因为在线安装总是遇到报错,就直接离线下载安装 离线安装报错可能是因为代理没关,下图 下载torch,torchvision离线文件 网址:...

    conda安装本地whl文件(opencv, pytorch, torchvision等)

    因为在线安装总是遇到报错,就直接离线下载安装

    离线安装报错可能是因为代理没关,下图

    安装出错

    下载torch,torchvision离线文件

    网址:https://download.pytorch.org/whl/torch_stable.html
    里面有cpu和GPU版本的离线文件,下载对应版本(gpu版本要对应cuda)
    0

    下载好之后,打开Anaconda prompt

    建一个专门的环境,我已经建好了,这里直接激活
    在这里插入图片描述
    进入存放whl文件的路径,pip install 安装就可以
    1
    安装离线包

    展开全文
  • pip whl本地安装

    2020-08-20 10:54:24
    pip install +whl文件路径 如果timeout报错的话,可能是因为下载速度太慢,加个镜像再试下: pip install+whl文件路径+ -i http://pypi.douban.com/simple --trusted-host pypi.douban.com(也可以换其它国内镜像
  • pip离线通过whl文件安装包

    千次阅读 2020-05-31 19:30:24
    (作者:陈玓玏data-master) 在离线环境下,我们没有办法直接通过pip install来安装包,此时...找到你的python对应版本的whl文件,注意,不只是py2和py3哦,py27或py37等也要是对应的。 下载好whl后,通过pip安装pip
  • 原因是 本地python版本与 whl 的版本不匹配 查看本地版本是 3.7.6,而我的安装包需要的是3.9版本的,所以报错了 到 https://www.lfd.uci.edu/~gohlke/pythonlibs/ 这里下载与自己版本对应的包再安装即可 ...
  • pip 是一个安装和管理 Python 包的工具,wheel 本质上是一个 zip 包格式(文件后缀 whl ),用于 python 模块的安装。...此时可使用whl文件安装pip._internal.pep425tags.get_supported获取文件适配
  • 操作系统:ubuntu 16.04,python=2.7,从官网下载了pytorch=0.4.1的whl文件,用pip安装报错如下: 原因:pip安装whl文件时,对whl文件名的格式有要求。 whl文件的名称可分为5部分: 库的名称(torch) 版本...
  • 基于pip安装lxml库报错解决方案

    千次阅读 2018-08-22 15:20:00
    pip是python中经常使用可以便捷安装python其他库的一款软件,我们经常在命令行cmd中使用它。 安装lxml库的时候容易出现没法从网上安装twisted库的错误,解决方案是从将twisted库下载到本地后,用命令进行安装。 ...
  • 如何解决pip安装如下错误: XXX is not a supported wheel on this platform. 例如: pip install torch_scatter-2.0.6-cp38-cp38-linux_x86_64.whl 报错: XXX is not a supported wheel on this platform. ERROR...
  • 环境 本地python版本为:3.7.3 自带pip 需要下载pyinstaller 可使用pip install pyinstaller ...执行pyinstaller命令时,需要加-p参数来添加第三方库的路径,通过pip安装的第三方库,都在本地python的python\Lib\si...
  • 因为做网页爬虫,需要用到一个爬新闻的BeautifulSoup 的包,然后再关网上下的是whl包,第一次装,虽然花了点时间,最后还是装上去了,记录一下,方便下次。建议有时间可以看一下Python包的文档。Beautiful Soup 相比...
  • CentOS7.3 1611 pip离线安装python模块whl文件的陷阱1、环境简述2、安装过程1、源码包安装python3.7.92、获取pypi模块依赖列表3、获取pypi模块文件(*.whl)4、安装whl文件 1、环境简述 本人目前的项目要求是为一台...
  • python 安装本地whl

    2021-03-29 16:27:26
    下载需要的whl cmd 到 whl文件所在位置 前提:已经安装pip 然后输入:python -m pip install xxx(需要安装whl文件名称)
  • Pip 技巧 批量下载安装 WHL 文件

    千次阅读 2020-05-27 20:57:56
    最近入坑 NLP 了,开始正儿八经玩 Python ,那么 pip 的使用就必须要掌握了。 2. 修改 Pip 仓库地址为国内源 这个跟 maven 一样如果使用默认的国外仓库,很多时候速度感人 …如果想按时下班,那么更换国内源是必须的...
  • python3.X 使用pip 离线安装whl

    万次阅读 2017-01-07 23:44:59
    0. 绪论断网的环境下配置python开发环境非常讨厌,本文... pip 1.5.2 友情提示:出现问题时候,看日志是王道!计算机不会犯错!机器上python2,3混用的问题,参考: http://blog.csdn.net/wangyaninglm/article/det
  • python安装本地包方法及报错的解决python安装本地报错一:is not a supported wheel on this...“PyOpenGL-3.1.5-cp37-cp37m-win_amd64.whl ”是要安装whl文件 报错一:is not a supported wheel on this platform.
  • 关于pip install [packages]报错的完美解决方法 错误信息 pip install [packages]报如下错误 ERROR: Command errored out with exit status 1: command: 'c:\users\lun\appdata\local\programs\python\python39\...
  • 如图,下载了一个pytorch wheel安装文件,如何安装它呢? 像我的话,只需要在文件所在文件夹打开控制台窗口,输入: pip install torch-1.1.0-cp36-cp36m-win_amd64....参考文章:Python模块 使用pip安装wheel文件 ...
  • 关于给python安装.whl文件的一些问题

    万次阅读 热门讨论 2018-01-17 01:33:02
    作为一个刚入行的计算机研究生,最近学习python遇到了一系列问题,今天纠结一整天,这里做一些小总结: 先提供下载whl文件的地址:...2 安装.whl文件,首先我们要用命令提示符在cmd下,进入.whl文件所在目录。如下图,
  • (https://pytorch.org/)给的pip方式安装不行,于是进入下面的网址,[troch、torchvision、torchaudio 的.whl文件下载地址](https://download.pytorch.org/whl/torch_stable.html)下载.whl文件本地,再安装
  • python 安装whl文件

    万次阅读 2018-08-13 23:49:54
    python 安装whl文件 使用场景:在terminal中 通过 pip install 命令进行第三方模块安装时,由于网络获其他原因会使得第三方模块下载失败,导致安装失败。此时,我们可以先通过下载网址将第三方模块包手动下载到...
  • .whl 是 Python 的一种第三方包安装文件,最近在树莓派上的虚拟环境中使用如下命令: pip install tensorflow-2.4.0-cp37-none-linux_armv7l.whl 安装 tensorflow 的 .whl 文件过程中总是抛出异常信息:zipfile....
  • 现象以下是我安装时的命令和报错信息,公司不允许上外网,所以下载了模块,进行离线安装D:\program\Python 2.7.12\Scripts>pip install --no-index --find-links="D:\program \Python 2.7.12\packages" ...
  • 使用pip install sshtunnel报错error: Microsoft Visual C++ 14.0 is required,网上的解决办法都是安装Microsoft Visual C++ Build Tools,我也打算这样解决,下载以后发现要装2个G,果断放弃了。 想了一下pip在线...
  • Pyhon3.4以后,pip都默认跟Python一块安装pip在python安装目录中的位置如下:执行方法:运行【win+R】+cmd,执行pip,查看是否安装成功。(找不到命令,则需要手动添加到环境变量)python官方提供了一个pypi库...
  • 这里把学习到的pip命令写一个汇总,方便想不起来时使用 通过cmd输入pip可以显示提示信息,中文翻译如下: 1)显示某个包的信息 pip show selenium #显示selenium模块的信息   2)显示所有包的列表 ...
  • 一、安装beautifulsoup4-4.9.3-py3-none-any.whl报错 报错内容:Could not find suitable distribution for ...1、在https://pypi.org/ 找到soupsieve,下载最新的whl文件 2、安装soupsieve新版本 pip install so

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,823
精华内容 729
关键字:

pip安装本地whl文件报错