精华内容
下载资源
问答
  • 放置一台主机、一台服务器,并用自动连线相连。 给PC主机设置IP地址: 给服务器配置IP地址: 打开仿真模式,隐藏其他网络协议,只显示HTTP协议:点击Misc,选择HTTP。 打开计算机中的浏览器,输入服务器的IP地址...

    放置一台主机、一台服务器,并用自动连线相连。
    在这里插入图片描述
    给PC主机设置IP地址:
    在这里插入图片描述
    给服务器配置IP地址:
    在这里插入图片描述
    打开仿真模式,隐藏其他网络协议,只显示HTTP协议:点击Misc,选择HTTP。
    打开计算机中的浏览器,输入服务器的IP地址。点击右侧的捕获/前进按钮,在右上侧的事件列表中,查看详情。
    在这里插入图片描述
    再次点击捕获/前进,服务器收到HTTP请求。
    在这里插入图片描述

    展开全文
  • 在某公司通过一个路由器与公网互联,内网通过一台交换机将所有电脑互联,在交换机上面划分两个VLAN,公司内部的PC通过各自所在的VLAN自动获取IP地址,然后去访问公网上面的Web服务器。本任务的实验拓扑如图所示: ...

    期末考查评分标准 A

    一、任务描述

    在某公司通过一个路由器与公网互联,内网通过一台交换机将所有电脑互联,在交换机上面划分两个VLAN,公司内部的PC通过各自所在的VLAN自动获取IP地址,然后去访问公网上面的Web服务器。本任务的实验拓扑如图所示:

    二、拓扑结构与训练要求

    三、相关基础知识、概念与网络设备:DHCP、VLAN、DNS、NAT、路由器、交换机等

    DHCPDynamic Host Configuration Protocol,动态主机配置协议)通常被应用在大型的局域网络环境中,主要作用是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用率。

    DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。DHCP具有以下功能:

    1. 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。

    2. DHCP应当可以给用户分配永久固定的IP地址。

    3. DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。

    4. DHCP服务器应当向现有的BOOTP客户端提供服务。

    DHCP有三种机制分配IP地址:

    1) 自动分配方式(Automatic Allocation),DHCP服务器为主机指定一个永久性的IP地址,一旦DHCP客户端第一次成功从DHCP服务器端租用到IP地址后,就可以永久性的使用该地址。

    2) 动态分配方式(Dynamic Allocation),DHCP服务器给主机指定一个具有时间限制的IP地址,时间到期或主机明确表示放弃该地址时,该地址可以被其他主机使用。

    3) 手工分配方式(Manual Allocation),客户端的IP地址是由网络管理员指定的,DHCP服务器只是将指定的IP地址告诉客户端主机。

    三种地址分配方式中,只有动态分配可以重复使用客户端不再需要的地址。

    DHCP消息的格式是基于BOOTPBootstrap Protocol)消息格式的,这就要求设备具有BOOTP中继代理的功能,并能够与BOOTP客户端和DHCP服务器实现交互。BOOTP中继代理的功能,使得没有必要在每个物理网络都部署一个DHCP服务器。RFC 951RFC 1542BOOTP协议进行了详细描述

    VLANVirtual Local Area Network)的中文名为"虚拟局域网"

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

    在计算机网络中,一个二层网络可以被划分为多个不同的广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同的广播域是相互隔离的。不同的广播域之间想要通信,需要通过一个或多个路由器。这样的一个广播域就称为VLAN

    DNSDomain Name System域名系统),万维网上作为域名和IP地址相互映射的一个分布式数据库,能够使用户更方便的访问互联网,而不用去记住能够被机器直接读取的IP数串。通过域名,最终得到该域名对应的IP地址的过程叫做域名解析(或主机名解析)。DNS协议运行在UDP协议之上,使用端口号53

    DNS功能

    每个IP地址都可以有一个主机名,主机名由一个或多个字符串组成,字符串之间用小数点隔开。有了主机名,就不要死记硬背每台IP设备的IP地址,只要记住相对直观有意义的主机名就行了。这就是DNS协议的功能。

    主机名到IP地址的映射有两种方式:

     

    1)静态映射,每台设备上都配置主机到IP地址的映射,各设备独立维护自己的映射表,而且只供本设备使用;

    2)动态映射,建立一套域名解析系统(DNS),只在专门的DNS服务器上配置主机到IP地址的映射,网络上需要使用主机名通信的设备,首先需要到DNS服务器查询主机所对应的IP地址 [1] 

    通过主机名,最终得到该主机名对应的IP地址的过程叫做域名解析(或主机名解析)。在解析域名时,可以首先采用静态域名解析的方法,如果静态域名解析不成功,再采用动态域名解析的方法。可以将一些常用的域名放入静态域名解析表中,这样可以大大提高域名解析效率

    NATNetwork Address Translation,网络地址转换)是1994年提出的。当在专用网内部的一些主机本来已经分配到了本地IP地址(即仅在本专用网内使用的专用地址),但现在又想和因特网上的主机通信(并不需要加密)时,可使用NAT方法。

    这种方法需要在专用网连接到因特网的路由器上安装NAT软件。装有NAT软件的路由器叫做NAT路由器,它至少有一个有效的外部全球IP地址。这样,所有使用本地地址的主机在和外界通信时,都要在NAT路由器上将其本地地址转换成全球IP地址,才能和因特网连接。

    NAT的实现方式有三种,即静态转换Static Nat、动态转换Dynamic Nat和端口多路复用OverLoad

    静态转换是指将内部网络的私有IP地址转换为公有IP地址,IP地址对是一对一的,是一成不变的,某个私有IP地址只转换为某个公有IP地址。借助于静态转换,可以实现外部网络对内部网络中某些特定设备(如服务器)的访问。

    动态转换是指将内部网络的私有IP地址转换为公用IP地址时,IP地址是不确定的,是随机的,所有被授权访问上Internet的私有IP地址可随机转换为任何指定的合法IP地址。也就是说,只要指定哪些内部地址可以进行转换,以及用哪些合法地址作为外部地址时,就可以进行动态转换。动态转换可以使用多个合法外部地址集。当ISP提供的合法IP地址略少于网络内部的计算机数量时。可以采用动态转换的方式。

    端口多路复用(Port address Translation,PAT)是指改变外出数据包的源端口并进行端口转换,即端口地址转换PATPort Address Translation).采用端口多路复用方式。内部网络的所有主机均可共享一个合法外部IP地址实现对Internet的访问,从而可以最大限度地节约IP地址资源。同时,又可隐藏网络内部的所有主机,有效避免来自internet的攻击。因此,目前网络中应用最多的就是端口多路复用方式。

    路由器(Router),是连接因特网中各局域网广域网的设备,它会根据信道的情况自动选择和设定路由,以最佳路径,按前后顺序发送信号。 路由器是互联网络的枢纽,"交通警察"目前路由器已经广泛应用于各行各业,各种不同档次的产品已成为实现各种骨干网内部连接、骨干网间互联和骨干网与互联网互联互通业务的主力军。路由和交换机之间的主要区别就是交换机发生在OSI参考模型第二层(数据链路层),而路由发生在第三层,即网络层。这一区别决定了路由和交换机在移动信息的过程中需使用不同的控制信息,所以说两者实现各自功能的方式是不同的。

    路由器(Router)又称网关设备Gateway)是用于连接多个逻辑上分开的网络,所谓逻辑网络是代表一个单独的网络或者一个子网。当数据从一个子网传输到另一个子网时,可通过路由器的路由功能来完成。因此,路由器具有判断网络地址和选择IP路径的功能,它能在多网络互联环境中,建立灵活的连接,可用完全不同的数据分组和介质访问方法连接各种子网,路由器只接受源站或其他路由器的信息,属网络层的一种互联设备。

    交换机(Switch)意为开关是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。其他常见的还有电话语音交换机、光纤交换机等。

    四、配置步骤

    配置代码:
    ########################################
    Server
    Router>en
    Router#config
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#no ip domain-lookup
    Router(config)#host Server
    Server(config)#line con 0
    Server(config-line)#logg syn
    Server(config-line)#exec-timeout 0 0
    Server(config-line)#exit
    Server(config)#int s0/0/0
    Server(config-if)#ip add 202.1.1.1 255.255.255.0
    Server(config-if)#ip nat outside
    Server(config-if)#no shut
    
    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
    Server(config-if)#exit
    Server(config)#access-list 1 permit 192.168.1.0 0.0.0.255
    Server(config)#ip nat inside source list 1 interface s0/0/0
    Server(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
    Server(config)#exit
    ########################################
    ISP
    Router>en
    Router#config
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#host ISP
    ISP(config)#no ip domain-lookup
    ISP(config)#line con 0
    ISP(config-line)#logg syn
    ISP(config-line)#exec-timeout 0 0
    ISP(config-line)#exit
    ISP(config)#int s0/0/0	
    ISP(config-if)#ip add 202.1.1.2 255.255.255.0
    ISP(config-if)#no shut
    
    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
    
    ISP(config-if)#
    ISP(config-if)#clock rate 64000
    ISP(config-if)#exit
    ISP(config)#int f0/0
    ISP(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
    
    ISP(config-if)#ip add 202.2.2.2 255.255.255.0
    ISP(config-if)#no shut
    
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    ISP(config-if)#
    ISP(config-if)#int f0/1
    ISP(config-if)#ip add 202.3.3.3 255.255.255.0
    ISP(config-if)#no shut
    
    %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    
    ISP(config-if)#
    ISP(config-if)#
    ########################################
    Server#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
    
    Server#config
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Server(config)#int f0/0.1
    Server(config-subif)#encapsulation dot1Q 2
    Server(config-subif)#ip add 192.168.1.1 255.255.255.0
    Server(config-subif)#no shut
    Server(config-subif)#exit
    Server(config)#int f0/0.2
    Server(config-subif)#encapsulation dot1Q 3
    Server(config-subif)#ip add 192.168.2.1 255.255.255.0
    Server(config-subif)#no shut
    Server(config-subif)#exit
    Server(config)#ip dhcp pool vlan2
    Server(dhcp-config)#network 192.168.1.0 255.255.255.0
    Server(dhcp-config)#dns 202.2.2.1
    Server(dhcp-config)#default-router 192.168.1.1
    Server(dhcp-config)#exit
    Server(config)#ip dhcp pool vlan3
    Server(dhcp-config)#network 192.168.2.0 255.255.255.0
    Server(dhcp-config)#dns 202.2.2.1
    Server(dhcp-config)#default-router 192.168.2.1
    Server(dhcp-config)#exit
    Server(config)#ip dhcp excluded-address 192.168.1.1
    Server(config)#ip dhcp excluded-address 192.168.2.1
    Server(config)#access-list 1 permit 192.168.2.0 0.0.0.255
    Server(config)#exit
    Server#
    %SYS-5-CONFIG_I: Configured from console by console
    
    Server#config
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Server(config)#int f0/0.1
    Server(config-subif)#ip nat inside
    Server(config-subif)#exit
    Server(config)#int f0/0.2
    Server(config-subif)#ip nat inside
    Server(config-subif)#exit
    Server(config)#
    Server(config)#interface FastEthernet0/0
    Server(config-if)#no shutdown
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    Server(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up
    %LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.2, changed state to up
    Server(config-if)#
    ########################################
    

    五、测试与结果

    • 在内网路由器Server上配置DHCP,实现下连交换机上处于不同Vlan的电脑获得相应的IP地址。
    • 查看公司内网的所有PC是正确分配到自己所在的VLAN的相应的IP地址。
    • 在PC上使用浏览器能通过www.cisco.com的域名访问ISP端的WWW服务器的网页。

    六、结束语

    感谢老师的指导,感谢父母的培养,我一定好好学习,努力学好Cisco。通过这次的期末作业,使我懂了很多,也收获了很多知识,自己的动手能力和思维方式得到解放。

     

     

     

     

     

     

    展开全文
  • 当主机与某WEB服务器同在防火墙的INSIDE口,但DNS服务器只存在于公网中,(OUTSIDE口)且防火墙上对内网的WEB服务器进行了静态NAT映射以与外界通信并被外界DNS解析,为了防止本地用户在访问WEB服务器URL时被外网解析...

            当主机与某WEB服务器同在防火墙的INSIDE口,但DNS服务器只存在于公网中,(OUTSIDE口)且防火墙上对内网的WEB服务器进行了静态NAT映射以与外界通信并被外界DNS解析,为了防止本地用户在访问WEB服务器URL时被外网解析DNS为防火墙映射公网地址,需要对外网DNS reply进行修改。

    思科ASA防火墙让内网用户能通过域名访问内网WEB服务器 - 海笑 - 海的印记

    1.用户穿过查询web服务器DNS

    2.DNS回应给用户WEB服务器的公网地址

    3.防火墙上收到该DNS reply,并进行修改

    4.用户得到一个将WEB服务器解析为内网地址的DNS reply

    相关命令:static (inside,outside) 公网地址 内网地址 netmask 。。。 dns

    配置举例:(防火墙为思科ASA 5520-K8,公网IP:209.165.201.10,内网web服务器ip:10.1.3.14)

    ASA Version 8.2(1)
    !
    hostname ciscoasa
    enable password 9jNfZuG3TC5tCVH0 encrypted
    passwd 9jNfZuG3TC5tCVH0 encrypted
    names
    !
    interface GigabitEthernet0/0
     nameif outside
     security-level 0
     ip address 209.165.201.10 255.255.255.252
    !
    interface GigabitEthernet0/1
     nameif inside
     security-level 100
     ip address 192.168.0.1 255.255.255.0
    !
    interface GigabitEthernet0/2
     shutdown
     no nameif
     no security-level
     no ip address
    !
    interface GigabitEthernet0/3
     shutdown
     no nameif
     no security-level
     no ip address
    !
    interface Management0/0
     nameif management
     security-level 100
     no ip address
     management-only
    !
    ftp mode passive
    clock timezone GMT 0
    access-list no-nat extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.
    255.255.0
    access-list vpnclient_splittunnelacl standard permit 192.168.1.0 255.255.255.0
    access-list 103 extended permit tcp any host 209.165.201.10 eq www
    access-list 103 extended permit tcp any host 209.165.201.10 eq 8080
    access-list 103 extended permit tcp any host 209.165.201.10 eq ftp
    access-list 103 extended permit tcp any host 209.165.201.10 eq 9091
    pager lines 24
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool vpnpool 192.168.3.1-192.168.3.253 mask 255.255.255.255
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list no-nat
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www 10.1.3.14 www netmask 255.255.255.25
    5  dns
    static (inside,outside) tcp interface 9091 10.1.3.14 9091 netmask 255.255.255.
    255  dns
    static (inside,outside) interface 10.1.3.14 netmask 255.255.255.255 dns
    access-group 103 in interface outside
    route outside 0.0.0.0 0.0.0.0 117.35.203.113 1
    route inside 192.168.0.0 255.255.0.0 192.168.0.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 0.0.0.0 0.0.0.0 inside
    http authentication-certificate inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set vpnset esp-des esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map outside-dyn-map 10 set transform-set vpnset
    crypto dynamic-map outside-dyn-map 10 set security-association lifetime seconds
    288000
    crypto dynamic-map outside-dyn-map 10 set reverse-route
    crypto map outside-map 10 ipsec-isakmp dynamic outside-dyn-map
    crypto map outside-map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
     authentication pre-share
     encryption 3des
     hash md5
     group 2
     lifetime 43200
    crypto isakmp nat-traversal 10
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl encryption des-sha1
    webvpn
    group-policy vpnclient internal
    group-policy vpnclient attributes
     vpn-tunnel-protocol IPSec
     split-tunnel-policy tunnelspecified
     split-tunnel-network-list value vpnclient_splittunnelacl
    username xytcm password InK4eTDOXqaQOloU encrypted
    username u0113 password COijz8/i0aYn1u0z encrypted
    username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15
    tunnel-group vpnclient type remote-access
    tunnel-group vpnclient general-attributes
     default-group-policy vpnclient
    tunnel-group vpnclient ipsec-attributes
     pre-shared-key *
    !
    class-map inspection_default
     match default-inspection-traffic
    !
    !
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum 512
      message-length maximum client auto
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect icmp
    !
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:953843e4c1242653603e11601e3a6969
    : end

     


    此种配置方法最后导致内网的电脑不能通过ASA访问远程VPN服务器,汗!
    展开全文
  • 如何通过域名访问web项目

    千次阅读 2018-12-11 18:03:44
    查看网页的时候都是通过域名来访问的,我就感觉很好奇啊,想着能不能让自己的项目也通过域名访问,今天我就研究了一下。 但是,也只能用http来访问,因为htttps要申请证书,是需要买的,可怜我个穷鬼,,, 此次,...

    一般而言,我之前做的项目都是通过localhost:8080/xxx或者127.0.0.1:8080/xxx来访问项目,xxx(项目名)。查看网页的时候都是通过域名来访问的,我就感觉很好奇啊,想着能不能让自己的项目也通过域名访问,今天我就研究了一下。

    但是,也只能用http来访问,因为htttps要申请证书,是需要买的,可怜我个穷鬼,,,

    此次,是在一个网站上申请的一个免费的域名,不过试用期只要一个月,续费的话也只是一个月1块钱,http的。

    网址:https://echosite.2bdata.com,上面的教程还是很详细的,用起来也很简单。

    1.申请域名

    2.下载客户端和配置文件,放到一个文件夹里面:

    3.修改配置文件echosite.yml

    注释上很详细了,可支持一个或多个映射。

    4.运行

    在该目录下按着‘shift’右键打开命令窗口,执行以下命令:echosite -config=echosite.yml start name1 

    出现如下,恭喜你,ok了。

    trust_host_root_certs: false 默认是false,意思是不开启SSL,也就是说不能用https访问,我将其改为true试了一下,发现根本开启不了,也就是说开启不了SSL。

    希望能帮到你!

    展开全文
  • ▶ 网络拓扑及配置 ▶ PC访问测试
  • 初试Cisco Packet Tracer–4——部署DHCP、DNS、Web服务器 1.实验环境 1.win10 2.Cisco Packet Tracer-7.3.1.0362(下载链接) 2.环境搭建 网络拓扑图 3台server设备、3台PC设备、1台交换机2960 DHCP服务器配置,...
  • 小型网络拓扑 不同vlan相互通信 pc通过dns域名解析访问服务器 华为与思科模拟实现 pc0与pc2配置命令: 二层交换机: //创建vlan10,与fa0/1 fa0/2 绑定: Ena Conf t Vlan 10 Int fa0/1 Switchport access vlan 10 ...
  • Internet中一台计算机访问Web服务器的全部过程,从中可以窥探Internet是如何工作的,本讲中会涉及到网络(或Internet)的专业术语、概念及Internet的重要内容,在以后的讲座中我们会详细讲解。本讲主要是想让大家明...
  • 使用Packet Tracer软件实现路由器,服务器,DNS域名服务器的配置及访问实现
  • Alias的两个功能: 利用DNS Doctoring修正外部DNS服务器回复 o 利用DNS Doctoring,PIX 将"改变" 外部DNS响应的地址到另一个IP,这个地址不同于DNS服务器上真实提供的域名-IP记录。 o 此功能实现从内部客户端通过内部...
  • web 服务器内网地址为 10.0.0.1 外网地址为 211.6.15.1 域名为 xx.love.com 问题:在内网10.0.0.2的机器上访问 外网地址 211.6.15.1 或者域名 xx.love.com  都无法访问,  解
  • cisco路由器做nat之后,内网只能通过内网的dns或者ip才可以访问内网服务器,不可以使用公网域名。其实解决起来很简单。下面介绍一下如何解决。 网络如图所示,某公司有一个合法IP地址,有一个WEB服务器对外提供服务...
  • 配置DNS服务器以及WEb服务器

    千次阅读 2019-07-25 13:18:06
    以下所有配置全部使用的是 Linux系统服务器 安装DNS服务 在正向查找添加tedu.cn 添加主机记录 添加别名 记录 在访问机上的DNS设为自建 使用nslookup查询域名解析 查询ftp.tedu.cn 配置虚拟web主机 注册两个...
  • 配制ciscoweb方式的访问

    千次阅读 2013-11-14 18:03:49
    怎样配制ciscoweb方式的访问 Cisco路由器进行HTTP访问 ip http server username 2008-05-06 17:57 Cisco IOS的这种特征使得通过浏览器实现对路由器的访问管理,这对那些更习惯于使用浏览器界面的用户...
  • 模拟器访问PC机WEB服务器方法

    千次阅读 2010-10-16 22:08:00
    模拟器默认访问PC机的IP地址为: http://10.0.2.2/如果要用域名访问,可以用APACHE做代理处理:ProxyPass / http://www.localhost.com/或者修改模拟器的HOST做下域名解析处理,例如在HOST加入: 10.0.2.2 ...
  • 摘要: 负载均衡(Load Balance)是集群技术(Cluster)的一种应用。负载均衡可以将工作任务分摊到多个处理单元,从而提高并发处理能力。...什么是web负载均衡服务器集群(Cluster)使得多个服务器节点能够协同工
  • 实验环境:思科模拟器Cisco Packet Tracer IP地址划分: WEB:192.168.1.1 DNS:192.168.1.2 ...内网能正常访问外网,外网只能访问内网的DNS服务器和WEB服务器 实验拓扑图: 在路由器上的配置: 1、添加标准A...
  • Web服务器配置与管理

    千次阅读 2015-12-27 19:24:00
    Web 服务器配置与管理 一.目的:  主要目的是学习网络服务器配置,包括IIS 配置方法、 Apache 配置 ... (3)制作简单网页验证Web服务器配置情况。 三.环境:  (1)WindowsXP/Windows Server 2003  
  • 公网IP地址如下:218.2.135.1/29~218.2.135.6/29他想用218.2.135.1/29这个IP地址让内部的PC去访问外网,其它的几个IP地址都分配给内部的服务器使用,这三台内部的服务器需要提供给外网用户访问。在这里PC1与PC2在...
  • 分分钟带你学会DNS、WEB、DHCP服务器的搭建

    千次阅读 多人点赞 2019-08-06 13:49:28
    分分钟带你学会DNS服务器、WEB服务器、DHCP服务器的搭建 DNS 一、DNS(Domain Name Server,域名服务器)是进行域名(domain name)和与之相对应的IP地址 (IP address)转换的服务器。DNS中保存了一张域名(domain ...
  • 好吧,我承认这个标题挺难读 , 从一会儿内网一会儿公网一会儿又内网的。 但是这确实一个很实在的问题。如果你用的是ASA或其他防火墙,可以直接 ...如图所示: 内网的一台电脑需要通过互联网的DNS访问内网的一
  • 应用请求web服务器的过程详解

    千次阅读 2014-11-25 00:16:45
    在这一讲中我们要了解一下Internet中一台计算机访问Web服务器的全部过程,从中可以窥探Internet是如何工作的,本讲中会涉及到网络(或Internet)的专业术语、概念及Internet的重要内容,在以后的讲座中我们会详细...
  • Packer tracer实验——DNS、web服务器配置

    千次阅读 多人点赞 2019-11-19 11:01:53
    文章目录网络拓扑图配置域名服务器(DNS)服务器:PC机: 网络拓扑图 配置 域名服务器(DNS) 对于Server5,配置域名服务器: 首先是IP地址、子网掩码、默认网关: Services->DNS,开启DNS服务,并添加地址和...
  • Packet_Tracer服务器配置

    2012-11-10 17:24:21
    Cisco_Packet_Tracer服务器配置_邮件传送_ftp_web_email_dns_dhcp图解
  • Web服务器常用端口

    万次阅读 2017-11-09 13:49:39
    DHCP:服务器端的端口号是67 DHCP:客户机端的端口号是68 POP3:POP3仅仅是接收协议,POP3客户端使用SMTP向服务器发送邮件。POP3所用的端口号是110。 SMTP: 端口号是25。SMTP真正关心的不是邮件如何被传送,而只...
  • 某公司通过一个路由器与公网互联,内网通过一台交换机将所有的计算机互联,在交换机上划分两个Vlan,公司内部的计算机通过各自所在的Vlan自动获取IP地址,然后访问公网的Web服务器如下图所示: 如本案例中用到的DNS...
  • Internet中一台计算机访问Web服务器的全部过程,从中可以窥探Internet是如何工作的,本讲中会涉及到网络(或Internet)的专业术语、概念及Internet的重要内容,在以后的讲座中我们会详细讲解。本讲主要是想让大家明...
  • 实现的网络拓扑图如下: web-dns 服务器基本配置如下: DNS加入域名www.zlq.com做...开始实验服务验证: PC0自动获取地址如下: PC0能够ping 通192.168.10.20且web端能够正常访问域名zlq.com(web-dns 服务器正常)
  • 两台 2811路由器是通过DCE串口互联,在内部路由器Server上配置NAT实现内网计算机访问互联网,在DNS服务器上做DNS配置,使公司内部能使用该DNS服务器地址访问Web服务器上的网页。 1、无线路由器的WAN端口接入内部...
  • 今天公司ERP告诉我说我公司的一台对外WEB服务器无法从外网访问,我直接在IE中输入域名,发现可以访问(服务器和我的电脑在同一防火墙下面,对外的WEB服务器做了1-TO-1映射了一个外网IP地址)。找了一台ADSL直接访问...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,552
精华内容 1,820
关键字:

思科域名访问web服务器