精华内容
下载资源
问答
  • 以及控制不同部门、不同站点之间互相访问VLAN转发技术原理vlan转发技术原理:在以太网中,交换机根据目的MAC地址来查MAC地址表进行数据帧的转发,MAC地址表中包含MAC地址与端口的一一对应关系...

    VLAN

    虚拟局域网

        VLAN:Virtual Local Area Network,虚拟局域网。通过划分不同的vlan,不仅可以隔离广播,防止广播风暴;还可以使网络拓扑更加灵活;以及控制不同部门、不同站点之间互相访问

    VLAN转发技术原理

        vlan转发技术原理:在以太网中,交换机根据目的MAC地址来查MAC地址表进行数据帧的转发,MAC地址表中包含MAC地址与端口的一一对应关系,当交换机收到一个数据帧时,会查看该数据帧中的MAC地址,如果是一个单播帧,交换机会根据MAC地址表从对应的端口转发出去;如果是广播帧,交换机则会从除开收到该广播帧意外的所有端口发送出去。

        但是在vlan技术中,交换机在数据帧中加上了一个标签,交换机在查MAC表对的过程中还要检查端口上的标签是否匹配,交换机只会在属于这个标签的端口上进行转发,如果不是就不进行转发操作。下图是VLAN之间的通信结果展示

    596708208220c9bd461e5e9935d183d3.png

        此时已经实现了广播域的隔离,但是要怎样才能让不同的vlan之间能够互相通信呢?vlan间的路由可以解决这个问题

    • 实验拓扑

    80be28a28ef0db22938b1ff315f56cb2.png

    • 实验配置

    R-1

    interfaceEthernet0/0

     no shutdown

     no ip address

    interfaceEthernet0/0.1

     no shutdown

     encapsulation dot1Q 10

     ip address 10.1.1.1 255.255.255.0

    interfaceEthernet0/0.2

     no shutdown

     encapsulation dot1Q 20

     ip address 10.1.2.1 255.255.255.0

    SW-1

    interfaceEthernet0/0

     no shutdown

     switchport access vlan 10

     switchport mode access

    interfaceEthernet0/1

     no shutdown

     switchport access vlan 20

     switchport mode access

    interfaceEthernet0/2

     no shutdown

     switchport trunk encapsulation dot1q

     switchport mode trunk

    SW-2
    interfaceEthernet0/0

     no shutdown

     switchport access vlan 10

     switchport mode access

    interfaceEthernet0/1

    no shutdown

    switchport access vlan 20

     switchport mode access

    interfaceEthernet0/2

     no shutdown

     switchport trunk encapsulation dot1q

    switchport mode trunk

    interfaceEthernet0/3

     no shutdown

     switchport trunk encapsulation dot1q

     switchport mode trunk
    • 实验结果

        四台PC之间能够互相通信

    点击下方“阅读原文”查看更多"vlan间的路由"↓↓↓

    -END-

    2c6d7f248d5256742ae7c28b1078b7d6.png

    点击留言不迷路,大家一起上高速

    d2233900a1000bed74b5664776d8d9ad.gif

    展开全文
  • 之前讨论的都是思科的,今天咱们具体讨论内容包含VLAN级联的静态配置; 通过GVRP协议实现的VLAN级联的动态配置;端口Hybrid特性配置;PVlan特性配置。实验一:vlan静态配置:在完成VLAN的相关配置之后,要求能够达到...

    之前讨论的都是思科的,今天咱们具体讨论内容包含VLAN级联的静态配置; 通过GVRP协议实现的VLAN级联的动态配置;端口Hybrid特性配置;PVlan特性配置。

    实验一:vlan静态配置:

    a51f79b45b9f74b33304342712647fa6.png

    在完成VLAN的相关配置之后,要求能够达到同一VLAN内的PC可以互通,不同VLAN间的PC不能互通的目的。首先按照上图连接各实验设备,然后配置PCA IP地址为10.1.1.2/24,PCB IP地址为10.1.2.2/24,PCC IP地址为10.1.1.3/24,PCD IP地址为10.1.2.3/24。

    1. 具体的配置如下:

    (1) 配置交换机端口属于特定VLAN

    [Quidway]sysname S3026A

    [S3026A]vlan 2

    [S3026A-vlan2]port Ethernet 0/9 to e0/16

    [S3026A-vlan2]vlan 3

    [S3026A-vlan3]port Ethernet 0/17 to e0/24

    [Quidway]sysname S3026B

    [S3026B]vlan 2

    [S3026B-vlan2]port Ethernet 0/9 to e0/16

    [S3026B-vlan2]vlan 3

    [S3026B-vlan3]port Ethernet 0/17 to e0/24

    当配置交换机端口属于特定VLAN时,有两种方法:一种是上面介绍的在VLAN配置模式下进行,另一种是在端口配置模式下进行,大家有兴趣可以试试看。

    (2) 配置交换机之间的端口为Trunk端口,并且允许所有VLAN通过

    [S3026A]int e0/1

    [S3026A-Ethernet0/1]port link-type trunk //设置端口工作在trunk模式(系统默认为access模式)

    [S3026A-Ethernet0/1]port trunk permit vlan all //允许所有VLAN通过Trunk端口

    [S3026B]int e0/1

    [S3026B-Ethernet0/1]port link-type trunk

    [S3026B-Ethernet0/1]port trunk permit vlan all

    配置完成后,可以看到,同一VLAN内部的PC可以互相访问,不同VLAN间的PC不能够互相访问。

    在S3026A和S3026B之间增加交换机S3526C,同样实现上述实验目标:VLAN内互通,VLAN间隔离。组网图如下:

    fc5870899869721e9140fca2382186ea.png

    继续上面的实验,这时候,我们需要修改三台交换机e0/1和e0/2接口的配置。

    配置步骤如下:

    (1) 配置三台交换机之间链路为trunk链路

    [Quidway]sysname S3526C

    [S3526C]int e0/1

    [S3526C-Ethernet0/1]port link-type trunk

    [S3526C-Ethernet0/1]port trunk permit vlan all

    [S3526C-Ethernet0/1]int e0/2

    [S3526C-Ethernet0/2]port link-type trunk

    [S3526C-Ethernet0/2]port trunk permit vlan all

    完成上述配置之后,我们可以测试一下VLAN内的主机之间是否可以ping通。结果是否定的,这是因为在交换机S3526C没有配置VLAN2和VLAN3,所以来自VLAN2和VLAN3的帧不能通过。必须在交换机上创建VLAN2和VLAN3,这样,这二个VLAN的帧才能够通过S3526C。

    (2) 在S3526C上创建VLAN2和VLAN3

    [S3526C]vlan 2

    [S3526C-vlan2]vlan 3

    如果S3026A和S3026B之间连接了多台交换机,是否需要在每一台交换机上都创建VLAN2和VLAN3?如果接入用户的交换机配置了许多VLAN,是否需要在每一台交换机上都创建这些VLAN?

    答案是肯定的。如果VLAN众多,这样的静态VLAN配置工作会很复杂。通过GVRP协议,在交换机上动态的创建和注册VLAN,避免了手工配置之苦。

    实验二:动态配置

    f589c11b6135f35698a2732f2116ec37.png

    1. 具体的配置如下:

    延续上面的实验配置。

    (1) 删除S3526上的VLAN创建:

    [S3526C]undo vlan 2

    [S3526C]undo vlan 3

    (2) 在三台交换机上配置VLAN动态注册协议——GVRP:

    首先在系统配置模式下启用GVRP协议。

    [S3526C]gvrp

    GVRP is enabled globally

    然后在每一个trunk端口启用GVRP协议。

    [S3526C]int e0/1

    [S3526C-Ethernet0/1]gvrp

    GVRP is enabled on port Ethernet0/1

    [S3526C-Ethernet0/1]int e0/2

    [S3526C-Ethernet0/2]gvrp

    GVRP is enabled on port Ethernet0/2

    在S3026A和S3026B上进行相同的配置,即在系统模式下和端口模式下分别启用GVRP协议。然后我们可以用下面的命令来察看配置的GVRP信息和VLAN信息。我们可以看到,在S3526C上,GVRP已经启用,并且自动学习创建了VLAN2和VLAN3。

    [S3526C]display gvrp statistics

    GVRP statistics on port Ethernet0/1

    GVRP Status : Enabled

    GVRP Failed Registrations : 0

    GVRP Last Pdu Origin : 00e0-fc07-7085

    GVRP Registration Type : Normal

    GVRP statistics on port Ethernet0/2

    GVRP Status : Enabled

    GVRP Failed Registrations : 0

    GVRP Last Pdu Origin : 00e0-fc07-7089

    GVRP Registration Type : Normal

    [S3526C]display vlan

    Now, the following VLAN exist(s):

    1(default), 2-3

    (3) 3. 接下来我们可以通过如下的方法来观察一下GVRP注册VLAN信息的过程:

    首先在交换机S3026A上手动添加一个VLAN5

    [S3026A]vlan 5

    然后在三台交换机上分别查看VLAN信息如下:

    [S3026B-Ethernet0/1]dis vlan

    VLAN function is enabled.

    Now, the following VLAN exist(s):

    1(default), 2-3, 5

    [S3026B-Ethernet0/1]dis vlan

    VLAN function is enabled.

    Now, the following VLAN exist(s):

    1(default), 2-3, 5

    [S3526C-Ethernet0/2]dis vlan

    Now, the following VLAN exist(s):

    1(default), 2-3, 5

    现在我们可以看到在另外两台交换机上都已经动态添加了有关VLAN5的信息。

    然后再看看有关的Trunk接口上又是怎么一回事:

    dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-708f

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan), 2-3, 5

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    1099 packets output

    98522 bytes, 158 multicasts, 176 broadcasts, 0 pauses

    998 packets input

    81803 bytes, 166 multicasts, 71 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-707c

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan), 2-3, 5

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    1092 packets output

    91028 bytes, 109 multicasts, 86 broadcasts, 0 pauses

    1264 packets input

    104679 bytes, 253 multicasts, 106 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc06-2380

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    MTU: 1500, Maximum Frame Length: 25608752

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan), 2-3, 5

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    Last 5 minutes output: 0 packets/sec, 0 bytes/sec

    Last 5 minutes input: 0 packets/sec, 0 bytes/sec

    input: 1314 packets, 116004 bytes

    184 broadcasts, 192 multicasts

    input: - input errors, 0 runts, 0 giants, 0 throttles, 0 CRC

    1152 frame, - overruns, aborts, 0 ignored, - parity errors

    Output: 1211 packets, 99117 bytes

    80 broadcasts, 197 multicasts, 0 pauses

    Output: - output errors, 0 underruns, - buffer failures

    - aborts, 0 deferred, 0 collisions, 0 late collisions

    - lost carrier, - no carrier

    dis int e0/2

    Ethernet0/2 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc06-2380

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    MTU: 1500, Maximum Frame Length: 25608752

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan), 2-3

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    Last 5 minutes output: 0 packets/sec, 0 bytes/sec

    Last 5 minutes input: 0 packets/sec, 0 bytes/sec

    input: 1168 packets, 97347 bytes

    89 broadcasts, 116 multicasts

    input: - input errors, 0 runts, 0 giants, 0 throttles, 0 CRC

    1081 frame, - overruns, aborts, 0 ignored, - parity errors

    Output: 1354 packets, 112066 bytes

    109 broadcasts, 274 multicasts, 0 pauses

    Output: - output errors, 0 underruns, - buffer failures

    - aborts, 0 deferred, 0 collisions, 0 late collisions

    - lost carrier, - no carrier

    现在我们发现在S3026A的Trunk接口e0/1上已经允许VLAN5通过,同样S3026B和S3526C的e0/1接口上也已经VLAN5,但是S3526C的e0/2接口上却只允许VLAN1,2,3通过,VLAN5不能通过,这是为什么呢?

    实际上这也是GVRP进行VLAN注册的一条规则,由于交换机S3026B上没有手工配置VLAN5,也就是说S3026B上没有VLAN5的成员,所以S3026B和S3526C之间的Trunk链路就不应该让VLAN5的帧通过。下面我们可以通过在S3026B上配置VLAN5来进行验证:

    [S3026B]vlan 5

    [S3026B-vlan5]port e0/3

    Dynamic VLAN is configured, now changed to static!

    由于交换机S3026B上已经动态注册了VLAN5,所以需要通过添加端口来将VLAN改变为静态VLAN。

    dis int e0/2

    Ethernet0/2 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc06-2380

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    MTU: 1500, Maximum Frame Length: 25608752

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan), 2-3, 5

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    Last 5 minutes output: 0 packets/sec, 0 bytes/sec

    Last 5 minutes input: 0 packets/sec, 0 bytes/sec

    input: 4065 packets, 337496 bytes

    253 broadcasts, 370 multicasts

    input: - input errors, 0 runts, 0 giants, 0 throttles, 0 CRC

    3765 frame, - overruns, aborts, 0 ignored, - parity errors

    Output: 4606 packets, 373337 bytes

    240 broadcasts, 903 multicasts, 0 pauses

    Output: - output errors, 0 underruns, - buffer failures

    - aborts, 0 deferred, 0 collisions, 0 late collisions

    - lost carrier, - no carrier

    在S3026B上已经有了VLAN5的成员之后,S3526C的e0/2接口开始允许VLAN5通过。

    (4) 在交换机的Trunk端口上,VLAN的GVRP注册有三种方法:normal、fixed和forbidden。其中normal是默认的注册方法,表示允许在该端口手工或动态创建、注册和注销VLAN。下面我们分别来看看其他两种方法:

    首先在S3026A上进行如下配置:

    [S3026A-Ethernet0/1]gvrp registration fixed

    fixed表示允许在该端口手工创建和注册VLAN,不允许动态注册或注销VLAN。也就是说S3026A的端口Ethernet0/1不会接受从对端来的动态VLAN信息。

    下面在S3026B上添加一个新的VLAN,配置如下:

    [S3026B]vlan 7

    [S3026B-vlan7]dis vlan

    VLAN function is enabled.

    Now, the following VLAN exist(s):

    1(default), 2-3, 5, 7

    在另外两台交换机上查看VLAN如下:

    dis vlan

    Now, the following VLAN exist(s):

    1(default), 2-3, 5, 7

    dis vlan

    VLAN function is enabled.

    Now, the following VLAN exist(s):

    1(default), 2-3, 5

    dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-708f

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan), 2-3, 5

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    647 packets output

    52285 bytes, 97 multicasts, 27 broadcasts, 0 pauses

    809 packets input

    66183 bytes, 228 multicasts, 54 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    可以看到S3026A上没有注册VLAN7。

    下面我们再来看看如何应用forbidden:

    在S3026A上进行如下配置:

    [S3026A-Ethernet0/1]gvrp registration forbidden

    forbidden表示在端口将注销除VLAN1之外的所有其它VLAN,并且禁止在该端口创建和注册任何其它VLAN。

    然后我们可以在查看一下S3026A的端口e0/1:

    [S3026A-Ethernet0/1]dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-708f

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: trunk

    VLAN passing : 1(default vlan)

    VLAN allowed : 1(default vlan), 2-4094

    Trunk port encapsulation: IEEE 802.1q

    929 packets output

    74705 bytes, 143 multicasts, 35 broadcasts, 0 pauses

    1173 packets input

    94456 bytes, 348 multicasts, 70 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    现在只有VLAN1可以通过端口e0/1。

    (5) 配置交换机端口属于特定VLAN

    [Quidway]sysname S3026A

    [S3026A]vlan 2

    [S3026A-vlan2]port Ethernet 0/9 to e0/16

    [S3026A-vlan2]vlan 3

    [S3026A-vlan3]port Ethernet 0/17 to e0/24

    实验三:Hybrid端口配置

    815b9a28430fe54e38c8bb1582f58059.png

    配置交换机之间的端口为Hybrid端口,并且允许VLAN2和VLAN3的帧通过Hybrid端口,并且VLAN2的帧在Hybrid端口打上VLAN2的tag,VLAN3的帧不打tag。

    1. 具体的配置如下:

    (1) 由于当交换机上有Trunk端口存在时不能配置Hybrid,所以我们需要先把Trunk端口改成Access端口。命令如下:

    [S3026A-Ethernet0/1]port link-type access

    在S3026B和S3526C上也作同样的配置。同时也要在S3526C上配置VLAN2和VLAN3,因为Trunk取消之后,GVRP也随之取消了。

    (2) 配置交换机之间的端口为Hybrid端口(注意,连接PC的端口不能配为Hybrid端口):

    [S3026A-Ethernet0/1]port link-type hybrid

    在S3026B的e0/1端口和S3526C的e0/1、e0/2端口上也作同样的配置

    下面查看S3026A的端口信息如下:

    [S3026A-Ethernet0/1]dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-708f

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: hybrid

    Tagged VLAN ID : none

    Untagged VLAN ID : 1

    1292 packets output

    101041 bytes, 423 multicasts, 118 broadcasts, 0 pauses

    2027 packets input

    152720 bytes, 1119 multicasts, 153 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    从上面的信息可以看出PVID为1,Tagged VLAN ID没有配置,而Untagged VLAN ID默认为1。

    2. 配置VLAN2打tag,VLAN3不打tag。

    [S3026A-Ethernet0/1]port hybrid vlan 2 tagged

    [S3026A-Ethernet0/1]port hybrid vlan 3 untagged

    在交换机S3026B的端口e0/1和S3526C的端口e0/1、e0/2上进行相同的配置。

    下面查看S3026A的端口信息如下:

    [S3026A-Ethernet0/1]dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-708f

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 1

    Mdi type: auto

    Port link-type: hybrid

    Tagged VLAN ID : 2

    Untagged VLAN ID : 1, 3

    1539 packets output

    122085 bytes, 480 multicasts, 266 broadcasts, 0 pauses

    2243 packets input

    172338 bytes, 1178 multicasts, 270 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    从上面的信息可以看出PVID为1,Tagged VLAN ID为2,而Untagged VLAN ID为1和3。

    然后我们可以分别查看VLAN2和VLAN3的信息如下:

    dis vlan 2

    VLAN ID: 2

    VLAN Type: static

    Route Interface: not configured

    Description: VLAN 0002

    Tagged Ports:

    Ethernet0/1

    Untagged Ports:

    Ethernet0/9 Ethernet0/10 Ethernet0/11

    Ethernet0/12 Ethernet0/13 Ethernet0/14

    Ethernet0/15 Ethernet0/16

    dis vlan 3

    VLAN ID: 3

    VLAN Type: static

    Route Interface: not configured

    Description: VLAN 0003

    Tagged Ports: none

    Untagged Ports:

    Ethernet0/1 Ethernet0/17 Ethernet0/18

    Ethernet0/19 Ethernet0/20 Ethernet0/21

    Ethernet0/22 Ethernet0/23 Ethernet0/24

    在VLAN2中,已经有一个tagged port:e0/1。

    实际上对于一个以太网帧来说,从主机到交换机接入端口这一段是没有VLAN tag的,这是因为一般的计算机并不能识别VLAN tag的。而当以太网帧在通过Hybrid端口发往另一台交换机之前,就已经打上了相应的VLAN tag以作区别。对于来自不同VLAN的帧,Hybrid端口会根据配置作不同的处理。

    以上面的配置为例,当一个从VLAN2来的帧从S3026A的Hybrid端口e0/1发往对端S3526C的e0/1时,S3026A的e0/1端口不会对它作任何处理,而当这个帧到达对端时,(对端也是一样的配置)S3526C的e0/1端口会检查它的VLAN tag,发现VLAN2是Tagged VLAN ID,于是S3526C的e0/1端口不会改变以太网帧的tag,并向相应正确的端口进行转发。

    当一个从VLAN3来的帧从S3026A的Hybrid端口e0/1发往对端S3526C的e0/1时,则会被去掉VLAN3的tag。当这个帧到达对端时,(对端也是一样的配置)S3526C的e0/1端口会检查它的VLAN tag,发现是没有VLAN tag的,则认为该帧属于VLAN 1(PVID为1),不会向VLAN 3的端口转发。

    这样配置完成后,VLAN2内的PC可以互相ping通,VLAN3内部的PC不能够互相ping通。

    如果我们设置Hybrid端口的PVID为3,这样,没有VLAN tag的帧将被认为属于VLAN 3,VLAN3内的主机可以通信。

    [S3026A-Ethernet0/1]port hybrid pvid vlan 3

    在交换机S3026B的端口e0/1和S3526C的端口e0/1、e0/2上进行相同的配置。

    dis int e0/1

    Ethernet0/1 is up

    Hardware is Fast Ethernet, Hardware address is 00e0-fc07-708f

    Auto-duplex(Full), Auto-speed(100M), 100_BASE_TX

    Flow control: disabled

    Broadcast MAX-ratio: 100%

    PVID: 3

    Mdi type: auto

    Port link-type: hybrid

    Tagged VLAN ID : 2

    Untagged VLAN ID : 1, 3

    4962 packets output

    395464 bytes, 523 multicasts, 959 broadcasts, 0 pauses

    5105 packets input

    410851 bytes, 1222 multicasts, 405 broadcasts, 0 pauses

    0 CRC errors

    0 long frames

    小结:

    Hybrid端口是介于Access端口和Trunk端口之间的一种端口属性,通过Hybrid端口的设置,可以配置部分VLAN的帧可以打上VLAN标记,另一部分VLAN在通过交换机间链路时,不打VLAN标记,从而实现对部分VLAN隔离的目的。当然,如果您对所有VLAN在Hybrid端口都配置为Untagged,那么交换机之间的所有VLAN都被隔离,满足一些特殊应用。

    实验四:PVLAN配置

    56ad082485b02052a133cb48912c6089.png

    从VLAN的帧格式我们知道VLAN ID域占用12个bit位,所以可以表示的VLAN范围为:0-4095(实际上用户可用的为1-4094)。这样的一个范围对于任何一个企业局域网或者是校园网都可以说已经足够,但是运营商在小区宽带接入的快速发展中,形成了不计其数的用户,而这些用户又不希望受到其它用户的直接访问和攻击。这时候我们如果为每个用户都分配一个VLAN ID来隔离他们,就显得VLAN ID不够用。利用PVLAN,即双层VLAN技术就可以很好的解决这一问题。

    在PVLAN中,一台交换机上存在Primary vlan和Secondary vlan。一个Primary vlan和多个Secondary vlan对应,Primary vlan包含所对应的所有Secondary vlaN中包含的端口和上行端口,这样对上层交换机来说,只须识别下层交换机中的Primary vlan,而不必关心Primary vlan中包含的Secondary vlaN,简化了配置,节省了VLAN资源。用户可以采用PVLAN实现二层报文的隔离,为每个用户分配一个Secondary VLAN,每个vlan中只包含该用户连接的端口和上行端口;如果希望实现用户之间二层报文的互通,也可以将用户连接的端口划入同一个Secondary VLAN中。

    如上图所示,S3026A划分了4个VLAN,其中VLAN5为Primary VLAN,VLAN2,3,4为Secondary VLAN。S3026B划分了3个VLAN,VLAN4为Primary VLAN,VLAN2,3为Secondary VLAN。其中Primary VLAN包括e0/1,e0/2,e0/3,e0/4口。完成上面配置后,您会发现,在同一交换机内的不同Secondary VLAN的主机不能够互相访问,所有Secondary VLAN的主机都能够访问Primary VLAN的主机;交换机之间的所有PC都能够互相访问。

    1. 具体的配置如下:

    (1) 在2台交换机上创建VLAN,并为VLAN分配接口(注意,必须为每一个VLAN划分端口):

    [S3026A]vlan 5

    [S3026A-vlan5]port Ethernet 0/1 to Ethernet 0/4

    [S3026A-vlan5]vlan 2

    [S3026A-vlan2]port Ethernet 0/5 to Ethernet 0/8

    [S3026A-vlan2]vlan 3

    [S3026A-vlan3]port Ethernet 0/9 to Ethernet 0/11

    [S3026A-vlan3]vlan 4

    [S3026A-vlan4]port Ethernet 0/12 to Ethernet 0/16

    [S3026B]vlan 4

    [S3026B-vlan4]port Ethernet 0/1 to Ethernet 0/4

    [S3026B-vlan4]vlan 2

    [S3026B-vlan2]port Ethernet 0/9 to Ethernet 0/16

    [S3026B-vlan2]vlan 3

    [S3026B-vlan3]port Ethernet 0/17 to Ethernet 0/24

    (2) 配置S3026A的VLAN5为Primary VLAN,VLAN2,3,4为Secondary VLAN,建立Primary VLAN和Secondary VLAN的映射关系;配置S3026B的VLAN4为Primary VLAN,VLAN2,3为Secondary VLAN,建立Primary VLAN和Secondary VLAN的映射关系。

    [S3026A]vlan 5

    [S3026A-vlan5]isolate-user-vlan enable //设置VLAN类型为Primary VLAN

    [S3026A-vlan5]quit

    [S3026A]isolate-user-vlan 5 secondary 2 3 4 //配置Primary VLAN和Secondary VLAN间的映射关系

    [S3026B]vlan 4

    [S3026B-vlan4]isolate-user-vlan enable

    [S3026B-vlan4]quit

    [S3026B]isolate-user-vlan 4 secondary 2 3

    完成上述配置之后,我们可以查看S3026A上的配置信息如下:

    [S3026A]dis current-configuration

    #

    sysname S3026A

    #

    radius scheme default

    #

    aaa authentication-scheme Default radius next local

    aaa accounting-scheme Default enable offline

    #

    interface Aux0/0

    #

    vlan 1

    #

    vlan 2

    #

    vlan 3

    #

    vlan 4

    #

    vlan 5

    isolate-user-vlan enable

    #

    interface Ethernet0/1

    port link-type hybrid

    port hybrid vlan 2 to 5 untagged

    port hybrid pvid vlan 5

    #

    interface Ethernet0/2

    port link-type hybrid

    port hybrid vlan 2 to 5 untagged

    port hybrid pvid vlan 5

    #

    interface Ethernet0/3

    port link-type hybrid

    port hybrid vlan 2 to 5 untagged

    port hybrid pvid vlan 5

    #

    interface Ethernet0/4

    port link-type hybrid

    port hybrid vlan 2 to 5 untagged

    port hybrid pvid vlan 5

    #

    interface Ethernet0/5

    port link-type hybrid

    port hybrid vlan 2 5 untagged

    port hybrid pvid vlan 2

    #

    interface Ethernet0/6

    port link-type hybrid

    port hybrid vlan 2 5 untagged

    port hybrid pvid vlan 2

    #

    interface Ethernet0/7

    port link-type hybrid

    port hybrid vlan 2 5 untagged

    port hybrid pvid vlan 2

    #

    interface Ethernet0/8

    port link-type hybrid

    port hybrid vlan 2 5 untagged

    port hybrid pvid vlan 2

    #

    interface Ethernet0/9

    port link-type hybrid

    port hybrid vlan 3 5 untagged

    port hybrid pvid vlan 3

    #

    interface Ethernet0/10

    port link-type hybrid

    port hybrid vlan 3 5 untagged

    port hybrid pvid vlan 3

    #

    interface Ethernet0/11

    port link-type hybrid

    port hybrid vlan 3 5 untagged

    port hybrid pvid vlan 3

    #

    interface Ethernet0/12

    port link-type hybrid

    port hybrid vlan 4 to 5 untagged

    port hybrid pvid vlan 4

    #

    interface Ethernet0/13

    port link-type hybrid

    port hybrid vlan 4 to 5 untagged

    port hybrid pvid vlan 4

    #

    interface Ethernet0/14

    port link-type hybrid

    port hybrid vlan 4 to 5 untagged

    port hybrid pvid vlan 4

    #

    interface Ethernet0/15

    port link-type hybrid

    port hybrid vlan 4 to 5 untagged

    port hybrid pvid vlan 4

    #

    interface Ethernet0/16

    port link-type hybrid

    port hybrid vlan 4 to 5 untagged

    port hybrid pvid vlan 4

    #

    interface Ethernet0/17

    #

    interface Ethernet0/18

    #

    interface Ethernet0/19

    #

    interface Ethernet0/20

    #

    interface Ethernet0/21

    #

    interface Ethernet0/22

    #

    interface Ethernet0/23

    #

    interface Ethernet0/24

    #

    interface NULL0

    #

    cluster

    #

    isolate-user-vlan 5 secondary 2 to 4

    #

    user-interface aux 0

    user-interface vty 0 4

    #

    从上面的信息中可以看出,PVLAN实际上是通过前一个实验中的hybrid端口来实现。即通过配置一系列的hybrid端口,并对来自不同VLAN的帧进行不同的VLAN tag处理,来达到隔离VLAN的目的。

    配置完成后,在同一交换机内的不同Secondary VLAN的主机不能够互相访问,所有Secondary VLAN的主机都能够访问Primary VLAN的主机;交换机之间的所有PC都能够互相访问。在交换机S3026A上使用display vlan 5命令可以看到,同一交换机的所有VLAN的所有端口都属于VLAN5,也就是说VLAN2,3和4是VLAN5的更细化的VLAN。

    [S3026A]display vlan 5

    VLAN ID: 5

    VLAN Type: static

    Isolate-user-VLAN type : isolate-user-VLAN

    Route Interface: not configured

    Description: VLAN 0005

    Tagged Ports: none

    Untagged Ports:

    Ethernet0/1 Ethernet0/2 Ethernet0/3

    Ethernet0/4 Ethernet0/5 Ethernet0/6

    Ethernet0/7 Ethernet0/8 Ethernet0/9

    Ethernet0/10 Ethernet0/11 Ethernet0/12

    Ethernet0/13 Ethernet0/14 Ethernet0/15

    Ethernet0/16

    接下来我们可以用如下的方法来测试不同VLAN间主机的连通性:

    1. 准备两台PC机PCA和PCB,然后配置PCA IP地址为10.1.1.2/24,PCB IP地址为10.1.1.3/24。

    2. 将PCA连接到交换机S3026A的端口e0/5上,将PCB分别连接到交换机S3026A的端口e0/9和e0/12上,从PCA ping PCB,看是否能够ping通。

    3. 将PCB连接到交换机S3026A的端口e0/2上,从PCA ping PCB,看是否能够ping通。

    4. 将PCB连接到交换机S3026B的任一端口上,从PCA ping PCB,看是否能够ping通。

    在测试连通性的过程中,大家可以参考前一个实验中对hybrid端口的解释,并对照前面的配置信息,来思考一下,为什么会ping得通或者ping不通?

    实际上从配置信息中可以看出在S3026A中划分给VLAN5的hybrid端口PVID都为5,同理划分给VLAN2,3,4的hybrid端口PVID分别为相应的VLAN ID,这就造成了在同一交换机内的不同Secondary VLAN的主机不能够互相访问。而VLAN5作为Primary VLAN,实际上包含了所有的端口,所以所有Secondary VLAN的主机都能够访问Primary VLAN的主机。在交换机之间,由于通过e0/1相连,而e0/1又划分在各自的Primary VLAN,PVID为各自的Primary VLAN ID,因此通过e0/1的帧会加上对方的Primary VLAN ID,可以访问对方所有的端口。

    展开全文
  • 点击蓝字关注我们vlan划分01技术原理VLAN是指在...相同 VLAN 内的主机可以相互直接通信,不同 VLAN间的主机之间互相访问必须经路由设备进行转发,广播数据包只可以在本 VLAN 内进行广播,不能传输到其他 VLAN 中。Po...

    点击蓝字

    00f794240b9fcd7b09559c359d5742e4.gif

    关注我们

    vlan划分

    01

    技术原理

    VLAN是指在一个物理网段内。进行逻辑的划分,划分成若干个虚拟局域网,VLAN做大的特性是不受物理位置的限制,可以进行灵活的划分。VLAN 具备了一个物理网段所具备的特性。相同 VLAN 内的主机可以相互直接通信,不同 VLAN间的主机之间互相访问必须经路由设备进行转发,广播数据包只可以在本 VLAN 内进行广播,不能传输到其他 VLAN 中。

    a88675bd8f22c38acbc3217e46215234.png


    Port VLAN 是实现 VLAN 的方式之一,它利用交换机的端口进行 VALN 的划分,一个端口只能属于一个 VLAN。
    以太网端口有三种链路类型:Access、Hybrid 和 Trunk。
    Access 类型的端口只能属于 1 个 VLAN,一般用于连接计算机的端口;
    Trunk 类型的端口可以允许多个 VLAN 通过,可以接收和发送多个 VLAN 的报文,一般用于交换机之间连接的端口。

    426e0e485c1fcff647094a207bf3537f.png


    Hybrid 类型的端口可以允许多个 VLAN 通过,可以接收和发送多个 VLAN 的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。Hybrid 端口和 Trunk 端口在接收数据时,处理方法是一样的,唯一不同之处在于发送数据时:Hybrid 端口可以允许多个 VLAN 的报文发送时不打标签,而 Trunk端口只允许缺省 VLAN 的报文发送时不打标签。

    02

    拓扑图

    e074e5379921eed267eadfe9b8dc9e52.png00f794240b9fcd7b09559c359d5742e4.gif

    下面看看视频讲解吧

    点击边框调出视频工具条  ab7d2178157f4ced6329a0bca5abdae3.png

    看这么多累了吧,看看咋们的公众号放松一下

    00f794240b9fcd7b09559c359d5742e4.gif6feec55060ae86d866836b7c47de40fa.png点击边框调出视频工具条   b057a65a96a758e17ca51ca4fe80160b.png

    咱家的公众号

    00f794240b9fcd7b09559c359d5742e4.gif

    后续更新更多

    敬请关注

    00f794240b9fcd7b09559c359d5742e4.gifb057a65a96a758e17ca51ca4fe80160b.png

    thedatabaseofDS

    00f794240b9fcd7b09559c359d5742e4.gif

    扫码|关注我们

    微信公众号

    lwqandds0829

    展开全文
  • 接下来我们将要学习的就是如何在不同的VLAN间进行路由,使分属不同VLAN的主机能够互相通信。首先,先来复习一下为什么不同VLAN间不通过路由就无法通信。在LAN内的通信,必须在数据帧头中指定通信目标的MAC地址。而...

    1 VLAN间路由1

    VLAN间路由的必要性


    根据目前为止学习的知识,我们已经知道两台计算机即使连接在同一台交换机上,只要所属的VLAN不同就无法直接通信。接下来我们将要学习的就是如何在不同的VLAN间进行路由,使分属不同VLAN的主机能够互相通信。

    首先,先来复习一下为什么不同VLAN间不通过路由就无法通信。在LAN内的通信,必须在数据帧头中指定通信目标的MAC地址。而为了获取MAC地址,TCP/IP协议下使用的是ARP。ARP解析MAC地址的方法,则是通过广播。也就是说,如果广播报文无法到达,那么就无从解析MAC地址,亦即无法直接通信。
    计算机分属不同的VLAN,也就意味着分属不同的广播域,自然收不到彼此的广播报文。因此,属于不同VLAN的计算机之间无法直接互相通信。为了能够在VLAN间通信,需要利用OSI参照模型中更高一层——网络层的信息(IP地址)来进行路由。关于路由的具体内容,以后有机会再详细解说吧。

    路由功能,一般主要由路由器提供。但在今天的局域网里,我们也经常利用带有路由功能的交换机——三层交换机(Layer 3 Switch)来实现。接下来就让我们分别看看使用路由器和三层交换机进行VLAN间路由时的情况。

    2 使用路由器进行VLAN间路由

    在使用路由器进行VLAN间路由时,与构建横跨多台交换机的VLAN时的情况类似,我们还是会遇到“该如何连接路由器与交换机”这个问题。路由器和交换机的接线方式,大致有以下两种:

    l将路由器与交换机上的每个VLAN分别连接
    l不论VLAN有多少个,路由器与交换机都只用一条网线连接

    最容易想到的,当然还是“把路由器和交换机以VLAN为单位分别用网线连接”了。将交换机上用于和路由器互联的每个端口设为访问链接,然后分别用网线与路由器上的独立端口互联。如下图所示,交换机上有2个VLAN,那么就需要在交换机上预留2个端口用于与路由器互联;路由器上同样需要有2个端口;两者之间用2条网线分别连接。

    99ef70bdddb050887d4ec8ad0fa0464f.png

    如果采用这个办法,大家应该不难想象它的扩展性很成问题。每增加一个新的VLAN,都需要消耗路由器的端口和交换机上的访问链接,而且还需要重新布设一条网线。而路由器,通常不会带有太多LAN接口的。新建VLAN时,为了对应增加的VLAN所需的端口,就必须将路由器升级成带有多个LAN接口的高端产品,这部分成本、还有重新布线所带来的开销,都使得这种接线法成为一种不受欢迎的办法。

    那么,第二种办法“不论VLAN数目多少,都只用一条网线连接路由器与交换机”呢?当使用一条网线连接路由器与交换机、进行VLAN间路由时,需要用到汇聚链接。

    具体实现过程为:首先将用于连接路由器的交换机端口设为汇聚链接,而路由器上的端口也必须支持汇聚链路。双方用于汇聚链路的协议自然也必须相同。接着在路由器上定义对应各个VLAN的“子接口(Sub Interface)”。尽管实际与交换机连接的物理端口只有一个,但在理论上我们可以把它分割为多个虚拟端口。
    VLAN将交换机从逻辑上分割成了多台,因而用于VLAN间路由的路由器,也必须拥有分别对应各个VLAN的虚拟接口。

    1f6f0b276bc852bf8e06899184eb4631.png

    采用这种方法的话,即使之后在交换机上新建VLAN,仍只需要一条网线连接交换机和路由器。用户只需要在路由器上新设一个对应新VLAN的子接口就可以了。与前面的方法相比,扩展性要强得多,也不用担心需要升级LAN接口数不足的路由器或是重新布线。

    3 VLAN间路由2

    同一VLAN内的通信


    接下来,我们继续学习使用汇聚链路连接交换机与路由器时,VLAN间路由是如何进行的。如下图所示,为各台计算机以及路由器的子接口设定IP地址。

    d1e2a641944bcd25fdf44957806e5c8c.png

    红色VLAN(VLAN ID=1)的网络地址为192.168.1.0/24,蓝色VLAN(VLAN ID=2)的网络地址为192.168.2.0/24。各计算机的MAC地址分别为A/B/C/D,路由器汇聚链接端口的MAC地址为R。交换机通过对各端口所连计算机MAC地址的学习,生成如下的MAC地址列表。

    f0110c68ad0ec41579a010a81c5cd50b.png

    首先考虑计算机A与同一VLAN内的计算机B之间通信时的情形。

    计算机A发出ARP请求信息,请求解析B的MAC地址。交换机收到数据帧后,检索MAC地址列表中与收信端口同属一个VLAN的表项。结果发现,计算机B连接在端口2上,于是交换机将数据帧转发给端口2,最终计算机B收到该帧。收发信双方同属一个VLAN之内的通信,一切处理均在交换机内完成。

    81f4b0a54f025ec555e52bf9b793e844.png

    4 不同VLAN间通信时数据的流程

    接下来是这一讲的核心内容,不同VLAN间的通信。让我们来考虑一下计算机A与计算机C之间通信时的情况。

    c9a3ddc75cb756a02669ddc5df1ab835.png

    计算机A从通信目标的IP地址(192.168.2.1)得出C与本机不属于同一个网段。因此会向设定的默认网关(Default Gateway,GW)转发数据帧。在发送数据帧之前,需要先用ARP获取路由器的MAC地址。

    得到路由器的MAC地址R后,接下来就是按图中所示的步骤发送往C去的数据帧。①的数据帧中,目标MAC地址是路由器的地址R、但内含的目标IP地址仍是最终要通信的对象C的地址。这一部分的内容,涉及到局域网内经过路由器转发时的通信步骤,有机会再详细解说吧。

    交换机在端口1上收到①的数据帧后,检索MAC地址列表中与端口1同属一个VLAN的表项。由于汇聚链路会被看作属于所有的VLAN,因此这时交换机的端口6也属于被参照对象。这样交换机就知道往MAC地址R发送数据帧,需要经过端口6转发。

    从端口6发送数据帧时,由于它是汇聚链接,因此会被附加上VLAN识别信息。由于原先是来自红色VLAN的数据帧,因此如图中②所示,会被加上红色VLAN的识别信息后进入汇聚链路。路由器收到②的数据帧后,确认其VLAN识别信息,由于它是属于红色VLAN的数据帧,因此交由负责红色VLAN的子接口接收。

    接着,根据路由器内部的路由表,判断该向哪里中继。
    由于目标网络192.168.2.0/24是蓝色VLAN,,且该网络通过子接口与路由器直连,因此只要从负责蓝色VLAN的子接口转发就可以了。这时,数据帧的目标MAC地址被改写成计算机C的目标地址;并且由于需要经过汇聚链路转发,因此被附加了属于蓝色VLAN的识别信息。这就是图中③的数据帧。

    交换机收到③的数据帧后,根据VLAN标识信息从MAC地址列表中检索属于蓝色VLAN的表项。由于通信目标——计算机C连接在端口3上、且端口3为普通的访问链接,因此交换机会将数据帧除去VLAN识别信息后(数据帧④)转发给端口3,最终计算机C才能成功地收到这个数据帧。

    进行VLAN间通信时,即使通信双方都连接在同一台交换机上,也必须经过:

    发送方——交换机——路由器——交换机——接收方

    这样一个流程。

    5 三层交换机(1)

    使用路由器进行VLAN间路由时的问题
    现在,我们知道只要能提供VLAN间路由,就能够使分属不同VLAN的计算机互相通信。但是,如果使用路由器进行VLAN间路由的话,随着VLAN之间流量的不断增加,很可能导致路由器成为整个网络的瓶颈。
    交换机使用被称为ASIC(Application Specified Integrated Circuit)的专用硬件芯片处理数据帧的交换操作,在很多机型上都能实现以缆线速度(Wired Speed)交换。而路由器,则基本上是基于软件处理的。即使以缆线速度接收到数据包,也无法在不限速的条件下转发出去,因此会成为速度瓶颈。就VLAN间路由而言,流量会集中到路由器和交换机互联的汇聚链路部分,这一部分尤其特别容易成为速度瓶颈。并且从硬件上看,由于需要分别设置路由器和交换机,在一些空间狭小的环境里可能连设置的场所都成问题。
    三层交换机(Layer 3 Switch)
    为了解决上述问题,三层交换机应运而生。三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的交换机才被称为“三层交换机”。
    关于三层交换机的内部结构,可以参照下面的简图。

    31319ab8206b93df024904584570dad1.png

    在一台本体内,分别设置了交换机模块和路由器模块;而内置的路由模块与交换模块相同,使用ASIC硬件处理路由。因此,与传统的路由器相比,可以实现高速路由。并且,路由与交换模块是汇聚链接的,由于是内部连接,可以确保相当大的带宽。

    6 三层交换机(2)

    使用三层交换机进行VLAN间路由(VLAN内通信)
    在三层交换机内部数据究竟是怎样传播的呢?基本上,它和使用汇聚链路连接路由器与交换机时的情形相同。
    假设有如下图所示的4台计算机与三层交换机互联。当使用路由器连接时,一般需要在LAN接口上设置对应各VLAN的子接口;而三层交换机则是在内部生成“VLAN接口(VLAN Interface)”。VLAN接口,是用于各VLAN收发数据的接口。(注:在Cisco的Catalyst系列交换机上,VLAN Interface被称为SVI——Switched Virtual Interface)

    942e9efbb4507d44bc48999cece28cac.png

    为了与使用路由器进行VLAN间路由对比,让我们同样来考虑一下计算机A与计算机B之间通信时的情况。首先是目标地址为B的数据帧被发到交换机;通过检索同一VLAN的MAC地址列表发现计算机B连在交换机的端口2上;因此将数据帧转发给端口2。

    7 使用三层交换机进行VLAN间路由(VLAN间通信)

    接下来设想一下计算机A与计算机C间通信时的情形。针对目标IP地址,计算机A可以判断出通信对象不属于同一个网络,因此向默认网关发送数据(Frame 1)。
    交换机通过检索MAC地址列表后,经由内部汇聚链接,将数据帧转发给路由模块。在通过内部汇聚链路时,数据帧被附加了属于红色VLAN的VLAN识别信息(Frame 2)。
    路由模块在收到数据帧时,先由数据帧附加的VLAN识别信息分辨出它属于红色VLAN,据此判断由红色VLAN接口负责接收并进行路由处理。因为目标网络192.168.2.0/24是直连路由器的网络、且对应蓝色VLAN;因此,接下来就会从蓝色VLAN接口经由内部汇聚链路转发回交换模块。在通过汇聚链路时,这次数据帧被附加上属于蓝色VLAN的识别信息(Frame 3)。
    交换机收到这个帧后,检索蓝色VLAN的MAC地址列表,确认需要将它转发给端口3。由于端口3是通常的访问链接,因此转发前会先将VLAN识别信息除去(Frame 4)。最终,计算机C成功地收到交换机转发来的数据帧。

    d7b84f3c45e349ea6840c4cdd7a1cbdd.png

    整体的流程,与使用外部路由器时的情况十分相似——都需要经过发送方→交换模块→路由模块→交换模块→接收方。

    展开全文
  • 1、VLAN基础知识VLAN(Virtual Local Area Network)的中文名为'虚拟局域网',注意不是'VPN'(虚拟专用网)。VLAN是一种将局域网设备从逻辑上划分(注意,不是从物理上划分)成一个个网段,从而实现虚拟工作组的新兴数据...
  • 要求财务部和销售部的 PC 可以互通,但为了数据安全起见,销售部和财务部需要进行互相隔离,现要在交换机上做适当配置来实现这一目标。VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。虚拟局域网(VLAN)是...
  • 关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。今天我们以华为交换机...
  • 前面我们发布了华为、锐捷、H3C交换机的配置,有很多的朋友提到了vlan的划分,今天我们来看下具体应用。很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多交换机,因此,我们今天以华为交换机为...
  • 这篇内容是华为交换机的基本配置,今天我们来看下具体应用,以华为交换机为例,也是用的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入...
  • 通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间的互访是隔离的。为了实现报文之间的二层隔离,用户可以将不同的端口加入不同的VLAN,但这样会浪费有限的VLAN资源。采用...
  • 这篇内容是华为交换机的基本配置,今天我们来看下具体应用,以华为交换机为例,也是用的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入...
  • 前面我们发布了图文并茂讲VLAN,让你看一遍就理解VLAN,这篇文章是讲原理,今天我们来看下具体应用,以华为交换机为例,也是用的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对...
  • vlan 10 vlan 20 int fas 0/2 switchport access vlan 10 exit int fas 0/3 switchport access vlan 20 exit int fas 0/1 switchport mode trunk 在 switch1进行设置; vlan 10 exi...
  • 如何禁止VLAN互相访问

    千次阅读 2013-11-05 00:22:45
    VLAN之间的ACL配置   步骤一:创建vlan10、vlan20、vlan30   S5750#conf ----进入全局配置模式   S5750(config)#vlan 10 ----创建VLAN10  
  • 思科三层交换机实现不同VLAN间互相访问配置案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间提供路由,为了解决这一问题,就必须增加思科路由器或思科三层交换机之类的路由设备。我们这里选择增加一...
  • H3C三层交换机配置VLAN之间不能互相访问2010-11-2013:30:54|分类:H3C|标签:qosvlanh3c交换机traffic|举报|字号订阅由于H3C交换机的VLAN之间可以互访,为了数据的安全性及链路需求,要让VLAN之间不能互访。...
  • Cisco Packet Tracer通过配置RIP路由协议和IP地址来划分两个vlan,使其通过局域网无法互相访问,但是通过广域网相互之间可以互相访问 1.实验拓扑图 2.实验配置参数 3.在交换机Switch0和Switch2中划分VLAN 点击...
  • 提问:如何禁止VLAN互相访问? 回答: 步骤一:创建vlan10、vlan20、vlan30 S5750#conf ----进入全局配置模式 S5750(config)#vlan 10 ----创建VLAN10 S5750(config-vlan)#exit ----退出VLAN配置模式 S...
  • 要求:1.PC1和PC2不能互相访问,但是都能访问PC3SW1配置:vlan batch 10 20 100interface Ethernet0/0/1port hybrid pvid vlan 10port hybrid untagged vlan 10 100#interface Ethernet0/0/2port hybrid pvid vlan ...
  • vlan之间Hybrid端口配置

    2018-07-17 17:57:00
    要求:1.PC1和PC2不能互相访问,但是都能访问PC3 SW1配置:vlan batch 10 20 100 interface Ethernet0/0/1 port hybrid pvid vlan 10port hybrid untagged vlan 10 100#interface Ethernet0/0/2port...
  • 华为--VLAN之间Hybrid端口配置

    千次阅读 2020-03-20 14:27:30
    vlan之间Hybrid端口配置 要求:1.PC1和PC2不能互相访问,但是都能访问PC3 SW1配置: vlan batch 10 20 100     //同时创建三个VLAN interface Ethernet0/0/1 port hybrid pvid vlan 10    //将此端口号的...
  • 前面我们为了所有VLAN都可以上网,开启了交换机的路由功能,但现实情况是需要限制某些VLAN之间互相访问,这就需要用到ACL(访问控制列表)功能了。
  • 此时,这些处于不同vlan中的设备如果要想互相 通信,就必须像不同局域网的设备之间需要进行通信时那样, 借助路由器来连接这些不同的网络vlan,为这些vlan间的流量 执行路由转发,这就叫作通过vlan间路由实现通信。 人...
  • 如果这篇文章对您有帮助,...假设你在一个比较大的公司里,一个部门,暂且定为财务部吧,分布在不同的楼层,网线都连接在不同的交换机上,要求所有的财务电脑都处于同一个vlan,财务的电脑之间可以互相访问,那么我们...
  • 实验1 是使用路由器来实现不同VLAN之间互相访问,而我们还可以将路由器换成3层交换机来实现不同VLAN之间的访问 实验步骤: a.首先在两台交换机上做VTP协议 SW1(config)# vtp mode server SW1(config) # ...
  • VLAN(Virtual Local Area Network,虚拟局域网)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样。...
  • 如何跨VLAN访问的实验

    2009-12-25 15:12:21
    当我们建立多个VLAN,而想要这多个VLAN之间实现互相访问时,该怎么去实现!! 以下是一个小实验: 1. 实验目的:建立两个VLAN,并且能够互相访问 2. 实验条件:1台路由器,2台2950T-24的交换机(思科),4台PC...
  • MUX VLAN

    万次阅读 多人点赞 2018-05-21 13:14:48
    对于企业来说,希望企业内部员工之间可以互相交流,而企业客户之间是隔离的,不能够互相访问。 为了实现所有用户都可访问企业服务器,可通过配置VLAN间通信实现。如果企业规模很大,拥有大量的用户,那么就...

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 163
精华内容 65
关键字:

vlan之间互相访问