精华内容
下载资源
问答
  • python升级pip失败

    2019-12-17 22:58:28
    本教程用于Python pip...安装其他模块过程中出现下面提示,便说明你需要升级pip You are using pip version 18.1.1, however version 19.0.1 is available. 你的版本为18.1.1需要升级到19.0.1 You should consider...

    本教程用于Python pip升级及失败解决方案

    首先查看脚本

    pip show pip

    我已经升级到了最新的版本

    安装其他模块过程中出现下面提示,便说明你需要升级pip

    You are using pip version 18.1.1, however version 19.0.1 is available.

    你的版本为18.1.1需要升级到19.0.1

    You should consider upgrading via the ‘python -m pip install --upgrade pip’ comm

    这句话的意思是提示你使用: python -m pip install --upgrade pip 来升级,直接复制就行

    当在下面出现Success,那么恭喜你安装成功。

    失败的看这里:

    失败的首先可以尝试更换升级指令,例如:

    python -m pip install -U --force-reinstall pip

    python -m pip install --upgrade pip

    如果依旧失败的话,告诉你一种终极方案,前提时你周围有人pip升级成功

    没错就是复制粘贴成功的文件,别问我怎么知道的,我就是这样成功的

    pip文件路径:C:\python\Lib\site-packages\pip-19.2.1.dist-info

    展开全文
  • 1、报pip 8.1.1 Not uninstalling pip at /usr/lib/python2.7/dist-packages, outside environment /usr Successfully installed pip-8.1.1 You are using pip version 8.1.1, however version 19.1.1 is available....

    1、报pip 8.1.1 Not uninstalling pip at /usr/lib/python2.7/dist-packages, outside environment /usr Successfully installed pip-8.1.1 You are using pip version 8.1.1, however version 19.1.1 is available.

    如下

    sudo pip install --upgrade pip

    The directory '/home/osrc/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

    The directory '/home/osrc/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

    Collecting pip

    Downloading https://files.pythonhosted.org/packages/5c/e0/be401c003291b56efc55aeba6a80ab790d3d4cece2778288d65323009420/pip-19.1.1-py2.py3-none-any.whl (1.4MB)

    100% |████████████████████████████████| 1.4MB 91kB/s

    Installing collected packages: pip

    Found existing installation: pip 8.1.1

    Not uninstalling pip at /usr/lib/python2.7/dist-packages, outside environment /usr

    Successfully installed pip-8.1.1

    You are using pip version 8.1.1, however version 19.1.1 is available.

    You should consider upgrading via the 'pip install --upgrade pip' command.

    可使用以下命令解决 sudo pip install --upgrade pip --user

    sudo pip install --upgrade pip --user

    /home/osrc/.local/lib/python2.7/site-packages/pip/_vendor/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.

    warnings.warn(warning, RequestsDependencyWarning)

    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.

    The directory '/home/osrc/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

    The directory '/home/osrc/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

    Collecting pip

    Downloading https://files.pythonhosted.org/packages/5c/e0/be401c003291b56efc55aeba6a80ab790d3d4cece2778288d65323009420/pip-19.1.1-py2.py3-none-any.whl (1.4MB)

    100% |████████████████████████████████| 1.4MB 11kB/s

    Installing collected packages: pip

    Found existing installation: pip 19.0.3

    Uninstalling pip-19.0.3:

    Successfully uninstalled pip-19.0.3

    Successfully installed pip-19.1.1

    安装成功后,在使用pip install xxx 时还会报以下错误,解决方法如下

    2、报 "/usr/local/bin/pip", line 7, in

    第一种解决方法:

    根据以上报错的路径

    /usr/local/bin/

    用vim直接编辑

    from pip import __main__

    if __name__ == '__main__':

    sys.exit(__main__._main())

    第二种解决方法【推荐】

    wget https://bootstrap.pypa.io/get-pip.py

    sudo python get-pip.py

    展开全文
  • 72016-03-28 13:10:10 +08:00@lxy pip 7.1.2 from /Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg (python 2.7)输入 python -m pip install --upgrade pip 的时候显示的还是Collecting pipUsing cached pip...

    7

    2016-03-28 13:10:10 +08:00

    @lxy pip 7.1.2 from /Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg (python 2.7)

    输入 python -m pip install --upgrade pip 的时候显示的还是

    Collecting pip

    Using cached pip-8.1.1-py2.py3-none-any.whl

    Installing collected packages: pip

    Found existing installation: pip 7.1.2

    Uninstalling pip-7.1.2:

    Exception:

    Traceback (most recent call last):

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/basecommand.py", line 211, in main

    status = self.run(options, args)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/commands/install.py", line 311, in run

    root=options.root_path,

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/req_set.py", line 640, in install

    requirement.uninstall(auto_confirm=True)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/req_install.py", line 716, in uninstall

    paths_to_remove.remove(auto_confirm)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/req_uninstall.py", line 125, in remove

    renames(path, new_path)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/utils/__init__.py", line 315, in renames

    shutil.move(old, new)

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 300, in move

    rmtree(src)

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 247, in rmtree

    rmtree(fullname, ignore_errors, onerror)

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 252, in rmtree

    onerror(os.remove, fullname, sys.exc_info())

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 250, in rmtree

    os.remove(fullname)

    OSError: [Errno 13] Permission denied: '/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/EGG-INFO/dependency_links.txt'

    You are using pip version 7.1.2, however version 8.1.1 is available.

    You should consider upgrading via the 'pip install --upgrade pip' command.

    展开全文
  • 72016-03-28 13:10:10 +08:00@lxy pip 7.1.2 from /Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg (python 2.7)输入 python -m pip install --upgrade pip 的时候显示的还是Collecting pipUsing cached pip...

    7

    2016-03-28 13:10:10 +08:00

    @lxy pip 7.1.2 from /Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg (python 2.7)

    输入 python -m pip install --upgrade pip 的时候显示的还是

    Collecting pip

    Using cached pip-8.1.1-py2.py3-none-any.whl

    Installing collected packages: pip

    Found existing installation: pip 7.1.2

    Uninstalling pip-7.1.2:

    Exception:

    Traceback (most recent call last):

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/basecommand.py", line 211, in main

    status = self.run(options, args)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/commands/install.py", line 311, in run

    root=options.root_path,

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/req_set.py", line 640, in install

    requirement.uninstall(auto_confirm=True)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/req_install.py", line 716, in uninstall

    paths_to_remove.remove(auto_confirm)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/req_uninstall.py", line 125, in remove

    renames(path, new_path)

    File "/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/utils/__init__.py", line 315, in renames

    shutil.move(old, new)

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 300, in move

    rmtree(src)

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 247, in rmtree

    rmtree(fullname, ignore_errors, onerror)

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 252, in rmtree

    onerror(os.remove, fullname, sys.exc_info())

    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 250, in rmtree

    os.remove(fullname)

    OSError: [Errno 13] Permission denied: '/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/EGG-INFO/dependency_links.txt'

    You are using pip version 7.1.2, however version 8.1.1 is available.

    You should consider upgrading via the 'pip install --upgrade pip' command.

    展开全文
  • pip 升级失败解决方案一般升级:1 python -m pip install --upgrade pip如果失败请尝试:1 python -m pip install -U --force-reinstall pip不排除网速问题下面这种就是网速问题C:\Users\88304\Desktop>pip install ...
  • 然后我就执行命令升级pip python -m pip install --upgrade pip 后来升级完后就这样了 完犊子完犊子。 后来无穷尽的百度后得到好办法 执行以下指令直接安装pip就行 easy_install pip==20.3.4 然后。 成功 ...
  • 错误:module 'pip' has no attribute 'main'pip升级到10.0.1之后...环境:pipversion:10.0.1pythonversion:3.6.4macos:10.12.6错误出现路径还原:升级pip$python-mpipinstallpip--upgradeRequirementalreadyup-to-...
  • python -m pip install --upgrade pip -i https://pypi.douban.com/simple pip国内的一些镜像   阿里云 https://mirrors.aliyun.com/pypi/simple/   中国科技大学 https://pypi.mirrors.ustc.edu.cn/simple/ ...
  • [global] index-url = https://pypi.tuna.tsinghua.edu.cn/simple [install] trusted-host=mirrors.aliyun.com
  • python升级pip失败处理 前几次升级pip时,忘记了记录,这次正好记录一下 (1)常规升级命令: python -m pip install --upgrade pip 升级成功可以利用 pip show pip 查看版本号: 但是本人升级失败了,...
  • 在使用python pip的时候,经常会发生pip版本过低导致失败的情况,这时候,系统会提示让你使用如下命令对pip进行升级更新:python -m pip install --upgrade pip但这种更新方式,经常会出现错误,如下所示多尝试几次...
  • python安装pip失败

    2021-02-01 20:22:20
    安装库包的时候,往往会出现pip版本为升级,导致不能安装别的库包。 进而更新pip,但是有时候会出现一种很尴尬的情况:旧的pip卸载后,无法安装新的pip,但是再重新使用pip install pip,因为没有pip所以无法安装。 ...
  • 小白在升级pip时,输入pip install pip --upgrade直接升级导致pip不可用。解决办法如下: 1.以管理员身份打开cmd 找到cmd应用程序 (C:\Windows\System32\cmd.exe),右键以管理员身份运行。 2.执行 python -m ...
  • python pip 升级失败

    2020-02-13 18:47:33
    python -m pip install --upgrade pip 失败 python -m pip install -U pip 失败 卸载 失败 正确方法为:自己下载pip,好多网址给的也不好用,我用的是get-pip https://download.csdn.net...
  • python 升级pip踩坑

    2020-09-28 19:16:29
    pip更新方法(失败了一般用换一种方法就...1,使用python -m pip install --upgrade pip升级失败 2,使用python -m pip install -U --force-reinstall pip依然失败 3,使用pip install --user --upgrade pip成功升级
  • python升级pip

    2018-07-20 21:49:43
    最近在yong用pip安装python库的时候,经常会安装失败。推测可能和pip有关,所以进行一下pip升级。 打开command命令,输入: python -m pip install --upgrade pip 安装过程如下:  ...
  • pythonpip升级失败pip升级遇到各种问题? 这里有针对升级过程出错地两种情况地解决办法。 一种是更新过程出错导致路径丢失 一种是setuptools安装工具出错 快来看看你的问题属于哪种吧 ...
  • 使用命令升级pip失败,通过网络查找,发现以下方法可用: 1、首先卸载pip cmd输入命令行: python -m pip uninstall pip 2、重新安装pip 在python文件下的Scripts目录下,打开cmd,输入命令行:easy_install....
  • Python pip 升级失败

    2021-03-19 15:14:19
    解决方案-使用以下命令: python -m pip install -U --force-reinstall pip
  • python pip升级失败

    2019-10-09 07:09:02
    接上篇,使用命令:python -m pip install --upgrade pip 发现pip升级时报错,无法升级 解决方法: 1、使用如下命令,查看具体失败原因: pip install --upgrade pip –vvv 2、果然在最后有提示,原来对我的用户...
  • 我的环境: python 3.6 Windows10 家庭中文版 1909 软件:pycharm 之前都是在setting中升级pip的,或者是在命令行(终端)中...python -m pip install --upgrade pip来升级pip的,但是今天新建了一个项目之后,发...
  • python更新pip失败解决办法

    万次阅读 多人点赞 2018-05-25 14:22:22
    You are using pip version 9.0.1, however version 10.0.1 is available.You should consider upgrading via the 'python -m pip install --upgrade pip' command.可以用管理员身份运行windows shell 然后输入 :...
  • python进行pip安装插件时提示如下: You are using pip version 10.0.1, however version 19.0.3 is available. 此时根据提示进行更新pip版本,在命令行中输入: python -m pip install --upgrade pip 但是此时...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,030
精华内容 2,812
关键字:

python升级pip失败

python 订阅