精华内容
下载资源
问答
  • 拓扑图如上 1. PC设置IP PC15:192.168.10.10/24 网关:10.1 PC19:192.168.20.10/24 网关: 20.1 ...# vlan batch 10 20 # inter face vlanif 10 ip address 192.168.10.1 24 ip address 192.168.20.1...

    拓扑图如上

    1. PC设置IP

    PC15:192.168.10.10/24 网关:10.1

    PC19:192.168.20.10/24 网关: 20.1

    PC17:192.168.30.10/24 网关: 30.1

    PC18:192.168.30.10/24 网关:30.1

    2.配置SW6

    # vlan batch 10 20

    # inter face vlanif 10

       ip address 192.168.10.1 24

       ip address 192.168.20.1 24 sub

    # inter face Ethernet 0/0/2

      port link-type access

      port default vlan 10

    # interface Ethernet 0/0/3

     port link-type access

     port default vlan 10

    #interface vlanif 20

     ip address 192.168.60.1 24

    #int g0/0/1

    port link-type trunk

    port trunk allow-pass vlan 20 

    3.配置SW7

    #vlan batch 30 20

    #

    # inter face vlanif 30

       ip address 192.168.30.1 24

       ip address 192.168.40.1 24 sub

    # inter face Ethernet 0/0/2

      port link-type access

      port default vlan 30

    # interface Ethernet 0/0/3

     port link-type access

     port default vlan 30

    #interface vlanif 20

     ip address 192.168.60.2 24

    #int g0/0/1

    port link-type trunk

    port trunk allow-pass vlan 20 

    3.配置静态路由

    LSW6: ip route-static:0.0.0.0 0.0.0.0 192.168.60.2

    LSW7: ip roue-static:0.0.0.0 0.0.0.0 192.168.60.1

    主机互通测试成功!

    展开全文
  • 利用三层交换机实现VLAN间路由
  • 小白必看:三层交换机实现VLAN互通实验(图文并茂) 一.实验环境 实验需要GNS3和c2691路由器 二.实验图 三.实验步骤 首先我们对sw-2进行设置。我们先添加vlan10和vlan20,操作如图。 接下来将接口分配到对应的vlan。...

    小白必看:三层交换机实现VLAN互通实验(图文并茂)

    前言:三层交换机是什么
    三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。
    对于数据包转发等规律性的过程由硬件高速实现,而像路由信息更新、路由表维护、路由计算、路由确定等功能,由软件实现。

    一.实验环境

    实验需要GNS3和c2691路由器

    二.实验图mark

    三.实验步骤

    首先我们对sw-2进行设置。我们先添加vlan10和vlan20,操作如图。
    mark

    接下来将接口分配到对应的vlan。操作如下图
    mark

    我们也可以通过如下图操作来对接口的设置进行检查。
    mark

    接下来我们对R3进行设置。首先我们先把R3的ip地址设置好。操作如下图。
    mark

    mark

    然后我们配置R3的静态路由
    mark

    接着我们对sw-3进行设置。我们先给sw-3添加vlan10和vlan20.
    mark

    我们还得对sw-3的f1/0接口设置好trunk,如图
    mark

    接下来我们设置sw-3虚拟接口的网关,操作如图
    mark

    打开三层接口,关闭交换接口,再去设置物理接口的ip地址。如图

    mark

    由于sw-3通往其他路由器有且仅有一条路线,所以在给他配一个默认路由。操作如图。
    mark

    然后我们就应该对pc机设置ip了。操作如下图。
    mark

    mark mark

    实验目前为止结束。最后只需要取用pc1去pingPC2和PC3就行,ping成功实验则成功。
    小结:sw3注意要设置虚拟接口,虚拟接口对应好vlan。设置默认路由比静态路由方便。

    展开全文
  • 思科三层交换机实现不同VLAN互相访问配置案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间...思科三层交换机VLAN间路由配置步骤:1、配置干道(TRUNK)在接口模式下声明该接口为trunk模式的命令格...

    思科三层交换机实现不同VLAN间互相访问配置

    案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间提供路由,为了解决这一问题,就必须增加思科路由器或思科三层交换机之类的路由设备。我们这里选择增加一台思科三层交换机来实现(可以实现VLAN间路由,同时可提供更多的接口来接入主机)。

    思科三层交换机VLAN间路由配置步骤:

    1、配置干道(TRUNK)

    在接口模式下声明该接口为trunk模式的命令格式:

    Switch(config-if)#switchport mode turnk

    指定接口封装类型的命令格式:

    Switch(config-if)#switchport trunk encapsulation {dot1q|ISL}

    注:dot1q封装类型为802.1q,一般在交换机默认封装dot1q类型

    2、配置VLAN

    在私有模式下进入vlan database声明VLAN的命令格式:

    Switch#vlan database

    Switch(vlan)#vlan vlan_number

    进入相应接口,将该接口划分到指定VLAN内的格式:

    Switch(config-if)#switch port mode access

    Switch(config-if)#switchport access vlan vlan_number

    3、配置VLAN间路由

    思科三层交换机的路由模块和交换模块直接通过思科交换机的背板总线连接,因此只需要在三层交换机的路由模块上定义与VLAN数量相当的逻辑接口,并和VLAN 对应,然后为这些接口分配IP地址即可。

    首先要在在思科三层交换机上打开路由功能,命令格式如下:

    Switch(config)#ip routing

    为VLAN分配地址的命令格式如下:

    Switch(config)#interface vlan vlan_number

    Switch(config)#ip add ip_adress netmask

    展开全文
  • 通过三层交换机实现vlan间互通

    万次阅读 2017-11-21 21:34:21
    一、配置思科2960交换机 创建vlan Switch> Switch>enable Switch#vlan database Switch(vlan)#vlan 10 name vlan10 VLAN 10 added:  Name: vlan10 Switch(vlan)#vlan 20 name vlan20 VLAN 20 added:  
    实验拓扑图:

    一、配置思科2960交换机

    创建vlan

    Switch>

    Switch>enable

    Switch#vlan database

    Switch(vlan)#vlan 10 name vlan10

    VLAN 10 added:

        Name: vlan10

    Switch(vlan)#vlan 20 name vlan20

    VLAN 20 added:

        Name: vlan20

    Switch(vlan)#exit


    分配端口(将f0/1-12端口划归vlan10,f0/13-f0/23端口划鬼vlan20)

    Switch#configure terminal

    Switch(config)#hostname L2-SW

    L2-SW(config)#

    L2-SW(config)#interface range f0/1-12

    L2-SW(config-if-range)#switchport mode access

    L2-SW(config-if-range)#switchport access vlan 10

    L2-SW(config-if-range)#interface range f0/13-23

    L2-SW(config-if-range)#switchport mode access

    L2-SW(config-if-range)#switchport access vlan 20

    L2-SW(config-if-range)#exit


    设置trunk

    L2-SW(config)#interface f0/24

    L2-SW(config-if)#switchport mode trunk

    L2-SW(config-if)#exit


    二、配置 Cisco3560交换机

    首先创建相同编号的vlan:

    Switch>enable

    Switch#vlan database

    Switch(vlan)#vlan 10 name vlan10

    VLAN 10 added:

        Name: vlan10

    Switch(vlan)#vlan 20 name vlan20

    VLAN 20 added:

        Name: vlan20

    Switch(vlan)#exit

    然后通过设置SVI交换虚拟接口,分别为每个VLAN设置IP:
    Switch#configure terminal

    Switch(config)#interface vlan 10

    Switch(config-if)#ip address 192.168.1.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    Switch(config)#interface vlan 20

    Switch(config-if)#ip address 192.168.2.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    Switch(config)#ip routing   #############启用三层交换机的路由功能,否则三层交换机只能使用其二层


    三、在PC上测试

    PC0  IP:192.168.1.2   GW:192.168.1.254

    PC1  IP:192.168.2.2   GW:192.168.2.254


    四、在三层交换机上在直接连接一个PC2,给个vlan10实现三台PC互通。

    在三层交换机上配置:

    Switch>enable

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#interface f0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 10

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    测试联通性:

    设置PC2 IP:192.168.1.3  GW:255.255.255.0


    参考至:http://m.jb51.net/softjc/56598.html

    展开全文
  • ·掌握通过三层交换机实现VLAN间通信的配置方法 ·掌握通过以太网Trunk链路实现VLAN间通信的配置方法 拓扑图 图1.4 三层交换实验拓扑图 场景 在企业网络中,通过使用三层交换机可以简便的实现...
  • 开始配置交换机 可以先关闭stp,然后提前把网线都插上,也可以先不插,按照后边的步骤一步一步来 [H3C]undo stp global enable #这是关闭指令 [H3C]stp global enable #这是开启指令 用于电脑1 <H3C>sys [H3C...
  • 摘要:描述:在三层交换机上配置DHCP,实现DHCP为PC1/PC3分配192.168.1.X网段;实现DHCP为PC2/PC4分配192.168.2.X网段;并且各个PC要可以互相通信。(文末附实验题,排错题,答案)引言:强调几个重点的命令:ip...
  • 通过配置三层交换机或路由器实现VLAN间的通信,通过路由器实现vlan间通信(单臂路由)在路由器与交换机的端口上配置子接口,每个子接口的IP地址是每个VLAN的网关地址(也可以理解为下一跳地址),并在子接口上封装802....
  • [SW1]display current-configuration#sysname SW1#undo info-center enable#vlan batch 10 to 12 20#cluster enablentdp enablendp enable#drop illegal-mac alarm#diffserv domain default#drop-profile default#aa...
  • 本次使用ensp模拟器模拟两台华为三层交换机如何配置不同网段不同vlan之间如何互通。网络拓补图如下图所示: IP地址如下: pc1:10.1.1.2 / 24 pc2 :10.1.2.2 / 24 pc3:192.168.1.2 /24 pc4:192.168.2.2 / 24 ...
  • 三层交换机实现VLAN间通信

    千次阅读 2019-08-08 20:17:27
    一般在交换机中,默认所有的接口都在vlan1中。 VLAN 具有灵活性和可扩展性。 VLAN 的好处 1)控制广播 每个VLAN 都是独立的广播域。 2)增强网络安全性 只能在同一vlan内的端口之间交换数据,不同vlan的端口...
  • 实现不同 VLAN间路由的方式方法,以 Cisco Packet Tracer(思科模拟器)为平台来配置ISO结构中的二、三层交换机实现 VLAN 内部路由的配置技术及实验过程,利用CISCO专有VTP技术实现了多台设备互联互通,并通过实验,...
  • 二、二层交换机的配置 Switch# Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit Switch...
  • 2、配置交换机LSW2 <Huawei>sys [Huawei]undo info-center enable [Huawei]vlan 2 [Huawei-vlan2]quit [Huawei]vlan 3 [Huawei-vlan3]quit [Huawei]int e0/0/1 [Huawei-Ethernet0/0/1]port link-type access ...
  • 三层交换机实现VLAN间通信过程

    万次阅读 多人点赞 2017-10-08 11:32:24
    1. 三层交换机由来 两个VLAN之间可以通过多端口的路由器实现互连,但是这种多端口路由器互连VLAN因为VLAN数量的动态性, 实际应用过程中是很难实施的,因此可以用单端口路由器互连多个VLAN。 单端口路由器互连VLAN...
  • 技术原理: 1. 三层交换机是带有三层路由功能的交换机,也就是这台交换机的端口既有三层路由功能,也具有二层交换功能。...三层交换机给接口配置IP地址,采用SVI(交换虚拟接口)的方式实现VLAN间互连,SVI是指为交
  • 华为交换机:三层交换机实现vlan间通信 实验环境介绍 一、划分vlan并将相应的接口加入VLAN swh1配置 swh2配置 swh3配置 二、配置trunk并允许所有vlan通过 三、核心交换机swh4的配置 四、验证结果 实验环境介绍 一、...
  • 因为不同vlan之间是不可以通信的,通过交换机的配置来实验不同vlan之间的通信 一:实验拓扑 这里把 pc1,pc4,pc7都归属于vlan10 pc2,pc5,pc8都归属于vlan20 pc3,pc6,pc9都归属于vlan30 二:pc的配置 因为pc机...
  • 三层交换机实现不同VLAN之间的互访

    千次阅读 2020-12-28 21:41:57
    【实训任务】1.将拓扑中PC1、PC5、PC3...2.通过配置三层交换机实现跨VLAN的互访。【相关知识】三层交换有时又称为路由交换、多层交换。三层交换具有路由功能,能够识别网络层的信息,将IP地址信息用于网络路径选...
  • 使用三层交换机实现不同vlan互通

    千次阅读 2018-09-29 17:29:00
    如下拓扑图所示,要实现vlan10(192.168.10.0/24)与vlan 20...三层交换机配置: 创建vlan:Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit 创建vl...
  • [(1)在二层交换机上配置VLAN2、...(3)在三层交换机上配置V一、华为三层交换机实现不同网段和不同vlan间互通目标实现:pc1和pc2之间互通1、拓扑图 2、三层交换机配置:display current-configuration#sysname S1#VLAN...
  • 配置要求:1.完成设备名称和IP地址等的设置。2.完成telnet线路配置使管理终端能够远程访问所有网络设备。...3.按图示完成端口汇聚设置。...S1、B1为服务器模式,其他设备为...6.指定S1为所有VLAN的根交换机,并确保B1-B...
  • 在华为三层交换机上进行VLAN间路由的配置,主要就是创建VLAN,端口划分,三层VLAN接口地址配置,静态路由或是RIP协议配置
  • 三层交换机实现不同vlan间通信

    万次阅读 2018-10-31 20:19:13
    层交换机为神州数码DCS-3950,路由交换机为神州数码DCRS-5650,路由器为神州数码DCR-2600。 2.原理 2.1交换机的带外管理和带内管理 交换机的管理方式可以分为带内管理和带外管理两种管理模式。所谓带内管理,是...
  • 需求一:实现一个交换机多个不同的网段(VLAN)可以互相通信。 例如:个网段**192.168.10. – 192.168.11. – 192.168.12.-- ** 实现3个网段互通。 第一步:设置VLAN #进入交换机配置界面 system-view # 简写...
  • 版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。 ... 一、试验拓扑 ...PC1和PC3属于VLAN 10 ,PC2和PC四属于VLAN 20,实现不同VLAN之间的相互通讯 、试验过程...
  • 交换机配置 [sw1]vlan 10 [sw1-vlan10]vlan 20 [sw1-vlan20]port g1/0/2 [sw1-vlan20]vlan 10 [sw1-vlan10]port g1/0/1 [sw1-vlan10]int g1/0/3 [sw1-GigabitEthernet1/0/3]port link-type trunk [sw1-...
  • 使用三层交换机实现VLAN间通信

    万次阅读 多人点赞 2017-10-17 22:41:09
    1.先配置使得vlan内通信,vlan间通信隔离 对switch0 Switch>ena Switch#conf t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 Switch(config-vlan)#exit Switc

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,884
精华内容 2,353
关键字:

三层交换机vlan间互通

友情链接: nvpbzm.zip