精华内容
参与话题
问答
  • 网络互联

    千次阅读 2016-04-23 19:52:36
    网络互联 第四章我们已经见到如何用点到点链路,共享介质 和 交换机 建立单一的网络。 网络互联需要强调两个重要的问题:异构性(heterogeneity)和可扩展性(scale)。异构性问题指的是一种类型网络上的用户希望能够同...

    WilsonLiu’s blog 首发地址

    网络互联 第四章

    我们已经见到如何用点到点链路共享介质交换机 建立单一的网络。 网络互联需要强调两个重要的问题:异构性(heterogeneity)和可扩展性(scale)。

    异构性问题指的是一种类型网络上的用户希望能够同其他类型网络上的用户通信。

    可扩展性问题因特网规模快速扩张,使得面临许多挑战,其中之一是路由(routing):你如何在有几百万个到几十亿个节点的网络中去找到一条高效的路径。与此密切相关的是编址(addressing),即给所有节点疼合适标识符的任务。

    4.1 简单的网络互联(IP)

    4.1.1 什么是互联网

    我们用小写i的internetwork(互联网)这个词或仅用internet指可提供某种主机到主机的分组传送服务的相互连接的网络的任意集合。

    4.1.2 服务模型

    可以将IP服务模型看成两部分:一是编址方案,提供标识互联网中所有主机的方法;二是传送数据的数据报(无连接的)模型。这种服务模型有时也称为尽力服务(best-effort)模型,这是因为尽管IP尽力传送数据报,但并不提供保证。

    数据报传送

    数据报传送是IP的基础。数据报详情请见3.1.1。

    分组格式

    在没有其他选项的时候,首部通常是5个字长(20个字节)。首部信息中有一个16位的length指定数据报的字节数目,故而IP数据报最大尺寸为65535个字节。然而IP运行的物理网络可能不支持如此长的分组,因此IP支持分段和重组。

    分段和重组

    每个网络类型都有一个最大传输单元(Maximum Transmission Unit,MTU),这是一帧能够携带的最大数据报。 通常,当路由器接到一个想要在一个网络上转发的数据报,而这个网络的MTU比所接受到的数据报小时,在路由器上将进行分段,为了在目的主机上可以重组,所以都标识符(Ident)字段上携带同样的标识符。这个标识符由发送主机选择,并且对于所有可能在某个合理时段内从这个源主机到达目的主机的数据报来说是唯一的。

    4.1.3 全局地址

    以太网地址也是全局唯一的,但是以太网地址是扁平的flat,也就是说他们没有结构,且几乎不对路由协议提供线索。 相比之下IP地址是分层次的hierarchical,即他们由对应于互联网某种层次结构的几个部分构成。IP地址分为两个部分:网络部分和主机部分。 更确切的说IP地址属于接口而不是属于主机。

    1. A类 第一位为0 7位网络,24位主机
    2. B类 第一位为0,第二位为1 14位网络,16位主机
    3. C类 第一二位为0,第三位为1 21位网络 8位主机

    4.1.4 IP中的数据报转发

    转发数据报按一下方法处理:一个数据报从源主机发往目的主机,沿途可能经过多个路由器。任何一个节点,无论是主机还是路由器,首先试图确定自己是否与目的主机连接在同一个物理网络上(通过比较目的地址的网络部分和它的每一个网络接口地址的网络部分)。

    网桥,交换机和路由器的区别: 他们都是从一条链路把消息转发到另一条链路上。 人们根据分层对他们做出区分:网桥是链路层的节点(他们在链路间转发帧,实现可扩展的LAN),交换机是网络层节点(他们在链路间转发分组实现分组交换网络),路由器是互联网层节点(他们在网络之间转发数据报实现互联网)。 交换机和路由器有什么区别:关键区别是转发包的种类,路由器转发IP数据报,而以太网帧或者ATM信元是用交换机转发的。 交换机构造的ATM网络和路由器构造的因特网之间有一个很大的区别就是,因特网可以适应异构性,而ATM只能包含同构链路。

    4.1.5 地址转换 ARP

    上一节,我们讨论了如何使IP数据报到达正确的物理网络,但是掩饰了一个数据报如何到达该网络上某一个特定主机或路由器的问题。主要问题是IP数据报包含IP地址,但是你想要传送到的主机或者路由器上的物理接口硬件只理解特定网络的编址方案。这样,我们就需要将IP地址转换为这个网络所能理解的链路层地址。(如一个48位的以太网地址)

    Address Resolution Protocol,ARP

    ARP的目标是使网络上每个主机都简历一张IP地址到链路层地址间的映射表。 例:如果一个主机要发送一个数据报给已知为同一网络内的另一个主机(或路由器)(即发送和接收节点有同样的网络号),那么它首先检查缓存中的映射,如果映射不存在,就调用ARP。即通过向网络广播一个ARP查询来实现,这个查询包括询问的IP地址,每个主机收到这个查询并检查是否与自己的IP地址匹配。如果匹配,该主机发送一个包含它的链路层地址的应答信息给发送出查询的源主机。源主机将次应答的包含的信息添加到自己的ARP表中。 同时查询信息中也包含源主机的IP地址和链路层地址,这样,每台主机都会知道源主机的链路层地址和IP地址,并更新自己的ARP表。

    4.1.6 主机配置 Dynamic Host Configuration Protocol

    DHCP依赖于DHCP服务器的存在,DHCP服务器负责向主机提供配置信息。一个管理域中至少有一个DHCP服务器。 为了与一个DHCP服务器相连,一台新自举或新连接的主机发送一条DHCPDISCOVER消息到一个特殊的IP地址(255.255.255.255)—-广播地址。DHCP服务器应答产生这条发现消息的主机(所有其他节点忽略这条消息)。然而,并不是每个网络都需要一个DHCP服务器,因此,DHCP使用一个中继代理(relayagen)的概念。每个网络中至少有一个中继代理,它只配置有一条消息:DHCP服务器的IP地址。 DHCP允许地址一段时间内被”租用”。一旦租用期满,服务器将地址回收。一个租用地址的主机,如果事实仍然连在网络上并功能正常,显然需要定期重新租用地址。 当然,DHCP也引入了更多的复杂性到了网络管理,因为它使物理主机与IP地址之间的绑定更为动态化。

    4.1.7 差错报告 ICMP

    IP总是和网际控制报文协议(Internet Control Message Protocol)配置在一起的,这个协议定义了当一个路由器或主机不能成功处理一个IP数据报时,向源主机发回的错误消息的集合。(与http状态码类似)

    4.2 路由

    转发(forwarding):转发过程包括接收一个分组,查看它的目的地址,查询转发表,按表中决定的路径把分组转发出去。转发是在一个节点本地执行的一个相对简单,定义良好的过程。 路由(routing):用于建立转发表的一个过程,依赖于在网络发展过程中不断演进的,复杂分布式算法。

    构造转发表是为优化转发分组时查找网络号的过程,而优化路由表是为了计算拓扑结构的改变。

    4.2.1 用图表示网络

    路由本质上是图论中的一个问题。 图中的边对应于网络中的链路,每条边都有一个相应的开销(cost),表示希望通过这段链路发送的通信量。 路由最基本的问题就是找出任意两个节点之间开销最小的路径,一条路径的开销等于组成这条路径的所有边上开销之和。

    4.2.2 距离向量 RIP

    每个节点构造一个包含到所有其他节点”距离”(开销)的一维数组(一个向量),并将这个向量分发给它的邻接点。对距离向量路由所作的最初假设是每个节点都知道到其直接邻接点的链路开销。到不相邻节点的链路开销被指定为无穷大。

    网络中没有任何一个节点有网络路由表的所有信息,每个节点只知道它自己路由表的内容。像这种分布式算法的优点就是它能够使所有节点在没有任何集中授权的情况下取得对网络的一致视图。

    路由表更新:第一种为定期更新(periodic),第二种为触发(triggered)更新。

    两种改进稳定路由时间的技术;第一种是使用一个相对较小的数作为无穷大的近似值,第二种被称为水平分割(splithorizon),其思想是当一个节点把路由的更新消息发送给相邻节点时,它并不把从各个相邻节点处学到的路由再回送给该节点。

    4.2.3 链路状态 OSPF

    假设每个节点都能找出到它的相邻节点的链路状态以及每条链路的开销,我们还希望提供给每个节点足够的信息,使他能找出到达任一目标的最小开销路径。 基本思想:每个节点都知道怎样到达它的邻接点,如果我们确保这种信息被完整地传播到每个节点,那么每个节点都有足够的网络信息来简历一个完整的网络映像。 链路状态路由协议依靠两种机制:链路状态信息的可靠传播和根据所有积累的链路状态指示的总和进行的路由计算。

    4.2.4 度量标准

    1. 第一版本的度量标准是在每条链路上排队等待发送的分组的数量。
    2. 第二版本的度量,即考虑了链路带宽,又考虑了链路时延,并使用延迟而不是队列长度作为负载的衡量标准。
    3. 第三版本的度量,主要的改进是大量缩减度量值的动态范围。

    4.3 全球因特网

    4.3.1 划分子网

    划分子网是减少分配网络号总数的一个很好的简单方法。 基本思想是只用一个网络号,把具有这个网络号的IP地址分配给多个物理网络,每个物理网络叫做一个子网(subnet)。在很多个网络当中共享一个网络号的机制涉及到使用子网掩码(subnetmask)配置每个子网中的所有节点。 因此现在我们可以认为IP地址分为3部分:网络部分,子网部分和主机部分。即我们将原来用于表示主机的部分划分为子网部分和主机部分。

    当主机要发送一个分组到一个特定的IP地址时,它所做的第一件事就是用它的子网掩码与目标IP地址做按位与运算。如果结果等于发送主机的子网号,那么它就得知目的主机在同一子网内,分组可以在子网中直接传送,如果不等于,就需要把分组发送给一个路由器以便转发到另一个子网。

    引入子网后,路由器的工作也跟着发生变化,原先的转发表是由成对形式的

    4.3.2 无类路由 CIDR

    ClasslessInter-DomainRouting技术用于解决因特网中两种可扩展问题:第一,越来越多的网络号需要存在于主干网路由表中,从而导致了它的增长;第二,在第40亿台主机连接到因特网之前,32位的IP地址就可能已经耗尽。 CIDR尝试在减少一个路由器所需要知道的路由数的愿望与有效分配地址的需求之间取得平衡。为了做到这一点,CIDR帮我们汇聚路由。它通过打破地址分类间的严格界限。 CIDR通过一种新型标注或者用已知的前缀来表示网络号,因为前缀可以任意长,所以通常是放置一个”/X”在前缀后,其中”/X”表示前缀的位长度。 如20位的前缀可以表示为 192.4.16/20

    4.4 多播

    如第二章中,以太网和令牌环这样的多点访问网络用硬件实现多播。 为了更好的支持多对以及一对多的连接,IP提供了一种IP级模拟多播用于多点访问网络。

    基本的IP多播模型是基于多播组的多对多模型,每个组都有自己的IP多播地址,组里的任何主机收到任何的分组拷贝都会发送到组的多播地址 这样发送主机不需要发送多个分组拷贝,因为路由器无论何时都会在需要的时候将分组转发给多个链接,相比于使用单播IP传送相同的分组给多个接受者,IP多播更可测,因为它消除了一些需要在同一个链路上发送多次的冗余流量,特别是靠近发送主机的链路。

    IP的原始多对多播(任意源多播,ASM)已经增强为可支持的一对多播的形式。在一对多播模型中,即源特定多播(SSM),接收主机指定一个多播组和特定发送主机,接收主机仅将从特定主机收到的多播地址发送给特定的组。

    4.4.1 多播地址

    IP中有一个子空间是保留给多播地址的。在IPV4中,这些地址被分配在D类地址空间中。

    4.4.2 多播路由

    多播路由是一个多播分配树的决策过程,更具体的书,是一个多播转发表的建立过程。

    1. 距离向量多播路由协议 DVMRP
    2. PIM
    3. MSDP

    4.5 多协议标记交换 Multi-protocol Lavel Switching ,MPLS

    MPLS的好处

    1. 使不具备按正常方式转发IP数据报能力的设备能支持IP
    2. 按”显示路由”—-即预先计算的路由转发IP数据报,而无需匹配普通IP路由协议选择的路由
    3. 支持特定类型的虚拟专用网服务

    4.5.1 基于目的地的转发

    链式索引(threaded index) 当一个路由器能够支持MPLS时,他给路由表中的每个前缀都分配一个标记,并将标记和所表示的前缀通知相邻路由器,此通知的分发由标记分发协议(LabelDistributionProtocol,LDP)携带。

    标记边缘路由器(Label Edge Router,LER)对到达的IP分组进行完全的IP查找,然后用他们的标记作为查找的结果并附加到这个分组的头部。 这样,我们就用标记查找代替正常的IP目的地址查找。(IP地址查找算法需要查找最长匹配,与将要转发的分组中的IP地址高比特部分相匹配的最长前缀。相反,标记转发机制则是一种精确匹配算法,建立一个数组,标记为数组的索引)

    4.5.2 显示路由

    源路由并未广泛使用,MPLS提供了一种方便的方法将类似源路由的能力添加到IP网络中,这种能力被称为显示路由。两者之间的区别在于。显示路由通常不是选择此路由的分组的真正源,在更多情况下它是服务提供者网络中的一个路由器。 资源预留协议(RSVP)

    展开全文
  • 网络互联技术 网络互联技术 网络互联技术 网络互联技术
  • 网络互联设备

    2020-06-07 21:43:41
    网络互联设备 互联设备 工作层次 主要功能 中继器 物理层 对接受信号继续再生和发送,只起到扩展传输距离的作用,对高层协议是透明的,但使用个数有限(例如,在以太网中只能使用4个) 网桥 ...

     

     

    网络互联设备
    互联设备 工作层次 主要功能
    中继器(repeater) 物理层 对接受信号进行再生和发送,只起到扩展传输距离的作用,对高层协议是透明的,但使用个数有限(例如,在以太网中只能使用4个)
    网桥(bridge) 数据链路层 根据帧物理地址进行网络之间的信息转发,可缓解网络通信繁忙度,提高效率。只能够连接相同MAC层的网络。用来连接多个局域网。
    路由器(router) 网络层 根据逻辑地址进行网络之间的协议转发,可完成异构网络之间的互联互通,只能连接使用相同网络层协议的子网。内部维护一张路由表,决定数据包的下一跳应该发往哪里;实现NAT功能。
    网关(gateway) 高层(4-7层) 最复杂的网络互联设备,用于连接网络层以上执行不同协议的子网。用来连接多种不同架构的网络,同时也有路由的作用
    集线器(hub) 网络层 多端口中继器。解决一个网段内局域网各台主机之间的通信。
    二层交换机(switch) 数据链路层 是指传统意义上的交换机,多端口网桥。解决一个网段内局域网各台主机之间的通信,比HUB先进的地方体现在它里面维护了一张表,这张表记录了各台主机MAC和其所连接的端口的对应关系
    三层交换机 网络层 带路由功能的二层交换机(路由器
    多层交换机 高层(4-7层) 带协议转换的交换机(网关

     

    摘自《系统架构师教程》并改编

    展开全文
  • 网络互联期末复习题

    千次阅读 多人点赞 2019-12-04 14:56:27
    网络互联期末复习题 1.3.4.2 动态路由 R2路由器 cisco enable class configure terminal router rip network 192.168.2.0 network 192.168.3.0 network 192.168.7.0 end R3路由器 cisco enable class configure ...

    网络互联期末复习题

    1.3.4.2 动态路由

    R2路由器

    cisco
    enable
    class
    configure terminal 
    router rip
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.7.0
    end
    

    R3路由器

    cisco
    enable
    class
    configure terminal 
    router rip
    network 192.168.3.0
    network 192.168.4.0
    network 192.168.5.0
    exit
    ip route 192.168.1.0 255.255.255.0 FastEthernet 0/0
    

    R4路由器

    cisco
    enable
    class
    configure terminal 
    router rip
    network 192.168.5.0
    network 192.168.6.0
    network 192.168.7.0
    end
    

    2.8.2.2 静态路由配置练习

    因为要每个子网支持60台主机,所以至少需要6位作为主机位,共可以划分4个子网,分别为:

    192.168.2.0/26
    192.168.2.64/26
    192.168.2.128/26
    192.168.2.192/26
    

    下面为拓扑网分配子网地址,题目要求为:

    • 将子网 1 分配给连接到 HQ 的 LAN
    • 将子网 2 分配给 HQ 和 BRANCH 之间的 WAN 链路
    • 将子网 3 分配给连接到 BRANCH 的 LAN
    • 子网 0 用于供将来扩展
      为设备接口分配适当的地址。
    • 将子网 1 中第一个有效主机地址分配给 HQ 上的 LAN 接口。
    • 将子网 1 中最后一个有效主机地址分配给 PC2。
    • 将子网 2 中第一个有效主机地址分配给 BRANCH 上的 WAN 接口。
    • 将子网 2 中第二个有效主机地址分配给 HQ 上的 WAN 接口。
    • 将子网 3 中第一个有效主机地址分配给 BRANCH 上的 LAN 接口。
    • 将子网 3 中最后一个有效主机地址分配给 PC1。
    设备 接口 IP地址 子网掩码 默认网关
    BRANCH Fa0/0 192.168.2.193 255.255.255.192 N/A
    BRANCH S0/0/0 192.168.2.129 255.255.255.192 N/A
    HQ Fa0/0 192.168.2.65 255.255.255.192 N/A
    HQ S0/0/0 192.168.2.130 255.255.255.192 N/A
    HQ S0/0/1 209.165.201.2 255.255.255.252 N/A
    ISP Fa0/0 209.165.200.225 255.255.255.224 N/A
    ISP S0/0/0 209.165.201.1 255.255.255.252 N/A
    PC1 网卡 192.168.2.254 255.255.255.192 192.168.2.193
    PC2 网卡 192.168.2.126 255.255.255.192 192.168.2.65
    Web服务器 网卡 209.165.200.254 255.255.255.224 209.165.200.225

    按照上表中给各个设备设置IP地址、子网掩码以及默认网关,这里就不放过程了,直接配置就可以,对端口配置完IP后别忘了开启端口。配置完成后进行下一步

    根据以下说明对 BRANCH、HQ 和 ISP 路由器进行基本配置:

    • 配置路由器主机名
    • 禁用 DNS 查找
    • 配置执行模式口令
    • 配置当天消息标题
    • 为控制台连接配置口令
    • 为 VTY 连接配置口令

    HQ路由器:

    enable
    configure terminal
    hostname HQ
    no ip domain-lookup
    enable password class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    Branch路由器

    enable
    configure terminal
    hostname Branch
    no ip domain-lookup
    enable password class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    ISP路由器

    enable
    configure terminal
    hostname ISP
    no ip domain-lookup
    enable password class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    下面配置静态路由:
    Branch:

    ip route 0.0.0.0 0.0.0.0 s0/0/0
    

    HQ:

    ip route 0.0.0.0 0.0.0.0 209.165.201.1
    ip route 192.168.2.192 255.255.255.192 s0/0/0
    

    ISP:

    ip route 192.168.2.0 255.255.255.0 s0/0/0
    

    7.5.2.2 RIPv2 练习配置实验(83/84)

    任务 1:对地址空间划分子网。

    步骤 1- 研究网络要求。

    此网络的编址方案应满足以下要求:

    • ISP LAN 使用 209.165.200.224/27 网络。

    • ISP 和 HQ 之间的链路使用 209.165.202.128/27 网络。

    • 必须使用 VLSM 对 192.168.40.0/24 网络划分子网,以供其它链路使用。

    • HQ LAN 1 需要 50 个主机 IP 地址。

    • HQ LAN 2 需要 50 个主机 IP 地址。

    • BRANCH LAN 1 需要 30 个主机 IP 地址。

    • BRANCH LAN 2 需要 12 个主机 IP 地址。

    • HQ 和 BRANCH 之间的链路两端各需要一个 IP 地址。

    Step 2- 创建网络设计时请思考以下问题:

    需要为 192.168.40.0/24 网络创建多少个子网?

    5个

    总共需要从 192.168.40.0/24 网络获得多少个 IP 地址?

    100+30+12+2 = 144个

    HQ LAN1 子网将使用什么子网掩码?

    255.255.255.192

    该子网可以使用的主机地址最多有多少个?

    62个 192.168.40.1/26 ~ 192.168.40.62/26

    HQ LAN2 子网将使用什么子网掩码?

    255.255.255.192

    该子网可以使用的主机地址最多有多少个?

    62个 192.168.40.65/26 ~ 192.168.40.126/26

    BRANCH LAN1 子网将使用什么子网掩码?

    255.255.255.224

    该子网可以使用的主机地址最多有多少个?

    30个 192.168.40.129/27 ~ 192.168.40.158/27

    BRANCH LAN2 子网将使用什么子网掩码?

    255.255.255.240

    该子网可以使用的主机地址最多有多少个?

    14个 192.168.40.161/28 ~ 192.168.40.174/28

    HQ 和 BRANCH 路由器之间的链路将使用什么子网掩码?

    255.255.255.252

    该子网可以使用的主机地址最多有多少个?

    2个 192.168.40.177/30 ~ 192.168.40.178/30

    任务 2:确定接口地址。

    步骤 1- 为设备接口分配适当的地址

    将 209.165.200.224/27 网络中的第一个有效主机地址分配给 ISP 路由器上的 LAN 接口。

    209.165.200.225/27

    将 209.165.200.224/27 网络中的最后一个有效主机地址分配给 PC5

    209.165.200.254/27

    将 209.165.202.128/27 网络中的第一个有效主机地址分配给 ISP 的 WAN 接口。

    209.165.202.129/27

    将 209.165.202.128/27 网络中的最后一个有效主机地址分配给 HQ 的 Serial 0/0/1 接口。

    209.165.202.158/24

    将 HQ LAN1 网络中的第一个有效主机地址分配给 HQ 的 LAN1 接口。

    192.168.40.1/26

    将 HQ LAN1 网络中的最后一个有效主机地址分配给 PC3。

    192.168.40.62/26

    将 HQ LAN2 网络中的第一个有效主机地址分配给 HQ 的 LAN2 接口。

    192.168.40.65/26

    将 HQ LAN2 网络中的最后一个有效主机地址分配给 PC 4。

    192.168.40.126/26

    将 HQ/BRANCH WAN 链路中的第一个有效主机地址分配给 HQ 的 Serial 0/0/0 接口。

    192.168.40.177/30

    将 HQ/BRANCH WAN 链路中的最后一个有效主机地址分配给 BRANCH 的 Serial 0/0/0 接口。

    192.168.40.178/30

    将 BRANCH LAN1 网络中的第一个有效主机地址分配给 BRANCH 的 LAN1 接口。

    192.168.40.129/27

    将 BRANCH LAN1 网络中的最后一个有效主机地址分配给 PC1。

    192.168.40.174/28

    将 BRANCH LAN2 网络中的第一个有效主机地址分配给 BRANCH 的 LAN2 接口。

    192.168.40.161/28

    将 BRANCH LAN2 网络中的最后一个有效主机地址分配给 PC 2
    分配IP地址

    192.168.40.158/27

    任务 3:准备网络

    步骤 1- 使用本练习中的图表和现有设备进行网络布线。

    拓补图为:

    在这里插入图片描述

    任务 4:执行基本路由器配置。

    • 根据以下说明对 BRANCH、HQ 和 ISP 路由器进行基本配置:

    • 配置路由器主机名。

    • 禁用 DNS 查找。

    • 配置执行模式口令。

    • 配置当日消息标语。

    • 配置控制台连接的口令。

    • 配置 VTY 连接的口令。

    HQ路由器:

    enable
    configure terminal
    hostname Branch
    no ip domain-lookup
    enable password class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    Branch路由器

    enable
    configure terminal
    hostname Branch
    no ip domain-lookup
    enable password class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    ISP路由器

    enable
    configure terminal
    hostname ISP
    no ip domain-lookup
    enable password class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    任务 5:配置并激活串行地址和以太网地址。

    步骤 1 - 配置 BRANCH、HQ 和 ISP 路由器。

    使用拓扑图下方地址表中的 IP 地址配置 BRANCH、HQ 和 ISP 上的接口。

    完成后,务必将运行配置保存到路由器的 NVRAM 中。

    步骤 2 - 配置 PC1、PC2、PC3、PC4 和 PC5 的以太网接口。

    使用拓扑图下方地址表中的 IP 地址配置 PC1、PC2、PC3、PC4 和 PC5 的以太网接口。

    各设备IP地址为:

    设备 接口 IP地址 子网掩码 默认网关
    ISP F0/0 209.165.200.225 255.255.255.224 N/A
    ISP S0/0/1 209.165.202.129 255.255.255.224 N/A
    HQ F0/0 192.168.40.1 255.255.255.192 N/A
    HQ F0/1 192.168.40.65 255.255.255.192 N/A
    HQ S0/0/0 192.168.40.177 255.255.255.252 N/A
    HQ S0/0/1 209.165.202.158 255.255.255.0 N/A
    Branch F0/0 192.168.40.129 255.255.255.224 N/A
    Branch F0/1 192.168.40.161 255.255.255.240 N/A
    Branch S0/0/0 192.168.40.178 255.255.255.252 N/A
    PC1 网卡 192.168.40.174 255.255.255.240 192.168.40.161
    PC2 网卡 192.168.40.158 255.255.255.224 192.168.40.129
    PC3 网卡 192.168.40.62 255.255.255.192 192.168.40.1
    PC4 网卡 192.168.40.126 255.255.255.192 192.168.40.65
    PC5 网卡 209.165.200.254 255.255.255.224 209.165.200.225

    Branch、HQ、ISP的时钟配置:

    interface serial 0/0/0
    clock rate 56000
    exit
    interface serial 0/0/1
    clock rate 56000
    exit
    

    任务 7:在 BRANCH 路由器上配置 RIPv2 路由。

    router rip
    version 2
    no auto-summary
    network 192.168.40.128
    network 192.168.40.160
    network 192.168.40.176
    passive-interface fastEthernet 0/0
    passive-interface fastEthernet 0/1
    

    任务 8:在 HQ 上配置 RIPv2 和静态路由。

    ip route 0.0.0.0 0.0.0.0 serial 0/0/1
    router rip
    version 2
    no auto-summary
    network 192.168.40.0
    network 192.168.40.64
    network 192.168.40.128
    network 192.168.40.160
    network 192.168.40.176
    network 209.165.202.128
    passive-interface fastEthernet 0/0
    passive-interface fastEthernet 0/1
    default-information originate 
    

    任务 9:在 ISP 路由器上配置静态路由。

    ip route 192.168.40.0 255.255.255.0 serial 0/0/1
    

    练习 3.5.2.2 VLAN 配置练习(73/74)

    地址表

    设设备 接口 IP 地址 子网掩码 默认网关
    S1 VLAN 56 192.168.56.11 255.255.255.0 不适用
    S2 VLAN 56 192.168.56.12 255.255.255.0 不适用
    S3 VLAN 56 192.168.56.13 255.255.255.0 不适用
    PC1 网卡 192.168.10.21 255.255.255.0 192.168.10.1
    PC2 网卡 192.168.20.22 255.255.255.0 192.168.20.1
    PC3 网卡 192.168.30.23 255.255.255.0 192.168.30.1
    PC4 网卡 192.168.10.24 255.255.255.0 192.168.10.1
    PC5 网卡 192.168.20.25 255.255.255.0 192.168.20.1
    PC6 网卡 192.168.30.26 255.255.255.0 192.168.30.1

    端口分配(交换机 2 和 3)

    端口 分配 网络
    Fa0/1-0/5 VLAN 56 - Management&Native 192.168.56.0 /24
    Fa0/6-0/10 VLAN 30 - Guest(Default) 192.168.30.0 /24
    Fa0/11 - 0/17 VLAN 10 - Faculty/Staff 192.168.10.0 /24
    Fa0/18 - 0/24 VLAN 20 - Students 192.168.20.0 /24

    任务 1:执行基本交换机配置

    根据以下指导原则配置交换机。Packet Tracer 只对主机名评分。
    配置交换机主机名。
    禁用 DNS 查找。
    将执行模式口令配置为 class。
    为控制台连接配置口令 cisco。
    为 vty 连接配置口令 cisco。
    S1:

    enable
    configure terminal
    hostname S1
    no ip domain-lookup
    enable secret class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    S2:

    enable
    configure terminal
    hostname S2
    no ip domain-lookup
    enable secret class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    S3:

    enable
    configure terminal
    hostname S3
    no ip domain-lookup
    enable secret class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    任务 2:配置并激活以太网接口

    步骤 1. 配置 PC。

    使用本练习开头部分地址表中的 IP 地址和默认网关配置六台 PC 的以太网接口。现在 PC1 的 IP 地址会评定为错误。您将在稍后的练习中更改 PC1 的地址。

    步骤 2. 在 S2 和 S3 上启用提供访问的用户端口。

    任务 3:在交换机上配置 VLAN

    步骤 1. 在交换机 S1 上创建 VLAN。

    VLAN ID 和名称列在本练习开头部分的端口分配表中。

    步骤 2. 检验在 S1 上创建的 VLAN。

    步骤 3. 在交换机 S2 和 S3 上配置、命名和检验 VLAN。

    步骤 4. 在 S2 和 S3 上将交换机端口分配给 VLAN。

    注意:S2 Fa0/11 端口现在会被评为错误,并且 Packet Tracer 将只对每个 VLAN 的第一个端口分配评分。

    步骤 5. 确定 S2 的哪些端口已添加到 VLAN 10。

    步骤 6. 在每台交换机上配置管理 VLAN 56。

    步骤1 - 6:
    S1

    vlan 56
    name Management&Native
    exit
    vlan 30
    name Guest(Default)
    exit
    vlan 10
    name Faculty/Staff
    exit
    vlan 20
    name Students
    exit
    interface range fastEthernet 0/1 -5
    switchport access vlan 56
    exit
    interface range fastEthernet 0/6 -10
    switchport access vlan 30
    exit
    interface range fastEthernet 0/11 -17
    switchport access vlan 10
    exit
    interface range fastEthernet 0/18 -24
    switchport access vlan 20
    exit
    interface vlan 56
    ip address 192.168.56.11 255.255.255.0
    

    S2:

    vlan 56
    name Management&Native
    exit
    vlan 30
    name Guest(Default)
    exit
    vlan 10
    name Faculty/Staff
    exit
    vlan 20
    name Students
    exit
    interface range fastEthernet 0/1 -5
    switchport access vlan 56
    exit
    interface range fastEthernet 0/6 -10
    switchport access vlan 30
    exit
    interface range fastEthernet 0/11 -17
    switchport access vlan 10
    exit
    interface range fastEthernet 0/18 -24
    switchport access vlan 20
    exit
    interface vlan 56
    ip address 192.168.56.12 255.255.255.0
    

    S3:

    vlan 56
    name Management&Native
    exit
    vlan 30
    name Guest(Default)
    exit
    vlan 10
    name Faculty/Staff
    exit
    vlan 20
    name Students
    exit
    interface range fastEthernet 0/1 -5
    switchport access vlan 56
    exit
    interface range fastEthernet 0/6 -10
    switchport access vlan 30
    exit
    interface range fastEthernet 0/11 -17
    switchport access vlan 10
    exit
    interface range fastEthernet 0/18 -24
    switchport access vlan 20
    exit
    interface vlan 56
    ip address 192.168.56.13 255.255.255.0
    

    步骤 7. 为所有三台交换机上的中继端口配置中继和本征 VLAN。检验中继配置情况。

    S1:

    interface fastEthernet 0/1
    switchport mode trunk 
    switchport trunk native vlan 56
    exit
    interface fastEthernet 0/2
    switchport mode trunk 
    switchport trunk native vlan 56
    exit
    

    S2:

    interface fastEthernet 0/1
    switchport mode trunk 
    switchport trunk native vlan 56
    exit
    interface fastEthernet 0/11
    switchport mode access 
    exit
    interface fastEthernet 0/18
    switchport mode access 
    exit
    interface fastEthernet 0/6
    switchport mode access 
    exit
    

    S3:

    interface fastEthernet 0/2
    switchport mode trunk 
    switchport trunk native vlan 56
    exit
    interface fastEthernet 0/11
    switchport mode access 
    exit
    interface fastEthernet 0/18
    switchport mode access 
    exit
    interface fastEthernet 0/6
    switchport mode access 
    exit
    

    步骤 8. 检验 S1、S2 和 S3 是否能够通信。

    步骤 9. 从 PC2 ping 其它主机。结果是什么?

    步骤 10. 将 PC1 移到与 PC2 相同的 VLAN 中。PC1 是否能 ping 通 PC2?

    步骤 11. 将 PC1 的 IP 地址更改为 192.168.20.21。PC1 是否能 ping 通 PC2?

    练习 4.4.2:VTP 配置(117/120)

    地址表

    设备 接口 IP 地址 子网掩码
    S1 VLAN 99 172.31.99.11 255.255.255.0
    S2 VLAN 99 172.31.99.12 255.255.255.0
    S3 VLAN 99 172.31.99.13 255.255.255.0
    PC1 网卡 172.31.10.1 255.255.255.0
    PC2 网卡 172.31.20.1 255.255.255.0
    PC3 网卡 172.31.30.1 255.255.255.0
    PC4 网卡 172.31.10.2 255.255.255.0
    PC5 网卡 172.31.20.2 255.255.255.0
    PC6 网卡 172.31.30.2 255.255.255.0

    端口分配(S2 和 S3)

    端口 分配 网络
    Fa0/1 - 0/5 802.1q 中继
    Fa0/6 - 0/10 VLAN 30 - Administration 172.31.30.0 /24
    Fa0/11 - 0/17 VLAN 10 - Engineering 172.31.10.0 /24
    Fa0/18 - 0/24 VLAN 20 - Sales 172.31.20.0 /24
    VLAN 99 - Network Mgmt 172.31.99.0 /24

    任务 1:执行基本交换机配置

    根据以下原则配置交换机 S1、S2 和 S3 并保存配置:

    按照拓扑所示配置交换机主机名。
    禁用 DNS 查找。
    将执行模式口令配置为 class。
    将控制台和 vty 连接口令配置为 cisco。

    S1:

    enable
    configure terminal
    hostname S1
    no ip domain-lookup
    enable secret class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    S2:

    enable
    configure terminal
    hostname S2
    no ip domain-lookup
    enable secret class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    S3:

    enable
    configure terminal
    hostname S3
    no ip domain-lookup
    enable secret class
    banner motd $
    this is banner!$
    line console 0
    password cisco
    login
    exit
    line vty 0 4
    password cisco
    

    任务 2:配置主机 PC 上的以太网接口

    使用地址表中的 IP 地址配置 PC1、PC2、PC3、PC4、PC5 和 PC6 的以太网接口。本练习无需配置默认网关。

    按照IP地址配置即可

    任务 3:在交换机上配置 VTP

    VTP 可让网络管理员通过创建 VTP 域来控制网络上的 VLAN 实例。在每个 VTP 域中,可以将一台或多台交换机配置为 VTP 服务器。然后可以在 VTP 服务器上创建 VLAN,并将这些 VLAN 传送给域中的其它交换机。常见的 VTP 配置任务是设置工作模式、域和口令。在本实验中,您将把 S1 配置为 VTP 服务器,并将 S2 和 S3 配置为 VTP 客户端。

    步骤 1. 检查三台交换机上的当前 VTP 配置。

    步骤 2. 在所有三台交换机上配置工作模式、域名和 VTP 口令。

    在三台交换机上,全部将 VTP 域名设置为 access,VTP 口令设置为 lab4。将 S1 配置为服务器模式,S2 配置为客户端模式,S3 配置为透明模式。Packet Tracer 开始时会将 S3 的模式评定为不正确。您需要在本练习的后面部分对此加以更正。

    注意:客户端交换机可从服务器交换机处获知 VTP 域名,但前提是客户端交换机的域为空。如果客户端交换机已设置有域名,则不会获知新的域名。因此,最好是在所有交换机上手动配置域名,以确保域名配置正确。位于不同 VTP 域中的交换机不会交换 VLAN 信息。

    步骤1-2:
    S1:

    configure terminal
    vtp mode server 
    vtp domain access
    vtp password lab4
    

    S2:

    configure terminal
    vtp mode client 
    vtp domain access
    vtp password lab4
    

    S3:

    configure terminal
    vtp mode transparent  
    vtp domain access
    vtp password lab4
    

    步骤 3. 为所有三台交换机上的中继端口配置中继和本征 VLAN。

    在所有交换机上,为 FastEthernet 接口 0/1-5 配置中继和本征 VLAN。

    S1:

    S1(config)#interface range fastEthernet 0/1-5
    S1(config-if-range)#switchport mode trunk 
    S1(config-if)#switchport trunk native vlan 99
    S1(config-if)#no shutdown
    

    S2:

    interface range fastEthernet 0/1-5
    switchport mode trunk
    switchport trunk native vlan 99
    no shutdown
    

    S3:

    interface range fastEthernet 0/1-5
    switchport mode trunk
    switchport trunk native vlan 99
    no shutdown
    

    步骤 4. 在 S2 和 S3 接入层交换机上配置端口安全功能。

    配置 S2 和 S3 上的端口 fa0/6、fa0/11 和 fa0/18,使它们最多允许两台主机连接到这些端口上,并使它们能动态获知主机的 MAC 地址。

    S2:

    S2(config)#interface range fastEthernet 0/6,fa0/11,fa0/18
    S2(config-if-range)#switchport port-security maximum 2
    S2(config-if-range)#switchport port-security mac-address sticky 
    S2(config-if-range)#switchport port-security violation shutdown 
    

    S3:

    interface range fastEthernet 0/6,fa0/11,fa0/18
    switchport port-security maximum 2
    switchport port-security mac-address sticky 
    switchport port-security violation shutdown 
    

    步骤 5. 在 VTP 服务器上配置 VLAN。

    本实验需要四个 VLAN:

    VLAN 99 management
    VLAN 10 engineering
    VLAN 20 sales
    VLAN 30 administration
    在 VTP 服务器上配置这些 VLAN。
    完成后,检验 S1 上是否创建了所有四个 VLAN。

    S1:

    VLAN 99 
    name management
    exit
    VLAN 10
    name engineering
    exit
    VLAN 20
    name sales
    exit
    VLAN 30
    name administration
    exit
    

    (如果S2,S3最后没获取到,可以手动设置)

    步骤 6. 检查 S1 上创建的 VLAN 是否已分发给 S2 和 S3。

    在 S2 和 S3 上使用 show vlan brief 命令检查 VTP 服务器是否已将其 VLAN 配置传送给所有的交换机。

    所有交换机上配置的 VLAN 都相同吗?

    为什么 S2 和 S3 具有不同的 VLAN 配置?

    步骤 7. 在所有三台交换机上配置管理接口地址。

    在继续操作之前,先将 S3 上的 VTP 模式更改为客户端。然后检验 S3 是否已通过 VTP 收到来自 S1 的 VLAN 配置。

    使用本练习开头部分提供的地址表中的 IP 地址配置所有三台交换机。将这些地址分配给网络管理 VLAN (VLAN 99)。

    在交换机之间执行 ping 操作,检查这些交换机是否都已得到正确配置。从 S1 ping S2 和 S3 的管理接口。从 S2 ping S3 的管理接口。

    ping 是否成功?若不成功,则找出交换机配置问题并解决。

    S1:

    interface vlan 99
    ip address 172.31.99.11 255.255.255.0
    no shutdown
    

    S2:

    interface vlan 99
    ip address 172.31.99.12 255.255.255.0
    no shutdown
    

    S3:

    interface vlan 99
    ip address 172.31.99.13 255.255.255.0
    no shutdown
    

    步骤 8. 分配交换机端口给 VLAN。

    请参阅本实验开头的端口分配表,将端口分配给 VLAN。请注意,端口分配不是通过 VTP 配置的。请记住,交换机 S2 和 S3 的配置方法相似。完成后保存配置。
    S2、S3:

    interface range fastEthernet 0/6-10
    switchport mode access 
    switchport access vlan 30
    exit
    interface range fastEthernet 0/11 -17
    switchport mode access
    switchport access vlan 10
    exit
    interface range fastEthernet 0/18-24
    switchport mode access 
    switchport access vlan 20
    exit
    

    步骤 9. 检验中继是否工作正常。

    在 PC1 上 ping PC4、PC5 和 PC6。

    有成功的 ping 操作吗?

    为什么有些 ping 失败了?

    可以从 PC3 到达哪些主机?

    练习 6.2.2.5 配置单臂路由器 VLAN 间路由

    地址表

    设备 接口 IP 地址 子网掩码 默认网关
    R1 Fa0/1.10 172.17.10.1 255.255.255.0 不适用
    Fa0/1.30 172.17.30.1 255.255.255.0 不适用
    PC1 网卡 172.17.10.10 255.255.255.0 172.17.10.1
    PC2 网卡 172.17.30.10 255.255.255.0 172.17.30.1

    任务 1:测试不使用 VLAN 间路由时的连通性

    步骤 1. 在 PC1 和 PC3 之间执行 Ping 操作。

    等待交换机收敛。在连接到 PC1 和 PC3 的交换机上,链路灯从琥珀色变为绿色。当链路灯呈绿色时,在 PC1 和 PC3之间执行 ping 操作。由于两台计算机位于不同网络中而且尚未配置路由器,因此它们无法相互通信,ping 操作会失败。

    步骤 2. 切换到模拟模式监控 ping 操作。

    单击 Simulation(模拟) 选项卡或按 Shift+S,切换到模拟模式。
    单击 Capture/Forward(捕获/转发),观看 ping 操作在 PC1 和 PC3 之间采取的步骤。
    请留意,ping 甚至无法经过交换机。
    完成比例应为 0%。

    任务 2:添加 VLAN

    步骤 1. 在 S1 上创建 VLAN。

    在 S1 上创建 VLAN 10 和 VLAN 30。PC1 属于 VLAN 10,PC3 属于 VLAN 30。 要创建 VLAN,请在全局配置模式下发出命令 vlan 10 和 vlan 30。

    S1#configure terminal
    S1(config)#vlan 10
    S1(config-vlan)#vlan 30
    

    要检查是否已创建 VLAN,请在特权执行提示符后发出 show vlan brief 命令。

    步骤 2. 为端口分配 VLAN。

    将交换机上的每个端口分配到 VLAN 以实现 VLAN 间通信。 Fa0/11 接口属于 VLAN 10,Fa0/6 接口属于 VLAN 30。

    要为端口分配 VLAN,需进入接口配置模式。Fa0/11 的命令是 interface fa0/11。switchport mode access 命令可将该端口设置为接入模式。switchport access vlan 10 命令用于将 VLAN 10 分配给该端口。

    S1(config)#interface fa0/11
    S1(config-if)#switchport mode access
    S1(config-if)#switchport access vlan 10
    

    对 VLAN 30 的 Fa0/6 接口重复上述步骤。

    S1(config)#interface fa0/6
    S1(config-if)#switchport mode access
    S1(config-if)#switchport access vlan 30
    

    将 S1 的 Fa0/5 端口设置为中继端口,使其传输来自 VLAN 10 和 VLAN 30 的流量。 从 Fa0/5 接口发出 switchport mode trunk 命令,将该端口设置为中继端口。

    Packet Tracer 不对此命令评分,但配置 VLAN 间路由时需要使用此命令。

    S1(config)#interface fa0/5
    S1(config-if)#switchport mode trunk
    

    步骤 3. 测试 PC1 和 PC3之间的连通性。

    现在,请在 PC1 和 PC3之间发出 ping 命令。ping 仍应失败。

    步骤 4. 检查结果。

    完成比例应为 27%。如果并非如此,请单击 Check Results(检查结果)查看尚未完成哪些必要部分

    任务 3:配置 IP 地址

    步骤 1. 使用 802.1Q 封装配置子接口。

    在 R1 上创建两个子接口:Fa0/1.10 和 Fa0/1.30。将这两个子接口分配到不同的 VLAN。要创建第一个子接口,请发出 interface fa0/1.10 命令进入 Fa0/1.10 的子接口配置模式。请留意,路由器的命令提示符会更改。

    在子接口配置模式下发出 encapsulation dot1Q 10 命令,将封装类型设置为 802.1Q 并将 VLAN 10 分配给该虚拟接口。

    为端口分配正确的 IP 地址。Fa0/1.10 的 IP 地址应为 172.17.10.1,子网掩码为 255.255.255.0。使用正确的 IP 地址和 VLAN ID 对 Fa0/1.30 接口重复上述步骤。

    R1(config)#interface fa0/1.10
    R1(config-subif)#encapsulation dot1Q 10
    R1(config-subif)#ip address 172.17.10.1 255.255.255.0
    R1(config)#interface fa0/1.30
    R1(config-subif)#encapsulation dot1Q 30
    R1(config-subif)#ip address 172.17.30.1 255.255.255.0
    

    步骤 2. 检查结果。

    完成比例应为 100%。如果并非如此,请单击 Check Results(检查结果)查看尚未完成哪些必要部分。

    任务 4:再次测试连通性

    步骤 1. 在 PC1 和 PC3 之间执行 Ping 操作。

    从 PC1 ping PC3。ping 应该会成功。

    步骤 2. 切换到模拟模式监控 ping 操作。

    单击 Simulation(模拟) 选项卡或按 Shift+S,切换到模拟模式。
    单击 Capture/Forward(捕获/转发),观看 ping 操作在 PC1 和 PC3 之间采取的步骤。
    观察 ping 如何从 PC1 首先到 S1,然后到 R1,再返回 S1,最终返回 PC3。

    练习 5.2.8:配置标准 ACL

    练习 5.2.8:配置标准 ACL

    任务 2:评估网络策略并规划 ACL 实施

    步骤 1. 评估 R1 LAN 的策略。

    允许 192.168.10.0/24 网络访问除 192.168.11.0/24 网络外的所有位置。
    允许 192.168.11.0/24 网络访问所有目的地址,连接到 ISP 的所有网络除外。

    步骤 2. 为 R1 LAN 规划 ACL 实施。

    用两个 ACL 可完全实施 R1 LAN 的安全策略。
    在 R1 上配置第一个 ACL,拒绝从 192.168.10.0/24 网络发往 192.168.11.0/24 网络的流量,但允许所有其它流量。
    此 ACL 应用于 R1 Fa0/1 接口的出站流量,监控发往 192.168.11.0 网络的所有流量。
    在 R2 上配置第二个 ACL,拒绝 192.168.11.0/24 网络访问 ISP,但允许所有其它流量。
    控制 R2 S0/1/0 接口的出站流量。
    ACL 语句的顺序应该从最具体到最概括。拒绝网络流量访问其它网络的语句应在允许所有其它流量的语句之前。
    S1:

    access-list 10 deny 192.168.10.0 0.0.0.255
    access-list 10 permit any 
    interface fastEthernet 0/1
    ip access-group 10 out
    

    S2:

    access-list 11 deny 192.168.11.0 0.0.0.255
    access-list 11 permit any 
    interface serial 0/1/0
    ip access-group 11 out
    

    步骤 3. 评估 R3 LAN 的策略。

    允许 192.168.30.0/10 网络访问所有目的地址。
    拒绝主机 192.168.30.128 访问 LAN 以外的地址。

    步骤 4. 为 R3 LAN 规划 ACL 实施。

    一个 ACL 即可完全实施 R3 LAN 的安全策略。
    在 R3 上配置该 ACL,拒绝 192.168.30.128 主机访问 LAN 以外的地址,但允许 LAN 中的所有其它主机发出的流量。
    此 ACL 将应用于 Fa0/0 接口的入站流量,监控尝试离开 192.168.30.0/10 网络的所有流量。
    ACL 语句的顺序应该从最具体到最概括。拒绝 192.168.30.128 主机访问的语句应在允许所有其它流量的语句之前。
    R3:

    ip access-list standard NO_ACCESS
    deny host 192.168.30.128
    permit any
    exit
    interface fastEthernet 0/0
    ip access-group NO_ACCESS in
    
    展开全文
  •  虽然作为程序员来讲不必过多的去了解网络互联的相关技术,但是目前互联网已经转向了物联网时代,从刚开始的软件+网络,成为今天的硬件+软件+网络的模式(即物联网) 智能家居的实现模式也是典型的物联网产物。因此...


     转载请标明出处: http://blog.csdn.net/sk719887916/article/details/46773109 作者:skay 


     一 互联技术

       虽然作为程序员来讲不必过多的去了解网络互联的相关技术,但是目前互联网已经转向了物联网时代,从刚开始的软件+网络,成为今天的硬件+软件+网络的模式(即物联网)

    智能家居的实现模式也是典型的物联网产物。因此有网络基础对成为一个高级软件架构师有着无比轻重的作用,因此接下来几篇文章我会给大家介绍下网络相关的知识,


       目前主流的互联技术包括小规模的主机互联(局域网)和大规模的主机互联(广域网)。


        主机互联一般基于的通信模式有一对一通信(双方)和多对多通信(多方)由以下两种通信方式。


       1  双方通信


        –双方信息打包后放到通信线路上发送,就能到达对方。
        –在通信线路上只有两方,所收到的信息必然是对方发过来给我的。


       2 多方通信 

                -只将信息打包后就放到通信线路上去发送,那么就无法知道到是从哪儿发来的然后到底底是发给谁的信息。

               因此,我们需要给每一个通信终端都编一个号,也就是IP地址(IP地址)。

           虽然程序员和硬件扯不上太大的关系,但是我们还是要知道早期的局域网是同过双绞线和同轴电缆当作通信介质,但是由于介质的损耗和带宽问题,目前已采用光纤通信,

    采用光速,不仅提高了传输速率,而且减少了损耗。以下两种介质的对比。

    名称

    速率

    介质类型

    最大线缆长度

    10BASE2

    10Mbps

    细同轴电缆

    200

    10BASE-T

    10Mbps

    双绞线

    100


     二  网络基础

          在大致了解网络通信前,我们必须了解几个概念,IP地址,MAC地址,路由表,TCP/UDP协议,和网络层次模型

       1 OSI 七层模型

       
       


             计算机网络通信制定的一个7层框架,协议的七层框架,称为:“OSI/RM"。OSI模型分为七层,依次从底层到上层为,物理层,数据链路层,传输层,会话层,表示层,应用层。每个层此又为上层提供服务,说

       2 TCP/IP 四层模型


         TCP/IP通讯协议采用了4层的层级结构,分别为: 


         应用层:应用程序间沟通的层,如简单电子邮件传输(SMTP)、文件传输协议(FTP)、网络远程访问协议(Telnet)等。 


         传输层:它提供了节点间的数据传送服务,如传输控制协议(TCP)、用户数据报协议(UDP)等,TCP和UDP给数据包加入传输数据并把它传输到下一层中,这一层负责传送数据,并且确定数据已被送达并接收。 


         互连网络层:负责提供基本的数据封包传送功能,让每一块数据包都能够到达目的主机(但不检查是否被正确接收),如网际协议(IP)。 


           网络接口层:对实际的网络媒体的管理,定义如何使用实际网络(如Ethernet、Serial Line等)来传送数据。
        两种层次模型的对比图.
                                          
     其具体功能前我用现实中的硬件设备来对比一下.

    --物理层:网卡,网线,集线器,中继器,调制解调器
    --数据链路层:网桥,交换机
    --网络层:路由器

    --网关:工作在第四层传输层及其以上。
      对于稍微有网络基础的开发人员来说这些名词不会太陌生.到这问题又来了什么是网桥,什么是中继器?
    --中继器 
       中继器是局域网环境下用来延长网络距离的最简单最廉价的网络互联设备,操作在OSI的物理层,中继器对在线路上的信号具有放大再生的功能,用于扩展局域网网段的长度(仅用于连接相同的局域网网段)。
    中继器(RP repeater)是连接网络线路的一种装置,常用于两个网络节点之间物理信号的双向转发工作。中继器主要完成物理层的功能,负责在两个节点的物理层上按位传递信息,完成信号的复制、调整和放大功能,以此来延长网络的长度。
       也就说类似生活中变电的变压器功能。
     --网桥
       网桥不是真实的物质东西,而是一个作用域的代名词,网桥(Bridge)像一个聪明的中继器。中继器从一个网络电缆里接收信号, 放大它们,将其送入下一个电缆。相比较而言,网桥对从关卡上传下来的信息更敏锐一些。网桥是一种对帧进行转发的技术,根据MAC分区块,可隔离碰撞。网桥将网络的多个网段在数据链路层连接起来。
    网桥也叫桥接器,是连接两个局域网的一种存储/转发设备,它能将一个大的LAN分割为多个网段,或将两个以上的LAN互联为一个逻辑LAN,使LAN上的所有用户都可访问服务器。
      -- 交换机

        交换机就是用来进行报文交换的机器。多为链路层设备(二层交换机),能够进行地址学习,采用存储转发的形式来交换报文.。

        -- 路由器

      -路由器用来连通不同的网络,另一个作用是选择信息和分发传送的线路功能。选择通畅快捷的近路,能大大提高通信速度,减轻网络系统通信负荷,节约网络系统资源,提高网络系统畅通率。 

        具有多个接口,用于连接多个IP子网及多种链路,并实现其互联互通的网络设备。工作在OSI第三层,其主要工作任务是在网络中转发IP数据包


      3 MAC地址


       Mac地址即设备物理地址,他类似人类的身份证,每个人出生就开始编制了号码,其互联网设备出厂也会标志唯一的mac地址,物理地址由IEEE统一指定和分配,比如联想和惠普就有不同的区段范围的mac地址,其原理和规则是: MAC统一编址,MAC地址长6个字节(48位),全球唯一。前24为OUI,由IEEE分配给各网络厂家。后24位为EUI,由厂家自行分配。


       4 路由表

       又称全局路由表,存储在路由器的内存中,用于指示路由器发送IP数据包转发至正确目的地的信息表。列如,生活中我们去乘火车,我们只关心目的城市,从上车之前我们并不知道其最近路线,二路由器就里面就保存着我们下一站的信息,火车没到一个站,都要经过铁路公司的统一安排开始进入对应的股道,而路由器就是铁路中的小枢纽站一样。

       

    协议

    标网段/掩码

    出口

    下一跳

    C

    192.168.1.0/55

    S0/0

    -----

    C

    192.168.1.4/45

    S0/1

    -----

    b

    192.168.10.0/23

    F0/0

    -----

    S

    192.168.18.0/20

    S0/0

    192.168.1.2

    O

    192.168.22.0/219

    S0/1

    192.168.1.6


    5 TCP/IP

       上面提到Tcp /IP是一种互联网通信协议,它包括四层模型,各自进行自己的职责。TCP/IP 定义了电子设备如何连入因特网,以及数据如何在它们之间传输的标准。协议采用了4层的层级结构,每一层都呼叫它的下一层所提供的协议来完成自己的需求。通俗而言:TCP负责发现传输的问题,一有问题就发出信号,要求重新传输,直到所有数据安全正确地传输到目的地

     --IP

    IP层接收由更低层(网络接口层例如以太网设备驱动程序)发来的数据包,并把该数据包发送到更高层---TCP或UDP层;相反,IP层也把从TCP或UDP层接收来的数据包传送到更低层。IP数据包是不可靠的,因为IP并没有做任何事情来确认数据包是否按顺序发送的或者有没有被破坏,IP数据包中含有发送它的主机的地址(源地址)和接收它的主机的地址(目的地址)。
    高层的TCP和UDP服务在接收数据包时,通常假设包中的源地址是有效的。也可以这样说,IP地址形成了许多服务的认证基础,这些服务相信数据包是从一个有效的主机发送来的。IP确认包含一个选项,叫作IP source routing,可以用来指定一条源地址和目的地址之间的直接路径。对于一些TCP和UDP的服务来说,使用了该选项的IP包好像是从路径上的最后一个系统传递过来的,而不是来自于它的真实地点。这个选项是为了测试而存在的,说明了它可以被用来欺骗系统来进行平常是被禁止的连接。那么,许多依靠IP源地址做确认的服务将产生问题并且会被非法入侵。

    --TCP



         TCP是面向连接的通信协议,通过三次握手建立连接,通讯完成时要拆除连接,由于TCP是面向连接的所以只能用于端到端的通讯。
        TCP提供的是一种可靠的数据流服务,采用“带重传的肯定确认”技术来实现传输的可靠性。TCP还采用一种称为“滑动窗口”的方式进行流量控制,所谓窗口实际表示接收能力,用以限制发送方的发送速度。
    如果IP数据包中有已经封好的TCP数据包,那么IP将把它们向‘上’传送到TCP层。TCP将包排序并进行错误检查,同时实现虚电路间的连接。TCP数据包中包括序号和确认,所以未按照顺序收到的包可以被排序,而损坏的包可以被重传。
        TCP将它的信息送到更高层的应用程序,例如Telnet的服务程序和客户程序。应用程序轮流将信息送回TCP层,TCP层便将它们向下传送到IP层,设备驱动程序和物理介质,最后到接收方。
    面向连接的服务(例如Telnet、FTP、rlogin、X Windows和SMTP)需要高度的可靠性,所以它们使用了TCP。DNS在某些情况下使用TCP(发送和接收域名数据库),但使用UDP传送有关单个主机的信息。

    常见Tcp的端口号
      

    协议

    端口号

    协议

    端口号

    协议

    端口号

    FTP

    21

    HTTP

    80

    SMTP

    25

    FT-data

    20

    HTTPS

    443

    POP3

    110

    Telnet

    23

    SQL

    1433

    Tacacs+

    49

    SSH

    22

    Oracel

    1521

    DNS

    53


    --UDP

          UDP是面向无连接的通讯协议,UDP数据包括目的端口号和源端口号信息,由于通讯不需要连接,所以可以实现广播发送(单播、广播、组播)。
            UDP通讯时不需要接收方确认,属于不可靠的传输,可能会出现丢包现象,实际应用中要求程序员编程验证。
          UDP与TCP位于同一层,但它不管数据包的顺序、错误或重发。因此,UDP不被应用于那些使用虚电路的面向连接的服务,UDP主要用于那些面向查询---应答的服务,例如NFS。相对于FTP或Telnet,这些服务需 要      交换的信息量较小。使用UDP的服务包括NTP(网络时间协议)和DNS(DNS也使用TCP)。
           欺骗UDP包比欺骗TCP包更容易,因为UDP没有建立初始化连接(也可以称为握手)(因为在两个系统间没有虚电路),也就是说,与UDP相关的服务面临着更大的危险。
     

    常见Tcp的端口号:

    协议

    端口号

    协议

    端口号

    协议

    端口号

    DHCP

    67   68

    Radius

    1812 1813

    WINS

    42

    TFTP

    69

    NTP

    123

    NETBIOS

    137 138 139

    SNMP

    161  162

    RIP

    520

    DNS

    53


    --ICMP



    ICMP与IP位于同一层,它被用来传送IP的控制信息。它主要是用来提供有关通向目的地址的路径信息。ICMP的‘Redirect’信息通知主机通向其他系统的更准确的路径,而‘Unreachable’信息则指出路径有问题。另外,如果路径不可用了,ICMP可以使TCP连接‘体面地’终止。PING是最常用的基于ICMP的服务。

    --端口

      TCP和UDP服务通常有一个客户/服务器的关系,例如,一个Telnet服务进程开始在系统上处于空闲状态,等待着连接。用户使用Telnet客户程序与服务进程建立一个连接。客户程序向服务进程写入信息,服务进程读出信息并发出响应,客户程序读出响应并向用户报告。因而,这个连接是双工的,可以用来进行读写。
      两个系统间的多重Telnet连接是如何相互确认并协调一致呢?TCP或UDP连接唯一地使用每个信息中的如下四项进行确认:
     *源IP地址 发送包的IP地址。
    *目的IP地址 接收包的IP地址。
    *源端口 源系统上的连接的端口。
    * 目的端口 目的系统上的连接的端口。

         端口是一个软件结构,被客户程序或服务进程用来发送和接收信息。一个端口对应一个16比特的数。服务进程通常使用一个固定的端口,例如,SMTP使用25、Xwindows使用6000。Tomcat的端口:8080,这些端口号是‘广为人知’的,因为在建立与特定的主机或服务的连接时,需要这些地址和目的地址进行通讯,列如我们去建立聊天通讯的指定的自定义端口(8090)。


    --数据格式

       数据帧:帧头+IP数据包+帧尾 (帧头包括源和目标主机MAC初步地址及类型,帧尾是校验字)
      IP数据包:IP头部+TCP数据信息(IP头包括源和目标主机IP地址、类型、生存期等)
      TCP数据信息:TCP头部+实际数据 (TCP头包括源和目标主机端口号、顺序号、确认号、校验字等)

      常见的以太帧结构
       


    --IP地址

          在因特网上连接的所有计算机,从大型机到微型计算机都是以独立的身份出现,我们称它为主机。为了实现各主机间的通信,每台主机都必须有一个唯一的网络地址。就好像每一个住宅都有唯一的门牌一样,才不至于在传输资料时出现混乱。
    Internet的网络地址是指连入Internet网络的计算机的地址编号。所以,在Internet网络中,网络地址唯一地标识一台计算机。我们都已经知道,Internet是由几千万台计算机互相连接而成的。而我们要确认网络上的每一台计算机,靠的就是能唯一标识该计算机的网络地址,这个地址就叫做IP(Internet Protocol的简写)地址,即用Internet协议语言表示的地址。
    在Internet里,IP地址是一个32位的二进制地址,为了便于记忆,将它们分为4组,每组8位,由小数点分开,用四个字节来表示,而且,用点分开的每个字节的数值范围是0~255,如202.116.0.1,这种书写方法叫做点数表示法。

      IP包的头文件结构:


                


         对有着开发经验的程序员来说,概念或许你并不知道,但是你知道socket建立时我需要指定目标地址,和主机端口号。而这些是怎么IP协议发送过去的呢,首先发送方进行封包,路由器进行不断转发,最后找到目标主机进行拆包,然后读取信息。

        网络建立连接有个三次握手协议,通俗讲,小时候你出去玩了,你很饿,你就喊妈妈,问妈妈饭最好了吗,你妈妈说好了,你说可以过去吃饭吗,妈妈说可以了,这样你才能回家吃饭。计算机通信也是这样。

     如下图,A向B请求,B收到后应答给A,然后A收到B的应答信息后再继续应答B, B收到后双方建立连接。 注意:后面我们程序的非对称加密协议和网网络连接一样类似,后面我会讲到。

                              

       

        当我的连接建立时我通常开始主机A的封包和主机B的解包,当然解包是封包的逆过程,通常称为完整的一次连接。

                                          

           这里我们还需要知道两个概念DNS和ARP

        --DNS

        提供域名解析服务将URL中的域名解析成IP地址

        - -ARP

          将IP地址解析成MAC地址

         

          通过今天的学习,我们可以大概了解下TCP/IP的架构分布和传输协议,以及网络通讯的术语和各自功能,包括几种连接方式,其建立成功连接需要的必要数据结构,曾经记得有次面试

    遇到了有关网络的面试题,有可能面试官懂点网络基础,想来虐虐我,最后没想到我从头讲到尾,但遗憾的是我还是未被录取。在下面的几篇文章中,我大致会给大家介绍下网络分布拓扑和

    网络安全知识和数据加解密的有关知识,但只限于作为程序员来讲方面的知识。欢迎阅读。

    转载请标明出处: http://blog.csdn.net/sk719887916/article/details/46773109 作者:skay 


       

       



    展开全文
  • 【计算机网络】-网络层-网络互联 互联将多个不同的网络合并成一个更大的网络,多种不同网络长期存在,需要网络互联 网络的不同之处 网络层上可能出现一些差异,不同网络差异可能很大,从而使互联网络变得复杂 当一...
  • virtrualbox网络互联配置

    万次阅读 2019-02-13 22:24:07
    这里采用的是桥接模式,实现主机和虚拟机的网络互联 1、查看宿主机网络 正常是windows, 这里记下默认网关、子网掩码 2、设置虚拟机网络 3、启动虚拟机修改网络 vi /etc/sysconfig/network-scripts/ifcfg-**** ...
  • 网络互联与路由选择

    2019-12-02 08:50:29
    网络互联与路由选择
  • 计算机网络互联

    2008-05-09 12:43:45
    网络互联(第二版) china pub china-pub
  • 网络互联和路由原理

    2019-05-12 11:52:44
    网络互联 网络互联通常是指交换机和路由器之间的互联,因为交换机和交换机互联存在三方面的不足:1、广播风暴,2、网络互联,3、网络安全。所以通常需要添加路由器,以有效的放置上述三种问题。路由器根据IP地址来...
  • 网络互联概述 网际协议(IP) IP 地址 IP 路由 IP 中的其他协议 IPv6 协议 一、网络互联概述 要让分布在世界各地,不同类型、不同协议的网络相互连接起来,并且能流畅、高效地实现信息共享,就必须依靠网络互联技术...
  • VirtualBox 使用心得——文件互联和网络互联前言VirtualBox 虚拟机和主机的网络互联VirtualBox 虚拟机和主机的文件互联Step1. 安装增强插件Step2. 选择需要共享的文件夹Step3. 修改权限总结 前言 VirtualBox 是一个...
  • 网络互联的本质

    2020-06-24 09:51:44
    怎么能网络互联 A设备发出的电信号,发出到一个唯一B地址,只有B设备能顺利接受并识别,就是互联了。 所以说tcp/ip为什么牛逼,就因为当时几个人定的东西,用了几十年,居然还很好用,物理层、链路层、网络层、传输...
  • 1. 网络层概述网络的互联问题大规模的计算机网络一般采用分层组网技术,即网络互联。原因: 避免大规模网络交换机寻址的复杂性; 解决不同物理网络(异构网络)的兼容性。 Internet网络层采用IP协议,其核心就是...
  • 第五章网络互联技术

    2020-07-10 23:32:39
    网络互联技术 一. 网络互联概述 网络互联技术是所有能在物理和逻辑上实现不同网络相互连接技术的总称,对应ISO/OSI模型的各个层次 互联 包括不同网络之间在功能和应用上看起来像一个完整的网络 自由顺畅的运行 ...
  • 模块一 网络互联基础IP网络基础TCPIP基础IP编址与路由传输层协议 IP网络基础 1.数据通信系统由哪几部分组成? 2.网络通常被分为哪几类? 3.有哪些常见的标准化组织? 4.典型的IP网络可分为哪几部分? TCPIP基础 ...
  • 详细介绍网络互联层的原理:网络互连层(Internetwork Layer)对应到TCP/IP协议有网际协议(Internet Protocol,IP)、因 特网控制消息协议(Internet Control Message Protocol,ICMP)、地址解析协议(Address ...
  • 引言 到现在为止,我们一直隐含着假设所讨论的网络是一个同质网络,即每台机器在每一层使用相同的协议。...在下面的章节中,我们将详细讨论当两个或者多个网络连接起来形成网络互联或简单的互联网时所涉及的一些...
  • 网络互联技术》实验手册(最终版2010.11.29)
  • CCNA 第一章 网络互联

    2018-03-24 16:49:00
    CCNA 第一章 网络互联 1: 网络互联基础  互联网络定义:使用路由器将多个网络连接起来,并配置IP或者IPV6协议的逻辑网络编址方案,便组成了互联网络。  导致LAN(局域网)拥塞的常见原因:  (1...
  • 网络互联设备

    2008-05-13 14:46:00
    网络互联设备 网络互联通常是指将不同的网络或相同的网络用互联设备连接在一起而形成一个范围更大的网络,也可以是为增加网络性能和易于管理而将一个原来很大的网络划分为几个子网或网段。 对局域网而言,所涉及的...
  • IP和网络互联

    2015-10-20 22:49:00
    IP和网络互联 IP网络互连机制: IP地址分类方法及原因: CIDR地址(无分类地址): IP分组首部格式: 数据分片方法: IP分组传输思路: 转载于:...
  • 无交换机实现集群网络互联

    千次阅读 2017-01-04 23:28:08
    分布式集群中对于高性能网络的需求日益增强,尤其是存储集群,对于数据交换的网络带宽、延迟等要求更高。而对于超小规模集群(三节点、四节点等),万兆交换机...这里对无交换机实现集群网络互联进行了一些简单的探索。
  • 网络互联设备对比

    千次阅读 2013-02-20 11:09:55
    网络互联设备,转发器、集线器、网桥、交换机、路由器和网关 转发器、集线器、网桥、交换机、路由器和网关都是网络互连设备。    转发器(Repeater)又被称为中继器或放大器,执行物理层协议,负责第一层...
  • 网络互联参考模型

    2015-03-15 14:43:53
    网络互联参考模型 1. 什么是协议   为了使数据可以在网络上从源传递到目的地,网络上所有设备需要“讲”相同的“语言” 描述网络通信中“语言”规范的一组规则就是协议 例如:两个人交谈,必须使用相同的语言...
  • 网络互联与互联网知识点笔记(一)1.网络互联设备(一)2.网络互联设备(二)3.因特网协议IP4.控制报文协议ICMP 1.网络互联设备(一) 常用网络互联设备: 1层物理层:中继器、集线器 2层链路层:网桥、交换机 3层...
  • 第五章 网络互联技术

    2019-09-26 00:43:26
    网络互连与网络互联 IP概述 IPv4协议报文格式 IP地址  分类的IP地址  子网划分  无分类编址 CIDR IP路由的结构及功能 路由表与路由表转发 路由算法 路由协议 地址解析协议(ARP) 动态主机配置协议...
  • 网络互联参考模型(详解)

    万次阅读 多人点赞 2012-02-10 19:22:40
    网络互联参考模型 1. 什么是协议 为了使数据可以在网络上从源传递到目的地,网络上所有设备需要“讲”相同的“语言” 描述网络通信中“语言”规范的一组规则就是协议 例如:两个人交谈,必须使用相同的语言,如果...
  • 网络互联复习(二) 精简版

    千次阅读 多人点赞 2019-12-16 19:41:00
    网络互联复习(二) 精简版 常规配置 配置路由器主机名 禁用 DNS 查找 配置执行模式口令 配置当天消息标题 为控制台连接配置口令 为 VTY 连接配置口令 配置命令为: enable configure terminal hostname Branch no ip...

空空如也

1 2 3 4 5 ... 20
收藏数 17,744
精华内容 7,097
关键字:

网络互联