精华内容
下载资源
问答
  • sql 日志冗余备份

    2013-04-12 15:48:22
    sql 日志冗余备份
  • 局域网冗余备份技术

    2020-03-17 20:07:39
    局域网冗余备份 冗余备份 链路捆绑 理解并掌握 单星形 容易单点故障 接入和核心 交换机 链路故障和设备故障 经过核心交换机 故障 引擎故障 电源故障等 引擎冗余 电源冗余 设备冗余 链路冗余避免单链路故障 引擎冗余 ...

    局域网冗余备份
    冗余备份 链路捆绑
    理解并掌握
    单星形 容易单点故障 接入和核心 交换机
    链路故障和设备故障 经过核心交换机 故障 引擎故障 电源故障等
    引擎冗余 电源冗余 设备冗余
    链路冗余避免单链路故障
    引擎冗余 设备启动后 一块工作 另一块备份 保存配置时 两块引擎 50毫秒内 切换接替
    设备电源模块 供电 双电路方式 采购时 注意 耗电量 决定电源的过滤 避免某些板卡不可用
    设备荣誉
    冷备份 一般冷备份 在线冷备份 备份设备 不参与业务 策略技术没有把流量引入
    热备份 平滑接替
    故障恢复时间短 不需要人为参与 自动接替
    数据应用冗余备份 网络里面的 互联网公司 腾讯 用户的账户信息 小型和 应用集群 存储设备
    动态滑接 镜像存储 普通数据 操作系统 应用 导致业务中断 应用中断时体现作用
    记录 数据丢失 快照进行数据恢复
    冗余备份技术选择
    业务可靠性要求
    使用一种或多种双引擎单设备 多链路捆绑
    数据可靠性要求 核心设备 容灾能力
    成本 网络维护人员技术水平 复杂出现故障之后如何恢复

    以太网链路捆绑
    贷款需求增长
    增加两台设备的可用带宽
    数据通道 更高带宽的 端口类型
    万兆 交换机
    低水平的设备进行端口链路捆绑 以太网通道 链路带宽倍增
    既能增加带宽 又能提高冗余能力
    速率/双工:所有捆绑的接口都应具有相同的速率和双工模式
    access链路:所有捆绑的链路必须在同一vlan
    trunk:封装模式,vlan nativevlan必须一样
    报文过滤 qos必须一样
    Ether Channel 2层接口捆绑
    Ether Channel 3层链路捆绑 可以直接炮IP流量
    使用
    拓扑图 终端 接入 汇聚 核心 运行 动态路由协议
    路由方式 收敛 三层链路 捆绑

    以太通道配置
    EC
    手动链路捆绑
    两边不需要链路捆绑协议的协商,直接进行捆绑
    interface range fastehernet 0/1-2
    switch mode trunk
    switch trunk allowed vlan all
    channel-group 2 mode on

    interface range fastehernet 0/1-2
    switch mode trunk
    switch trunk allowed vlan all
    channel-group mode on

    PAGP 端口聚合 思科私有
    auto 主动要求对方
    desirable
    两边主动 可以
    一边主动 一边期望 可以
    两边期望 不可以
    interface range fastehernet 0/1-2
    switch mode trunk
    switch trunk allowed vlan all
    channel-group 2 mode desirable
    interface range fastehernet 0/1-2
    switch mode trunk
    switch trunk allowed vlan all
    channel-group 2 mode desirable

    LACP 链路聚合 IEEE共有标准
    思科产品 和 其他厂商 滑接
    passive
    active
    interface range fastehernet 0/1-2
    switch mode trunk
    switch trunk allowed vlan all
    channel-group 2 mode active
    interface range fastehernet 0/1-2
    switch mode trunk
    switch trunk allowed vlan all
    channel-group 2 mode active

    三层链路捆绑
    interface range fastehernet 0/1-2
    no switchport
    channel-group 5 mode on
    interface port-channel 5
    ip address 10.1.1.1 255.255.255.252 //IP 配载逻辑端口 三层IP对接

    show etherchannel summary
    group port-channel protocol

    以太网通道负载均衡
    基于目标IP或MAC的负载均衡 某一条链路比较雍塞 串行
    基于源IP或MAC的负载均衡 相同的原 一个设备发送的 链路分离 并行 两个不同的实现 轮询
    默认基于源MAC
    Ether channel
    Switch(config)#prot-channel load-balance ?
    Switch#show ehterchannel load-balance

    局域网网关冗余应用
    局域网默认网关缺陷
    网关作为网络边界
    两台互为备份 更换网关
    早期解决方案
    静态配置默认网关 手动或通过DHCP为主机配置一个默认网关
    代理ARP 三层设备收到ARP请求 以自身MAC地址作为最终解析的地址 300s
    存在大量的ARP报文 不利于网段子网IP规划

    PC启用 动态路由协议 rip 三层设备 路由发送 为PC 构成 路由表 交换机
    消耗占用PC处理资源 占用链路带宽

    主流方案
    HSRP 思科私有
    热备份路由协议
    使用一组设备沟通提供网关服务 保证业务不间断
    HSRP 组
    一组参与HSRP的路由器
    HSRP组中角色
    虚拟路由器 拟化出来的
    活跃路由器 组中真正用来处理数据的设备 最终 由活跃路由器
    备份路由器 活跃路由器的替代 网关从来不变
    其他路由器 多个设备路由器共同组成 一般用两个设备
    HSRP角色选取 比较优先级 端口指定的权值 0-255 默认100 0表示不参与选举 大优
    IP地址越大越优先
    注意事项 同一个HSRP组必须在同一个广播域 hello组播地址224.0.0.2
    同一个HSRP成员必须在同一个子网
    工作原理 MAC地址 计算生成 一个设备上面可以有多个编号 备份路由器不作回应
    活跃路由器回应

    HSRP的消息类型
    底层协议 UDP:1985 非面向连接 尽力而为 不可靠
    无法知道对方的状态 协议本身需要可靠保证
    HSRP是上层协议 由底层提供
    报文
    hello消息 选举不同设备角色 判断对方状态 3S interval 10S hold time
    政变消息:coup 备份路由器 变为活跃路由器 发送一个coup
    辞职消息 当活跃路由器要宕机或者当有优先级更高的路由器发送hello消息时,活跃路由器发送一个resign
    HSRP状态
    initial 第一次启用
    learn 不知道虚拟IP地址,等待活跃路由器发送过来的Hello消息
    listen 路由器知道了虚拟IP地址但还不是活跃路由器额备份路由器,同时监听hello消息
    speak 周期发送hello消息,并积极参与活跃路由器和备份路由器选举
    standby 备用状态 该路由器是下一个活跃路由器的候选设备,并周期发送hello消息
    active 路由器负责转发到HSRP组的虚拟MAC地址的数据包,并周期发送hello消息
    HSRP消息详细格式
    Op编码
    状态 设备 hello实践
    HSRP配置和命令
    一、进接口模式配置路由器为HSRP的成员
    Switch(config-if)#standby 10 ip ?//同vlan号,便于区分;虚拟IP address第一个地址
    Switch(config-if)#standby 10 priority ?//优先级
    Switch(config-if)#standby 10 preempt //开启抢占,活跃设备故障,备份设备顶上 恢复也不重新顶上
    Switch(config-if)#standby 10 timers ? //更改hello time 计时器
    查看
    Switch#show standby brief

    案例 HSRP负载均衡配置案例
    组 1 和组2 的 活跃路由器和 备份路由器分离
    4个vlan
    PC1 10
    PC2 20
    PC3 30
    PC4 40
    三层交换机
    规范定义
    SW1配置命令
    SW1(config)#interface vlan 10
    SW1(config-if)#ip address 192.168.10.1 255.255.255.0
    SW1(config-if)#standby 10 ip 192.168.10.254
    SW1(config-if)#standby 10 priority 200
    SW1(config-if)#standby 10 preempt

    SW1(config)#interface vlan 20
    SW1(config-if)#ip address 192.168.20.1 255.255.255.0
    SW1(config-if)#standby 20 ip 192.168.20.254
    SW1(config-if)#standby 20 priority 200
    SW1(config-if)#standby 20 preempt

    SW1(config)#interface vlan 30
    SW1(config-if)#ip address 192.168.30.1 255.255.255.0
    SW1(config-if)#standby 30 ip 192.168.30.254
    SW1(config)#interface vlan 40
    SW1(config-if)#ip address 192.168.40.1 255.255.255.0
    SW1(config-if)#standby 40 ip 192.168.40.254

    SW2配置命令
    SW2(config)#interface vlan 30
    SW2(config-if)#ip address 192.168.30.2 255.255.255.0
    SW2(config-if)#standby 30 ip 192.168.30.254
    SW2(config-if)#standby 30 priority 200
    SW2(config-if)#standby 30 preempt

    SW2(config)#interface vlan 40
    SW2(config-if)#ip address 192.168.40.2 255.255.255.0
    SW2(config-if)#standby 40 ip 192.168.40.254
    SW2(config-if)#standby 40 priority 200
    SW2(config-if)#standby 40 preempt

    SW2(config)#interface vlan 10
    SW2(config-if)#ip address 192.168.10.2 255.255.255.0
    SW2(config-if)#standby 10 ip 192.168.10.254
    SW2(config)#interface vlan 20
    SW2(config-if)#ip address 192.168.20.2 255.255.255.0
    SW2(config-if)#standby 20 ip 192.168.20.254
    show standby brief 查看HSRP的状态

    HSRP的端口跟踪技术
    HSRP负载分担
    交换机接口坏了而非设备本身坏了
    角色 被动机制 收到对方的
    需要设置端口跟踪 自我惩罚
    启用HSRP端口跟踪
    基于被跟踪端口的可用性而自动进行调整
    如果端口变为不可用 自我惩罚
    规定时间 自我惩罚 阀值范围 自我惩罚 减少
    恢复之后 可以再抢占回来
    设置
    SW1(config)#interface vlan 10
    SW1(config-if)#ip address 192.168.10.1 255.255.255.0
    SW1(config-if)#standby 10 ip 192.168.10.254
    SW1(config-if)#standby 10 priority 200
    SW1(config-if)#standby 10 preempt
    SW1(config-if)#standby 10 track fastEthernet 0/1 110

    SW2(config)#interface vlan 10
    SW2(config-if)#ip address 192.168.10.2 255.255.255.0
    SW2(config-if)#standby 10 ip 192.168.10.254
    SW2(config-if)#standby 10 preempt

    VRRP协议概述
    虚拟路由冗余协议 IEEE公有标准
    多厂商设备环境 避免出现兼容性问题
    IP报文 作为传输协议 进行 协议报文的传送
    传输效率更高 不可靠的协议
    被动等待计时器 认为失效
    协议号 112 访问控制列表 过滤 HSRP 1985端口 , 过滤 VRRP 过滤协议号112
    只有通告报文
    1S
    hold time 3S 切换更快 网络拥塞 可能导致设备误判
    地址 0.0.0.2
    initialize
    master 类似于 active
    backup 类似于standby
    交互通告报文
    VRRP选择原则 优先级越大越优先 IP地址越大越优先
    虚拟网关可以使用实际的接口 但实际指定
    R1(config)#interface FastEthernet0/1.10
    R1(config-if)#ip address 192.168.8.1 255.255.255.0
    R1(config-if)#encapsulation dot1Q 10
    R1(config-if)#vrrp 1 ip 192.168.8.254
    R1(config-if)#vrrp 1 preempt
    R1(config-if)#vrrp 1 priority 200
    R1(config-if)#vrrp 1 track 1 decrement 120
    R1(config-if)#vrrp 1 interface FastEthernet0/2 line-protocol

    R2(config)#interface FastEthernet0/1.10
    R2(config-if)#ip address 192.168.8.2 255.255.255.0
    R2(config-if)#encapsulation dot1Q 10
    R2(config-if)#vrrp 1 ip 192.168.8.254
    R2(config-if)#vrrp 1 preempt

    查看 show vrrp brief

    STP与HSRP结合案例分析

    展开全文
  • 一、运营商出口负载均衡同时冗余备份 电信、移动、联通、广电线路出口冗余备份,根据IP地址规划,选择合适的网络出口,保持数据来回路径一致,出口设备有IP划分地址池进行数据来源匹配,保持从哪个口入就从哪个口出...

    一、运营商出口负载均衡同时冗余备份

          电信、移动、联通、广电线路出口冗余备份,根据IP地址规划,选择合适的网络出口,保持数据来回路径一致,出口设备有IP划分地址池进行数据来源匹配,保持从哪个口入就从哪个口出的措施。

    二、网络冗余备份

       保持局域网有冗余备份线路,包括以下技术:

    1. HSRP/VRRP路由冗余技术

           热备份路由器协议(HSRP)的设计目标是支持特定情况下 IP 流量失败转移不会引起混乱、并允许主机使用单路由器,以及即使在实际第一跳路由器使用失败的情形下仍能维护路由器间的连通性。

    虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议

       2、VGMP(VRRP组管理协议)/HRP(双机热备协议)

           VGMP(VRRP Group Management Protocol)协议是华为公司的私有协议。VGMP协议中定义了VGMP组,设备基于VGMP组实现设备主备状态管理。

           HRP协议是承载在VGMP(Vrrp Group Management Protocol)报文上进行传输的,在Master和Backup防火墙设备之间备份关键配置命令和会话表状态信息,是双机热备协议。

    三、网络设备链路聚合

          同一设备链路聚合Eth-Trunk

          跨设备链路聚合E-Trunk

         端口聚合以太通道(ethernet channel)

         IRF技术就是“硬件虚拟化技术”

         交换机CSS集群

        思科:VSS (Virtual Switching Supervisor) 

        华三:IRF (Intelligent Resilient Framework2) 

        华为:CSS (Cluster Switch System) 

        锐捷:VSU (Virtual Switching Unit)

    四、应用负载均衡(Load Balance)

          将负载(工作任务)进行平衡、分摊到多个操作单元上进行运行

    软负载:DNS Load Balance,CheckPoint Firewall-1 ConnectControl;apache(跨平台的网页服务器)、ngnix(高性能的 HTTP和反向代理服务器)、lvs(linux虚拟服务器)、HAProxy(基于TCP和HTTP应用的代理)、keepalived(web服务器的高可用(HA high availably))、memcached(分布式内存对象缓存系统)、terracotta(Java集群平台);

    硬负载:F5负载均衡器、Radware、A10、深信服、信诺瑞得、PIOLINK、网域、弘积、冰川、迪普科技等;

    五、磁盘冗余备份(RAID)

        相同的数据存储在多个硬盘的不同的地方,RAID0、RAID1、RAID5、RAID10等

    80493018251b552c7f275ae582a6abb6.png

    351f51219c195f5eb7a36186e0e6f12c.png

    六、网卡冗余备份bond模式

    网卡绑定mode共有七种(0~6) bond0、bond1、bond2、bond3、bond4、bond5、bond6;

    常用三种:

    mode=0:平衡负载模式,有自动备援,但需要”Switch”支援及设定。

    mode=1:自动备援模式,其中一条线若断线,其他线路将会自动备援。

    mode=6:平衡负载模式,有自动备援,不必”Switch”支援及设定。

    七、数据中心级冗余备份

          两地三中心

    1、 同城容灾

    同城容灾 是在同城或相近区域内 ( ≤ 200K M )建立两个数据中心 : 一个为数据中心,负责日常生产运行 ; 另一个为灾难备份中心,负责在灾难发生后的应用系统运行。同城灾难备份的数据中心与灾难备份中心的距离比较近,通信线路质量较好,比较容易实现数据的同步 复制 ,保证高度的数据完整性和数据零丢失。同城灾难备份一般用于防范火灾、建筑物破坏、供电故障、计算机系统及人为破坏引起的灾难。

    2、 异地容灾

    异地容灾 主备中心之间的距离较远 (> 200KM ) , 因此一般采用异步镜像,会有少量的数据丢失。异地灾难备份不仅可以防范火灾、建筑物破坏等可能遇到的风险隐患,还能够防范战争、地震、水灾等风险。由于同城灾难备份和异地灾难备份各有所长,为达到最理想的防灾效果,数据中心应考虑采用同城和异地各建立一个灾难备份中心的方式解决。

    89313e4f5fb0982f2032a166e7de841d.png

    展开全文
  • windows文件服务器冗余备份方案
  • 南京电信政企客户支撑中心综合考虑客户接入设备层次、网络管理水平和客户需求等因素,以公司推进的维护服务产品化工作为契机,创新性地提出基于路由交换技术的静态专线宽带冗余备份方法,并及时在省市级重点保障大...
  • 802.3ad冗余备份测试

    2018-02-08 22:56:33
    计算机网络 实验四 802.3ad冗余备份测试 (包括截图和说明)
  • 1:n的冗余备份Backups and redundancy schemes are both data protection methods, but they are not interchangeable. Join us as we explore what makes them different, and why that’s important to you. 备份...
    1:n的冗余备份

    1:n的冗余备份

    Backups and redundancy schemes are both data protection methods, but they are not interchangeable. Join us as we explore what makes them different, and why that’s important to you.

    备份和冗余方案都是数据保护方法,但是它们不可互换。 与我们一起探索我们与众不同的原因,以及为什么这对您很重要。

    Redundancy is a data protection method intended as a real-time fail-safe measure against hard drive failure. A common redundancy feature found in servers and NAS boxes to prevent data loss is RAID (which stands for Redundant Array of Independent Disks), which creates multiple copies of files across several hard drives. If one hard drive in the array fails, the other hard drives pick up the slack with (usually) no interruption. A backup, on the other hand, doesn’t provide real-time protection, but it does provide protection against a greater set of problems, including failed drives, device theft, fire, or even just accidentally deleting files.

    冗余是一种数据保护方法,旨在作为针对硬盘驱动器故障的实时故障保护措施。 服务器和NAS盒中用于防止数据丢失的常见冗余功能是RAID (代表独立磁盘冗余阵列),它可在多个硬盘驱动器上创建文件的多个副本。 如果阵列中的一个硬盘驱动器发生故障,则其他硬盘驱动器会(通常)不间断地吸收松弛。 另一方面,备份不能提供实时保护,但可以提供保护以防止出现更多问题,包括驱动器故障,设备失窃,失火甚至是意外删除文件。

    冗余实际上是为了什么 (What Redundancy Is Actually For)

    In a nutshell, redundant data storage provides a real-time fail-safe against hard drive failure rather than an actual backup of your data. The idea is that the other hard drives in the array can immediately kick in and save the day without any downtime. This type of redundancy is typically used on servers or NAS boxes where the downtime of recovering from a failed hard drive is not an option.

    简而言之,冗余数据存储提供了针对硬盘驱动器故障的实时故障保护,而不是数据的实际备份。 这个想法是阵列中的其他硬盘驱动器可以立即启动并节省一天的时间,而无需任何停机时间。 这种类型的冗余通常用在服务器或NAS盒上,这些服务器或NAS盒无法从故障硬盘中恢复。

    And that right there is really the main purpose of redundant storage: reliability and uptime. If a hard drive fails and there’s no data redundancy in place, it can temporarily take out all of the data until the failed hard drive can get replaced and a backup can be restored.

    正确的做法实际上就是冗余存储的主要目的:可靠性和正常运行时间。 如果硬盘驱动器发生故障并且没有数据冗余,它可以暂时取出所有数据,直到可以更换发生故障的硬盘驱动器并可以恢复备份为止。

    Redundancy isn’t as important for regular consumers like you and me, but it’s critical for businesses that rely on data storage. This is especially true for companies that offer cloud storage or file hosting—any kind of downtime is bad for business.

    冗余对于像您和我这样的普通消费者而言并不那么重要,但是对于依赖数据存储的企业而言,它至关重要。 对于提供云存储或文件托管的公司来说尤其如此,任何类型的停机都对业务不利。

    备份可防止所有类型的数据丢失 (Backups Protect Against All Types of Data Loss)

    There are a lot of ways you can lose data: accidental deletion, file corruption, drive failure, malware, software bugs, theft, damage, and more. Redundancy only protects against drive failure, whereas a true backup protects against every one of these factors (or at least most of them).

    丢失数据的方式有很多:意外删除,文件损坏,驱动器故障,恶意软件,软件错误,盗窃,损坏等。 冗余只能防止驱动器发生故障,而真正的备份可以防止这些因素中的每一个(或至少其中大多数)。

    Let’s take accidental file deletion as an example. If you accidentally delete a file, redundancy won’t save you, since the redundant copy of the file in the RAID setup also gets deleted.

    让我们以意外删除文件为例。 如果您不小心删除了文件,冗余将无法保存您,因为RAID设置中文件的冗余副本也会被删除。

    The backup, though, would have that accidentally-deleted file still intact on a completely separate, independent storage medium. This is why you should always back up even your NAS, even if it’s already set up for RAID.

    但是,备份将在完全独立的独立存储介质上保留意外删除的文件的完整性。 因此,即使已为RAID设置NAS ,也应始终备份

    您应该如何备份数据 (How You Should Back Up Your Data)

    If you regularly back up all the files on your computer to a separate hard drive and call it a day, that’s great, but it’s only a start. The truth is, you may not be doing as good of a job as you could be when it comes to backing up your data.

    如果您有规律地将计算机上的所有文件备份到单独的硬盘驱动器上,并且每天都将其命名,那很好,但这只是一个开始。 事实是,在备份数据时,您可能做得不尽如人意。

    Ideally, you want to have both a local backup of your data and a backup stored at an offsite location. The local backup is there to keep you protected against things like accidental file deletion and hard drive failure. Having an immediately accessible backup means restoring is that much faster.

    理想情况下,您既要对数据进行本地备份,又要在异地存储备份。 本地备份可确保您免受意外文件删除和硬盘驱动器故障的伤害。 拥有可立即访问的备份意味着还原要快得多。

    But, what if your computer and your local backup drive are stolen? What if your home is hit by natural disaster? That offsite backup means that after you replace your computer, you can still restore all your data. Having that second copy of your backup also means you’re better protected in case one of those backups fails.

    但是,如果您的计算机和本地备份驱动器被盗怎么办? 如果您的家遭受自然灾害怎么办? 异地备份意味着更换计算机后,您仍然可以还原所有数据。 拥有备份的第二个副本还意味着在其中一个备份失败的情况下,可以更好地保护您。

    On top of having multiple backups, it’s important that you store them not only in completely separate locations, but that you store them in safe locations. For example, you could store one in a safe deposit box at your local bank and the second one in your own safe at home. Or you could even have one of your backup methods be to the cloud, which instantly takes care of the separate and safe location.

    除了具有多个备份外,重要的是不仅将它们存储在完全独立的位置,而且还要将它们存储在安全的位置。 例如,您可以将一个存放在本地银行的保险箱中,将另一个存放在自己家里的保险箱中。 或者,您甚至可以将其中一种备份方法存储到云中,从而立即处理单独且安全的位置。

    In the end, if all you do is plug in an external hard drive and sync files to it whenever you remember to do so, that’s better than nothing. Hell, if they’re not super important files or anything, then sure, what’s the problem, right? But you likely have some data on your computer that you’d be devastated over if you completely lost it. So do yourself a favor and do your backup due diligence!

    最后,如果您要做的就是插入外部硬盘驱动器,并在您记得这样做时将文件同步到它,那总比没有好。 地狱,如果它们不是超重要的文件或其他任何东西,那么可以肯定,这是什么问题,对吗? 但是,如果您完全丢失了计算机上的某些数据,则可能会遭受破坏。 因此,请您帮个忙,并做好备份尽职调查!

    翻译自: https://www.howtogeek.com/346907/backups-vs.-redundancy-what’s-the-difference/

    1:n的冗余备份

    展开全文
  • IMC服务器冗余备份方案,有需要的可以下
  • sql server 2000双机冗余备份

    热门讨论 2011-06-06 03:13:34
    sql server 2000双机冗余备份,主要是sql2000的双机相互备份,自动切换
  • 实验报告格式 班 级 姓 名 学 号 实验日期 评 分_ 实验名称 端口聚合提供冗余备份链路 实验学时 2学时 实验类型 验证型 实验目的 理解链路聚合的配置及原理 实验内容 增加交换机之间的传输带宽并实现链路冗余备份 ...
  • VxWorks环境下双网卡冗余备份技术的实现.pdf
  • 冗余备份链路,设计,配置,思路,非常详细,适合学习
  • 网络冗余备份之浮动路由

    千次阅读 2019-01-14 22:44:54
    网络冗余备份之浮动路由与VRRP技术备份 1.浮动路由 欢迎使用Markdown编辑器 你好! 这是你第一次使用 Markdown编辑器 所展示的欢迎页。如果你想学习如何使用Markdown编辑器, 可以仔细阅读这篇文章,了解一下Markdown...

    浮动路由

    什么是浮动路由,为什么要配置它,它有什么作用???

    1.单一路由的局限性

    • 只有唯一“”最佳“”路径
    • 存在单点风险,一旦中断直接无法通信
      在这里插入图片描述

    2. 浮动路由定义与特点

    • 配置一个优先级低的静态路由,作为应对突发情况的备份路径
    • 在主路由正常运作的情况下,浮动路由不会出现在路由表中

    3.配置浮动路由

    注意:由于路由接口较少,一旦出现IP地址无法输入的现象,建议给路由进行接口配置,列如下:

    在这里插入图片描述
    配置方法:在此AR配置界面先关闭设备(红色开关),然后选择左下方适合的eNSP支持的接口卡,托引到设备中。然后重启路由器以及外面的拓扑图。

    4.拓扑图配置命令

    配置思路:
    1.配置终端
    PC-1/2(X 为 1-2号)
    ip : 192.168.x.1
    mask : 255.255.255.0
    gaetway : 192.168.x.254
    2.配置网络设备:

    配置路由器AR1
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip address 192.168.2.1 24
    [R1-GigabitEthernet0/0/1]int g2/0/0
    [R1-GigabitEthernet2/0/0]ip address 192.168.3.1 24
    [R1-GigabitEthernet2/0/0]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24
    [R1-GigabitEthernet0/0/0]q
    [R1]ip route-static 192.168.4.0 24 192.168.2.2
    [R1]ip route-static 192.168.4.0 24 192.168.3.2 preference 100

    配置路由器AR2
    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 192.168.2.2 24
    [R2-GigabitEthernet0/0/1]int g2/0/0
    [R2-GigabitEthernet2/0/0]ip address 192.168.3.2 24
    [R2-GigabitEthernet2/0/0]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.4.254 24
    [R2-GigabitEthernet0/0/0]q
    [R2]ip route-static 192.168.1.0 24 192.168.2.1
    [R2]ip route-static 192.168.1.0 24 192.168.3.1 preference 100

    3.验证实验结果
    用PC1 ping PC2
    在这里插入图片描述
    PC1 能与PC2正常通信,由此得出,整个链路正常通信。
    然后断开链路中连个路由器之间 192.168.2.0 网段的线路,
    在这里插入图片描述
    再ping下
    在这里插入图片描述
    PC1与PC2仍能正常通信。

    5.实验结论:浮动路由在不影响链路正常通信的情况下,能很好的为整个网络通信提供一份安全保障。

    展开全文
  • Keepalived冗余备份 服务器仍是可以进行冗余备份操作的,且,负载均衡和冗余备份在现实生活中就像是亲兄弟一样被绑定在一起的。 它的原理是,使用两台调度器做服务器,通过虚拟ip地址作为代理,当任何一条线的网络...
  • 解决设备冗余备份之proxy arp hsrp vrrp glrp
  • 8.2.3ad 冗余备份测试 链路聚合原理 实验步骤及总结均包含在内
  • Cloudundancy是跨平台的C ++命令行程序,用于将文件和文件夹的可配置列表快速复制到目标文件夹的可配置列表,以实现文件的云冗余和设备冗余备份。 例如,在Cloudundancy.ini文件中,可以将目标文件夹配置为自动云...
  • 基于SDN的冗余备份型虚拟网络映射算法 ,刘通,卢美莲,在网络虚拟化中,虚拟网络映射已经变成一个热门话题。现有的虚拟网络映射算法只需负责完成对虚拟网络的映射过程,无需考虑向虚拟
  • Centos 7 冗余备份磁盘配置介绍我们上一盘介绍了Centos 7 磁盘阵列配置介绍,今天继续上一篇的配置介绍,通过上一篇的配置介绍我们发现了一个问题。,运维人员需要在硬盘硬件出现故障后,手动增加新的硬盘进去,这样...
  • 本示例的基本拓扑结构如图所示. HostA通过Switch 双线... RouterB 接替作为网关继续进行工作, 实现网关的冗余备份; RouterA故障恢复后, 可以在20 s 内重新成为网关(即抢占延时为20 s) 。 1. 基本配置思路分析 ...
  • 4 配置端口聚合提供冗余备份链路

    千次阅读 2020-02-20 22:16:45
    配置端口聚合提供冗余备份链路 网络拓扑图如图所示 1 交换机S24的基本配置 配置 查看 2 在交换机S24上配置聚合端口 配置 查看 3 交换机S213的基本配置 配置 查看 4 在交换机S213上配置聚合端口 配置 查看 5 ...
  • DB2删除冗余备份

    2012-02-06 23:13:06
    DB2删除冗余备份 今天太晚了,不想写了,明后天看有时间好好写写 转载于:https://blog.51cto.com/freebile/773620
  • cisco 3750G 冗余备份

    2014-12-01 14:01:44
    cisco 3750G 冗余备份  分类: 网络与安全 目标: 通过3750堆叠或者HSRP,实现IDC11机房的网关冗余。 现状: 现在idc11 的网关为单独的一台cisco 3750G交换机,一旦物理设备出现问题,整个网络将面临...
  • Cisco 冗余备份(IRDP)

    千次阅读 2012-04-25 23:06:16
    冗余备份特性 能够提供冗余备份的机制: 1. IRDP,ICMP Router Discovery Protocol(ICMP路由发现协议) 2. HSRP,Hot Standby Router Potocol(热备份路由协议) 3. VRRP,Virtual Router Redundancy Potocol...
  • 多生成树协议,冗余备份,负载均衡 实验拓扑: Version:1.0 StartHTML:000000202 EndHTML:000020761 StartFragment:000002241 EndFragment:000020693 StartSelection:000002241 EndSelection:000020687 ...
  • 服务器作为企业信息平台... 本文将以单机和集群两种环境来解说相关冗余备份的实现原理与过程。 单机环境 下图为服务器双网卡接入的基本拓扑图,为保证网络设备热备份,核心设备、服务器接入设备都使用了双机,配...
  • 工作准备 环境准备 开发板需要有双网卡,并能进行正常通信。 若选择中断机制实现,硬件PHY上需具有中断引脚且能正常输出。 原理概述 双网卡冗余备份方案采用&...双网卡冗余备份方案采用轮询机制检测,即每隔一段时间
  • 文中利用随机 Petri 网对 n+k 形式冗余备份通信系统进行了综合分析 分析过程充分考虑了系统的动 态变化和工程中的实际情况 建模过程简单直观而且通过 PIPE 软件的仿真 得出了通信系统可靠性评价的一系列结果 该方法...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 77,921
精华内容 31,168
关键字:

冗余备份