单臂路由 订阅
单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。在Cisco网络认证体系中,单臂路由是一个重要的学习知识点。通过单臂路由的学习,能够深入的了解VLAN(虚拟局域网)的划分、封装和通信原理,理解路由器子接口、ISL协议和802.1Q协议,是CCNA考试中经常考的。 展开全文
单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。在Cisco网络认证体系中,单臂路由是一个重要的学习知识点。通过单臂路由的学习,能够深入的了解VLAN(虚拟局域网)的划分、封装和通信原理,理解路由器子接口、ISL协议和802.1Q协议,是CCNA考试中经常考的。
信息
缺    点
容易成为网络单点故障
优    点
实现不同vlan之间的通信
外文名
Single arm routing
中文名
单臂路由
性    质
在路由器的一个接口上配置子接口
目    的
实现原来不同VLAN之间的互联互通
单臂路由单臂路由的子接口
路由器的物理接口可以被划分成多个逻辑接口,这些被划分后的逻辑接口被形象的称为子接口。值得注意的是这些逻辑子接口不能被单独的开启或关闭,也就是说,当物理接口被开启或关闭时,所有的该接口的子接口也随之被开启或关闭。
收起全文
精华内容
下载资源
问答
  • 华为单臂路由配置

    2021-01-09 10:05:57
    拓扑图如下:   SW-1配置命令如下: system-view //进系统视图 [Huawei]sysname SW-1 //修改主机名 [SW-1]vlan batch 10 20 //创建vlan 10 20 [SW-1]interface e0/0/1 //进接口 [SW-1-Ethernet0/0/1]port link-...
  • 单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应一个vlan。在每个子接口的数据在物理链路上传递都要标记封装。Cisco设备支持ISL和802.1q(dot1Q)协议。华为只支持802.1q
  • 华三静态路由、单臂路由以及动态路由(RIP)配置实验报告,给出了详细的网络拓扑图,实验过程就截图、实验结果和实验分析心得。
  • 这是一个基于eNSP的 单臂路由+OSPF路由协议已经配置好了的拓扑图,可以直接进行通信,里面含有各个设备的配置命令。
  • 任务1. 路由器的基本配置 实验目标 掌握路由器几种常用配置方法; 掌握采用Console线缆配置路由器的方法;... 路由器单臂路由配置 实验目标 掌握单臂路由器配置方法; 通过单臂路由器实现不同VLAN之间互相通信;
  • 要求 1.按照拓扑所示,搭建网络环境,进行设备重命名 2.根据pc机给定地址信息,完成各自ip地址、网关地址计算及配置 3.采用RIP协议+静态路由实现pc1、2、3互通
  • 单臂路由实验.docx

    2020-06-23 21:23:55
    单臂路由实验:在路由器上利用子接口实现不同VLAN间的通信 1.划分VLAN,将接口添加到对应VLAN里 2.因为24口与路由器相连,要实现路由器和交换机的通信,把交换机的24口设置为trunk口: 3.在路由器上创建子接口、分配...
  • Cisco单臂路由.pkt

    2020-08-27 11:38:16
    (1) PC0 分别属于VLAN 100;PC9属于VLAN200。 (2) VLAN 100 的网络地址为201.201.... VLAN 200 的网络地址为 202.202....PC10 所在的网段地址为 203.203....PC0的IP地址为201.201....PC9的IP地址为202.202....
  • 单臂路由实验: 目的:实现不同VLAN通过路由器通信 实现方法: 1.在交换机上配置好VLAN,将相应的端口添加到VLAN中 2.交换机和路由器相连接的那个端口,即交换机的上联端口要配置为Trunk 3.在路由器的接口上进入“子...
  • 此文是Mikrotik的产品培训教程,教大家如何使用ROS操作系统实现VLAN互通(单臂路由) 以及如果快速配置Mikrotik的其他参数,实现应用
  • 实验:配置单臂路由 为所以交换机路由器设备配置telnet远程登入 使用Cisco Packet Tracer Student模拟器 此实验所用设备为:一台2811路由器、两台2960交换机+四台2950T交换机以及PC八台
  • ensp 单臂路由 已成功搭建,可运行,配置文件 作业文件,打开之后需要启动里面的交换机
  • 用三层交换机来实现单臂路由,实现不同vlan间的通信,有详细的实验拓扑图和命令
  • 掌握如何路由器端口上划分子接口、封装 Dot1Q(IEEE 802.1Q)协议,实现 VLAN 间的路由
  • 本案例为我教学中的案例,目的是训练路由配置、单臂路由、Vlan划分、静态路由重分发的技术。配置中只进行最简洁的命令内容,同时在文档时也有各个设置的配置指令,方便学习使用
  • 单臂路由

    2021-03-09 21:29:00
    缺点:单臂路由的 “臂”,承载的是不同vlan的双向流量,单臂出现单点故障,对网络影响非常大 单臂链路负载过重,容易出现流量瓶颈,影响通信效率 六、扩展学习 Eth-Trunk 状态下的单臂路由配置: 1.SW交换机设置: ...

    在这里插入图片描述

    一、技术背景

    园区网 划分vlan之后,导致广播域 局域网被隔离--->不同vlan之间不能通信
    	VLAN的划分,按照地理位置、部门、人员属性划分---> 部门
    	VLAN的通信在二层上是被隔离了
    

    针对以上问题有以下方案:
    方案一:在同一台交换机上使用一根线把不同的vlan连接起来
    结果:已经划分好的 减小的广播域 又被扩大了—>不可行

    方案二:用路由器的接口来实现不同vlan所对应的网段之间的通信 —>不可行
    原因:路由器的接口有限,一般来说,企业路由器的接口不会超过10个,运营商级别的路由器存在多个接口

    二、技术的概念 如何实现-----子接口

    1.实现:通过路由器的一个物理接口,虚拟成 多个子接口,并且封装802.1Q
    实现一个接口能够处理不同vlan网段数据的能力

    2.子接口:虚拟的接口、逻辑上存在的接口
    (1)子接口基于物理接口来实现:要实现子接口能够工作,物理接口必须处于up的状态
    (2)子接口是一个逻辑的接口
    (3)子接口可以配置IP地址,需要指定这个接口配置的 vlan id 范围 0-4094
    (4)封装的协议 dot1q(802.1q)—> 具有tag字段的封装
    (5)物理接口不用进行任何的配置,处于up的状态即可
    (6)子接口和它所在的物理接口共享MAC地址

    三、单臂路由的配置

    1.交换机的配置
    (1)正常的划分 网络所需要的vlan
    (2)将接口 access 到相应的vlan下
    (3)将干道接口设置成Trunk并且允许相对应的vlan通过

    2.路由器的配置:
    1.主接口不做任何配置
    2.划分子接口
    (1)interface GigabitEthernet0/0/0.10 # 进入划分的子接口 范围 1-4096
    (2)dot1q termination vid 10 # 在子接口上通过802.1q协议,关联相对应的vlan
    (3)ip address 192.168.10.254 255.255.255.0 # 配置IP地址
    (4)arp broadcast enable # 开启 arp 广播—>让子接口具有接收和回复广播包的功能

    四、单臂路由的通信过程、通信原理

    在这里插入图片描述
    PC1 ping PC2:
    1.PC1 首先要将目标IP网段和自己的IP地址进行与运算,计算出目标IP是否和自己同网段,是否需要跨网段通信,上图为跨网段通信
    2.PC 要封装ICMP数据----封装网关(G0/0/0)目标MAC失败,触发ARP请求报文
    3.ARP广播报文进入 E0/0/1(pvid 10),ARP报文封装一个vlan id = 10的 tag字段
    4.4.ARP 报文经过 G0/0/1接口(pvid=1),ARP 报文依然携带tag字段上到Trunk链路上
    5.ARP请求包 被G0/0/0收到—> G0/0/0需要将这个ARP请求包去掉tag,分配给它的子接口—>G0/0/0.10
    6.当子接口收到ARP请求的时候,查看源目MAC地址, 根据源MAC地址来更新ARP缓存表,继续解读ARP的内容,发现是请求网关的MAC地址的请求包,则G0/0/0.10 对这个ARP的请求报文进行回复
    7.G0/0/0.10 对PC1进行ARP回复 ARP应答包+vlanid=10
    8.ARP 回复包被交换机 G0/0/1 收到
    9.ARP回复包 携带tag字段进入交换机
    10.交换机根据 ARP 回复包携带的tag字段,将这个数据包,查CAM表关于 VLAN10 的表项,发送给 PC1
    11.PC1 收到ARP relay 后,解封装数据链路层,学习源MAC地址,更新到自己的ARP缓存表
    12.PC1 ICMP数据包 ,源MAC为自己,目标MAC为网关
    13.ICMP数据包被E0/0/1接收,打上vlanid为10的tag字段
    14.ICMP 数据包经过G0/0/1 直接通过
    15.ICMP数据包到达G0/0/0,G0/0/0接收,查看tag,去掉tag,将这个数据包丢给了G0/0/0.10 子接口
    16.数据包被路由器收到,路由器根据数据包的目标IP地址,查看自己的路由表,发现目标网段位 20.1 对应的接口为 G0/0/0.20
    17.G0/0/0.20 要把这个数据包发送给 PC2,先要知道PC2的MAC地址,然后G0/0/0.20 发送一个ARP的请求包,请求20.1主机的MAC地址
    18.APR 请求包被PC2收到,PC2做出回复, G0/0/0.20 知道 PC2 的MAC地址
    19.ICMP的数据包 从G0/0/0.20发出, 携带vlanid为20的tag字段
    20.数据包经过交换机的G0/0/1(trunk),携带vlanid为20的tag字段 进入交换机
    21.交换机 查看 和 vlan 20 相关的CAM表,将这个ICMP的请求包 发送给 PC2,在经过E0/0/2的时候,去掉tag
    22.PC2 回复 ICMP数据包

    五、单臂路由的优缺点

    1.优点:实现多vlan通信,解决不同vlan之间通信的问题
    节约路由器的接口

    2.缺点:单臂路由的 “臂”,承载的是不同vlan的双向流量,单臂出现单点故障,对网络影响非常大
    单臂链路负载过重,容易出现流量瓶颈,影响通信效率

    六、扩展学习

    Eth-Trunk 状态下的单臂路由配置:
    在这里插入图片描述

    1.SW交换机设置:

    <Huawei>system-view 
    [Huawei]vlan batch 10 20							#创建VLAN
    [Huawei]int e0/0/1	
    [Huawei-Ethernet0/0/1]port link-type access 		#配置access口
    [Huawei-Ethernet0/0/1]port default vlan 10			#将VLAN10加入接口
    [Huawei-Ethernet0/0/1]undo shutdown
    [Huawei]int e0/0/2
    [Huawei-Ethernet0/0/2]port link-type access			#配置access口
    [Huawei-Ethernet0/0/2]port default vlan 20			#将vlan 20加入接口
    [Huawei-Ethernet0/0/2]undo shutdown 
    Huawei-Ethernet0/0/2]quit	
    [Huawei]int Eth-Trunk 1								#配置Eth-Trunk虚拟接口
    [Huawei-Eth-Trunk1]trunkport g 0/0/1 to 0/0/2		#将两个接口加入此虚拟接口
    [Huawei-Eth-Trunk1]port link-type trunk				#将接口设置为trunk模式
    [Huawei-Eth-Trunk1]port trunk allow-pass vlan all	#允许所有vlan通过
    [Huawei-Eth-Trunk1]undo shutdown
    

    2.路由器设置:

    <Huawei>system-view 	
    [Huawei]sysname R1
    [R1]interface Eth-Trunk 1						#配置Eth-Trunk
    [R1-Eth-Trunk1]trunkport g 0/0/1 to 0/0/2	
    [R1-Eth-Trunk1]quit
    [R1]int Eth-Trunk 1.1							#配置Eth-Trunk子接口
    [R1-Eth-Trunk1.1]dot1q termination vid 10
    [R1-Eth-Trunk1.1]ip address 192.168.10.1 24
    [R1-Eth-Trunk1.1]arp broadcast enable 			#开启ARP广播功能
    [R1-Eth-Trunk1.1]quit
    [R1]interface Eth-Trunk 1.2
    [R1-Eth-Trunk1.2]dot1q termination vid 20
    [R1-Eth-Trunk1.2]ip address 192.168.20.1 24
    [R1-Eth-Trunk1.2]arp broadcast enable 
    [R1-Eth-Trunk1.2]undo shutdown 
    [R1-Eth-Trunk1.2]quit
    

    3.设置PC1、PC2
    配置PC1,PC2IP地址,子网掩码以及网关

    PC1:
    在这里插入图片描述

    PC2:
    在这里插入图片描述

    4.PC1ping PC2测试
    在这里插入图片描述

    展开全文
  • 此文档格式为ppt格式,主要从单臂路由的配置步骤以及配置命令,使用三层交换机和路由器分别进行配置,比较其中的不同点,以便于初学者完全理解单臂路由的配置以及原理。
  • 一份关于VLAN间单臂路由配置计算机网络实验报告 实验的几个步骤 1搭建主机交换机路由间的拓扑图 2交换机端口配置,Access口和Trunk口 3路由器子接口配置 4PC机IP地址配置
  • 单臂路由是基础网络课程中非常重要的一个知识点。概括来讲,就是路由器通过在一个接口中配置子接口的方式来实现不同局域网之间的通信。这里的局域网是通过802.1q协议配置Vlan的方式来实现物理隔离的。这篇文章将使用...
  • 单臂路由+DHCP+DNS.pkt

    2020-01-28 15:17:37
    单臂路由+DHCP+DNS 第一步:单臂路由+DHC实验拓扑图 第二步:创建vlan,VTP 第三步:单臂路由 第四步:DHCP动态获取IP地址 第五步:实验结果
  • 简单的 单臂路由 配置命令
  • 单臂路由实验.pkt

    2020-06-23 21:24:38
    单臂路由实验:在路由器上利用子接口实现不同VLAN间的通信 1.划分VLAN,将接口添加到对应VLAN里 2.因为24口与路由器相连,要实现路由器和交换机的通信,把交换机的24口设置为trunk口: 3.在路由器上创建子接口、分配...
  • 单臂路由(router-on-a-sTIck)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。 优缺点  VLAN能有效分割...

    单臂路由(router-on-a-sTIck)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

    单臂路由是一种技术,用于在没有三层交换机的情况下,实现不同vlan之间的通信。具体方法是在路由器内接口上配置虚拟子接口,具体配置命令可以百度。
    这里要说明一下,单臂路由是一种应急技术,仅仅用于网络预算不足,无力购置三层交换机,或者网络规模很小的情况下使用,一般情况下vlan都要配合三层交换机使用。

    优缺点
      VLAN能有效分割局域网,实现各网络区域之间的访问控制。但现实中,往往需要配置某些VLAN之间的互联互通。比如,你的公司划分为领导层、销售部、财务部、人力部、科技部、审计部,并为不同部门配置了不同的VLAN,部门之间不能相互访问,有效保证了各部门的信息安全。但经常出现领导层需要跨越VLAN访问其他各个部门,这个功能就由单臂路由来实现。

    优点: 实现不同vlan之间的通信,有助理解、学习VLAN原理和子接口概念。

    缺点: 容易成为网络单点故障,配置稍有复杂,现实意义不大。

    原文链接:http://www.elecfans.com/baike/wuxian/20171205594403_a.html

    展开全文
  • 思科路由器
  • 锐捷设备,单臂路由详细配置,具有很强操作性。
  • 网络单臂路由实验以及拓扑,了解单臂路由的特性实验,可以进行数据包的抓取以去获得单臂路由的数据流走向,结合理论更加深切了解单臂路由
  • 单臂路由数据流分析? 说明路由器的F0/0.1和F0/0.2是路由器的逻辑子接口F0/0.1是VLAN2的路由点F0/0.2是VLAN3的路由点 PCA发送数据帧给PCB的数据流分析过程如下 1PCA以广播的形式发送ARP请求询问F0/0.1端口的MAC地址 2...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,537
精华内容 2,214
关键字:

单臂路由