精华内容
下载资源
问答
  • 路由器的配置

    2012-05-10 10:55:54
    (1)配置接口IP地址 (2)激活接口 (3)配置终端服务器 (4)配置静态路由 一、配置路由协议 (1)配置RIP协议 (2)配置IGRP协议 (3)配置OSPF协议 (4)配置EIGRP协议 二、配置广域网接入 (1)...

    (1)配置接口IP地址

    (2)激活接口

    (3)配置终端服务器

    (4)配置静态路由


    一、配置路由协议

    (1)配置RIP协议

    (2)配置IGRP协议

    (3)配置OSPF协议

    (4)配置EIGRP协议

    二、配置广域网接入

    (1)配置ISDN

    (2)配置PPP和DDR

    三、配置帧中继

    展开全文
  • 交换机与路由器的配置

    万次阅读 多人点赞 2019-05-30 11:02:14
    交换机与路由器的配置 一、交换机的基本配置 配置enable口令、密码和主机名 Switch> (用户执行模式提示符) Switch>enable (进入特权模式) Switch# ...

    交换机与路由器的配置

    一、交换机的基本配置

    1. 配置enable口令、密码和主机名
      Switch> (用户执行模式提示符)
      Switch>enable (进入特权模式)
      Switch# (特权模式提示符)
      Switch#config terminal (进入配置模式)
      Switch(config)#enable password cisco (设置enable password为cisco)
      Switch(config)#enable secret cisco1 (设置enable secret为sisco1)
      Switch(config)#hostname C2950 (设置主机名为C2950)
      C2950(config)#end (退回到特权模式)
      C2950#
    2. 配置交换机IP地址、默认网关、域名和域名服务器
      C2950(config)#ip address 192.168.1.1 255.255.255.0 (设置交换机IP)
      C2950(config)#ip default-gateway 192.168.1.254 (设置默认网关)
      C2950(config)#ip domain-name cisco.com (设置域名)
      C2950(config)#ip name-server 200.0.0.1 (设置域名服务器)
      C2950(config)#end
    3. 配置交换机的端口属性
      C2950(config )#interface fastethernet0/1 (进入接口0/1的配置模式)
      C2950(config-if)#speed ? (查看speed命令的子命令)
      C2950(config-if)#speed 100 (设置该端口速率为100Mbps)
      C2950(config-if)#duplex ? (查看duplex命令的子命令)
      C2950(config-if)#duplex full (设置该端口为全双工)
      C2950(config-if)#description TO_PC1 (设置该端口描述为TO_PC1)
      C2950(config-if)#^Z (返回到特权模式,同end)
      C2950#show interface fastethernet0/1 (查看端口0/1的配置结果)
      C2950#show interface fastethernet0/1 status (查看端口0/1的状态)
    4. 配置和查看MAC地址表
      C2950(config)#mac-address-table ? (查看mac-address-table的子命令)
      C2950(config)#mac-address-table aging-time 100 (设置超时时间为100s)
      C2950(config)#mac-address-table permanent 0000.0c01.bbcc f0/3 (加入永久地址)
      C2950(config)#mac-address-table restricted static 0000.0c02.bbcc f0/3 f0/7
      (加入静态地址)
      C2950(config)#end
      C2950#show mac-address-table (查看整个MAC地址表)
      C2950#clear mac-address-table restricted static (清除限制性地址)
      二、配置和管理VLAN
    5. VLAN基础知识
      VLAN技术:把物理上直接相连的网络从逻辑上划分为多个子网。每一个VLAN对应着一个广播域,处于不同VLAN上的主机不能直接进行通信,不同VLAN之间的通信要引入第三层交换技术才可以解决。
      VLAN中继(VLAN Trunk)也称为VLAN主干,是指在交换机与交换机或交换机与路由器之间连接的情况下,在互相连接的端口上配置中继模式,使得属于不同VLAN的数据帧都可以通过这条中继链路进行传输。
      VLAN中继协议(即VTP协议)可以帮助交换机配置VLAN。VTP有三种工作模式:服务器模式、客户模式、透明模式。交换机的初始状态是工作在透明模式。
      通常虚拟局域网(VLAN)的实现形式有三种:静态端口分配、动态虚拟网、多虚拟网端口配置。
    6. 配置VTP协议
      1)配置2950A交换机为服务器模式
      Switch>enable (进入特权模式)
      Switch#config terminal (进入配置子模式)
      Switch(config)#hostname 2950A (修改主机名为2950A)
      2950A(config)#end
      2950A#
      2950A#vlan dataBase (进入VLAN配置子模式)
      2950A(vlan)#vtp ? (查看和VTP配合使用的命令)
      2950A(vlan)#vtp server (设置本交换机为Server模式)
      Setting device to VTP SERVER mode.
      2950A(vlan)#vtp domain vtpserver (设置域名)
      Changing VTP domain name from NULL to vtpserver.
      2950A(vlan)#vtp pruning (启动修剪功能)
      Pruning switched ON
      2950A(vlan)#exit (退出VLAN配置模式)
      APPLY completed. Exiting…
      2950A#show vtp status (查看VTP设置信息)
      2)配置2950B交换机为客户端模式
      Switch(config)#config terminal (进入配置子模式)
      Switch(config)#hostname 2950B (修改主机名为2950B)
      2950B(config)#end
      2950B#vlan database
      2950B(vlan)#vtp client
      Setting device to VTP CLIENT mode.
      2950B(vlan)#exit
    7. 配置VLAN Trunk端口
      跨交换机的同一VLAN内的数据经过Trunk线路进行交换,默认情况下trunk允许所有的VLAN通过。可以使用switchport trunk allowed vlan remove vlan-list来去掉某一VLAN。可以在交换机2950A和2950B上做如下相同的配置操作。
      Switch#config terminal
      Swich(config)#interface f0/24 (进入端口24配置模式)
      Switch(config-if)#switchport mode trunk (设置当前端口为Trunk模式)
      Switch(config-if)#switchport trunk allowed vlan all
      (设置允许从该端口交换数据的VLAN)
      Switch(config-if)#exit
      Switch(config)#exit
      Switch#
    8. 创建VLAN
      VLAN信息可以在服务器模式或透明模式交换机上创建。
      2950A#vlan dataBase
      2950A(vlan)#vlan 2 (创建一个VLAN2)
      VLAN 2 added:
      Name:VLAN0002 (系统自动命名)
      2950A(vlan)#vlan 3 name vlan3 (创建一个VLAN3,并命名为vlan3)
      VLAN 3 added: Name:vlan3
      2950A(vlan)#exit
    9. 将端口加入到某个VLAN中
      Switch#config terminal
      Enter configuration commands,one per line.End with CNTL/Z.
      Switch(config)#interface f0/9 (进入端口9的配置模式)
      Switch(config-if)#switchport mode access (设置端口为静态VLAN访问模式)
      Switch(config-if)#switchport access vlan2 (把端口9分配给相信的VLAN2)
      Switch(config-if)#exit
      Switch(config)#interface f0/10
      Switch(config-if)#switchport mode access
      Switch(config-if)#switchport access vlan3
      Switch(config-if)#exit
      Switch(config)#exit
      Switch#show vlan (查看VLAN配置信息) (结果省略)
      Switch#

    三、生成树协议配置
    生成树协议(STP)的目的是在实现交换机之间冗余连接的同时,避免网络环路的出现,实现网络的高可靠性。当交换机之间有多个VLAN时Trunk线路负载会过重,这时需要设置多个Trunk端口,但这样会形成网络环路,而STP协议便可以解决这一问题。

    1. 使用STP端口权值实现负载均衡
      假如用端口f0/23做Trunk1,用端口f0/24做Trunk2,则配置如下。
      (配置VTP)
      Switch1#vlan dataBase (进入VLAN配置子模式)
      Switch1(vlan)#vtp server (设置本交换机为Server模式)
      Switch1(vlan)#vtp domain vtpserver (设置域名)
      Switch1(vlan)#exit
      Switch1#show vtp status (验证VTP设置信息)
      (配置Trunk)
      Switch1#config terminal
      Switch1(config)#interface f0/23 (进入端口23配置模式)
      Switch1(config-if)#switchport mode trunk (设置当前端口为Trunk模式)
      Switch1(config-if)#exit
      Switch1(config)#interface f0/24 (进入端口24配置模式)
      Switch1(config-if)#switchport mode trunk (设置当前端口为Trunk模式)
      Switch1(config-if)#end
      Switch1#
      (配置STP权值)
      Switch1#config terminal
      Switch1(config)# interface f0/23 (进入端口23配置模式,Trunk1)
      Switch1(config-if)#spanning-tree vlan 1 port-priority 10 (将VLAN 1的端口权值设为10)
      Switch1(config-if)#spanning-tree vlan 2 port-priority 10 (将VLAN 2的端口权值设为10)
      Switch1(config-if)#exit
      Switch1(config)#interface f0/24 (进入端口24配置模式,Trunk2)
      Switch1(config-if)#spanning-tree vlan 3 port-priority 10 (将VLAN 3的端口权值设为10)
      Switch1(config-if)#spanning-tree vlan 4 port-priority 10 (将VLAN 4的端口权值设为10)
      Switch1(config-if)#spanning-tree vlan 5 port-priority 10 (将VLAN 5的端口权值设为10)
      Switch1(config-if)#end
      Switch1#copy running-config startup-config (保存配置文件)
    2. 配置STP路径值的负载均衡
      Switch1#config terminal
      Switch1(config)#interface f0/23 (进入端口23配置模式,Trunk1)
      Switch1(config-if)#spanning-tree vlan 3 cost 30 (设置VLAN 3生成树路径值为30)
      Switch1(config-if)#spanning-tree vlan 4 cost 30 (设置VLAN 4生成树路径值为30)
      Switch1(config-if)#spanning-tree vlan 5 cost 30 (设置VLAN 5生成树路径值为30)
      Switch1(config-if)#exit
      Switch1(config)#interface f0/24 (进入端口24配置模式,配置Trunk2)
      Switch1(config-if)#spanning-tree vlan 1 cost 30 (设置VLAN 1生成树路径值为30)
      Switch1(config-if)#spanning-tree vlan 2 cost 30 (设置VLAN 2生成树路径值为30)
      Switch1(config-if)#end
      Switch1#
      四、路由器的基本配置
      路由器的配置操作有三种模式:用户执行模式、特权模式和配置模式。其中,配置模式又分为:全局配置模式和接口配置模式、路由协议配置模式、线路配置模式等子模式。
    3. 路由器的基本配置
      Router>enable (进入特权执行模式)
      Router#config t (进入全局配置模式)
      Router(config)#interface fastethernet0/1 (进入接口F0/1配置模式)
      Router(config-if)#ip address 192.168.1.11 255.255.255.0 (设置接口IP地址)
      Router(config-if)#no shutdown (激活接口)
      Router(config-if)#end (退回到特权模式)
      Router#show running-config (检查配置结果)
    4. 配置终端服务器
      Term_Server#
      Term_Server#router1 (访问主机表中的router1路由器)
      Trying router1(10.1.1.1,2001)…Open
      Router>enable Router#config t
      Router(config)#hostname router1 (设置路由器1的主机名)
      Router1(config)#end
      Router1#
      (会话切换命令 先同时按下Ctrl+Shift+6组合键,松开后再按下x键)
      Term_Server#
      Term_server#router2
      Trying router2(10.1.1.1,2002)…Open
      Router>enable
      Router#config t
      Router(config)#hostname router2
      Router2(config)#end
      Router2#
      (会话切换命令Ctrl+Shift+6后接x)
      Term_server#show sessions (查看终端服务器会话)
      Term_server#disconnect 2 (断开会话2)
      Term_server#show line 1 (查看线路1的状态)
      Term_server#clear line 1 (清除线路2)
    5. 配置静态路由
      (1) IPv4静态路由设置
      路由器R1:E0(10.1.1.1/24) E1(192.168.1.1/24)
      路由器R2:E0(10.1.1.2/24)
      路由器R3
      R1#ping 10.1.1.2 (R1上ping R2,结果连通)
      R1#ping 192.168.1.3 (R1上ping R3,结果连通)
      从R2路由器ping路由器R1的E1接口
      R2#ping 192.168.1.1 (ping R1的E1接口,结果不连通)
      R2#show ip route (查看路由表)
      发现路由表中显示只有直接相连的网段10.1.1.0/24在其路由表内,标志为C表示连接(Connected)。为此,可以在R2路由表中加入静态路由。
      R2#config t
      R2(config)#ip route 192.168.1.0 255.255.255.0 10.1.1.1 (加入静态路由)
      R2#(config)#end
      这条静态路由信息表示从该路由器出发发往192.168.1.0 255.255.255.0网段的数据包其下一跳点(Next Hop)的地址是10.1.1.1(即通过R1的E0接口地址)。再从R2 ping R1的E1接口,发现可以ping通了。
      R2#ping 192.168.1.1 (ping R1的E1接口,结果连通)
      但是,此时从R2 ping R3的E0接口却不能ping通。原因为:从R2发出的数据包可以经过R1的E0端口转发且让R3收到,但是R3此时不能发送响应数据包ICMP Echo Reply到10.1.1.2,因为在R3上还没有发往R2路由器的路由信息。
      R2#ping 192.168.1.3 (ping R3的E0接口,结果不连通)
      此时需要在R3上加入发往R2网段数据包的路由信息。
      R3#config t
      R3(config)#ip route 10.1.1.0 255.255.255.0 192.168.1.1 (加入静态路由)
      R3(config)#end
      注意:在有些路由器上默认情况是不启动IP路由的,这时可以用ip routing和no ip routing来启动和关闭IP路由。

    (2) IPv6静态路由设置
    R1: E0(2005:CCCC::1/64) S0(2007:CCCC::1/64)
    R2: E0(2004:CCCC::1/64) S0(2007:CCCC::2/64)
    PC1: IP 2005:CCCC::2/64 网关 2005:CCCC::1
    PC2: IP 2004:CCCC::2/64 网关 2004:CCCC::1
    R1相关配置如下。
    Router#
    Router#configure terminal
    Router(config)#hostname R1
    R1(config)#ipv6 unicast-routing (开启IPv6单播路由)
    R1(config)#interface f0/0
    R1()config-if)#ipv6 address 2005:CCCC::1/64 (设置E0口IPv6地址)
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#interface Serial0/2/0
    R1(config-if)#ipv6 address 2007:CCCC::1/64 (设置S0口IPv6地址)
    R1(config-if)#clock rate 128000 (配置S0口时钟频率)
    R1(config-if)#exit
    R1(config)#ipv6 route 2004:CCCC::/64 Serial0/2/0 (设置IPv6静态地址)
    R2相关配置如下。
    Router#
    Router#configure terminal
    Router(config)#hostname R2
    R2(config)#ipv6 unicast-routing (开启IPv6单播路由)
    R2(config)#interface f0/0
    R2(config-if)#ipv6 address 2004:CCCC::1/64 (设置E0口IPv6地址)
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#interface Serial0/2/0
    R2(config-if)#ipv6 address 2007:CCCC::2/64 (设置S0口IPv6地址)
    R2(config-if)#clock rate 128000 (配置S0口时钟频率)
    R2(config-if)#exit
    R2(config)#ipv6 route 2005:CCCC::/64 Serial0/2/0 (设置IPv6静态路由)
    配置完成后,在R1中查看IPv6路由表如下。
    R1#show ipv6 interface (内容省略)
    五、配置路由协议
    IP路由选择协议用有效的、无循环的路由信息填充路由表,从而为数据包在网络之间传递提供了可靠的路径信息。路由选择协议又分为距离矢量、链路状态和平衡混合三种。
    距离矢量(Distance Vector)路由协议计算网络中所有链路的矢量和距离并以此为依据确认最佳路径。使用距离矢量路由协议的路由器定期向其相邻的路由器发送全部或部分路由表。典型的距离矢量路由协议有RIP和IGRP。
    链路状态(Link State)路由协议使用为每个路由器创建的拓扑数据库来创建路由表,每个路由器通过此数据库建立一个整个网络的拓扑图。在拓扑图的基础上通过相应的路由算法计算出通往各目标网段的最佳路径,并最终形成路由表。典型的链路状态路由协议是OSPF(Open Shortest Path First,开放最短路径优先)路由协议。
    平衡混合(Balanced Hybrid)路由协议结合了链路状态和距离矢量两种协议的优点,此类协议的代表是EIGRP,即增强型内部网关协议。

    1. 配置RIP协议
      RIP(路由选择信息协议)使用非常广泛,它简单、可靠、便于配置。但是,RIP只适用于小型的同构网络,因为它允许的最大跳数为15,任何超过15个站点的目的地均被标记为不可达。RIP每隔30s广播一次路由信息。
      RIP版本2还支持无类域间路由(CIDR)和可变长子网掩码(VLSM)及不连续的子网,并且使用组播地址发送路由信息。

    RIP相关命令
    命令 功能
    router rip 指定使用RIP协议
    version{1|2} 指定RIP版本
    network network 指定与该路由器相连的网络
    show ip route 查看路由表信息
    show ip route rip 查看RIP协议路由信息
    各接口IP地址分配如下。
    R1 E0 192.168.1.1
    R1 S0 192.168.65.1
    R1 S1 192.168.67.1
    R2 E0 192.168.3.1
    R2 S0 192.168.65.2
    R2 S1 192.168.69.1
    R3 E0 192.168.5.1
    R3 S0 192.168.69.2
    R3 S1 192.168.67.2
    根据要求配置各路由器的各接口地址
    R1#config t
    R1(config)#no logging console (不在控制台接口显示log提示信息)
    R1(config)#interface fastethernet0/1
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#interface serial 0
    R1(config-if)#ip address 192.168.65.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#interface serial 1
    R1(config-if)#ip address 192.168.67.1 255.255.255.0
    R1(config-if)#no shutdown
    在全局配置模式下使用no logging console配置命令,可以防止大量的端口状态变化信息和报警信息对配置过程的影响。类似配置R1各接口地址的方法可以配置好路由器R2和R3的各接口地址。
    用show ip route命令查看路由表信息
    R1#show ip route
    配置路由器R1
    R1(config)#ip routing (允许路由选择协议)
    R1(config)#router rip (进入rip协议配置子模式)
    R1(config-router)#network 192.168.1.0 (声明网络192.168.1.0/24)
    R1(config-router)#network 192.168.65.0
    R1(config-router)#network 192.168.67.0
    R1(config-router)#version 2 (设置RIP协议版本2)
    R1(config-router)#exit
    配置路由器R2
    R2(config)#ip routing
    R2(config)#router rip (进入RIP协议配置子模式)
    R2(config-router)#network 192.168.3.0 (声明网络192.168.3.0/24)
    R2(config-router)#netword 192.168.65.0
    R2(config-router)#network 192.168.69.0
    R2(config-router)#version 2 (设置RIP协议版本2)
    R2(config-router)#exit
    配置路由器R3
    R3(config)#ip routing
    R3(config)#router rip (进入RIP协议配置子模式)
    R3(config-router)#network 192.168.5.0 (声明网络192.168.5.0/24)
    R3(config-router)#network 192.168.67.0
    R3(config-router)#network 192.168.69.0
    R3(config-router)#version 2 (设置RIP协议版本2)
    R3(config-router)#exit
    2. 配置IGRP协议
    内部网关路由协议(Interior Gateway Routing Protocol,IGRP)是一种动态距离向量路由协议,它不支持VLSM和不连续的子网。
    默认情况下,IGRP每90s发送一次路由更新广播,在3个更新周期内(即270s)没有从路由表中的一个路由器接收到更新,则宣布路由不可访问。在7个更新周期(即360s)后,IOS软件从路由表中清除路由。
    IGRP相关命令
    命令 功能
    router igrp autonomous-system 指定使用IGRP协议
    network network 指定与该路由器相连的网络
    show ip route 查看路由表信息
    show ip route igrp 查看IGRP协议路由信息
    在这里插入图片描述
    查看R1、R2、R3的配置清单
    R1#show running-config
    R2#show running-config
    R3#show running-config
    查看三个路由器的路由表
    R1#show ip route igrp
    R2#show ip route igrp
    R3#show ip route igrp
    3. 配置OSPF协议
    开放最短路径优先(OSPF)协议是一种链路状态路由选择协议。链路是路由器接口的另一种说法,因此OSPF也称为接口状态路由协议。OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。
    OSPF相关命令
    命令 功能
    router ospf process-id 指定使用OSPF协议
    network address wildcard-mask area area-id 指定与该路由器相连的网络
    show ip route 查看路由表信息
    show ip route ospf 查看OSPF协议路由信息
    注:1. OSPF路由进程process-id需要指定范围在1-65535之间。
    2. wildcard-mask是子网掩码的反码,网络区域ID area-id 是在0-4294967295内的十进制数,
    也可以带有IP地址格式的x.x.x.x。当网络区域ID为0时为主干域。不同网络区域的路由器通过主干域学习路由信息。

    按照设计图所示的网络拓扑结构图来配置OSPF协议。
    在这里插入图片描述
    R1:
    interface Ethernet 0
    ip address 192.1.0.129 255.255.255.192
    Interface serial 0
    ip address 192.200.10.5 255.255.255.252
    router ospf 100
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.128 0.0.0.63 area 1
    R2:
    interface Ethernet 0
    ip address 192.1.0.65 255.255.255.192
    interface serial 0
    ip address 192.200.10.6 255.255.255.252
    router ospf 200
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.64 0.0.0.63 area 2
    R3:
    interface ethernet 0
    ip address 192.1.0.130 255.255.255.192
    router ospf 300
    network 192.1.0.128 0.0.0.63 area 1
    R4:
    interface Ethernet 0
    ip address 192.1.0.66 255.255.255.192
    router ospf 400
    network 192.1.0.64 0.0.0.63 area 1
    用以下命令来调试或查看配置信息和路由信息。
    debug ip ospf events
    debug ip ospf packet
    show ip ospf
    show ip ospf database
    show ip ospf interface
    show ip ospf neighbor
    show ip route
    在这里插入图片描述
    下面给出各路由器的配置清单,清单中只列出其中重要的配置信息。
    R1#show running-config
    Interface Serial0
    Ip address 192.200.10.1 255.255.255.252
    Interface Ethernet0
    Ip address 10.20.10.1 255.255.255.255
    router eigrp 200
    network 192.200.10.0 0.0.0.3
    network 10.20.10.0 0.0.0.255
    no auto-summary
    R2#show running-config
    Interface Serial0
    Ip address 192.200.10.2 255.255.255.252
    Interface Ethernet0
    Ip address 201.10.10.1 255.255.255.255
    router eigrp 200
    network 192.200.10.0 0.0.0.3
    network 201.10.10.0
    no auto-summary
    在这里插入图片描述
    连接好线路后,就可以进行配置工作。
    R1#config t
    R1(config)#isdn switch-type ?
    (查看交换机类型,在中国使用basic-net3类型的最多)
    配置R1:
    R1(config)#isdn switch-type basic-net3 (设置交换机类型为basic-net3)
    R1(config)#interface bri0 (进入BRI接口配置模式)
    R1(config-if)#ip address 192.168.1.1 255.255.255.0 (设置接口IP地址)
    R1(config-if)#encapsulation ppp (设置封装协议为ppp)
    R1(config-if)#dialer string 80000002 (设置拨号串,R2的ISDN号码)
    R1(config-if)#dialer-group 1 (设置拨号组号为1,把BRI0接口与拨号列表1相关联)
    R1(config-if)#no shutdown (激活接口)
    R1(config-if)#exit
    R1(config)#dialer-list 1protocol ip permit (设置拨号列表1)
    R1(config)#end
    R1#
    其中dialer-list 1 protocol ip permit允许IP协议包成为引起拨号的“感兴趣包”,即当有IP包需要在拨号线路上传送时可以引起拨号。

    配置R2:
    R2(config)#isdn switch-type basic-net3 (设置交换机类型为basic-net3)
    R2(config)#interface bri0 (进入BRI接口配置模式)
    R2(config-if)#ip address 192.168.1.2 255.255.255.0 (设置接口IP地址)
    R2(config-if)#encapsulation ppp (设置封装协议为ppp)
    R2(config-if)#dialer string 80000001 (设置拨号串,R1的ISDN号码)
    R2(config-if)#dialer-group 1 (设置拨号组号为1,把BRI0接口与拨号列表1相关联)
    R2(config-if)#no shutdown (激活端口)
    R2(config-if)#exit
    R2(config)#dialer-list 1 protocol ip permit (设置拨号列表1)
    R2(config)#end
    R2#
    配置完成后,可以使用debug和ping命令来调试配置结果。
    R1(config)#logging console (在终端上显示监测信息)
    R1(config)#exit
    R1#debug dialer (监测dialer信息)
    Dial on demand events debugging is on
    R1#ping 192.168.1.2 (内容省略…)
    R1#undebug all (关闭所有调试信息)
    还可以用show isdn status命令查看ISDN状态,用show dialer命令显示当前的拨号及其配置等信息。
    在这里插入图片描述
    (1) 配置基本的帧中继连接。
    路由器R1:
    R1#config t
    R1(config)#interface E0
    R1(config-if)#ip address 192.1.1.1 255.255.255.0
    R1(config-if)#no keepalive
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#interface s0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#encap frame-relay (该接口使用帧中继封装格式)
    R1(config-if)#no shutdown
    R1(config-if)#no frame-relay inverse-arp (关闭帧中继逆向ARP)
    R1(config-if)#frame map ip 192.168.1.2 cisco
    R1(config-if)#end
    R1#
    路由器R2:
    R2#config t
    R2(config)#interface E0
    R2(config-if)#ip address 192.1.2.1 255.255.255.0
    R2(config-if)#no keepalive
    R2(config-if)#no shutdown
    R2(config-if)#exit
    R2(config)#interface s0
    R2(config-if)#ip address 192.168.1.2 255.255.255.0
    R2(config-if)#encap frame-relay (该接口使用帧中继封装格式)
    R2(config-if)#no shutdown
    R2(config-if)#no frame-relay inverse-arp (关闭帧中继逆向ARP)
    R2(config-if)#frame map ip 192.168.1.1 cisco
    R2(config-if)#end
    R2#
    配置完成后可以用下面的命令查看帧中继相关信息。
    show frame pvc
    show frame map
    show frame traffic
    show frame lmi

    展开全文
  • 路由器的配置模式和常用的配置命令 掌握路由器的配置模式之间的切换,常用的路由器配置指令,理解IP 数据包路 由过程。 原理 这个实验由于交换机是即插即用故不用配置三层交换机,只需配置路由器的的 拓扑结构 ...

    路由器的配置模式和常用的配置命令

    掌握路由器的配置模式之间的切换,常用的路由器配置指令,理解IP 数据包路 由过程。

    原理

    这个实验由于交换机是即插即用故不用配置三层交换机,只需配置路由器的的

    拓扑结构

    选择一台C2811 路由器,并添加两台交换机和两台计算机。分别在2 台计算机上配置IP 地址和网关,配置的IP 地址和网关如图所示 

    (2) 在路由器C2811 上,使用帮助查找路由器常用配置命令,

    (3) 进入路由器f0/0 接口模式,配置IP 地址为192.168.1.1/24。进入路由器f0/1 接口模式,配置IP 地址为192.168.2.1/24 

     

    (4) 在路由器全局模式下使用show ip route 查看路由表,

     

    (5) 192.168.1.100 与192.168.2.100 之间进行ping 通

     

    6)用show interface f0/0来查看局域网接口f0/0的详细信息,用show interface f0/1

    来查看局域网接口f0/1的详细信息。

    show interface f0/0

     show interface f0/1

     2. 在路由器上用show arp 

    总结: 

    从主机192.168.1.1上ping主机192.168.2.1时,数据包是如何传递的?主机、交

    换机、路由器分别又是如何处理的?

    主机192.168.1.1先查看自己的mac地址如果没有目标主机mac地址就给交换机进行广播,如果广播没有回应的,就交给网关,网关在交给路由器,路由器在去查看自己的路由表,如果查到最长相似的就交给它,再有它转发给目标地址

    欢迎留言 :

    展开全文
  • 思科交换机和路由器的配置交换机的配置交换机端口的隔离 上一篇:思科的安装与汉化 接下来将用实例带小伙伴们一起来了解思科交换机和路由器的配置 交换机的配置 交换机端口的隔离 实例:将交换机的1—5号端口划分在...

    上一篇:思科的安装与汉化
    下一篇:思科综合实例

    接下来将用实例带小伙伴们一起来了解思科交换机和路由器的配置

    交换机的配置

    交换机端口的隔离

    实例1:将交换机的1—5号端口划分在VLAN 10中,10—15号端口划分在VLAN20中,并分别为其命名为test10和test20。

    结果:Vlan 10的各PC间能通讯,Vlan 20的各PC间能通讯,Vlan 10与VLAN 20之间的各PC间不能能通讯。

    步骤:
    1.按图示连接pc机和交换机
    在这里插入图片描述
    2.给每个PC机配置地址
    在这里插入图片描述
    在这里插入图片描述
    3、在交换机上划分vlan
    在这里插入图片描述
    具体代码:

    Switch#config t
    Switch(config)#vlan 10                    //创建VLAN 10
    Switch(config-vlan)#name test10   //为VLAN 10 命名test10
    Switch(config-vlan)#exit          //返回上层:即全局配置模式
    Switch(config)#vlan 20
    Switch(config-vlan)#name test20
    Switch(config-vlan)#exit
    Switch(config)#exit
    (用SHOW   VLAN 验证VLAN的划分及命名)
    //将接口分配到指定的VLAN
    Switch#config t
    Switch(config)#interface range fastEthernet 0/1-5   //进入fastEthernet 0接口配置模式
    Switch(config-if-range)#switch access vlan 10       
                                                       //将fastEthernet 0接口的1—5端口加入VLAN 10
    Switch(config-if-range)#exit
    Switch(config)#interface range fastEthernet 0/10-15
    Switch(config-if-range)#switch access vlan 20
    Switch(config-if-range)#exit
    Switch(config)#exit
    (用SHOW   VLAN 验证)
    

    4、测试PC机之间的连通性
    在这里插入图片描述
    证明ping通
    在这里插入图片描述

    跨交换机实现VLAN

    实例2:将switch A和switch B的1—5号端口划分在VLAN 10中,10—15号端口划分在VLAN20中,并分别为其命名为test10和test20。

    结果:使在同一VLAN的PC机能相互跨交换机通信,而不同VLAN的PC机能相互跨交换机不能通信。

    步骤:
    1.按图示连接pc机和交换机
    在这里插入图片描述
    2、给每个PC机分配地址
    3、在两台交换机上划分vlan(参照实例1)
    4、配置两台交换机相连的端口
    代码:

    Switch(config)#interface fastEthernet 0/24       /进入fastEthernet 0接口配置模式
    Switch(config-if)#switchport mode trunk        /将fastEthernet 0/24端口定义为tang vlan模式
    Switch(config)#exit
    
    (用SHOW   VLAN 验证VLAN的划分及命名)
    

    5、测试PC机之间的连通性。

    路由器的配置

    静态路由

    实例3:用一根双绞线将Router A与Router B 的fastEthernet1/1接口连接起来,PC1、PC2分别和Router A与Router B 的fastEthernet1/0接口连接。

    结果:使连接在Router A与Router B 上的PC机相互通信

    步骤:
    1.按图示连接pc机和路由器
    在这里插入图片描述
    2、给每个PC机配置地址
    3、在路由器上进行配置
    代码:
    Route 0上的配置:

    //路由器使用端口地址的配置
    Router#config t
    Router(config)#hostname Red-Giant
    Red-Giant(config)#interface fastEthernet 0/0    /进入fastEthernet0/0接口的配置模式
    Red-Giant(config-if)#ip  address 198.168.2.1 255.255.255.0  /为fastEthernet0/0接口配置IP地址 
    Red-Giant(config-if)#no shutdown       /开启fastEthernet0/0接口
    Red-Giant(config-if)#exit
    Red-Giant(config)#interface fastEthernet 1/0
    Red-Giant(config-if)#ip  ddress 198.168.1.1  255.255.255.0
    Red-Giant(config-if)#no shutdown
    Red-Giant(config-if)#exit
    
    / /在Router B配置静态路由
    Red-Giant(config)#ip  route 198.168.3.0 255.255.255.0  198.168.2.2  
    Red-Giant(config)#exit
    (用SHOW  IP  interface  brief 验证路由器的配置)
    (用SHOW  IP ROUTER 验证路由器Router  B的静态路由
    S    198.168.3.0/24 [1/0] via 198.168.2.2表示该条路由为静态条路,到达198.168.3.0网络的数据包通过邻居的端口198.168.2.2即可达。)
    

    Route 1上的配置:

    //路由器使用端口地址的配置
    Router#config t
    Router(config)#hostname Red-Giant
    Red-Giant(config)#interface fastEthernet 1/1      /进入fastEthernet1/1接口的配置模式
    Red-Giant(config-if)#ip  address 198.168.2.2 255.255.255.0  /为fastEthernet1/1接口配置IP地址 
    Red-Giant(config-if)#no shutdown       /开启fastEthernet1/1接口
    Red-Giant(config-if)#exit
    Red-Giant(config)#interface fastEthernet 1/0
    Red-Giant(config-if)#ip  ddress 198.168.3.1  255.255.255.0
    Red-Giant(config-if)#no shutdown
    Red-Giant(config-if)#exit
    
    
    / /在Router B配置静态路由
    Red-Giant(config)#ip  route 198.168.1.0 255.255.255.0  198.168.2.1  
    Red-Giant(config)#exit
    (用SHOW  IP  interface  brief 验证路由器的配置)
    (用SHOW  IP ROUTER 验证路由器Router  B的静态路由
    S    198.168.1.0/24 [1/0] via 198.168.2.1表示该条路由为静态条路,到达172.168.1.0网络的数据包通过邻居的端口172.168.2.1即可达。)
    

    4、测试PC机的连通性

    RIP Version 1协议(动态路由)

    实例4:用一根双绞线将Router A与Router B 的fastEthernet 1/1接口连接起来,PC1、PC2分别和Router A与Router B 的fastEthernet1/1接口连接。

    结果:使连接在Router A与Router B 上的PC机相互通信

    步骤:
    1.按图示连接pc机和路由器
    在这里插入图片描述
    2、给各PC机配置地址
    3、路由器使用端口配置地址(参照实例3路由器端口地址的配置)
    4、创建动态路由进程
    代码:
    Route 0上的配置:

    ROUTERA (config)#router  rip       /创建RIP路由进程
    ROUTERA (config-router)#network 198.168.1.0 /通告网络号,并启用相应接口参与动态路由进程
    ROUTERA (config-router)#network 198.168.2.0
    ROUTERA (config-router)#exit
    ROUTERA (config)#exit
    (show ip route验证 ROUTERA和 ROUTER B上的RIP V1路由器表
    出现R    198.168.3.0/24 [120/1] via 198.168.2.2, 00:00:14, FastEthernet0/0即可)
    

    Route 1上的配置:

    ROUTERA (config)#router  rip       /创建RIP路由进程
    ROUTERA (config-router)#network 198.168.3.0 /通告网络号,并启用相应接口参与动态路由进程
    ROUTERA (config-router)#network 198.168.2.0
    ROUTERA (config-router)#exit
    ROUTERA (config)#exit
    (show ip route验证 ROUTERA和 ROUTER B上的RIP V1路由器表
    出现R    198.168.1.0/24 [120/1] via 198.168.2.1, 00:00:16, FastEthernet0/0即可)
    

    5、测试PC机的连通性

    实例1、2、3、4.pkt文件网盘链接

    链接:https://pan.baidu.com/s/1hkILw1J7DgRtUc8k_ohcyA
    提取码:amfc

    展开全文
  •  路由器的配置对初学者来说,并不是件十分容易的事。现将路由器的一般配置和简单调试介绍给大家,供朋友们在配置路由器时参考,本文以Cisco2501为例。  Cisco2501有一个以太网口(AUI)、一个Console口(RJ45)...
  • Linux路由器的配置

    千次阅读 2007-08-03 17:14:00
    本文主要介绍如何用Linux做一个功能完备的路由器,这里将主要介绍静态路由器和动态路由器的配置,但不包括IP伪装或者说公用一个IP地址访问外面网络等问题。其已经不属于本主题讨论的范围,请参考其他如防火墙的配置...
  • 路由器的配置模式

    千次阅读 2017-06-12 10:51:43
    第4级全局配置模式子模式第1级:用户模式 (User EXEC Mode)在这一级别,用户通常只能使用少量查看性质命令以终端或Telnet方式进入路由器时系统会提示用户输入口令,输入口令后便进入了第1级,即用户模式级别。
  • 1、两台路由器默认没有对方网段路由表项 2、配置静态路由,默认路由让两台主机互通 实验步骤 1、打开eNSP 软件,配置两台路由器,两台主机 2、将两台主机配好IP地址 开启设备 下面开始配置R1,R2端口IP地址 R1...
  • 新CCIE笔记-路由器的配置

    千次阅读 2018-01-05 11:00:25
    CCIE重修笔记之路由器基本配置与最简单路由。 路由器与交换机基本配置命令 全局配置模式下有多种子模式 (华为可以跳跃切换模式) 思科命令行技巧 Tab键补全,也可以直接保留缩写 问号‘?’类似linux...
  • 计算机网络——路由器的配置1

    千次阅读 2018-09-25 21:39:13
    1、路由器的工作原理回顾: 互联不同的网络,在网络之间进行路由选择和分组转发 不同的网络:指IP网络号不同 2、 3、路由器命令的四种操作模式: 逐级进入! 用户模式: 特权模式: 全局配置模式: 接口配置...
  • 路由器的配置与调试

    2005-11-09 17:47:00
    路由器的配置与调试路由器在计算机网络中有着举足轻重的地位,是计算机网络的桥梁。通过它不仅可以连通不同的网络,还能选择数据传送的路径,并能阻隔非法的访问。 路由器的配置对初学者来说,并不是件十分容易的事...
  • 由于合租的房子比较大,一部路由器不足以覆盖家中全部范围,所以用了路由器再接路由器的方法。组网方式可以简单表示如下(先不用关注IP,那是后面要说的问题),图中Internet表示外网。R0表示入户网线连接的路由器,...
  • (2) 在路由器C2811 上,使用帮助查找路由器常用配置命令,并对命令运行结果进行观察。见实验1,常用交换机配置命令。 (3) 进入路由器f0/0 接口模式,配置IP 地址为192.168.1.1/24。进入路由器f0/1 接口模式,配置...
  •  关于结合curl在命令行中实现路由器的配置,路由器牌子是TP-link。在网上看了一些做法,包括在cmd中输入:curl -u admin:admin http://192.168.1.1,cmd中成功显示相应页面信息,我理解是可以成功访问路由器相应...
  • ) Cisco2620路由器的基本配置 1. 初始安装 第一次安装时系统会自动进入Dialog Setup,依屏幕提示,分别回答路由器名称、加密超级登录密码、超级登录密码、远程登录密码、动态路由协议以及各个接口...
  • python网络编程中,两个交换机和一个路由器的配置
  • 思科路由器的配置通过TFTP备份 首先:从网上下载tftp serverA.将路由器FLASH中的文件copy出来的步骤:1、首先在PC机上运行TFTP server,TFTP server的地址为本PC机的IP地址192.168.100.25;2、一旦我们启用了一个...
  • 一个小型路由器的配置总结

    千次阅读 2007-04-01 10:34:00
    一个小型路由器的配置总结1、硬件安装: 1)建立局域网连接 将路由器LAN口和局域网中的Hub或交换机连接,也可将路由器LAN口直接和一台计算机的网卡相连接。 2)建立广域网连接 将外面接进来的网线,如xDSL或...
  • 路由器的配置

    2015-02-24 14:59:04
    今天给人部署了一个小型局域网,里面用到李shuan
  • (1)服务器的配置: 首先设置服务器的IP地址为192.168.1.1,这里可以使用PC机,但在使用前...如图所示:(2)路由器的配置:Router>enableRouter#Router#configure terminalRouer(config)#interface f0/0Router(c...
  • 无线路由器的配置

    千次阅读 2011-09-02 12:40:37
    实验室因为想试验kindle 3WIFI功能,打算用一个无线路由器来构建一个无线网络,实验室原本网络是由一个普通有线路由器和交换机构建。 WAN:广域网结构WAN(WideAreaNetwork)-广域网,是目前对网络一个...
  • CISCO路由器的配置与调试

    千次阅读 2005-05-12 08:03:00
    路由器的配置对初学者来说,并不是件十分容易的事。现将路由器的一般配置和简单调试介绍给大家,供朋友们在配置路由器时参考,本文以Cisco2501为例。 Cisco2501有一个以太网口(AUI)、一个Console口(RJ45)、一个...
  • 思科2811路由器的配置命令!

    千次阅读 2016-08-28 11:42:19
    Access-enable 允许路由器在动态访问列表中创建临时访问列表入口 Access-group 把访问控制列表(ACL)应用到接口上 Access-list 定义一个标准IP ACL Access-template 在连接的路由器上手动替换临时访问列表入口 Appn...
  • 华为:路由器的配置Telnet验证

    千次阅读 2019-05-28 19:49:13
    [Huawei]sysname AR5 [AR5]int g0/0/0 [AR5-GigabitEthernet0/0/0]ip add 192.168.1.1 24 [AR5-GigabitEthernet0/0/0]q Huawei]sysname AR6 [AR6]int g0/0/0 [AR6-GigabitEthernet0/0/0]ip add 192.168.1.2 24 ...
  • 只怪当初不好好读书,路由器都搞...房东线直连电脑,开机WIN + R 输入 cmd 打开 DOS界面DOS界面路输入 ipconfig /all 查看 ip 配置并截图拔掉网线,将线接入 路由器,连上路由器电源通过 无线 进入路由器配置页面上网
  • 路由器的配置命令

    千次阅读 2010-05-10 13:24:00
    路由命令十全大补router> enable 从用户模式进入特权模式router# disable or exit 从特权模式退出到用户模式router# show sessions 查看本机上TELNET会话router# disconnect 关闭所有TELNE
  • 路由器的配置,IP,NAT、DHCP

    千次阅读 2017-05-11 18:37:30
    复旦大学无线网本来挺好,然而我们自己实验室无线网却烂到掉渣。这里所说实验室,竟然是随便一下就能传几十上百个Gb/s通信实验室。...如果要用这个网口上网话,需要自己配置IP)。3...
  • linux系统路由器的配置

    万次阅读 2010-09-27 18:09:00
    B计算机 ip:192.168.2.120 默认网关:192.168.2.1C计算机 ip:192.168.3.114 默认网关:192.168.3.1现在B、C计算机要以A为路由器上网,并实现B、C网段之间访问。A计算机配置:$/sbin/ifconfig eth0 192168.1.125 ...
  • 封禁ICMP协议,只转发212.78.170.166/27所在子网所有站点ICMP数据包,正确access-list配置 Router(config)#access-list110permiticmp212.78.170.1600.0.0.31any? Router(config)#access-list110denyicmpanyany...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,836
精华内容 9,934
关键字:

路由器的配置