精华内容
下载资源
问答
  • 华为网络设备-NAT实验

    千次阅读 2021-02-08 12:37:48
    华为网络设备-NAT实验 作者: 陈诺    排版: 赖裕鑫    审核: 蔡宗唐 文章目录一、实验简介1. NAT简介2. NAT类型2.1 静态NAT2.2 动态NAT2.3 Easy IP(转换成出接口地址)2.4 NAPT...

    华为网络设备-NAT实验

    作者: 陈诺    排版: 赖裕鑫    审核: 蔡宗唐



    一、实验简介

    1. NAT简介

    NAT(Network Address Translation) 网络地址转换,是一种IETF(Internet Engineering Task Force, Internet工程任务组)标准,是把内部私有网络地址转换成合法外部公有网络地址的技术。

    TCP/IP协议版本IPv4,有IP地址匮乏的先天生缺陷;如果专用网络的计算机要访问Internet,则组织机构在连接Internet的设备上至少需要一个公有IP地址,然后采用NAT技术,将内部网络的计算机私有IP地址转换为公有IP地址,从而让使用私有IP地址的计算机能够和Internet中的计算机进行通信。

    NAT 除了解决 IP 地址短缺的问题,还带来了两个好处:

    • 有效避免来自外网的攻击,可以很大程度上提高网络安全性。

    • 控制内网主机访问外网,同时也可以控制外网主机访问内网,解决了内网和外网不能互通的问题。

    2. NAT类型

    2.1 静态NAT

    在路由器中,将内网IP地址固定的转换为外网IP地址,通常应用在允许外网用户访问内网服务器的场景。

    2.2 动态NAT

    将一个内部IP地址转换为一组外部IP地址池中的一个IP地址(公有地址),内网获得的公网地址是随机非永久使用的。

    2.3 Easy IP(转换成出接口地址)

    通过端口号识别不同的内网地址,无需创建地址池,直接将内网地址转换为公网地址,属NAPT的特例

    2.4 NAPT(网络地址端口转换)

    允许多个内网地址转换到同一个公网地址的不同端口,在内网通过端口号进行区分。NAPT又分为以下两种类型:

    动态NAPT

    IP地址及端口号(TCP或UDP)为转换条件,将内部网络的私有IP地址及端口号转换成外部公有IP地址及端口号。

    静态NAPT

    在路由器中以 IP+端口 形式,将内网IP及端口固定转换为外网IP及端口,应用在允许外网用户访问内网计算机特定服务的场景。

    2.5 多种模式的比较

    在这里插入图片描述

    二、实验配置

    1. 动态NAT

    1.1 实验要求

    在这里插入图片描述

    如图所示,ABC公司通过路由器R1接入Internet,相关背景和需求如下。

    • 公司向ISP申请了1批公网IP:16.16.16.8~16.16.16.16。

    • 公司内网计算机(192.168.100.0/24)可通过路由器R2随机映射到公网,实现内外网互访。

    1.2 操作过程

    1.21 地址规划

    • PC1:192.168.100.1/24
    • PC2:192.168.100.3/24
    • Server:16.16.16.233/24

    1.22 R1的配置

    <Huawei> system-view
    [Huawei] sysname R1
    [R1] interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/0] ip address 192.168.100.254 24
    [R1-GigabitEthernet0/0/0] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] ip address 16.16.16.8 24
    [R1-GigabitEthernet0/0/1] quit
    [R1] nat address-group 1 16.16.16.9 16.16.16.16                     //创建地址池(由于16.16.16.8已使用,顺延)
    [R1] acl 2000
    [R1-acl-basic-2000] rule 5 permit source 192.168.100.0 0.0.0.255
    [R1-acl-basic-2000] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] nat outbound 2000 address-group 1 no-pat  //为出口网关应用NAT地址池
    [R1-GigabitEthernet0/0/1] quit
    

    提示:

    nat address-group命令用来配置NAT地址池,当然要预留至少一个IP用于路由设备与公网通信

    nat outbound命令用来将一个访问控制列表ACL和一个地址池关联起来,其表示ACL中规定的地址可以使用地址池进行NAT转换;

    no-pat 参数表示只转换数据报文的IP地址而不转换端口信息。


    1.23 实验验证

    首先,PC1能联通Server(16.16.16.233/24)。
    在这里插入图片描述

    其次,PC2能正常访问Server(16.16.16.233/24)的FTP服务。
    在这里插入图片描述

    在R1查看会话信息(display nat session all)。

    在这里插入图片描述

    以上测试结果得知,成功在路由器R1上配置动态NAT,内网可访问外网主机。

    2. 静态NAT

    2.1 实验要求

    在这里插入图片描述

    如图所示,某公司通过路由器R1接入到Internet,相关背景和需求如下。

    • 公司向ISP申请了2个公网IP:16.16.16.8和16.16.16.9。

    • 公司的FTP服务器需要以静态NAT方式对外提供服务,映射IP为16.16.16.9。

    2.2 操作过程

    2.21 地址规划

    • PC1:192.168.100.1/24
    • Server:192.168.100.2/24
    • Client:16.16.16.233/24

    2.22 R1的配置

    <Huawei> system-view
    [Huawei] sysname R1
    [R1] interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/0] ip address 192.168.100.254 24
    [R1-GigabitEthernet0/0/0] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] ip address 16.16.16.8 24
    [R1-GigabitEthernet0/0/1] nat static global 16.16.16.9 inside 192.168.100.2  //将Server映射出去
    [R1-GigabitEthernet0/0/1] quit
    

    2.23 实验验证

    首先,Client可以Ping通公司的公网地址(16.16.16.9/24)。

    在这里插入图片描述

    其次,Client通过公司的公网地址(16.16.16.9/24)访问公司内部服务器的FTP服务。

    在这里插入图片描述

    最后,在R1上查看NAT会话信息(display nat session all)。

    在这里插入图片描述

    以上测试结果得知,成功在路由器R1上配置静态NAT,实现FTP服务器的私网地址192.168.100.2与公网地址16.16.16.9的映射。

    3. NAPT

    3.1 实验要求

    在这里插入图片描述

    某公司通过动态NAT实现了内网主机和公网之间的通信,但随着公司员工的不断增加,有限的公网IP地址已不能满足所有员工上网需求,公司希望采用NAPT来解决更多员工的外网接入需求。

    3.2 操作过程

    3.21 地址规划

    • PC1:192.168.100.1/24
    • PC3:192.168.100.4/24
    • Client:16.16.16.233/24

    3.22 R1的配置

    <Huawei> system-view
    [Huawei] sysname R1
    [R1] interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/0] ip address 192.168.100.254 24
    [R1-GigabitEthernet0/0/0] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] ip address 16.16.16.8 24
    [R1-GigabitEthernet0/0/1] quit
    [R1] nat address-group 1 16.16.16.9 16.16.16.16             //创建地址池(由于16.16.16.8已使用,顺延)
    [R1] acl 2000
    [R1-acl-basic-2000] rule 5 permit source 192.168.100.0 0.0.0.255
    [R1-acl-basic-2000] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] nat outbound 2000 address-group 1 //为出口网关应用NAPT地址池
    [R1-GigabitEthernet0/0/1] quit
    

    提示:命令中no-pat参数的表示为NAPT

    3.23 实验验证

    首先,分别在企业内网主机PC1、PC3中执行ping 16.16.16.233命令,测试内网主机与外网的连通性。

    结果如下图所示,成功连接外网。

    在这里插入图片描述
    在这里插入图片描述

    可以看出,一个公网IP地址可以为多个私网IP提供NAPT服务,解决了更多内网终端连接外网的问题。

    其次,在R1上查看NAT会话信息(display nat session all)。

    在这里插入图片描述

    从以上信息得知,PC1和PC3的两个私网IP地址同时映射同一个公网IP地址,只是映射了不同的端口号。

    4. Easy IP

    4.1 实验要求

    在这里插入图片描述
    某公司通过拨号接入Internet,并申请到一个固定公网IP:16.16.16.8;且公司要求使用Easy IP技术实现全部内网计算机快速访问Internet。

    4.2 操作过程

    4.21 地址规划

    • PC1:192.168.100.1/24
    • PC3:192.168.100.4/24
    • Client:16.16.16.233/24

    4.22 R1的配置

    <Huawei> system-view
    [Huawei] sysname R1
    [R1] interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/0] ip address 192.168.100.254 24
    [R1-GigabitEthernet0/0/0] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] ip address 16.16.16.8 24
    [R1-GigabitEthernet0/0/1] quit
    [R1] acl 2000
    [R1-acl-basic-2000] rule 5 permit source 192.168.100.0 0.0.0.255
    [R1-acl-basic-2000] quit
    [R1] interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/1] nat outbound 2000  //为出口应用Easy IP模式
    [R1-GigabitEthernet0/0/1] quit
    

    提示:

    Easy IP技术是对NAPT技术的简化,因为Easy IP只会用到一个公有IP地址,所以它无需建立公有IP地址地址池,用于转换的公网IP就是该路由器接口的IP地址。

    即在本例中,nat outbound 2000表示对ACL 2000定义的地址段进行转换,并直接使用G0/0/0口的IP地址作为输出(Easy IP)地址。

    4.23 实验验证

    首先,在私网主机PC1PC3中,执行ping 16.16.16.233命令,测试内网主机与外网的连通性。

    结果如下所示,成功连接外网。

    在这里插入图片描述

    在这里插入图片描述

    其次,在R1上查看NAT出口信息(display nat outbound)。

    在这里插入图片描述

    Address-group/IP/InterfaceType表项信息得知,接口和ACL 2000允许的私网网段192.168.100.0/24已关联,且 Easy IP已配置成功。


    在这里插入图片描述

    展开全文
  • 描述:华为网络设备查看设备温度检查命令方法 命令: display device temperature all

    描述:华为网络设备查看设备温度检查命令方法
    命令:

    display device temperature all
    
    展开全文
  • 华为网络设备-Telnet实验

    千次阅读 2021-01-27 09:01:13
    华为网络设备 - Telnet实验 作者:杨佳佳 文章目录实验介绍实验目标实验配置实验验证任务总结 实验介绍 1、在路由器上配置Telnet,使交换机能够远程登录路由器进行操作。 2、Telnet提供了一个交互式操作界面,允许...

    华为网络设备-Telnet实验

    作者: 杨佳佳    排版: 赖裕鑫    审核: 蔡宗唐



    实验介绍

    1、在路由器上配置Telnet,使交换机能够远程登录路由器进行操作。

    2、Telnet提供了一个交互式操作界面,允许终端远程登录到任何可以充当 Telnet服务器的设备。Telnet用户可以像通过Console口本地登录一样对 设备进行操作。远端Telnet服务器和终端之间无需直连,只需保证两者 之间可以互相通信即可。通过使用Telnet,用户可以方便的实现对设备 进行远程管理和维护。

    3、Telnet以客户端/服务器模式运行。Telnet基于TCP协议,服务器端口号 默认是23,服务器通过该端口与客户端建立Telnet连接.

    实验目标

    • 掌握telnet的配置方法

    • 实现在交换机上用telnet登录路由器

    实验拓扑图
    在这里插入图片描述

    实验配置

    配置思路

    • 在交换机的vlan 1上配置IP
    • 在路由器的接口上配置IP、配置虚拟接口

    配置脚本

    • 交换机的配置脚本:
    #LSW1 
    
    <Huawei> sys                                            #进入系统视图模式        
    [Huawei] sysname LSW1                                   #修改名字为LSW1
    [LSW1] display current-configuration interface Vlanif 1 #查看vlan 1的配置
    [LSW1] interface Vlanif 1                               #进入vlan 1
    [LSW1-Vlanif1] ip add 10.1.1.1 24                       #设置ip地址
    [LSW1-Vlanif1] quit                                     # 退出
    [LSW1] aaa                     #进入aaa配置视图,公有的认证、授权、审计 的协议
    [LSW1-aaa] local-user huawei password cipher huawei  #创建一个本地用户huawei 密码是huawei                    
    [LSW1-aaa] local-user huawei privilege level 15      #给这个用户权限等级15最高的                    
    [LSW1-aaa] local-user huawei service-type telnet     #代表的创建huawei用来做telnet服务的                                                                                     
    [LSW1-aaa] quit                                      # 退出
    [LSW1] user-interface vty 0 4                        #进入VTY0~VTY4用户界面视图
    [LSW1-ui-vty0-4] authentication-mode aaa             #配置VTY类型用户界面的验证方式AAA
    [LSW1-ui-vty0-4] quit                                # 退出
    
    
    
    
    
    • 路由器的配置脚本:
    #AR1 
    
    <Huawei> sys                                    #进入系统视图模式        
    [Huawei] sysname AR1                            #修改名字为AR1
    [AR1] display current-configuration interface g0/0/0   #查看g0/0/0的接口配置
    [AR1] int g0/0/0                                #进入g0/0/0
    [AR1-GigabitEthernet0/0/0] ip add 10.1.1.2 24   #设置ip地址
    [AR1-GigabitEthernet0/0/0] quit                 #退出
    [AR1] user-interface vty 0 4                    #进入VTY0~VTY4用户界面视图
    [AR1-ui-vty0-4] authentication-mode password 
              # 认证模式有两种aaa、password 这里要求是密码模式(回车后输入密码huawei)
    [AR1-ui-vty0-4] user privilege level 15         #给这个用户权限等级15最高的
    [AR1-ui-vty0-4] quit                            #退出
    
    

    在模拟器eNSP上的配置:

    • 交换机的配置:
      在这里插入图片描述

    • 路由器上的配置:
      在这里插入图片描述

    实验验证

    • AR1能ping通LSW1
      在这里插入图片描述

    • LSW1能ping通AR1

    在这里插入图片描述

    • 路由器退到用户视图模式下telnet测试**
      在这里插入图片描述

    • 路由器退到用户视图模式下telnet测试

    在这里插入图片描述

    任务总结

    虽然Telnet较为简单实用也很方便,但是在格外注重安全的现代网络技术中,Telnet并不被重用。原因在于Telnet是一个明文传送协议,它将用户的所有内容,包括用户名和密码都明文在互联网上传送,具有一定的安全隐患,因此许多服务器都会选择禁用Telnet服务。如果我们要使用Telnet的远程登录,使用前应在远端服务器上检查并设置允许Telnet服务的功能。


    在这里插入图片描述

    展开全文
  • 华为网络设备查看风扇状态命令

    千次阅读 2020-11-14 09:21:59
    描述:华为网络设备查看风扇状态命令 命令:  show fan

    描述:华为网络设备查看风扇状态命令
    命令:

    display  device  fan
    
    展开全文
  • 华为网络设备的配置与管理教学系列文章 第二章—— 单臂路由的配置示例 作者:杨佳佳 华为网络设备的配置与管理教学系列文章: 第一章 利用三层交换机实现VLAN之间的路由配置实例 第二章 单臂路由的配置示例 文章...
  • 华为网络设备基本配置

    千次阅读 2019-09-18 07:42:23
    (一)华为网络设备的链路聚合的相关概念总揽。1、链路聚合是什么? 2、成员接口有什么限制?3、链路聚合的工作模式有哪些?4、活动接口与非活动接口的概念。5、主动端与被动端的概念。6、负载均衡模式有哪几种? ...
  • 描述:华为网络设备交换机路由器查看路由表情况命令方法 命令: display ip routing-table
  • 描述:华为网络设备交换机路由器查看日志命令方法 命令: display logbuffer
  • 描述:华为网络设备查看风扇状态电源状态检查命令 命令: display device fan
  • 华为网络设备-OSPF路由实验

    千次阅读 2021-01-28 10:41:50
    华为网络设备 - OSPF路由实验 作者:江泽明 文章目录OSPF简介实验拓扑实验背景IP规划配置思路实验步骤任务总结 OSPF简介 路由协议OSPF全称为Open Shortest Path First,也就开放的最短路径优先协议,因为OSPF是由...
  • 华为网络设备-DHCP基础配置实验

    千次阅读 2021-02-01 15:16:12
    华为网络设备-DHCP基础配置实验 作者: 梁文婷    排版: 赖裕鑫    审核: 蔡宗唐 文章目录实验拓扑实验目的DHCP介绍实验背景实验配置实验验证 实验拓扑 实验目的 掌握DHCP接口...
  • 华为网络设备-生成树协议配置

    千次阅读 2021-01-28 14:08:28
    华为网络设备-生成树协议配置 作者:郑伟钦 文章目录原理概述实验目的实验内容实验拓扑图实验步骤基本配置根交换机的选举原则配置拓扑图中的根交换机理解根端口的选举理解指定端口与备份端口的选举 原理概述 STP...
  • 描述:华为网络设备交换机路由器查看OSPF状态检查命令方法 命令: dispaly ospfv3 peer
  • 描述:华为网络设备交换机路由器查看用户配置命令 命令: system #进入系统视图 aaa #进入3A模式 display this #查看用户配置
  • 描述:华为网络设备交换机路由器查看ARP表项命令方法 命令: display arp
  • 华为网络设备的配置与管理教学系列文章 第一章—— 利用三层交换机实现VLAN之间的路由配置实例 作者:何嘉愉 华为网络设备的配置与管理教学系列文章: 第一章 利用三层交换机实现VLAN之间的路由配置实例 第二章 锐捷...
  • 华为网络设备-访问控制列表配置实验 作者: 赖裕鑫    排版: 赖裕鑫    审核: 蔡宗唐 文章目录实验介绍实验目的实验拓扑实验思路操作步骤实验验证任务总结 实验介绍 访问控制列表...
  • 描述:华为网络设备交换机路由器查看BGP状态检查命令方法 命令: display bgp all summary
  • 描述:华为网络设备CPU和内存占用率检查命令方法 方法: display cpu display memory
  • 描述:华为网络设备交换机路由器查看MAC地址表项命令方法 命令: display mac-address summary
  • 描述:华为网络设备交换机路由器查看VRRP状态检查命令方法 命令: display vrrp
  • 描述:华为网络设备交换机路由器查看系统时间检查命令方法 命令: display clock
  • 描述:华为网络设备交换机路由器查看光模块状态命令方法 命令: display interface transceiver verbose
  • 描述:华为网络设备交换机路由器查看NTP状态检查命令方法 命令: display ntp status
  • 华为网络设备介绍及基础配置命令

    千次阅读 2019-09-18 07:42:21
    二、华为网络设备的操作系统:VRP 三、华为网络设备的模拟器及基础配置命令 一、华为产品分类: 目前华为网络产品有路由器、交换机、防火墙。 1、路由器 路由器主要分为AR系列和NE系列: AR系列路由器:AR系列是...
  • 描述:华为网络设备交换机路由器查看告警信息命令方法 命令: show logging alarm
  • 描述:华为网络设备交换机路由器查看堆叠状态检查命令方法 命令: display stack
  • 华为网络设备与基础配置

    千次阅读 2019-10-26 16:05:56
    华为网络设备与Cisco的网络设备原理上大致都是一样。不同就是华为有很多的私有的技术。有学过Cisco的网络设备,当然学习华为也不是什么费事的事情。目前很多企业的网络部署都是混合部署,就是多厂商设备混合使用。...
  • 描述:华为网络设备查看单板状态检查引擎板冗余状态检查命令 命令: display device

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 49,465
精华内容 19,786
关键字:

华为网络设备