精华内容
下载资源
问答
  • 思科三层交换机
    万次阅读 多人点赞
    2020-01-22 16:53:01

    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?

    在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省网络设备的性能,另外图形界面,也方便查看。

    业务需求:
    将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段
    人事部、财务部、生产部、采购部分别属于VLAN10、VLAN20、VLAN30、VLAN40
    VLAN10: 192.168.10.0/24       网关:192.168.10.1
    VLAN20: 192.168.20.0/24       网关:192.168.20.1
    VLAN30: 192.168.30.0/24       网关:192.168.30.1
    VLAN40: 192.168.40.0/24       网关:192.168.40.1
    注意:创建DHCP地址池要将网关地址做排除。Switch5和Switch8的F0/4端口已经被管理性关闭了,开启的话会使SW0/SW5/SW8产生网络回路,引起网络风暴,下一篇博客我会写打开这个端口而如何避免这样的问题。

     

    网络拓扑:

    网络配置:

    Switch5:
    SW5#conf t
    SW5(config)#vlan 10					        //创建两个VLAN
    SW5(config-vlan)#vlan 20
    SW5(config-vlan)#int f0/2					//给端口分别划分VLAN
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 10
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/3
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/1					        //设置端口为trunk模式
    SW5(config-if)#switchport mode trunk
    SW5(config-if)#switchport trunk allowed vlan 10,20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    
    Switch8:
    SW8#conf t
    SW8(config)#vlan 30
    SW8(config-vlan)#vlan 40
    SW8(config-vlan)#int f0/2
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 30
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/3
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/1
    SW8(config-if)#switchport mode trunk
    SW8(config-if)#switchport trunk allowed vlan 30,40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    
    Switch0
    SW0#conf t
    SW0(config)#vlan 10					//创建4个VLAN
    SW0(config-vlan)#vlan 20
    SW0(config-vlan)#vlan 30
    SW0(config-vlan)#vlan 40
    SW0(config-vlan)#int f0/1
    SW0(config-if)#switchport mode trunk			//设置端口1为trunk模式,允许VLAN10,20,30,40的流量通过
    SW0(config-if)#switchport trunk allowed vlan 10,20,30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/2
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 10,20
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/3
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    
    Multilayer Switch2
    SW2#conf t
    SW2(config)#vlan 10						//创建4个VLAN
    SW2(config-vlan)#vlan 20
    SW2(config-vlan)#vlan 30
    SW2(config-vlan)#vlan 40
    SW2(config-vlan)#int f0/1					//设置f0/1的端口模式
    SW2(config-if)#switchport trunk allowed vlan 10,20,30,40	//三层交换机不用先配置为trunk模式
    SW2(config-if)#exit
    SW2(config)#ip dhcp excluded-address 192.168.10.1		//对DHCP地址池地址做排除
    SW2(config)#ip dhcp excluded-address 192.168.20.1
    SW2(config)#ip dhcp excluded-address 192.168.30.1
    SW2(config)#ip dhcp excluded-address 192.168.40.1
    SW2(config)#int vlan 10						//设置VLAN10的IP地址。三层交换机与路由器的不同之处,不能用单臂路由,划分子端口,所以用此方法分别设置VLAN的地址作为每个DHCP地址池的网关地址
    SW2(config-if)#ip address 192.168.10.1 255.255.255.0
    SW2(config-if)#ip routing					//开启VLAN间路由的功能
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 10					//创建DHCP地址池10
    SW2(config-dhcp)#network 192.168.10.0 255.255.255.0		//设置DHCP地址池网段
    SW2(config-dhcp)#default-router 192.168.10.1			//设置默认网关地址。这里设置为VLAN10的IP地址,所有VLAN10的主机通过这个网关地址获取IP
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 20						
    SW2(config-if)#ip address 192.168.20.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 20					//创建DHCP地址池20
    SW2(config-dhcp)#network 192.168.20.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.20.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 30
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 30					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.30.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.30.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 40
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 40					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.40.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.40.1
    SW2(config-dhcp)#exit

    本文原创,转载请注明出处。

     

    更多相关内容
  • cisco三层交换机怎么设置实现vlan间的通讯?层交换机是不能实现vlan间通讯的,这就需要三层路由功能,而3560默认情况下是二层交换机,这就需要多交换机进行一些配置,实现vlan间的通讯,下面通过具体实验对其进行...
  • Cisco三层交换机的详细配置

    万次阅读 多人点赞 2021-04-08 17:01:58
    使用到的机器型号为:五台电脑,一台服务器,三个普通交换机(2960型号),一个三层交换机(3560-24PS),两台普通服务器(2811) 文章目录一、什么是三层交换机二、配置交换机步骤1.配置二层交换机2.配置三层交换机...

    **

    本文适用于新手小白以及微微基础的同学来用于参考,实验是在Cisco Packet Tracer Student 进行,实验最终效果如图所示,所有命令配置与图中的一致。

    效果图

    使用到的机器型号为:五台电脑,一台服务器,三个普通交换机(2960型号),一个三层交换机(3560-24PS),两台普通服务器(2811)


    一、什么是三层交换机

    1.三层交换机 = 三层路由+二层交换机
    2.工作在OSI网络标准模型的第三层:网络层。
    3.特点:一次路由,多次转发。
    4.作用:三层交换机的作用是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的

    二、配置交换机步骤

    1.配置二层交换机

    按照要求,我们首先需要配置好三个交换机的五个VLAN区域,方便后续通信,还需将F0/2配置为turnk端口。第一台交换机具体命令如下:

    第一台交换机:
    en //进入特权模式
    conf t //进入全局模式 
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //创建五个vlan区域
    exit //退出
    int f0/1 //进入F0/1
    switchport access vlan 10 //将F0/1划分为VLAN 10
    int f0/3
    switchport access vlan 20 //将F0/3划分为VLAN 20
    int f0/2
    switchport mode trunk //将F0/2配置为trunk端口,为交换机与服务器之间的相联
    
    第二台交换机:
    en
    conf t
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //创建五个vlan区域
    exit //退出
    int f0/1 //进入F0/1
    switchport access vlan 30 //将F0/1划分为VLAN 30
    int f0/3
    switchport access vlan 40 //将F0/3划分为VLAN 40
    int f0/2
    switchport mode trunk //将F0/2配置为trunk端口,为交换机与服务器之间的相联
    
    第三台交换机
    en
    conf t
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //创建五个vlan区域
    exit //退出
    int f0/1 //进入F0/1
    switchport access vlan 50 //将F0/1划分为VLAN 10
    int f0/2
    switchport mode trunk //将F0/2配置为trunk端口,为交换机与服务器之间的相联
    

    至此,三台交换机配置完毕,我们开始三层交换机的配置

    2.配置三层交换机

    这台三层交换机的配置有些繁琐,但我们只要掌握其中的思路,剩下的只是重复的配置。具体命令如下:

    en
    conf t 
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //配置vlan
    exit
    //配置vlan的ip,后续作为各vlan的网关,方便DHCP的ip下发,以及数据上行。
    int vlan10
    ip address 10.1.1.254 255.255.255.0
    int vlan20
    ip address 10.1.2.254 255.255.255.0
    int vlan30
    ip address 10.1.3.254 255.255.255.0
    int vlan40
    ip address 10.1.4.254 255.255.255.0
    int vlan50
    ip address 10.1.5.254 255.255.255.0 //至此vlan的IP地址设置完毕,设置途中可能会出现错误,确认命令无误后回车再写一遍命令就好了。
    
    //设置F0/1,F0/2,F0/4为turnk口
    int f0/1
    switchport trunk encapsulation dot1q //这一步的命令为确认端口协议为802.1Q 三层交换机有两个协议,一个是ISL,另一个就是802.Q1,配置前需要指定协议。
    switchport mode trunk 
    f0/2与f0/3同理,此处省略。
    
    配置DHCP服务器
    ip dhcp excluded-address 10.1.1.1 10.1.1.99 //保留1-99的IP地址不做分配
    ip dhcp pool v10 //配置DHCP地址池名字为v10
    network 10.1.1.0 255.255.255.0 //配置地址池网段
    default-router 10.1.1.254 //配置网关,(这就与前面配的vlan10的IP地址对应上了)
    dns-server 10.1.5.1 //dns服务器
    
    ip dhcp excluded-address 10.1.2.1 10.1.2.99 //保留1-99的IP地址不做分配
    ip dhcp pool v20 //配置DHCP地址池名字为v20
    network 10.1.2.0 255.255.255.0 //配置地址池网段
    default-router 10.1.2.254 //配置网关,(这就与前面配的vlan10的IP地址对应上了)
    dns-server 10.1.5.1 //dns服务器
    这里vlan10和vlan20区域的DHCP就配置好了,我们还需要按照此步骤配置vlan30,vlan40
    vlan50则不需要配置,因为vlan50里面是服务器,而服务器的IP是固定的,所以不需要DHCP来分配IP。 
    
    Switch(config)# ip routing 在三层交换机启动路由功能。
    
    配置好这步后,点击所在vlan10的计算机,点击IP配置,DHCP,好的,你已经成功一半了。
    接下来在打开计算机中的CMD ping一下其他计算机的IP,等待回包后。你已经成功四分之三了
    
    
    
    
    

    这步可以说是灵魂所在,有点复杂,但绝对正确,一遍不明白就多思考配制几遍,命令是壳,思想是核。对了,一定别忘了配置后启动三层交换机路由转发功能,这是总闸。


    3.配置两台路由器以及最后一台电脑

    这里考查的就是路由器的配置,以及三层交换机上的F0/3口的配置。就差这一嘚瑟了。

    1.按照要求,先配置最后一台电脑的固定IP。进入电脑——IP配置
    在这里插入图片描述
    接来下我们开始配置的第一台路由器
    在这里插入图片描述

    首先配置F0/0
    Router(config)#int f0/0
    Router(config-if)#ip ad
    Router(config-if)#ip address 80.1.1.254 255.255.255.0
    Router(config-if)#no sh //重启F0/1口
    
    配置F0/1
    Router(config-if)#int f0/1
    Router(config-if)#ip address 70.1.1.2 255.255.255.0
    Router(config-if)#no sh
    
    接下来设置目标网段以及下一跳转的路由器
    由于我们没有目标网段,所以设置为0网段
    Router(config)#ip route 0.0.0.0 0.0.0.0 70.1.1.1
    第一台路由配置完毕
    

    接来下我们开始配置的第二台路由器
    在这里插入图片描述

    Router(config)#int f0/1
    Router(config-if)#ip address 70.1.1.1 255.255.255.0
    Router(config-if)#no sh
    
    Router(config)#int f0/0
    Router(config-if)#ip address 60.1.1.2 255.255.255.0
    Router(config-if)#no sh
    设置双向目标地址以及下一跳转的路由器IP
    ip route 80.1.1.0 255.255.255.0 70.1.1.2
    ip route 0.0.0.0 0.0.0.0 60.1.1.1
    
    

    最后一步,设置三层交换机上的F0/3口

    首先将二层端口升级为三层端口,否则二层配置不了IP地址
    Switch(config)#int f0/3
    Switch(config-if)#no switchport 
    Switch(config-if)#ip address 60.1.1.1 255.255.255.0
    Switch(config-if)#exit
    配置好IP地址后,由于与目标IP中间有两个路由器,所以需要在路由表中
    写入两台路由的网段
    Switch(config)#ip route 80.1.1.0 255.255.255.0 60.1.1.2
    Switch(config)#ip route 70.1.1.0 255.255.255.0 60.1.1.2
    
    

    实验结束
    结果:实现全网互通。

    展开全文
  • Cisco三层交换机链路聚合配置应用实例!!!!
  • 普通交换机工作在链路层,即二层交换机,无路由功能,也就是只能同一个网段的机器才能通信,现以思科3550交换机为例配置三层路由功能
  • 配置要求:1.完成设备名称和IP地址等的设置。2.完成telnet线路配置使管理终端能够远程访问所有网络设备。...3.按图示完成端口汇聚设置。...S1、B1为服务器模式,其他设备为...6.指定S1为所有VLAN的根交换机,并确保B1-B...

    配置要求:

    1.完成设备名称和IP地址等的设置。

    2.完成telnet线路配置使管理终端能够远程访问所有网络设备。远程访问密码为:123456,enable密码为1234。

    3.按图示完成端口汇聚设置。

    4.建立VTP域,域名mydomain1,密码111111。S1、B1为服务器模式,其他设备为客户端模式。(暂不配置)

    5.按图示完成VLAN及端口配置。

    6.指定S1为所有VLAN的根交换机,并确保B1-B2、B3-B4间链路处于阻断状态。(咱不配置)

    7.实现VLAN间的通信,确保各培训部间终端能够ping通。

    拓扑结构

    企业网络典型组网拓扑图

    设备配置

    (1)为每台PC和Server配置IP地址、子网掩码和网关(网关为interface vlan X 的ip地址)

    网关用于实现设备之间的三层通信,即路由,默认网关可先不填,因为还没有配置逻辑接口vlan的ip地址;也可以先填写,一般网关地址都为x.x.x.254,这里可以先写上192.168.2.254,后面再进行配置,其他PC配置略。

    配置PC的ip地址、子网掩码以及默认网关

    (2)为每台网络设备配置管理IP,配置命令如下,其他配置略:

    Switch>enable

    Switch#configure terminal

    #进入逻辑vlan接口1

    Switch(config)#interface vlan 1

    #配置ip地址,用于远程管理telnet登录使用

    Switch(config-if)#ip address 192.168.1.3 255.255.255.0

    #激活逻辑端口

    Switch(config-if)#no shutdown(用于激活接口,必须)

    网络设备管理地址配置

    (3)完成telnet线路配置

    #进入特权模式

    Switch>enable

    #进入配置模式

    Switch#configure terminal

    #配置进入到路由器特权模式的密码

    Switch(config)#enable password 1234

    #进入路由器的 VTY 虚拟终端下,“vty 0”表示用户连接数,共1个虚拟终端

    Switch(config)#line vty 0

    #配置 vty 的密码,即 telnet 密码

    Switch(config-line)#password 123456

    Switch(config-line)#login

    Switch(config-line)#end

    telnet线路配置

    其中 enable password 1234,用于配置进入特权模式所需要的密码

    password 123456,用于配置telnet管理员的远程登录密码

    配置完成后使用管理终端进行telnet连接,如图所示

    使用终端远程登录网络设备

    其他设备telnet配置略

    (4)端口汇聚配置

    构成EtherChannel的端口必须具有相同的特性,如双工模式、速度、Trunking的状态等。

    在两台三层交换机上分别配置链路聚合:

    Switch>enable

    Switch#configure terminal

    #创建以太通道,要指定一个唯一的通道组号,组号的范围是1~6的正整数。要取消EtherChannel时用“no interface port-channel 1”

    Switch(config)#interface port-channel 1

    Switch(config-if)#exit

    #进入端口21-22

    Switch(config)#interface range fastEthernet 0/21-22

    #将物理接口指定到已创建的通道中。

    Switch(config-if-range)#channel-group 1 mode desirable

    Switch(config-if-range)#no shutdown

    Switch(config-if-range)#end

    Switch#write

    3560交换机链路聚合配置

    配置完成后,使用show etherchannel summary命令,查看链路聚合配置情况

    查看链路聚合结果

    (5)trunk模式配置

    根据拓扑结构,在每台交换机上分别将用于连接网络设备的端口改为trunk模式。

    2960配置命令如下:

    配置二层交换机之间互连的端口为trunk类型

    Switch>enable

    Switch#configure terminal

    Switch(config)#interface fastEthernet 0/24

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    2960二层交换机trunk口配置

    对于3560三层交换机,需要将封装类型改为dot1q,再将端口类型设置为trunk,配置如下:

    Switch>enable

    Switch#configure terminal

    Switch(config)#interface f0/1

    #配置 trunk 链路的封装类型,同一链路的两端封装要相同。有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    Switch(config)#interface f0/2

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    #同时对于链路聚合的port-channel 1 也要设置为trunk模式,配置通道中的物理接口的属性

    Switch(config)#interface port-channel 1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    #另外一台3560交换机trunk模式配置相同

    3560三层交换机trunk口配置

    (6)VLAN配置

    在4个二层交换机上配置相应VLAN

    #创建VLAN2,VLAN3

    Switch(config)#vlan 2

    Switch(config-vlan)#vlan 3

    Switch#configure terminal

    Switch(config)#interface range f0/1-8

    #将接口f0/1-8划分到vlan2中,把交换机端口的模式改为 access 模式,说明该端口是用于连接计算机的,而不是用于 trunk

    Switch(config-if-range)#switchport access vlan 2

    Switch(config)#interface range f0/9-16

    #将接口f0/9-16划分到vlan3中

    Switch(config-if-range)#switchport access vlan 3

    对接入层交换机进行VLAN划分

    (7)单臂路由配置

    不同VLAN之间的通信,需要借助第三层设备,二层设备无法实现不同VLAN间的通信,可以选择路由器,三层交换机,本实验使用三层交换机进行实现,方法类似于华为设备中的VLANIF实现方式,配置逻辑接口VLAN,不同的VLAN对应配置不同的逻辑接口interface vlan x,并在接口下配置ip地址及子网掩码,此ip地址就是前文中提到的各终端设备的默认网关,对于不同VLAN中的终端设备,默认网关设置对应逻辑vlan中的ip地址即可实现三层交换机的路由功能。

    在S1交换机上创建单臂路由,配置命令如下:

    #在其中一台三层交换机S1上创建vlan即可,无需两台设备都配置,即一台作为路由器使用,另一台仍作为交换机使用

    Switch(config)#vlan 2

    Switch(config-vlan)#vlan 3

    Switch(config-vlan)#vlan 4

    Switch(config-vlan)#vlan 5

    Switch(config-vlan)#exit

    #开启三层交换机路由模式

    Switch(config)#ip routing

    #创建对应的逻辑接口vlan x

    Switch(config)#interface vlan 2

    #配置接口的IP地址及子网掩码

    Switch(config-if)#ip address 192.168.2.254 255.255.255.0

    #激活逻辑接口

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 3

    Switch(config-if)#ip address 192.168.3.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 4

    Switch(config-if)#ip address 192.168.4.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 5

    Switch(config-if)#ip address 192.168.5.254 255.255.255.0

    Switch(config-if)#no shutdown

    配置单臂路由

    若按照题目中要求,运行部内部电脑能够跨交换机通信,运行部和检修部之间无法ping通,信息培训部和通信培训部之间能够ping通,那么只需要将3560S1三层交换机中允许vlan2,3,4,5通过、并配置interface vlan 4 和 interface vlan 5 的ip地址即可,无需配置interface vlan2 和interface vlan 3 的ip地址(若配置会导致运行部和检修部之间也能ping通,),3560S2三层交换机中配置允许 vlan4和vlan5通过即可。

    未完待续。。。

    展开全文
  • 由于期末在即,课程设计又是计科生的梦魇,所以我快马加鞭写了这篇三层交换机vlan划分的实验报告,希望能给那些和我一样受课程设计困扰的同学一些建议和帮助。示例:相信这个结构的拓扑图大家都熟悉吧。 2、Switch1...

    系列文章目录

    提示:这里可以添加系列文章的所有文章的目录,目录需要自己手动添加


    提示:写完文章后,目录可以自动生成,如何生成可参考右边的帮助文档


    前言

    由于期末在即,课程设计又是计科生的梦魇,所以我快马加鞭写了这篇三层交换机vlan划分的实验报告,希望能给那些和我一样受课程设计困扰的同学一些建议和帮助。

    提示:以下是本篇文章正文内容,下面案例可供参考

    一、拓扑图

    示例:相信这个结构的拓扑图大家都熟悉吧。
    在这里插入图片描述

    二、Switch配置

    1、Switch0配置

    代码如下(示例):

    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    %SYS-5-CONFIG_I: Configured from console by console
    rker.
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#e
    Switch(config)#int f0/1
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#int f0/3
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#e
    Switch(config)#int f0/2
    Switch(config-if)#switchport mode trunk 
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
    
    该处使用的url网络请求的数据。
    
    下面展示一些 `内联代码片`。
    
    ```#
    

    2、Switch1配置

    //
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 20
    Switch(config-vlan)#e
    Switch(config)#int f0/3
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#int f0/2
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#int f0/1
    Switch(config-if)#switchport mode trunk 
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    
    
    
    

    3、三层Switch0配置

    // Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#vlan 20
    Switch(config-vlan)#e
    Switch(config)#ip routing
    Switch(config)#int vlan 10
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    
    Switch(config-if)#ip add
    Switch(config-if)#ip address 192.18.1.254 255.255.255.0
    Switch(config-if)#no shutdown 
    Switch(config-if)#int vlan 20
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    下面展示一些 `内联代码片`

    三、ping通试验

    1、pc0 ping pc2

    在这里插入图片描述

    2、pc2 ping pc3

    在这里插入图片描述

    提示:到这一步也全部ping通,实验的第一步也完成。关于DHCP获取ip的实验也可以加进来,前面也写过关于这一方面的实验。

    展开全文
  • 三层交换机还可作为路由器,需要先开启三层交换机的路由功能ip routing 三层交换机的基本配置 ip routing no shutdown 实验验证 网络拓扑图 配置端口0/1的ip地址和子网掩码 配置端口0/2的ip地址和子网...
  • 思科三层交换机配置步骤

    万次阅读 多人点赞 2020-04-08 13:34:09
    思科三层交换机配置图如下: 配置的过程如下: 首先,设置各个PC的ip地址,子网掩码,网关 设置完成之后,进行二层交换机的设置: 在三层交换机的配置实验中 二层交换机设置的主要是vlan的设置,vlan接口的设置和...
  • 网络环境:cisco三层交换机一台,分为三个vlan 。vlan2所在网络有一台服务器,配置为http和dns服务器,还有一台主机。vlan3和vlan4各有一台主机。实验要求:vlan3和vlan4不能相互访问,但是可以访问vlan2下面是...
  • CISCO三层交换机怎么配置DHCP服务?利用CISCO三层交换机自带的DHCP功能,可以实现多VLAN的IP地址自动分配,在三层交换机上如何配置DHCP服务呢,下面一起来看看
  • 三层交换机配置: Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#vlan 30 Switch(config-vlan)#vlan 40 Switch(config-vlan)#exit Switch...
  • 思科三层交换机实现不同VLAN间互相访问配置案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间提供路由,为了解决这一问题,就必须增加思科路由器或思科三层交换机之类的路由设备。我们这里选择增加一...
  • cisco 思科三层交换机配置命令

    千次阅读 2020-09-29 10:25:28
    1.交换机支持的命令 交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 ...
  • 思科 三层交换机 NAT转换 ACL 实验

    千次阅读 2020-07-29 23:20:13
    思科 三层交换机 NAT转换 ACL 实验 拓扑图 ACL要求: 1、允许pc0访问server1 禁止ping 2、禁止pc1 访问server1 允许ping 3、禁止server1 访问server0 先配置三层交换机 switch 0: vlan 10 int f0/2 sw mode acc sw ...
  • 思科三层交换机配置DHCP中继

    千次阅读 2022-06-07 15:19:27
    三层交换机配置DHCP中继 网络内配置了VLAN,VLAN能隔离广播,而DHCP协议使用广播,也就是说,默认情况下DHCP协议只能在VLAN内部使用。DHCP服务器在VLAN100中,就是要该VLAN内的客户机能从DHCP服务器哪里获取IP地址...
  • Cisco三层交换机实现vlan间路由的配置拓扑图: 一、配置要求如下: 本次测试使用cisco Packet Tracer7.0模拟器进行,请按照实验操作文件(pka)的要求完成配置任务。pka文件中的拓扑和设备命名均不许修改,终端和...
  • 三层交换机与路由器的比较在大型局域网中对掌握三层交换机很有帮助,但现在有些厂家的交换机也可以直接接Internet提供路由器功能,感兴趣的朋友可以了解下哈
  • 随着交换技术的发展,三层交换机在网络汇聚层与核心层的应用越来越多。在内网中子网与子网之间的通讯越来越少依赖于路由(几乎见不到了),而是使用带有路由功能的三层交换机,这对于内网中子网之间的通信效率的提高...
  • CISCO三层交换机+二层交换机配置VLAN的实例[文].pdf
  • 思科三层交换机配置步骤实例

    万次阅读 多人点赞 2020-06-14 16:21:18
    思科三层交换机配置步骤实例## 这篇文章适合新手看哟,文章有点长,细节有点细,嘻嘻,慢慢来,加油! 利用思科Packet Tracer 6.2组建如上图所示网络,并实现以下功能: 1.正确配置各设备端口IP地址。 2.将各部门...
  • Cisco 三层交换机与路由器ospf协议配置多区域area 分布操作:1.划分vlan 2.ospf、area 3.测试ping
  • 思科三层交换机实现vlan间路由拓扑图。使用Cisco Packet Tracer模拟器实现Cisco三层交换机实现Vlan间路由的配置脚本,内含每一步的详细操作及注释说明,包括配置接入层交换机、配置核心交换机、配置firewall路由器、...
  • 三层交换机链路聚合实验 一.实验内容 互联网结构如图所示,三层交换机S1和S2的端口3-5构成端口通道,这一对端口通道作为实现S1和S2互连的三层接口。三层交换机S1和S2的端口6-8构成端口通道,这一对端口通道构成三层...
  • Cisco三层交换机的配置详解

    万次阅读 多人点赞 2019-05-22 17:38:53
    那么使用单臂路由技术就显得有点力不从心了,这是我们就要引入三层交换机了。 现在大多数新型的catalyst交换机都支持CEF(Cisco快速转发)多层交换,CEF是一种基于拓扑的转发模型,可预先将所有的路由选择信息加入到...
  • ACL访问控制列表是构建安全规范的网络不可缺少的,但在三层交换机上配置ACL却不为一些刚进企业的初级网络管理维护人员所知。下面介绍一下在三层交换机上配置ACL的试验过程。 三层交换机上配置本地Vlan 实现下层接入...
  • 三层交换机和普通交换机简洁清晰的配置步骤。
  • 主要介绍了思科三层交换机配置命令,需要的朋友可以一起看看
  • 思科三层交换机VLAN配置 内部网络全部使用10.186.x.x网段,SW2和SW3两个交换机连接两个学院, Sw2学院有电脑500台,sw3学院有电脑200台,合理分配IP地址段,避免浪费, 两个学院可以互相访问,也可以访问内网的web ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 19,248
精华内容 7,699
关键字:

思科三层交换机

友情链接: gocron-master.zip