精华内容
下载资源
问答
  • 在中小企业中适应最多的交换技术就要属虚拟局域网了,虚拟局域网也称为VLAN技术,他可以让连接到同一台交换机的不同PC机处于不同网段中,互相无法访问,需要的朋友可以参考下
  • 虚拟局域网

    2018-12-26 20:38:04
    模拟虚拟局域网中帧的传输过程,完成简单图形界面。 实现内容包括:初始化交换机的转发表或者采用自学习算法获得。模拟在同一个交换机上同一虚拟局域网与不同局域网之间的帧传输过程。不同交换机上同一局域网的帧...
  • 构建VMware虚拟局域网实验操作1.新建虚拟机2 .VMware tools安装3.虚拟网络构建实验1:实现两个虚拟机相互通信。实验二:实现虚拟机和物理机的通信实验三:虚拟机连网实验注意事项 VMware软件的安装及要用到的操作...
  • 计算机网络实验与学习指导-基于Cisco Packet Tracert模拟器
  • 虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网
  • 虚拟局域网vlan的主要用途和作用,重点说明了主要好处
  • 实验二 虚拟局域网VLAN实验二 虚拟局域网VLAN
  • 域网的配置 实验目的 掌握交换机各种命令行操作模式的区别, 以及各模式间切换方法 掌握交换机的基本配置方法 掌握交换机系统和配置信息的査看方法, 获取交换机的当前工作状态 掌握交换机虚拟局域网的配置,跨交换 机...
  • VLAN是为解决以太网的广播问题和安全性而提出的,它在以太网帧的基础上增加了VLAN头,用VLAN ID把用户划分为更小的工作组,限制不同工作组间的用户二层互访,每个工作组就是一个虚拟局域网
  • 随着计算机网络技术的高速...在众多提高网络安全性的技术中,虚拟局域网技术得到了广泛的应用。文章通过介绍虚拟局域网技术构建的相关问题,分析了影响网络安全的因素,并进一步阐述了该技术对加强网络信息安全的作用。
  • YDT 1260-2003 基于端口的虚拟局域网(VLAN)技术要求和测试方法
  • 现为该学校构建一个局域网,使得该学校任意两台主机都可以互相通信,且教学、科研和行管三个部门处于独立的广播域,使得三个部门上传下达的广播信息相互隔离。(提示:使用4个交换机,其中包括1个三层交换机。) ...
  • 基于三层交换机的校园网构建论文, 很好的案例。
  • 软件学院 计算机网络 课程实验报告 20132014学年 第 二 学期 2013 级 软件工程 专业 班级 学号 实验三 虚拟局域网配置 一实验目的 1掌握二层和三层交换机的基本操作 2掌握VLAN的配置操作 二实验环境 1.华为ENSP...
  • 组建vlan虚拟局域网

    2018-10-25 18:53:54
    这个资源是课程资源,对学习有很大的帮助,希望各位同学能够好好珍惜
  • 计算机网络原理实验 实验项目 实验三 虚拟局域网VLAN划分与配置 实验类型 设计型 指导老师* 实验地点 网络实验室(2) 时间2013年11月21日14时至16时 实验目的: 了解vlan的作用掌握在一台交换机上划分 VLan的方法和跨...
  • 电气与信息工程学院计算机系 网络工程 实验报告 实验名称 虚拟局域网VLAN实验 班级 计 姓名 学号 组员 实验地点 实验3-209 日期 2012年 09月 10日 一实验目的 理解Port Vlan 的配置学会划分不同的Vlan通过Port Vlan...
  • 掌握跨交换机配置虚拟局域网的方法。使在同一个虚拟局域网的计算机能跨交换机互相通信,而在不同的虚拟局域网的计算机不能通信。
  • 本文从实践的角度出发,利用P2P直连技术,使用ZeroTier工具对多台主机设备进行虚拟局域网的组网配置,使得本来不在同一层网络的分布在网络中的多台主机在虚拟的新网卡中都处于同一层网络而不需要中继服务器,从而使...

    此文章涉及:
    Zerotier速度慢的解决办法
    Zerotier实际应用展示
    Zerotier简单实用教程

    技术背景

    在经过接近一个学期的互联网安全的学习,我接触到了网络的很多种攻击,渗透与防守的方式。从这个学习的过程中,我深刻的了解到,如果想要对网络主机进行渗透,首先要对网络结构运行的原理掌握的非常透彻,才能够从中找出攻击和防守的办法。网络上的攻防,主要是利用网络本身的特性与协议设计时的缺陷等来进行的。
    另外,从互联网安全的攻防的实践出发的话,主动防守的话如果没有攻击方的话看不出来效果,主动攻击的话,由于目前IPv4的地址池缺少等问题,大部分个人主机都处于路由器NAT的保护下,并不会对公网开放网络接口,因此主要的攻击手段主要为使用木马,病毒等方式感染目标机,令目标机主动接受控制指令。如果只使用单纯的网络攻击的话,目前大部分拥有公网IP的主机都是服务器。在没有向服务器管理人员取得渗透测试许可的话,直接对他人服务器进行渗透工作属于违法行为。因此直接在公网进行渗透,不仅可能有违法风险,同时服务器的安全措施一般来说都非常严密,很有可能无功而返。
    因此,本论文主要讨论搭建虚拟局域网的工作,一是可以为接下来的渗透测试工作可以穿过公网,有更好的借鉴意义,二是虚拟局域网本身就具有一定的实用性,如在宿舍或外出时使用虚拟局域网连接工作主机或NAS服务器,进行继续工作等。

    技术介绍

    虚拟局域网实质上是一种内网穿透,而内网穿透实际上是一个存在了很久的技术。但Zerotier和传统的内网穿透技术有着很大的不同。类似于FRP、Ngrok
    这样的反向代理程序,通过服务器转发数据来达到外网访问的目的,这样就需要自己有个
    VPS,或者使用他人搭建的服务,据我所知的免费服务都是限速的,要是自己搭建的话,体验就要看服务器的网络质量了。
    Zerotier在连接的过程,服务器不起到一个中转的作用,只是起到了一个认证的作用,其在工作的时候为每一台虚拟局域网设备做认证,如果有一台虚拟局域网内的主机打算访问另一台虚拟局域网内的主机的话,其会访问Zerotier的服务器,服务器获取两台主机的信息,并为他们做好自动的打洞,让主机双方可以拿到一个临时的公网IP,然后Zerotier服务器不再干涉后续的数据传输,两台主机实际上是P2P传输,可以达到很高的带宽,不受中转服务器的速度限制,也不吃中转服务器的带宽。
    需要注意的是,服务器为双方主机打通P2P通道需要网络环境协议的支持,如果存在某一方主机无法打洞获得临时公网地址,那么将无法建立P2P连接,Zerotier会作为传统的中继服务器为双方保持通信,这会导致网络质量的急速下降,我们在设计的时候应该要极力避免这种情况。

    环境搭建

    Zerotier支持多种平台,如Windows,Linux,Android和Mac。在这里我们使用最为常见的Windows平台做虚拟局域网的主要平台,需要在官网进行下载并安装。此时安装完毕后Zerotier将作为一个系统服务运行,同时会在网络适配器中增加Zerotier的虚拟网卡。在这个测试环境中我安装完成后的软件版本信息如下。注意所有需要加入虚拟局域网的主机设备都需要安装该软件。

    软件信息

    在软件安装完成后,我们需要创建一个属于自己的虚拟局域网。在创建之前我们先需要在官网创建我们的账号。创建账号的过程较为简单在此不再赘述。免费的账号可以允许局域网里面加入50台主机,对于个人而言是完全够用的。创建账号完成后我们需要为其创建一个虚拟局域网络。点击该软件右键,点击Zerotier
    Central即可进入账户的控制面板,点击上方的Network,点击Add
    Network,输入虚拟局域网的名称即可创建好一个虚拟局域网。

    进入中心

    在网络创建完成后,服务器会为这个网络分配一个网络ID,然后我们需要在我们的客户端右键中点击Join
    Network,输入我们刚刚创建的网络ID,就可以申请加入。如果我们在创建网络的时候选择认证方式为Public的话,那么网络就已经加入完成了。该网络可以由任何人加入,会缺少安全保障。因此大部分网络创建的时候是private形式的。如果是private形式的网络,我们还需要在刚刚的网络中心里点击刚刚创建的网络,在里面的控制面板中允许刚刚我们加入的主机的Noid
    ID,这样就可以控制局域网的私有性。

    网络环境优化

    由于前面所提到的,Zerotier是利用P2P连接,最大化提升虚拟局域网的带宽,因此,P2P的链接是否能够成功建立对网络环境的影响至关重要。可以在开始菜单右键,点击"命令提示符(管理员)"或是管理员权限的powershell打开一个系统终端,输入zerotier-cli
    peers
    查看虚拟局域网内各主机的链接状态,DIRECT说明是成功建立P2P链接的,如果出现RELAY或不能获取到对方主机的ip地址的话,这说明P2P并没有成功建立,当前由Zerotier在进行中继链接。如果发生了中继链接的话延迟会大大的提高,ping指令的延迟会达到1000ms以上,甚至超时,无法胜任虚拟局域网的大部分工作。以下是几种避免中继的方法:

    1. uPnP。Zerotier的P2P连接是通过uPnP协议来进行握手的。目前大部分路由器都会有upnp的选项,如果发生了连接中继,我们应该在所有的终端主机的路由器上确认upnp是否打开。

    2. NAT等级。路由器的NAT等级也会影响p2p连接穿透的效果,如果路由器的NAT使用的是Full
      Cone NAT,那么连接是最为可靠稳定的。如果发现当前所处的网络环境属于Symmetric
      NAT 的话,则基本是没有办法在IPv4上打洞的。

    3. IPv6。如果前面的网络环境都没有办法改善(如没有路由器网关的控制权限等),但主机可以拥有IPv6的话,可以试图使用IPv6来进行工作。由于IPv6的地址池庞大,且当前地址池可以允许全球拥有IPv6地址,所以使用IPv6来建立Zerotier连接,实际上是不需要穿透的,因为大家都可以互相获得IPv6的工作地址。如果要启用IPv6,需要确定路由器,ISP,以及自己的主机设备都要支持且开启IPv6相关服务。软件如果可以通过IPv6通信,会进行自动切换。

    4. 自建中转。如果上面的方式都无法成功的建立,只能使用RELAY方式的话,由于Zerotier的官方服务器在外国,中继延迟会十分的高,我们可以使用自定义Zerotier中转服务器来提高中转的效率,在直连的时候还可以提高P2P握手的效率。

    使用效果展示

    在搭建完成并建立P2P链接后,即可以使用最高性能的虚拟局域网进行业务通信了,下面将进行网络延迟,网络带宽,实际体验三方面进行展示。

    测试环境参数

    主机1:学校内宿舍电信网络主机,带宽100M,Windows环境,IP:192.168.191.3
    主机2:学校内教研室教育网教研室主机,带宽未知,Windows环境,IP:192.168.191.2

    延迟测试

    在命令提示符下使用指令ping 192.168.191.2 -t获得结果如下,以百度(www.baidu.com)的延迟测试作为对比。

    延迟效果

    在这里插入图片描述

    可以看到,P2P状态下,虚拟局域网的访问延迟还低于百度的延迟,由于百度有做CDN和负载均衡等网络加速,其基本代表外网访问延迟的较低者,P2P效果可以得到比外网低延迟还低的性能。

    网络带宽

    在Windows
    SMB共享文件系统下,主机1访问主机2的共享文件夹并复制一个压缩包,以平均文件传输速度判断带宽。

    文件传输速度

    可以看到文件的传输速度维持在3MB/s,相当于24Mbps宽带的速度,没有达到宿舍电信网络主机的最高性能,但优于绝大多数的中继式内网穿透服务。速度没有跑满的原因是可能教研室的网络负载较重,教研室主机分到的带宽不足所导致的。

    实际体验

    实际体验主要分为远程连接服务,远程虚拟机服务,以及局域网文件传输服务。由于局域网传输在网络带宽项进行了测试。因此主要测试前两项。
    远程连接服务:使用Windows自带的RDP协议远程连接,在使用前需要先配置好主机允许远程连接。日常使用基本感觉不到延迟,只有在看视频等显示画面变化幅度较快且变化画幅较大的时候偶尔会产生掉帧现象。

    远程连接

    远程虚拟机:教研室电脑作为虚拟机服务器,开放虚拟机访问权限,远程电脑可以通过ip地址连接服务器,并远程连接上该电脑里的虚拟机,不需要本机存放虚拟机。虚拟机远程运行后,日常操作基本感觉不到卡顿和延迟,可以识别本地机上的USB设备并连接到远程虚拟机上。

    远程虚拟机

    结束语

    经过对各台主机进行虚拟局域网的搭建,主机之间的通信效率大大提高,生产,工作更为方便,我们可以在任意一台主机上远程快速访问所有的虚拟局域网内的主机,访问各台电脑的共享文件夹
    在搭建的过程中,我们了解了P2P协议建立的各种方法,如uPnP,自建中继服务器,IPv6等相关知识,在实践过程中对这些协议有了更深入的了解。
    域网内的主机,访问各台电脑的共享文件夹
    在搭建的过程中,我们了解了P2P协议建立的各种方法,如uPnP,自建中继服务器,IPv6等相关知识,在实践过程中对这些协议有了更深入的了解。

    展开全文
  • 本文主要是关于使用ZeroTier创建虚拟局域网来实现免费远程桌面的方案的体验,包含了一些对不同方案的优缺点的描述。最近因为疫情在家不得不通过远程连接实验室电脑,有两种基本的解决方案:连接学校VPN,然后使用...

    本文主要是关于使用ZeroTier创建虚拟局域网来实现免费远程桌面的方案的体验,包含了一些对不同方案的优缺点的描述。

    最近因为疫情在家不得不通过远程连接实验室电脑,有两种基本的解决方案:

    1. 连接学校VPN,然后使用系统自带的远程桌面连接;
    2. 使用TeamViewer连接。

    由于学校VPN的速度太慢,造成远程桌面实在卡顿,因此我一般使用TeamViewer,个人版是免费的,连接速度也尚可。然而可能是白嫖过多的原因,TeamViewer不让我用了,说是检测到商业用途,申诉也无门。因此开始研究其他方案。网上很多人推荐的方案是AnyDesk,但是我这边实测连接非常卡顿,而且画质也差。还有一个国产同类软件是向日葵,我没试过。

    后来我找到的较为满意的方案是--ZeroTier. ZeroTier是一个虚拟网络解决方案,我们可以用它来创建一个虚拟局域网,让自己的不同设备都加入到这个虚拟局域网中(免费版最多可添加100台机器),然后就可以用分配的IP来直接用系统自带的远程桌面连接了。

    更新:蒲公英也可以创建虚拟局域网,实测效果和ZeroTier类似,但免费版限制的客户端个数较少,本文不再展开。

    具体操作步骤如下:

    前提:

    远程主机支持远程桌面连接(可以使用Windows自带的远程桌面连接或者NoMachine等)

    操作:

    1. 访问ZeroTier官网下载页面,下载并安装对应系统的客户端
    Download - ZeroTier​www.zerotier.com

    2. 创建并登录账户,转到ZeroTier Central中创建网络

    在网页中点击"Create a Network"就可以创建一个新网络,得到ID。

    v2-19b0b610bea315710c887b5af5818dec_b.jpg

    3. 在两台主机上打开ZeroTier One客户端,将ID输入到客户端中,加入网络

    以Windows为例,在任务栏托盘图标右击,选择"Join Network",在弹出的对话框中输入上一步获取的网络ID即可。

    17628922745442a23d1ca615ccdc21c8.png

    e96b1037c85e1bd24351ee48c2e7bd96.png

    操作完成后,上面第一张图对应位置会出现网络ID,前方打勾就代表加入该网络。

    4. 在网页端允许主机加入网络,查看分配给主机的IP

    在网页端点击刚刚创建的网络ID,就可以进入管理界面。找到Members一栏,把对应主机前打勾就行了。"Managed IP"就是分配的局域网IP。其他地方都可以不修改。

    7dea0468cf1bca4b7cbad3844f9fc90c.png

    5. 使用IP进行远程桌面连接

    以Windows为例,打开自带的“远程桌面连接”,输入局域网IP即可连接,按照要求输入用户名密码即可。

    55a4ca4955eee4b8f000e08dd7e74dd2.png

    实测通过这种方式连接的响应速度和画质均优于TeamViewer。主要原因应该是在可能的情况下,ZeroTier会建立P2P的连接,两台机器直接相连的速度当然快了。但是使用TeamViewer传输文件操作会比较简便,可以直接拖动。不过有了局域网之后挂载远程硬盘或者通过SFTP, SCP之类传输文件也很简单了,推荐使用XShell和XFTP.

    与VPN的解决方案相比,ZeroTier不仅速度快很多,而且由于创建了一个虚拟网卡,因此普通的网络连接不会受到影响,不像使用VPN之后所有流量都要发送到学校,使得上网速度明显变慢。

    此外,ZeroTier可以配置Moon节点作为中转来加速访问,如果发现连接速度不快的话可以试试。

    在使用中还发现一个问题,使用Windows自带的远程桌面软件进行连接,有时会出现整个远程桌面突然卡住不动的情况,或许是因为网络本身不够稳定。于是便想着换个软件。经过一番尝试之后发现,微软商店里的UWP版的远程桌面就没有这个问题。但还有一个小问题是,UWP版远程桌面在文本编辑模式下的鼠标颜色有问题导致对比度太低看不清,所以我手动调节了光标颜色就好了。在知乎上有看到人推荐mRemoteNG,但是我实际用起来发现它主要是一个远程桌面管理软件,对于多窗口之类的支持较好,但是连接的时候仍然是调用了系统自带的远程桌面。此外,还有人推荐NoMachine来进行连接,据说速度非常快,不过是需要额外安装软件的。然而我自己试了之后不知为何连接总是黑屏,我也没啥耐心去仔细研究,就暂且作罢了。

    总结一下,在网络条件合适的情况下,ZeroTier的P2P连接使得远程桌面体验较佳,不管是速度还是画质。而且正常使用也是完全免费的,用来连接自己的远程主机还是很舒服的。虽然略微比使用TeamViewer麻烦一点,但是也值得一试。当然,ZeroTier能做到的事不仅于此,有了虚拟局域网之后就能做各种在局域网中能做的事,不过这就不是本文的范畴了。

    展开全文
  • 设置vlan虚拟局域网

    2021-08-07 08:50:12
    文章目录一.vlan虚拟局域网1.vlan的好处2.vlan的划分1.静态vlan2.动态vlan二.pc机设置vlan1.创建VLAN2.划分VLAN三.总结 一.vlan虚拟局域网        VLAN,是英文Virtual Local ...

    一.vlan虚拟局域网

           VLAN,是英文Virtual Local Area Network的缩写,中文名为"虚拟局域网", VLAN是一种将局域网(LAN)设备从逻辑上划分(注意,不是从物理上划分)成一个个网段(或者说是更小的局域网LAN),从而实现虚拟工作组(单元)的数据交换技术。 VLAN这一新兴技术主要应用于交换机和路由器中,但目前主流应用还是在交换机之中。
           VLAN的特点可知,一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,从而有助于控制流量、减少设备投资、简化网络管理、提高网络的安全性。 VLAN除了能将网络划分为多个广播域,从而有效地控制广播风暴的发生,以及使网络的拓扑结构变得非常灵活的优点外,还可以用于控制网络中不同部门、不同站点之间的互相访问。

    1.vlan的好处

           1.安全性。不同VLAN不能直接通信,杜绝了广播信息的不安全性。
           2.灵活性。更改用户所属的网络不必换端口和连线,只更改软件配置就可以了。
           3.隔离广播域。即便在同一个交换机上,处于不同VLAN的端口也是不能通信的。这样一个物理的交换机可以当作多个逻辑的交换机使用。

    2.vlan的划分

           基于端口的VLAN,简单的讲就是交换机的一个端口就是一个虚拟局域网,凡是连接在这个端口上的主机属于同个虚拟局域网之中。

    VLAN ID范围范围用途
    0,4095保留仅限系统使用,用户不能查看和使用这些VLAN
    1正常用户能够使用这些VLAN,但不能删除它
    2-1001正常用于以太网的VLAN,用户可以创建、使用、删除这些VLAN
    1002-1005正常默认VLAN,用户不能删除这些VLAN
    1006-1024保留仅限系统使用,用户不能查看和使用这些VLAN
    1025-4094扩展仅用于以太网VLAN

    1.静态vlan

           在VLAN管理员最初配置交换机Port和VLAN ID的对应关系时,就已经固定了这种对应关系,即这个Port只能对应这个VLAN ID,之后无法进行更改,除非管理员再重新配置。
    在这里插入图片描述
    静态VLAN的优缺点
           可以说静态VLAN与基于端口的VLAN有一丝相似之处,用户可在交换机上 让一个或多个交换机端口形成一个略大一些的虚拟局域网。从一定意义上讲静态虚拟局域网在某些程度上弥补了基于端口的虚拟局域网的缺点。缺陷方面,静态 VLAN虽说是可以使多个端口的设置成一个虚拟局域网,假如两个不同端口、不同虚拟局域网的人员聚到一起协商一些事情,这时候问题就出现了,因为端口及虚 拟局域网的不一致往往就会直接导致某一个虚拟局域网的人员就不能正常的访问他原先所在的VLAN之中(静态虚拟局域网的端口在同一时间只能属于同一个虚拟 局域网),这样就需要网络管理人员随时配合及时修改该线路上的端口。

    2.动态vlan

    基于MAC划分动态VLAN
           将所有主机的硬件地址都加入到VLAN的管理数据库中,例如,一主机随便连接到交换机的一个动态VLAN的Port时,管理数据库将根据主机的MAC地址查询到该主机要加入VLAN 2中,然后自动设置该Port为VLAN 2。缺点是当主机更换了网卡之后,管理数据库需要重新设定。

    二.pc机设置vlan

           如图所示,三台pc机连接在一台交换机上。

    在这里插入图片描述
    PC1:192.168.1.10 255.255.255.0
    PC2:192.168.1.20 255.255.255.0
    PC3:192.168.1.30 255.255.255.0
    这时未设置虚拟局域网,因此三台PC机均能联通。
    在这里插入图片描述
           接下来将三台PC机设置到不同VLAN中
           在交换机上设置!

    1.创建VLAN

    由于系统默认有VLAN1,且连接接口
    在这里插入图片描述
    所以要新建VLAN2、VLAN4、VLAN6

    [ ]vlan batch 2 4 6                  //在系统视图下
    

    在这里插入图片描述
    新建成功

    2.划分VLAN

    将PC1划到VLAN2,将PC2划到VLAN4,将PC3划到VLAN6.

    [ ]interface e0/0/1                                   // 进入与PC1连接的接口
    [ ]port link-type access                              // 设置接口类型
    [ ]port default vlan 2                                // 将接口划分到VLAN2
    

    在这里插入图片描述
    这时就设置好PC1了

    [ ]interface e0/0/2                                   // 进入与PC2连接的接口
    [ ]port link-type access                              // 设置接口类型
    [ ]port default vlan 4                                // 将接口划分到VLAN4
    [ ]interface e0/0/3                                   // 进入与PC3连接的接口
    [ ]port link-type access                              // 设置接口类型
    [ ]port default vlan 6                                // 将接口划分到VLAN6
    

    以此类推,设置完成
    在这里插入图片描述
    这时再用PC1pingPC2和PC3
    在这里插入图片描述
           不能ping成功即设置完成

    三.总结

           1.创建单个VLAN:[ ]vlan x ;创建多个VLAN:[ ]vlan batch x x x ;创建多个连续的VLAN:[ ]vlan batch x to x。
           2.查询VLAN:[ ]display vlan
           3.设置静态VLAN简单便宜,设置动态VLAN复杂且贵。
           4.交换机连接的是电脑则设置接口类型为access;交换机连接的是交换机则设置接口类型为trunk。

    展开全文
  • 这篇文档的主要目的是使读者能够快速了解交换机和虚拟局域网的原理及其基础知识,使读者快速入门
  • VLAN--虚拟局域网(理论详解)

    千次阅读 多人点赞 2020-11-01 21:02:13
    在一个局域网中,如果上网的人越来越多,就会开始有人抱怨网速怎么这么慢,干什么都慢的不行了 因为电脑要访问别人,会发送ARP广播报文,你想想看,在我们这个教室里面,坐30个人和,和坐300人会怎么样 人越多,...


    前言

    • 在一个局域网中,如果上网的人越来越多,就会开始有人抱怨网速怎么这么慢,干什么都慢的不行了
      在这里插入图片描述
    • 这是因为电脑要访问别人,大多都会发送ARP请求报文(广播报文)
      你可以想想看,在我们这个教室里面,坐30个人和,和坐300人会怎么样
    • 人越多,噪音越大
    • 但如果把这300个人分成10个班,去10个不同的教室,噪音问题就基本解决了
    • 在网络世界中也是这样,随着网络规模的不断扩大,接入的主机和设备越来越多,网络中的广播流量也随之加大
      广播域中电脑数量越多,广播报文也就越多,一方面广播报文会占用大量带宽,电脑也会消耗大量资源去处理很多无用的广播报文
    • 怎么才能把一个广播域控制在一个合理的范围呢?
    • 接下来要讲解的VLAN(Virtual Local Area Network,虚拟局域网)技术,可以从逻辑上将一个大的网络分成若干小的虚拟局域网

    在这里插入图片描述


    一、VLAN概述

    1.VLAN的概念及优势

    • 在传统的交换式以太网中,所有的用户都在同一个广播域中,当网络规模较大时,广播包的数量会急剧增加,当广播包的数量占到总量的30%时,网络的传输效率将会明显下降

    • 特别是当某个网络设备出现故障后,若不停的向网络发送广播,就会导致广播风暴,使网络通信陷于瘫痪
      那么应该怎样解决这个问题呢?

    • 本来,二层交换机只能构建单一的广播域,不过使用VLAN功能后,它能够将网络分割成多个广播域
      mark

    • 分隔广播域有两种办法:

      • 物理分割:将网络从物理上划分为若干个小网络,然后使用能隔离广播的路由设备将不同的网络连接起来实现通信
      • 逻辑分割:将网络从逻辑上划分为若干个小的虚拟网络,即VLAN(Virtual Local Area Network,虚拟局域网),VLAN工作在OSI参考模型的数据链路层,一个VLAN就是一个交换网络,其中所有的用户都在同一个广播域中,各VLAN通过路由设备的连接实现通信
    • 物理分割有很多缺点,它会使局域网的设计缺乏灵活性;因为使用路由器分割广播域的话,所能分割的个数完全取决于路由器的网络接口个数,使得用户不能根据实际需求分割广播域

    • VLAN的产生给局域网的设计增加了灵活性,使得网络管理员在划分工作组时,不再受限于用户所处的物理位置

    • VLAN可以在一个交换机上实现,也可以跨交换机实现,可以根据网络用户的位置、作用或部门等进行划分

    • VLAN具有灵活性和可扩展性等特点,使用VLAN技术有以下好处:

      • 控制广播
        每个VLAN都是一个独立的广播域,这样就减少了广播对网络带宽的占用,提高了网络传输效率,并且一个VLAN出现网络风暴不会影响到其他的VLAN
      • 增强网络安全性
        由于只能在同一VLAN内的端口之间交换数据,不同VLAN的端口之间不能直接访问,因此通过划分VLAN可以限制个别主机访问服务器等资源,提高网络的安全性
      • 简化网络管理
        对于交换式以太网,如果对某些用户重新进行网段分配,需要网络管理员对网络系统的物理结构进行调整,甚至需要追加网络设备,这样会增大网络管理的工作量
        而对采用VLAN技术的网络来说,一个VLAN可以根据部门职能、对象组或者应用将不同地理位置的用户划分为一个逻辑网段,在不改动网络物理连接的情况下可以任意地将工作站在工作组或者子网之间移动
        利用VLAN技术,大大减轻了网络管理和维护工作的负担,降低了网络维护的费用

    2.VLAN的种类

    • 动态VLAN
      基于MAC地址划分VLAN(了解即可,现在静态是最常见的)

    • 静态VLAN
      静态VLAN也称基于端口的VLAN,是目前最常见的VLAN实现方式
      静态VLAN即明确指定交换机的端口属于哪个VLAN,这需要管理员手动配置
      当用户主机连接到交换机端口上时,就被分配到了对应VLAN中
      mark
      这种端口和VLAN的映射只在本地有效,而交换机之间不能共享这一信息
      注:一个VLAN可以包含多个端口,但一个端口只能对应一个VLAN

    静态VLAN配置:
    在这里插入图片描述


    二、VLAN Trunk

    当网络中有很多台交换机时,位于不同交换机上的相同VLAN的主机之间是如何通信呢?
    这就是接下来要进行讲解的,即跨交换机的VLAN通信
    (Trunk可以理解为是一条公共链路)

    1.Trunk的作用

    • 如图所示,在两台交换机上分别创建了VLAN10、20和30,那么如何才能让连接在不同交换机上的相同VLAN的主机通信呢
      在这里插入图片描述
    • 如果为每个VLAN都连接一条物理链路,那么两台交换机之间有几个VLAN通信,就需要连接几条物理链路
      这种连接方式的扩展性有很大的问题,即随着VLAN数量的增加,就需要在两台交换机之间连接多条物理链路,从而会占用很多个交换机端口,这显然不可取
    • 类似现实生活中运送货物的例子,为了使货物在到达目的地后能被正确的分开,通常是做货物上贴上不同的标签
    • 那么在VLAN中,由于不同VLAN的VLAN号不同,实际上可以只使用一条中继链路,将属于不同VLAN的数据帧打上不同的标识即可
      在这里插入图片描述
      在交换网络中,有两种类型链路:
    1. 接入链路:通常属于一个VLAN(主机与交换机之间)
    2. 中继链路:可以承载多个VLAN(交换机连接交换机或者交换机连接到路由器上)

    Trunk(干道、中继)的作用就是使同一个VLAN能够跨交换机通信
    那么在VLAN跨交换机通信的过程中,数据帧有什么变化呢?

    在这里插入图片描述

    1. VLAN30的主机A发送数据帧给主机B,这时主机A发送的数据帧为普通数据帧,交换机接收到数据帧后,知道了是来自VLAN30且要转发给下一台交换机,就会在数据帧上打上VLAN30的标识,然后发给下一台交换机
    2. 下一台交换机收到带有VLAN30标识的数据帧后,根据目标MAC地址,得知数据帧是发送给主机B的,于是删除VLAN标识还原为普通数据帧,然后转发给主机B

    2.VLAN的标识

    在这里插入图片描述

    • 802.1q 规定了公有的标记方法,其他厂商的产品也支持这种标记方法
      链路双方的设备要使用相同的标记方法
      例如,如果Cisco交换机与其他厂商的交换机互联,就要使用标准的802.1q协议

    • 下面重点介绍IEEE 802.1q的工作原理和帧格式。
      802.1q使用了一种内部标记机制。中继设备将四字节的标记插入到数据帧内,并重新计算FCS (Frame Check Sequencl,帧校验序列)
      如下图所示,采用802.1q的帧标识在标准以太网帧内插入了四字节
      在这里插入图片描述
      这个四字节的标记头包含以下内容

    1. 2字节标记协议标识符(TPID) 包含一个0x8100的固定值,这个特定的TPID值指明了该帧带有802.1q的标记信息。
      (2) 2字节标记控制信息(TCI) 包含了下面的元素
    1. 3位的用户优先级(Priority) : 802.1q 不使用该字段
    2. 1位的规范格式标识符(CFI) : CFI 常用于以太网和令牌环网。在以太网中,CFI的值通常设置为0
    3. 12位VLAN标识符(VLANID) :该字段唯一标识了帧所属的VLAN。VLAN ID可以唯一地标识4096个VLAN,但 VLAN0 和 VLAN4095 是被保留的

    在这里插入图片描述

    三、eNSP配置命令

    system-view
    [Huawei] sysname SW1
     
     ##显示当VLAN信息
    [SW1] dis vlan 
     
    ##添加单个VLAN
    [SW1] vlan 10
    [SW1-vlan10] quit
     
     ##批量添加VLAN
    [SW1] vlan batch 20 30 40 
     
    ##删除VLAN
    [SW1] undo vlan 10
    

    1.Access

    • Access口只能加入一个VLAN,一般用于连接计算机端口
     [Huawei] int e0/0/0 (进入接口模式)
     [Huawei-Ethernet0/0/0] port link-type access (定义二层端口模式)
     [Huawei-Ethernet0/0/0] port default vlan 10 (将端口加入到VLAN中)
     [Huawei-Ethernet0/0/0] undo shutdown
    
     [Huawei-Ethernet0/0/0] undo port default vlan (将端口从VLAN删除)
     [Huawei-Ethernet0/0/0] port link-type hybrid (将端口类型恢复成默认的hybrid)
     
     [Huawei-Ethernet0/0/0] dis this  (查看当前端口模式、状态)
     
    同时将多个端口加入VLAN:
     [Huawei] port-group 1 (新增组1)
     [Huawei-port-group-1] group-member Ethernet 0/0/1 to Ethernet 0/0/20 (组1的成员是e0/0/1到e0/0/20)
     [Huawei-port-group-1] port link-type access
     [Huawei-port-group-1] port default vlan 30 
     
     [Huawei] clear configuration interface e0/0/1 (端口恢复默认配置,注意,执行完命令后,接口会被shut down)
    
     [Huawei] dis vlan 10 (查看指定VLAN信息)
    

    2.Trunk

    • Trunk 口可以允许多个VLAN通过,可以接收和发送多个VLAN报文,一般用于交换机与交换机相关的接口
    [Huawei] int e0/0/0
     [Huawei-Etherent0/0/0] port link-type trunk (定义二层端口模式)
     [Huawei-Etherent0/0/0] port trunk allow-pass vlan 10 20 30 (配置Trunk 端口允许通过的vlan)
     [Huawei-Etherent0/0/0] undo shutdown
     
     [Huawei-Etherent0/0/0] undo port trunk allow -pass vlan 10 (禁止Trunk传送某个VLAN的数据,删除这个VLAN)
    

    3.Hybrid

    • 是一种混合端口(人为控制经过端口时是否脱去vlan标签)

    • Hybrid 接口是华为设备的特殊的二层接口模式,Hybrid 接口和Trunk接口的相同之处是都可以允许多个VLAN的流量通过并打标签

    • 不同之处在于Hybrid 接口可以允许多个VLAN的报文发送时不打标签

    Hybrid 接口作为华为交换机的特有属性接口,主要特点有:

    1. 华为交换机接口默认为Hybrid 模式
    2. 既可以实现Access接口的功能,也可以实现Trunk 接口的功能
    3. 不借助三层设备即可实现跨VLAN 通信和访问控制
    4. 相对于Access 接口和Trunk 接口具有更高的灵活性与可控性
    5. Hybrid可以根据需要以tagged 或者 untagged 方式加入某个VLAN或者多个VLAN

    心法口诀:
    数据帧出口检查:查untag 表,有标时,脱标;无标时,查tag表,有则放通,无则丢掉
    数据帧进口检查:先查有无标签,有标时,查tag表,有则放通,无标则丢弃;
    无标时,打上PVID后,放通

    [Huawei] int e0/0/0 ###可理解成access口
     [Huawei-Etherent0/0/0] port link-type hybrid
     [Huawei-Etherent0/0/0] port hybrid pvid vlan 10
     ###**把Pvid 当成vlanid , 从PC到交换机进口的数据帧是没有标签的,所以要给数据帧打上标签再送进交换机*
     
    [Huawei-Etherent0/0/0] port hybrid pvid vlan 10
     ###在untag 表里添加vlanid, 如果数据帧要从此接口出时就要先查untag 表,若发现有对应的vlanid 的标签就会脱掉此标签再发送出去
     [Huawei-Etherent0/0/0] undo shutdown 
     
    [Huawei] int e0/0/1 ###可理解成trunk口
    [Huawei-Etherent0/0/0] port link-type hybrid
    [Huawei-Etherent0/0/1] port hybrid tagged vlan 10 20 30
    ###在tag 表里添加vlanid , 如果数据帧要从此接口出时就要先查 untag 表,如没有会再查tag 表,若发现有对应的vlanid 的标签就会放通,否则丢掉
    [Huawei-Etherent0/0/1] undo shutdown 
     
    [Huawei] int e0/0/2 ####上层接路由器配法
    [Huawei-Etherent0/0/2] port link-type hybrid
    [Huawei-Etherent0/0/2] port hybrid untagged vlan 10 30 ###经过端口时脱去vlan10 30 标签
    [Huawei-Etherent0/0/2 ] undo shutdown 
     
     [Huawei] int e0/0/0
    [Huawei-Etherent0/0/0] undo port default vlan ####初始化还原
    [Huawei-Etherent0/0/0] port link-type hybrid ####将这个口变为hybrid 模式,华为交换机默认hybrid口
    
    展开全文
  • 实验六 虚拟局域网(VLAN)

    千次阅读 2020-12-16 12:21:47
    实验六 虚拟局域网(VLAN) 一、 实验目的 综合应用所学计算机网络知识,完成一个虚拟局域网(VLAN)创建、配置和测试,比较全面的掌握和了解虚拟局域网。 1.理解虚拟局域网的概念。 2.了解VLAN技术在交换式以太网中...
  • 虚拟局域网VLAN划分与配置实验.rar
  • 虚拟局域网VLAN简介

    2020-12-30 00:38:12
    虚拟局域网VLANVLAN1、根据端口划分VLAN2、根据MAC地址划分VLAN3、根据网络层划分VLAN4、 IP组播作为VLANVLAN优点1、减少移动和改变的代价2、虚拟工作组3、限制广播包4、安全性 VLAN Virtual LANs目前发展很快,世界...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 75,292
精华内容 30,116
关键字:

虚拟局域网