精华内容
下载资源
问答
  • 思科交换机配置命令大全switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname...
  • 思科交换机命令大全,word文件。 switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch# configure terminal switch(conf)#
  • cisco命令全集,还不错,大家分享,呵呵,不过感觉还是不够全面,没有例子
  • 思科交换机命令大全 一

    千次阅读 2019-06-12 09:31:31
    5.查看Cisco邻接设备的CDP通告 switch# show cdp inte***ce [type modle/port] switch# show cdp neighbors [type module/port] [detail] switch(enable) show cdp neighbors[module/port] [vlan|duplex|...

    1.设置主机名/系统名 switch(config)# hostname “hostname” switch(enable) set system name name-string
    2.设置登录口令 switch(config)# enable password level 1 password switch(enable) set password
    switch(enable) set enalbepass
    3.设置远程访问 switch(config)# inte***ce vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address switch(enable) set inte***ce sc0 ip-address netmask broadcast-address
    switch(enable) set inte***ce sc0 vlan
    switch(enable) set ip route default gateway
    4.启用和浏览CDP信息 switch(config-if)# cdp enable
    switch(config-if)# no cdp enable switch(enable) set cdp {enable|disable} module/port
    5.查看Cisco邻接设备的CDP通告 switch# show cdp inte***ce [type modle/port]
    switch# show cdp neighbors [type module/port] [detail] switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
    6.端口描述 switch(config-if)#description escription-string switch(enable)set port name module/number description-string
    7.设置端口速度 switch(config-if)# speed{10|100|auto} switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}
    8.设置以太网的链路模式 switch(config-if)# duplex {auto|full|half} switch(enable) set port duplex module/number {full|half
    9.配置静态VLAN switch# vlan database
    switch(vlan)# vlan vlan-num name vla
    switch(vlan)# exit
    switch# configure teriminal
    switch(config)#inte***ce inte***ce module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list
    10.配置VLAN中继线 switch(config)# inte***ce inte***ce mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)#switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list switch(enable)set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]

    展开全文
  • 思科交换机命令大全》 思科交换机命令大全,需要的课速下载,基本上全部的命令都在了。
  • CISCO交换机常用命令》 一、交换机四种基本模式 1、四种模式介绍 2.进入四种模式 (1)从用户模式进入特权模式:enable (2)从特权模式进入全局配置模式:conf t (3)从全局端口配置模式进入视图模式...

     

                                           《CISCO交换机常用命令》

    一、交换机四种基本模式

    1、四种模式介绍

     

    2.进入四种模式

    (1)从用户模式进入特权模式:enable

    (2)从特权模式进入全局配置模式:conf t

    (3)从全局端口配置模式进入视图模式:int f0/1

    (4)从全局模式返回至特权模式:end

    3.退回返回上一层:exit

    4.修改交换机名称:hostname X

    5.重启:reload

    6自动命令补全:tab

    7.帮助信息:?、co?、copy?

    8.配置交换机端口参数:speed,duplex

    9.保存交换机配置:Switch#wr

     

    二、功能及查看命令

    1.实现以太网通道负载平衡:

    (1)按照源/目标主机IP地址数据分发来:port-channel load-balance dst-ip;

    (2)按照源/目标MAC地址分发来:port-channel load-balance src-mac

    3.查看信息:

    (1)查看虚拟通道包含的接口数量:Switch#show etherchannel summary

    (2)查看交换机版本信息:Switch#show version

    (3)查看当前生效的配置信息:Switch#show running-config

    (4)查看保存在NVRAM中启动配置信息:Switch#show startup-config

    (5)查看端口信息:Switch#Switch#show interface

    (6)查看交换机的MAC地址表Switch#show mac-address-table

    (7)查看交换机的vlan配置Switch#show vlan

    4.特定功能

    (1)选择某个端口:Switch(config)#interface type mod/port

    (type表示端口类型,通常有ethernet、Fastethernet、Gigabitethernet)所在的模块,mod表示端口所在的模块,port表示该模块中的编号)

    (2)选择多个端口:Switch(config)interface type mod/startport-endport

    (3)设置端口通信速度:Switch(config-if)#speed[10/100/auto]

    (4)设置端口单双工模式Switch(config-if)#duplex[half/full/auto]

    (5)思科三层交换机开启路由功能:Switch(config)#ip routing

    5.密码设置

    (1)设置进入特权模式的密码:Switch(config)#enable password ******

    (2)可以设置通过console端口连接及Telnet远程登录时所需的密码:Switch(config-line)#

    (3)配置控制台线路,0是控制台的线路编号:Switch(config)#line console 0

    (4)用于打开登录认证功能:Switch(config-line)#login

    (5)设置进入控制台访问的密码:Switch(config-line)#password 5ijsj

    展开全文
  • 思科交换机命令详细

    2018-05-29 16:40:31
    思科交换机配置详细解释,各个命令的用途和实际使用场景。
  • 思科交换机命令-思科交换机命令统计51CTO下载-思科交换机命令统计
  • cisco思科交换机-常用命令及配置

    万次阅读 多人点赞 2020-05-22 15:28:06
    switch> 用户模式 1:进入特权模式enable switch> enable switch# ...3:交换机命名hostname name 以cisco001 为例 switch> enable switch#c onfigure terminal switch(conf)#hostname cisc

    连接步骤:

    双击SecureCRT 打开软件;
    选择快速连接;
    协议:SSH2,主机名:IP地址,点击连接;(Cisco设备使用telnet登陆);

    视图模式介绍

    1.普通视图router>

    2.特权视图router# / 在普通模式下输入enable

    3.全局视图router(config)#/ 在特权模式下输入configt

    4.接口视图router(config-if)#/在全局模式下输入int 接口名称例如int s0 或 int e0

    5.路由协议视图router ( config-route ) #/ 在全局模式下输入router 动态路由协议名称
    switch> 用户模式
    工作模式:
    在这里插入图片描述
    命令大致划分:
    v 用户模式下大多都是对设备IOS系统进行操作配置的一些命令。
    v 特权模式下大多都是Show查看类命令。
    v 全局模式下大多都是配置类命令。
    v 接口模式下大多都是对于接口的配置命令。
    CSICO基础常用命令

    展开全文
  • 思科交换机命令

    2019-06-28 14:09:39
    交换机模拟器实验六 2.查看端口名字 SWA#sh vlan default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8 f是端口名子 default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7...

    1.不同的vlan

    不同vlan需要路由
    在路由的端口设置多个IP段
    交换机模拟器实验六

    2.查看端口名字

    SWA#sh vlan
    default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8
    f是端口名子
    default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8
    Gi是端口名字

    3.创建动态链路聚合

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#channel-group 1 mode active
    Switch(config-if-range)#exit

    4.创建端口的链路类型

    以太网端口有三种链路类型:Access、Hybrid、Trunk。Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;Trunk 类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。Hybrid端口和Trunk端口的不同之处在于Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    表1-9 设置以太网端口的链路类型

    操作
    命令

    设置端口为Access端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode access

    设置端口为Hybrid端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode hybrid

    设置端口为Trunk端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode trunk

    恢复端口的链路类型为缺省的Access端口
    undo port link-type

    三种类型的端口可以共存在一台以太网交换机上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    缺省情况下,端口为Access端口。

    需要注意的是:Access端口加入的VLAN必须已经存在并且不能是缺省VLAN;Hybrid端口加入的VLAN必须已经存在;Trunk端口加入的VLAN不能是缺省VLAN。

    执行了本配置,当前以太网端口就可以转发指定VLAN的报文。Hybrid端口和Trunk端口可以加入到多个VLAN中,从而实现本交换机上的VLAN与对端交换机上相同VLAN的互通。Hybrid端口还可以设置哪些VLAN的报文打上标签,哪些不打标签,为实现对不同VLAN报文执行不同处理流程打下基础

    5.交换机显示命令

    思科重启

    思科所有的重启命令都是reload

    交换机显示命令:

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看vlan配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息
    switch#show cdp nei ;查看端口上行设备及连接的对应端口信息
    switch#show ip int bir 查看端口VLAN IP 开启状态总览
    switch#show int status 查看端口状态总览
    switch#show inventory 查看光模块显信
    switch#sh int etherchannel sum 查看“端口聚合/链路捆绑
    switch#sh int port-channel 查看“端口聚合/链路捆绑
    switch#show spanning-tree 查看生成树状态
    switch#show access-list 查看规则状态
    switch#show history 查看历史输入命令
    switch#show errdisable recovery 查看哪些保护会在超时后可自动恢复
    switch#show errdisable detect​查看 err-disabled 状态的原因

    6.配置vlan的IP
    s(config)#int vlan 6
    s(config-vlan)#no shu
    s(config-vlan)#ip add 10.2.20.1 255.255.255.254
    SWA#wr
    7.配置交换机的IP和网关

    配置交换机网关:Switch(config)#ip default-gateway 网关

    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run

    8.清除思科所有配置

    SWA#del vlan.dat
    SWA#reload

    9.删除动态链接

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#no channel-group 1
    Switch(config-if-range)#exit

    10.设置vtp

    switch(config)#vtp domain ;设置发vtp域名
    switch(config)#vtp password ;设置发vtp密码
    switch(config)#vtp mode server ;设置发vtp模式
    switch(config)#vtp mode client ;设置发vtp模式

    11.设置思科交换机的IP和子网掩码

    switch#conf t
    进入默认VLAN状态:
    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run
    SWA#write

    12.思科telnet登陆方法

    开始–cmd—telnet

    13.思科保存方法

    在全局配置模式下
    Router#copy running-config startup-config //保存当前的配置

    Router#write
    也行

    14.思科查看vlan

    SWA#sh vlan

    15.思科查看当前配置

    查看当前配置:
    switch#sh run

      16.思科恢复出厂设置
    

    Switch#erase startup-config

    Switch#reload

    有提示要保存配置 就选择no

    17.思科将端口加入vlan
    

    SWA(config)#int f0/5 (f是端口号sh vlan可以看端口号,端口号是不一样的我们的是Gi)
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/6
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/7
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)# end
    SWA#sh vlan
    SWA#wr(保存)

    18.思科和电脑接法
    

    首先这个软件不能连接真实设备:
    选择一台PC,一个设备(交换机,路由器都行)
    连接PC和设备,线缆选择蓝色线缆,英文应该是console—控制台的意思。连接是,PC上选择RS232接口,设备上选择CONSOLE接口
    连接好之后,双击PC图标,打开一个窗口,点击桌面(desktop),再选择终端(terminal),点击OK,就可以了!

    19.思科进入
    

    Switch>enable
    Switch#

    20.思科模式

    呵呵终于找到一个关于cisco的问题了。

    朋友你好,我就用我自己的语言表达了哈,有点长哈,但一定帮你学懂哈。思科的路由器的用户界面有以下几种:
    1.用户执行模式(User EXEC Mode)
    2.特权执行模式(Privileged EXEC Mode)
    3.全局配置模式(Global Configuration Mode)
    4.监控模式(ROM Monitor Mode) 安ctrl + break
    5.安装模式(Setup Mode) 先进入特权模式 在setup 就行
    6.Boot模式(RXBoot Mode)

    常用的是1、2和3。下面我就来正式回答你问的。

    路由器一开机,进去的那个界面提示符是“>”,比如像这样子哈,“Router>”这个就是用户执行模式,也是最低级别的模式,它只允许有限数量的基本监视命令,该模式下不允许任何会改变路由器配置的命令。

    那我们要配置路由器时该咋弄呢,这时就必须先得进入到“特权执行模式”了(也就是在用户执行模式下输入“enable”命令)。出现像这样的提示符“#”,比如“Router#”。相比用户执行模式,它提供更多的命令和权限,比如debug命令,和更为细致的测试等。

    至于“全局配置模式”,是配置(全局)系统和相应的具体细节配置(比如接口ip、路由协议这些)时进入的界面,在此配置的东东是影响全局的。全局配置模式的提示符是这样的“(config)#”,比如我这里举的例就该是“Router(config)#”。

    而要配置具体的东东就得从全局配置模式下进入到相应的子配置模式下。比如:
    Router(config-if)# //具体的接口配置
    Router(config-line)# //line模式配置,比如console和vty这些哈
    Router(config-router)# //路由器模式,比如配置路由协议时

    百度知道不能回帖功能不够强大,不然我可以重新更漂亮的排版和标记,好让朋友更加容易理解。

    简单总结下你的问题就是,特权执行模式主要是用来调试的,全局配置模式是用来配置的。而且他们的关系,要到达全局配置模式,你必须先得处在特权执行模式哈。

    而相应的命令见下面哈:

    Router>
    Router>enable //将从用户执行模式进入到特权执行模式
    Password: //如果对特权执行模式设置了密码的话,进入时还得输入密码哈
    Router#
    Router#exit //将从特权执行模式退回到用户执行模式
    Router>

    //下面我演示如何从用户执行模式一步步到达全局配置模式哈:
    Router>enable
    Router#
    Router#configure terminal
    Router(config)#

    21.思科配置vlan并保存

    SWA#vlan database
    SWA(vlan)#vlan 2
    SWA(vlan)#vlan 3
    SWA(vlan)#exit
    SWA#write

    22.思科配置远程登录

    111(config)# line vty 0 4 进入虚拟线程配置模式,在这个模式里可对
    telnet功能进行配置
    111(config-line)# login
    111(config-line)# password XXX 配置telnet密码,默认的网络设备telnet的功能是
    关闭的,配了密码之后会自动打开
    111(config)# enable password XXX 配置进入enable模式的密码, 区分大小写
    111(config)# enable secret XXX 配置进入enable模式的密码,是加密的密码,show
    run是看不见的
    111(config)# line console 0
    111(config-line)# login
    111(config-line)# password XXX 配置进入用户模式的密码
    111(config-line)# logging synchronous 输入同步
    111(config-line)# exec-timeout 0 0 禁止因为一段时间没有输入而跳出
    111#SWA#write保存配置
    23.思科批处理登陆

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 你的网络设备telnet登录IP” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的密码{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “conf{ENTER}”>>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    del telnet_tmp.vbs
    24.思科删除vlan

    jjf{cinfig}#no vlan 10 删除vlan10
    jjf{cinfig}#end 回到特权模式
    jjf{cinfig}sh vlan 查看vlan
    SWA#write

                              25.思科设置trunk干线
    

    设置干线trunk
    将连接两个交换机的端口设置成trunk。
    SWA(config)#int f0/8
    SWA(config-if)#switchport mode trunk
    SWA(config-if)#switchport trunk allowed vlan 1,2,3(只允许vlan 1 2 3 在这条个trunk链路上走,这个就是vlan修剪。)
    SWA(config-if)#switchport trunk encap dot1q(可以不要dot1q是vlan中继协议(802.1q)一般交换机都是自带的)
    SWA(config-if)#end
    SWA#sh run

    SWB(config)#int f0/1
    SWB(config-if)#switchport mode trunk
    SWB(config-if)#switchport trunk allowed vlan 1,2,3
    SWB(config-if)#switchport trunk encap dot1q
    SWB(config-if)#end
    SWB#sh run
    26.思科型号

    Cisco Catalyst 2960G-24TC-L 24个以太网10/100/1000端口,其中有4个为两用端口

                                  26.思科远程登陆pingIP地址(可做批处理)
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 登陆交换机IP地址” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “登录密码{ENTER}”>>telnet_tmp.vbs
    echo sh.SendKeys “ping 192.168.0.2{ENTER}” >>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs
    27.思科远程交换机登陆配置

    1.进入vlan 1接口模式
    switch(config)#interface vlan 1
    2.打开vlan 1端口
    switch(config-if)#no shutdown
    3.配置vlan 1的IP地址
    switch(config-if)#ip address 172.16.10.99 255.255.255.0
    三、配置交换机Telnet登录
    1.在全局配置模式下设置特权模式口令
    switch(config)#enable password cisco
    2.在全局配置模式下设置虚拟终端(Virtual terminal)的线路号
    switch(config)#line vty 0 4
    switch(config-line)#
    3.在线路配置模式下设置通过虚拟终端登录的用户口令为net(必须设置口令才能使用管理IP远程登录交换机)
    switch(config-line)#password net
    4.在线路配置模式下使用login命令测试是否可以远程登录
    switch(config-line)#login
    switch(config-line)#
    如果没有出现提示,说明设置成功,如果出现五行提示,说明设置有误。
    四、使用PC1机远程登录交换机
    1.将PC1用直通线连接到交换机的FastEthernet0/3端口。
    2.打开PC1的“桌面”上的“IP配置”,选择静态配置,设置IP地址为172.16.10.100,子网掩码为255.255.255.0。
    3.打开PC1的“桌面”上的“命令提示符”。
    4. 在命令提示符中使用telnet命令远程登录交换机(交换机管理IP地址为172.16.10.99)
    PC>telnet 172.16.10.99
    Trying 172.16.10.99 …
    User Access Verification
    Password:
    在接下来出现的password提示文字后输入前面交换机上设定的telnet登录口令net(该口令输入时不会显示任何符号),即可进入交换机的用户配置模式。
    5.输入特权模式口令进入全局配置模式
    在用户配置模式下输入enable命令,再后输入所配置的特权模式口令cisco(该口令输入时不会显示任何符号)即可进入全局配置模式进行后续网络设置。
    Switch>enable
    Password:
    28. 思科重启

    思科所有的重启命令都是reload

                                   29.           远程登录交换机可做批处理
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 192.168.6.100” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{enter}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “root{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “jjf1{ENTER}”>>telnet_tmp.vbs

    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs

    Translating “enb”…domain server (255.255.255.255) 快捷键
    ctrl shift + 6 no ip domain

    明天的你会感谢今天拼命奋斗的自己1.不同的vlan

    不同vlan需要路由
    在路由的端口设置多个IP段
    交换机模拟器实验六

    2.查看端口名字

    SWA#sh vlan
    default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8
    f是端口名子
    default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8
    Gi是端口名字

    3.创建动态链路聚合

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#channel-group 1 mode active
    Switch(config-if-range)#exit

    4.创建端口的链路类型

    以太网端口有三种链路类型:Access、Hybrid、Trunk。Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;Trunk 类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。Hybrid端口和Trunk端口的不同之处在于Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    表1-9 设置以太网端口的链路类型

    操作
    命令

    设置端口为Access端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode access

    设置端口为Hybrid端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode hybrid

    设置端口为Trunk端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode trunk

    恢复端口的链路类型为缺省的Access端口
    undo port link-type

    三种类型的端口可以共存在一台以太网交换机上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    缺省情况下,端口为Access端口。

    需要注意的是:Access端口加入的VLAN必须已经存在并且不能是缺省VLAN;Hybrid端口加入的VLAN必须已经存在;Trunk端口加入的VLAN不能是缺省VLAN。

    执行了本配置,当前以太网端口就可以转发指定VLAN的报文。Hybrid端口和Trunk端口可以加入到多个VLAN中,从而实现本交换机上的VLAN与对端交换机上相同VLAN的互通。Hybrid端口还可以设置哪些VLAN的报文打上标签,哪些不打标签,为实现对不同VLAN报文执行不同处理流程打下基础

    5.交换机显示命令

    思科重启

    思科所有的重启命令都是reload

    交换机显示命令:

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看vlan配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息
    switch#show cdp nei ;查看端口上行设备及连接的对应端口信息
    switch#show ip int bir 查看端口VLAN IP 开启状态总览
    switch#show int status 查看端口状态总览
    switch#show inventory 查看光模块显信
    switch#sh int etherchannel sum 查看“端口聚合/链路捆绑
    switch#sh int port-channel 查看“端口聚合/链路捆绑
    switch#show spanning-tree 查看生成树状态
    switch#show access-list 查看规则状态
    switch#show history 查看历史输入命令
    switch#show errdisable recovery 查看哪些保护会在超时后可自动恢复
    switch#show errdisable detect​查看 err-disabled 状态的原因

    6.配置vlan的IP
    s(config)#int vlan 6
    s(config-vlan)#no shu
    s(config-vlan)#ip add 10.2.20.1 255.255.255.254
    SWA#wr
    7.配置交换机的IP和网关

    配置交换机网关:Switch(config)#ip default-gateway 网关

    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run

    8.清除思科所有配置

    SWA#del vlan.dat
    SWA#reload

    9.删除动态链接

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#no channel-group 1
    Switch(config-if-range)#exit

    10.设置vtp

    switch(config)#vtp domain ;设置发vtp域名
    switch(config)#vtp password ;设置发vtp密码
    switch(config)#vtp mode server ;设置发vtp模式
    switch(config)#vtp mode client ;设置发vtp模式

    11.设置思科交换机的IP和子网掩码

    switch#conf t
    进入默认VLAN状态:
    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run
    SWA#write

    12.思科telnet登陆方法

    开始–cmd—telnet

    13.思科保存方法

    在全局配置模式下
    Router#copy running-config startup-config //保存当前的配置

    Router#write
    也行

    14.思科查看vlan

    SWA#sh vlan

    15.思科查看当前配置

    查看当前配置:
    switch#sh run

      16.思科恢复出厂设置
    

    Switch#erase startup-config

    Switch#reload

    有提示要保存配置 就选择no

    17.思科将端口加入vlan
    

    SWA(config)#int f0/5 (f是端口号sh vlan可以看端口号,端口号是不一样的我们的是Gi)
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/6
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/7
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)# end
    SWA#sh vlan
    SWA#wr(保存)

    18.思科和电脑接法
    

    首先这个软件不能连接真实设备:
    选择一台PC,一个设备(交换机,路由器都行)
    连接PC和设备,线缆选择蓝色线缆,英文应该是console—控制台的意思。连接是,PC上选择RS232接口,设备上选择CONSOLE接口
    连接好之后,双击PC图标,打开一个窗口,点击桌面(desktop),再选择终端(terminal),点击OK,就可以了!

    19.思科进入
    

    Switch>enable
    Switch#

    20.思科模式

    呵呵终于找到一个关于cisco的问题了。

    朋友你好,我就用我自己的语言表达了哈,有点长哈,但一定帮你学懂哈。思科的路由器的用户界面有以下几种:
    1.用户执行模式(User EXEC Mode)
    2.特权执行模式(Privileged EXEC Mode)
    3.全局配置模式(Global Configuration Mode)
    4.监控模式(ROM Monitor Mode) 安ctrl + break
    5.安装模式(Setup Mode) 先进入特权模式 在setup 就行
    6.Boot模式(RXBoot Mode)

    常用的是1、2和3。下面我就来正式回答你问的。

    路由器一开机,进去的那个界面提示符是“>”,比如像这样子哈,“Router>”这个就是用户执行模式,也是最低级别的模式,它只允许有限数量的基本监视命令,该模式下不允许任何会改变路由器配置的命令。

    那我们要配置路由器时该咋弄呢,这时就必须先得进入到“特权执行模式”了(也就是在用户执行模式下输入“enable”命令)。出现像这样的提示符“#”,比如“Router#”。相比用户执行模式,它提供更多的命令和权限,比如debug命令,和更为细致的测试等。

    至于“全局配置模式”,是配置(全局)系统和相应的具体细节配置(比如接口ip、路由协议这些)时进入的界面,在此配置的东东是影响全局的。全局配置模式的提示符是这样的“(config)#”,比如我这里举的例就该是“Router(config)#”。

    而要配置具体的东东就得从全局配置模式下进入到相应的子配置模式下。比如:
    Router(config-if)# //具体的接口配置
    Router(config-line)# //line模式配置,比如console和vty这些哈
    Router(config-router)# //路由器模式,比如配置路由协议时

    百度知道不能回帖功能不够强大,不然我可以重新更漂亮的排版和标记,好让朋友更加容易理解。

    简单总结下你的问题就是,特权执行模式主要是用来调试的,全局配置模式是用来配置的。而且他们的关系,要到达全局配置模式,你必须先得处在特权执行模式哈。

    而相应的命令见下面哈:

    Router>
    Router>enable //将从用户执行模式进入到特权执行模式
    Password: //如果对特权执行模式设置了密码的话,进入时还得输入密码哈
    Router#
    Router#exit //将从特权执行模式退回到用户执行模式
    Router>

    //下面我演示如何从用户执行模式一步步到达全局配置模式哈:
    Router>enable
    Router#
    Router#configure terminal
    Router(config)#

    21.思科配置vlan并保存

    SWA#vlan database
    SWA(vlan)#vlan 2
    SWA(vlan)#vlan 3
    SWA(vlan)#exit
    SWA#write

    22.思科配置远程登录

    111(config)# line vty 0 4 进入虚拟线程配置模式,在这个模式里可对
    telnet功能进行配置
    111(config-line)# login
    111(config-line)# password XXX 配置telnet密码,默认的网络设备telnet的功能是
    关闭的,配了密码之后会自动打开
    111(config)# enable password XXX 配置进入enable模式的密码, 区分大小写
    111(config)# enable secret XXX 配置进入enable模式的密码,是加密的密码,show
    run是看不见的
    111(config)# line console 0
    111(config-line)# login
    111(config-line)# password XXX 配置进入用户模式的密码
    111(config-line)# logging synchronous 输入同步
    111(config-line)# exec-timeout 0 0 禁止因为一段时间没有输入而跳出
    111#SWA#write保存配置
    23.思科批处理登陆

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 你的网络设备telnet登录IP” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的密码{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “conf{ENTER}”>>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    del telnet_tmp.vbs
    24.思科删除vlan

    jjf{cinfig}#no vlan 10 删除vlan10
    jjf{cinfig}#end 回到特权模式
    jjf{cinfig}sh vlan 查看vlan
    SWA#write

                              25.思科设置trunk干线
    

    设置干线trunk
    将连接两个交换机的端口设置成trunk。
    SWA(config)#int f0/8
    SWA(config-if)#switchport mode trunk
    SWA(config-if)#switchport trunk allowed vlan 1,2,3(只允许vlan 1 2 3 在这条个trunk链路上走,这个就是vlan修剪。)
    SWA(config-if)#switchport trunk encap dot1q(可以不要dot1q是vlan中继协议(802.1q)一般交换机都是自带的)
    SWA(config-if)#end
    SWA#sh run

    SWB(config)#int f0/1
    SWB(config-if)#switchport mode trunk
    SWB(config-if)#switchport trunk allowed vlan 1,2,3
    SWB(config-if)#switchport trunk encap dot1q
    SWB(config-if)#end
    SWB#sh run
    26.思科型号

    Cisco Catalyst 2960G-24TC-L 24个以太网10/100/1000端口,其中有4个为两用端口

                                  26.思科远程登陆pingIP地址(可做批处理)
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 登陆交换机IP地址” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “登录密码{ENTER}”>>telnet_tmp.vbs
    echo sh.SendKeys “ping 192.168.0.2{ENTER}” >>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs
    27.思科远程交换机登陆配置

    1.进入vlan 1接口模式
    switch(config)#interface vlan 1
    2.打开vlan 1端口
    switch(config-if)#no shutdown
    3.配置vlan 1的IP地址
    switch(config-if)#ip address 172.16.10.99 255.255.255.0
    三、配置交换机Telnet登录
    1.在全局配置模式下设置特权模式口令
    switch(config)#enable password cisco
    2.在全局配置模式下设置虚拟终端(Virtual terminal)的线路号
    switch(config)#line vty 0 4
    switch(config-line)#
    3.在线路配置模式下设置通过虚拟终端登录的用户口令为net(必须设置口令才能使用管理IP远程登录交换机)
    switch(config-line)#password net
    4.在线路配置模式下使用login命令测试是否可以远程登录
    switch(config-line)#login
    switch(config-line)#
    如果没有出现提示,说明设置成功,如果出现五行提示,说明设置有误。
    四、使用PC1机远程登录交换机
    1.将PC1用直通线连接到交换机的FastEthernet0/3端口。
    2.打开PC1的“桌面”上的“IP配置”,选择静态配置,设置IP地址为172.16.10.100,子网掩码为255.255.255.0。
    3.打开PC1的“桌面”上的“命令提示符”。
    4. 在命令提示符中使用telnet命令远程登录交换机(交换机管理IP地址为172.16.10.99)
    PC>telnet 172.16.10.99
    Trying 172.16.10.99 …
    User Access Verification
    Password:
    在接下来出现的password提示文字后输入前面交换机上设定的telnet登录口令net(该口令输入时不会显示任何符号),即可进入交换机的用户配置模式。
    5.输入特权模式口令进入全局配置模式
    在用户配置模式下输入enable命令,再后输入所配置的特权模式口令cisco(该口令输入时不会显示任何符号)即可进入全局配置模式进行后续网络设置。
    Switch>enable
    Password:
    28. 思科重启

    思科所有的重启命令都是reload

                                   29.           远程登录交换机可做批处理
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 192.168.6.100” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{enter}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “root{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “jjf1{ENTER}”>>telnet_tmp.vbs

    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs

    Translating “enb”…domain server (255.255.255.255) 快捷键
    ctrl shift + 6 no ip domain

    明天的你会感谢今天拼命奋斗的自己

    展开全文
  • 思科交换机配置命令大全
  • Cisco思科光纤交换机怎么配置呢?相信很多网友还是不太了解,下面就为大家收集的Cisco思科光纤交换机配置说明教程,一起来看看了解下
  • 思科华为华三交换机常用命令的对比,包含三家所有常用的命令
  • 思科交换机命令大全

    千次阅读 2015-10-15 22:05:45
    为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name 21. 为了从一条中继链路上删除VLAN,可使用下列命令: switch...
  • 思科arp手册,ccna或者从事交换机测试工作开发、测试人员必备。
  • 1.设置主机名/系统名 IOS:switch(config)# hostname "hostname" CLI:switch(enable) set system name name-string 2.设置登录口令 IOS:switch(config)# enable password level 1 password ...
  • 思科交换机配置命令

    2018-06-13 13:41:36
    思科交换机配置命令(全面经典)!!!!!!!1!!!!!
  • 可以转换华为和思科命令,相互转换十分强大
  • 思科交换机查看配置及日常维护命令,方便日常维护查询
  • 思科交换机命令大全.txt 防火墙配置必备
  • 思科交换机命令大全 思科交换机命令大全思科交换机命令大全
  • 交换机常用命令,当你在配置交换机时,可以迅速查找到常用的命令
  • 思科交换机常用配置命令》学习笔记(更新中)

    万次阅读 多人点赞 2018-12-09 13:21:40
    1、基本配置 Switch>enable //进入特权模式 Switch# Switch#configure ...Switch(config)#hostname cisco-sw1 //修改交换机名称 cisco-sw1(config)#enable password cisco //配置交换机明文密码,登录特...
  • 思科交换机-常用命令及配置

    万次阅读 多人点赞 2017-09-06 12:17:48
    switch> 用户模式 1:进入特权模式enable switch> enable switch#   2:进入全局配置模式configure terminal switch> enable ...3:交换机命名hostname name 以cisco001 为例 switch> enable
  • cisco交换机命令大全

    2010-12-03 08:25:03
    cisco交换机命令大全 1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的...
  • 思科交换机命令大全基于ios的交换机命令 基于CLI的交换机命令
  • 思科交换机:基本命令(上)

    千次阅读 2020-10-26 19:35:52
    五、show查看命令 查看交换机接口 Switch>show ip interface brief 查看vlan Switch>show vlan 查看路由表 R1(config)#do show ip route Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - ...
  • 11.配置VTP管理域 switch# vlan database ...为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令:  switch(config)# cluster enable cluster-name

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 9,432
精华内容 3,772
关键字:

思科交换机命令