精华内容
下载资源
问答
  • 交换机原理

    千次阅读 2021-05-10 12:58:34
    交换机原理

    交换机原理
    Access接口类型与Trunk接口类型
    网络拓扑图
    在这里插入图片描述

    实验要求:
    1.将S1的两个端口加入到VLAN10,将S2的两个端口加入到VLAN20,测试两台PC能否通信?分析原因(YES)
    2.将S1的E0/0/2端口改为TRUNK端口,允许VLAN10通过,将S2的E0/0/2端口改为TRUNK端口,允许VLAN20通过,测试两台PC能否通信?分析原因(NO)
    第一题配置命令:
    S1
    system-view
    [Huawei]sysname S1
    [S1]vlan batch 10 20
    [S1]interface e0/0/1
    [S1-Ethernet0/0/1]port link-type access
    [S1-Ethernet0/0/1]port default vlan 10
    [S1-Ethernet0/0/1]interface e0/0/2
    [S1-Ethernet0/0/2]port link-type access
    [S1-Ethernet0/0/2]port default vlan 10
    S2
    system-view
    [Huawei]sysname S2
    [S2]vlan batch 10 20
    [S2]interface e0/0/1
    [S2-Ethernet0/0/1]port link-type access
    [S2-Ethernet0/0/1]port default vlan 20
    [S2-Ethernet0/0/1]interface e0/0/2
    [S2-Ethernet0/0/2]port link-type access
    [S2-Ethernet0/0/2]port default vlan 20
    测试PC1与PC2通信
    在这里插入图片描述

    从结果可以看出处于两个不同VLAN的PC可以进行通信
    分析、原因
    通过对交换机S1的E0/0/2端口和交换机S2的E0/0/1端口进行抓包测试
    S1 – E0/0/2端口
    在这里插入图片描述

    S2 – E0/0/1端口
    在这里插入图片描述

    从图中可知从两个交换机中发出的数据均不带Tag数据帧
    原因:
    当Access接口收到一个无标记帧时,交换机会接受这个数据帧,并将数据帧打上接口缺省VLAN的Tag,交换机S1的E0/0/1接口为Access接口,而且加入了VLAN10,当E0/0/1收到来自PC1的一个数据帧时,交换机会接收这个数据帧并将数据帧打上VLAN10的Tag。
    当Access接口发送数据帧时,交换机会将数据帧中的Tag删除,然后再将数据帧从该接口发送出去,交换机S1的E0/0/2接口为Access接口,并且加入了VLAN10,在交换机内部的数据帧从E0/0/2接口发出时,Tag会被删除,前提是,交换机内的数据帧所携带的VLAN-ID为10,否则无法从E0/0/2接口发出。S2同理,如下图所示。
    在这里插入图片描述

    第二题配置命令:
    S1
    system-view
    [Huawei]sysname S1
    [S1]vlan batch 10
    [S1]interface e0/0/1
    [S1-Ethernet0/0/1]port link-type access
    [S1-Ethernet0/0/1]port default vlan 10
    [S1-Ethernet0/0/1]interface e0/0/2
    [S1-Ethernet0/0/2]port link-type trunk
    [S1-Ethernet0/0/2]port trunk allow-pass vlan 10
    S2
    system-view
    [Huawei]sysname S2
    [S2]vlan batch 20
    [S2]interface e0/0/1
    [S2-Ethernet0/0/1]port link-type access
    [S2-Ethernet0/0/1]port default vlan 20
    [S2-Ethernet0/0/1]interface e0/0/2
    [S2-Ethernet0/0/2]port link-type trunk
    [S2-Ethernet0/0/2]port trunk allow-pass vlan 20
    测试PC1与PC2通信
    在这里插入图片描述

    从结果可以看出处于PC1与PC2无法进行通信
    分析、原因
    通过对交换机S1的E0/0/2端口和交换机S2的E0/0/1端口进行抓包测试
    S1 – E0/0/2端口
    在这里插入图片描述

    S2 – E0/0/1端口
    在这里插入图片描述

    由图可知数据帧可以从S1交换机发出,而无法进入S2交换机
    原因:
    当交换机S1准备发送数据帧时,由第一题S1的E0/0/1 Access接口可知,此时交换机内的数据帧的VLAN-ID为10,与发送接口E0/0/2的PVID不同,而VLAN10又在该接口允许通过的VLAN-ID列表中,因此保留这个数据帧原有的Tag,并从E0/0/2接口发出。

    当带有VLAN-ID为10的数据帧到达S2交换机的E0/0/2接口时,交换机查询到VLAN20不在允许通过的VLAN-ID列表中,则被丢弃掉。如下图所示。
    在这里插入图片描述

    展开全文
  • 1-程控交换机原理.ppt

    2020-07-31 10:41:17
    1-程控交换机原理,程控交换机原理,程控交换机原理,程控交换机原理,程控交换机原理,程控交换机原理,程控交换机原理,程控交换机原理,程控交换机原理
  • 交换机原理及交换机基本配置
  • 交换机原理交换机原理.doc、交换机原理交换机原理.doc
  • 交换机原理  数据传输基于OSI七层模型,而交换机就工作于其第二层,即数据链路层。在交换机内部存有一条背部总线和内部交换矩阵,其中,背部总线用于连接交换机的所有端口,内部交换矩阵用于查找数据包所需传送的...

    原文连接:http://www.elecfans.com/dianzichangshi/20171204593673.html

    交换机原理

      数据传输基于OSI七层模型,而交换机就工作于其第二层,即数据链路层。在交换机内部存有一条背部总线和内部交换矩阵,其中,背部总线用于连接交换机的所有端口,内部交换矩阵用于查找数据包所需传送的目的地址所在端口。

      控制电路受到数据包后,首先通过内部交换矩阵对其目的端口进行查询,若查询到则立刻将数据包发往该端口,若没有查询到,则广播至所有端口,接受端口发出回应后,将数据包发往该端口,并将其添加至内部交换矩阵中。

      交换机原理_交换机工作原理解析

      交换机工作原理解析

      交换机并不会把收到每个数据信息都以广播的方式发给客户端,是由于交换机可以根据MAC地址智能的转发数据帧。交换机存储的MAC地址表将MAC地址和交换机的接口编号对应在一起,每当交换机收到客户端发送来的数据帧时,它就会根据MAC地址表的信息判断该如何转发。

      交换机转发数据帧的过程

      1、MAC地址的学习

      如下面图所示,假设A主机发送的数据帧(源MAC地址为00-00-00-11-11-11,目标MAC地址为00-00-00-22-22-22)到交换机的1号接口,交换机首先查询的MAC地址表中1号接口对应的源MAC地址条目,如果条目中没有数据帧的源MAC地址,交换机会就将这个接口对应的源地址和收到该数据帧的接口标号(1号口)对应起来,添加到MAC地址表中

      交换机原理_交换机工作原理解析

      2、广播未知数据帧

      如果交换机没有在MAC地址表中找到数据帧目的地所对应的条目,交换机就无法确定该从那个接口将数据帧转发出去,于是它被迫选用了广播的方式,即除了1号口之外的所有接口都将转发这个数据帧,我下面图所示,于是,网络中的主机B和主机C都会收到

      交换机原理_交换机工作原理解析

      3、接收回应信息

      主机B会响应这个广播,并回应一个数据帧(源MAC地址为00-00-00-22-22-22,目标MAC地址为00-00-00-11-11-11),交换机也会将此帧的源MAC地址和接口标号(2号口)对应起来,添加到MAC地址表中,如下面图所示

      交换机原理_交换机工作原理解析

      4、交换机实现单播方式

      现在,主机A和主机B之间的通讯不用借助广播了。因为MAC地址表中已经有它们的条目了,如下面图所示,主机A发送的数据帧的目标地址为00-00-00-22-22-22,交换机会发现这个地址对应的接口号为2,于是交换机将只向2号口发送数据帧

      交换机原理_交换机工作原理解析

      查看MAC地址表

      1、MAC地址表相当于交换机内部的一个数据库,记录着MAC地址和接口编号的对应关系。查看MAC地址表的命令如下面你图所示。dynamic为可选参数,它可以使交换机只显示交换机动态靴子到的MAC地址

      交换机原理_交换机工作原理解析

      2、如下面如所示,SW1和SW2与PC1、PC2、CP、、PC3、互连在一起,在SW1上使用上述命令查看MAC地址表

      交换机原理_交换机工作原理解析

      3、由于windows系统在接入网络后会自动查询是否有其他主机存在,所以,交换机已经学习到三台主机的MAC地址。

      4、这里值得关注的问题是,虽然PC3与SW1没有直接相连,PC3的MAC地址也存在域SW1的MAC地址表中,且对应着接口Fa0/24。这是由于交换机之间互相学习(同步)

      MAC地址表所致。从MAC地址表中可以看出,SW1通过接口Fa0/24与SW2相连,于是SW1就将从SW2同步过来的MAC地址全部对应到Fa0/24接口上。

    展开全文
  • 以太网交换机原理

    2012-04-18 17:57:51
    以太网交换机原理 一、基本以太网 二、交换机原理与应用 三、三层交换的概念 四、四层交换技术
  • 交换机原理概述

    2012-12-24 00:09:23
    交换机原理概述
  • 现代交换机原理

    2013-05-14 08:21:01
    现代交换机原理 交换机实验 实验课程 实验报告 报告说明
  • 交换机原理

    2012-02-10 10:12:27
    交换机原理图,大家学习单片机的,青睐下载吧
  • 以太网交换机原理与应用以太网交换机原理与应用以太网交换机原理与应用以太网交换机原理与应用以太网交换机原理与应用
  • RTL8370,8口千兆网口交换机原理图。功能已验证,速度已测速通过。电源设计,变压器设计,RJ45设计以及显示灯设计已经按照规格书设计了,并且验证OK了。
  • 交换机原理详解

    2019-01-15 00:19:00
    不懂交换机的,看这一个文档就能入门了,大公司技术专家写的,讲的深入浅出,非常清楚明白。包括VLAN原理等。
  • 高层交换机原理高层交换机原理及其组网结构及其组网结构
  • 交换机原理与配置

    2019-10-16 11:54:16
    交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。...交换机原理 1、以太网MAC地址 用来识别一个以太网上的某个单独的设备或一组设备,它由48位二进制...

    交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。交换机工作于OSI参考模型的第二层,即数据链路层
    在这里插入图片描述

    数据链路层的功能

    (1)数据链路的建立、维护与拆除
    (2)帧包装、帧传输、帧同步
    (3)帧的差错恢复
    (4)流量控制

    交换机原理

    1、以太网MAC地址

    用来识别一个以太网上的某个单独的设备或一组设备,它由48位二进制组成。
    在这里插入图片描述

    2、以太网帧格式

    以太网有多种帧格式,常用的是Ethernet II格式
    在这里插入图片描述

    3、交换机转发原理

    (1)初始状态
    一台新的交换机刚接入网络对外界一无所知
    (2)MAC地址学习
    A和B通讯,数据帧到达交换机后,交换机MAC地址表会学习源MAC和端口号
    (3)广播未知数据帧
    交换机不知道B在哪里后会产生广播,寻找B
    (4)接收方回应
    B接收后回应A,这时候B变成了源主机,到达交换机后,交换机MAC地址表会学习住源MAC和端口号,再转发给A
    (5)交换机实现单播通信
    交换机MAC地址表学习双方MAC地址和端口后,两台计算机再通信交换机可以直接转发,实现单播通信
    在这里插入图片描述

    4、交换机以太网接口的工作模式

    单工:两个数据站之间只能沿单一方向传输数据
    半双工:两个数据站之间可以双向数据传输,但不能同时进行
    全双工:两个数据站之间可双向且同时进行传输

    5、交换机以太网接口速率

    接口连接时进行协商
    协商失败则无法正常通信

    交换机简单配置

    1、命令行的层次关系

    在这里插入图片描述

    2、常间的简单命令

    显示命令、显示参数、命令列表

    Tab补齐命令、提示命令

    enable用户模式进入特权模式

    disable特权模式返回用户模式

    configure terminal特权模式进入全局模式

    interface fastethernet1/0全局模式进入接口模式(“1/0”为需要设置对应的接口)

    exit返回上一层

    end返回特权模式

    no ip routing关闭路由功能

    show running查看运行配置

    do show running跨模式查看运行配置

    show version 查看版本信息

    show mac-address-table 查看MAC地址表

    speed 100设置速率为100M/s

    duplex full设置接口模式为全双工

    展开全文
  • 在本文中,我们会在eNSP中搭建一个简单的含有PC机和交换机的局域网拓扑,在PC相互通信时通过wireshark抓包来查看交换机工作过程并查看交换机MAC地址表来学习交换机原理

    本文概述

    在本文中,我们会在eNSP中搭建一个简单的含有PC机和交换机的局域网拓扑,在PC相互通信时通过wireshark抓包来查看交换机工作过程并查看交换机MAC地址表来学习交换机原理。

    理论

    数据链路层

    我们知道交换机是工作在二层数据链路层的
    数据链路层位于网络层和物理层之间,数据单元(PDU)为数据帧
    数据链路层功能:数据链路层的建立、维护和拆除;帧包装、帧传输和帧同步;帧的差错恢复;流量控制
    在这里插入图片描述

    请大家认真的记一记各层的数据单元

    以太网MAC地址

    以太网是当今现有局域网采用的最通用的通信协议标准。MAC用来识别一个以太网上的某个单独的设备或一组设备。
    前24比特为供应商标识,如08005a表示IBM(国际商业机器公司)
    后24比特为网卡编号,第8比特需要注意0或1代表不同。
    在这里插入图片描述

    以太网帧格式

    目的地址和源地址均为MAC地址;类型用来标识上层协议如0800H表示网络层的IP协议
    在这里插入图片描述

    交换机工作原理

    交换机工作原理:某局域网内两台主机AB通过交换机互相通信时,初始状态交换机mac表为空,当主机A发出含有目的MAC地址和源 Mac地址的数据帧到达交换机,交换机更新源主机A的MAC地址和接口号到MAC地址表,然后在局域网内广播泛洪主机A的数据帧,主机B收到广播后发现是找自己的则向A进行回应(mac表中此时已有A的Mac地址和接口号),交换机更新主机B的MAC地址和接口号到MAC表,其他主机收到广播知道不是找自己的则丢弃广播包,后续主机AB再进行通信时由于交换机MAC表中已有相关条目则可实现单播。
    在这里插入图片描述

    总结:交换机先学习后转发,学习源MAC地址,转发目的MAC地址,没有MAC的广播泛洪

    实验

    简单命令

    查看MAC地址表:display mac-address

    实验内容

    实验拓扑

    在这里插入图片描述

    具体步骤

    PC配置
    这是PC1的,其他PC都这样配上相应的地址就好了。
    在这里插入图片描述
    配好地址后,在拓扑图中蓝色点抓包,右击节点->开始抓包,用PC1去pingPC4,查看抓包情况,我们可以看到有请求MAC地址的过程,之后看到两个PC之间实现单播通信了。
    在这里插入图片描述
    在这里插入图片描述
    查看交换机上的MAC地址表,都已经更新了PC1和PC4应该从哪个接口去转发
    在这里插入图片描述

    如果看不到mac地址表,可能是ping后隔太长时间才去查看mac地址表造成的,它会清除的,所以再ping一次去查看就好了

    学习笔记供参考,祝大家学习顺利><

    展开全文
  • 三层交换机原理与设计 从原理和设计方面阐述交换原理和设计的原理。
  • 交换机原理与配置一. 了解以太网帧结构1. 数据链路层的功能2. 以太网的由来3. 以太网帧格式3.1 MAC地址:3.2 以太网帧格式:二. 理解交换机转发原理1. 交换机介绍2. 交换机的工作原理3. 交换机接口的双工模式4. ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 60,377
精华内容 24,150
关键字:

交换机原理