精华内容
下载资源
问答
  • acl配置
    千次阅读
    2021-06-21 11:34:58

    交换机ACL配置
    在这里插入图片描述
    实验要求:PC3能ping通R3和R4
    PC2能ping通R3和R4
    R3和R4全网互通
    通过ACL使PC2不能ping通PC3
    先给每个接口配置ip:
    PC3:192.168.5.3/24 192.168.5.254
    PC2:192.168.6.6/24 192.168.6.254
    R1 e0/0/1:192.168.5.254/24 e0/0/0:192.168.1.254/24
    R2 e0/0/1:192.168.3.254/24 e0/0/0:192.168.6.254/24
    R3 e0/0/0:192.168.2.254/24
    R4 e0/0/0:192.168.4.254/24
    LSW2 g0/0/1:192.168.1.100/24 e0/0/1:192.168.3.100/24
    e0/0/2:192.168.2.100/24 e0/0/3:192.168.4.100/24
    先在交换机上建立4个vlan,并给每个接口都划分一个vlan
    vlan batch 2 3 4 5
    int g0/0/1
    port link-type access
    port default vlan 2
    再给vlan配置ip地址
    int vlanif2
    ip add 192.168.1.100 24
    其余三个接口根据上面步骤顺序配置
    在每个路由器上配置一条缺省路由,以R1为例
    ip route-static 0.0.0.0 0 192,168.1.100
    再交换机上配置2条静态路由使PC2和PC3实现互通
    ip route-static 192.168.5.0 255.255.255.0 192.168.1.254
    ip route-static 192.168.6.0 255.255.255.0 192.168.3.254
    配置ACL,并在LSW2接口e0/0/1上引用,实现PC2ping不通PC3
    acl number 3001
    rule deny ip source 192.168.6.0 0.0.0.255 destination 192.168.5.0 0.0.0.255
    int e0/0/1
    traffice-filter inbound acl 3001

    更多相关内容
  • 访问控制列表ACL(Access Control List)是实现网络安全、性能稳定...2 ACL支持的License和配置注意事项 3 配置基于接口的ACL 4 配置基本ACL 5 配置高级ACL 6 配置二层ACL 7 配置用户ACL 8 配置基于MPLS的ACL 9 维护ACL
  • 华为高级ACL配置.topo

    2019-08-27 14:58:20
    实验名称:华为高级ACL配置 需求: 1)允许Client1访问Server1的Web服务 2)允许Client1访问网络192.168.2.0/24 3)禁止Client1访问其它网络
  • ACL配置

    2022-07-19 13:43:17
    访问控制列表(ACL)是一种基于包过滤的访问控制技术,它可以根据设定的条件对接口上的数据包进行过滤,允许其通过或丢弃。访问控制列表被广泛地应用于路由器和三层交换技术,借助于访问控制列表,可以有效地控制用户...

    一、简介

            访问控制列表(ACL)是一种基于包过滤的访问控制技术,它可以根据设定的条件对接口上的数据包进行过滤,允许其通过或丢弃。访问控制列表被广泛地应用于路由器和三层交换技术,借助于访问控制列表,可以有效地控制用户对网络的访问,从而最大程度地保障网络安全。

    二、工作原理

            总之,一入站数据包,由路由器处理器调入内存,读取数据包的包头信息,如目标IP地址,并搜索路由器的路由表,查看是否在路由表项中,如果有,则从路由表的选择接口转发(如果无,则丢弃该数据包),数据进入该接口的访问控制列表(如果无访问控制规则,直接转发),然后按条件进行筛选。

            当ACL处理数据包时,一旦数据包与某条ACL语句匹配,则会跳过列表中剩余的其他语句,根据该条匹配的语句内容决定允许或者拒绝该数据包。如果数据包内容与ACL语句不匹配,那么将依次使用ACL列表中的下一条语句测试数据包。该匹配过程会一直继续,直到抵达列表末尾。

            最后一条隐含的语句适用于不满足之前任何条件的所有数据包。这条最后的测试条件与这些数据包匹配,通常会隐含拒绝一切数据包的指令。此时路由器不会让这些数据进入或送出接口,而是直接丢弃。最后这条语句通常称为隐式的“deny any”语句。由于该语句的存在,所以在ACL中应该至少包含一条permit语句,否则,默认情况下,ACL将阻止所有流量。

     三、应用

    1. 应用在接口的ACL——过滤数据包(源目ip地址,源目mac, 端口)
    2. 应用在路由协议——匹配相应的路由条目
    3. NAT、IPSEC VPN、QOS-----匹配感兴趣的数据流(匹配上我设置的 数据流的)

    四、种类

    • 编号2000-2999——基本ACL——依据依据数据包当中的源IP地址匹配数据(数据时从 哪个IP地址 过来的)
    • 编号3000-3999——高级ACL——依据数据包当中源、目的IP,源、目的端口、协议号匹配数据
    • 编号4000-4999——二层ACL——MAC、VLAN-id、802.1q 

    五、配置实例 

    1.配置客户端和服务器ip

    pc1:192.168.1.1/24

    pc2:192.168.1.2/24

    server1:192.168.2.1/24

    server2:192.168.3.1/24

    2.配置路由接口ip

    3.配置接口acl过滤ip

    需求1配置:

    基本acl范围:2000 ~ 2999

    acl规则条目:默认起始序号为5,step为5(便于更改插入条目)

    通配符:在acl中,可使用通配符掩码指定特定网络或者特定主机的范围,通配符中0对应ip地址不可变位,1对应ip地址中可变位。

    - 单个ip地址通配符:0

    - 一个网段中所有ip地址:0.0.0.255

    acl方向:
    inbound方向——当接口收到数据包时执行ACL
    outbound方向——当设备从特定接口向外发送数据时执行ACL 

    需求2配置:

    4.测试需求

    需求1:

     需求2:

      

    展开全文
  • 华为ACL配置.zip

    2020-03-08 23:54:18
    华为ACL访问控制列表协议通信技术,本文档内包含了(基本ACL+高级ACL+综合应用)设备拓扑以及设备代码,下载解压后可以直接查看设备代码,用eNSP打开后(给PC配好地址)可以直接通信
  • acl配置

    千次阅读 2021-07-18 15:05:17
    基本acl配置案例 配置基本acl步骤 配置规则生效时间段 执行命令system-view,进入系统视图。 执行命令time-rangetime-name{start-timetoend-time{days} &<1-7> |fromtime1date1[to...

    1 配置

    1. 基本acl配置案例

    配置基本acl步骤

    配置规则生效时间段

    1. 执行命令system-view,进入系统视图。
    2. 执行命令time-range time-name { start-time to end-time { days } &<1-7> | from time1 date1 [ to time2 date2 ] },创建一个时间段。

    创建基本ACL

    1. 执行命令acl { [ number ] acl-number | name acl-name { [ number ] acl-number | basic } },创建基本ACL,并进入基本ACL视图。

      基本ACL编号acl-number的范围是2000~2999。

      缺省情况下,未创建ACL。

    2. (可选)执行命令step step,配置ACL步长。

      缺省情况下,步长值为5。

    3. (可选)执行命令description text,配置ACL描述信息。

      缺省情况下,未配置ACL的描述信息。

    配置规则

    1. 执行命令rule [ rule-id ] [ name rule-name ] { deny | permit } [ fragment-type fragment | source { source-ip-address { source-wildcard | 0 | src-netmask } | any } | time-range time-name | vpn-instance vpn-instance-name | logging ] *,配置基本ACL的规则

     1;配置接口地址,不再讲述

    2;配置acl

    #配置基本ACL

    acl number 2000 

     rule 5 deny source 192.168.1.2 0

     rule 10 permit

    interface GigabitEthernet0/0/0

     ip address 192.168.1.254 255.255.255.0

     traffic-filter inbound acl 2000 #调用ACL

    #

    disp  acl  all (查看ACL)

     Total quantity of nonempty ACL number is 1

    Basic ACL 2000, 2 rules

    Acl's step is 5

     rule 5 deny source 192.168.1.2 0 (5 matches)

     rule 10 permit (994 matches)

    基本acl常用在限制用户这块,目的为了安全,只让特定的网段进来。

    1. 高级acl配置案例

    2 检查

    3 个人体验

    展开全文
  • 《华为基础实验》- 实验二十九 基于时间的 ACL 配置及策略.docx
  • SANGFOR_AD_V5.2_ACL配置指导书.pdf
  • 详细解答华为S5700交换机, VLAN划分 和 ACL配置命令,非常适合新手
  • 华为[ENSP]ACL配置实例(访问控制列表配置实例)

    万次阅读 多人点赞 2022-04-03 19:30:42
    华为[ENSP]ACL配置实例(访问控制列表配置实例)

    ACL配置实验一(高级ACL)(简单)的拓扑图如下:


    一、配置PC1、PC2和Server

     


     二、配置Router(运用高级ACL配置)

    相关命令解析:

    [Router]acl 3000(进入高级ACL配置,编号为3000)
    
    [Router-acl-adv-3000]route 1 permit source 10.1.7.66 0(0为通配符掩码) destination 20.1.1.2 0(0为通配符掩码)
    
    [Router-acl-adv-3000]route 2 deny source 10.1.7.2 0 destination 20.1.1.2 0
    
    //通配符掩码:0.0.0.0,表示唯一匹配的一个主机地址(对于华为eNSP的命令直接输0也可以)
    
    //rule 1/rule 2表示设立一条规则,编号为一/二
    
    //permit是允许通过的意思,deny是不允许通过的意思
    
    [Router-GigabltEthernet0/0/0]traffic-filter outbound acl 3000 
    //意思是把acl 3000的配置这条规则放在G0/0/0这个端口之下,并在接口上配置基于ACL对报文进行过滤。

    traffic-filter命令用来在接口上配置基于ACL对报文进行过滤。 

    使用实例

    # 在Eth2/0/0上配置基于ACL对报文流进行过滤,允许源IP为192.168.0.2/32的报文通过。
    
    <Huawei> system-view 
    [Huawei] acl 3000
    [Huawei-acl-adv-3000] rule 5 permit ip source 192.168.0.2 0 
    [Huawei-acl-adv-3000] quit 
    [Huawei] interface ethernet 2/0/0 
    [Huawei-Ethernet2/0/0] traffic-filter inbound acl 3000

    区分反掩码和通配符掩码

    反掩码其实就是用255.255.255.255减去掩码,剩下的就为反掩码。反掩码也必须由从右到左连续的“1”和“0”组成 。通配符掩码和反掩码很不同的一点是反掩码必须有连续的"1"和"0"组成,但是通配符的"1"可以被"0"隔开。通配符掩码中"0"代表精确匹配,"1"代表任意匹配。当然,通配符掩码的计算方式类似于反掩码,在细节上又不同于反掩码。

    举例1:192.168.1.0  0.0.0.255这条规则匹配了192.168.1.0 /24 这个网段,共有256个地址

    把点分十进制组成的0.0.0.255通配符掩码写成二进制,就变为00000000 00000000 00000000 11111111,因为在通配符掩码中,"0"代表精确匹配,"1"代表任意匹配,因此,IP地址只匹配最后八位11111111,共有2^8=256个地址数可供选择,所以,可以匹配的地址就是192.168.1.0~192.168.1.255


     三、实验结果(能Ping通PC2但无法Ping通PC1)


     ACL配置实验二(基本ACL)的拓扑图如下:


     一、配置PC1、PC2和路由器AR1、AR2


    二、配置静态路由使得PC1、PC2能够Ping通AR2

    相关解析:

    [R2]ip route-static 172.16.1.0 24 12.1.1.1
    //配置静态路由命令,24表示掩码位数,172.16.1.0是目标网段地址,12.1.1.1是AR2路由器的下一跳地址。


     三、配置基本ACL(使得PC1无法访问(Ping通)AR2,PC2可以访问(Ping通)AR2)

    1.在路由器R1上配置基本ACL 并确认ACL配置结果,然后调用ACL并且检查ACL调用结果

    命令格式: 

    执行命令rule [ rule-id ] { deny | permit } [ source { source-address source-wildcard | any } | fragment | logging | time-range time-name | { vpn-instance vpn-instance-name | public } ] *

    [R1]acl 2000

    [R1-acl-basic-2000]rule 1 deny source 172.16.1.100 0  //不允许PC1访问

    [R1-acl-basic-2000]rule 2 permit source 172.16.1.200 0  //允许PC2访问

    [R1-acl-basic-2000]rule permit  //放行其他流量,系统默认为拒绝所有流量

    [R1-acl-basic-2000]dis this  //查看ACL配置结果

    [R1]int g0/0/1  //进入端口号g0/0/1调用ACL

    [R1-GigabitEthernet]traffic-filter outbound 2000  //前面ACL实验一已有详细解释,不再赘述。

    [R1-GigabitEthernet]dis this //查看g0/0/1接口的ACL调用情况

      

    2.测试PC1、PC2能否访问路由器R2

     3.检查ACL的匹配情况

    由图可知,由匹配数字,说明配置的基本ACL生效了,一个基本ACL配置实验完成。


     ACL配置实验三(高级ACL)的拓扑图如下:


    一、配置R1、R2、R3、R4


    二、配置静态路由使得各个路由器可以连通


    三、测试Telnet功能

    1.开启Telnet

     2.测试Telnet


    四、配置高级ACL

    [R2-acl-adv-3000]rule deny tcp destination 12.1.1.2 0 destination-port 
    eq 23 source 172.16.1.200 0 
    
    //这是一条ACL规则,意思是拒绝目的TCP端口为23号端口的数据包,(telnet使用的是
    //tcp23号端口),作用即如果有数据包是访问某IP的telnet端口的,则会被拒绝掉。
    //eq 是端口的意思

    inbound和outbound的区别

    inbound代表ACL入接口,outbound代表ACL出接口,可与前面的实验一进行对比。


    五、检查实验结果

    由图可知路由器R3可以Telnet路由器R2,而路由器R4不能Telnet路由器R2。同时其他业务没有受到影响。

     由上面两图可知,ICMP的流量正常。最后,让我们看一下ACL匹配情况。ACL的匹配项验证结果如下图所示:

    由上图可知,匹配情况正常,这说明ACL匹配成功,且应用成功。至此,配置实验完毕。


     ACL配置实验四(基于时间的ACL及其配置实例)的拓扑图如下:

    继续实验三的实验完成实验四的配置:


    一、配置基于时间的ACL 

    1.在路由器R2上配置基于时间的ACL

     2.调用基于时间的ACL


    二、测试

    1.在路由器R2上查看时间,如下图所示,验证VRP系统的时间

    2.由上图可知,在访问时间内,发起Telnet会话,如下图所示,完成有效时间内的网络测试

     3.由上图可知,Telnet配置成功。最后我们来查看一下基于时间的ACL是否匹配,如下图所示,进行生效验证。

    由上图可知,有的字段为Active,并且由匹配项,这说明是在正确的时间内进行访问的。读者可以测试一下,不在规则的时间内进行访问的结果,测试结果会告诉你,基于时间的ACL可以有效控制网络访问。


    展开全文
  • cisco最完美的ACL配置详解及配置全过程cisco最完美的ACL配置详解及配置全过程cisco最完美的ACL配置详解及配置全过程cisco最完美的ACL配置详解及配置全过程cisco最完美的ACL配置详解及配置全过程cisco最完美的ACL配置...
  • kafka acl配置

    千次阅读 2021-12-13 15:59:09
    kafka acl配置_ahzsg1314的专栏-CSDN博客_kafka 配置acl 概览 kafka附带一个可插拔的Authorizer和out-of-box authorizer实现,并使用zookeeper来存储所有acl。默认情况下,如果资源R没有关联acl,除了超级用户,...
  • 高级ACL配置

    2021-11-18 12:53:07
    配置高级acl总结与思考 原理概述 基本的acl只能用于原IP地址和实际应用当中,往往需要针对数据包的其他参数进行匹配,比如目的IP协议号,端口号等,所以基本的acl由于匹配的局限性而无法实现更多的功能,所以就需要...
  • ACL(Access Control List,访问控制列表)是由一系列规则组成的集合,ACL通过这些规则对数据包进行分类,进而路由设备根据这些规则判断数据包被拒绝或者被接受。ACL可以用于很多的业务中,比如路由策略、流量策略、...
  • ACL配置实验报告(XDU物联网安全)

    千次阅读 2021-07-30 12:55:53
    ACL配置实验 一、实验目的 深入理解用ACL实现访问控制的工作原理 二、实验所用仪器(或实验环境) 计算机科学与技术学院实验中心,可接入Internet网台式机44台。 三、实验基本原理及要求 拓扑结构如下图所示(要求:...
  • ACL配置实验
  • H3C--ACL配置实践

    千次阅读 2021-12-26 15:46:28
    2.会基本ACL配置; 3.会高级ACL配置。 实验任务与要求: 1.按照图示配置各个网段的 IP 地址。 2.按照图示采用RIPv2路由协议,实现全网互通。 3.在服务器上配置开启 TELNET 和 FTP 服务。 4.配置 ACL ...
  • cisco实现ACL配置

    千次阅读 2021-06-17 23:09:36
    1. 什么是ACL 大家先看下面这张图: 当给路由器R1和路由器R2均配好路由选择协议之后 PC1可以ping通PC3 PC2也可以ping通PC3 那如果我现在不想让PC2去ping通PC3咋办,那就是去实现ACL(可以在路由器R2上去实现,也...
  • ACL配置及原理

    2021-08-28 08:37:44
    总结:ACL配置的时候需要首先全网互通,互通以后再操作ACL策略的设置 一、ACL-访问控制列表 作用:读取三层、四层头部信息,根据预先定义好的规则对流量进行筛选、过滤。 层头部信息:源、目IP 四层头部信息:源、目...
  • 华为交换机ACL配置

    千次阅读 2022-07-09 16:55:29
    一、ACL的概述ACL:访问控制列表 ※是由一系列permit和deny语句组成的(后面跟着条件列表)、有序规则的列表,它通过匹配报文的相关信息实现对报文的分类。 ※ACL本身只能够用于报文的匹配和区分,而无法实现对报文...
  • 锐捷交换机ACL配置

    2010-05-08 18:30:37
    锐捷交换机ACL配置 基于时间的acl配置
  • 03 ACL配置.doc

    2012-09-29 22:47:03
    7 ACL配置 7-1 7.1 访问控制列表简介 7-2 7.1.1 访问控制列表概述 7-2 7.1.2 访问控制列表的分类 7-2 7.1.3 访问控制列表的匹配顺序 7-2 7.1.4 访问控制列表的步长设定 7-4 7.1.5 基本访问控制列表 7-4 7.1.6 高级...
  • 思科标准ACL配置

    千次阅读 2021-05-24 16:59:38
    思科标准ACL配置 思科标准ACL配置 应用标准ACL实现PC3禁止访问PC1,PC2可以访问PC1 配置IP地址 配置静态路由 配置完IP地址和静态路由后查看连通性 创建...
  • 路由器防火墙ACL配置

    2022-04-15 10:41:28
    路由器防火墙ACL配置
  • 思科标准与扩展ACL配置实验

    千次阅读 2021-05-05 22:30:48
    一.ACL概述 1.简介 ACL(访问控制列表)ACL (Access Control List,访问控制列表)是一系列运用到路由器接口的策略列表。这些策略告诉路由器接收哪些数据包、拒绝哪些数据包,接收或者拒绝根据一定的规则进行,如源...
  • ACL配置实验

    2019-01-30 14:19:40
    路由与交换技术实验报告:ACL配置实验。 包括实验目的、实验要求、实验拓扑、具体过程、心得体会等内容。
  • ACL配置实验拓扑实验准备实验思路实验步骤实验验证 实验拓扑 实验准备 实验思路 如果要让vlan10 ping不通vlan20,可以在R1路由器上设置普通的acl策略,阻止源为vlan10网段的ip的访问,然后把策略映射到vlan...
  • ENSP配置 实例十 ACL配置

    千次阅读 2020-06-19 12:38:03
    ENSP配置 实例十 ACL配置 R1 [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24 [R1-GigabitEthernet0/0/0]int g0/0/1 [R1-GigabitEthernet0/0/1]ip add 10.0.12.1 24 [R1]ip route-static 192.168...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 95,250
精华内容 38,100
关键字:

acl配置