精华内容
下载资源
问答
  • pppoe拨号

    2017-10-25 10:32:11
    pppoe拨号上网,又叫做ADSL拨号上网、宽带拨号上网。这种上网方式,宽带运营商会分配一个宽带账号、宽带密码给用户;在未使用路由器的情况下,电脑上需要使用“宽带连接”拨号来实现上网;目前国内绝大多数用户办理...

    pppoe拨号上网,又叫做ADSL拨号上网、宽带拨号上网。这种上网方式,宽带运营商会分配一个宽带账号、宽带密码给用户;在未使用路由器的情况下,电脑上需要使用“宽带连接”拨号来实现上网;目前国内绝大多数用户办理的宽带,都属于pppoe拨号这种类型。

    在Windows7操作系统下设置宽带PPPOE的步骤:
    第一步:

    点击“开始”菜单,然后点击”控制面板”,进入到了计算机设置界面,点击”查看 网站状态和任务”选项进入“网络和共享中心”界面

    第二步:

    在“网络和共享中心”界面下选择”设置新的连接或网络”

    第三步:

    选择“ 连接到Internet “

    第四步:

    选择“ 宽带PPPOE(R) “

    第五步:

    进入到了关键的一步,需要填写运营商提供给我们上网的用户名及密码,并点击“连接”,然后会提示“正在连接到’宽带连接‘”,这时先点击下下面的“跳过”按钮,最后选择“关闭”。

    第六步:

    进入到上面说到的“网络和共享中心”界面,选择“更改网络适配器设置”选项

    第七步:

    可以看到我们新建立的“宽带连接”,双击打开,然后点击“连接”。这一步就完成了手动PPPOE拨号设置的全部步骤。

    https://jingyan.baidu.com/article/15622f245b0f3bfdfcbea5ab.html

    展开全文
  • PPPOE 拨号

    2012-06-01 21:58:08
    PPPOE拨号主要用于ADSL的拨号,但在终端用户的拨号中又有三种方式,一个是采用透明桥接,两是采用PPPOE,三是采用PPPOA。 在如上图中,最上面的就是透明桥接的接入方式 在下面的图中采用的PPPOE拨号方式,...

    PPPOE拨号主要用于ADSL的拨号,但在终端用户的拨号中又有三种方式,一个是采用透明桥接,两是采用PPPOE,三是采用PPPOA。

     
        在如上图中,最上面的就是透明桥接的接入方式
                                 在下面的图中采用的PPPOE拨号方式,中间的采用MODEM+路由器
                                 而在最下面图中,采用PC做为客户端,在系统下采用软件PPPOE拨号
     
     
        这样方式是采用PPPOA 即PPP over ATM. 在路由器上安装DSL模块来实现拨号功能
     
     
    一。实验目的
           了解PPPOE的拨号过程和PPPOE的工作原理
     
    二。实验配置
    R1#sh run
    Building configuration...
    Current configuration : 955 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    ip cef
    interface FastEthernet0/0
    no ip address
    duplex half
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp chap hostname R1
    ppp chap password 0 cisco!
    !
    省……
    end
          
    R2#sh run
    Building configuration...
    Current configuration : 1175 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    ip cef
    vpdn-group 1
    accept-dialin
    protocol pppoe
    virtual-template 1
    !
    username R1 password 0 cisco

    interface Loopback0
    ip address 10.1.1.1 255.255.255.0
    !        
    interface Loopback1
    no ip address
    !
    interface FastEthernet0/0
    no ip address
    duplex half
    pppoe enable
    !
    interface Serial1/0
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !        
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Virtual-Template1
    ip unnumbered Loopback0
    peer default ip address pool cisco
    ppp authentication chap
    !
    interface Virtual-TokenRing1
    no ip address
    ring-speed 16
    !
    ip local pool cisco 10.1.1.10 10.1.1.20
    ip classless
    no ip http server
    no ip http secure-server
    //以上配置不用解释了吧
     
    三。监视和配置测试
    1。R1拨号的过程
    R1(config-if)#
    *Jun 17 17:44:13.491: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    R1(config-if)#
    *Jun 17 17:44:22.727: Sending PADI: Interface = FastEthernet0/0
    *Jun 17 17:44:22.795: PPPoE 0: I PADO R:ca01.0498.0000 L:ca00.0498.0000 Fa0/0
    *Jun 17 17:44:24.807: PPPOE: we've got our pado and the pado timer went off
    *Jun 17 17:44:24.807: OUT PADR from PPPoE Session
    *Jun 17 17:44:24.863: PPPoE 29: I PADS R:ca01.0498.0000 L:ca00.0498.0000 Fa0/0
    *Jun 17 17:44:24.863: IN PADS from PPPoE Session
    *Jun 17 17:44:24.879: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
    *Jun 17 17:44:24.879: PPPoE: Virtual Access interface obtained.
    *Jun 17 17:44:24.883: PPPoE : encap string prepared
    *Jun 17 17:44:24.883: [0]PPPoE 29: data path set to Virtual Acess
    *Jun 17 17:44:24.883: Vi1 PPP: Using dialer call direction
    *Jun 17 17:44:24.887: Vi1 PPP: Treating connection as a callout
    *Jun 17 17:44:24.887: Vi1 PPP: Session handle[6700005A] Session id[0]
    *Jun 17 17:44:24.891: Vi1 PPP: Authorization required
    *Jun 17 17:44:24.891: Vi1 PPP: No remote authentication for call-out //采用单向认证
    *Jun 17 17:44:24.895: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
    *Jun 17 17:44:26.939: Vi1 PPP: No authorization without authentication
    *Jun 17 17:44:27.039: Vi1 CHAP: I CHALLENGE id 1 len 23 from "R2"
    *Jun 17 17:44:27.047: Vi1 CHAP: Using hostname from interface CHAP
    *Jun 17 17:44:27.047: Vi1 CHAP: Using password from interface CHAP
    *Jun 17 17:44:27.047: Vi1 CHAP: O RESPONSE id 1 len 23 from "R1"
    *Jun 17 17:44:27.359: Vi1 CHAP: I SUCCESS id 1 len 4
    *Jun 17 17:44:28.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
    R1(config-if)#do sh ip int brie
    Interface                  IP-Address      OK? Method Status                Protocol
    FastEthernet0/0            unassigned      YES unset up                    up     
    Serial1/0                  unassigned      YES unset administratively down down   
    Serial1/1                  unassigned      YES unset administratively down down   
    Serial1/2                  unassigned      YES unset administratively down down   
    Serial1/3                  unassigned      YES unset administratively down down   
    Virtual-Access1            unassigned      YES unset up                    up     
    Dialer1                    10.1.1.10       YES IPCP   up                    up
    可以看出R1从R2上获取到了IP地址
    R1(config-line)#do sh int dia 1
    Dialer1 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Internet address is 10.1.1.10/32
    MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 1 seconds on reset
    Interface is bound to Vi1
    Last input never, output never, output hang never
                省……
    Bound to:
    Virtual-Access1 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Listen: CDPCP
    Open: IPCP
    PPPoE vaccess, cloned from Dialer1
    Vaccess status 0x44, loopback not set
    Keepalive set (10 sec)
    Interface is bound to Di1 (Encapsulation PPP)
    Last input 00:07:00, output never, output hang never
    Last clearing of "show interface" counters 00:07:24
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
                  省……
    //从上面可以看出,我们能正常用运行商那里获得公网IP地址
     
    2。PPPOE上的认证过程
    服务端:
    R2(config-line)#do debug ppp authe
    PPP authentication debugging is on
    *Jun 17 18:00:24.243: ppp32 PPP: Using default call direction
    *Jun 17 18:00:24.247: ppp32 PPP: Treating connection as a dedicated line
    *Jun 17 18:00:24.247: ppp32 PPP: Session handle[F4000020] Session id[32]
    *Jun 17 18:00:24.251: ppp32 PPP: Authorization required
    *Jun 17 18:00:26.355: ppp32 CHAP: O CHALLENGE id 1 len 23 from "R2"
    *Jun 17 18:00:26.435: ppp32 CHAP: I RESPONSE id 1 len 23 from "R1"
    *Jun 17 18:00:26.439: ppp32 PPP: Sent CHAP LOGIN Request
    *Jun 17 18:00:26.447: ppp32 PPP: Received LOGIN Response PASS
    *Jun 17 18:00:26.471: Vi1.1 PPP: Sent LCP AUTHOR Request
    *Jun 17 18:00:26.475: Vi1.1 PPP: Sent IPCP AUTHOR Request
    *Jun 17 18:00:26.483: Vi1.1 LCP: Received AAA AUTHOR Response PASS
    *Jun 17 18:00:26.483: Vi1.1 IPCP: Received AAA AUTHOR Response PASS
    *Jun 17 18:00:26.487: Vi1.1 CHAP: O SUCCESS id 1 len 4
    R2(config-line)#
    客户端:
    R1(config-if)#
    *Jun 17 18:00:27.251: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
    *Jun 17 18:00:27.255: Vi1 PPP: Using dialer call direction
    *Jun 17 18:00:27.255: Vi1 PPP: Treating connection as a callout
    *Jun 17 18:00:27.259: Vi1 PPP: Session handle[87000063] Session id[0]
    *Jun 17 18:00:27.259: Vi1 PPP: Authorization required
    *Jun 17 18:00:27.259: Vi1 PPP: No remote authentication for call-out
    *Jun 17 18:00:27.263: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
    *Jun 17 18:00:29.295: Vi1 PPP: No authorization without authentication
    *Jun 17 18:00:29.315: Vi1 CHAP: I CHALLENGE id 1 len 23 from "R2"
    *Jun 17 18:00:29.319: Vi1 CHAP: Using hostname from interface CHAP
    *Jun 17 18:00:29.323: Vi1 CHAP: Using password from interface CHAP
    *Jun 17 18:00:29.323: Vi1 CHAP: O RESPONSE id 1 len 23 from "R1"
    *Jun 17 18:00:29.759: Vi1 CHAP: I SUCCESS id 1 len 4

    转载于:https://blog.51cto.com/cisco130/885160

    展开全文
  • PPPOE拨号

    2011-03-01 10:51:48
    PPPOE拨号的几个过程分析 第一步:PADI(PPPoE Active Discovery Initiation)PPPOE主动发现初始包, PPPOE的验证过程是由用户计算机的PADI数据开始的,PADI广播发送,它的作用是询问网络上有没有提供服务的PPPOE...

    PPPOE拨号的几个过程分析

    第一步:PADI(PPPoE Active Discovery Initiation)PPPOE主动发现初始包,
    PPPOE的验证过程是由用户计算机的PADI数据开始的,PADI广播发送,它的作用是询问网络上有没有提供服务的PPPOE验证服务器,服务器会发送1个单播的PADO作为回应。

    第二步:PADO(PPPoE Active Discovery Offer)PPPOE主动发现提议包,
    单播方式回应客户端的PADI请求,若网络中存在多个验证服务器的时候,会以先收到PADI的服务器进行后续的验证过程。

    第三步:PADR(PPPoE Active Discovery Request)PPPOE主动发现请求包,
    验证过程中计算机在一个数据包中以明文方式发送用户名和密码,单播更新,验证服务器在收到客户端发来的PADR以后,告诉客户机接入服务器(请求)。

    第四步:PADS(PPPoE Active Discovery Session-confirmation)PPPOE主动发现会话确认包,
    客户端验证通过,可以正常上网了,但是此时服务器会在以后的时间内定时发送Echo-Request数据包,测试客户机是否在线,如果服务器多次未收到Echo-Request的回应包,就认为用户下线,再次从新进行用户名和密码的验证。

    PADT(PPPoE Active Discovery Terminate)PPPOE主动发现终止,
    若在拨号过程中出现PADT,拨号连接就会马上终止

    转载于:https://blog.51cto.com/358962913/503435

    展开全文
  • PPPoE拨号宽带拨号源码系统结构:LoadMyForm,初始化窗口,窗口渐显,窗口渐消,取系统目录,取网络流量,取连接时间,读数据中天气信息,读天气图标,附加日期,GetIfTable_Byte,GetIfTable_Long,SendMessage
  • JuniperSRX防火墙PPPOE拨号配置 封装PPPOE GW-root# set interfaces ge-0/0/0.0 encapsulation ppp-over-ether 如果运营商为CHAP配置 GW-root# set interfaces pp0.0 ppp-options chap default-chap-secret ccieh...

    拓扑

    pppoe

    Juniper SRX防火墙 PPPOE拨号配置

    封装PPPOE
    GW-root# set interfaces ge-0/0/0.0 encapsulation ppp-over-ether

    如果运营商为CHAP配置
    GW-root# set interfaces pp0.0 ppp-options chap default-chap-secret ccieh3c.com
    GW-root# set interfaces pp0.0 ppp-options chap local-name ccieh3c
    GW-root# set interfaces pp0.0 ppp-options chap passive 【采用被动模式】

    如果运营商为PAP配置
    GW-root# set interfaces pp0.0 ppp-options pap default-password ccieh3c.com
    GW-root# set interfaces pp0.0 ppp-options pap local-name ccieh3c
    GW-root# set interfaces pp0.0 ppp-options pap local-password ccieh3c.com
    GW-root# set interfaces pp0.0 ppp-options pap passive 【采用被动】

    PPPOE的参数配置
    GW-root# set interfaces pp0.0 pppoe-options underlying-interface ge-0/0/0.0 【在该接口下启用PPPOE】
    GW-root# set interfaces pp0.0 pppoe-options idle-timeout 0 【空闲超时值】
    GW-root# set interfaces pp0.0 pppoe-options auto-reconnect 3 【3秒自动重拨】
    GW-root# set interfaces pp0.0 pppoe-options client 【定义为client模式】
    GW-root# set interfaces pp0.0 family inet mtu 1492 【定义MTU】
    GW-root# set interfaces pp0.0 family inet negotiate-address 【自动协商地址】

    加入untrust zone
    GW-root# edit security zones security-zone untrust
    GW-root# set interfaces pp0.0 host-inbound-traffic system-services ping
    测试

    pppoe

    已经成功获取到地址了。

    定义默认路由与NAT

    GW-root# set routing-options static route 0/0 next-hop pp0.0
    这里定义了路由,直接指向PP0.0,访问internet

    [edit]
    GW-root# edit security nat source rule-set access-internet

    [edit security nat source rule-set access-internet]
    GW-root# set from zone trust

    [edit security nat source rule-set access-internet]
    GW-root# set to zone untrust

    [edit security nat source rule-set access-internet]
    GW-root# edit rule 1

    [edit security nat source rule-set access-internet rule 1]
    GW-root# set match source-address 192.168.1.0/24

    [edit security nat source rule-set access-internet rule 1]
    GW-root# set then source-nat interface
    说明:定义一个源NAT,可以让192.168.1.0,通过出接口地址进行转换出去。

    pppoe
    pppoe

    可以看到访问114这个地址,而且正常转换为202.100.1.3

    容易遇到的问题

    (1)一些网站或者应用打开慢以及打不开的情况,这个很有可能是MTU与TCP MSS导致,可以多尝试几个值来达到比较理想的效果。
    GW-root# set interfaces pp0.0 family inet mtu 1492 【定义MTU】
    GW-root# set security flow tcp-mss all-tcp mss 1300 【定义TCP-MSS】
    (2)一些小企业或者SOHO级别的网络可能申请的是民用的拨号线路,那这个时候有可能自己用电脑先拨入测试效果,然后发现在路由器上面怎么都拨入不了,那很有可能是运营商那边绑定了,需要打电话过去松绑。
    (3)ADSL有可能采用私网地址分配,所以在申请的时候需要考虑是否需要做映射服务出去或者一些VPN拨入,在申请的时候需要跟对方说明清楚。(包括80端口是否可以用)

    如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

    展开全文
  • pppoe拨号源码

    2017-09-07 21:09:30
    pppoe拨号软件源码 版本:3.12 linux版本 亲测可用
  • 教程名称:网管必备之企业常见的PPPOE拨号课程目录:【】PPPOE拨号之一:Cisco路由器PPPOE拨号配置【】PPPOE拨号之七:华为防火墙 USG PPPoE拨号配置【】PPPOE拨号之三:H3C路由器PPPoE典型配置【】PPPOE拨号之二:...
  • 这三种接入方式分别是:1、PPPOE拨号上网(目前常见的上网方式);2、DHCP自动获取IP地址上网;3、固定IP地址(企业用户用的比较多) 运营商是怎么通过PPPOE拨号认证服务器,让我们使用电脑或路由器拨号的方式达到共享...
  • PPPOE拨号自动统计

    2018-06-23 11:45:17
    PPPOE拨号自动统计,输入拨号账号密码,多次拨号自动统计成功率,监测网络稳定性。
  • 上一期文章我们配置了Mikrotik RouterOS 设置LAN和DHCP,本期我们来配置PPPOE拨号和固定IP上网。一、配置PPPOE拨号1. 点击Interface-点击+号-点击PPPoE Client点击General,选择拨号的接口(我这里是第1个网口ether1)...
  • pppoe拨号流程

    2019-12-04 14:35:10
    pppoe拨号抓包流程 ...pppoe拨号流程 PPPoE(Point to Point Protocol over Ethernet,基于以太网的点对点协议)的工作流程包含发现(Discovery)和会话(Session)两个阶段,发现阶段是无...
  • 路由器怎么设置pppoe拨号?新购买的路由器如何设置,怎么自动拨号、怎么设置wifi、怎么修改默认登录名称与密码?下面我们一起来看看吧
  • 如果你具备了上网的基本条件包括:电脑已有网卡并且驱动安装正常运营商的网线已正确接于网卡并提供信号有运营商提供用于PPPOE拨号的帐号密码具备以上三个条件后现在就差万里长征的最后一步也就是配置系统了,设置的...
  • 创翼错误118 pppoe拨号模块损坏

    万次阅读 多人点赞 2019-04-20 16:21:58
    创翼错误118 pppope拨号模块损坏 . 1809版本、创翼的bug 一、新建一个.txt文件 二、复制下面代码到.txt文件里并保存 Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\...
  • 路由器中的pppoe拨号密码怎么查看?之前设置的密码后来忘了,想查看一下,该怎么查看呢?今天我们就来看看从国配置文件来查看pppoe拨号密码的方法,需要的朋友可以参考下
  • PPPOE拨号用户名批量测试工具,课批量测试用户名有效性
  • 飞鱼星路由器怎么设置PPPOE拨号上网?飞鱼星路由器想要设置上网该怎么设置呢?下面我们就来看看飞鱼星路由器设置PPPOE的教程,需要的朋友可以参考下
  • 华为防火墙的PPPOE拨号配置。挺实用的
  • pppoe拨号.bat

    千次阅读 2017-05-25 13:25:28
    现在很多的地方用pppoe拨号,但是有时候发现总是需要自己输入登录,很麻烦,(其实可以记住密码的但是很多人搞不好),所以这里给两种win10的pppoe拨号方法。 也作为保存,方便自己以后翻阅。前期准备: 1.先打开...
  • cisco 企业路由器PPPOE拨号上网步骤教程和命令配置方法,可以用GNS3模拟也可以用EVE-NG模拟
  • 现在买回来的路由器后自己不会设置,来是连接不上网络,老是出现路由器PPPOE拨号失败,针对这个问题,下面为大家详细介绍下
  • AR22003200系列配置PPPoE拨号上网示例
  • 在工作中,很有可能遇到的外网接入方式就是ADSL拨号了,虽然看着简单,但是这里讲讲Cisco 防火墙ASA上面的一些注意事项与配置。 1、PPPOE配置部分 Router-ASA(config)# vpdn group isp request dialout pppoe ...
  • linux pppoe拨号上网

    2020-06-26 18:09:55
    linux pppoe拨号上网 安装软件和修改配置文件: [root@cv ~]# yum -y install rp-pppoe [root@cv ~]# cp /usr/share/doc/rp-pppoe-3.11/configs/pppoe.conf  /etc/ppp/ [root@cv ~]# cat /etc/ppp/pppoe.conf |...
  • Kali PPPoE 拨号上网

    2019-06-21 00:09:10
    Kali PPPoE 拨号上网1.下载PPPoE2.Terminal > nm-connection-editor3.Settings---->Network---->点击PPPoE 1.下载PPPoE sudo apt install pppoe li@li:~$ sudo apt install pppoe 我们信任您已经从...
  • 1、PPPOE配置 GW-GW-> set pppoe interface eth4 GW-GW-> set pppoe username ccieh3c password ccieh3c.com GW-GW-> set flow tcp-mss 1420说明:MTU的问题,只要调用了PPPOE的话,会自动修改为1492的。 ...
  • HG813 路由器怎么社会设置PPPOE拨号?无线路由器已经成为大多数上网用户的必须品之一了。那么使用无线路由器,应该如何安装和设置Poe拨号呢?下面分享解决办法,需要的朋友可以参考下
  • ubuntu PPPoE拨号上网

    2019-06-13 13:32:00
    1.打开linux终端,输入命令sudo pppoeconf 图形化界面操作即可 其他功能: 打开pppoe拨号上网命令:sudo pon dsl-provider 关闭连接:sudo poff dsl-provider

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,817
精华内容 726
关键字:

pppoe拨号