精华内容
下载资源
问答
  • OSPF配置

    2020-01-02 14:03:11
    OSPF配置实验拓扑端口配置OSPF配置,进程号1避免不必要的路由流量,设置被动端口配置路由器的 router-id实验结果 主机 端口 Ip 子网掩码 默认网关 PC1 192.168.0.222 255.255.255.224 192.168.0.193 PC2 ...

    主机 端口 Ip 子网掩码 默认网关
    PC1 192.168.0.222 255.255.255.224 192.168.0.193
    PC2 192.168.0.190 255.255.255.192 192.168.0.129
    PC3 192.168.0.126 255.255.255.128 192.168.0.1
    R1 F0/0 10.0.0.1 255.255.255.252
    R1 F0/1 192.168.0.193 255.255.255.224
    R2 F0/0 10.0.0.5 255.255.255.252
    R2 F0/1 192.168.0.129 255.255.255.192
    R3 F0/0 10.0.0.9 255.255.255.252
    R3 F0/1 192.168.0.1 255.255.255.128
    R4 F0/0 10.0.0.2 255.255.255.252
    R4 F0/1 10.0.0.6 255.255.255.252
    R4 F0/2 10.0.0.10 255.255.255.252

    实验拓扑

    在这里插入图片描述

    在这里插入图片描述

    端口配置

    R1#configure terminal 
    R1(config)#interface f0/0
    R1(config-if)#ip address 10.0.0.1 255.255.255.252
    R1(config-if)#no shutdown 
    R1(config-if)#interface f0/1
    R1(config-if)#ip address 192.168.0.193 255.255.255.224
    R1(config-if)#no shutdown 
    
    R2(config)#interface f0/0
    R2(config-if)#ip address 10.0.0.5 255.255.255.252
    R2(config-if)#no shutdown
    R2(config)#interface f0/1
    R2(config-if)#ip address 192.168.0.129 255.255.255.128
    R2(config-if)#no shutdown
    
    R3(config)#interface f0/0
    R3(config-if)#ip address 10.0.0.9 255.255.255.252
    R3(config-if)#no shutdown
    R3(config-if)#interface f0/1
    R3(config-if)#ip address 192.168.0.1 255.255.255.128
    R3(config-if)#no shutdown
    
    
    R4(config)#interface f0/0
    R4(config-if)#ip address 10.0.0.2 255.255.255.252
    R4(config-if)#no shutdown
    R4(config-if)#interface f0/1
    R4(config-if)#ip address 10.0.0.6 255.255.255.252
    R4(config-if)#no shutdown
    R4(config-if)#interface f0/1
    R4(config-if)#ip address 10.0.0.6 255.255.255.252
    R4(config-if)#no shutdown
    

    OSPF配置,进程号1

    R1(config)#router ospf 1
    R1(config-router)#network 10.0.0.0 0.0.0.3 area 0
    R1(config-router)#network 192.168.0.192 0.0.0.31 area 0
    
    
    R2(config)#router ospf 1
    R2(config-router)#network 10.0.0.0 0.0.0.3 area 0
    R2(config-router)#network 10.0.0.4 0.0.0.3 area 0
    R2(config-router)#network 192.168.0.128 0.0.0.63 area 0
    
    R3(config)#router ospf 1
    R3(config-router)#network 10.0.0.0 0.0.0.3 area 0
    R3(config-router)#network 10.0.0.8 0.0.0.3 area 0
    R3(config-router)#network 192.168.0.0 0.0.0.127 area 0
    
    R4(config)#router ospf 1
    R4(config-router)#network 10.0.0.0 0.0.0.3 area 0
    R4(config-router)#network 10.0.0.4 0.0.0.3 area 0
    R4(config-router)#network 10.0.0.8 0.0.0.3 area 0
    

    避免不必要的路由流量,设置被动端口

    R1(config)#router ospf 1
    R1(config-router)#passive-interface f0/1
    
    R2(config)#router ospf 1
    R2(config-router)#passive-interface f0/1
    
    R3(config)#router ospf 1
    R3(config-router)#passive-interface f0/1
    

    配置路由器的 router-id

    R1(config)#router ospf 1
    R1(config-router)#router-id 172.16.1.1
    R1(config-router)#end
    R1#clear ip ospf process
    
    R2(config)#router ospf 1
    R2(config-router)#rout
    R2(config-router)#router-id 172.16.1.2
    R2(config-router)#end
    R2#clear ip ospf process
    
    R3(config)#router ospf 1
    R3(config-router)#router-id 172.16.1.3
    R3(config-router)#end
    R3#clear ip ospf process
    
    R4(config)#router ospf 1
    R4(config-router)#router-id 172.16.1.4
    R4(config-router)#end
    R4#clear ip ospf process
    

    实验结果

    在这里插入图片描述

    展开全文
  • ospf配置

    2019-09-16 16:36:22
    Ospf配置 拓扑 先为各台路由器配置ip sys Enter system view, return user view with Ctrl+Z. [Huawei]sysname R1 [R1]user-interface console 0 [R1-ui-console0]idle-timeout 0 [R1-ui-console0]quit [R1]quit ...

    Ospf配置
    拓扑
    在这里插入图片描述
    先为各台路由器配置ip
    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R1
    [R1]user-interface console 0
    [R1-ui-console0]idle-timeout 0
    [R1-ui-console0]quit
    [R1]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R1]interface GigabitEthernet0/0/0
    [R1-GigabitEthernet0/0/0]ip add 17.1.1.1 24
    [R1-GigabitEthernet0/0/0]quit
    [R1]interface Ethernet0/0/0
    [R1-Ethernet0/0/0]ip add 13.1.1.1 24
    [R1-Ethernet0/0/0]quit
    [R1]interface Ethernet0/0/1
    [R1-Ethernet0/0/1]ip add 12.1.1.1 24
    [R1-Ethernet0/0/1]quit
    [R1]interface LoopBack 0
    [R1-LoopBack0]ip add 1.1.1.1 24
    [R1-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R2
    [R2]user-interface console 0
    [R2-ui-console0]idle-timeout 0
    [R2-ui-console0]quit
    [R2]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R2]interface Ethernet0/0/0
    [R2-Ethernet0/0/0]ip add 12.1.1.2 24
    [R2-Ethernet0/0/0]quit
    [R2]interface Ethernet0/0/1
    [R2-Ethernet0/0/1]ip add 25.1.1.1 24
    [R2-Ethernet0/0/1]quit
    [R2]interface GigabitEthernet0/0/0
    [R2-GigabitEthernet0/0/0]ip add 29.1.1.1 24
    [R2-GigabitEthernet0/0/0]quit
    [R2]interface LoopBack 0
    [R2-LoopBack0]ip add 2.2.2.2 24
    [R2-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R3
    [R3]user-interface console 0
    [R3-ui-console0]quit
    [R3]quit
    sys
    Enter system view, return user view with Ctrl+Z.
    [R3]user-interface console 0
    [R3-ui-console0]idle-timeout 0
    [R3-ui-console0]quit
    [R3]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R3]interface Ethernet0/0/1
    [R3-Ethernet0/0/1]ip add 13.1.1.2 24
    [R3-Ethernet0/0/1]quit
    [R3]interface Ethernet0/0/0
    [R3-Ethernet0/0/0]ip add 34.1.1.1 24
    [R3-Ethernet0/0/0]quit
    [R3]interface LoopBack 0
    [R3-LoopBack0]ip add 3.3.3.3 24
    [R3-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R4
    [R4]user-interface console 0
    [R4-ui-console0]idle-timeout 0
    [R4-ui-console0]quit
    [R4]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R4]interface Ethernet0/0/0
    [R4-Ethernet0/0/0]ip add 34.1.1.2 24
    [R4-Ethernet0/0/0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R5
    [R5]user-interface console 0
    [R5-ui-console0]idle-timeout 0
    [R5-ui-console0]quit
    [R5]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R5]interface Ethernet0/0/0
    [R5-Ethernet0/0/0]ip add 25.1.1.2 24
    [R5-Ethernet0/0/0]quit
    [R5]interface Ethernet0/0/1
    [R5-Ethernet0/0/1]ip add 56.1.1.1 24
    [R5-Ethernet0/0/1]quit
    [R5]interface LoopBack 0
    [R5-LoopBack0]ip add 5.5.5.5 24
    [R5-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R6
    [R6]user-interface console 0
    [R6-ui-console0]id
    [R6-ui-console0]idle-timeout 0
    [R6-ui-console0]quit
    [R6]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R6]interface Ethernet0/0/0
    [R6-Ethernet0/0/0]ip add 56.1.1.2 24
    [R6-Ethernet0/0/0]quit
    [R6]interface LoopBack 0
    [R6-LoopBack0]ip add 6.6.6.6 24
    [R6-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R7
    [R7]user-interface console 0
    [R7-ui-console0]idle-timeout 0
    [R7-ui-console0]quit
    [R7]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R7]interface Ethernet0/0/0
    [R7-Ethernet0/0/0]ip add 17.1.1.2 24
    [R7-Ethernet0/0/0]quit
    [R7]interface Ethernet0/0/1
    [R7-Ethernet0/0/1]ip add 78.1.1.1 24
    [R7-Ethernet0/0/1]quit
    [R7]interface LoopBack 0
    [R7-LoopBack0]ip add 7.7.7.7 24
    [R7-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R8
    [R8]user-interface console 0
    [R8-ui-console0]idle-timeout 0
    [R8]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R8]interface Ethernet0/0/0
    [R8-Ethernet0/0/0]ip add 78.1.1.2 24
    [R8-Ethernet0/0/0]quit
    [R8]interface LoopBack 0
    [R8-LoopBack0]ip add 8.8.8.8 24
    [R8-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R9
    [R9]user-interface console 0
    [R9-ui-console0]idle-timeout 0
    [R9-ui-console0]quit
    [R9]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R9]interface Ethernet0/0/0
    [R9-Ethernet0/0/0]ip add 29.1.1.2 24
    [R9-Ethernet0/0/0]quit
    [R9]interface Ethernet0/0/1
    [R9-Ethernet0/0/1]ip add 91.1.1.1 24
    [R9-Ethernet0/0/1]quit
    [R9]interface LoopBack 0
    [R9-LoopBack0]ip add 9.9.9.9 24
    [R9-LoopBack0]quit

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R10
    [R10]user-interface console 0
    [R10-ui-console0]idle-timeout 0
    [R10-ui-console0]quit
    [R10]quit
    undo ter monitor
    Info: Current terminal monitor is off.
    sys
    Enter system view, return user view with Ctrl+Z.
    [R10]interface Ethernet0/0/0
    [R10-Ethernet0/0/0]ip add 91.1.1.2 24
    [R10-Ethernet0/0/0]quit
    [R10]interface LoopBack 0
    [R10-LoopBack0]ip add 10.10.10.10 24
    [R10-LoopBack0]quit

    测试直连连通性
    在这里插入图片描述在这里插入图片描述在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述

    配置ospf
    [R1]ospf 100 router-id 1.1.1.1
    [R1-ospf-100]area 0
    [R1-ospf-100-area-0.0.0.0]network 12.1.1.0 0.0.0.255
    [R1-ospf-100-area-0.0.0.0]network 1.1.1.1 0.0.0.0
    [R1-ospf-100-area-0.0.0.0]quit
    [R1-ospf-100]area 1
    [R1-ospf-100-area-0.0.0.1]network 13.1.1.0 0.0.0.255
    [R1-ospf-100-area-0.0.0.1]quit
    [R1-ospf-100]area 3
    [R1-ospf-100-area-0.0.0.3]network 17.1.1.0 0.0.0.255
    [R1-ospf-100-area-0.0.0.3]quit
    [R1-ospf-100]quit

    [R2]ospf 100 router-id 2.2.2.2
    [R2-ospf-100]area 0
    [R2-ospf-100-area-0.0.0.0]network 12.1.1.0 0.0.0.255
    [R2-ospf-100-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [R2-ospf-100-area-0.0.0.0]quit
    [R2-ospf-100]area 2
    [R2-ospf-100-area-0.0.0.2]network 25.1.1.0 0.0.0.255
    [R2-ospf-100-area-0.0.0.2]quit
    [R2-ospf-100]area 4
    [R2-ospf-100-area-0.0.0.4]network 29.1.1.0 0.0.0.255
    [R2-ospf-100-area-0.0.0.4]quit
    [R2-ospf-100]quit

    [R3]ospf 100 router-id 3.3.3.3
    [R3-ospf-100]area 1
    [R3-ospf-100-area-0.0.0.1]network 13.1.1.0 0.0.0.255
    [R3-ospf-100-area-0.0.0.1]network 34.1.1.0 0.0.0.255
    [R3-ospf-100-area-0.0.0.1]network 3.3.3.3 0.0.0.0
    [R3-ospf-100-area-0.0.0.1]quit
    [R3-ospf-100]quit

    [R4]ospf 100 router-id 4.4.4.4
    [R4-ospf-100]area 1
    [R4-ospf-100-area-0.0.0.1]network 34.1.1.0 0.0.0.255
    [R4-ospf-100-area-0.0.0.1]network 4.4.4.4 0.0.0.0
    [R4-ospf-100-area-0.0.0.1]quit
    [R4-ospf-100]quit

    [R5]ospf 100 router-id 5.5.5.5
    [R5-ospf-100]area 2
    [R5-ospf-100-area-0.0.0.2]network 25.1.1.0 0.0.0.255
    [R5-ospf-100-area-0.0.0.2]network 56.1.1.0 0.0.0.255
    [R5-ospf-100-area-0.0.0.2]network 5.5.5.5 0.0.0.0
    [R5-ospf-100-area-0.0.0.2]quit
    [R5-ospf-100]quit

    [R6]ospf 100 router-id 6.6.6.6
    [R6-ospf-100]area 2
    [R6-ospf-100-area-0.0.0.2]network 56.1.1.0 0.0.0.255
    [R6-ospf-100-area-0.0.0.2]network 6.6.6.6 0.0.0.0
    [R6-ospf-100-area-0.0.0.2]quit
    [R6-ospf-100]quit

    [R7]ospf 100 router-id 7.7.7.7
    [R7-ospf-100]area 3
    [R7-ospf-100-area-0.0.0.3]network 17.1.1.0 0.0.0.255
    [R7-ospf-100-area-0.0.0.3]network 78.1.1.0 0.0.0.255
    [R7-ospf-100-area-0.0.0.3]network 7.7.7.7 0.0.0.0
    [R7-ospf-100-area-0.0.0.3]quit
    [R7-ospf-100]quit

    [R8]ospf 100 router-id 8.8.8.8
    [R8-ospf-100]area 3
    [R8-ospf-100-area-0.0.0.3]network 78.1.1.0 0.0.0.255
    [R8-ospf-100-area-0.0.0.3]network 8.8.8.8 0.0.0.0
    [R8-ospf-100-area-0.0.0.3]quit
    [R8-ospf-100]quit

    [R9]ospf 100 router-id 9.9.9.9
    [R9-ospf-100]area 4
    [R9-ospf-100-area-0.0.0.4]network 29.1.1.0 0.0.0.255
    [R9-ospf-100-area-0.0.0.4]network 91.1.1.0 0.0.0.255
    [R9-ospf-100-area-0.0.0.4]network 9.9.9.9 0.0.0.0
    [R9-ospf-100-area-0.0.0.4]quit
    [R9-ospf-100]quit

    [R10]ospf 100 router-id 10.10.10.10
    [R10-ospf-100]area 4
    [R10-ospf-100-area-0.0.0.4]network 91.1.1.0 0.0.0.255
    [R10-ospf-100-area-0.0.0.4]network 10.10.10.10 0.0.0.0
    [R10-ospf-100-area-0.0.0.4]quit
    [R10-ospf-100]quit

    查看路由表
    在这里插入图片描述
    OSPF扩展配置
    1、认证–邻居间的身份核实
    1)接口认证–在邻居间相连的接口上做两个邻居之间的认证
    [R1]interface Ethernet0/0/1
    [R1-Ethernet0/0/1]ospf authentication-mode md5 1 cipher hcip
    在相连俩接口上同时启用认证否则链接会断开
    在这里插入图片描述
    在这里插入图片描述
    2、缺省–在连接运营商的边界路由器上配置
    [r1]ospf 1
    [r1-ospf-1]default-route-advertise //非强制下发缺省
    [r1-ospf-1]default-route-advertise always //强制下发缺省

    非强制:若要在协议内下发缺省成功,路由器本身应该有缺省路由
    强制:总是能够下发缺省
    3、静默接口–只接收不发送协议报文,只能用于连接用户的接口,禁止用于路由器之间的接口
    [r1]ospf 1
    [r1-ospf-1]silent-interface GigabitEthernet 0/0/0
    Ospf三种表的查看
    1) 邻居表
    在这里插入图片描述
    2) 数据库表
    在这里插入图片描述
    3) 路由表
    在这里插入图片描述

    展开全文
  • 多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置
  • CiscoOSPF配置

    2017-05-31 23:54:50
    本实验报告为路由器的OSPF配置,利用ospf协议实现个路由下的PC能够互相通信。内有实验拓扑图和详细的配置步骤。模拟器为Cisco Packet Tracer 6.0.
  • OSPF配置技巧

    2014-12-23 16:00:30
    OSPF配置技巧实验
  • 11.6.1 基本ospf配置

    2017-11-17 13:47:27
    思科11.6.1基本OSPF配置实验,自己做的答案,欢迎下载
  • 多区域OSPF配置
  • 案例1:单区域OSPF配置 1.单区域OSPF配置实验拓扑图: 2.配置终端 配置终端的IP--子网掩码--网关 pc4 192.168.1.1/24 255.255.255.0 192.168.1.254 pc5 192.168.2.1/24 255.255.255.0 192.168.2.254 2.1 ...

    案例1:单区域OSPF配置

    案例2:多区域OSPF配置

    常见问题:

    案例1:单区域OSPF配置

    1.单区域OSPF配置实验拓扑图:

    2.配置终端

    配置终端的IP--子网掩码--网关
    pc4
    192.168.1.1/24
    255.255.255.0
    192.168.1.254
    
    pc5
    192.168.2.1/24
    255.255.255.0
    192.168.2.254

    2.1 配置r1:

    1.初始化r4:
    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r1
    [r1]int g0/0/2
    [r1-GigabitEthernet0/0/2]ip add 192.168.1.254 24
    [r1-GigabitEthernet0/0/2]q
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]ip add 192.168.12.1 24
    [r1-GigabitEthernet0/0/0]q
    
    [r1]ospf
    [r1-ospf-1]area 0骨干区域(非骨干区域必须直连)
    [r1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255反演码
    [r1-ospf-1-area-0.0.0.0]network 192.168.12.0 0.0.0.255反演码
    [r1-ospf-1-area-0.0.0.0]display ip routing-table 192.168.2.1
    [r1-ospf-1-area-0.0.0.0]display ip routing-table 192.168.1.1
    
    [r1]display ospf peer br
    <r1>reset ospf process 
    Warning: The OSPF process will be reset. Continue? [Y/N]:y
    <r1>display ospf peer br
    [r1]ospf 1 router-id 1.1.1.1
    
    [r1]display ip routing-table protocol ospf
    
    <r1>u t m
    <r1>sys
    [r1]display ip routing-table protocol ospf

     2.2 配置r2:

    
    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r2
    [r2]int g0/0/1
    [r2-GigabitEthernet0/0/1]ip add 192.168.12.2 24
    [r2-GigabitEthernet0/0/1]q
    [r2]int g0/0/0
    [r2-GigabitEthernet0/0/0]ip add 192.168.23.2 24
    [r2-GigabitEthernet0/0/0]q
    [r2]ospf
    [r2-ospf-1]area 0
    [r2-ospf-1-area-0.0.0.0]network 192.168.12.0 0.0.0.255
    [r2-ospf-1-area-0.0.0.0]network 192.168.23.0 0.0.0.255
    [r2-ospf-1-area-0.0.0.0]display ip routing-table 192.168.1.1
    [r2-ospf-1-area-0.0.0.0]display ip routing-table 192.168.2.1
    

    2.3 配置r3: 

    
    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r3
    [r3]int g0/0/2
    [r3-GigabitEthernet0/0/2]ip add 192.168.2.254 24
    [r3-GigabitEthernet0/0/2]q
    [r3]int g0/0/1
    [r3-GigabitEthernet0/0/1]ip add 192.168.23.3 24
    [r3-GigabitEthernet0/0/1]q
    [r3]ospf 
    [r3-ospf-1]area 0
    [r3-ospf-1-area-0.0.0.0]network 192.168.23.0 0.0.0.255
    [r3-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    [r3-ospf-1-area-0.0.0.0]q
    
    [r3]int g0/0/2
    [r3-GigabitEthernet0/0/2]ospf cost 8
    [r3-GigabitEthernet0/0/2]display ospf int g0/0/2
    
    	

    案例2:多区域OSPF配置

    1.多区域OSPF配置实验拓扑图:

    2.配置终端

    pc1:
    192.168.1.1
    255.255.255.0
    192.168.1.254
    pc2:
    192.168.2.1
    255.255.255
    192.168.2.254

    2.1.配置r1:

    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r1
    [r1]int g0/0/2
    [r1-GigabitEthernet0/0/2]ip add 192.168.1.254 24
    [r1-GigabitEthernet0/0/2]q
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]ip add 192.168.12.1 24
    [r1-GigabitEthernet0/0/0]q
    [r1]ospf 1 router-id 1.1.1.1
    [r1-ospf-1]area 12
    [r1-ospf-1-area-0.0.0.12]network 192.168.12.0 0.0.0.255
    [r1-ospf-1-area-0.0.0.12]network 192.168.1.0 0.0.0.255
    

    2.2.配置r2:

    
    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r2
    [r2]int g0/0/1
    [r2-GigabitEthernet0/0/1]ip add 192.168.12.2 24
    [r2-GigabitEthernet0/0/1]q
    [r2]int g0/0/0
    [r2-GigabitEthernet0/0/0]ip add 192.168.23.2 24
    [r2-GigabitEthernet0/0/0]q
    [r2]ospf 1 router-id 2.2.2.2
    [r2-ospf-1]area 12
    [r2-ospf-1-area-0.0.0.12]network 192.168.12.0 0.0.0.255
    [r2-ospf-1-area-0.0.0.12]q
    [r2-ospf-1]area 0
    [r2-ospf-1-area-0.0.0.0]network 192.168.23.0 0.0.0.255
    [r2-ospf-1-area-0.0.0.0]q
    

    2.1.配置r3: 

    <Huawei>sys
    [Huawei]sys r3
    [r3]int g0/0/1
    [r3-GigabitEthernet0/0/1]ip add 192.168.23.3 24
    [r3-GigabitEthernet0/0/1]q
    [r3]int g0/0/0
    [r3-GigabitEthernet0/0/0]ip add 192.168.34.3 24
    [r3-GigabitEthernet0/0/0]q
    [r3]ospf 1 router-id 3.3.3.3
    [r3-ospf-1]area 0
    [r3-ospf-1-area-0.0.0.0]network 192.168.23.0 0.0.0.255
    [r3-ospf-1-area-0.0.0.0]network 192.168.34.0 0.0.0.255
    [r3-ospf-1-area-0.0.0.0]q

    2.1.配置r4: 

    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r4
    [r4]int g0/0/1
    [r4-GigabitEthernet0/0/1]ip add 192.168.34.4 24
    [r4-GigabitEthernet0/0/1]q
    [r4]int g0/0/0
    [r4-GigabitEthernet0/0/0]ip add 192.168.45.4 24
    [r4-GigabitEthernet0/0/0]q
    [r4]ospf 1 router-id 4.4.4.4
    [r4-ospf-1]area 0
    [r4-ospf-1-area-0.0.0.0]network 192.168.45.0 0.0.0.255
    [r4-ospf-1-area-0.0.0.0]network 192.168.34.0 0.0.0.255
    [r4-ospf-1-area-0.0.0.0]q

    2.1.配置r5: 

    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r5
    [r5]int g0/0/1
    [r5-GigabitEthernet0/0/1]ip add 192.168.45.5 24
    [r5-GigabitEthernet0/0/1]q
    [r5]int g0/0/0
    [r5-GigabitEthernet0/0/0]ip add 192.168.56.5 24
    [r5-GigabitEthernet0/0/0]q
    [r5]ospf 1 router-id 5.5.5.5
    [r5-ospf-1]area 56
    [r5-ospf-1-area-0.0.0.56]network 192.168.56.0 0.0.0.255
    [r5-ospf-1-area-0.0.0.56]q
    [r5-ospf-1]area 0
    [r5-ospf-1-area-0.0.0.0]network 192.168.45.0 0.0.0.255
    [r5-ospf-1-area-0.0.0.0]q

    2.1.配置r6: 

    <Huawei>u t m
    <Huawei>sys
    [Huawei]sys r6
    [r6]int g0/0/2
    [r6-GigabitEthernet0/0/2]ip add 192.168.2.254 24
    [r6-GigabitEthernet0/0/2]q
    [r6]int g0/0/1
    [r6-GigabitEthernet0/0/1]ip add 192.168.56.6 24
    [r6-GigabitEthernet0/0/1]q
    [r6]ospf router-id 6.6.6.6
    [r6-ospf-1]area 56
    [r6-ospf-1-area-0.0.0.56]network 192.168.2.0 0.0.0.255
    [r6-ospf-1-area-0.0.0.56]network 192.168.56.0 0.0.0.255
    [r6-ospf-1-area-0.0.0.0]q

    2.1.配置优先级--修改接口网络类型为php-计时器:

    Border  AREA  边界路由器
     路由=网段+掩码
    <r3>display ospf lsdb 查看数据库
    <r1>display ospf lsdb router 1.1.1.1查看1类LSA1.1.1.1的详细信息
    [r6]display ospf ls network 192.168.56.6
    <r3>display ospf summary 192.168.1.0 -r3上查看pc1所在的网段的路由条目192.168.1.0/24
    优先级:
    <r3>u t m
    <r3>sys	
    [r3]int g0/0/0
    <r3>reset ospf process 重启ospf
    Warning: The OSPF process will be reset. Continue? [Y/N]:y
    <r3>display this
    
    修改接口网络类型为php:
    <r1>u t m
    <r1>sys 
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]ospf network-type p2p
    [r1-GigabitEthernet0/0/0]display ospf peer br
    <r2>u t m
    <r2>sys
    [r2]int g0/0/1
    [r2-GigabitEthernet0/0/1]ospf network-type p2p
    [r2-GigabitEthernet0/0/1]display ospf peey br
    
    计时器:
    [r1]int g0/0/0	
    [r1-GigabitEthernet0/0/0]ospf timer hello 5
    [r1-GigabitEthernet0/0/0]ospf timer dead 30
    [r2]int g0/0/0	
    [r2-GigabitEthernet0/0/0]ospf timer hello 5
    [r2-GigabitEthernet0/0/0]ospf timer dead 30

     3.常见问题:

    OSPF邻接无法建立:

    • IP地址无法Ping通
    • OSPF的区域号写错
    • OSPF的network写错
    • OSPF接口计时器写错
    • OSPF的router-id相同

     

    展开全文
  • 路由器ospf配置

    2013-05-31 13:49:59
    路由器的OSPF配置,有拓扑图和文档,这里代码就不写了,但可以在show running里查看代码
  • 思科OSPF配置示例

    2009-07-27 09:11:07
    思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令
  • 华为OSPF配置练习

    千次阅读 2021-03-12 19:07:45
    华为OSPF配置练习一、拓扑以及需求二、所需技术以及简单配置(1)OSPF(2)RIP(3)虚链路(4)重发布三、配置思路(1)打通0域(2)打通RIP域外(3)连接各域1、使用虚链路2、使用双向重发布四、验证(1)连通性...

    一、拓扑以及需求

      某公司核心网络采用OSPF协议来打通,其中R1、2、3、4构成ospf的0域;R9、10采用rip来充当ospf域外路由。具体的区域划分如拓扑所示:
    在这里插入图片描述
    我在各个区域选择一个环回地址充当此区域的用户

    地址规划说明:
    	接口ip:10.200.x.y
    	为验证需要,我在各个区域选择一个环回充当此区域的用户:
    		0域:2.2.2.2
    		1域:5.5.5.5
    		2域:6.6.6.6
    		rip(域外)9.9.9.9
    

    二、所需技术以及简单配置

    (1)OSPF

      开放的最短路径优先协议,首先工作在AS内(内部网关协议,即IGP),流量使用的ip协议号是89,它采用触发更新(增量更新)。部署的时候需要0域(骨干区域),其余所有分支必须与0域直接相连。

    配置:
    [r1]ospf 1 router-id 1.1.1.1   //启动协议,需要配置进程号,具有本地意义,可以选择配置RID,若不配置,则路由器自己选择
    [r1-ospf-1]area 0   //进入区域
    [r1-ospf-1-area-0.0.0.0]network 172.16.1.0 0.0.0.255  //宣告路由或接口
    

    (2)RIP

      RIP是距离矢量协议,它以跳数作为衡量标准(16即为不可达),共有v1和v2两个版本,端口号520、521。同样是内部网关协议工作在AS内,定时更新(30s),且传路由所以不适用于大型网络。

    配置:
    [r1]rip 1    //启动协议时必须配置进程号,仅具有本地意义
    [r1-rip-1]version 1   //选择版本,以版本1为例,版本2同版本1
    [r1-rip-1]network 192.168.1.0    //宣告路由,基于主类范围宣告
    [r1-rip-1]undo summary   //关闭自动汇总
    

    (3)虚链路

      故名思议,虚拟的链路。由于OSPF的其他区域必须与0域相连,由拓扑我们可知2域与0域并不能直接相连,所以在此我们需要虚链路来缝合领域,使它在逻辑上是相连的。

    配置:
    	需要配置在0域和本域的ABR设备上,且虚连接在所跨域中。
    	以本文拓扑为例:需配置在R4和R5设备上,且虚连接存在于1域中。
    R4配置:
    [r4]ospf
    [r4-ospf-1]area 1
    [r4-ospf-1-area-0.0.0.1]vlink-peer 5.5.5.5
    
    R5配置:
    [r5]ospf
    [r5-ospf-1]area 1
    [r5-ospf-1-area-0.0.0.1]vlink-peer 4.4.4.4
    

    (4)重发布

      当两个协议边界相遇时,为了使双方均可学习得对方路由,此时可采取双向重发布来实现。

    配置:
    	配置在ASBR设备中。
    	以本文拓扑为例:需配置R1设备上
    [r1]ospf
    [r1-ospf-1]import-route rip 1 
    [r1]rip
    [r1-rip-1]import-route ospf 1
    
    

    三、配置思路

    (1)打通0域

      在R1、2、3、4设备上起OSPF并宣告接口。

    以R2、R4为例
    	R2配置如下:
    [r2]ospf 1 router-id 1.1.1.1 
    [r2-ospf-1]area 0
    [r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0 //此环回充当此区域的用户
    [r2-ospf-1-area-0.0.0.0]network 10.0.21.0 0.0.0.255 
    [r2-ospf-1-area-0.0.0.0]network 10.0.23.0 0.0.0.255 
    [r2-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255 
    
    	R4配置如下:
    [r4]ospf 1 router-id 4.4.4.4 
    [r4-ospf-1]area 0
    [r4-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255 
    [r4-ospf-1-area-0.0.0.0]area 1 
    [r4-ospf-1-area-0.0.0.1]network 10.200.0.0 0.0.0.255 
    

      其他OSPF域配置均与之相同。
      结果展示:
    在这里插入图片描述

    (2)打通RIP域外

      在R1、9、10三台设备中起RIP协议。

    以R1、R10为例:
    	R1配置如下:
    [r1]rip 1
    [r1-rip-1]undo summary
    [r1-rip-1]version 1
    [r1-rip-1]network 10.0.0.0
    
    	R9配置如下:
    [r1]rip 1
    [r1-rip-1]undo summary
    [r1-rip-1]version 1
    [r1-rip-1]network 10.0.0.0
    [r1-rip-1]network 9.0.0.0  此环回(9.9.9.9)充当此区域的用户
    

    结果展示:
    在这里插入图片描述

    (3)连接各域

    1、使用虚链路

      首先是2域和0域并未直接相连,此时我们需要虚链路来缝合0域。
      配置如下:

    R4配置:
    [r4]ospf
    [r4-ospf-1]area 1
    [r4-ospf-1-area-0.0.0.1]vlink-peer 5.5.5.5
    
    R5配置:
    [r5]ospf
    [r5-ospf-1]area 1
    [r5-ospf-1-area-0.0.0.1]vlink-peer 4.4.4.4
    

    2、使用双向重发布

      为了使RIP和OSPF相互学习得到路由,且全网可达,我们在ASBR设备R1上对此进行双向重发布。
      配置如下:

    R1配置:
    [r1]ospf
    [r1-ospf-1]import-route rip 1 
    [r1]rip
    [r1-rip-1]import-route ospf 1
    
    

      到此即打通了所有域,实现全网可达。我们在0域的R2设备;2域的R6设备;RIP域的R10设备中分别查看它们是否学得我们充当用户的环回路由即可验证。
    R2:
    在这里插入图片描述
    R6:
    在这里插入图片描述
    R10:
    在这里插入图片描述

    四、验证

    (1)连通性验证

      我们验证用户R9-R6;R2-R6;R2-R9:
      R9-R6结果展示:
    在这里插入图片描述

      R2-R6结果展示:
    在这里插入图片描述

      R2-R9结果展示:
    在这里插入图片描述

    五、完整配置

      在这里我们只给出核心的一些设备的全部配置。

    R1

      R1的完整配置如下:

    [r1]display current-configuration 
    [V200R003C00]
    #
     sysname r1
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.21.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.19.1 255.255.255.0 
    #
    ospf 1 router-id 2.2.2.2 
     import-route rip 1
     area 0.0.0.0 
      network 10.0.21.0 0.0.0.255 
    #
    rip 1
     undo summary
     version 1
     network 10.0.0.0
     import-route ospf 1
    
    

    R2

      R2的完整配置如下:

    [r2]display current-configuration 
    [V200R003C00]
    #
     sysname r2
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.21.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.0.23.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/2
     ip address 10.0.24.2 255.255.255.0 
    #
    ospf 1 router-id 1.1.1.1 
     area 0.0.0.0 
      network 2.2.2.2 0.0.0.0 
      network 10.0.21.0 0.0.0.255 
      network 10.0.23.0 0.0.0.255 
      network 10.0.24.0 0.0.0.255 
    

    R4

      R1的完整配置如下:

    [r4]display current-configuration
    [V200R003C00]
    #
     sysname r4
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.24.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.0.2 255.255.255.0 
    #
    ospf 1 router-id 4.4.4.4 
     area 0.0.0.0 
      network 10.0.24.0 0.0.0.255 
     area 0.0.0.1 
      network 10.200.0.0 0.0.0.255 
      vlink-peer 5.5.5.5
    

    R5

      R1的完整配置如下:

    [r5]display current-configuration 
    [V200R003C00]
    #
     sysname r5
    #
    interface GigabitEthernet0/0/0
     ip address 10.200.0.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255 
    #
    ospf 1 router-id 5.5.5.5 
     area 0.0.0.1 
      network 5.5.5.5 0.0.0.0 
      network 10.200.0.0 0.0.0.255 
      vlink-peer 4.4.4.4
     area 0.0.0.2 
      network 10.200.1.0 0.0.0.255 
    

    R6

      R1的完整配置如下:

    [r6]display current-configuration 
    [V200R003C00]
    #
     sysname r6
    #
    interface GigabitEthernet0/0/0
     ip address 10.200.1.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 6.6.6.6 255.255.255.0 
    #
    ospf 1 router-id 6.6.6.6 
     area 0.0.0.2 
      network 6.6.6.6 0.0.0.0 
      network 10.200.1.0 0.0.0.255 
    

    R9

      R1的完整配置如下:

    [r9]display current-configuration 
    [V200R003C00]
    #
     sysname r9
    #
    interface GigabitEthernet0/0/0
     ip address 10.200.109.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.200.19.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 9.9.9.9 255.255.255.255 
    #
    rip 1
     undo summary
     version 1
     network 10.0.0.0
     network 9.0.0.0
    

      到这里简单的全网可达已经实现了,但是网络中依然存在一些问题,例如:双重发布时学习的子网掩码为8的路由会存在问题,拓扑够大时可能出现环路或者路由黑洞等问题,所以这些问题还需要解决。
      但本文中不再对此进行赘述。

    展开全文
  • ENSP配置 实例六 OSPF配置 R1 [R1]interface e0/0/0 [R1-Ethernet0/0/0]ip add 192.168.1.254 24 [R1-Ethernet0/0/0]int e0/0/1 [R1-Ethernet0/0/1]ip add 10.0.12.1 24 [R1]ospf 1 router-id 1.1.1.1 [R1-ospf-1]...
  • 单区域的ospf配置

    2021-01-02 10:11:32
    单区域的ospf配置 对R1路由器进行ospf配置 首先进入全局模式,然后在全局模式下开始配置,具体代码如下图: 对R2进行配置: 对R3进行配置 ping测试: 测试成功
  • 华为路由器OSPF配置

    千次阅读 2019-05-13 14:52:11
    转自华为路由器OSPF配置 配置拓扑 按照拓扑图上配置ospf的三个区域,相互学习到路由并查看每个路由器的LSDB和相关LSA信息,AR4与AR6分别扮演ASBR角色并将自己的环回接口网络重分布进ospf网络中,AR6的外部路由使...
  • 4 eNSP模拟--OSPF配置.rar

    2020-04-24 16:04:02
    4 eNSP模拟--OSPF配置.rar
  • ospf配置详解

    2018-12-19 11:57:58
    ospf单区域多区域路由配置详解,里面包括配置命令以及拓扑图
  • 路由ospf配置

    2018-05-19 19:18:30
    路由协议ospf基本配置!喜欢的可以下载收藏一下。。。。
  • 帧中继ospf配置

    2012-10-18 13:19:53
    帧中继ospf配置 1.根据帧中继拓扑一,配置帧中继,IP地址以及单区域OSPF 2、说明此时都有哪几种OSPF网络类型,以及该类型的特点 3、修改路由器帧中继接口的OSPF网络类型分别为:Broadcast,Point-to-MutilPoint,...
  • h3c ospf配置

    2013-07-30 22:08:32
    h3c ospf配置 h3c文档opf
  • 动态OSPF配置路由表

    2019-09-30 06:30:52
    动态ospf设置路由表 以Rourer1为例子 (1)首先设置路由器端口ip Router(config)#inter f0/0 Router(config-if)#ip add 192.168.1.1 255.255.255.0 (2)启用端口Ip ...(3)ospf配置路由表 Rout...
  • CCNA ospf配置

    2015-03-25 08:48:51
    ospf配置命令 大

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,499
精华内容 2,999
关键字:

ospf配置