精华内容
下载资源
问答
  • DHCP和DHCP中继
    2021-12-07 18:31:02

    目录

    DHCP介绍

    中继模式介绍

    实验配置命令

    总结

    DHCP用途与工作原理

    DHCP ( Dynamic Host Conf iguration Protocol,动态主机配置协议)是一个局域网的网络协议,使用UDP协议工作,主要有两个用途:
    1.给内部网络或网络服务供应商自动分配IP地址
    2.给用户或者内部网络管理员作为对所有计算机作中央管理的手段
    使用DHCP的好处:
    减少管理员的工作量避免输入错误的可能避免工P地址冲突
    当更改IP地址段时,不需要重新配置每个用户的IP地址提高了IP地址的利用率
    方便客户端的配置
    DHCP的典型应用模式如下:在网络中架设一台专用的DCP服务器,负责集中分配各种网络地址参数(主要包括IP地址、子网掩码、广播地址、默认网关地址、DNS服务器地址);其他主机作为DHCP客户机,将网卡配置为自动获取地址,即可与DHCP服务器进行通信,完成自动配置过程。
    DRCP协议采用upP作为传输协议,主机发送请求消息到DHCP服务器的67号端口,DHCP服务器回应应答消息给客户端的68号端口

    DHCP的IP地址自动获取工作原理:

    第一步:客户端在网络中搜索服务器。
    客户端通过广播发送DHCP Discover报文寻找服务器端
    第二步:服务器向客户端响应服务。
    服务器端通过单播发送DHCPOoffer报文向客户端提供IP地址等网络信息,从IP地址池中挑选一个尚未分配的IP地址分配给客户端
    第三步:客户端向服务器发出服务请求。
    如果有多台DHCP服务器向该客户端发来DHCP-offer报文,客户端只接受第一个收到的DHC
    -offer报文并提取IP地址,然后客户端通过广播
    发送DHCP Request报文告知服务器端本地选择使用该IP地址
    第四步:服务器向客户端提供服务。
    服务器通过单播发送DHCPAck报文告知客户端IP地址是合法可用的,并在选项字段中增加I
    P地址:的使用租期信息
    (5)重新登录
    UACcP客户机每次重新登录网络时,不需要再发送DHCP Discover信息,而是直接发送包含前一次所分配的IP地址的DHCP Request请求信息。
    (6)更新租约
    当DHCP服务器向客户机出租的IP地址租期达到50%时,就需要更新租约。客户机直接向提供租约的服务器发送DHCPRequest包,要求更新现有的地址租约。

    中继模式的用途与工作原理

    #######DHCP中继########﹒####.######应用场景:
    在大型的网络中,可能会存在多个网段。DHCP客户机通过网络广播消息获得DHCP服务器的响应后得到IP地址。但广播消息是不能跨越网段的。因此,如果DBCP客户机和服务器在不同的网段内,客户机还能不能向服务器申请I地址呢?这就要用到DAcP中继代理。DHCP中继代理实际上是一种软件技术安装在DHCP中继代理的设备(路由器,交换机,服务器)称为DHCP中继代理服务器,它承担不同网段间的DHCP客户机和服务器的通信任务。
    工作原理:
    当DHCP客户端启动并进行DHCP初始化时,它在本地网络广播配置请求报文。

    如果本地网络存在DHCP服务器,则可以直接进行DHCP配置,不需要DHCP中继。

    如果本地网络没有DHCP服务器,则与本网络相连的且带DECP中继功能的网络设备收到该广播报文后,进行适当的处理并转发给指定的在其它网络上的DHCP服务器。

    DHCP服务器根据客户端提供的信息进行相应的配置,并通过DHCP中继将配置信息发送给客户端,完成对客户端的动态配置。
    DHCP和中继模式的配置实验

    接口模式实验

    [R1-GigabitEthernet0/0/0]ip add 192.168.100.1 24
    [R1-GigabitEthernet0/0/0]dhcp select interface
    [R1-GigabitEthernet0/0/0]dhcp server lease day 7
    [R1-GigabitEthernet0/0/0]dhcp server excluded-ip-address 192.168.100.250 192.168.100.253
    [R1-GigabitEthernet0/0/0]dhcp server dns-list 8.8.8.8


    全局模式实验
    1.设置地址
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.100.1 24
    [R1-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 192.168.200.1 24
    [R1-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.


    2.配置网关和mac 地址绑定
    [R1]ip pool 1
    Info:It's successful to create an IP address pool.    
    [R1-ip-pool-1]gateway-list 192.168.100.1     ###设置DHCP客户端的出口网关地址 
    [R1-ip-pool-1]network 192.168.100.0 mask 24 ###配置DHCP可分配地址网段,掩码也可用24表示
    [R1-ip-pool-1]dns-list 8.8.8.8
    [R1-ip-pool-1]excluded-ip-address 192.168.100.250 192.168.100.254
    [R1-ip-pool-1]lease day 10
    [R1-ip-pool-1]static-bind ip-address 192.168.100.88 mac-address 5489-9833-3A53

        
    [R1]ip pool 2
    Info:It's successful to create an IP address pool.
    [R1-ip-pool-2]gateway-list 192.168.200.1
    [R1-ip-pool-2]network 192.168.200.0 mask 255.255.255.0    
    [R1-ip-pool-2]lease day 7
    [R1-ip-pool-2]dns-list 114.114.114.114
    [R1-ip-pool-2]static-bind ip-address 192.168.200.66 mac-address 5489-9866-2B2B

    3.配置全局模式

    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]dhcp select global 
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]dhcp select global 

    释放主机IP
    ipconfig /release
    ipconfig /renew


    DHCP 中继  关闭两个路由 重新启动
    R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.100.1 24
    [R1-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 192.168.200.1 24 
    [R1-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R1-GigabitEthernet0/0/1]int g0/0/2
    [R1-GigabitEthernet0/0/2]ip add 12.0.0.1 24
    [R1-GigabitEthernet0/0/2]un sh
    Info: Interface GigabitEthernet0/0/2 is not shutdown.
    [R1-GigabitEthernet0/0/2]dis ip int br

    配置中继
    [R1]int g0/0/0
    dhcp enable
    [R1-GigabitEthernet0/0/0]dhcp select relay 
    [R1-GigabitEthernet0/0/0]undo shutdown 
    [R1-GigabitEthernet0/0/0]dhcp relay server-ip 12.0.0.2

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]dhcp select relay 
    [R1-GigabitEthernet0/0/1]undo shutdown 
    [R1-GigabitEthernet0/0/1]dhcp relay server-ip 12.0.0.2

    R2配置

    [R2]int g0/0/0
    dhcp enable
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.

    [R2]ip pool 1
    Info:It's successful to create an IP address pool.    
    [R2-ip-pool-1]gateway-list 192.168.100.1
    [R2-ip-pool-1]network 192.168.100.0 mask 24
    [R2-ip-pool-1]dns-list 8.8.8.8
    [R2-ip-pool-1]lease day 10
    [R2-ip-pool-1]di th

    [R2]ip pool 2
    Info:It's successful to create an IP address pool.    
    [R2-ip-pool-1]gateway-list 192.168.200.1
    [R2-ip-pool-1]network 192.168.200.0 mask 24
    [R2-ip-pool-1]dns-list 114.114.114.114
    [R2-ip-pool-1]lease day 10
    [R2-ip-pool-1]di th

    [R2]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1

    [R2]int g0/0/0    
    [R2-GigabitEthernet0/0/0]dhcp select global 

    总结:掌握DHCP的工作原理

               掌握中继模式的工作原理

               掌握接口模式,全局模式,中继模式的相关配置

     

    更多相关内容
  • 提出了一种在中小型网络中部署DHCP的新方式,只需利用Microsoft的路由和远程访问服务,即可实现不同子网之间的路由,同时为不同子网的...探索出了DHCP中继代理在虚拟机上的实现过程,便于广大的专业技术人员掌握、学习。
  • ccieh3c.qzone.qq.com:(5)华为防火墙USG上部署DHCP服务以及DHCP中继.pdf
  • H3C Cloud Lab模拟器DHCP中继-完整实验配置,给需要学习的学友们,内容简洁明了,易懂,由其是初学者
  • DHCP中继代理在虚拟机linux系统中的研究与实现
  • 12.3 配置DHCP中继

    千次阅读 2021-11-28 08:02:43
    DHCP中继可以使客户端通过它与其他网段的服务器通信,最终获取IP地址,解决了DHCP客户端不能跨网段向服务器动态获取IP地址的问题。这样,在多个不同网络上的DHCP客户端可以使用同一个DHCP服务器,...

    原理概述

            由于在IP地址动态获取过程中,客户端采用广播方式发送请求报文,而广播报文不能跨网段网速,因此DHCP只适用于DHCP客户端和服务器处于同一个网段内的情况。当多个网段都需要进行动态IP地址分配时,就需要所有网段上都设置一个DHCP服务器,这显然是不易管理和维护的。

            DHCP中继可以使客户端通过它与其他网段的服务器通信,最终获取IP地址,解决了DHCP客户端不能跨网段向服务器动态获取IP地址的问题。这样,在多个不同网络上的DHCP客户端可以使用同一个DHCP服务器,即节省了成本,又便于进行集中管理和维护。路由器或三层交换机都可以充当DHCP中继设备。

    实验目的

    •         理解DHCP的应用场景
    •         掌握DHCP中继的配置

    实验内容

            本实验模拟企业网络场景。某公司分部的网络由交换机S1和网关路由器R1组成,员工终端PC1和PC2都连接在S1上。公司要求分部内所有员工主机的IP地址都通过总部的DHCP服务器自动获取。分部网关路由器R1通过公网路由器R2访问公司总部的DHCP服务器R3。由于公司分部与总部不在同一个子网,需要在R1上配置DHCP中继,使分部内主机能跨网段从总部的DHCP服务器自动获取IP地址。

    实验编址

    设备接口  IP地址子网掩码默认网关
    R1G0/0/110.1.1.254255.255.255.0N/A
    G0/0/0200.1.1.1255.255.255.0N/A
    R2G0/0/0 200.1.1.2255.255.255.0N/A
    G0/0/1100.1.1.2255.255.255.0N/A
    R3G0/0/1100.1.1.1255.255.255.0

              N/A

    实验拓扑

    实验步骤

    1.基本配置 

            根据实验编址对三台路由器进行相应的IP地址配置,并测试其直连链路的连通性。

    2.搭建OSPF网络

            在公司路由器R1、R2、R3 上都配置OSPF协议,所有网段都发布到区域0中。

            [R1]ospf 1
            [R1-ospf-1]area 0
            [R1-ospf-1-area-0.0.0.0]network 200.1.1.0 0.0.0.255
            [R1-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255

            [R2]ospf 1
            [R2-ospf-1]area 0
            [R2-ospf-1-area-0.0.0.0]network 200.1.1.0 0.0.0.255
            [R2-ospf-1-area-0.0.0.0]network 100.1.1.0 0.0.0.255

            [R3]ospf 1
            [R3-ospf-1]area 0
            [R3-ospf-1-area-0.0.0.0]network 100.1.1.0 0.0.0.255
            [R3-ospf-1-area-0.0.0.0]network 200.1.1.0 0.0.0.255

            配置完成后,查看路由表信息。

            

            <R1>dis ip routing-table 
            Route Flags: R - relay, D - download to fib
            ------------------------------------------------------------------------------
            Routing Tables: Public
                     Destinations : 11       Routes : 11       

            Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

                   10.1.1.0/24  Direct  0    0           D   10.1.1.254      GigabitEthernet0/0/1
                 10.1.1.254/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1
                 10.1.1.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1
                  100.1.1.0/24  OSPF    10   2           D   200.1.1.2       GigabitEthernet0/0/0
                  127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
                  127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
            127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
                  200.1.1.0/24  Direct  0    0           D   200.1.1.1       GigabitEthernet0/0/0
                  200.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0
                200.1.1.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0
            255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0

            <R2>dis ip routing-table 
            Route Flags: R - relay, D - download to fib
            ------------------------------------------------------------------------------
            Routing Tables: Public
                     Destinations : 11       Routes : 11       

            Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

                   10.1.1.0/24  OSPF    10   2           D   200.1.1.1       GigabitEthernet0/0/0
                  100.1.1.0/24  Direct  0    0           D   100.1.1.2       GigabitEthernet0/0/1
                  100.1.1.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1
                100.1.1.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1
                  127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
                  127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
            127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
                  200.1.1.0/24  Direct  0    0           D   200.1.1.2       GigabitEthernet0/0/0
                  200.1.1.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0
                200.1.1.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0
            255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0

            <R3>dis ip routing-table 
            Route Flags: R - relay, D - download to fib
            ------------------------------------------------------------------------------
            Routing Tables: Public
                     Destinations : 9        Routes : 9        

            Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

                   10.1.1.0/24  OSPF    10   3           D   100.1.1.2       GigabitEthernet0/0/1
                  100.1.1.0/24  Direct  0    0           D   100.1.1.1       GigabitEthernet0/0/1
                  100.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1
                100.1.1.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1
                  127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
                  127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
            127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
                  200.1.1.0/24  OSPF    10   2           D   100.1.1.2       GigabitEthernet0/0/1
            255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0

            可以观察到,目前每台设备都可以正常获得路由信息。

    3.配置DHCP服务器

            总部路由器R3配置为DHCP服务器,负责为分部的网络分配IP地址。在R3上使用 dhcp enable 命令开启DHCP功能,创建全局地址池 ip-pool ,可分配IP地址范围为10.1.1.0/24 ,出口网关指定为10.1.1.254。并在面向DHCP中继设备的接口上开启DHCP服务功能,指定从全局地址池分配地址。

            [R3]dhcp enable
            Info: The operation may take a few seconds. Please wait for a moment.done.
            [R3]ip pool ip-pool
            Info: It's successful to create an IP address pool.
            [R3-ip-pool-ip-pool]network 10.1.1.0 mask 255.255.255.0
            [R3-ip-pool-ip-pool]gateway-list 10.1.1.254
            [R3-ip-pool-ip-pool]int g0/0/1  
            [R3-GigabitEthernet0/0/1]dhcp select global 

            配置完成后,使用命令 display ip pool 查看IP地址池的配置情况。       

            <R3>dis ip pool 
              -----------------------------------------------------------------------
              Pool-name      : ip-pool
              Pool-No        : 0
              Position       : Local           Status           : Unlocked
              Gateway-0      : 10.1.1.254      
              Mask           : 255.255.255.0
              VPN instance   : --


              IP address Statistic
                Total       :253   
                Used        :0          Idle        :253   
                Expired     :0          Conflict    :0          Disable   :0     

            可以观察到,目前可用地址出去网关IP以外还剩253个,还没有PC动态申请IP地址。

      4.配置DHCP中继

            下面配置R1为DHCP中继设备,指定DHCP服务器为R3。这是如果R1从G0/0/1接口收到PC的DHCP广播请求包,R1作为DHCP中继设备会以单播形式转发请求包到中继设备所指明的DHCP服务器R3;R3收到DHCP请求包后,会把分配的IP地址通过单播包返回给R1,R1再把地址信息发送给PC。

            配置指定DHCP服务器有两种方式,一种方式是在面向PC的接口下直接配置DHCP服务器地址;另一种方式是在面向PC的接口下调用全局定义的DHCP服务器组。

            ⑴第一种配置方式:直接在R1的G0/0/1接口下开始DHCP中继功能,并直接指定DHCP服务器地址为100.1.1.1。

            [R1]dhcp enable
            Info: The operation may take a few seconds. Please wait for a moment.done.
            [R1]int g0/0/1
            [R1-GigabitEthernet0/0/1]dhcp select relay    
            [R1-GigabitEthernet0/0/1]dhcp relay server-ip 100.1.1.1

            ⑵第二种配置方式:在R1上创建DHCP服务器组,指定组名为dhcp-group ,并使用 dhcp-server 命令添加远端的DHCP服务器地址。接着在G0/0/1接口下开启DHCP中继功能并配置所对应的DHCP服务器组。

            [R1]dhcp server group dhcp-group
            Info:It's successful to create a DHCP server group. 
            [R1-dhcp-server-group-dhcp-group]dhcp-server 100.1.1.1
            [R1-dhcp-server-group-dhcp-group]int g0/0/1
            [R1-GigabitEthernet0/0/1]dhcp select relay  
            [R1-GigabitEthernet0/0/1]dhcp relay server-select dhcp-group

            两种方式均能达到同样的配置要求,相比而言,在接口下指定DHCP服务器IP地址的方式比较简单。但如果中继设备上有多个接口需要配置DHCP中继功能,则要在所有接口上重复同样的配置,产生的配置量比较大。这种情况就应该使用服务器组的方式,仅在全局定义一次,在每个接口重复调用即可,当有多个DHCP服务器或者服务器IP地址需要更改时尤为方便。

    5.配置PC获取地址方式为DHCP

            现在两台 PC都从总部DHCP服务器获得IP地址,测试PC的连通性。

            PC>ping 10.1.1.253

            Ping 10.1.1.253: 32 data bytes, Press Ctrl_C to break
            From 10.1.1.253: bytes=32 seq=1 ttl=128 time=31 ms
            From 10.1.1.253: bytes=32 seq=2 ttl=128 time=47 ms
            From 10.1.1.253: bytes=32 seq=3 ttl=128 time=16 ms
            From 10.1.1.253: bytes=32 seq=4 ttl=128 time=31 ms
            From 10.1.1.253: bytes=32 seq=5 ttl=128 time=47 ms

            测试成功。PC通过DHCP中继设备成功从DHCP服务器获得IP地址,并能使用该地址相互通信。

            整个配置过程,仅在网关路由器R1上开启DHCP中继功能,在分部没有其他过多的DHCP配置。由此可见,在网络涉及和管理中灵活使用DHCP中继功能能够使网络运行更加高效、方便。

     

     

    展开全文
  • 提出了一种在中小型网络中部署 DHCP的新方式,只需利用 Microsoft的路由和远程访问服务,即可实现不同子网之间的路由,同时为不同子网的...探索出了 DHCP中继代理在虚拟机上的实现过程,便于广大的专业技术人员掌握、学习。
  • 华为 DHCP、DHCP中继、DHCP snooping

    万次阅读 多人点赞 2021-02-15 22:02:28
    DHCP客户端获取地址的过程,分为四个阶段:发现阶段,提供阶段,选择阶段,确认阶段。

    哈喽,大家好!我是艺博东 ,是一个思科出身专注于华为的网工;好了,话不多说,我们直接进入正题。

    一、DHCP 拓扑

    在这里插入图片描述

    二、DHCP 基础配置

    R1

    [Huawei]sysname R1
    [R1]dhcp enable 
    [R1]ip pool 160
    [R1-ip-pool-160]gateway-list 192.168.160.1                #网关
    [R1-ip-pool-160]network 192.168.160.0 mask 255.255.255.0  #分配的网段
    [R1-ip-pool-160]lease day 3 hour 0 minute 0               #租期
    [R1-ip-pool-160]dns-list 114.114.114.114                  #dns服务器的IP地址
    [R1-ip-pool-160]q
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip address  192.168.160.1 24
    [R1-GigabitEthernet0/0/0]q
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]dhcp select global               #接口下选择全局的地址池给DHCP客户端使用
    [R1-GigabitEthernet0/0/0]q
    

    三、DHCP 测试

    PC1

    选择DHCP—>右下角点击“应用”
    在这里插入图片描述
    输入ipconfig
    在这里插入图片描述
    由以上输出结果可知,已成功获取。

    测试连通性
    PC>ping 192.168.160.1
    在这里插入图片描述
    已ping通。

    四、DHCP 分析

    抓包

    在这里插入图片描述
    DHCP客户端获取地址的过程,分为四个阶段:发现阶段,提供阶段,选择阶段,确认阶段。

    (1)发现阶段

    首先是DHCP客户发起DHCP Discover报文来寻找DHCP服务器。由于DHCP服务器的IP地址对于客户端来说是未知的,所以DHCP客户端以广播方式发送DHCP Discover报文。所有收到DHCP Discover报文的DHCP服务器都会发送回应报文,DHCP客户端据此可以知道网络中存在的DHCP服务器的位置。

    在这里插入图片描述
    它的源地址为0.0.0.0,目的地址为255.255.255.255。

    DHCP报文的广播标志字段(flags),当标志字段的最高位为0时,表示客户端希望服务器以单播方式发送DHCP Offer/DHCP Ack报文;当标志字段的最高位为1时,表示客户端希望服务器以广播方式发送DHCP Offer/DHCP Ack报文。

    option 53 消息类型
    option 61 DHCP 客户端 ID
    option 55 请求的参数
    在这里插入图片描述

    (2)提供阶段

    网络中接收到DHCP Discover报文的DHCP服务器,会从地址池选择一个合适的 IP 地址,连同 IP 地址租约期限和其他配置信息通过DHCP Offer报文发送给DHCP客户端。

    在这里插入图片描述

    它的源地址为192.168.160.1(DHCP 服务器的地址),目的地址为192.168.160.254(分配给DHCP客户端的IP地址)。

    option 53 消息类型
    option 1 子网掩码
    option 3 网关地址
    option 6 DNS服务器的地址
    option 51 租期时间
    option 59 87.5% 续租时间
    option 58 50% 续租时间
    option 54 DHCP 服务器 ID

    option 53 消息类型
    在这里插入图片描述

    option 1 子网掩码
    在这里插入图片描述
    option 3 网关地址
    在这里插入图片描述

    option 6 DNS服务器的地址
    在这里插入图片描述

    option 51 租期时间
    在这里插入图片描述

    option 59 87.5%会续租时间
    在这里插入图片描述

    option 58 50%会续租时间

    在这里插入图片描述

    option 54 DHCP 服务器 ID
    在这里插入图片描述

    (3)选择阶段

    如果有多台 DHCP 服务器向 DHCP 客户端回应 DHCP Offer 报文,则 DHCP 客户端只接收第一个收到的 DHCP Offer报文。然后以广播方式发送 DHCP Request请求报文,该报文中包含服务器标识选项,即它选择的 DHCP 服务器的 IP 地址信息。

    在这里插入图片描述
    它的源地址为0.0.0.0(DHCP 服务器的地址),目的地址为255.255.255.255(分配给DHCP客户端的IP地址)。

    option 53 消息类型
    option 54 DHCP 服务器 ID
    option 50 请求的IP地址
    option 61 DHCP 客户端 ID
    option 55 请求的参数
    在这里插入图片描述

    (4)确认阶段

    当 DHCP 服务器收到 DHCP 客户端回答的 DHCP Request报文后,DHCP 服务器会根据 DHCP Request报文中携带的 MAC 地址来查找有没有相应的租约记录。如果有,则向客户端发送包含它所提供的 IP 地址和其它设置的 DHCP Ack 确认报文。DHCP 客户端收到该确认报文后,会以广播的方式发送免费 ARP 报文,探测是否有主机使用服务器分配的 IP 地址,如果在规定的时间内没有收到回应,客户端才使用此地址。

    在这里插入图片描述
    它的源地址为192.168.160.1(DHCP 服务器的地址),目的地址为192.168.160.254(分配给DHCP客户端的IP地址)。

    DHCP Release 报文是主动释放服务器分配给它的IP地址。
    在这里插入图片描述

    五、DHCP 中继

    5.1 定义

    DHCP Relay 即 DHCP 中继,它实现了不同网段间的 DHCP 服务器和客户端之间的报文交互。

    5.2 作用

    DHCP 中继承担处于不同网段间的 DHCP 客户端和服务器之间中继服务,将 DHCP 协议报文跨网段透传到目的 DHCP 服务器,最终使网络上的 DHCP 客户端可以共同使用一个 DHCP 服务器。

    六、DHCP 中继 拓扑

    在这里插入图片描述

    七、DHCP 中继 基础配置

    R1

    [R1]dhcp enable
    [R1]ip pool 200
    [R1-ip-pool-200]gateway-list 192.168.200.254
    [R1-ip-pool-200]network 192.168.200.0 mask 255.255.255.0
    [R1-ip-pool-200]lease day 3 hour 0 minute 0
    [R1-ip-pool-200]dns-list 114.114.114.114
    [R1-ip-pool-200]q
    [R1]ip pool 100
    [R1-ip-pool-100]gateway-list 192.168.100.254
    [R1-ip-pool-100]network 192.168.100.0 mask 255.255.255.0
    [R1-ip-pool-100]lease day 3 hour 0 minute 0
    [R1-ip-pool-100]dns-list 114.114.114.114
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip address 192.168.160.1 255.255.255.0
    [R1-GigabitEthernet0/0/0]dhcp select global
    [R1-GigabitEthernet0/0/0]q
    [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.160.2
    

    R2

    [R2]dhcp enable
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.160.2 255.255.255.0
    [R2-GigabitEthernet0/0/0]q
    [R2]vlan batch 100 200
    [R2]int g0/0/1.100
    [R2-GigabitEthernet0/0/1.100]dot1q termination vid 100
    [R2-GigabitEthernet0/0/1.100]ip address 192.168.100.254 255.255.255.0
    [R2-GigabitEthernet0/0/1.100]arp broadcast enable
    [R2-GigabitEthernet0/0/1.100]dhcp select relay
    [R2-GigabitEthernet0/0/1.100]dhcp relay server-ip 192.168.160.1
    [R2-GigabitEthernet0/0/1.100]q
    [R2]int g0/0/1.200
    [R2-GigabitEthernet0/0/1.200]dot1q termination vid 200
    [R2-GigabitEthernet0/0/1.200]ip address 192.168.200.254 255.255.255.0
    [R2-GigabitEthernet0/0/1.200]arp broadcast enable
    [R2-GigabitEthernet0/0/1.200]dhcp select relay
    [R2-GigabitEthernet0/0/1.200]dhcp relay server-ip 192.168.160.1
    [R2-GigabitEthernet0/0/1.200]q
    [R2]ip route-static 0.0.0.0 0.0.0.0 192.168.160.1
    

    LSW1

    [Huawei]sysname LSW1
    [LSW1]vlan batch 100 200 
    [LSW1]dhcp enable 
    [LSW1]int g0/0/1
    [LSW1-GigabitEthernet0/0/1]port link-type trunk             #端口类型为trunk
    [LSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all   #放行所有VLAN
    [LSW1-GigabitEthernet0/0/1]int g0/0/2
    [LSW1-GigabitEthernet0/0/2]p l a 
    [LSW1-GigabitEthernet0/0/2]port default vlan 200
    [LSW1-GigabitEthernet0/0/2]int g0/0/3
    [LSW1-GigabitEthernet0/0/3]p l a 
    [LSW1-GigabitEthernet0/0/3]port default vlan 100
    [LSW1-GigabitEthernet0/0/3]q
    [LSW1]int Vlanif 200
    [LSW1-Vlanif200]ip address 192.168.200.254 255.255.255.0
    [LSW1-Vlanif200]dhcp select relay
    [LSW1-Vlanif200]dhcp relay server-ip 192.168.160.1  
    [LSW1-Vlanif200]q
    [LSW1]int Vlanif 100
    [LSW1-Vlanif100]ip address 192.168.100.254 255.255.255.0
    [LSW1-Vlanif100]dhcp select relay                   #使能DHCP Relay功能
    [LSW1-Vlanif100]dhcp relay server-ip 192.168.160.1  #DHCP中继所代理的DHCP服务器的IP地址
    

    八、DHCP 中继 测试

    PC5

    PC>ipconfig
    在这里插入图片描述
    已成功获取IP地址

    PC6

    PC>ipconfig

    在这里插入图片描述
    已成功获取IP地址

    PC5 PING 测 PC6

    PC>ping 192.168.100.252
    在这里插入图片描述
    由以上输出结果可知,可PING测通。

    抓包

    在这里插入图片描述
    DHCP Discover
    在这里插入图片描述
    DHCP Offer
    在这里插入图片描述
    DHCP request

    在这里插入图片描述
    DHCP Ack

    在这里插入图片描述

    九、DHCP snooping

    9.1 定义

    DHCP Snooping是DHCP的一种安全特性,用于保证DHCP客户端从合法的DHCP服务器获得IP地址,并记录DHCP客户端IP地址与MAC地址等参数的对应关系,防止网络上针对DHCP服务的攻击。

    9.2 基本功能:

    (1)信任功能:能够保证客户端从合法的服务器获取 IP 地址。DHCP Snooping 信任功能将接口分为信任接口和非信任接口:
    a)信任接口正常接收 DHCP 服务器响应的DHCP ACK、DHCP NAK 和 DHCP Offer报文。
    b)非信任接口在接收到 DHCP 服务器响应的DHCP ACK、DHCP NAK和DHCP Offer报文后,丢弃该报文。

    9.3 应用场景

    (1)防止DHCP服务器的仿冒者攻击

    攻击原理:由于 DHCP Server 和 DHCP Client 之间没有认证机制,所以如果在网络上随意添加一台 DHCP 服务器,它就可以为客户端分配 以及其他网络参数。如果该 DHCP 服务器为用户分配错误的 IP 地址和其他网络参数,将会对网络造成非常大的危害。
    解决方法:为了防止 DHCP Server 仿冒者攻击,可配置设备接口的“信任(Trusted)/非信任(Untrusted)”工作模式。将与合法 DHCP 服务器直接或间接连接的接口设置为信任接口,其他接口设置为非信任接口。此后,从“非信任(Untrusted)”接口上收到的 DHCP 回应报文将被直接丢弃,这样可以有效防止 DHCP Server 仿冒者的攻击。

    [LSW1]int g0/0/1
    [LSW1-GigabitEthernet0/0/1]dhcp snooping enable 
    [LSW1-GigabitEthernet0/0/1]dhcp snooping trusted
    

    (2)防止DHCP报文泛洪攻击

    攻击原理:在DHCP网络环境中,若存在DHCP用户短时间内向设备发送大量的DHCP报文,将会对设备的性能造成巨大的冲击以致可能会导致设备无法正常工作。

    解决方法:通过使能对DHCP报文上送DHCP报文处理单元的速率进行检测功能将能够有效防止DHCP报文泛洪攻击。

    [LSW1]dhcp snooping enable 
    [LSW1]dhcp snooping check dhcp-rate enable
    [LSW1]vlan 100
    [LSW1-vlan100]dhcp snooping check dhcp-rate enable
    

    (3)防止DHCP服务器拒绝服务攻击(饿死攻击)

    攻击原理:若R2设备接口 int g0/0/1下存在大量攻击者恶意申请 IP 地址,会导致 DHCP Server 中 IP 地址快速耗尽而不能为其他合法用户提供 IP 地址分配服务。另一方面,DHCP Server 通常仅根据 DHCP Request报文中的 CHADDR(Client Hardware Address)字段来确认客户端的MAC 地址。如果某一攻击者通过不断改变 CHADDR字段向 DHCP Server申请 IP 地址,同样将会导致 DHCP Server 上的地址池被耗尽,从而无法为其他正常用户提供 IP 地址。

    解决方法:限制SW的每个接口下PC通过DHCP获取地址的数量

    在这里插入图片描述

    [R2]dhcp snooping max-user-number 100
    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]dhcp snooping max-user-number 100
    

    (4)防止仿冒DHCP报文攻击

    攻击原理:在DHCP中,若攻击者仿冒合法用户的DHCP Request报文发往DHCP Server,将会导致用户的IP地址租约到期之后不能够及时释放,以致合法用户无法使用该IP地址,若攻击者仿冒合法用户的DHCP Release报文发往DHCP Server,将会导致用户异常下线。

    解决方法:为了有效的防止仿冒 DHCP 报文攻击,可利用 DHCP Snooping 绑定表的功能。设备通过将 DHCP Request 续租报文和 DHCP Release 报文与绑定表进行匹配操作能够有效的判别报文是否合法(主要是检查报文中的 VLAN、IP、MAC、接口信息是否匹配动态绑定表),若匹配成功则转发该报文,匹配不成功则丢弃。

    [LSW1]dhcp snooping check dhcp-request enable vlan 100
    [LSW1]dhcp snooping alarm threshold 100
    [LSW1]int g0/0/2
    [LSW1-GigabitEthernet0/0/2]dhcp snooping alarm dhcp-request threshold 100
    [LSW1]vlan 100
    [LSW1-vlan100]dhcp snooping check dhcp-request enable
    

    (5)防止非DHCP用户攻击

    手动配置IP地址的的用户的数据 SW不会转发

    PC5 的 MAC-address:54-89-98-2E-1E-95
    在这里插入图片描述

    [R1-ip-pool-200]static-bind ip 192.168.200.99 mac-address 5489-982E-1E95
    

    在这里插入图片描述
    OK,本期就到这里了。

    《周易》
    天行健,君子以自强不息;地势坤,君子以厚德载物。


    在这里插入图片描述
    好了这期就到这里了,如果你喜欢这篇文章的话,请点赞评论分享收藏,如果你还能点击关注,那真的是对我最大的鼓励。谢谢大家,下期见!

    展开全文
  • DHCP与DHCP中继简介

    2020-12-31 20:09:38
    DHCP与DHCP中继简介一、DHCP1、主要用途2、DHCP的好处1.引入库2.读入数据总结 一、DHCP DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段IP地址范围,客户机登录服务器时就可以自动获得...

    一、DHCP

    DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段IP地址范围,客户机登录服务器时就可以自动获得服务器分配的IP地址和子网掩码。

    1、主要用途

    1. 给内部网络或者网络服务供应商自动分配IP地址。
    2. 给用户或者内部网络服务管理员作为对所有计算机作中央管理的手段。

    2、DHCP的好处

    • 减少管理员的工作量
    • 避免输入错误的可能
    • 避免IP地址冲突
    • 当更改IP地址段时,不需要重新配置每个用户的IP地址
    • 提高了IP地址段的利用率
    • 方便客户端的配置

    3、三大分配模式

    • 自动分配方式(Automatic Allocation),DHCP服务器为主机指定一个永久性的IP地址,一旦DHCP客户端第一次成功从DHCP服务器端租用到IP地址后,就可以永久性的使用该地址。

    • 动态分配方式(Dynamic Allocation),DHCP服务器给主机指定一个具有时间限制的IP地址,时间到期或主机明确表示放弃该地址时,该地址可以被其他主机使用。

    • 手工分配方式(Manual Allocation),客户端的IP地址是由网络管理员指定的,DHCP服务器只是将指定的IP地址告诉客户端主机。

    4、工作原理

    1. 客户端在网络中搜索服务器
      客户端通过广播发送DHCP Discover报文寻找服务器端 。

    2. 服务器向客户端响应服务
      服务器通过单播发送DHCP offer报文向客户端提供IP地址等网络信息,从IP地址池中挑选一个尚未分配的IP地址给客户端。

    3. 客户端向服务器发出服务请求
      如果有多台DHCP服务器向该客户端发来DHCP-offer报文,客户端只接受第一个收到的DHCP-offer报文并提取IP地址,然后客户端通过广播发送DHCP Request报文来告知服务器端本地选择使用该IP地址。

    4. 服务器向客户端提供服务
      服务器通过单播发送DHCP Ack报文告知客户端IP地址时合法可用的,并在选项字段中增加IP地址的使用租期信息。

    二、DHCP接口模式

    接口地址池可动态分配IP地址,范围就是接口的IP地址所在的网段,且只在此接口下生效,当DHCP服务器收到DHCP客户端的请求报文后,DHCP服务器将会使用该接口的地址段给客户端分配地址。

    [Huawei]dhcp enable                                  #开启DHCP功能
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 192.168.10.2 24	 
    [Huawei-GigabitEthernet0/0/0]dhcp select interface   #基于接口配置DHCP
    [Huawei-GigabitEthernet0/0/0]dhcp server lease day 7 #配置基于接口的DHCP server租期(默认一天)
    [Huawei-GigabitEthernet0/0/0]dhcp server excluded-ip-address 192.168.10.200 192.168.10.210 
    #配置接口地址池中不参与自动分配的IP地址范围为192.168.10.200192.168.10.210
    [Huawei-GigabitEthernet0/0/0]dhcp server dns-list 8.8.8.8  #给用户自动分配DNS服务地址
    

    三、DHCP全局模式

    [Huawei]dhcp enable                              #开启DHCP功能
    [Huawei]ip pool 1                                #创建地址池名称
    [Huawei-ip-pool-1]gateway-list 192.168.10.2      #设置DHCP客户端出口网关地址
    [Huawei-ip-pool-1]network 192.168.10.2 mask 24   #配置DHCP可分配地址网段,掩码也可用255.255.255.0表示
    [Huawei-ip-pool-1]dns-list 114.114.114.114	     #配置DHCP分配DNS地址
    [Huawei-ip-pool-1]excluded-ip-address 192.168.10.250 192.168.10.254  #配置保留地址范围
    [Huawei-ip-pool-1]static-bind ip-address 192.168.10.88 mac-address 5489-980B-6C51  
                                                     #绑定IP192.168.10.88固定分配给MAC5489-980B-6C51的机器
    [Huawei-ip-pool-1]lease day 10                   #租期10[Huawei-ip-pool-1]int g0/0/0	
    [Huawei-GigabitEthernet0/0/0]dhcp select global  #配置DHCP为global全局模式
    

    四、DHCP中继代理

    DHCPRelay(DHCPR)DHCP中继(也叫做DHCP中继代理)是一个小程序,其可以实现在不同子网和物理网段之间处理和转发dhcp信息的功能。
    如果DHCP客户机与DHCP服务器在同一个物理网段,则客户机可以正确地获得动态分配的ip地址。如果不在同一个物理网段,则需要DHCP Relay Agent(中继代理)。

    1、简介

    用DHCP Relay代理可以去掉在每个物理的网段都要有DHCP服务器的必要,它可以传递消息到不在同一个物理子网的DHCP服务器,也可以将服务器的消息传回给不在同一个物理子网的DHCP客户机。

    2、工作原理

    1. 当DHCP启动并执行DHCP初始化时,它在本地网络广播配置请求报文
    2. 如果本地网络存在DHCP服务器,则可直接进行DHCP配置,不需要DHCP中继
    3. 如果本地没有DHCP服务器,则与本地网络相连的且带有DHCP中继功能的网络设备收到该广播报文后,进行适当处理,并转发给指定的在其他网络上的DHCP服务器
    4. DHCP根据客户端提供的信息进行相应配置,并通过DHCP中继将配置发送给客户端,完成对客户端的配置

    3、命令实例

    在这里插入图片描述

    [Huawei]dhcp enable         #开启DHCP功能
    [Huawei]int g0/0/0          #进入下行接口
    [Huawei-GigabitEthernet0/0/0]ip add ip add 192.168.10.2 24  #接口配置IP
    [Huawei-GigabitEthernet0/0/0]dhcp select relay              #选取中继模式
    [Huawei-GigabitEthernet0/0/0]dhcp rel server-ip 192.168.20.3#指向DHCP服务器的地址192.168.20.3请求DHCP服务
    [Huawei-GigabitEthernet0/0/0]q
    

    总结

    DHCP及DHCP中继代理虽然不难,但是得明白其原理,对于以后的知识点串联有一定作用,毕竟以后用到的地方多的是。

    展开全文
  • DHCP中继原理解析

    千次阅读 2022-03-21 14:48:26
    DHCP中继 当企业的内部网络规模较大时,通常被划分为多个不同的子网,网络内配置了VLAN,VLAN能隔离广播,而DHCP协议使用广播。DHCP服务器在哪个vlan中,就只有在相同vlan内的客户机能从DHCP服务器那里获取IP地址。...
  • DHCP服务提高了IP地址的利用率,方便了管理员对客户机的管理,很实用的一门技术,这里 就详细介绍一下DHCP服务,以及它是如何搭建的。 一、DHCP工作原理 1、了解DHCP服务 DHCP(Dypamic HostConfiguration ...
  • Linux搭建dhcp以及dhcp中继服务,附拓扑图和详细说明.
  • dhcp中继实验

    2022-04-16 11:45:58
    一:DHCP协议 1.1 DHCP简述 DHCP(Dynamic HostConfigurationProtocol)动态主机配置协议)是一种局域网的协议。主要是集中的管理,分配IP地址,使网络环境中的主机动态的获得IP地址。基于udp协议,端口号67&68 ...
  • DHCP+DHCP中继

    2021-08-27 09:31:23
    目录一、DHCP定义1.DHCP的作用2.DHCP的好处3.架构二、DHCP的工作原理三、租期四、DHCP服务的实现五、同网段DHCP服务的实现六、不同网段DHCP服务的实现总结 一、DHCP定义 DHCP(动态主机配置协议)是一个局域网的...
  • DHCP/DHCP中继运行原理

    2022-05-02 16:33:57
    我当初在查阅相关资料时,发现目前网络上DHCP介绍的已经是十分详细,但是DHCP中继运行原理相关介绍寥寥无几,所以现在我就把这两种原理运行情况都来介绍一下,着重介绍DHCP中继。 一、DHCP产生背景 近些年网络规模...
  • Linux dhcp 中继

    2021-11-25 08:09:47
    配置好一个双网卡(centos6.5)、一个dhcp服务器(centos7)和一个客户机 客户机为2网卡(此处为192.168.2.0网段0 ...中继的第一块网关指向服务器的IP systemctl stop firewalld setenforce 0 配置第二块网卡 cd
  • 三层交换机DHCP服务器/DHCP中继互联配置详述

    千次阅读 多人点赞 2022-03-17 00:47:06
    三层交换机DHCP服务器与三层交换机DHCP中继互联为不同vlan发放地址详细讲解
  • DHCP以及DHCP中继

    2021-08-27 09:42:28
    一、什么是DHCP 二、DHCP的运用 1、使用DHCP好处 2、架构 3、DHCP原理: 三、基本命令 一、什么是DHCP DHCP--动态主机配置协议 DHCP是一个局域网的网络协议。指的是由服务器控制一段IP地址范围,客户机登录...
  • DHCP和DHCP中继相关配置命令一、DHCP用途二、DHCP好处三、DHCP典型应用模式四、DHCP传输协议五、DHCP的IP地址自动获取工作原理六、DHCP两种配置方法1.接口模式2.全局模式七、DHCP中继1.应用场景2.工作原理3.配置DHCP...
  • DHCP中继代理

    2022-03-03 16:53:09
    DHCP中继代理 配置思路: 1、PC端开启DHCP服务 2、配置DHCP服务器 3、配置DHCP中继 4、验证 1、PC端开启DHCP服务 选择DHCP,点击应用 2、配置DHCP服务器 system-view [Huawei]system DHCP #启用DHCP服务 [DHCP]dhcp...
  • DHCP和DHCP中继介绍

    2021-03-19 15:49:56
    DHCP和DHCP中继介绍 一、DHCP是什么? 二、DHCP的IP地址自动获取工作原理 三、DHCP的两种配置方法 1、接口模式下的配置方法: 2、全局模式下的配置方法: 四、DHCP中继 1、什么情况下会用到DHCP中继? 2、其工作的...
  • 配置dhcp中继

    千次阅读 2021-11-20 22:08:19
    标题原理概述二、实验拓扑三、实验内容1....DHCP中继可以使客户端通过它与其他网段的DHCP服务器通信,最终获取IP地址,解决了DHCP客户端不能跨网段向服务器动态获取P地址的问题。这样,在多个不同网络上的
  • 交换机配置DHCP中继

    千次阅读 2020-12-24 11:23:43
    华为S2700/S3700/S5700/S9300二三层交换机配置DHCP中继DHCP中继DHCP Relay即DHCP中继,它是为解决服务器和客户端不在同一个网段而提出来的,它提供了对DHCP广播报文的透明传输功能,能够把DHCP客户端的广播报文透明...
  • DHCP、DHCP中继功能与配置

    千次阅读 2021-01-06 09:57:46
    文章目录一、DHCP1、DHCP主要用途2、使用DHCP的好处3、DHCP的典型应用模式4、DHCP采用的传输协议5、DHCP的IP地址自动获取工作原理二、DHCP两种配置方法1、接口模式2、全局模式三、DHCP中继1、应用场景2、工作原理3、...
  • DHCP和DHCP中继原理

    2021-05-21 15:07:27
    了解DHCP服务 DHCP (Dynamic Host Configuration Protocol,动态主机配置协议) 由Internet工作任务小组设计开发专门用于为TCP/IP网络中的计算机自动分配TCP/IP参数的协议 了解DHCP服务3-2使用DHCP的好处 ●减少管理...
  • 今天给大家带来实战——DHCP中继的原理和配置。本文首先介绍DHCP中继的原理,其次通过华为eNSP模拟器,实现了采用DHCP中继的方式实现DHCP的实验。 本文适合有一定DHCP基础的同学阅读,如果您对DHCP原理还存在疑惑,...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,607
精华内容 6,242
关键字:

dhcp中继