精华内容
下载资源
问答
  • TRUNK接口的工作过程接收1. 当收到一个数据帧判断帧是否有 VLAN Tag。2. 没有 Tag,则标记上 Trunk 端口的 PVID,进行转发3. 有 Tag,则判断该 Trunk 端口... 如果匹配trunk端口的PVID先剥离帧的 VLAN Tag,再发送N...

    TRUNK接口的工作过程

    接收

    1. 当收到一个数据帧判断帧是否有 VLAN Tag。

    2. 没有 Tag,则标记上 Trunk 端口的 PVID,进行转发

    3. 有 Tag,则判断该 Trunk 端口是否允许该 VLAN数据帧允许则转发,否则丢弃帧

    发出

    4. 当数据帧从 Trunk 端口发出时,允许该vlan数据帧则转发,否则丢弃

    5. 如果匹配trunk端口的PVID先剥离帧的 VLAN Tag,再发送

    Native Vlan

    native vlan 是不打标签的,使用Dot1q的交换机把所有未被标记的数据标记为native vlan 的tag

    注:本征VLAN是思科中的概念,华为只在了trunk中标记为PVID

    实验案例:

    6d871e75a8d6f31f5c099a2ba2c43fa4.png

    思路解析:

    · PC1经过LSW1-LSW2 trunk 允许了vlan 10 通过,可以顺利到达PC4

    · PC2经过LSW1设置本征为20,发出时会剥离空标签发出,到达LSW2时

    本征设置为30会压入30标签,顺利到达PC3

    配置实现:

    LSW1

    interface GigabitEthernet0/0/1

    port link-type access

    port default vlan 10

    接口划入vlan10

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 20

    interface GigabitEthernet0/0/3

    port link-type trunk

    修改为trunk模式

    port trunk pvid vlan 20

    PVID设置为20(也就是本征)

    port trunk allow-pass vlan 10 20

    允许vlan10 20 的数据帧经过

    LSW2

    interface GigabitEthernet0/0/1

    port link-type access

    port default vlan 30

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 10

    interface GigabitEthernet0/0/3

    port link-type trunk

    port trunk pvid vlan 30

    port trunk allow-pass vlan 10 30

    PC1

    fbdf5b7a36843253d083fb0c7cfb5a7e.png

    PC2

    b6c93d487fdc096807ffd12bf8083198.png

    PC3

    b83a8e4dc218e7f6715db78493d7618d.png

    PC4

    da3df3b1e2220c62cfe45fd7a25fbdb7.png

    验证测试:

    PC1----PC4

    6c8f5f7d6b0d8f5c31c41b57c3470349.png

    PC2----PC3

    9e10468aad24ec2a9d885edc6405a215.png
    展开全文
  • Access端口、Trunk端口和Hybrid端口 Access类型:端口只能属于1个VLAN,一般用于连接计算机; Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接; Hybrid类型:端口可以...

    Access端口、Trunk端口和Hybrid端口

    Access类型:端口只能属于1个VLAN,一般用于连接计算机; 
    
    Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接; 
    
    Hybrid类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。
    

    Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    三种类型的端口可以共存在一台设备上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    Access端口只能属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;Hybrid端口和Trunk端口可以属于多个VLAN,所以需要设置端口的缺省VLAN ID。

    Acess端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)

    Acess端口发报文:

    将报文的VLAN信息剥离,直接发送出去

    trunk端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有判断该trunk端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃

    trunk端口发报文:

    比较端口的PVID和将要发送报文的VLAN信息,如果两者相等则剥离VLAN信息,再发送,如果不相等则直接发送

    hybrid端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则判断该hybrid端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用)

    hybrid端口发报文:

    1,判断该VLAN在本端口的属性(dispinterface即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)

    2,如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送

    例如

    [Switch-Ethernet0/1]inte0/1

    [Switch-Ethernet0/1]portlink-type hybrid

    [Switch-Ethernet0/1]port hybrid pvid vlan 10

    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged

    [Switch-Ethernet0/1]inte0/2

    [Switch-Ethernet0/2]portlink-type hybrid

    [Switch-Ethernet0/2]porthy bridpvid vlan 20

    [Switch-Ethernet0/2]porthy brid vlan 10 20 untagged

    此时intere0/1和intere0/2下的所接的PC是可以互通的,但互通时数据所走的往返vlan是不同的。

    以下以intere0/1下的所接的pc1访问intere0/2下的所接的pc2为例进行说明

    pc1所发出的数据,由inter0/1所在的pvidvlan10封装vlan10的标记后送入交换机,交换机发现intere0/2允许vlan10的数据通过,于是数据被转发到intere0/2上,由于intere0/2上vlan10是untagged的,于是交换机此时去除数据包上vlan10的标记,以普通包的形式发给pc2,此时pc1->p2走的是vlan10

    再来分析pc2给pc1回包的过程,pc2所发出的数据,由inter0/2所在的pvidvlan20封装vlan20的标记后送入交换机,交换机发现intere0/1允许vlan20的数据通过,于是数据被转发到intere0/1上,由于intere0/1上vlan20是untagged的,于是交换机此时去除数据包上vlan20的标记,以普通包的形式发给pc1,此时pc2->pc1走的是vlan20
    转载于:https://blog.51cto.com/zerozerozero/802540

    展开全文
  • access端口、trunk端口和hybird端口

    万次阅读 2018-04-10 10:45:11
    Access端口、Trunk端口和Hybrid端口 Access类型:端口只能属于1个VLAN,一般用于连接计算机; Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接; Hybrid类型:端口可以...
    Access端口、Trunk端口和Hybrid端口

        Access类型:端口只能属于1VLAN,一般用于连接计算机; 

        Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接; 

        Hybrid类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签

    三种类型的端口可以共存在一台设备上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口

    Access端口只能属于1VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;Hybrid端口和Trunk端口可以属于多个VLAN,所以需要设置端口的缺省VLAN ID

     

     

    Acess端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)

    Acess端口发报文:

    将报文的VLAN信息剥离,直接发送出去

    trunk端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有判断该trunk端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃

    trunk端口发报文:

    比较端口的PVID和将要发送报文的VLAN信息,如果两者相等则剥离VLAN信息,再发送,如果不相等则直接发送

    hybrid端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则判断该hybrid端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用)

    hybrid端口发报文:

    1,判断该VLAN在本端口的属性(dispinterface即可看到该端口对哪些VLANuntag,哪些VLANtag)

    2,如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送

    例如

    [Switch-Ethernet0/1]inte0/1

    [Switch-Ethernet0/1]portlink-type hybrid

    [Switch-Ethernet0/1]port hybrid pvid vlan 10

    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged

    [Switch-Ethernet0/1]inte0/2

    [Switch-Ethernet0/2]portlink-type hybrid

    [Switch-Ethernet0/2]porthy bridpvid vlan 20

    [Switch-Ethernet0/2]porthy brid vlan 10 20 untagged

    此时intere0/1intere0/2下的所接的PC是可以互通的,但互通时数据所走的往返vlan是不同的。

    以下以intere0/1下的所接的pc1访问intere0/2下的所接的pc2为例进行说明

    pc1所发出的数据,由inter0/1所在的pvidvlan10封装vlan10的标记后送入交换机,交换机发现intere0/2允许vlan10的数据通过,于是数据被转发到intere0/2上,由于intere0/2vlan10untagged的,于是交换机此时去除数据包上vlan10的标记,以普通包的形式发给pc2,此时pc1->p2走的是vlan10

    再来分析pc2pc1回包的过程,pc2所发出的数据,由inter0/2所在的pvidvlan20封装vlan20的标记后送入交换机,交换机发现intere0/1允许vlan20的数据通过,于是数据被转发到intere0/1上,由于intere0/1vlan20untagged的,于是交换机此时去除数据包上vlan20的标记,以普通包的形式发给pc1,此时pc2->pc1走的是vlan20

    展开全文
  • 什么是trunk端口

    万次阅读 2019-09-18 16:24:22
    什么是iis7服务器监控工具Trunk端口 基本概念 Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口; 处理流程 trunk端口收报文: 收到一个报文,判断是否有VLAN信息...

    什么是iis7服务器监控工具Trunk端口 
    基本概念
    Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    处理流程
    trunk端口收报文:  收到一个报文,判断是否有VLAN信息,如果没有则打上端口的PVID,并进行交换转发;如果有判断该trunk端口是否允许该 VLAN的数据进入:如果允许则报文携带原有VLAN标记进行转发,否则丢弃该报文。
    trunk端口发报文:  比较端口的PVID和将要发送报文的VLAN信息,如果两者相等则剥离VLAN信息,再发送,否则报文将携带原有的VLAN标记进行转发。 
     
     
    总结
    1、Access 端口可接受并转发的数据来源:
       1)来自PC的无VLAN信息数据包;
       2)从一个Access口入打上VLAN标记在交换机内转交给相同VLAN的access口去掉标记的无VLAN信息数据包;
       3)Access 端口发送出去的数据包无VLAN信息,可被PC接受或Access口接受。
       示例:
     
    上图中,pc1不能ping通pc2,因为同一交换机内从pc1进入交换机A的access口的数据包被打上了VLAN10的标记,而和pc2相连的access的是VLAN20,从上面总结的2)条不满足,无法ping通。同理,pc1和pc3也不能ping通。
    上图中,pc2和pc3能互ping通。因为数据包从pc2进入交换机A的access口时,被打上了VLAN20的标记;交换机A与B想连的access口是VLAN20,所以数据包可以从该口发出。发出的时候去掉了VLAN20的标记,到B时,由于没有标记,可以被B的左边的access口接收并打上VLAN10的标记。由于B的右边的access口也属于VLAN10,所以数据包可以从该口出(出的时候去除掉VLAN10的标记,并到达pc3)
     
    2、Trunk 端口可接受并转发的数据来源:双绞线相连的一对Trunk口或同一交换机上的两个Trunk口可以将数据包(有或无VLAN信息)原封不动的从一端传到另一端。
     
    1)上图中pc1和pc3可以相通,因为数据包从pc1进入A的access口是打上了VLAN10的标记,A的右边trunk口可以接受数据包,并转发到B的trunk口(无论vid是否等于pvid)。而B的acces属于VLAN10所以pc3能收到数据包。
    2)同理,pc2和pc6相通

    1、 在网络的分层结构和宽带的合理分配方面,TRUNK被解释为“端口汇聚”,是带宽扩展和链路备份的一个重要途径。TRUNK(端口汇聚)功能是将交换机的多个物理端口汇聚在一起形成一个逻辑上的物理端口,同一汇聚组内的多条链路则可视为一条逻辑链路。端口汇聚可以实现用多条链路汇聚成一条逻辑链路增加带宽;同时,同一汇聚组的各个成员端口之间彼此动态备份,提高连接可靠性。TRUNK技术可以实现TRUNK内部多条链路互为备份的功能,即当一条链路出现故障时,不影响其他链路的工作,同时多链路之间还能实现流量均衡,就像我们熟悉的打印机池和MODEM池一样。

    2、在电信网络的语音级的线路中,Trunk指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它能够在两端之间进行转接,并提供必要的信令和终端设备

    3、 但是在最普遍的路由与交换领域,VLAN的端口聚合也有的叫TRUNK,不过大多数都叫TRUNKING ,如CISCO公司。所谓的TRUNKING是用来在不同的交换机之间进行连接,以保证在跨越多个交换机上建立的同一个VLAN的成员能够相互通讯。其中交换机之间互联用的端口就称为TRUNK端口。与一般的交换机的级联不同,TRUNKING是基于OSI第二层数据链路层RUNKING技术,如果你在2个交换机上分别划分了多个VLAN(VLAN也是基于Layer2的),那么分别在两个交换机上的VLAN10和VLAN20的各自的成员如果要互通,就需要在A交换机上设为VLAN10的端口中取一个和交换机B上设为VLAN10的某个端口作级联连接。VLAN20也是这样。那么如果交换机上划了10个VLAN就需要分别连10条线作级联,端口效率就太低了。 当交换机支持TRUNKING的时候,事情就简单了,只需要2个交换机之间有一条级联线,并将对应的端口设置为Trunk,这条线路就可以承载交换机上所有VLAN的信息。这样的话,就算交换机上设了上百个个VLAN也只用1个端口就解决了。

    如果是不同台的交换机上相同id的vlan要相互通信,那么可以通过共享的trunk端口就可以实现,如果是同一台上不同id的vlan/不同台不同id的vlan它们之间要相互通信,需要通过第三方的路由来实现;vlan的划分有两个需要注意的地方:一是划分了几个不同的vlan组,都有不同的vlan id号;分配到vlan 组里面的交换机端口也有port id.比如端口1,2,3,4划分到vlan10,5,6,7,8划分到vlan20,我可以把1,3,4的端口的port id设置为10,而把2端口的 port id设置为20;把5,6,7端口的port id设置为20,而把8端口的port id设置为10.这样的话,vlan10中的1,3,4端口能够和vlan20中8端口相互通信;而vlan10中的2端口能够和vlan20中的5,6,7端口相互通信;虽然vlan id不同,但是port id相同,就能通信,同样vlan id相同,port id不同的端口之间却不能相互访问,比如vlan10中的2端口就不能和1,3,4端口通信。

    转载于:https://my.oschina.net/u/4176053/blog/3085116

    展开全文
  • VLAN(TRUNK端口 & ACCESS 端口) VLAN(TRUNK端口 & ACCESS 端口) 对于电脑------首先所有主机发出的帧是不带tag的,同理,计算机在处理数据帧的时候也不会处理携带tag的帧对于交换机-------交换机所有...
  • 端口有三种模式:access,Hybrid,Trunk。access就不说了,trunk可以属于多个VLAN,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;hybrid也可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于...
  • 链路汇聚和端口汇聚,就是端口聚合,交换机的堆叠是堆叠和端口聚合无关。端口聚合概念:(包括二层端口聚合和三层端口聚合)1.端口聚合IEEE标准是将最多16条链路聚合成一个逻辑的链路。其中只有8条可以使用, 其余8条...
  • Esxi6.7网络trunk端口设置和vlan端口设置访问 1,Esxi网络trunk端口设置,即带tag的端口 1.1, 网络—虚拟交换机设置—添加标准虚拟交换机VlanAll,绑定vmnic3网卡,安全模式都接受,如下设置 1.2, 网络端口组...
  • Trunk端口收发 总结 1、Access 端口可接受并转发的数据来源: 2、Trunk 端口可接受并转发的数据来源 相关文章 基本概念 Access类型的端口 只能属于1个VLAN,一般用于连接计算机的端口; Trunk类型的端口 ...
  • 交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层(DataLinkLayer)的技术。 两台交换机上分别创建了多个VLAN(VLAN是基于Layer 2的),在两台交换机上相同的VLAN(比如VLAN10)要通信,需要...
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置为Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • 一 组网需求:1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访;2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20...
  • 华为S2700交换机原来的trunk端口设置如下:interface Ethernet0/0/24port link-type trunkport trunk allow-pass vlan 1 to 4094ntdp enablendp enable现在想把trunk端口改为access端口,于是使用undo命令,却一直...
  • S5700的Eth-Trunk端口汇聚及Trunk删除

    千次阅读 2018-10-24 15:58:32
    S5700的Eth-Trunk端口汇聚 链路汇聚和端口汇聚,就是端口聚合,交换机的堆叠是堆叠和端口聚合无关。 端口聚合概念:(包括二层端口聚合和三层端口聚合) 1.端口聚合IEEE标准是将最多16条链路聚合成一个逻辑的链路...
  • S5700的Eth-Trunk端口汇聚 链路汇聚和端口汇聚,就是端口聚合,交换机的堆叠是堆叠和端口聚合无关。 端口聚合概念:(包括二层端口聚合和三层端口聚合) 1.端口聚合IEEE标准是将最多16条链路聚合成一个逻辑的链路...
  • trunk端口配置的PVID

    万次阅读 2012-09-05 00:39:21
    学习到vlan的时候,配置trunk端口的时候,可以配置该端口的PVID,默认情况下是vlan1. 当两个trunk端口互联的时候,当配置的PVID不同的时候,两个端口之间不能通信,且会不停地提示Nativevlan不同的消息.两端配置的PVID的...
  • ibm北电与华为组trunk端口汇聚,不同于北电与h3c的lacp
  • 当mode trunk出现如下提示时,要先封装协议再设置trunk端口。 第一步:switchport trunk encap dot1q \封装协议 第二步:switch mode trunk \设置trunk端口 如下
  • Access端口和Trunk端口

    千次阅读 2019-09-10 21:06:12
    交换机的端口类型 802.1Q帧是由交换机来处理的,而不是由用户主机来处理的。 当交换机收到普通的以太网帧时,会将其插入4字节的VLAN标识,进而改变为802.1Q帧,简称为"打标签"。 当交换机转发802.1Q...
  • 查看trunk端口

    2019-09-26 17:40:36
    [H3C1]display interface e0/4/3 部分显示省略 ...Port link-type: trunk VLAN passing : 1(default vlan) //默认只有vlan1通过 VLAN permitted: 1(default vlan) //默认只允许vlan1通过 Trunk ...
  • , 例如,此端口Trunk 的根端口时, 将此端口在生成树中 disable ,并且在剩余 Trunk 端口中重新选择一个端口作为根端口,保证系统正常运行。但是在用户看来系统并没有变化。 3、能在 Trunk 组中的端口实现负载...
  • 华为S2700交换机原来的trunk端口设置如下: interface Ethernet0/0/24 port link-type trunk port trunk allow-pass vlan 1 to 4094 ntdp enable ndp enable 现在想把trunk端口改为access端口,于是使用undo...
  • 下面的内容摘自一年多来一直热销不断的《Cisco/H3C交换机配置与管理完全手册》图书。 许多朋友对Cisco交换机中的Access和Trunk二层端口的报文...下面先介绍笔者自己总结的Access和Trunk端口报文收\发规则,然后再...
  • 提示:结合access和trunk端口在接收数据、发送数据时对标签的处理。 1、 终端1向终端2发送数据时,在每一段链路及端口上,数据帧携带标签情况。 终端1发出一个没有VLAN ID 的数据帧,到达交换机1的e0/0/1Access端口...
  • Trunk端口的配置

    千次阅读 2019-03-27 09:37:51
    以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机与交换机之间、交换机与路由器之间)承载多个不同VLAN...
  • trunk 端口汇聚

    2013-04-20 21:46:56
    在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,...TRUNK把多个物理端口捆绑在一起当作一个逻辑端口使用,可以把多组端口的宽带叠加起来使用。TRUNK技术可以实现TRUNK内部多条链...
  • 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20的IP地址为...
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有...当我们在port link-type 后面打问号的时候,会出现下图的样子这是华为端口的工作模式,有四种,今天我们来讲解其中的三种:access ,trunk,hybridAc...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,415
精华内容 966
关键字:

trunk端口