精华内容
下载资源
问答
  • 2021-08-07 09:45:21

    目录

     一、VLAN介绍

    二、VLAN实现原理 

    三、VLAN好处

    四、VLAN划分/管理方式

    五、静态VLAN 创建步骤

    六、总结




     一、VLAN介绍

       VLAN(虚拟局域网)是对连接到的第二层交换机端口的网络用户的逻辑分段,不受网络用户的物理位置限制而根据用户需求进行网络分段。一个VLAN可以在一个交换机或者跨交换机实现。VLAN可以根据网络用户的位置、作用、部门或者根据网络用户所使用的应用程序和协议来进行分组。基于交换机的虚拟局域网能够为局域网解决冲突域、广播域、带宽问题。

    冲突:两个节点同时发送数据

    冲突域:产生冲突的范围

    集线器/交换机冲突域:集线器所有接口都处在一个冲突域,交换机一个接口一个冲突域。

    本网段广播:发送的消息会传达给这个网段的所有成员

    广播域:广播扩散的范围

    交换机/路由器的广播域:交换机的所有接口都处在同一个广播域中,路由器一个接口一个广播域

    二、VLAN实现原理 


    一个VLAN=一个广播域=逻辑网段(子网)

    三、VLAN好处

     
    1)隔离了广播域

    2)更安全

    3)更易于管理

    四、VLAN划分/管理方式

     
    1.静态vlan:基于端口划分VLAN

    静态VLAN也称基于端口的VLAN,是目前最常见的VLAN实现方式。
    静态VLAN即明确指定交换机的端口属于哪个VLAN,这需要网络管理员手动配置,当主机连接到交换机的接口上时,就被分到对应的VLAN中。

    PS:华为的vlan数量是4096;其中vlan0和vlan4095系统保留不可见不可使用;vlan1,系统默认vlan,用户可以使用这个vlan,但不可以删除,vlan2~vlan4094用户可以创建,使用,删除

    2.动态vlan:基于MAC地址划分(需要额外买服务器) 

    五、静态VLAN 创建步骤

     
    1.交换机上创建vlan

    1)创建一个vlan

                        [ ]vlan X,例如:[ ]vlan 2

    2)创建多个vlan

      2-1)创建多个不连续vlan

              例如:一次性创建vlan3 vlan9 vlan20

                      [ ] vlan batch 3 9 20

      2-2) 创建多个连续vlan 

               例如:一次性创建vlan5 vlan6 vlan7

                     [ ] vlan 5 to 7

    3)验证vlan是否创建成功

                     [ ]display vlan

    2.接口划分进对应的vlan

    1)进入接口,例如:

    [ ]interface  e0/0/1

    2)设置接口的链路类型,例如:

    [ ] port link-type access

    3)将该接口划分进对应的vlan

     [接口]  port   default  vlan   3

    PS:access:用于交换机和主机相连或者主机和路由器相连时需要的类型,access接口只能属于一个vlan
          Trunk:用于交换机和交换机相连的类型(连接两端需要相同配置),trunk不属于任何vlan,它是一条公有链路,用来在单条链路上承载不同的vlan流量让其通过

    其他命令 :

    1)清空接口所有配置:[ ]clear configuration interface 对应的接口

    2)清空接口所有配置后需要重启接口:undo shutdown

    3)查看当前接口下的配置:display this

    六、总结

            主要是明白VLAN划分的原理,为何要划分VLAN,知道划分VLAN的优点,熟记华为命令及含义。

    更多相关内容
  • 计算机网络思科交换机的vlan划分的配置,适合小白
  • 1. 基于端口的VLAN 基于端口的VLAN的划分是最简单、最有效的VLAN划分方法。该方法只需网络管理员针对于网络设备的交换端口进行重新分配组合在不同的逻辑网段中即可。而不用考虑该端口所连接的设备是什么。 2. 基于...
  • vlan划分

    2021-12-09 10:22:56
    计算机网络,vlan划分

    基于接口划分 VLAN

    在网络中,用于终端与交换机、交换机与交换机、交换机与路由器,这里就接入层交换机(二层交换机)的 VLAN 划分举例说明。

    1、access口配置
    在这里插入图片描述

    [SW1]vlan 10 
    [SW1-vlan10]quit 
    [SW1]vlan 20 
    [SW1-vlan20]quit //创建 vlan10、vlan20(快速创建多个 vlan 使用 vlan batch 10 20 命令) 
    [SW1]display vlan summary //查看设备的 vlan 信息 
    [SW1]int Ethernet0/0/1
    [SW1-Ethernet0/0/1]port link-type access 
    [SW1-Ethernet0/0/1]port default vlan 10 //将接口 e0/0/1 划入对应的 vlan10
    [SW1-Ethernet0/0/1]quit 
    [SW1]int e0/0/2 
    [SW1-Ethernet0/0/2]port default vlan 20 //将接口 e0/0/2 划入对应的 vlan20 
    [SW1-Ethernet0/0/2]quit 
    [SW1]int Ethernet0/0/3 
    [SW1-Ethernet0/0/3]port link-type trunk 
    [SW1-Ethernet0/0/3]port trunk allow-pass vlan 30 //将接口 e0/0/3 划入对应的 vlan30 
    [SW1-Ethernet0/0/3]quit 
    [SW1]display port vlan active //查看接口对应的 vlan 信息 
    [SW1]quit
    
    批量划分vlan
    vlan  batch  10 to  20
    将接口批量划入某vlan : 
    port-group group-member  g/0/0/3   to   g/0/0/20
    查看vlan :dis  port  vlan       dis vlan
    

    默认情况下,不同vlan的用户单播默认不能直接通信,广播报文永远不能通信,如果想通信,还需三层设备做路由。

    2、配置trunk
    在这里插入图片描述
    默认情况下,交换机的一个接口只能从属于一个vlan,只允许该vlan的数据通过
    trunk干道:主干道链路,通常用于交换机之间,通过一个接口传输多个vlan数据包

    配置:
    1、首次将相应的接口划入到vlan 10和vlan 20当中

    trunk配置方式
    int g/0/0/4
    port link-type trunk
    port trunk allow-pass vlan all    这里的all可以设为运行哪些vlan通过
    
    int g/0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    

    3、hybird接口配置
    hybird混合接口:hybird接口是一种混合接口,是华为设备特有的接口,华为设备交换设备默认接口的封装类型,hybird接口同时具备access和trunk接口的两种功能。
    查看接口类型:dis port vlan
    需要管理员手动指定调试命令:dis port vlan actice
    在这里插入图片描述
    hybird通信前提:接口类型相同

    将hybrid口当成access口使用:

    sw1
    int g/0/0/1
    	 port hybird  pvid  vlan 10
    	 port hybird untagged vlan 10
    
    int g/0/0/2
    	port hybird  pvid  vlan 20
    	port hybird untagged vlan 20
    

    将hybird口当trunk使用
    int g/0/0/3
    port hybird tagged vlan 10 20

    hybird高级用法
    在这里插入图片描述
    在这里插入图片描述
    hybird:可以给连接终端的设备设置多个vlan,当给终端接口设置成access口时只能通信一个valn。

    4、PVID
    PVID(port vlan id)是端口特有的属性,看来的数据包有无标签,给没有打标签的包打上标签tag,通过会将该报文进过trunk接口时做标记(tag),默认情况下本证vlan是vlan1

    dis port vlan
    int g0/0/1
    port link-type trunk
    port trunk pvid vlan 20  将trunk接口的本证vlan改为20
    

    5、vlan基本通信原理
    vlan 中的消息通过看两个值PVID和标签列表,当消息打上标签时且在vlanid标签列表,就直接查看vlanid标签列表转发到相应的接口,当标签上没有标签时,PVID为其打上标签,然后在查看标签列表是否进行转发。

    access口:无法更改pvid,发送出数据包时去掉标签,一般接pc(pc不认识vlan标记,不标记tag)。
    trunk口:可以更改pvid,PVID和标记相同去掉tag发送,PVID不同保持原有tag。
    hybird口:可以自由设置pvid和是否有标签通过。

    6、Access端口收发数据帧的规则如下:
    收报文:
    如果该端口收到对端设备发送的帧是untagged(不带 VLAN标签),交换机将强制加上该端口的PVID(PVID即 Port VLAN ID,代表端口的缺省VLAN)。如果该端口收到对端设备发送的帧是tagged(带VLAN标签),交换机会检查该标签内的VLAN ID。当VLAN ID与该端口的PVID相同时,接收该报文。当VLAN ID与该端口的PVID不同时,丢弃该报文。

    发报文:Access端口发送数据帧时,总是先剥离帧的Tag,然后再发送。Access端口发往对端设备的以太网帧永远是不带标签的帧

    将交换机的接口属性更改是:例如access-》trunk或者trunk-》access必须重置接口的默认值
    clear configuration int g0/0/0 进入g/0/0/0口将原来的链路状态删除。

    展开全文
  • VLAN划分

    千次阅读 2020-06-14 15:08:21
    Vlan划分步骤及命令详解 步骤一:了解基础命令 交换机的基本配置模式: 用户模式:switch> 特权模式:Switch# 进入方法:在默认的用户模式下输入:enable 进入。 退出方法:输:exit 退回到用户模式。 注意用户...

    Vlan划分步骤及命令详解

    步骤一:了解基础命令

    交换机的基本配置模式:

    用户模式:switch>

    特权模式:Switch#

    进入方法:在默认的用户模式下输入:enable 进入。

    退出方法:输:exit 退回到用户模式。

    注意用户模式和特权模式的前面代码的区别:一个是switch>;一个是Switch#。

    VLAN模式:Switch(vlan)#

    进入方法:从#模式输入 vlan database 进入

    全局配置模式:

    Switch(config)#

    进入方法:从#模式输入 config terminal 进入,也可以使用简写conf t 进入

    接口配置模式:

    Switch(config-if)#

    进入方法:从(config)#模式输入 interface+接口号进入 //同时分配多个接口要加一个range

    要记住这些交换机的配置模式,要知道如何进入和退出,也有能看懂当前处于哪个模式下,在所有模式中,输入exit返回上级,输入end或ctrl+z退出。

    VLAN的常用配置命令:

    交换机没有被划分VLAN的时候,交换机默认只有VLAN1,所有的端口都在VLAN1里面,所以我们是不能创建也不能删除VLAN1的。

    创建VLAN

    Switch#vlan database (进入VLAN数据库)

    Switch(vlan)# vlan 1 name vlan10

    switch(vlan)# vlan 2 name vlan20

    第一条命令:进入VLAN数据库

    第二条命令:创建一个名称为VLAN10 的 VLAN 1
    第三条命令:创建一个名称为VLAN20 的 VLAN 2

    这里Name属性最好定义一下,如果不定义会和默认VLAN名称冲突,这样一一对应比较好。

    端口划入VLAN

    Switch(config)#interface fa0/1

    Switch(config-if)#switchport access vlan 10

    第一条命令的意思是:进入接口fa0/1,这里的0表示第1个插槽,1表示第2个端口。(设备第一个端口通常为0,第二个端口通常为1)。

    第二条命令:把fa0/1这个端口划分给VLAN 10 这样配置之后,接在这个端口的所有设备就属于VLAN 10 了。

    查看VLAN信息

    Switch#show vlan 查看所有VLAN信息

    Switch#show vlan id 10 查看vlan 10的信息

    删除VLAN

    switch#vlan database

    Switch(vlan)#no vlan 10

    删除VLAN 10后,所有分配给VLAN10的端口都变回非活动状态,直到下次再次分配给别的VALN为止。

    一个VLAN可以有多个端口,如果要将某个端口从VLAN中删除

    Switch(config)# interface f0/2

    Switch(config-if)#no switchport access vlan 10

    开始步骤

    一个简单的VLAN划分,将终端0-2和9-11划分为 vanl 1 ,其余的划分为vlan 2
    一个简单的VLAN划分,将终端0-2和9-11划分为 vanl 1 ,其余的划分为vlan 2
    首先我们需要进行创建VLAN,我们需要创建一个vlan 1 和一个vlan 2 ,并且命名
    Switch>en
    Switch>enable
    Switch#vlan d
    Switch#vlan database
    Switch(vlan)#
    Switch(vlan)#vl
    Switch(vlan)#vlan 1 name vlan1
    A default VLAN may not have its name changed.
    Switch(vlan)#vl
    Switch(vlan)#vlan 2 name vlan2
    VLAN 2 added:
    Name: vlan2
    Switch(vlan)#exit

    创建好vlan后我们需要将计算机终端分配给各自的vlan
    在这里插入图片描述
    Switch#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#in
    Switch(config)#interface r
    Switch(config)#interface range f0/2-4
    Switch(config-if-range)#sw
    Switch(config-if-range)#switchport a
    Switch(config-if-range)#switchport access v
    Switch(config-if-range)#switchport access vlan 2
    Switch(config-if-range)#exit
    Switch(config)#int
    Switch(config)#interface r
    Switch(config)#interface range f0/5-7
    Switch(config-if-range)#sw
    Switch(config-if-range)#switchport a
    Switch(config-if-range)#switchport access v
    Switch(config-if-range)#switchport access vlan 1
    Switch(config-if-range)#exit
    Switch(config)#

    如此便将6太计算机分配成功
    但是我们还需要将f0/1划分为串口,让它可以让不同的vlan通过

    Switch(config)#interface f0/1
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#switchport trunk allowed v
    Switch(config-if)#switchport trunk allowed vlan
    如此配置好一个交换机了
    我们同理配置另外一台交换机就完成vlan的划分了

    展开全文
  • 局域网VLAN划分.docx

    2022-07-04 13:27:40
    局域网VLAN划分 实验目的: 1:了解Vlan的概念及作用 2:了解交换机的Vlan接口类型 3:了解Vlan标签协议802.1Q 4:了解Vlan的实际应用 实验原理: 一 : VLAN概述 VLAN(Virtual Local Area Network)即虚拟局域网,...
  • 为解决以太网的广播问题和安全性问题,可采用基于端口的虚拟局域网VLAN划分技术。笔者阐述了VLAN划分的意义,介绍了利用交换机进行基于端口的VLAN划分时交换机配置及PC配置的详细操作。VLAN划分后利用ping命令验证其...
  • 三、vlan划分拓扑图 ​总结 冲突、广播、冲突域、广播域 冲突:两个节点同时发送数据的情况 冲突域:产生冲突的范围 集线器/交换机的冲突域:集线器所有接口都处于一个冲突域中,交换机一个接口一个冲突域 ...

    目录

    一、冲突、广播、冲突域、广播域

    二、VLAN实现的原理与好处

    三、VLAN管理的方式

    四、VLAN的数量

    五、静态VLAN的创建步骤

    1、交换机上创建vlan

    2、接口划分进对应的vlan

    3、vlan划分拓扑图

    六、同一台交换机相同vlan的通信

    1、拓扑图​

    2、项目要求

    3、项目实施

    七、跨交换机相同vlan之间的通信

    1、vlan运作

    2、拓扑图

    3、配置代码  

    4、vlan跨交换机的传输过程

    八、 单臂路由

    1、vlan间通信使用的技术

    2、拓扑图

    3、配置命令

    4、检查通信

    九、三层交换

    2、三层交换机和路由器的区别

    3、三层交换机拓扑图

    4、配置代码

    总结 


    一、冲突、广播、冲突域、广播域

    冲突:两个节点同时发送数据的情况

    冲突域:产生冲突的范围

    集线器/交换机的冲突域:集线器所有接口都处于一个冲突域中,交换机一个接口一个冲突域

    本网段广播:发送的消息会传达给这个网段的全体成员

    广播域:广播扩散的范围

    交换机/路由器的广播域:交换机的所有接口处于一个广播域中,路由器一个接口一个广播域

    二、VLAN实现的原理与好处

    一个VLAN=一个广播域=逻辑网段(子网)

    好处:分段,隔离了广播域

               灵活性,更易于管理

               安全性

    三、VLAN管理的方式

    静态VLAN——(简单,经济

            基于端口划分静态VLAN

    动态VLAN——(复杂,成本高

            基于MAC地址划分动态VLAN

    四、VLAN的数量

    VLAN的数量

    VLAN的数量一共是4096个(0——4095)

    其中VLAN 0,VLAN 4095,系统保留,不可见也不可用

    VLAN 1 系统默认VLAN,用户可以使用这个VLAN,但是不能删除

    VLAN 2——4094 用户可以创建、使用、删除

    五、静态VLAN的创建步骤

    1、交换机上创建vlan

    1)创建一个vlan

                    [        ]vlan 2

    2)创建多个vlan

            2-1)创建多个不连续的vlan

                    例:一次性创建vlan 3,vlan 6,vlan 9

                    [        ]vlan bat 3 6 9

            2-2)创建多个连续的vlan

                    例:一次性创建vlan 10,11,12,13,14,15

                    [        ]vlan bat 10 to 15

    3)验证vlan是否创建成功

                    [        ]display vlan

    2、接口划分进对应的vlan

    1)进入接口

                    [        ]interface e0/0/1

    2)设置该接口的链路类型

                    [接口]port link-type access

    3)将该接口划分进对应的vlan

                    [接口]port default vlan 3

    补充:交换机根据连接对象的不同,会有不同的链路类型

    交换机连接的对象是电脑——那么接口链路类型为access(接入)

    注:access这种类型的接口只能属于一个vlan

    交换机连接对象是交换机——那么接口链路类型为trunk(主干)

    注:trunk不属于任何vlan,它是一条公有链路,用来在单条链路上承载不同的vlan流量,让其通过

    代码补充:用于操作失误后的弥补

                    [        ]interface e0/0/*        /*进入接口*/                                

                    [接口0/0/*]clear configuration interface e0/0/*        /*清空这个接口所有配置*/

    注:这段代码输入后,这个接口会默认处于关闭状态,需要重新开启

                    [接口0/0/*]undo shutdown        /*开启当前接口*/             

    3、vlan划分拓扑图

    六、同一台交换机相同vlan的通信

    1、拓扑图

    2、项目要求

    1)在交换机上创建vlan 10,20

    2)将pc1和pc3划入vlan 10,pc2和pc4划入vlan 20,使同一vlan的机器可以相互通信

    3、项目实施

    1)先对交换机做基础设置

    <Huawei>undo terminal monitor

    [Huawei]sys    

    [Huawei]sysname sw1

     [sw1]user-interface console 0

    [sw1-ui-console0]idle-timeout 0 0

    [sw1-ui-console0]q

    2)开始划分vlan

    [sw1]vlan bat 10 20

    [sw1]interface e0/0/1  

    [sw1-Ethernet0/0/1]port link-type access 

    [sw1-Ethernet0/0/1]port default vlan 10

    [sw1]int Eth0/0/3  

    [sw1-Ethernet0/0/3]port link-type access 

    [sw1-Ethernet0/0/3]port default vlan 10

    [sw1-Ethernet0/0/3]int e0/0/2

    [sw1-Ethernet0/0/2]port link-type access  

    [sw1-Ethernet0/0/2]port default vlan 20

    [sw1-Ethernet0/0/2]int e0/0/4  

    [sw1-Ethernet0/0/4]port link-type access  

    [sw1-Ethernet0/0/4]port default vlan 20

    [sw1-Ethernet0/0/4]q

    3)检查通信

    输入[        ]display vlan查看vlan配置

     在pc1上尝试ping其他计算机(要能和pc3 ping通,其它则不通)

     至此,该项目完成

    七、跨交换机相同vlan之间的通信

    1、vlan运作

    每个逻辑的vlan就像一个独立的物理桥

    同一个vlan可以跨越多个交换机

    主干功能支持多个vlan的数据

    主干使用了特殊的封装格式支持不同的vlan

    只有快速以太网端口可以配置为主干端口

    2、拓扑图

    3、配置代码  

    1)基础配置

    <Huawei>undo terminal m
    <Huawei>system-view 
    [Huawei]sys sw1 
    [sw1]user-interface console 0
    [sw1-ui-console0]idle-timeout 0 0
    [sw1-ui-console0]q    

    2)正文配置

    [sw1]vlan bat 10 20 30
    [sw1]in    
    [sw1]int e0/0/1  
    [sw1-Ethernet0/0/1]port link-type access 
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]int e0/0/2  
    [sw1-Ethernet0/0/2]port link-type ac
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]int e0/0/3  
    [sw1-Ethernet0/0/3]port link-type access 
    [sw1-Ethernet0/0/3]port default vlan 30
    [sw1-Ethernet0/0/3]q
    [sw1]int g0/0/1 
    [sw1-GigabitEthernet0/0/1]port link-type trunk  
    [sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20 30

    注:在sw2交换机上做相同配置

    3)检查通信

    要求:各个vlan之间的pc机可以相互通信

     

     

    检查完毕,各个vlan之间通信正常

    4、vlan跨交换机的传输过程

    PC机经过发送方交换机某个接口发送数据,此时交换机会对应vlan信息表,给经过某接口的数据打上对应的标签,打上对应标签的数据经由trunk (主干)链路验证这个vlanid是不是在trunk链路的白名单范围内,若是在白名单范围内,无条件放行,若不在白名单范围内,则该流量不予通过,当打了标签的数据到达接收方交换机后,接收方交换机会解开这个数据对应的vlan标签,对照本地mac地址和vlan信息表,将此数据发送到该vlan对应的端口上。

    八、 单臂路由

    1、vlan间通信使用的技术

    相同vlan间通信:

    情况一:

    同一台交换机相同vlan间通信,查看本地mac地址表,将打了相同pvid标签的数据包转发到对应的端口上去

    情况二:

    跨交换机,通过trunk技术实现多vlan数据通信,可以帮助我们实现相同vlan间通信。

    不同vlan间通信(不同网段):

    单臂路由

    组成:一台二层交换机和一台路由器

    三层交换

    组成:三层交换机

    vlan封装的方式:802.1q

    2、拓扑图

    3、配置命令

    sw1)
    <Huawei>undo terminal m
    Info: Current terminal monitor is off.
    <Huawei>sys    
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z. 
    [Huawei]sysname sw1   
    [sw1]user-interface console 0
    [sw1-ui-console0]idle-timeout 0 0
    [sw1-ui-console0]q 

    [sw1]vlan bat 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done. 
    [sw1]int e0/0/1  
    [sw1-Ethernet0/0/1]port link-type access 
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access 
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]q
    [sw1]int g0/0/1  
    [sw1-GigabitEthernet0/0/1]port link-type trunk   
    [sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20

    r1)
    <Huawei>undo terminal monitor 
    Info: Current terminal monitor is off.
    <Huawei>sys 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys r1 
    [r1]user-interface console 0 
    [r1-ui-console0]idle-timeout 0 0
    [r1-ui-console0]q

    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]undo shut
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [r1-GigabitEthernet0/0/0]int g0/0/0.1  
    [r1-GigabitEthernet0/0/0.1]vlan-type dot1q 10 default 
    [r1-GigabitEthernet0/0/0.1]ip add 192.168.10.1 24
    [r1-GigabitEthernet0/0/0.1]int g0/0/0.2   
    [r1-GigabitEthernet0/0/0.2]vlan-type dot1q 20 default 
    [r1-GigabitEthernet0/0/0.2]ip add 192.168.20.1 24

    4、检查通信

    要求:使两台pc相互ping通

     关于单臂路由配置完成

    九、三层交换

    三层交换机

    三层交换机要执行三层信息的硬件交换路由处理器(三层引擎)必须将有关路由选择的三层信息下载到硬件中。以便对数据包进行过处理。为完成在硬件中处理数据位的高层信总,会使用传统的MLS和基于CEF的MLS.

    传统的MLS

    使用传统的MLS时,交换机将流中第一个数据包转发给第三层引擎,后者以软件交换的方式对数据包进行过处理,对数据流中的第一个包进行路由处理后,第三层引擎对硬件交换组织进行编程,使之为后续的数据包选择路由。这个过程被称为“一次路由多次交换”,也就是说交换机的三层引擎只需要处理数据流中的第一个数据包,而后续的数据全部由硬件来执行转发。这样实现了三层交换的线速转发。

    基于CEF的MLS

    写传统MLS不同的是,CEF预先根据路由表学习路由信息后,直接储存在FIB(转发信息库)REF预先根据ARP表生成邻接表,直接由硬件进行转发。传统MLS至少需要软件查询一次路由表后,建立转发条目、才能使用硬件进行转发。

    工作原理:

    ①主机A给B发送单播数据包

    ②交换机查找FIB表,找到下一跳地址

    ③查找下一跳地址对应的邻接关系的2层封装信息

    ④转发

    三层交换技术

    使用三层交换机实现vlan间通信

    三层交换=二层交换+三层转发

    2、三层交换机和路由器的区别

    功能不同

    路由器的真正用途是计算路由

    交换机的主要功能是数据交换

    面对环境不同

    路由器功能更多的体现在不同类型网络之间的互联上

    三层交换机面对的主要是简单的局域网连接

    性能不一样

    路由器基于cpu

    三层交换机通过硬件

    3、三层交换机拓扑图

    4、配置代码

    三层交换机:

    <        >sys

    [        ]sysname L3-SW1

    [        ]vlan bat 10 20                //创建vlan 10 20

    [        ]int g0/0/1                //进入接口g0/0/1

    [        ]port link-type access                //接口链路类型为access

    [        ]port default vlan 10                //将g0/0/1划分进vlan10

    [        ]int vlan 10                //进入vlanif 10

    [        ]ip address 192.168.10.1 24                //设置ip地址和子网掩码长度

    [        ]int g0/0/2                //进入接口g0/0/2

    [        ]port link-type access                //接口链路类型为access

    [        ]port default vlan 20                 //将g0/0/2划分进vlan20

    [        ]int vlan 20                 //进入vlanif 20

    [        ]ip address 192.168.20.1 24                //设置ip地址和子网掩码长度

    pc配置

    pc1 ip 设置为192.168.10.10 255.255.255.0 网关指向 192.168.10.1

    pc2 ip 设置为192.168.20.10 255.255.255.0 网关指向 192.168.20.1

      最终效果是使两个不同vlan的计算机互相ping通

    总结 

    本次项目主要是针对vlan的划分,需要熟悉vlan划分的原理以及好处,学习vlan管理的方式,了解vlan的数量,能熟练进行划分vlan的操作(包括同一交换机相同vlan之间的通信、跨交换机相同vlan之间的通信、单臂路由、三层交换机。

    展开全文
  • 计算机网路vlan划分练习

    千次阅读 2021-12-10 19:36:07
    ①lsw1和lsw2存在两个vlan(vlan2和vlan3),而lsw3也存在两个独立的vlan(vlan2和vlan3),所以要对交换机进行vlan划分 ②交换机和交换机之间要能进行数通,并且可以全网可达,所以要配置干道 ③需要配置dhcp池和...
  • 首先,分析了设计的IaaS资源池结构,对VLAN划分进行分析,提出VLAN的结构、划分方式、VLAN的配置策略,并且设计IP池管理的方案。最后,对VLAN划分与IP池管理进行测试。通过测试结果表示满足实际需求,能够使资源池...
  • ensp vlan 划分

    千次阅读 2021-11-21 20:48:27
    ensp vlan 划分 1、VLAN概念 VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理局域网在逻辑上划分成多个广播域的技术,配置VLAN,在交换机上可以实现在同一个VLAN内的用户可以进行二层相互访问,而不同...
  • ensp VLAN划分

    2022-04-15 20:11:46
    在SW1上划分vlan <Huawei>system-view [Huawei]sysname SW1 [SW1]vlan batch 10 20 [SW1]interface Ethernet0/0/1 [SW1-Ethernet0/0/1]port link-type access 将接口设为access接口...
  • VLAN是一种将局域网设备从逻辑上划分(不是从物理上划分)成一个个网段,从而实现虚拟工作组的新兴数据交换技术。这一新兴技术主要应用于交换机和路由器中,但主流应用还是在交换机之中。但又不是所有交换机都具有此...
  • VLAN划分实验

    2021-04-03 20:05:32
    传统VLAN划分实验 目录传统VLAN划分实验实验环境实验思路具体步骤使用Hybrid配置网络实验环境解决问题具体实现结果测试 实验环境 实验思路 1.配置主机IP 2.划分VLAN并绑定端口 3.在SW1和SW2之间放行VLAN 4.测试是否...
  • VLAN划分和子网划分的区别和联系

    千次阅读 2022-04-20 17:42:39
    初学计算机网络的同学们,可能会跟我有一样的疑问,咱们在学习数据链路层的时候已经学习了VLAN划分VLAN已经能够分隔广播域,在第二层上实现虚拟局域网的划分。到了网络层的学习,我们又学习到了子网的划分,子网...
  • vlan划分实验.pkt

    2021-07-29 17:47:24
    使用仿真器PACKET TRACER,在六节点星型网络、树型网络、总线型网络里构造Vlan并测试。(下面例子以六节点星型网络为例,全部的仿真链接在文章末尾总结处) 其中仿真要求:(主机ip地址的命名规则:192.168.学号后两...
  • VLAN划分实例

    2021-05-27 08:55:11
    目录 配置程序如下: 1.配置LSW3 2.配置LSW2 3.配置SW1 ...题目,使得PC1能ping通...vlan batch 10 20 int e0/0/2 port link-type access port default vlan 10 undo shutdown ine e0/0/3 port link-type a..
  • vlan划分实验报告.doc

    千次阅读 2021-01-17 14:47:58
    vlan划分实验报告计算机网络实验报告实验名称: VLAN划分实验分组号:实 验 人:班 级:学 号:实验指导教师:实验场地:实验时间:成 绩:一、实验目的1、掌握VLAN原理2、熟练掌握二层交换机VLAN的划分方法二、实验...
  • 这篇文章简单的介绍了计算机网络实验:VLAN 划分VLAN 间通信。
  • 本文将详细介绍思科2950交换机VLAN划分,需要的朋友可以参考下
  • 华为hcie示例,已通过。 使用ensp打开即可。 有修改均已在示例中注明。
  • VLAN划分(华为)

    千次阅读 2022-04-10 22:16:30
    应领导要求要对vlan进行划分,咋个办,学撒。 简易top图 在没有进行配置的情况下所有的交换机接口都在vlan1内,所以在这个都可以ping通 那么现在要做的就是 PC1 ping PC4 OK PC1 ping PC2 NO PC2 ping...
  • 基础VLAN划分(思科)

    2022-04-15 19:06:30
    将他们划分为2个vlan 从左边交换机开始 基本命令 Switch>enable 特权模式 Switch#confi 全局配置模式 Switch(config)#vl 10 创建vlan10 Switch(config)#vl 20创建vlan20 Switch(config-vlan)#int f0/1 进入...
  • vlan划分命令

    千次阅读 2020-12-21 23:02:50
    vlan划分命令:CiscoCatalyst1900交换机的VLAN配置【网讯网络通信学院】第1步:设置好超级终端,连接上1900交换机,通过超级终端配置交换机的VLAN,连接成功后出现如下所示的主配置界面(交换机在此之前已完成了基本...
  • eNSP实验二:VLAN划分与配置

    千次阅读 2022-05-06 18:44:50
    VLAN的创建;Access、Trunk和Hybrid类型接口的配置;基于接口划分VLAN的配置方法;基于MAC地址划分VLAN的配置方法;MAC地址表及VLAN信息的查看方式
  • VLAN划分介绍.ppt

    2021-05-24 17:39:34
    VLAN划分

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 28,092
精华内容 11,236
关键字:

vlan划分