精华内容
下载资源
问答
  • 基于思科2960交换机的二层设备配置范例及基本概念介绍
  • 思科2960交换机telnet连接配置

    千次阅读 2020-07-24 19:17:02
    本次实验是基于思科2960交换机进行配置,实验设备:笔记本、思科2960交换机、console线一条、网线一条。 本次实验的连接软件为XSHELL。 一、交换机重置 如果交换机已经经过配置,可以通过如下方式进行重置: ...

    本次实验是基于思科2960交换机进行配置,实验设备:笔记本、思科2960交换机、console线一条、网线一条。

    本次实验的连接软件为XSHELL。

    一、交换机重置

    如果交换机已经经过配置,可以通过如下方式进行重置:

    长按CISCO 2960交换机MODE键10秒,直到STAT DUPLX SPEED 三个LED灯常亮,然后三个灯同时闪烁再到常亮,放开MODE键,此时,交换机已重置完成。

    二、交换机配置

    1.xshell登录

    我们将console线一端接交换机 console口(注意:不是网口),一端USB接笔记本。console线连接好后,我们进入设备管理器,可以看到端口已经有USB接入,对应端口是COM4口。

    此时,我们就可以启动xshell,协议选择“SERIAL”,接下来选择左边串口,端口选择COM4,波特率选择9600,确认后,即可连接。连接后,界面如下:

     

    此时,已经用xshell完成console口登录,可以进行配置了。

    2.交换机配置

    进入交换机后,思科交换机有以下几种模式,需要注意:

    登录后,默认是用户模式。

    通过命令”enable”可以进入特权模式:

    通过命令”configure terminal”可以进入全局模式:

    各个模式的命令及权限有所区别,输入命令时,需要注意所处在的模式。

    此时,我们就可以开始配置了:

    2.1配置ip地址

    先进入全局模式:

    输入下图命令:

    进入vlan 1中;接着输入如图命令,添加IP地址和子网掩码:

    通过no shutdown命令,开启端口:

    2.2设置特权模式密码

    通过以下命令,设置进入特权模式的密码,如果不设置特权模式密码,telnet命令连接后,无法进行操作。

    2.3设置登录人数

    通过以下命令设置允许登录的人数,0-5为编号,此时设置可供6人登录。

    2.4设置登录模式

    一共有三种登录模式:

    login:账号密码登录

    login local:本地登录

    no login local:无密码登录

    此时,我们设置为本地登录:

    2.5登录用户及密码设置

    设置好登录模式和登录人数后,我们退出到全局模式进行登录用户、权限及密码配置,如下图:

     

    配置完成后,我们就可以通过网线,运用telnet命令进行登录了。

    三、telnet连接

    1.打开telnet服务

    win10的telnet命令默认是被禁止了的,需要手动进行打开,打开“控制面板“,点击”卸载程序”,找到左边的”启用或关闭windows功能”,找到”Telnet Client”,勾选即可。

    2.配置ip

    telnet服务需要将设备和交换机放在同一网段下,需重新配置ip地址,配置如下:

    3.telnet连接

    进入cmd界面,我们可以先”ping”一下,查看连接情况:

    证明连接正常,此时,我们可以进行talnet登录了:

    输入用户名和密码,进入交换机,可以通过对交换机进行配置和管理了。

    如果要进入特权模式,还需要输入相应密码。

    展开全文
  • 思科2960交换机四大安全特性,生成树协议、风暴控制、端口安全、DHCP snooping,当然2960最新版已经支持DAI了。
  • 思科2960交换机 - 配置命令大全

    千次阅读 2018-11-13 15:36:47
    今天给大家分享下思科2960交换机的配置命令: 一、使能口令和使能密码 1、使能口令(enable password),口令以明文显示。 2、使能密码(enbale secret), 口令以密文显示。 Switch.> /*用户直行模式...

    今天给大家分享下思科2960交换机的配置命令:

    一、使能口令和使能密码


    1、使能口令(enable password),口令以明文显示。

    2、使能密码(enbale secret), 口令以密文显示。

    Switch.> /*用户直行模式提示符

    Switch.>enable /*进入特权模式

    Switch.# /*特权模式(进入前要输入密文)

    Switch.#config terminal /*进入全局配置模式

    Switch.(config)# /*配置模式提示符

    Switch.(config)# hostname Pconline /*设置主机名Pconline

    Pconline(config)# enable password cisco3560 /*设置使能口令为pconline

    Pconline(config)# enable secret cisco3560 /*设置使能密码为network

    Pconline(config)# line vty 0 15 /*设置虚拟终端线

    Pconline(config-line)# login /*设置登陆验证

    Pconline(config-line)# password cisco3560 /*设置虚拟终端登陆密码

    二、 交换机VLAN设置


    Switch.> /*用户直行模式提示符

    Switch.>enable /*进入特权模式

    switch#vlan database ; 进入VLAN设置

    switch(vlan)# vlan 2 ; 建VLAN 2 switch(vlan)#no vlan 2 ; 删vlan 2

    switch(config)#int f0/1 ; 进入网络端口1

    switch(config)#int giga0/1 ; 进入汇聚千兆口1

    switch(config-if)# duplex {auto | full | half} 设置端口为---自动/全双工/半双工

    switch(config-if)#switchport mode trunk ; 当前端口设置为汇聚口

    switch(config-if)#switchport mode access ; 当前端口设置为接入模式

    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置1,2号口允许的vlan组

    switch(config-if)#switchport trunk vlan 2 ; 设置1号口允许的vlan

    switch(config-if)#switchport access vlan 2 ; 当前端口加入vlan 2

    switch(config-if)#switchport trunk encap dot1q ; 设置vlan 中继

    cisco网络中,交换机在局域网中最终稳定状态的接口类型主要有四种:

    1、access: 主要用来接入终端设备,如PC机、服务器、打印服务器等。

    2、trunk: 主要用在连接其它交换机,以便在线路上承载多个vlan。

    3、multi: 在一个线路中承载多个vlan,但不像trunk,它不对承载的数据打标签。

    主要用于接入支持多vlan的服务器或者一些网络分析设备。现在基本不使用此类接口,在cisco的网络设备中,也基本不支持此类接口了。

    4、dot1q-tunnel: 用在Q-in-Q隧道配置中。

    switch(config)#vtp domain ; 设置发vtp域名

    switch(config)#vtp password ; 设置发vtp密码

    switch(config)#vtp mode server ;设置发vtp模式

    switch(config)#vtp mode client ;设置发vtp模式

    三、交换机设置IP地址


    switch(config)#interface vlan 1 进入vlan 1 switch(config-if)#ip address 132.37.48.3 255.255.255.0; 设置交换机管理IP

    switch(config)#ip default-gateway 132.37.48.1 ;设置交换机默认网关

    switch(config)#end; 退出当前模式

    Switch#conf t 进入特权模式

    Switch(config)# interface fa0/5

    Switch(config-if)# shutdown 关闭端口

    Switch(config-if)# no shutdown 打开端口

    四、交换机显示命令


    特权模式下:

    switch#write ; 保存配置信息

    switch#show vtp ; 查看vtp配置信息

    switch#show run ; 查看当前配置信息

    switch#show vtp ; 查看交换机vtp信息

    switch#show vlan ; 查看vlan配置信息

    switch#show interface ; 查看端口信息

    Switch#show interfaces fastethernet 0/1 switchport ;显示二层端口的状态,可以用来决定此口是否为二层或三层口。

    switch#show int f0/0 ; 查看指定端口信息

    sw1924_b#show ip; 查看上述设置环境

    sw1924_b#show versi;查看交换机的版本等信息

    sw1924_b#show running-config;查看交换机的当前运行配置等全部信息

    sw1924_b#show int e0/1;查看交换机的第1个端口信息

    基于端口的MAC地址绑定 Switch#config terminal #进入配置模式

    Switch(config)# Interface fastethernet 0/1 #进入具体端口配置模式

    Switch(config-if)#Switchport port-secruity #配置端口安全模式

    Switch(config-if )switchport port-security mac-address MAC(主机的MAC地址) #配置该端口要绑定的主机的MAC地址

    Switch(config-if )no switchport port-security mac-address MAC(主机的MAC地址)

    #删除绑定主机的MAC地址

    关于思科2960交换机的配置命令就介绍到这里,如您有想了解更多资讯以及思科产品信息可登陆星万全科技官网。

    展开全文
  • 思科2960交换机配置命令

    千次阅读 2013-11-11 10:47:56
    思科2960交换机配置命令  交换机基本状态:  switch: ;ROM状态, 路由器是rommon>  hostname> ;用户模式  hostname# ;特权模式  hostname(config)# ;全局配置模式  hostname...

    思科2960交换机配置命令  


    交换机基本状态: 
    switch: ;ROM状态, 路由器是rommon> 
    hostname> ;用户模式 
    hostname# ;特权模式 
    hostname(config)# ;全局配置模式 
    hostname(config-if)# ;接口状态

    交换机口令设置: 
    switch>enable ;进入特权模式 
    switch#config terminal ;进入全局配置模式 
    switch(config)#hostname ;设置交换机的主机名 
    switch(config)#enable secret xxx ;设置特权加密口令 
    switch(config)#enable password xxa ;设置特权非密口令 
    switch(config)#line console 0 ;进入控制台口 
    switch(config-line)#line vty 0 4 ;进入虚拟终端 
    switch(config-line)#login ;允许登录 
    switch(config-line)#password xx ;设置登录口令xx 
    switch#exit ;返回命令

    交换机VLAN设置: 
    switch#vlan database ;进入VLAN设置 
    switch(vlan)#vlan 2 ;建VLAN 2 
    switch(vlan)#no vlan 2 ;删vlan 2 
    switch(config)#int f0/1 ;进入端口1 
    switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2 
    switch(config-if)#switchport mode trunk ;设置为干线 
    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan 
    switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继 
    switch(config)#vtp domain ;设置发vtp域名 
    switch(config)#vtp password ;设置发vtp密码 
    switch(config)#vtp mode server ;设置发vtp模式 
    switch(config)#vtp mode client ;设置发vtp模式

    交换机设置IP地址: 
    switch(config)#interface vlan 1 ;进入vlan 1 
    switch(config-if)#ip address ;设置IP地址 
    switch(config)#ip default-gateway ;设置默认网关 
    switch#dir flash: ;查看闪存

    交换机显示命令: 
    switch#write ;保存配置信息 
    switch#show vtp ;查看vtp配置信息 
    switch#show run ;查看当前配置信息 
    switch#show vlan ;查看vlan配置信息 
    switch#show interface ;查看端口信息 
    switch#show int f0/0 ;查看指定端口信息

    展开全文
  • 思科2960交换机密码破解

    千次阅读 2017-12-12 15:07:32
    1、重新启用交换机时,一直按mode键直到绿灯变成橘色就行。  2、就是进入romm的模式后  3、再输入flash_init后,输入dir(查看目录)  4、再输入dir flash:/(查看flash目录的信息)  5、在输入rename flash...

      1、重新启用交换机时,一直按mode键直到绿灯变成橘色就行。
      2、就是进入romm的模式后
      3、再输入flash_init后,输入dir(查看目录)
      4、再输入dir flash:/(查看flash目录的信息)
      5、在输入rename flash:config.text flash:XXX更改文件名让它找不到此文件就可登陆,登陆后要改会原本文件名
      6、然后输入reset重启
      7、进入特权模式后输入dir(查看目录)
      8、rename flash:XXX flash:config.text 将配置 文件名改回来
      9、copy flash:config.text running-config 将文件复制到内存中
      10、进入端口模式更改密码
          enable password xxx
          line console 0
          password xxx

    展开全文
  • ![在这里插入图片描述](https://img-blog.csdnimg.cn/20190301193204292.jpg?x-oss-
  • 微软的Windows server 2012已经能支持LACP(IEEE 802.3ad)链路聚合了,由于使用...实验准备:思科交换机2960一台、安装server 2012的服务器一台,内有两个千兆网卡,网线两根。步骤:1、思科交换机的配置在特权模式下...
  • 思科C2960交换机的默认网关

    千次阅读 2017-05-17 09:25:43
    思科C2960交换机的默认网关。直接命令补充,看不到default-gateway。但实际输入会出现。
  • 思科2918与2960交换机性能参数及功能对比
  • 配置思科2960G交换机

    2012-08-08 07:15:27
    配置思科2960G交换机交换机命名及特权密码设置 (config)#hostname MLK-sw2960 //交换机命名 (config)#enable seret morning //设置特权加密口令,为方便管理,此处使用下面的明码 (config)#enable ...
  • 本文讲的是思科Catalyst 2960交换机中的CVE-2017-3881漏洞分析, 2017年3月17日,思科官方网站发布公告称Cisco IOS&IOS XE Software 集群管理协议(Cluster Management Protocol)存在远程执行代码漏洞(CVE-2017...
  • 思科2960.TXT

    2013-04-16 14:46:49
    思科2960交换机29602960
  • 本文转载自胖鲨鱼网络http://www.pangshayu.com/html/6010.html关键字:思科交换机,CISCO2960,重灌IOS,重装IOS,switch:公司的一台思科2960交换机拿来设置,在清空配置的时候不小心清空了Flash:结果reload启动不起来...
  • 思科交换机 2960 ISO

    2011-11-17 13:13:05
    思科交换机 2960系统ISO文件,可以用来配合模拟器做各种实验。
  • 思科交换机2960配置

    2010-05-13 13:11:19
    思科 交换机 2960 配置 中文,非常简单实用
  • 思科交换机中为了防止ip被盗用或员工乱改ip,可以做以下措施,既ip与mac地址的绑定,和ip与交换机端口的绑定。一、通过IP查端口 先查MAC地址,再根据MAC地址查端口: bangonglou3#show arp | include 208.41...
  • Cisco® Catalyst® 2960-L 系列交换机是具有固定配置的入门级千兆以太网交换机,可为企业分支机构、传统工作场 所和配线间外应用提供企业级二层接入。该系列交换机专为实现操作简易性而设计,从而降低总拥有成本,...
  • 公司一台设备, WS-C2960S-24TS-L,是思科24口1000M的二层交换杨,使用的IOS版本为12.2(55) universalk9-M的IOS软件,最近公司安装了一些数字摄像头,把监控主机和一台球型监控接到了这台机器上,接口的收发速率...
  • 2960交换机简要配置手册(中文)针对思科基础二层设备进行配置讲解
  • CISCO 思科 ios 2960

    2019-02-13 09:07:17
    思科2960 交换机 ios 版本号思科ios 版本号c2960-lanbasek9-mz.122-55.SE7
  • 2960>en;第一次密码为空2960h#conf t;进入全局配置模式2960(config)#...设置交换机2960(config)#enable secret aaa;设置特权加密口令为aaa2960(config)#enable password aax;设置特权非密口令为aax...
  • Cisco2960交换机忘记密码的解决办法

    千次阅读 2014-08-26 17:07:00
    思科2960密码破解1.长按MODEL键,打开电源,按住mode按钮直到sys灯不闪动(常亮状态)直到出现switch:模式2.初始化flash卡switch:flash_init InitializingFlash... flashfs[0]:603files,19directories flashfs[0]:0...
  • 思科2960配置参考.doc

    2020-06-02 19:55:35
    Cisco 2960交换机配置 详细的cisco2960配置实例 精简实用
  • 常用交换机型号Catalyst2960 系列交换机·Catalyst3560 系列交换机·Catalyst3750 系列交换机·Catalyst4500 系列交换机·Catalyst4948 系列交换机·Catalyst6500 系列交换机思科交换机测试中常用配置用户模式Sw...
  • Cisco(思科)交换机堆叠技术配置向导

    万次阅读 2018-10-15 10:47:41
    思科3750/2960交换机堆叠技术配置向导***光纤跳线注意事项***光纤线在暗处,可以通过肉眼看的到光,光纤模块,必须是多模对多模,单模对单模,光纤模块GLC-SX-MMD 表示多模 GLC-LH-SMD 表示单模。如果是两根光纤线,...
  • 思科CISCO 交换机命名规则

    千次阅读 2014-03-23 18:16:28
    看下这些:WS-C2960-24TC-L 、WS-C2950G-24-EI-DC、WS-C2960-24TT-L 、WS-C3750G-24TS-E、WS-C3750G-24T-S,我们并没有在交换机的证明发现它们,我们只看到catalyst 2950series,把它写全是这样的:CISCO c

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 161
精华内容 64
关键字:

思科2960交换机