精华内容
下载资源
问答
  • 思科交换机配置命令大全switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname...
  • 思科交换机配置命令

    2018-06-13 13:41:36
    思科交换机配置命令(全面经典)!!!!!!!1!!!!!
  • Cisco思科光纤交换机怎么配置呢?相信很多网友还是不太了解,下面就为大家收集的Cisco思科光纤交换机配置说明教程,一起来看看了解下
  • 思科交换机配置命令大全
  • 思科交换机配置命令大全
  • 思科交换机配置命令.docx
  • 思科交换机配置命令
  • 思科交换机配置命令大全.doc
  • 思科交换机相关配置 一、基础操作 进入交换机界面为一般用户模式 switch> 输入命令 enable进入特权用户模式 switch# 输入命令config terminal进入全局配置模式 switch(config)# 输入命令int xxx可进入端口或者...

    思科交换机相关配置
    一、基础操作
    进入交换机界面为一般用户模式 switch>
    输入命令 enable进入特权用户模式 switch#
    输入命令config terminal进入全局配置模式 switch(config)#
    输入命令int xxx可进入端口或者vlan的全局配置子模式switch(config-if)#

    特权用户模式可输入show命令查看相关设置,命令后输入?可查询帮助
    可用no 命令撤销已经设置的配置

    二、Telnet远程登录设置
    1.交换机配置IP地址
    进入vlan 1 //int vlan 1
    启用 //no shutdown
    设置ip地址 ///ip address ip地址 子网掩码
    2.设置交换机用户名和密码
    useename xxx
    password/secret xxx
    设置enable密码
    enable password xxx
    3.设置访问数量
    line vty 0 x(x是数量,最小为1)
    password xxx
    login
    也可以直接调用上面设置的本地用户名密码
    line vty 0 x
    login local
    4.console口的密码设置也相似
    line console 0
    login local

    三、SSH远程登录
    1.基础设置与Telnet类似
    2.设置访问数量
    line vty 0 x
    3.选择ssh方式
    transport input ssh
    4.更改hostname
    hostname xxx
    5.设置域名
    ip domain-name xxx.com
    6.设置rsa加密密钥
    crypto key generate rsa
    [512]:在360-2048中选择即可
    7.PC端登录命令
    ssh -l username ip地址

    四、交换机中划分vlan
    1.创建vlan
    vlan x(数字)
    可以使用name命令改名
    2.进入端口,分配vlan
    int f0/1
    switchport access vlan x
    3.交换机之间相连需要在连接端口做trunk
    进入连接端口
    int f0/24
    创建trunk
    switchport mode trunk

    五、核心交换机中划分vlan
    1.创建vlan
    vlan x1
    vlan x2

    2.vlan 中设置网关,vlan下的pc终端也要设置相同网关
    int vlan x
    ip address xxx xxx
    3.三层交换机与交换机相连端口做trunk
    封装dot1q协议
    switchport trunk encapsulation dot1q
    创建trunk
    switchport mode trunk
    4.如有需要,可以开启路由功能
    ip routing

    六、本地端口镜像
    1.设置源端口
    monitor session 1 source int f0/1
    2.设置目的端口
    monitor session 1 destination f0/2

    七、远程端口镜像
    1.设置远程专用vlan
    vlan 100
    开启远程端口镜像功能
    remote-span
    2.被监视交换机中
    设置源端口
    monitor session 1 source int f0/1
    设置目的端口
    monitor session 1 destination remote vlan 100 reflector-port f0/1
    3.另一台监视交换机
    同上,创建vlan,开启远程镜像
    设置源端口
    monitor session 2 source remote vlan 100
    设置目的端口
    monitor session 2 destination int f0/3

    八、PVST配置,负载均衡
    1.打开pvst功能
    spanning-tree mode pvst
    2.进入交换机全局配置模式
    配置主根
    spainning-tree vlan x1 priority 4096
    配置次根
    spanning- tree vlan x2 priority 8192
    3.进入另一个交换机
    配置主根
    spainning-tree vlan x2 priority 4096
    配置次根
    spanning- tree vlan x1 priority 8192
    3.进入另一个交换机

    九、链路聚合lacp
    1.进入需要配置的端口
    int range f0/21-24
    2.选择lacp协议
    channel-protocol lacp
    2.开启
    channel-group 1 mode active
    3.如果链路聚合需要做trunk,可以执行以下操作
    int port- channel 1
    switchport mode trunk

    展开全文
  • 华为思科交换机配置命令大全 EXE文件,可以选择 非常方便可以选择华为或者是思科的命令解释
  • (交换机)简单的思科交换机配置命令

    千次阅读 多人点赞 2018-09-11 14:47:55
    今天有机会配置了一波思科交换机配置思路和华为交换机区别有限。 趁此机会做个学习总结。 我是用串口线直连交换机进行配置,由于经常出现断开连接的情况,所以进入虚拟终端设置了一下超时时间。 一,起手式 ...

    今天有机会配置了一波思科交换机,配置思路和华为交换机区别有限。 趁此机会做个学习总结。
    我是用串口线直连交换机进行配置,由于经常出现断开连接的情况,所以进入虚拟终端设置了一下超时时间。

    一,起手式

    提示符操作命令
    switch>进入特权模式enable
    switch#进入全局配置模式config t
    switch#查看当前运行的配置show run
    switch#保存当前配置到下次启动copy run startup
    switch#返回命令exit

    虚拟终端设置(一般远程登录用)

    提示符操作命令
    switch#进入虚拟终端line vty 0 4
    switch(config-line)#设置超时时间为10分0秒exec-timeout 10 0
    switch(config-line)#虚拟终端允许登录login ##实际未配置
    switch(config-line)#设置虚拟终端登录口令csico6password csico6 #实际未配置
    switch(config-line)#返回命令exit

    二,VLAN创建,删除,端口属性的设置,配置trunk端口,将某端口加入vlan中

    提示符操作命令
    switch#vlan database进入VLAN设置 实际未配置,可能是比较老的版本需要
    switch(vlan)#vlan 2建VLAN 2
    switch(vlan)#no vlan 2删vlan 2
    switch(config)#int f0/1进入端口f0/1,参照着写,比如,int g1/0/12
    switch(config)#description TO_PC1这是该端口描述为TO_PC1
    switch(config-if)#switchport access vlan 2当前端口加入vlan 2
    switch(config-if)#switchport mode trunk设置为trunk模式(access模式)
    switch(config-if)#switchport trunk allowed vlan 1,2设置允许通过的vlan
    switch(config-if)#switchport trunk allowed vlan all设置允许通过所有vlan

    三,设置IP地址,默认网关,配置静态MAC地址表

    提示符命令配置
    switch(config)#interface vlan 1进入vlan 1
    switch(config-if)#ip address 192.168.1.1 255.255.255.0设置IP地址
    switch(config-if)#exit返回命令
    switch(config)#ip default-gateway 192.168.1.6设置默认网关
    switch(config)#ip routing开启交换机三层路由
    switch(config)#mac-address-table?查看mac-address-table的子命令
    switch(config)#mac-address-table aging-time 100设置超时时间为100ms
    switch(config)#mac-address-table permanent 0000.0c01.bbcc f0/3加入永久地址在f0/3端口
    switch(config)#mac-address-table restricted static 0000.0c02.bbcc f0/6 f0/7加入静态地址目标端口f0/6源端口f0/7
    switch(config)#end回到特权模式
    switch#show mac-address-table查看整个MAC地址表 ##查看mac的信息有时会非常有用
    switch#clear mac-address-table restricted static清除限制性静态地址

    四,交换机查看命令

    命令说明
    show run查看当前运行的配置
    show run interfaces查看端口更具体的信息,可以敲“?”号查看
    show vlan查看vlan的配置信息
    show int查看端口信息
    show int ?查看端口更具体的信息,可以敲“?”号查看
    show ip interfaces brief查看包括ip信息在内的端口简要状态信息
    dir flash查看闪存

    五,恢复出厂设置命令

    提示符命令
    switch>enable
    switch#erase startup-configure
    switch#reload
    展开全文
  • 思科交换机配置命令大全!

    千次阅读 多人点赞 2012-11-22 15:26:46
    1. 交换机支持的命令交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 ...

    1. 交换机支持的命令:
    交换机基本状态:

    switch: ;ROM状态, 路由器是rommon>
    hostname> ;用户模式
    hostname# ;特权模式
    hostname(config)# ;全局配置模式
    hostname(config-if)# ;接口状态
    
    交换机口令设置:
    switch>enable ;进入特权模式
    switch#config terminal ;进入全局配置模式
    switch(config)#hostname  ;设置交换机的主机名
    switch(config)#enable secret xxx ;设置特权加密口令
    switch(config)#enable password xxa ;设置特权非密口令
    switch(config)#line console 0 ;进入控制台口
    switch(config-line)#line vty 0 4 ;进入虚拟终端
    switch(config-line)#login ;允许登录
    switch(config-line)#password xx ;设置登录口令xx
    switch#exit ;返回命令
    

    交换机VLAN设置:

    switch#vlan database ;进入VLAN设置
    switch(vlan)#vlan 2 ;建VLAN 2
    switch(vlan)#no vlan 2 ;删vlan 2
    switch(config)#int f0/1 ;进入端口1
    switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2
    switch(config-if)#switchport mode trunk ;设置为干线
    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan
    switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继
    switch(config)#vtp domain  ;设置发vtp域名
    switch(config)#vtp password  ;设置发vtp密码
    switch(config)#vtp mode server ;设置发vtp模式
    switch(config)#vtp mode client ;设置发vtp模式
    

    交换机设置IP地址:

    switch(config)#interface vlan 1 ;进入vlan 1
    switch(config-if)#ip address   ;设置IP地址
    switch(config)#ip default-gateway  ;设置默认网关
    switch#dir flash: ;查看闪存
    

    交换机显示命令:

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看vlan配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息    
    

    2. 路由器支持的命令:
    路由器显示命令:

    router#show run ;显示配置信息
    router#show interface ;显示接口信息
    router#show ip route ;显示路由信息
    router#show cdp nei ;显示邻居信息
    router#reload     ;重新起动
    

    路由器口令设置:

    router>enable ;进入特权模式
    router#config terminal ;进入全局配置模式
    router(config)#hostname  ;设置交换机的主机名
    router(config)#enable secret xxx ;设置特权加密口令
    router(config)#enable password xxb ;设置特权非密口令
    router(config)#line console 0 ;进入控制台口
    router(config-line)#line vty 0 4 ;进入虚拟终端
    router(config-line)#login ;要求口令验证
    router(config-line)#password xx ;设置登录口令xx
    router(config)#(Ctrl+z) ; 返回特权模式
    router#exit ;返回命令
    

    路由器配置:

    router(config)#int s0/0 ;进入Serail接口
    router(config-if)#no shutdown ;激活当前接口
    router(config-if)#clock rate 64000 ;设置同步时钟
    router(config-if)#ip address   ;设置IP地址
    router(config-if)#ip address  second ;设置第二个IP
    router(config-if)#int f0/0.1 ;进入子接口
    router(config-subif.1)#ip address  ;设置子接口IP
    router(config-subif.1)#encapsulation dot1q  ;绑定vlan中继协议
    router(config)#config-register 0x2142 ;跳过配置文件
    router(config)#config-register 0x2102 ;正常使用配置文件
    router#reload ;重新引导
    

    路由器文件操作:

    router#copy running-config startup-config ;保存配置
    router#copy running-config tftp ;保存配置到tftp
    router#copy startup-config tftp ;开机配置存到tftp
    router#copy tftp flash: ;下传文件到flash
    router#copy tftp startup-config;下载配置文件

    ROM状态:
    Ctrl+Break ;进入ROM监控状态
    rommon>confreg 0x2142 ;跳过配置文件
    rommon>confreg 0x2102 ;恢复配置文件
    rommon>reset  ;重新引导
    rommon>copy xmodem: flash: ;从console传输文件

    rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP
    rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码
    rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP
    rommon>TFTP_FILE=c2600.bin ;指定下载的文件
    rommon>tftpdnld ;从tftp下载
    rommon>dir flash: ;查看闪存内容
    rommon>boot ;引导IOS

    静态路由:

    ip route    ;命令格式
    router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例
    router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例
    

    动态路由:

    router(config)#ip routing ;启动路由转发
    router(config)#router rip ;启动RIP路由协议。
    router(config-router)#network  ;设置发布路由
    router(config-router)#negihbor  ;点对点帧中继用。
    

     

    帧中继命令:

    router(config)#frame-relay switching ;使能帧中继交换
    router(config-s0)#encapsulation frame-relay ;使能帧中继
    router(config-s0)#fram-relay lmi-type cisco ;设置管理类型
    router(config-s0)#frame-relay intf-type DCE ;设置为DCE
    router(config-s0)#frame-relay dlci 16 ;
    router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号
    router(config-s0)#frame-relay interface-dlci 16 ;
    router(config)#log-adjacency-changes ;记录邻接变化
    router(config)#int s0/0.1 point-to-point ;设置子接口点对点
    router#show frame pvc ;显示永久虚电路
    router#show frame map ;显示映射 
    

    基本访问控制列表:

    router(config)#access-list  permit|deny  
    router(config)#interface  ;default:deny any
    router(config-if)#ip access-group  in|out ;default:out

    例1:
    router(config)#access-list 4 permit 10.8.1.1
    router(config)#access-list 4 deny 10.8.1.0 0.0.0.255
    router(config)#access-list 4 permit 10.8.0.0 0.0.255.255
    router(config)#access-list 4 deny 10.0.0.0 0.255.255.255
    router(config)#access-list 4 permit any
    router(config)#int f0/0
    router(config-if)#ip access-group 4 in

    扩展访问控制列表:
    access-list  permit|deny icmp  <DESTINATIONIP
    wild>[type]
    access-list  permit|deny tcp  <DESTINATIONIP
    wild>[port]
    例3:
    router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo
    router(config)#access-list 101 permit ip any any
    router(config)#int s0/0
    router(config-if)#ip access-group 101 in
    例3:
    router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80
    router(config)#access-list 102 permit ip any any
    router(config)#interface s0/1
    router(config-if)#ip access-group 102 out
    

    删除访问控制例表:

    router(config)#no access-list 102
    router(config-if)#no ip access-group 101 in

    路由器的nat配置

    Router(config-if)#ip nat inside ;当前接口指定为内部接口
    Router(config-if)#ip nat outside ;当前接口指定为外部接口
    Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]
    Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1
    Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80
    Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0
    Router(config)#ip nat inside source list 1 pool p1
    Router(config)#ip nat inside destination list 2 pool p2
    Router(config)#ip nat inside source list 2 interface s0/0 overload
    Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary
    Router#show ip nat translation
    rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
    overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。
    

    外部网关协议配置:

    routerA(config)#router bgp 100
    routerA(config-router)#network 19.0.0.0
    routerA(config-router)#neighbor 8.1.1.2 remote-as 200

    配置PPP验证:

    RouterA(config)#username  password 
    RouterA(config)#int s0
    RouterA(config-if)#ppp authentication {chap|pap}
    

    3.PIX防火墙命令

    Pix525(config)#nameif ethernet0 outside security0 ;命名接口和级别
    Pix525(config)#interface ethernet0 auto ;设置接口方式
    Pix525(config)#interface ethernet1 100full ;设置接口方式
    Pix525(config)#interface ethernet1 100full shutdown
    Pix525(config)#ip address inside 192.168.0.1 255.255.255.0
    Pix525(config)#ip address outside 133.0.0.1 255.255.255.252
    Pix525(config)#global (if_name) natid ip-ip ;定义公网IP区间
    Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 ;例句
    Pix525(config)#global (outside) 1 133.0.0.1 ;例句
    Pix525(config)#no global (outside) 1 133.0.0.1 ;去掉设置
    Pix525(config)#nat (if_name) nat_id local_ip [netmark]
    Pix525(config)#nat (inside) 1 0 0
    内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。
    Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0
    内网172.16.5.0/16网段的主机可以访问global 1指定的外网。
    Pix525(config)#route if_name 0 0 gateway_ip [metric] ;命令格式
    Pix525(config)#route outside 0 0 133.0.0.1 1 ;例句
    Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 ;例句
    Pix525(config)#static (inside, outside) 133.0.0.1 192.168.0.8
    表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。
    Pix525(config)#static (dmz, outside) 133.0.0.1 172.16.0.8
    中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。
    **************************************************************************************************************************************************************************************

    1.在基于IOS的交换机上设置主机名/系统名:
    switch(config)# hostname hostname
    在基于CLI的交换机上设置主机名/系统名:
    switch(enable) set system name name-string

    2.在基于IOS的交换机上设置登录口令:
    switch(config)# enable password level 1 password
    在基于CLI的交换机上设置登录口令:
    switch(enable) set password
    switch(enable) set enalbepass

    3.在基于IOS的交换机上设置远程访问:
    switch(config)# interface vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address
    在基于CLI的交换机上设置远程访问:
    switch(enable) set interface sc0 ip-address netmask broadcast-address
    switch(enable) set interface sc0 vlan
    switch(enable) set ip route default gateway

    4.在基于IOS的交换机上启用和浏览CDP信息:
    switch(config-if)# cdp enable
    switch(config-if)# no cdp enable
    为了查看Cisco邻接设备的CDP通告信息:
    switch# show cdp interface [type modle/port]
    switch# show cdp neighbors [type module/port] [detail]
    在基于CLI的交换机上启用和浏览CDP信息:
    switch(enable) set cdp {enable|disable} module/port
    为了查看Cisco邻接设备的CDP通告信息:
    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

    5.基于IOS的交换机的端口描述:
    switch(config-if)# description description-string
    基于CLI的交换机的端口描述:
    switch(enable)set port name module/number description-string

    6.在基于IOS的交换机上设置端口速度:
    switch(config-if)# speed{10|100|auto}
    在基于CLI的交换机上设置端口速度:
    switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}

    7.在基于IOS的交换机上设置以太网的链路模式:
    switch(config-if)# duplex {auto|full|half}
    在基于CLI的交换机上设置以太网的链路模式:
    switch(enable) set port duplex module/number {full|half}

    8.在基于IOS的交换机上配置静态VLAN:
    switch# vlan database
    switch(vlan)# vlan vlan-num name vla

    switch(vlan)# exit
    switch# configure teriminal
    switch(config)# interface interface module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end
    在基于CLI的交换机上配置静态VLAN:
    switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list

    9. 在基于IOS的交换机上配置VLAN中继线:
    switch(config)# interface interface mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)# switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list
    在基于CLI的交换机上配置VLAN中继线:
    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]

    10.在基于IOS的交换机上配置VTP管理域:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    在基于CLI的交换机上配置VTP管理域:
    switch(enable) set vtp [domain domain-name]

    11.在基于IOS的交换机上配置VTP 模式:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    switch(vlan)# vtp {sever|cilent|transparent}
    switch(vlan)# vtp password password
    在基于CLI的交换机上配置VTP 模式:
    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

    12. 在基于IOS的交换机上配置VTP版本:
    switch# vlan database
    switch(vlan)# vtp v2-mode
    在基于CLI的交换机上配置VTP版本:
    switch(enable) set vtp v2 enable

    13. 在基于IOS的交换机上启动VTP剪裁:
    switch# vlan database
    switch(vlan)# vtp pruning
    在基于CL I 的交换机上启动VTP剪裁:
    switch(enable) set vtp pruning enable

    14.在基于IOS的交换机上配置以太信道:
    switch(config-if)# port group group-number [distribution {source|destination}]
    在基于CLI的交换机上配置以太信道:
    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

    15.在基于IOS的交换机上调整根路径成本:
    switch(config-if)# spanning-tree [vlan vlan-list] cost cost
    在基于CLI的交换机上调整根路径成本:

    switch(enable) set spantree portcost moudle/port cost
    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

    16.在基于IOS的交换机上调整端口ID:
    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
    在基于CLI的交换机上调整端口ID:
    switch(enable) set spantree portpri {mldule/port}priority
    switch(enable) set spantree portvlanpri {module/port}priority [vlans]

    17. 在基于IOS的交换机上修改STP时钟:
    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
    ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
    在基于CLI的交换机上修改STP时钟:
    switch(enable) set spantree hello interval[vlan]
    switch(enable) set spantree fwddelay delay [vlan]
    switch(enable) set spantree maxage agingtiame[vlan]

    18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:
    switch(config-if)#spanning-tree portfast
    在基于CLI的交换机端口上启用或禁用Port Fast 特征:
    switch(enable) set spantree portfast {module/port}{enable|disable}

    19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:
    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
    在基于CLI的交换机端口上启用或禁用UplinkFast 特征:
    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name

    21. 为了从一条中继链路上删除VLAN,可使用下列命令:
    switch(enable) clear trunk module/port vlan-range

    22. 用show vtp domain 显示管理域的VTP参数.

    23. 用show vtp statistics显示管理域的VTP参数.

    24. 在Catalyst交换机上定义TrBRF的命令如下:
    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

    25. 在Catalyst交换机上定义TrCRF的命令如下:
    switch (enable) set vlan vlan-num [name name] type trcrf
    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num

    26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:
    switch(enable) set vlan vlan-num mod-num/port-num

    27. 命令show spantree显示一个交换机端口的STP状态.

    28. 配置一个ELAN的LES和BUS,可以使用下列命令:
    ATM (config)# interface atm number.subint multioint
    ATM(config-subif)# lane serber-bus ethernet elan-name

    29. 配置LECS:
    ATM(config)# lane database database-name
    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
    ATM(lane-config-databade)# name …

    30. 创建完数据库后,必须在主接口上启动LECS.命令如下:
    ATM(config)# interface atm number
    ATM(config-if)# lane config database database-name
    ATM(config-if)# lane config auto-config-atm-address

    31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:
    ATM(config)# interface atm number.subint multipoint
    ATM(config)# lane client ethernet vlan-num elan-num

    32. 用show lane server 显示LES的状态.

    33. 用show lane bus显示bus的状态.

    34. 用show lane database显示LECS数据库可内容.

    35. 用show lane client显示LEC的状态.

    36. 用show module显示已安装的模块列表.

    37. 用物理接口建立与VLAN的连接:
    router# configure terminal
    router(config)# interface media module/port
    router(config-if)# description description-string
    router(config-if)# ip address ip-addr subnet-mask
    router(config-if)# no shutdown

    38. 用中继链路来建立与VLAN的连接:
    router(config)# interface module/port.subinterface
    router(config-ig)# encapsulation[isl|dotlq] vlan-number
    router(config-if)# ip address ip-address subnet-mask

    39. 用LANE 来建立与VLAN的连接:
    router(config)# interface atm module/port
    router(config-if)# no ip address
    router(config-if)# atm pvc 1 0 5 qsaal
    router(config-if)# atm pvc 2 0 16 ilni
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-mask
    router(config-if)# lane client ethernet elan-num
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-name
    router(config-if)# lane client ethernet elan-name
    router(config-if)# …

    40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:
    router(config)# ip routing
    router(config)# router ip-routing-protocol
    router(config-router)# network ip-network-number
    router(config-router)# network ip-network-number

    41. 配置默认路由:
    switch(enable) set ip route default gateway

    42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:
    router(config)# interface interface number
    router(config-if)# mls rp vlan-id vlan-id-num

    43. 在路由处理器启用MLSP:
    router(config)# mls rp ip

    44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:
    router(config)# interface interface number
    router(config-if)# mls rp vtp-domain domain-name

    45. 查看指定的VTP域的信息:
    router# show mls rp vtp-domain vtp domain name

    46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:
    router(config-if)#mls rp management-interface

    47. 要检验MLS-RP的配置情况:
    router# show mls rp

    48. 检验特定接口上的MLS配置:
    router# show mls rp interface interface number

    49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:
    set mls flow [destination|destination-source|full]

    50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令:
    router(config)# mls rp ip input-acl

    51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令:
    switch(enable) set mls enable

    52. 若想改变老化时间的值,可在特权模式下输入以下命令:
    switch(enable) set mls agingtime agingtime

    53. 设置快速老化:
    switch(enable) set mls agingtime fast fastagingtime pkt_threshold

    54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定:
    switch(enable) show mls include

    55. 显示MLS高速缓存记录:
    switch(enable) show mls entry

    56. 用命令show in arp显示ARP高速缓存区的内容。

    57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令:
    router(config-if)# standby group-number ip ip-address

    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
    router(config-if)# standy group-number preempt

    59. 访问时间和保持时间参数是可配置的:
    router(config-if)# standy group-number timers hellotime holdtime

    60. 配置HSRP跟踪:
    router(config-if)# standy group-number track type-number interface-priority

    61. 要显示HSRP路由器的状态:
    router# show standby type-number group brief

    62. 用命令show ip igmp确定当选的查询器。

    63. 启动IP组播路由选择:
    router(config)# ip muticast-routing

    64. 启动接口上的PIM:
    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

    65. 启动稀疏-稠密模式下的PIM:
    router# ip multicast-routing
    router# interface type number
    router# ip pim sparse-dense-mode

    66. 核实PIM的配置:
    dallasr1># show ip pim interface[type number] [count]

    67. 显示PIM邻居:
    dallasr1># show ip neighbor type number

    68. 为了配置RP的地址,命令如下:
    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

    69. 选择一个默认的RP:
    dallasr1># ip pim rp-address
    通告RP和它所服务的组范围:
    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
    为管理范围组通告RP的地址:
    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
    设定一个RP映像代理:
    dallasr1># ip pim send-rp-discovery scope ttl
    核实组到RP的映像:
    dallasr1># show ip pim rp mapping
    dallasr1># show ip pim rp [group-name|group-address] [mapping]

    70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值:
    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

    71. 用show ip pim neighbor显示PIM邻居表。

    72. 显示组播通信路由表中的各条记录:
    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

    73. 要记录一个路由器接受和发送的全部IP组播包:
    dallasr1> #debug ip mpacket [detail] [access-list][group]

    74. 要在CISCO路由器上配置CGMP:
    dallasr1>(config-if)# ip cgmp

    75.配置一个组播路由器,使之加入某一个特定的组播组:
    dallasr1>(config-if)# ip igmp join-group group-address

    76. 关闭 CGMP:
    dallasr1>(config-if)# no ip cgmp

    77. 启动交换机上的CGMP:
    dallasr1>(enable) set cgmp enable

    78. 核实Catalyst交换机上CGMP的配置情况:
    catalystla1>(enable) show config
    set prompt catalystla1>
    set interface sc0 192.168.1.1 255.255.255.0
    set cgmp enable

    79. CGMP离开的设置:
    Dallas_SW(enable) set cgmp leave

    80. 在Cisco设备上修改控制端口密码:
    R1(config)# line console 0
    R1(config-line)# login
    R1(config-line)# password Lisbon
    R1(config)# enable password Lilbao
    R1(config)# login local
    R1(config)# username student password cisco

    81. 在Cisco设备上设置控制台及vty端口的会话超时:
    R1(config)# line console 0
    R1(config-line)# exec-timeout 5 10
    R1(config)# line vty 0 4
    R1(config-line)# exec-timeout 5 2

    82. 在Cisco设备上设定特权级:
    R1(config)# privilege configure level 3 username
    R1(config)# privilege configure level 3 copy run start
    R1(config)# privilege configure level 3 ping
    R1(config)# privilege configure level 3 show run
    R1(config)# enable secret level 3 cisco

    83. 使用命令privilege 可定义在该特权级下使用的命令:
    router(config)# privilege mode level level command

    84. 设定用户特权级:
    router(config)# enable secret level 3 dallas
    router(config)# enable secret san-fran
    router(config)# username student password cisco

    85. 标志设置与显示:
    R1(config)# banner motd ‘unauthorized access will be prosecuted!’

    86. 设置vty访问:
    R1(config)# access-list 1 permit 192.168.2.5
    R1(config)# line vty 0 4
    R1(config)# access-class 1 in

    87. 配置HTTP访问:
    Router3(config)# access-list 1 permit 192.168.10.7
    Router3(config)# ip http sever
    Router3(config)# ip http access-class 1
    Router3(config)# ip http authentication local
    Router3(config)# username student password cisco

    88. 要启用HTTP访问,请键入以下命令:
    switch(config)# ip http sever

    89. 在基于set命令的交换机上用setCL1启动和核实端口安全:
    switch(enable) set port security mod_num/port_num…enable mac address
    switch(enable) show port mod_num/port_num
    在基于CiscoIOS命令的交换机上启动和核实端口安全:
    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
    switch# show mac-address-table security [type module/port]

    90. 用命令access-list在标准通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

    91. 用命令access-list在扩展通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name in [type number]

    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number

    94. set snmp命令选项:
    set snmp community {read-only|ready-write|read-write-all}[community_string]

    95. set snmp trap 命令格式如下:
    set snmp trap {enable|disable}
    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
    set snmp trap rvcr_addr rcvr_community

    96. 启用SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable chassis

    97. 启用所有SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable

    …………以下由about于2002年12月6日增加…………
    98. 禁用SNMP chassis 陷阱:
    Console>(enable) set snmp trap disable chassis

    99. 给SNMP陷阱接收表加一条记录:
    Console>(enable) set snmp trap 192.122.173.42 public

    100. show snmp 输出结果。

    101. 命令set snmp rmon enable 的输出结果。

    102. 显示SPAN信息:
    Consile> show spanCISCO交换机配置命令大全

    展开全文
  • CISCO交换机常用命令》 一、交换机四种基本模式 1、四种模式介绍 2.进入四种模式 (1)从用户模式进入特权模式:enable (2)从特权模式进入全局配置模式:conf t (3)从全局端口配置模式进入视图模式...

     

                                           《CISCO交换机常用命令》

    一、交换机四种基本模式

    1、四种模式介绍

     

    2.进入四种模式

    (1)从用户模式进入特权模式:enable

    (2)从特权模式进入全局配置模式:conf t

    (3)从全局端口配置模式进入视图模式:int f0/1

    (4)从全局模式返回至特权模式:end

    3.退回返回上一层:exit

    4.修改交换机名称:hostname X

    5.重启:reload

    6自动命令补全:tab

    7.帮助信息:?、co?、copy?

    8.配置交换机端口参数:speed,duplex

    9.保存交换机配置:Switch#wr

     

    二、功能及查看命令

    1.实现以太网通道负载平衡:

    (1)按照源/目标主机IP地址数据分发来:port-channel load-balance dst-ip;

    (2)按照源/目标MAC地址分发来:port-channel load-balance src-mac

    3.查看信息:

    (1)查看虚拟通道包含的接口数量:Switch#show etherchannel summary

    (2)查看交换机版本信息:Switch#show version

    (3)查看当前生效的配置信息:Switch#show running-config

    (4)查看保存在NVRAM中启动配置信息:Switch#show startup-config

    (5)查看端口信息:Switch#Switch#show interface

    (6)查看交换机的MAC地址表Switch#show mac-address-table

    (7)查看交换机的vlan配置Switch#show vlan

    4.特定功能

    (1)选择某个端口:Switch(config)#interface type mod/port

    (type表示端口类型,通常有ethernet、Fastethernet、Gigabitethernet)所在的模块,mod表示端口所在的模块,port表示该模块中的编号)

    (2)选择多个端口:Switch(config)interface type mod/startport-endport

    (3)设置端口通信速度:Switch(config-if)#speed[10/100/auto]

    (4)设置端口单双工模式Switch(config-if)#duplex[half/full/auto]

    (5)思科三层交换机开启路由功能:Switch(config)#ip routing

    5.密码设置

    (1)设置进入特权模式的密码:Switch(config)#enable password ******

    (2)可以设置通过console端口连接及Telnet远程登录时所需的密码:Switch(config-line)#

    (3)配置控制台线路,0是控制台的线路编号:Switch(config)#line console 0

    (4)用于打开登录认证功能:Switch(config-line)#login

    (5)设置进入控制台访问的密码:Switch(config-line)#password 5ijsj

    展开全文
  • cisco思科交换机-常用命令配置

    万次阅读 多人点赞 2020-05-22 15:28:06
    switch> 用户模式 1:进入特权模式enable switch> enable switch# ...3:交换机命名hostname name 以cisco001 为例 switch> enable switch#c onfigure terminal switch(conf)#hostname cisc
  • 一般来说,可以用5种方式来设置路由器: 1.Console口接终端或运行终端仿真软件的微机; 2.AUX口接MODEM,通过电话线与远方的终端或运行终端仿真软件的微机相连; 3.通过Ethernet上的TFTP服务器;...
  • 思科交换机常用命令配置

    千次阅读 2019-10-01 10:19:13
    打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。 Switch>enable Switch# 2 从特权模式进入全局配置模式 Switch#configure terminal Switch(config)# 3 ...
  • 思科交换机常用配置命令》学习笔记(更新中)

    万次阅读 多人点赞 2018-12-09 13:21:40
    1、基本配置 Switch&gt;enable //进入特权模式 Switch# Switch#configure terminal //从特权模式进入全局配置模式 ...cisco-sw1(config)#enable password cisco //配置交换机明文密码,登录特...
  • 思科交换机配置命令详解,思科交换机用途广泛,面积越来越大,了解命令是管理的基础
  • Cisco交换机配置命令

    2018-08-21 14:02:09
    命令针对Cisco的命令行
  • 在写路由过程中不用再记那烦索的命令了,希望对大家有用。 用户模式: 用户模式: Router> Router> 特权模式: 特权模式: Router>en Router>enable Router# Router# 全局配置模式 全局配置模式 Router#conf t Router...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,466
精华内容 3,386
关键字:

思科交换机配置命令