ie8 订阅
北京时间2008年3月6日,微软发布了InternetExplorer 8的第一个公开测试版本(beta1)。本次测试第一次包涵简体中文(3月27日推出)版本。测试版本仍然是在IE7的架构下改进的。界面除了做一些细微的调整,增加少许实用功能外,并无改进。beta1版本推出了模拟IE7的模式、增加了在线邮件浏览功能、提高了兼容性、反钓鱼功能进一步增强,可以进行网页地址筛选。 展开全文
北京时间2008年3月6日,微软发布了InternetExplorer 8的第一个公开测试版本(beta1)。本次测试第一次包涵简体中文(3月27日推出)版本。测试版本仍然是在IE7的架构下改进的。界面除了做一些细微的调整,增加少许实用功能外,并无改进。beta1版本推出了模拟IE7的模式、增加了在线邮件浏览功能、提高了兼容性、反钓鱼功能进一步增强,可以进行网页地址筛选。
信息
软件名称
IE浏览器 8
上线时间
2008年3月6日
发行日期
2009年3月20日
原版名称
Internet Explorer 8
发行阶段
正式版
软件语言
默认英文,有多国语言包(一共25种)
终止时间
2016年1月12日
开发商
微软(Microsoft)
销    售
微软(Microsoft)
软件版本
IE 11
软件平台
WinXP~Win7
发行公司
微软(Microsoft)
软件大小
24.60 MB
最近更新时间
2009年3月20日
软件授权
微软
简    称
ie8
Internet Explorer 8.0运行环境
Windows XP和Windows7
收起全文
精华内容
下载资源
问答
  • 浏览器兼容 谷歌IE8.js,IE9.js下载

    热门讨论 2016-01-29 16:29:26
    浏览器兼容 谷歌IE8.js,IE9.js下载
  • easyui新版本不再兼容IE8及以下版本。 低版本的easyui也不能使用太高版本的jquery。 so,备份一份可以在有需要兼容IE8-的项目里使用的组合。
  • IE8离线安装文件(不需要外网)

    热门讨论 2015-01-09 18:15:56
    IE8离线安装文件,不需要外面安装。局域网安装的好程序。
  • IE8绿色版 for win7

    千次下载 热门讨论 2013-03-20 15:18:08
    使用thinapp制作的IE8,能与其他windows自带的IE兼容运行在win7(或其他操作系统)中。我的资源中还有IE6 for win7,IE7 for win7。全部都能同时独立运行,为前端开发在兼容问题上带来便利。制作方法请google:thinapp
  • IE8绿色版(单个exe文件,不与系统中浏览器冲突)

    千次下载 热门讨论 2012-06-21 13:59:54
    IE8绿色版(单个exe文件,不与系统中浏览器冲突) 现在大多数系统都已经用IE9了,对于开发人员需要测试与IE7的兼容性找一款IE6的操作系统比较困难. 网上找到的都说用IETester,但我实际测了并不能百分百还原IE8, 使用...
  • IE8-WindowsXP-x86离线完整安装包

    千次下载 热门讨论 2013-03-11 21:16:29
    IE8-WindowsXP-x86离线完整安装包
  • IE8 简体中文语言包

    热门讨论 2012-05-02 17:03:30
    IE8 简体中文语言包 安装IE8英文版后可直接安装此语言包进行汉话
  • IE8能正常显示applet Java IE插件

    千次下载 热门讨论 2011-02-18 21:30:10
    Java IE插件,IE8能正常显示applet
  • httpwatch(IE9.IE8,IE6)

    热门讨论 2012-12-01 01:18:17
    httpwatch (IE9.IE8,IE6) 适用(IE9.IE8,IE6) 测试过的
  • IE8汉化包下载

    热门讨论 2008-08-01 15:00:00
    IE8汉化包下载后解压缩后.复制在X:\\Windows\\System32\\en-US下. 2.加入你是直接复制进去的话,可能会报错误.所以请你把原来那个ieframe.dll.mui文件改个名然后再把这个mui文件复制进去. 3.接着就是重起IE...
  • 兼容IE8的多文件上传实现

    万次阅读 2019-12-11 23:40:11
    兼容IE8的注意点: 原生多文件属性multiple只在IE10/11上有效,IE8不兼容无法使用 formdata对象同样只支持在IE10/11,IE8无法使用 很多API在IE8上无法使用,同样是兼容的难点 IE8的安全机制,使一些操作无法实现...

    兼容IE8的注意点:

    1. 原生多文件属性multiple只在IE10/11上有效,IE8不兼容无法使用
    2. formdata对象同样只支持在IE10/11,IE8无法使用
    3. 很多API在IE8上无法使用,同样是兼容的难点
    4. IE8的安全机制,使一些操作无法实现

    本文使用原生JS对文件进行简单处理实现多文件上传,未使用其他插件。

    实现思路:

    由于multiple属性无法使用,采取通过增加input框的方式实现多文件的选择和存储,故单次只能选择一个文件,可选择多次。

    选择完一个文件之后,调用方法隐藏input,并将文件名以列表形式显示出来,并提供删除选项。

    效果图:

    效果图

    实现代码:

    <!DOCTYPE html>
    <html>
    
    <head>
        <title>多文件上传</title>
        <meta charset="utf-8">
        <style>
            .file-select{
    			position: relative;
    		}
    		/*设置透明*/
    		.file-select input[type=file]{
    			position: absolute;
    			width: 50px;
    		    filter: progid:DXImageTransform.Microsoft.Alpha(opacity=0);
    		    -ms-filter: progid:DXImageTransform.Microsoft.Alpha(opacity=0);
    		    opacity: 0;
    		    -webkit-opacity: 0;
    		    -moz-opacity: 0;
    		    z-index: 100;
    		}
    		.brower{
    			display: inline-block;
    			width: 50px;
    			position: absolute;
    			left: 0px;
    			color: skyblue;
    		}
    		.file-select input:hover + span.brower{
    			text-decoration: underline;
    		}
    	</style>
    </head>
    
    <body>
        <form action="hello.do" method="post" enctype="multipart/form-data">
            <div id="eee">
                <span>选择文件:</span>
                <input type="submit"  value="提交" />
                <br />
                <div class="file-select" id="file_div1">
                    <input type="file" name="UploadFile" onchange="fileChange()" />
                    <span class="brower">浏览</span>
                    <input type="button" onclick="deleteDiv()" style="display: none;" value="删除" />
                </div>
            </div>
        </form>
        <script>
        var FILECOUNT = 1;
    
        function fileChange() {
    
            var preDiv = document.getElementById("file_div" + FILECOUNT);
            var nextDiv = preDiv.cloneNode(true);
            FILECOUNT = FILECOUNT + 1;
    
            // 添加新的div
            nextDiv.setAttribute("id", "file_div" + FILECOUNT)
            document.getElementById("eee").appendChild(nextDiv);
    
            // 对已选完文件的div进行处理
            var preFile = preDiv.children[0],
                preSpan = preDiv.children[1],
                preButton = preDiv.children[2];
            preFile.style["display"] = "none";
            preSpan.className = "";
            preSpan.innerHTML = preFile.value;
            preButton.style["display"] = "inline-block";
    
    
        }
    
        // 删除方法
        function deleteDiv(event) {
            var ev = event || window.event;
            var target = ev.target || ev.srcElement;
            document.getElementById("eee").removeChild(target.parentNode);
        }
        </script>
    </body>
    
    </html>

    持续更新:github地址

    展开全文
  • ie8 for win7(windows7旗舰版内提取)

    千次下载 热门讨论 2010-05-25 10:23:44
    ie8 for win7(windows7旗舰版内提取) win7 内IE 崩溃后可用此包替换
  • IE8升级IE11失败原因整理

    万次阅读 2018-12-03 20:04:30
    因为要用vs2015+编程,导致必须要把win7中的自带ie8升级到ie11。=,=可是升级的路却坎坎坷坷。 升级方式有两种 1、win7自动升级【至少需要1G+】 2、IE11安装包升级【x64 50M x86 30M】 升级中往往会失败,过程会...

    因为要用vs2015+编程,导致必须要把win7中的自带ie8升级到ie11。=,=可是升级的路却坎坎坷坷。

    升级方式有两种

    1、win7自动升级【至少需要1G+】

    2、IE11安装包升级【x64 50M  x86 30M】

    升级中往往会失败,过程会记录在C会indows目录下【IE11_main】,然后在桌面上生成一个页面链接。

    如下:

    那个页面链接会指向一个页面,告诉用户解决办法。比如缺少一些补丁。

    x64如下:

    x86如下:

    一般到这一步,很多人都成功了,而我很不幸,还是失败。纳闷的,最狠的一次让我重新装了一次系统。造孽啊。尤其是作为开发来说。

    然而这次因换电脑让我又碰到了,实在不想装系统,试了第2种方式,发现不行,后面又换到第1种方式。还是不行。

    试了试很多IE11升级包

    无意中升级时,看到了金山提醒IE11升级包修改游览器主页被拦截了。让我感觉有点意外,难不成是和这个有关系?

    我就把这些锁定全部解开。重新升级IE11。终于成功了。

    展开全文
  • vue兼容IE8以上解决方案

    千次阅读 2020-07-11 14:25:47
    三、还未解决看下面的操作 1、当你的语法比较规则的时候,可能按照上面的就可以兼容IE8以上了。 2、报错 SCRIPT1006: 缺少 ')' 打开IE F12 如上图提示app.js 12104行报错。点击进入查看。 查看之后,很快就能明白...

    一、说明背景

    vue主要采用了ES6 Promise,我们知道的,在 JavaScript 中,所有代码都是单线程的,也就是同步执行的。而 Promise 就为异步编程提供了一种解决方案。

    二、解决方案

    1、采用 babel-polyfill 进行转换语法。

    2、安装babel-polyfill

    npm install -S babel-polyfill

     3、main.js 引入babel-polyfill

    import 'babel-polyfill'

    注意:babel-polyfill 默认会把node_modules 进行过滤出来(这就是很多引入了babel-polyfill还是不能解决兼容性问题的根本原因)

    三、还未解决看下面的操作

    1、当你的语法比较规则的时候,可能按照上面的就可以兼容IE8以上了。

    2、报错 SCRIPT1006: 缺少 ')'

    • 打开IE F12 
    • 如上图提示app.js 12104行报错。点击进入查看。
    展开全文
  • IE11兼容IE8的设置

    千次阅读 2019-09-24 22:53:25
    那么ie11浏览器怎么设置兼容IE8呢?下面就让小编给大家介绍一下吧。 首先我们打开电脑里面的ie11浏览器,然后找到右上角的设置按钮,并点击。 在设置里面,我们找到兼容性视图设置,并...

    我们在使用ie11浏览器的时候,有些网站的兼容性不是太好,这个时候就要设置下ie11的兼容性了。那么ie11浏览器怎么设置兼容IE8呢?下面就让小编给大家介绍一下吧。

     

    1. 首先我们打开电脑里面的ie11浏览器,然后找到右上角的设置按钮,并点击。

       

    2.  在设置里面,我们找到兼容性视图设置,并点击。

       

    3.  在兼容性视图设置页面,我们添加需要添加到兼容性视图中的网站。添加之后直接点击下面的关闭就可以了。
       
    4.  然后我们再找到设置里面的f12开发人员工具。直接按键盘的快捷键f12也是可以的。

       

       

    5.  在弹出开发人员工具之后,我们在右上角找到一个电脑形状的按钮然后点击他后面的下拉菜单按钮。

       

       
    6.  我们可以看到,现在默认选择的是11,我们直接选择下面的8就可以了。这样我们就设置好了ie11浏览器兼容IE8。

       

    转载于:https://www.cnblogs.com/jason223233/p/11409064.html

    展开全文
  • ie8视频播放器兼容

    千次阅读 2019-01-24 10:12:43
    今天做一个pc端的视频播放,要兼容ie8,在网上看了很多文章,整了都不行。最后是问了一个上一家公司的后台大佬,用ckplayer.js插件做,直接贴代码 先引入ckplayer.js &lt;script src="...
  • ie8中rem 与ie兼容性

    千次阅读 2020-03-24 19:48:54
    ie8中rem 与ie兼容性 web开发中经常会在css中用到rem单位,但是在ie8ie8以下不支持rem单位。 解决方法: 可以使用rem.js这个插件来使其自适用rem.js; 要注意将其引入在页脚,也就是css,dom加载完才能执行...
  • 【css】兼容IE8IE8以下伪类选择器

    千次阅读 2017-12-05 11:52:39
    但有个麻烦,IE8IE8以下对很多伪类选择器并不兼容。这六个伪类选择器是比较长用到的:这时会发现,IE9对这些伪类选择器都兼容。IE8、IE7除了的 :first-child 是兼容的,其他五个都不兼容。兼容:&lt;body&...
  • IE11怎么设置默认以IE8的方式解析

    千次阅读 2018-11-02 21:23:18
    IE11仿真 调试IE8效果,一般情况下可以用IE11的仿真来弄 但是关闭F12工具后,默认会切换会11模式,我们可以通过通过 保留仿真设置 里防止其自动切回11。 ...
  • 记一次webpack4.x打包兼容ie8 的经历

    千次阅读 2019-08-15 03:27:51
    记一次webpack4.x打包兼容ie8 的经历 写在前面 打包经历中没有用到Promise等语法,只用到了es6的一些语法书写逻辑 webpack使用的是4.x ; babel 使用的是7.x 不一定适用于所有要兼容ie 8 的场景,请注意 背景: ...
  • IE8不支持let 添加js可以是IE8支持

    千次阅读 2019-12-19 17:26:02
    引入browser.min.js IE8支持ES6。 也可以不使用let关键字定义。
  • vue ie8 兼容方案

    万次阅读 2018-10-18 15:45:30
    项目的最后上线,客户提出必须要 兼容IE8 最后的最后,只能寻求解决兼容方案了。在先用的双向绑定的框架中,我选用了 avalon2 avalon2是一款基于虚拟DOM与属性劫持的 迷你、 易用、 高性能 的 前端MVVM框架, ...
  • 判断是否IE浏览器极其版本主要是三种方法,第一种是通过 if IE 条件注释语句,第二种是通过 @cc_on 条件编译结合 document.documentMode 属性来判断,第三种则是简单粗暴地通过 JS 语句判断 navigator.userAgent ...
  • 今天项目中遇到一个问题需要前端解决:在IE8浏览器的环境下,进入登录页,页面会一直刷新,肉眼看到的效果就是不停地闪烁。但是在其他高版本浏览器中就不会出现这个问题。 我的第一反应就是:浏览器的兼容性问题。...
  • ie8兼容性ie8缺少SCRIPT1010: 缺少标识符 SCRIPT1010: 缺少标识符 ,一般是在IE下会出现这个问题。 今天在调试一段js代码时,在chrome,ff下均正常,但是在IE下就是一直这样的提示,出现这个问题的原因主要有...
  • React兼容IE8

    千次阅读 2018-10-09 10:55:39
    查找网上的React兼容IE8的方法,也发现不少的项目去兼容,而且都修改成功了,但我按照他们的修改方法去改我的框架的时候还是发现很多细节和他们的不一样。下面进行一个修改总结: 一、按照官方微博的公布信息,支持...
  • 如何将360浏览器兼容IE8、IE7

    千次阅读 2019-06-18 10:23:29
    如何将360浏览器兼容IE8、IE7写此博客的原因直接上图,方便大家 写此博客的原因 好多时候我们的电脑已经升级了,针对不同IE8以及以前的浏览器和现在的浏览很难兼容,但是你为了一些原因不得不使用低版本的浏览器...
  • WinXP升级IE6至IE8: WinXP 至少升级至SP3(WINXP-SP3)后,才能进行升级。 一般安装IE8的离线升级包,重启安装IE8即可,如果安装不了,应该是系统精简了。 WIN7下IE8升级至IE11: WIN7至少升级至SP1(WIN7-SP1)后,...
  • IE8下实现pdf预览

    万次阅读 2018-08-27 21:37:44
    项目中遇到一个问题,需要在IE8下能够直接预览pdf,在百度上进行查找,很多帖子都是说需要安装pdf.js和pdfobject.js,但是,这两个js在IE8下是不支持的。 后来,在google上进行查找,找到了这篇帖子,还是在官网上...
  • ueditor ie8兼容性问题

    千次阅读 2017-09-21 19:14:43
    ie8情况下,在进入加载有uEditor编辑器页面时候,不显示工具栏,会提示ueditor 缺少对象或者出现错误 1.引用Ueditor的js 的时候用绝对路径 网上搜出来的一种解决方法 不过我通过该方法没有解决 而且放到...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,092,911
精华内容 437,164
关键字:

ie8