精华内容
下载资源
问答
  • “The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.”,在web开发的过程中,看到这一段错误提示,不管是在入门阶段还是已经是web...

    写在前面

    “The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.”,在web开发的过程中,看到这一段错误提示,不管是在入门阶段还是已经是web老手都会感到很头痛。我也是在使用JSTL库的过程中,出现了这个问题,困扰了我很长时间才搞定的,所以决定有必要写一篇博客,碰到这个问题真的非常令人头痛,我这里解决了之后,就想着总结一下各种解决方法,希望能给还在苦海的朋友一些帮助,还是挺有用的。动动手指头,点个关注和点个赞,不胜感激

    问题一(也是我碰到的问题)

    我在web开发中,为了配置JSTL库改动了web.xml,手残不小心把文件的部署路径写错了,所以导致了出现这个问题,这还是我自己看了eclipse的console出错信息才发现的,所以console的出错信息还是很有用的

    问题二

    试一试调节Project的 Build,如图勾选:

    问题三

    双击Tomcat,进入调节,当然双击前必须先移除Tomcat Server中的项目,这样才可以更改其中的设置,如图:

    问题四

    一定要注意路径是否有错误,这个是很愚蠢的问题。

     

    问题五

    xml的版本问题,在Eclipse编译器中右键项目—>Properties—>Project Facets—>Dynamic Web Module 如图:

    问题六

    检查文件是否有加载至Tomcat下的webapps目录下

    这是我知道的一些问题,不够全面,但是希望能帮助到一些人。

     

     

    展开全文
  • Failed to configure a DataSource: 'url' attribute is not specified and no embedded datasource could be configured. 翻译就是:无法配置DataSource:未指定'url'属性,也无法配置嵌入数据源。 很明显,...

    Failed to configure a DataSource: 'url' attribute is not specified and no embedded datasource could be configured.

    翻译就是:无法配置DataSource:未指定'url'属性,也无法配置嵌入数据源。

     

    很明显,就是你在应用中没有配置datasource的一些相关属性,例如:地址值啊,数据库驱动啊,用户名啊,密码啊,

     

     

    都知道,SpringBoot的最大一个好处就是自动配置:所以我们只是需要给他配置文件的值,它就会自动配置。配置在application.properties文件中

    那么我将把SpringBoot的一些最基本的配置信息给大家站出来:

    #访问根路径
    
    #应用名称
    spring.application.name=springboot-demo
    
    #访问端口号
    server.port=8080
    
    #编码格式
    server.tomcat.uri-encoding=utf-8
    
    #数据库相关配置
    spring.datasource.driver-class-name=com.mysql.cj.jdbc.Driver
    spring.datasource.url=jdbc:mysql://localhost:3306/sql_test
    spring.datasource.username=root
    spring.datasource.password=123456
    spring.datasource.max-idle=10
    spring.datasource.max-wait=10000
    spring.datasource.min-idle=5
    spring.datasource.initial-size=5
    
    #session生命周期
    server.servlet.session.timeout=30m
    
    
    
    
    
    

     

    当然,也可以不配置,但是你需要声明一下

    启动类头部声明就可以了:

    @SpringBootApplication(exclude= {DataSourceAutoConfiguration.class})

     

    展开全文
  • python对缩进具有严格的要求稍微一步留神就会发生unindent does not match any outer indentation level的错误,发生错误的原因一般有三点:1、代码前后缩进量不一致可以看到def前面有红色小波浪线,说明在这里出现...

    python对缩进具有严格的要求,稍微一不留神就会发生unindent does not match any outer indentation level的错误,发生错误的原因一般有三点:


    1、代码前后缩进量不一致

    这里写图片描述

    可以看到def前面有红色小波浪线,说明在这里出现了缩进错误,显然def前面的注释缩进量和def不一致(一个为2一个为4),改成一致就好了

    这里写图片描述


    2、代码前后缩进符号不一致

    这里写图片描述

    上图中两个函数的定义前面缩进都是一样的,但是在x=3后面出现错误提示,说明在句附近(前后)出现了缩进错误,将鼠标移到高亮黄色区域或者红色波浪线错误区域都会显示错误信息:

    这里写图片描述

    这里写图片描述

    从错误信息中可以看到,x=3与下面的缩进不匹配,进一步在第二幅图中可以看到提示:不连续的缩进,上一行的缩进使用的tab缩进而这一行使用的是sapce缩进,显然,将def test2前面的缩进改成tab就OK了

    这里写图片描述

    同样,将y=3前面的缩进也修改一下就行了

    3、tab与space混用

    这个很显然,如果你在一段代码前面即使用空格又使用tab进行缩进,自然会发生错误,这个时候pycharm会自动进行判断,根据你设置的预先缩进值(intentaion)进行调整

    这里写图片描述

    你设置的缩进值上面的设置中进行设置,一般为4,上图为3。

    ####如果你打开别人的python程序或者python脚本,很有可能出现缩进错误,这时只要修改错误地方的缩进量即可。或者使用全局替换对代码中的空格和缩进进行替换

    采用Crtl+H的快捷键进行替换即可

    这里写图片描述

    在上图中统一将制表符tab(\t)替换为4个空格,注意在替换符号时需要勾选Regex选项,图中绿色区域为tab区域,黄色区域为空格区域

    如果你与我志同道合于此,很愿意与你交流
    如果你喜欢我的内容,欢迎关注和支持
    微信公众号 : oldpan博客
    神秘链接 : oldpan.me

    展开全文
  • 问题描述: 使用Eclipse自带的Maven插件创建Web...Could not resolve archetype org.apache.maven.archetypes:maven-archetype-webapp:RELEASE from any of the configured repositories. Could not resolve artifa

    问题描述:

            使用Eclipse自带的Maven插件创建Web项目时报错:

    Could not resolve archetype org.apache.maven.archetypes:maven-archetype-webapp:RELEASE from any of the configured repositories.
    Could not resolve artifact org.apache.maven.archetypes:maven-archetype-webapp:pom:RELEASE
    Failed to resolve version for org.apache.maven.archetypes:maven-archetype-webapp:pom:RELEASE: Could not find metadata org.apache.maven.archetypes:maven-archetype-webapp/maven-metadata.xml in local (C:\Users\liujunguang\.m2\repository)
    Failed to resolve version for org.apache.maven.archetypes:maven-archetype-webapp:pom:RELEASE: Could not find metadata org.apache.maven.archetypes:maven-archetype-webapp/maven-metadata.xml in local (C:\Users\liujunguang\.m2\repository)

    错误如图:

     

    解决方案:

    1. 在Eclipse Maven配置中添加新的Catalog配置:

     
    2. 也可以下载到本地,然后再添加,这样比较快(推荐)
     
         如图:

     

     

    接下来在使用刚添加的catalog创建web工程

          

        这个时候就可以看到Eclipse联网下载了:

         
    这个时候看一下是不是创建成功了

     

    如果还是不能创建或者问题没有解决可以安装下面的方法:

    1.删除maven已经下载的文件路径:.m2\repository\org\apache\maven

    删除之后再试下,这时候如果看到有进度,只需要耐心等待就行了

     

    2.Maven下载jar慢可以使用国内阿里镜像

    具体配置文件(settings.xml)如下,放在.m2文件夹下,.m2一般位于用户目录下

    打开 maven 的配置文件( windows 机器一般在 maven 安装目录的 conf/settings.xml ),在<mirrors></mirrors>标签中添加 mirror 子节点:

    <mirror>
      <id>aliyunmaven</id>
      <mirrorOf>*</mirrorOf>
      <name>阿里云公共仓库</name>
      <url>https://maven.aliyun.com/repository/public</url>
    </mirror>
    如果想使用其它代理仓库,可在<repositories></repositories>节点中加入对应的仓库使用地址。以使用 spring 代理仓为例:
    <repository>
      <id>spring</id>
      <url>https://maven.aliyun.com/repository/spring</url>
      <releases>
        <enabled>true</enabled>
      </releases>
      <snapshots>
        <enabled>true</enabled>
      </snapshots>
    </repository>

    参考文档:https://maven.aliyun.com/mvn/guide

    展开全文
  • org.apache.ibatis.binding.BindingException: Invalid bound statement (not found)问题,即在mybatis中dao接口与mapper配置文件在做映射绑定的时候出现问题,简单说,就是接口与xml要么是找不到,要么是找到了却...
  • 笔者使用的Navicat Premium 12启动界面截屏: 请注意是64位的。...连接Oracle时提示“oracle library is not loaded”。 解决方法: 1.前往“http://www.oracle.com/technetwork/database/database-te...
  • TypeError: not all arguments converted during string formatting 举例 例如: &amp;gt;&amp;gt;&amp;gt; strs=(1,2,3,4) #创建一个集合 &amp;gt;&amp;gt;&amp;gt; ...
  • (Python)解决NameError: name 'XXX' is not defined的问题

    万次阅读 多人点赞 2019-02-26 16:04:14
    在编辑代码时,如果需要采用非本代码所在文件夹下的代码文件的函数或者类时,那么需要添加该代码文件所在路径,否则会报“NameError: name 'XXX' is not defined”的错误,其实解决方案也非常简单,只要使用sys函数...
  • Linux下提示bash:command not found解决方法小结

    万次阅读 多人点赞 2019-04-19 14:33:58
    0x00 前言 文章中的文字可能存在语法错误以及...1.前几次还好用的命令,这次再输入就出现-bash: ***: command not found的情况; 2.第一次使用就出现 -bash: ** : command not found的情况。 导致这种问题的原...
  • 完美解决Linux上执行 #tar -xvf jdk-8u131-linux-x64.tar.gz命令后报错问题 gzip: stdin: not in gzip format tar: Child returned status 1 tar: Error is not r
  • TypeError: ‘int‘ object is not iterable

    万次阅读 多人点赞 2018-09-20 16:12:28
    Python写循环程序的时候遇到 TypeError: ‘int’ object is not iterable,原因是循环中使用的应该是一组数,将 for i in len(A) 改成 for i in range(len(A)) 即可
  • Pytorch错误:Torch not compiled with CUDA enabled

    万次阅读 多人点赞 2020-04-24 12:20:57
      在用Pytorch炼丹的过程中,很意外地碰到了一个错误提示AssertionError: Torch not compiled with CUDA enabled,如下图所示。 错误提示   代码本身可以确定是没有问题的,因为只是在往日已经跑过的代码上加入...
  • 上篇中将本地SSH添加到... fatal: Not a git repository (or any of the parent directories): .git 提示说没有.git这样一个目录 在命令行 输入 git init 然后回车就好了 再重新执行添加文件的命令即可。 ...
  • linux中vim: command not found

    万次阅读 多人点赞 2019-03-26 00:16:31
    bash vim: command not found1.查看系统是否安装完整vim2.安装vim3. 我的解决过程 这个问题首先就是vim是否安装 解决问题步骤: 1.查看系统是否安装完整vim 执行一下命令: rpm -qa|grep vim 如果已经正确安装的话...
  • 错误:was not registered for synchronization because synchronization is not active 解决思路: 1)对应的sql中出现了ParamterType对应的实体类中缺少的字段。 比如:if标签中,对name是否为空进行了判断。...
  • Linux -bash: java: command not found 解决方法
  • 今天在电脑上安装了Mysql 8.0.11,然后又屁颠屁颠地安装了Navicat for MySQL,打开Navicat准备链接数据库的时候出现了如下提示: 上网搜索解决方案,网上说出现这种情况的原因是:mysql8 之前的版本中加密规则是...
  • 解决 js 报错 xxx is not defined

    万次阅读 2019-02-16 14:32:29
    报错信息:Uncaught ReferenceError: xxx is not defined 处理该问题从下面几个方面入手: 检查 xxx的 js文件是否已经引入到该页面 检查xxx的 js文件的路径是否有问题 检查 xxx的 js文件的引用顺序 检查 js ...
  • 解决 primordials is not defined 问题

    万次阅读 多人点赞 2019-11-10 18:24:49
    在安装npm依赖的时候碰到了ReferenceError: primordials is not defined的问题, 搜索发现是安装gulp版本与node版本不兼容的问题, 我的项目gulp版本是3.9.1, 本地node版本是12.4.0 stackoverflow给出的方法是回退...
  • 解决default activity not found办法大全

    万次阅读 多人点赞 2019-08-26 14:08:37
    最近在项目中遇到一个问题,就是以前用android studio能正常打开的工程,今天突然报default activity not found错误,该错误导致app那块显示一个红叉,无法直接launch app,可以build工程产生apk文件,但是不能用...
  • scp 报错 not a regular file

    万次阅读 2018-03-09 10:53:30
    scp 报错 not a regular file两台 linux 服务器之间拷贝文件;从 A 服务器(192.168.1.113) 拷贝到 B 服务器:命令: scp test2 dafei@192.168.1.113:/data/www/test/报错:test2: not a regular file原因:这样...
  • python运行报错 KeyError: “[‘year’] not in index”

    万次阅读 多人点赞 2020-05-14 21:57:20
    学习时,编写Python代码的时候,报了下面的错误 KeyError: “[‘year’] not in index” 。 问题描述 学习数据可视化的时候,调用到 pandas 包,代码运行报错,错误提示如下 KeyError: "['year'] not in index" 键...
  • Could not transfer artifact xxx from/to xxx的解决方案

    万次阅读 多人点赞 2018-11-10 20:54:33
    Could not transfer artifact xxx from/to xxx解决方案问题描述解决步骤 问题描述 本地仓库有对应的jar包,但是maven install 一直提示 Could not transfer artifact。折腾了我老半天 Failed to read artifact ...
  • required string parameter 'XXX'is not present 的几种情况 情况一:原因是由于头文件类型不对,可以在MediaType中选择合适的类型,例如GET和POST 情况二:jquery提交delete时,不支持@RequestParam,只支持@...
  • 原因是最近xlrd更新到了2.0.1版本,只支持.xls文件。所以pandas.read_excel(‘xxx.xlsx’)会报错。 可以安装旧版xlrd,在cmd中运行: pip uninstall xlrd pip install xlrd==1.2.0
  • TypeError: this.getOptions is not a function

    万次阅读 多人点赞 2021-02-02 13:42:17
    今天用webpack打包项目,安装了less-loader模块之后报错,如下图: 原因: less-loader安装的版本过高 解决方案: 1.npm uninstall less-loader 2.npm install less-loader@5.0.0
  • Session ‘app’: Installation did not succeed. The application could not be installed: INSTALL_FAILED_USER_RESTRICTED 上面显示安装程序失败,原因在于用户权限不够。 单词restrict...
  • Host is not allowed to connect to this MySQL server解决方法

    万次阅读 多人点赞 2017-01-12 22:46:38
    今天在Linux上面装完MySQL,却发现在本地登录可以,但是远程登录却报错Host is not allowed to connect to this MySQL server,找了半天试了网上的一些方法都没有解决,最终在一篇文章里找到了解决方法,特意记录一下...
  • 对于大于100M的文件,爬取时会得到user is not authorized, hitcode:119的返回值。 不知道什么时候开始,百度网盘禁止非客户端环境下载大文件。 所以爬取内容时,将User-Agent修改 本来你请求头中的User-Agent是...
  • thymeleaf + Spring Boot 在开发环境正常,但用jar运行时报错 Error resolving template template might not exist or might not be accessible; 这个问题我们都很好明白,就是模板页不存在,但是实际上它能找到...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,206,264
精华内容 2,082,505
关键字:

not