精华内容
下载资源
问答
  • 三层交换技术

    2021-08-10 19:18:33
    众所周知,传统的交换技术是在OSI网络标准模型中的第二层——数据链路层进行操作的,而三层交换技术是在网络模型中的第三层实现了数据包的高速转发。简单地说,三层交换技术就是:二层交换技术+三层转发技术。 二、...

    目录

    一、什么是三次交换技术

    二、工作原理

    三、三层交换实验

     四、总结


    一、什么是三次交换技术

            三层交换(也称多层交换技术,或IP交换技术)是相对于传统交换概念而提出的。众所周知,传统的交换技术是在OSI网络标准模型中的第二层——数据链路层进行操作的,而三层交换技术是在网络模型中的第三层实现了数据包的高速转发。简单地说,三层交换技术就是:二层交换技术+三层转发技术。

    二、工作原理

            三层交换机要执行三层信息的硬件交换,路由处理器必须将有关路由选择的三层信息下载到硬件中。以便对数据包进行处理。为完成在硬件中的处理数据包的高层信息,会使用传统的MLS和基于CEF的MLS。

            传统的MLS:交换机要将流中的第一个数据包给第三层引擎,后者一软件交换的方式对数据包进行处理,对数据流中的第一个包进行路由处理后,第三层引擎对硬件交换组织进行编程,使之后的数据包进行选择路由,这个过程被称作为:一次路由多次交换。

            基于CEF的MLS:CEF预先根据路由表中学习的路由信息直接储存在FIB(转发信息表),REF预先根据ARP表生成邻接关系表,直接由硬件进行转发。

            工作原理:

            1.主机a给b发单播数据包

            2.交换机查找FIB表,找下一个地址。

            3.查找下一跳地址对应的邻接关系的2层封装信息

            4.转发

    三、三层交换实验

            实验所需:一台三层交换机和两台pc。

             配置PC7与PC8的IP地址以及子网掩码和网关。

             进入三层交换机进行配置

            在PC7上ping对方IP查看是否成功

     四、总结

            三层交换技术的出现,解决了局域网网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。

            有了三层交换机还要路由器做什么呢?当然路由器有其不具备的功能。路由器端口类型多,支持的三层协议多,路由能力强,所以适合于在大型网络之间的互连,虽然不少三层交换机甚至二层交换机都有异质网络的互连端口,但一般大型网络的互连端口不多,互连设备的主要功能不在于在端口之间进行快速交换,而是要选择最佳路径,进行负载分担,链路备份和最重要的与其它网络进行路由信息交换,所有这些都是路由器才能完成的功能。

     

    展开全文
  • 三层交换技术及配置

    2021-03-16 11:10:59
    三层交换技术及配置实例一、三层交换技术概述二、三层交换的配置三、三层交换配置示例 一、三层交换技术概述 随着Internet的发展,局域网和广域网技术得到了广泛的推广和应用。数据交换技术从简单的电路交换发展到二...

    一、三层交换技术概述

    随着Internet的发展,局域网和广域网技术得到了广泛的推广和应用。数据交换技术从简单的电路交换发展到二层交换,从二层交换又逐渐发展到今天较成熟的三层交换,以致发展到将来的高层交换。 三层交换技术就是:二层交换技术+三层转发技术。它解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。

    1、三层交换的原理(一次路由,多次交换)

    三层交换技术可以实现VLAN间通信
    三层交换 = 二层交换 + 三层转发
    当三层设备接收到一个数据帧,会拆除原数据帧,重新封装新的源MAC地址和目标MAC地址,并且因为帧头部的信息发生变化,最后的帧校验CRC也应当随之改变。
    在这个流中的多个数据包,其中只有第一个数据包是由三层交换机的三层引擎来处理的,处理的方式是软件方式,与路由器相同,三层引擎获取了新的2层封装信息后,路由这个数据包。
    在第一个数据包转发完成后,在硬件中创建一个MLS条目,用于后续的数据包由硬件执行的重新封装和快速转发。2层数据帧会被重新封装为需要转发的下一个网段的帧格式。
    这就是MLS “一次路由,多次交换”的原理。"
    在这里插入图片描述

    2、基于CEF的MLS

    基于CEF(一种基于拓扑转发的模型)的MLS,其关键是两张转发信息表,转发信息库(FIB)与路由表一一对应,是路由表的一个镜像。路由表更新时,FIB随之变化,其中FIB包含邻接主机的IP地址与VLANID的对应关系。而邻接关系表包含邻接主机和交换机MAC地址的对应关系用来提供二层重写信息。
    基于CEF的MLS转发过程,即发送单播数据包,通过查找FIB和邻接关系表,重新封装数据帧,从相应端口进行转发。

    在这里插入图片描述

    二、三层交换的配置

    三层交换机具备路由功能,所以两个VLAN之间可以互相访问,每一个VLAN虚接口就是该网段的网关。

    ####在三层交换机上配置的VLAN接口为虚接口
    [Huawei]interface Vlanif 10
    [Huawei-vlanif10]ip address 192.168.10.1 24
    [Huawei-vlanif10]display ip interface brief   ###端口自动激活

    三、三层交换配置示例

    主机:PC1,PC2,PC3,PC4
    交换机:SW1
    路由器:R1,R2
    在这里插入图片描述

    配置R1
    在这里插入图片描述

    配置R2
    在这里插入图片描述
    配置SW1
    在这里插入图片描述

    在这里插入图片描述查看交换机SW1配置

    在这里插入图片描述
    在这里插入图片描述
    设置三层交换机作为路由器的默认路由,因为是默认网段,所以不能主动连接,所以要设置默认路由
    在这里插入图片描述
    配置主机
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    检测主机之间是否连通(ping)
    1、PC1-ping-PC2/PC3
    在这里插入图片描述
    2、PC1-ping-4在这里插入图片描述
    3、PC3-ping-4在这里插入图片描述
    4、PC2-ping-4在这里插入图片描述
    互相ping通,通信成功!

    展开全文
  • 三层交换技术的概念

    2021-08-10 22:44:13
    目录三层交换技术三层交换两种方式实验总结 三层交换技术 三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的...

    三层交换技术

    三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。
    在这里插入图片描述

    三层交换机要执行三层信息的硬件交换,路由处理器(三层引擎)必须将有关路由选择等的三层
    信息下载到硬件中。以便对数据包进行过处理。为完成在硬件中处理数据包的高层信息,会使用
    传统的MLS和基于CEF的MLS
    三层交换技术=二层交换+三层转发

    ④转发

    三层交换两种方式

    传统MLS:
    使用传统的MLS时,交换机将流中第一个数据包转发给第三层引擎,后者以软件交换的方式对数据包进行过处理,对数据流中的第一个包进行路由处理后,第三层引擎对硬件交换组织进行编程,使之为后续的数据包选择路由。这个过程被称为“一次路由多次交换”,也就是说交换机的三层引擎只需要处理数据流中的第一个数据包,而后续的数据全部由硬件来执行转发。这样实现了三层交换的线速转发。

    基于CEF的MLS:
    与传统MLS不同的是,CEF预先根据路由表学习路由信息后,直接储存在FIB(转发信息库)。REF预先根据ARP表生成邻接表,直接由硬件进行转发。 传统MLS至少需要软件查询一次路由表后,建立转发条目,才能使用硬件进行转发。
    工作原理:
    ①主机A给B发送单播数据包
    ②交换机查找FIB表,找到下一跳地址
    ③查找下一跳地址对应的邻接关系的2层封装信息
    ④转发

    实验

    拓扑图
    在这里插入图片描述
    配置交换机

    ZYS]int g0/0/1
    [ZYS-GigabitEthernet0/0/1]port l	
    [ZYS-GigabitEthernet0/0/1]port link-typ	
    [ZYS-GigabitEthernet0/0/1]port link-type a	
    [ZYS-GigabitEthernet0/0/1]port link-type access 
    [ZYS-GigabitEthernet0/0/1]port default vlan 	
    [ZYS-GigabitEthernet0/0/1]port default vlan 2
    [ZYS-GigabitEthernet0/0/1]
    <ZYS>dis vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:GE0/0/2(U)      GE0/0/3(D)      GE0/0/4(D)      GE0/0/5(D)      
                    GE0/0/6(D)      GE0/0/7(D)      GE0/0/8(D)      GE0/0/9(D)      
                    GE0/0/10(D)     GE0/0/11(D)     GE0/0/12(D)     GE0/0/13(D)     
                    GE0/0/14(D)     GE0/0/15(D)     GE0/0/16(D)     GE0/0/17(D)     
                    GE0/0/18(D)     GE0/0/19(D)     GE0/0/20(D)     GE0/0/21(D)     
                    GE0/0/22(D)     GE0/0/23(D)     GE0/0/24(D)                     
    
    2    common  UT:GE0/0/1(U)                                                      
    
    3    common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    <ZYS>int g0/0/2
         ^
    Error: Unrecognized command found at '^' position.
    <ZYS>syst
    Enter system view, return user view with Ctrl+Z.
    [ZYS]
    [ZYS]int g0/	
    [ZYS]int g0/0/2
    [ZYS-GigabitEthernet0/0/2]port link-	
    [ZYS-GigabitEthernet0/0/2]port link-type a	
    [ZYS-GigabitEthernet0/0/2]port link-type access 
    [ZYS-GigabitEthernet0/0/2]port d	
    [ZYS-GigabitEthernet0/0/2]port de	
    [ZYS-GigabitEthernet0/0/2]port default vlan 3
    [ZYS-GigabitEthernet0/0/2]
    <ZYS>dis vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:GE0/0/3(D)      GE0/0/4(D)      GE0/0/5(D)      GE0/0/6(D)      
                    GE0/0/7(D)      GE0/0/8(D)      GE0/0/9(D)      GE0/0/10(D)     
                    GE0/0/11(D)     GE0/0/12(D)     GE0/0/13(D)     GE0/0/14(D)     
                    GE0/0/15(D)     GE0/0/16(D)     GE0/0/17(D)     GE0/0/18(D)     
                    GE0/0/19(D)     GE0/0/20(D)     GE0/0/21(D)     GE0/0/22(D)     
                    GE0/0/23(D)     GE0/0/24(D)                                     
    
    2    common  UT:GE0/0/1(U)                                                      
    
    3    common  UT:GE0/0/2(U)                                                      
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    <ZYS>int vlan 2
         ^
    Error: Unrecognized command found at '^' position.
    <ZYS>syst	
    <ZYS>system-view 
    Enter system view, return user view with Ctrl+Z.
    [ZYS]int vlan 2
    [ZYS-Vlanif2]ip a	
    [ZYS-Vlanif2]ip address 192.168.1.254 24
    Error: The address already exists.
    [ZYS-Vlanif2]int vlan 3
    [ZYS-Vlanif3]ip a	
    [ZYS-Vlanif3]ip address 192.168.2.254 24
    Error: The address already exists.
    [ZYS-Vlanif3]
    

    配置完成后PC1PINGPC2
    在这里插入图片描述
    可以PING通

    总结

    三层交换机拥有强大的路由传输、带宽分配、多媒体传输和安全控制功能, 能够根据不同的通信业务系统划分不同的用户群体, 实现电业业务的高效传输, 具有重要的作用。除了优秀的性能之外,三层交换机还具有一些传统的二层交换机没有的特性,这些特性可以给校园网和城域教育网的建设带来许多好处。

    展开全文
  • 三层交换 解决单臂路由的缺陷。提供园区网内部高速交换路由转发功能 通过三层交换机来实现 交换机 路由器 三层交换机(二层交换机+路由器的结合体) 一,三层交换原理 把内网的交换机更换为带有路由功能的多层...

    单臂路由缺陷
    1,一条链路承载多个vlan的数据,很容易形成瓶颈。
    2,单臂路由不具备冗余性,容易形成单点故障

    三层交换
    解决单臂路由的缺陷。提供园区网内部高速交换路由转发功能

    通过三层交换机来实现     交换机   路由器  三层交换机(二层交换机+路由器的结合体)
    

    一,三层交换原理

    把内网的交换机更换为带有路由功能的多层交换机
    通过在多层交换机上配置 vlanif(SVI)虚拟接口, 作为每个VLAN的网关,进而实现跨VLAN通信的效果
    

    二、三层交换配置
    1、先创建vlan
    2、接口划分vlan
    3、创建vlanif接口
    4、配置IP地址
    5、查看测试
    dis ip interface brief 查看接口Ip信息
    display ip routing-table 查看路由表
    补充: 三层交换机的三层接口UP需要一定的条件
    1、vlanif要想生效,在它相应的vlan下 一定要有一个物理接口是UP的
    2、vlanif要想生效,如果相应的vlan下,没有物理接口,那么一定要有一个激活的trtunk接口,并且允许该vlan通过。

    三,三层交换实验演示
    如下图所示模拟一家小型企业网络TOP图,有核心交换机SW1,接入交换机SW4,SW5,出口路由器R1,现有4个部门,
    PC1代表生产部、PC2代表财务部、PC3代表保卫部、PC4代表后勤部,分别在VLAN10,VLAN20,VLAN30,VLAN40下 一台服务器在VLAN50下。

    **实验要求:**将实验TOP搭建完成之后,请你按照下面的步骤完成实验配置,最后实现内网用户互通,以及能访问外网LOOP 0

    实验实现

    1,分配PC的IP地址和网关

    在这里插入图片描述

    2, 对三台交换机进行VLAN与Trunk的配置。注意核心交换机上要有全网VLAN。

    vlan及接口
    配置命令
    vlan batch 10 20 30 40 50 60
    interface g0/0/1
    port link-type trunk
    port trunk allow-pass vlan 10 20
    interface g0/0/2
    port link-type trunk
    port trunk allow-pass vlan 30 40

    interface g0/0/3
     port link-type access
     port default vlan 60
    interface g0/0/4
     port link-type access
     port default vlan 50
    

    sw1配置信息
    在这里插入图片描述

    3,核心交换机上启用VLANIF

    vlanif配置命令
    interface Vlanif10
    ip address 192.168.10.254 255.255.255.0
    q
    interface Vlanif20
    ip address 192.168.20.254 255.255.255.0
    q
    interface Vlanif30
    ip address 192.168.30.254 255.255.255.0
    q
    interface Vlanif40
    ip address 192.168.40.254 255.255.255.0
    q
    interface Vlanif50
    ip address 192.168.50.254 255.255.255.0
    q
    interface Vlanif60
    ip address 172.100.1.254 255.255.255.0
    在这里插入图片描述

    1. sw1和R1上配置静态路由
      因为要去外网,所以要配置全网地址(默认路由)
      ip route-static 0.0.0.0 0.0.0.0 vlanif60 172.100.1.1
      在这里插入图片描述
      ip route-static 192.168.0.0 255.255.192.0 GigabitEthernet0/0/0 172.100.1.254
      在这里插入图片描述
    2. 测试
      PC1 ping loop0
      在这里插入图片描述PC1 ping 服务器
      在这里插入图片描述
      PC1ping PC4
      在这里插入图片描述
    展开全文
  • 三层交换机要执行三层信息的硬件交换,路由处理器(三层引擎)必须将有关路由选择等的三层信息下载到硬件中。以便对数据包进行过处理。为完成在硬件中处理数据包的高层信息,会使用传统的MLS和基于CEF的MLS。 传统的...
  • 一、三层交换技术 ①使用三层交换技术实现wlan间的通信 ②三层交换技术等于二层交换+三层转发 二、传统的ML-S2 2.1三层转发过程中要重新封装2层 (1)、三层交换机上,第三层引擎处理数据流的第一个包 (2)、交换...
  • 单臂路由与三层交换技术简单介绍单臂路由与三层交换技术一、单臂路由技术二、使用实例二、三层交换技术使用实例总结 单臂路由与三层交换技术 我们如何实现不同vlan之间的通信: 单臂路由技术:二层交换机+路由器 ...
  • 三层交换:使用三层交换技术来实现不同vlan间的通信 三层交换=二层交换+三层转发(功能) 三层交换组成:三层交换机 二,三层交换实现的方式 实现:传统的MSL和基于CEF的MLS 传统的MSL--一次路由多次交换...
  • 二、三层交换技术 (一)、概念 (二)、传统的MLS2-1 三层转发过程中要重新封装2层 2、基于CEF的MLS (1)、CEF是一种基于拓扑转发的模型 (2)、当三层设备接收到一个数据帧,会拆除原数据帧,重新封装新的源...
  • 三层交换技术的工作原理:第三层交换工作在OSI七层网络模型中的第三层即网络层,是利用第三层协议中的IP包的包头信息来对后续数据业务流进行标记,具有同一标记的业务流的后续报文被交换到第二层数据链路层,从而打...
  • Hybrid类型与单臂路由及三层交换技术华为Hybrid接口单臂路由单臂路由概述链路类型子接口单臂路由的工作原理单臂路由产生的瓶颈三层交换技术概念三层交换原理==MLS==三层交换机VLAN间通信的转发过程三层交换机实现...
  • 最近工作上有个项目碰到了三层交换,所以拿出来加深一下记忆。 提示:以下是本篇文章正文内容,下面案例可供参考 一、拓补图 二、配置三层交换机 layer3-SW1]vlan bat 10 20 //创建vlan10和20 Info: This ...
  • 单臂路由与三层交换技术

    千次阅读 2021-01-04 17:13:45
    单臂路由与三层交换技术单臂路由概述操作交换机的配置路由器配置方案一方案二PC的IP地址和网关地址配置三层交换技术三层交换原理 单臂路由 概述 当只能使用二层交换机的时候使用 实现不同Vlan之间通信 操作 通过将...
  • 三层交换技术 使用三层交换技术实现VLAN间通信 三层交换=二层交换+三层交换 传统的MLS2-2 交换ASIC从3层引擎中获悉2层重写信息在硬件中创建 负责重写和转发数据流中的后续数据包 基于CEF的MLS CEF是一种基于拓扑转发...
  • 二十三·三层交换技术 三层交换机(内置路由器(路由引擎))=三层路由+二层交换机 三层路由引擎可以关闭或开启 解决了网络瓶颈问题,解决了单点故障(虚拟接口不再依赖物理接口)一次路由,永久交换 三层路由里有两...
  • stp与三层交换

    2021-01-04 09:19:32
    文章目录前言一、三层交换的定义与配置1.定义2.配置方法STP生成树 前言 三层交换功能类似于单臂路由,在不同vlan和网段之间实现通信,但在实用性上三层交换时大于单臂路由,在有三层交换时并不推荐使用单臂路由。...
  • 三层交换技术总结 提示:以下是本篇文章正文内容,下面案例可供参考 一、单臂路由 单臂路由是通过路由器上配置虚拟接口(子接口)的方式来实现不同VLAN(虚拟局域网)之间相互通信。 我们假设PC5接入VLAN 2,PC6...
  • 一、 VLAN功能介绍: 1、VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的局域网在逻辑上划分...VLAN技术部署在数据链路,用于隔离二流量。同一个VLAN内的主机共享同一个广播域,它们之间可以直接
  • VLAN是英文Virtual Local Area Network的简称,又叫虚拟局域网,是一种通过将局域网内的设备逻辑地而不是物理地划分成一个个网段从而实现虚拟工作组的技术。要想划分VLAN,必须购买支持VLAN功能的网络设备。 划分...
  • 三层交换技术就是:二层交换技术+三层转发技术。它解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。 1.2.三层交换机 三层交换机:具有部分...
  • 路由交换技术需要知道的基础知识点视图的作用与切换方式常用的基础操作几条比打的命令telnet管理设备(交换机、路由器)web管理设备vlan、trunkhybridvlan间路由(单臂路由、三层交换机)链路捆绑STP二级目录三级...
  • 文章目录引言一、理解三层交换技术二、二层交换和三层交换的区别三、三层交换工作原理四、项目详情1.项目准备2.配置两台PC3.配置交换机总结: 引言 在实际应用的网络环境中,对于跨网段通信的需求不断提高,在今天的...
  • 单臂路由与三层交换

    2021-03-13 15:17:50
    文章目录单臂路由与三层交换单臂路由的概述单臂路由实现不同vlan间通信单臂路由实现不同vlan间通信的原理三层交换技术概念传统的MLS2-1虚接口链路聚合配置命令 单臂路由的概述 单臂路由实现不同vlan间通信 链路类型 ...
  • 为了能够使不同的vlan能够通信,而且节省路由器的端口资源,产生了单臂路由技术和三层交换技术 单臂路由 1、单臂路由介绍 通过在路由器上创建逻辑接口来实现不同vlan间的通信 逻辑接口是依托于真实接口来虚拟的接口...
  • 华为ensp_三层交换

    2020-12-28 19:32:22
    三层交换技术 1.基本原理 使用三层交换技术实现VLAN间通信 三层交换=二层交换+三层转发 三层交换技术的原理: “一次路由,多次交换” 当三层设备接收到一个数据帧,会拆除原数据帧,重新封装新的源MAC地址和目标MAC...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 177,858
精华内容 71,143
关键字:

三层交换技术