精华内容
下载资源
问答
  • 使用NAT从外网访问内网

    千次阅读 2020-09-12 11:43:27
    使用NAT从外网访问内网 使用NAT的原因 一般一个网络中,拨号上网只会有一个外网的ip地址,内网可以设置很多的内网的ip地址,例如:192.168.1.x/24 , 每台电脑,服务器都可以享有一个或者多个IP,如果是在内网里搭建...

    使用NAT从外网访问内网

    使用NAT的原因

    一般一个网络中,拨号上网只会有一个外网的ip地址,内网可以设置很多的内网的ip地址,例如:192.168.1.x/24 , 每台电脑,服务器都可以享有一个或者多个IP,如果是在内网里搭建的服务器,或者是一些应用程序,在外网想访问该怎么办呢? 按理来说是没有直接访问到内网的私网ip地址的,内网的私网ip地址对于外网来说不是唯一的标识,因为可能在很多的局域网里都有192.168.1.1这样的ip地址。这个时候可以借用nat从外网穿透到内网中。

    NAT的功能介绍

    NAT可以实现内网网ip的映射,例如:
    在这里插入图片描述
    按如上图的映射关系,在外网中访问,http://219.152.168.222:9201 访问的就是内网的192.168.1.59:80(是一个部署在内网的一个服务器)。如上图,不只有80端口的web server可以访问,其它端口的应用也可以这样访问。

    举例说明

    以某厂家的三层交换机为例说明:
    在这里插入图片描述
    上图:以图来说明
    内网设备:IPC1、IPC2、二层交换机、三层交换机的PORT1/1
    外网设备:PC1、PC2、二层交换机、三层交换机的PORT1/2
    各个设备的IP地址、子网掩码、默认网关见拓扑图
    配置三层交换机,要求在PC1上的浏览器中输入地址111.53.92.254:8001,实现对内网IPC1(192.168.1.1/24 80)的访问;在PC2上的浏览器中输入地址111.53.92.254:8002,实现对内网IPC2(192.168.1.2/24 80)的访问

    实际配置

    interface vlan 1
    ip address 192.168.1.254/24
    no shutdown
    exit
    interface vlan 2
    add port ethernet 1/2 untagged
    ip address 111.53.92.254/24
    no shutdown
    exit
    interface vlan 100
    add port ethernet 1/3 untagged (1/3-1/12)
    ip nat choice napt
    ip nat outside destination static tcp 111.53.92.254/24 8001 192.168.1.1/32 80
    ip nat apply
    ip nat outside destination static tcp 111.53.92.254/24 8002 192.168.1.2/32 80
    ip nat apply
    
    

    实现效果

    在PC1的浏览器中,地址栏输入“111.53.92.254:8001”,实现对内网IPC1(192.168.1.1)的访问。
    在这里插入图片描述
    在PC2的浏览器中,地址栏输入“111.53.92.254:8002”,实现对内网IPC2(192.168.1.2)的访问。
    在这里插入图片描述

    展开全文
  • 外网访问内网服务器配置方法

    万次阅读 2016-05-17 16:07:15
    前提需要有固定IP路由器必须得是通过固定IP上网,才能通过外网访问内网服务器登录路由器在地址栏输入192.168.1.1或192.168.0.1。初始密码为admin,若忘记密码请重置路由器。这里以TP-Link WR842N为例。点击应用管理...

    前提需要有固定IP

    路由器必须得是通过固定IP上网,才能通过外网访问内网服务器


    登录路由器

    在地址栏输入192.168.1.1或192.168.0.1。初始密码为admin,若忘记密码请重置路由器。这里以TP-Link WR842N为例。


    点击应用管理选择虚拟服务器

    界面不一样的话,一般在转发规则一栏可以找到虚拟服务器;

    这里写图片描述

    在虚拟服务器中点击添加,常用服务和协议类型不知道可以不填,
    外部端口和内部端口可以自行填写,为避免冲突可设置在10000以上
    但必须一致。ip地址即为服务器内网ip,可通过cmd中ipconfig命令查询。

    123

    这里写图片描述

    同时还要打开DMZ主机服务,ip同样为服务器内网ip

    这里写图片描述

    至此路由器配置完成,但仍可能无法通过IP地址访问服务器,接下来需要配置防火墙。


    配置防火墙进站规则

    控制面板—>系统和安全—>Windows防火墙—>高级设置

    这里写图片描述

    在进站规则中点击 新建规则,按照提示一步一步来。

    这里写图片描述

    这里写图片描述

    这里写图片描述

    这里写图片描述

    名称这里可以随意填写,保证不重名即可,以下仅为示例。

    这里写图片描述

    最后点击完成即可。所有配置至此结束,可以在浏览器上输入IP+端口号,如:192.168.23.45:8008来访问服务器上网站。

    展开全文
  • 通过外网访问内网服务器 ———————————————— 版权声明:本文为CSDN博主「Chao's Code」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。 原文链接:...

    通过外网访问内网服务器

    ————————————————

    版权声明:本文为CSDN博主「Chao's Code」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
    原文链接:https://blog.csdn.net/jinzhichaoshuiping/article/details/45751671

    首先使用tomcat在电脑上建立一个服务器,怎样建立看我的另外一篇博客。

    在这里插入图片描述

    此时,我的tomcat开放的端口是8888.

    然后登录路由器的管理页面,在cmd中查看ip地址,ipconfig

    在这里插入图片描述

    看到路由器的管理地址是192.168.1.1

    在浏览器中输入192.168.1.1,输入用户名和密码进入管理页面。点击转发规则—虚拟服务器,创建端口映射。

    添加新条目,本机的ip是192.168.1.108,需要连接的端口是8888.(要与Tomcat开放的端口一致)

    在这里插入图片描述
    点击保存即可。

    然后点击运行状态,查看路由器ip(注意:路由器ip,不一定是外网ip,有可能还经过了其他路由,本文中只经过了一层路由)

    在这里插入图片描述
    看到路由的ip是,100.64.73.154

    关闭页面,在浏览器中输入100.64.73.154:8888

    在这里插入图片描述

    访问本地服务器成功!!!

    展开全文
  • 内网穿透在实际生活中,我们经常会在内网里部署服务让外网访问内网应用,比如Apache,Tomcat,数据库,微信小程序的开发以及企业的一些管理软件(OA、CRM、ERP),还有远程桌面等等的外网都是无法直接访问内网的。...

    内网穿透在实际生活中,我们经常会在内网里部署服务让外网访问内网应用,比如Apache,Tomcat,数据库,微信小程序的开发以及企业的一些管理软件(OA、CRM、ERP),还有远程桌面等等的外网都是无法直接访问内网的。

    内网穿透实现外网访问内网

    有些方式可以通过设置路由器虚拟服务器开放一些端口供外网访问,但由于运营商的原因,这些IP有时候并不是直接的IP,更多的时候这些IP都是动态的,简单说就是今天给你的IP是15.63.87.251,明天随时都有可能变为变得IP,并且是不能访问80个443端口的,那么有没有一种办法可以实现在没有公网IP的情况下,又不用设置路由器就可以让外网直接访问内网里的应用呢,今天要讲的就是这个:

    首先普及一下基本的概念,可能有些拗口,不过没关系,这个看不懂也不要紧,可以直接跳过这一段:

    什么是内网穿透、为什么要内网穿透,内网、公网和NAT是什么意思? 

    公网、内网是两种Internet的接入方式。

     内网接入方式:上网的计算机得到的IP地址是Inetnet上的保留地址,保留地址有如下3种形式:    
     10.x.x.x 
     172.16.x.x至172.31.x.x 
     192.168.x.x 
      内网的计算机以NAT(网络地址转换)协议,通过一个公共的网关访问Internet。内网的计算机可向Internet上的其他计算机发送连接请求,但Internet上其他的计算机无法向内网的计算机发送连接请求。 

      公网接入方式:上网的计算机得到的IP地址是Inetnet上的非保留地址。公网的计算机和Internet上的其他计算机可随意互相问。 
        NAT(Network Address Translator)是网络地址转换,它实现内网的IP地址与公网的地址之间的相互转换,将大量的内网IP地址转换为一个或少量的公网IP地址,减少对公网IP地址的占用。NAT的最典型应用是:在一个局域网内,只需要一台计算机连接上Internet,就可以利用NAT共享Internet连接,使局域网内其他计算机也可以上网。使用NAT协议,局域网内的计算机可以访问Internet上的计算机,但Internet上的计算机无法访问局域网内的计算机。
        Windows操作系统的Internet连接共享、sygate、winroute、unix/linux的natd等软件,都是使用NAT协议来共享Internet连接。 所有ISP(Internet服务提供商)提供的内网Internet接入方式,几乎都是基于 NAT协议的。

    什么是固定IP、动态IP地址、什么是域名?

    固定IP地址是长期分配给一台计算机或网络设备使用的IP地址。一般来说,采用专线上网的计算机才拥有固定的IP地址。

    什么是动态IP地址 ?

    通过Modem、ISDN、ADSL、有线宽频、小区宽频等方式上网的计算机,每次上网所分配到的IP地址都不相同,这就是动态IP地址。因为IP地址资源很宝贵,大部分用户都是通过动态IP地址上网的。普通人一般不需要去了解动态IP地址,这些都是计算机系统自动完成的。

    当然在很多情况下你可能并没有公网IP,不要问我为什么,本人曾经做过2年的售后工程师,给几百家客户安装实施部署过软件,有3分之一的企业虽然有路由器,但运营商分给的IP却是内网的,奇怪吧,比如10、172或者100开头的都是运营商的内网IP。

    这里简单说一下怎么查看是否是内网IP:
    1.如果你使用的是Window平台,点击自己电脑窗口的“开始”“运行”输入“cmd”,在DOS命令窗口输入“ipconfig /all”,得到的IP如果和上面一样,说明你拥有自己的外网IP
    2.如果你使用的是unix/linux平台,运行 ifconfig -a 得到的IP如果和上面一样,说明你拥有自己的外网IP。

    现在开始正式进入正题:

    接下来我就演示2个应用,一个是设置远程桌面,设置让外网可以通过3389远程控制局域网内的电脑,另一个就是访问内网里Tomcat的应用,端口是8080,使用的工具是神卓互联,快速实现内网穿透。

    首先可以去神卓互联官网下载一个客户端。(地址自己百度吧),这个一般是针对企业级应用的,比如管家婆,OA系统等等,对于我们这些平民可以使用社区版,这个真的是免费的。

    神卓内网穿透

     

    下载好之后点安装就可以。

    神卓互联_内网穿透安装

    安装的过程很顺利,直接点下一步就可以了。

    神卓互联_外网访问内网

    安装完成后我们就可以打开登录了,(这个登录框背景是半透明的,不要找不到/捂脸)

    简单注册一个账号,然后选择社区版,直接确定登录就可以了。

    内网穿透_免费的内网穿透软件

    接下来就可以开始正式使用了。

    内网穿透

    接下来就是添加映射了,首先是3389远程访问的映射

    点击主面板左下角的添加映射按钮

    应用名称可以随便填,这里可以填远程桌面,服务器IP可以是局域网内任意IP,这里填写127.0.0.1就可以了,端口号肯定是填3389了,点击其二添加就好了。主面板就会返回一个固定的公网地址和端口号,当然这个地址可以把后面的端口号去掉,也可以绑定域名,这里就不多说了,不是重点。

    接下来就可以通过外网访问了,打开下面这个远程桌面连接,

     

    然后就可以直接连接了。

    接下来就是穿透8080端口了,

    只需要把端口号改为8080,当然可以是任意的端口号和tomcat保存一致就可以了。

    太晚了,明天再写。

    本人最近在写博客,就是为了实现这个功能,用Java语言编写,感兴趣的话可以关注下我

     

     

    展开全文
  • 无线路由设置外网访问内网

    千次阅读 2016-09-09 09:07:14
    转载:... 路由器的端口映射,外网访问内网服务器: http://wenku.baidu.com/link?url=DcjFBAhWCVEuqy7t71WFjB1U0MfJC8mw_BUN4sUBphj1qFcp_LVyBX5lGJQo6UK2y3Y1HpSL7W
  • 应用场景:外网访问内网SpringBoot 1、我们首先确保本地项目内网可以访问 查看本地ip地址, 打开cmd 2、通过ipconfig查看 这里查看到我本地的是: 192.168.10.24 3、内网访问本地SpringBoot项目 因为我本地...
  • 之后在地址转换中将除了C以外的内网地址nat给A(源地址转换),然后用目标地址转换将B转换到内网的C来实现外网访问内网的邮箱服务器。 现在的问题是,我通过外网telnet B 22,可以打开服务器,但是怎么也访问不到80...
  • 树莓派--外网访问内网

    千次阅读 2016-11-30 08:24:13
    使用https://www.ngrok.cc/服务器解决的外网访问内网问题、本地WEB外网访问、本地开发微信、TCP端口转发一.使用http外网访问。1.打开https://www.ngrok.cc/申请开通http隧道,使用前置域名。例如前置域名raspberry_...
  • 1、如何在外网访问内网服务器数据库? 2、如何在外网访问无公网的云服务器数据库? 3、如何在外网访问服务器集群中的多个异构数据库? 4、如何提高远程数据库管理及维护的效率质量。 这些问题十分普遍,基于...
  • 内网穿透在实际生活中,我们经常会在内网里部署服务让外网访问内网应用,比如Apache,Tomcat,数据库,微信小程序的开发以及企业的一些管理软件(OA、CRM、ERP),还有远程桌面等等的外网都是无法直接访问内网的。...
  • nginx外网访问内网站点配置

    万次阅读 2019-05-08 10:21:49
    背景: 站点是前后端分离:vue+springboot 前端内网地址:192.168.1.10:81 API内网地址:192.168.1.12:8080 ...方案一:(前提:外网域名映射服务器外网IP) 1.nginx配置域名监听且访问静态资源 2...
  • 1. PC1通过NAT静态转换访问外网 2. PC2和PC4通过NAT动态转换访问外网 3. PC3通过NAT端口多路复用访问外网 4. 外网访问内网时使用NAT的地址转换
  • 动态IP或无公网IP时外网访问内网FTP

    千次阅读 2014-05-05 23:33:04
    动态IP时,外网访问内网FTP的实现: 1.在内网启用nat123动态域名解析。使用自己的域名,或提示免费域名。 2.如FTP主机经过路由,在路由的转发规则上做端口映射和DMZ。 3.在外网访问FTP时,用域名即可正常访问。 ...
  • 动态IP时,外网访问内网路由器的实现: 1.在内网使用nat123动态域名解析。可使用自己的域名,或直接使用免费域名。 2.访问时,用动态解析的域名即可。 无公网IP时,外网访问内网路由器的实现: 1.在内网使用...
  • NAT反向代理技术的实现(外网访问内网)(版权所有,引用 请联系作者,注明出处) NAT技术是网络中的重要应用之一。当有一个场景:内网搭建了服务器,需要外网访问时,可以借助NAT映射来实现。如:单位建立了一个Web...
  • 本文以访问内网samba服务为例,介绍了如何使用FRP外网访问内外FTP服务器。
  • 如何实现外网访问内网远程桌面windows电脑? 2,解决方案: 使用nat123端口映射,将内网远程桌面地址映射到外网,实现外网的访问。 3,实现过程: 非网站映射转发,具体实现过程方法参考一《外网访问内网远程桌面-非...
  • 外网访问内网的FTP服务器

    万次阅读 2014-04-25 16:29:08
    外网访问内网的FTP服务器     目录 1. 背景简介.. 2 2.基础知识.. 2 2.1.命令端口.. 2 2.2.数据端口.. 2 2.3.主动模式 (PORT)2 2.4.被动模式 (PASV)3 3.我走过的弯路.. 3 3.1.使用环境.. 3 ...
  • 动态IP时,外网访问内网MYSQL数据库的实现: 1.在内网启用NAT123动态域名解析。使用自己的域名,或直接使用提示免费域名。 2.如MYSQL主机经过路由器,在路由器上的转发规则做端口映射(3306端口)。 3.访问数据库...
  • 端口映射是 NAT 的一种,它将外网主机的 IP 地址的一个端口映射到内网中一台机器,提供相应的服务。当用户访问该 IP 的这个端口时,服务器自动将请求映射到对应局域网内部的机器上。 现在市场上的家庭路由器都具备 ...
  • 动态IP时,外网访问内网ORACLE数据库的实现: 1.在内网启用NAT123动态域名解析。使用自己的域名,或提示免费域名。 2.如数据库主机有经过路由,需要在路由做端口映射(1521端口)。 3.访问时,用动态解析的域名...
  • 外网访问内网svn

    2019-05-13 18:31:57
    现在内网使用svn客户端能够正常update,外网就凉凉了。 方案: ①:使用ssh代理,在window开发机上安装svn客户端。右键settings,network,配置proxy setting ,然后enable。 问题来了,这样配置之后好像并没有...
  • 端口映射是 NAT 的一种,它将外网主机的 IP 地址的一个端口映射到内网中一台机器,提供相应的服务。当用户访问该 IP 的这个端口时,服务器自动将请求映射到对应局域网内部的机器上。 现在市场上的家庭路由器都具备 ...
  • 动态IP时,外网访问内网SQLSERVER数据库的实现: 1.在内网启用NAT123动态域名解析。使用自己的域名,或提示免费域名。 2.如数据库主机有经过路由,需要在路由做端口映射(1433端口)。 3.访问时,用动态解析的...
  • 外网访问内网的主机,内网任何一台主机都可以搭建www服务器让外网访问;内网主机既可以动态获取ip访问外网,也可以手动设置ip访问外网!一,搭建nat服务器实现内网与外网相互访问;二,搭建dhcp服务器便于对内网主机...
  • 实验环境:思科模拟器Cisco Packet Tracer IP地址划分: WEB:192.168.1.1 DNS:192.168.1.2 ...内网能正常访问外网外网只能访问内网的DNS服务器和WEB服务器 实验拓扑图: 在路由器上的配置: 1、添加标准A...
  • 由于公网IP地址有限,不少ISP都采用多个内网用户通过代理和网关路由...就象在局域网或网吧内一样,虽然你可以架设多台服务器和网站,但是对外网来说,你还是只有一个外部的IP地址,怎么样把外网的IP映射成相应的内网
  • 公司现在有个需求是想让外网下载和上传文件到内网的一台服务器,用vpn经常被封不考虑!端口映射吧公司路由器的ip也是一个内网的没法做!我在考虑能不能用一个阿里云服务器做中转所有的请求都访问阿里云然后内网...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 62,843
精华内容 25,137
关键字:

外网访问内网