精华内容
下载资源
问答
  • microsoft visual c++ 14.0 is required问题解决办法

    万次阅读 多人点赞 2017-10-12 15:41:44
    error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools 方法1 不管你是安装什么库,方...

    背景

    安装pymssql, 执行命令pip install pymssql时出错:

    error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools

    解决方案

    以下方案二选一即可,若想一劳永逸,建议选择方案二

    方案一.手动下载whl

    step1.手动下载whl文件

    这里搜索您要下载的库。
    这里写图片描述


    下载哪一个呢?

     - cp后接python版本, 请与你的python版本对应
     - win32,标识32位架构,适用于32位系统
     - 后接`_amd64`指64位架构,适用于64位系统
    

    step2. 执行pip install xxx

    > pip3 install C:\Users\chenjun\Desktop\pymssql-2.1.3-cp36-cp36m-
    win32.whl

    方案二.下载c++ 14.0

    因为提示需要c++ 14.0,下载14.0.

    1. 点击此处进入下载。
    2. 解压安装(可能比较花时间)
    3. 安装完毕再次执行pip install xx

    备注:因为上传到CSDN后需要的积分有点高(非本人设置),故添加baidu盘链接,如果失效请留言告知。
    链接:https://pan.baidu.com/s/1R-u3AJtA4nSGQi83cNAiug
    提取码:07oe


    方案三.运行时库

    安装微软运行时库(比方案二更轻便):

    链接:https://pan.baidu.com/s/1FQy5V6cgBnlxVC6yvF143Q
    提取码: amos

    安装完之后再次执行pip install xxx

    备注:方案三经过其他童鞋评论说不可用,暂时去掉。

    若解决了您的问题,欢迎点赞、评论、关注
    展开全文
  • Python 典藏篇-Microsoft Visual C++ 14.0 is required,官方vc++运行库工具一键式解决! Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools。 在用pip安装pyHook3的时候报错...

    前言
    error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools
    在用 pip 安装 pyHook3 的时候报错了,说缺少 vc++14.0,但是在网上却找不到,为什么呢。
    vc++14.0 就是 vc++2015,全称:Microsoft Visual c ++ 2015

    下面提供3种解决方式:

    • 推荐: 安装 vc++ 运行库集合,这个我有官方工具,不用安装整个 vs2017
    • 直接下载 whl 库进行安装,简单
    • 安装 vc++2015这个我是试了,没管用
    官方c++运行库安装工具,❤强力推荐!

    因为很多时候即使我们安装成功了它说的对应的运行库,还是不行,必须安装所有的运行库才可以,不知道它还需要什么库。

    Microsoft Visual C++ Build Tools官方工具获取使用

    直接下载whl库进行安装

    一般碰到
    Microsoft Visual C++ 14.0 is required
    最好的解决办法就是下在网上下一个whl库到本地,我们再安装就好了。

    whl库常用获取地址:
    pipy 官方下载
    lfd.uci.edu 下载

    安装vc++2015

    vc++2015 获取方式:
    小蓝枣的csdn资源仓库

    为什么呢? 我们安装时就会看到最后面有个 14.0 的版本号,发行的时候是按年号来发行的便于大家记忆,15 年发行的对应的内部对应的版本就是 14.0
    在这里插入图片描述
    注:安装的话 x86x64 都要安装,虽然是 64 位的,但是 x86 更重要呢,因为很多程序用的库都是基于 x86 的,因为兼容性更好,相比 x64 却很少被用。

    喜欢的点个赞❤吧

    展开全文
  • 其中最受困扰的就是这个问题:error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual…… 微软就是霸道,看到这个问题上网搜索一下,我都不想解决,感觉需要重装系统才能...

    对于程序员来说,经常pip安装自己所需要的包,大部分的包基本都能安装,但是总会遇到包安装不了的问题,预研学习的动力第一步就被安装包给扼杀了。其中最受困扰的就是这个问题:error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual……

    微软就是霸道,看到这个问题上网搜索一下,我都不想解决,感觉需要重装系统才能彻底解决。我之前不只一次遇到这个报错,一直没有解决好,网上的方法试了好多,但是还是没有根本解决问题。一般我权宜之计对于这种pip安装不上的包,一种就是去Python安装包大全中(https://www.lfd.uci.edu/~gohlke/pythonlibs/)去下载 对应后缀为 .whl 的安装包进行安装。

    后缀为 .whl 的安装包进行安装的方法:下载对应的后缀为 .whl 的安装包放在自己指定的文件夹下,进入cmd,

    pip install  Scrapy-1.5.0-py2.py3-none-any.whl (包括后缀.whl)。

    另一种就是,对于没有找到后缀为.whl包的,或者.whl包没有安装成功的,一般去服务器上的乌班图系统上操作,在linux系统上pip 安装这些包还是很方便的,不会报错。

    但都没有从根本解决这个问题。

    言归正卷,说说我是怎么解决这个问题的,记录下来,希望大家少走弯路。

    首先再运行代码时,说 *** 包没安装,遇到这个问题,就去cmd,结果pip install 安装报错:

    上网查找各种解决方法,但都不是我的菜。一般都说重新下载一个新版本的安装即可(下载地址),但我下载下来后都安装不上,报错。。。

    显示      visual studio installer 已停止工作 。。。

    我尝试下载安装 Microsoft Visual 2017 https://download.csdn.net/download/heyshheyou/10624594,但是下载下来安装的时候,一点击安装就报错,       visual studio installer 已停止工作    彻底无语。。。。。下载 不同版本的visual studio 安装都是这个报错  ,可能是程序冲突吧。

    网上还有卸载 .NET Framework文件,下载一个最新的.NET Framework文件;还有说卸载所有 Microsoft Visual开头的文件的:

     

               

                

    差点我就试了,还好继续找了其他的解决方法。除了最后没得办法可以尝试,或者重装系统。不到万不得已不要去重装系统。

    安装和卸载 .NET Framework 受阻疑难解答

           对于下载的Microsoft Visual C++ 版本:
             Visual Studio 2013 ---> 12
             Visual Studio 2015 ---> 14
             Visual Studio 2017 ---> 15

             python3 是用 VC++ 14 编译的, python27 是 VC++ 9 编译的, 安装 python3 的包需要编译的也是要 VC++ 14 以上支持的.
     

    上面是我的踩坑历程,都没有解决我的问题,大家如果遇到报错:error: Microsoft Visual C++ 14.0 is required,直接先试一下下面的解决办法。

    最后的解决方法:

     以上都不能解决,就只能乖乖装Microsoft visual c++ 14.0了,找了好多找不到包,最后找到了一个Microsoft Visual C++ Build Tools 2015

    文件名为:visualcppbuildtools full 下载下来安装即可。

                         

    如果包丢失或者损坏 ,访问以下链接:

    链接:https://pan.baidu.com/s/154Nba8InfUyF5SITxgwTpg 
    提取码:a3za 

    双击visualcppbuildtools_full.exe,选择默认即可,点击安装,等待10分钟左右即可完成安装。

    最后安装完成,查看 控制面板——程序——卸载程序里下多了一个文件 Microsoft visual c++ Build Tools:

    即安装成功。

    结果再到cmd中pip安装自己所需的包即可。

    参考: visual c++ build tools的安装与使用

     

    展开全文
  • redis客户端连接(error) NOAUTH Authentication required

    万次阅读 多人点赞 2017-11-06 19:08:59
    redis客户端连接成功,但是操作报异常——(error) NOAUTH Authentication required 错误的含义是说你没有认证,说明没有使用密码连接查看密码:进入redis的安装目录(是安装目录的),查看redis.config文件vi ...

    redis客户端连接成功,但是操作报异常——(error) NOAUTH Authentication required
    错误的含义是说你没有认证,说明没有使用密码连接



    查看密码:



    进入redis的安装目录(是安装目录的),查看redis.config文件

    vi redis.config
    

    打开配置文件后,输入/#requirepass foobared(快速定位的命令)



    这里写图片描述



    然后回车



    这里写图片描述

    红框里的就是密码



    使用密码连接

    ./redis-cli -h 127.0.0.1 -p 6379 -a Passw0rd
    

    这里写图片描述
    或者

    先./redis-cli 
    输入auth +空格+ 刚才设置的密码
    

    在这里插入图片描述
    再操作就没问题了


    这里写图片描述

    是不是很神奇,我的咖啡没糖了,你不给加点?

    展开全文
  • @Autowired(required=false)注入注意的问题

    万次阅读 多人点赞 2018-03-16 14:47:14
    1、前言在使用spring开发过程中,我们基本上都是使用@...今天整理一个我在实际开发中的例子2、required属性@Autowired(required=true):当使用@Autowired注解的时候,其实默认就是@Autowired(required=true)...
  • required string parameter 'XXX'is not present 的几种情况 情况一:原因是由于头文件类型不对,可以在MediaType中选择合适的类型,例如GET和POST 情况二:jquery提交delete时,不支持@RequestParam,只支持@...
  • HTML required

    千次阅读 2018-04-19 21:15:34
    required required属性表明该控件为必填项。required特性可用于任何类型的输入元素。required属性是布尔类型属性,无需专门把它设置为true,只需将它添加到标签中即可。一个表单中,可以有多个元素拥有required...
  • 发生这一错误的主要原因是Controller类中需要接收的是Date类型,但是在页面端传过来的是String类型,最终导致了这个错误。 这里提供两种解决方案,一种是局部转换,一种是全局转换。 一....@Controller ...
  • Microsoft Visual C++ 14.0 is required 的解决方案

    万次阅读 多人点赞 2018-10-30 09:29:20
    个人认为Python的一大亮点就是对于我们在学习中遇到的常见问题,它都有很多现成的module可供使用,但是,在我们安装这些module时,可能会出现**“error: Microsoft Visual C++ 14.0 is required. Get it with ...
  • REQUIREDREQUIRED_NEW

    千次阅读 2017-07-06 16:12:07
    spring 事务的传播行为中,有两个容易混淆的行为:REQUIRED和REQURED_NEW。当程序在某些情况下抛出异常时,如果对于这两者不够了解,就可能很难发现而且解决问题。 下面我们给出三个场景进行分析: 场景一: ...
  • 成功解决TypeError: a bytes-like object is required, not 'str'

    万次阅读 多人点赞 2018-11-07 22:31:18
    成功解决TypeError: a bytes-like object is required, not 'str' 目录 解决问题 解决思路 解决方法 解决问题 TypeError: a bytes-like object is required, not 'str' 解决思路 问题出在...
  • error: the following arguments are required: cfg_file

    万次阅读 多人点赞 2019-02-04 22:35:49
    error: the following arguments are required: cfg_file 错误原因:参数前面需要加-- 正确写法: parser = argparse.ArgumentParser(description="Test CornerNet") parser.add_argument("--cfg...
  • easyui动态修改required

    千次阅读 2019-01-30 16:15:44
    经常使用easyui,对于基本的使用还算了解,经常有这样的需要,需要动态的修改required,也就是在某些情况下required是true,有些情况下required是false,之前使用的方法主要有两种: 一种是构造函数方法,重新构造一...
  • 在Spring Boot 2.0配置多数据源和Spring Boot 1.5.x之前,一些配置及用法多少有些不同,其中一个问题就是“jdbcUrl is required with driverClassName.”的错误 解决办法: 在配置文件中使用spring.datasource....
  • 用dreamerweaver制作的用户登陆页面,在浏览器中显示 username is required,password is required! 请问是怎么回事!
  • 1、REQUIRED 事务的默认传播属性是REQUIRED,当传播属性是REQUIRED时,看图 在事务1中包含两个事务,并且这两个事务的传播属性都是REQUIRED, 当执行到事务2 的时候,若事务2发生异常,则事务1回滚到初始状态...
  • 解决方法: 将pubspec.yaml中的 environment改为以下内容: ...现在,required是dart 2.10中的关键字。 如果flutter版本升级到1.22,dart版本会随之升级上来,所以正常运行没有错误,但是编译器会报错。 ...
  • Required request body is missing

    万次阅读 多人点赞 2019-08-07 16:07:29
    最近对代码进行统一日志处理,通过拦截器,打印请求日志,方便排查问题,通过拦截器取参数后遇到一个问题:Required request body is missing;在进行了相关实验后最终解决此问题。 【解决问题】 一、问题复现 ...
  • jquery required

    千次阅读 2014-11-10 17:58:08
    class="required" 非空,有值后还提示的话,可能是type没有设置类型。比如添加 type="text"就可以了
  • Required Device Capabilities

    千次阅读 2016-08-07 17:51:38
    Required Device Capabilities Declaring the Required Device Capabilities If your application requires device-related features in order to run, you must add a list of required capabilities t
  • Redis (error) NOAUTH Authentication required.解决方法

    万次阅读 多人点赞 2019-05-13 15:48:48
    Redis (error) NOAUTH Authentication required.解决方法 出现认证问题,应该是设置了认证密码,输入密码既可以啦 注意密码是字符串形式! 127.0.0.1:6379>auth"yourpassword" 例如密码是‘root’,当出现...
  • input required属性

    千次阅读 2018-04-17 09:31:18
    如果使用该属性,则字段是必填(或必选)的。 <input type="... required="required" placeholder="please input your title" autofocus="autofocus"/>
  • jQuery 添加required属性

    千次阅读 2019-09-19 17:18:59
    $('#yourId').removeClass('required'); $('#yourId').addClass('required');
  • @Required用法

    千次阅读 2016-12-23 10:24:30
    @Required用法   在检查javabean中的某些属性是否一定有值的时候,可以通过@Required来实现。 @Required注解检查 但他只检查属性是否已经设置而不会测试属性是否非空   要使用注解,我们要在配置文件上加上这...
  • error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools 方法1: 手动下载安装whl...
  • Required List parameter 'XXX' is not present

    万次阅读 2018-10-15 20:05:17
    Required List parameter ‘XXX’ is not present 错误原因: 使用Spring MVC时向后台传值,使用注解@RequestParam,添加value=“paramter”,required=false 解决方式: 如果前端传入的是正常表单数据,那么后端...
  • 1.异常org.springframework.http.converter.HttpMessageNotReadableException: Required request body is missing2.问题展示@RequestMapping(value = "/somewhere", method = POST) public SomeResponse ...
  • 请求报错Required String parameter 'id' is not present

    万次阅读 多人点赞 2018-08-09 17:20:05
    关于spring请求时报 Required String parameter ‘id’ is not present异常, 如果前端传入的是json数据那么后端使用@RequestBody HashMap
  • html5 表单的required属性

    千次阅读 2021-06-03 21:57:34
    html5 表单的required属性 描述 今天无意之中发现form有自带非空判断功能,查了资料发现,...注释:required 属性适用于以下 类型:text, search, url, telephone, email, password, date pickers, number, checkbox, r

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 255,155
精华内容 102,062
关键字:

required