策略路由 订阅
策略路由,是一种比基于目标网络进行路由更加灵活的数据包路由转发机制。路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器。 展开全文
策略路由,是一种比基于目标网络进行路由更加灵活的数据包路由转发机制。路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器。
信息
级    别
高级
外文名
Policy based routing
概    念
一种灵活的数据包路由转发机制
种    类
目的地址路由,源地址路由
操作对象
数据包
中文名
策略路由
策略路由概念
应用策略路由,必须要指定策略路由使用的路由图,并且要创建路由图。一个路由图由很多条策略组成,每个策略都定义了1 个或多个的匹配规则和对应操作。一个接口应用策略路由后,将对该接口接收到的所有包进行检查,不符合路由图任何策略的数据包将按照通常的路由转发进行处理,符合路由图中某个策略的数据包就按照该策略中定义的操作进行处理。策略路由可以使数据包按照用户指定的策略进行转发。对于某些管理目的,如QoS需求或VPN拓扑结构,要求某些路由必须经过特定的路径,就可以使用策略路由。例如,一个策略可以指定从某个网络发出的数据包只能转发到某个特定的接口。 [1] 
收起全文
精华内容
下载资源
问答
  • 策略路由

    千次阅读 2018-03-14 21:33:49
    策略路由可以不按路由表来进行报文的转发而路由策略主要控制路由信息的引入发布、接收等策略路由可以不按路由表来进行报文的转发而路由策略主要控制路由信息的引入发布、接收等如上图拓扑所示,要求PC1访问2.2.2.2...
    策略路由可以不按路由表来进行报文的转发而路由策略主要控制路由信息的引入
    
    发布、接收等

    策略路由可以不按路由表来进行报文的转发而路由策略主要控制路由信息的引入
    发布、接收等

    如上图拓扑所示,要求PC1访问2.2.2.2网段时通过AR3的g0/0/0接口转发出去,PC2访问
    2.2.2.2网段时通过AR3的g0/0/1接口转发出去,那么我们可以用策略路由来实现,配置
    命令如下:
    acl number 3001                                                          配置编号为3001的acl                                                            
    rule 5 permit ip source 192.168.1.1 0 destination 2.2.2.2 0              配置acl规则,匹配源ip地址与目的ip地址
    acl number 3002                                                          配置编号为3002的acl
    rule 5 permit ip source 192.168.1.2 0 destination 2.2.2.2 0              配置acl规则,匹配源ip地址与目的ip地址
    policy-based-route 5226 permit node 10                                   配置节点为10的策略路由
    if-match acl 3001                                                        匹配编号为3001的acl
    apply output-interface GigabitEthernet0/0/0                              如果匹配就做相应的动作,这里表示从相应接口转发出去
    policy-based-route 5226 permit node 20                                   配置节点为20的策略路由                          
    if-match acl 3002                                                        匹配编号为3002的acl
    apply output-interface GigabitEthernet0/0/1                              如果匹配就做相应的动作,这里表示从相应接口转发出去
    ip local policy-based-route 5226                                         最后调用该策略路由
    注意:apply output-interface GigabitEthernet0/0/0  接口类型必须为GigabitEthernet口,不能是Ethernet口,如果是Ethernet口,有可能接的是广播网络,数据就不知道要转发给哪个接口了。也可以通过apply ip-address next-hop x.x.x.x 来指定数据转发的下一跳地址
    展开全文
  • 策略路由 路由策略 双点双向引入

    万次阅读 多人点赞 2020-07-10 01:33:17
    一、策略路由 二、路由策略 2.1 前缀列表 三、拓扑 四、策略配置 4.1 网络互通 4.2 网络优化 4.3 网络控制 策略路由 路由策略 双点双向引入 一、策略路由 (一)策略路由–Policy-Based Routing—PBR 1、什么是...

    锲而不舍,金石可镂。

    策略路由 路由策略 双点双向引入

    一、策略路由

    (一)策略路由–Policy-Based Routing—PBR

    1、什么是策略路由:

    对特定数据报文不按照路由表内的条目执行转发,根据需要按照某种策略改变数据报文转发路径。

    2、运行机制:

    根据的报文的目的地址,报文的源地址,报文的大小和链路质量等属性制定策略路由,改变报文的转发路径。手动配置后基于策略转发,失败后再查找路由表转发。

    3、实现方式:

    华为设备支持3种策略路由:

    本地策略路由

    (1)名称:本地策略路由
    (2)对象:本设备产生流量
    (3)应用:对本机的ICMP,BGP等各种报文需要使用不同的源地址或者不同长度的报文通过不通方式进行发送时。

    接口策略路由

    (1)名称:接口策略路由
    (2)对象:流经本设备的数据
    (3)应用:针对用户不同源目地的数据按照流重定向选择下一跳,不按照路由表转发。

    智能策略路由(SSR)

    (1)名称:智能策略路由
    (2)对象:流经本设备的数据,基于链路质量信息为业务数据流选择最佳链路。
    (3)应用:对用户不同业务选择不同质量的链路。
    (4)注意:SSR的功能需要配合License来使用。

    (二)本地策略路由

    1、配置本地策略路由的匹配规则:

    可以通过ACL匹配到数据或者报文长度来进行对需要策略的数据执行匹配。

    2、配置本地策略路由的转发动作:

    可以通过接口或者下一跳地址发出。

    3、本地应用本地策略路由:

    在系统视图ip lcal policy-based-route X-X-----------调用名称为x-x的本地策略路由。

    (三)接口策略路由

    1、通过ACL匹配需要策略的流量

    2、定义流分类

    需要执行流策略的流量–即哪些流量需要转发
    通过ACL匹配需要策略的流量

    3、制定流行为

    指定需要执行流策略的动作,即如何转发

    4、制定流策略

    将流分类(匹配到需要转发的流量)和流行为(具体需要转发的动作)关联起来

    5、挂接流策略

    接口下在数据的进方向挂接流策略

    策略路由----PBR Policy Based Route—基于策略的路由(选址转发)

    策略路由----针对数据---------接口

    (四)策略路由配置

    1、策略路由指定的出接口要优于指定的下一跳
    2、策略路由指定的下一跳>路由表>策略部署的默认下一跳。

    二、路由策略

    路由策略----RP Route policy

    路由策略-------针对路由条目----路由协议----route policy
    人为的控制或者影响路由协议选路----过滤,cost,引入

    路由三要素----前缀----掩码----下一跳
    动态三要素----前缀----掩码----cost

    路由策略----路由条目

    对象:路由条目
    策略:过滤;修改路由属性

    1、路由匹配工具----抓取路由

    同意路由匹配工具

    ① ACL
    ② IP-preix----前缀列表
    ③ route-policy

    2、 BGP专属路由匹配工具

    ① ip murit-fiete----团体属性过滤列表
    ② ip as-patch-fiter----as路 径属性过滤列表

    3、路由策略工具----执行路由动作

    过滤

    ① route-policy
    ② fiter-policy

    属性修改

    route-policy

    2.1 前缀列表

    注意:由于route-policy不支持匹配Loopback接口,使用前缀列表来匹配loopbackO接口的路由。

    greater-equal X 掩码大约等于X
    less-equal X 掩码小于等于X

    如果只写前缀长度,掩码长度等于前缀长度
    如果只写greater-equal X,会自动补全less-equal 32

    在Route- policy同时调用ACL和ip-prix时,谁最后调用启用谁(ACL与ip-prix是覆盖关系)

    1、匹配任意掩码的路-------0.0.0.0 0 greater-equal x less-equal X
    2、匹配默认路----------------0.0.0.0 0 greater-equal 0 less-equal 0
    3、匹配所以明细路由-------0.0.0.0 0 greater-equal 1
    4、匹配所有的主机路-------0.0.0.0 0 greater-equal 32

    三、拓扑

    在这里插入图片描述

    四、策略配置

    AR-1的环回口loopback1 1.1.1.1/32模拟外部路由

    [AR-1]acl 2010
    [AR-1-acl-basic-2010] rule 5 permit source 1.1.1.1 0
    [AR-1-acl-basic-2010]rule 10 permit source 1.1.1.2 0
    
    [AR-1]route-policy di permit  node 10
    [AR-1-route-policy]if-match acl 2010
    
    [AR-1]ospf 
    [AR-1-ospf-1]import-route direct type 1 route-policy di
    

    4.1 网络互通

    在边界路由器完成双点双向路由引入实现全网互通与冗余备份

    [AR-3]isis 
    [AR-3-isis-1]network-entity 49.0001.0000.0000.0003.00
    [AR-3-isis-1]cost-style wide
    [AR-3-isis-1]quit
    [AR-3]int g0/0/0
    [AR-3-GigabitEthernet0/0/0]isis enable 
    [AR-3-GigabitEthernet0/0/0]int l0
    [AR-3-LoopBack0]isis enable 
    [AR-3-LoopBack0]quit
    [AR-3]ospf 1 router-id 3.3.3.3
    [AR-3-ospf-1]a 0   
    [AR-3-ospf-1-area-0.0.0.0]net 23.1.1.3 0.0.0.0、
    
    [AR-3]ospf 1	
    [AR-3-ospf-1]import-route isis
    [AR-3-ospf-1]isis 	
    [AR-3-isis-1]import-route ospf
    

    dis ip routing-table
    在这里插入图片描述

    4.2 网络优化

    通过路由策略消除存在次优路径与环路问题
    AR4:正常双向引入即可

    [AR-3]isis
    [AR-3-isis-1]undo import-route ospf
    [AR-3-isis-1]ospf 
    [AR-3-ospf-1]undo import-route  isis
    [AR-3-ospf-1]quit
    [AR-3]ospf 
    [AR-3-ospf-1]import-route  isis
    [AR-3-ospf-1]quit
    [AR-3]isis
    [AR-3-isis-1]import-route ospf
    [AR-3-isis-1]quit
    

    次优路径

    tracert 1.1.1.1
    在这里插入图片描述

    [AR-3]ospf 
    [AR-3-ospf-1]import-route  isis 1 type 1
    

    环路

    tracert 1.1.1.1
    在这里插入图片描述
    消除环路

    [AR-4]ip ip-prefix ospf index 10 permit 1.1.1.1 32
    [AR-4]ip ip-prefix ospf index 20 permit 2.2.2.2 32
    [AR-4]ip ip-prefix ospf index 30 permit 3.3.3.3 32
    [AR-4]ip ip-prefix ospf index 40 permit 4.4.4.4 32
    [AR-4]ip ip-prefix ospf index 50 permit 1.1.1.2 32
    
    [AR-4]route-policy ospf-->isis permit node 20
    [AR-4-route-policy]if-match  ip-prefix ospf
    [AR-4-route-policy]apply tag 100
    [AR-4-route-policy]quit
    [AR-4]isis	
    [AR-4-isis-1]import-route ospf 1 route-policy  ospf-->isis 
    [AR-4-isis-1]quit
    
    [AR-3]route-policy isis-->ospf deny node 10 //创建名称为isis-->ospf的路由策略组,此组的节点10执行拒绝路由的过滤动作
    [AR-3-route-policy]if-match tag 100         //此节点过滤带有100 tag标记的路由
    [AR-3-route-policy]quit
    [AR-3]route-policy isis-->ospf permit node 20
    
    [AR-3]ospf
    [AR-3-ospf-1]import-route isis route-policy  isis-->ospf  type 1 
    //在ospf进程中将isis进程1的路由导入,进入OSPF的IS-IS路由需要经过名称为isis-->ospf 的策略过滤 
    

    tracert 1.1.1.1
    在这里插入图片描述
    tracert 1.1.1.1
    在这里插入图片描述

    [AR-3]ip ip-prefix ospf index 10 permit 1.1.1.1 32
    [AR-3]ip ip-prefix ospf index 20 permit 2.2.2.2 32
    [AR-3]ip ip-prefix ospf index 30 permit 3.3.3.3 32
    [AR-3]ip ip-prefix ospf index 40 permit 4.4.4.4 32
    [AR-3]ip ip-prefix ospf index 50 permit 1.1.1.2 32
    
    [AR-3]route-policy ospf-->isis permit node 20
    [AR-3-route-policy]if-match ip-prefix ospf
    [AR-3-route-policy]apply  tag 200
    [AR-3-route-policy]isis
    [AR-3-isis-1]import-route ospf 1 route-policy  ospf-->isis 
    
    [AR-4]route-policy isis-->ospf deny node 8
    [AR-4-route-policy]if-match tag  200
    [AR-4-route-policy]quit
    [AR-4]route-policy isis-->ospf permit node 20
    
    [AR-4-ospf-1]import-route  isis route-policy  isis-->ospf  type 1
    

    tracert 1.1.1.1
    在这里插入图片描述
    tracert 1.1.1.1
    在这里插入图片描述

    [AR-4]route-policy isis-->ospf  permit node 15
    [AR-4-route-policy]apply tag 300
    [AR-4-route-policy]quit
    
    [AR-4]route-policy ospf-->isis  deny node 8
    [AR-4-route-policy]if-match  tag  400
    
    [AR-3]route-policy ospf-->isis  deny node 8
    [AR-3-route-policy]if-match tag  300
    [AR-3-route-policy]quit
    
    [AR-3]route-policy isis-->ospf  permit node 20
    [AR-3-route-policy]apply  tag 400
    

    消除次优

    [AR-4]route-policy isis-->pre permit node 20
    [AR-4-route-policy]if-match  tag  200
    [AR-4-route-policy]apply preference 151
    [AR-4-route-policy]quit
    [AR-4]isis
    [AR-4-isis-1]preference route-policy isis-->pre 15
    
    [AR-3]route-policy isis-->pre permit node 10
    [AR-3-route-policy]if-match tag  100
    [AR-3-route-policy]apply preference 151
    [AR-3-route-policy]isis 	
    [AR-3-isis-1]preference  route-policy  isis-->pre 15
    

    tracert 1.1.1.1
    在这里插入图片描述

    4.3 网络控制

    网络控制(不要修改接口开销)

    ① 修改开销(引入)
    ② 修改优先级(注意匹配策略)
    ③ 修改下一跳权值
    ④ 静态
    ⑤ 过滤

    (1)OSPF网络(AR-4除外)去往6.6.6.1的数据走上行线路:R3---->R5---->R6

    修改开销

    [AR-4]ip ip-prefix 35 permit  35.1.1.0 24
    [AR-4]ip ip-prefix 35 permit  6.6.6.1 32
    
    [AR-4]route-policy isis-->ospf permit  node 14
    [AR-4-route-policy]if-match ip-prefix 35 
    [AR-4-route-policy] apply cost 20 
    [AR-4-route-policy] apply tag 200
    

    在这里插入图片描述
    (2)OSPF网络(AR-3除外)去往6.6.6.2的数据走下行线路:R4---->R5---->R6

    修改优先级

    [AR-2]ip ip-prefix 23 permit 23.1.1.3 32
    [AR-2]ip ip-prefix 62 permit 6.6.6.2 32
    
    [AR-2]route-policy pre permit node 10
    [AR-2-route-policy]if-match ip-prefix 62
    [AR-2-route-policy]if-match  ip next-hop  ip-prefix 23
    [AR-2-route-policy]apply  preference 130
    [AR-2-route-policy]quit
    
    [AR-2]ospf	
    [AR-2-ospf-1]preference ase route-policy  pre
    

    dis ip routing-table
    在这里插入图片描述
    (3)IS-IS网络(AR-3除外)去往1.1.1.2的数据走下行线路: R4---->R2---->R1

    在AR-3上配置:增加1.1.1.2的开销值

    [AR-3]ip ip-prefix 452 permit 1.1.1.2 32
    [AR-3]route-policy ospf-->isis permit node 16
    	
    [AR-3-route-policy]if-match ip-prefix 452
    [AR-3-route-policy]apply tag 100
    [AR-3-route-policy]apply cost 200
    [AR-3-route-policy]quit
    
    [AR-3]route-policy ospf-->isis  permit  node 22
    [AR-3-route-policy]apply tag 100
    

    dis ip routing-table
    在这里插入图片描述
    (4)IS-IS网络(AR-4除外)去往1.1.1.1的数据走上行线路: R3---->R2---->R1

    策略路由----指定数据转发----不查看路由表

    ① 匹配数据
    acl

    ② 制定流分类
    traffic classifier

    ③ 制定流行为
    traffic behavior

    ④ 策略的组合
    traffic policy 数据与策略的组合

    ⑤ 挂接流策略
    在数据的进站方向挂接

    用策略路由写

    [AR-5]acl 3010
    [AR-5-acl-adv-3010]rule 10 permit ip source any destination 1.1.1.1 0  //匹配内网去往1.1.1.1的流量
    [AR-5-acl-adv-3010]quit
     
    [AR-5]traffic classifier host           //创建名称为host的流分类(这里匹配的到的数据将执行流动作)
    [AR-5-classifier-host]if-match acl 3010 //通过acl3010获得流量需要执行流分类	
    [AR-5-classifier-host]quit
    
    [AR-5]traffic behavior host                       //创建名称为host的流行为
    [AR-5-behavior-host]redirect ip-nexthop 35.1.1.3  //这个流行为匹配到的流量执行下一跳重定向动作
    [AR-5-behavior-host]quit
    
    [AR-5]traffic policy host                              //创建名称为host的流策略
    [AR-5-trafficpolicy-host]classifier host behavior host //将名称为host流分类匹配到数据和名称为host的流行为结合
    [AR-5-trafficpolicy-host]quit
    
    [AR-5]int g0/0/2  
    [AR-5-GigabitEthernet0/0/2]traffic-policy host  inbound
    //将名称为cl的流策略挂接到此接口的入方向,进入此接口被匹配到数据将安装流策略的规定动作转发,没有匹配到数据按照路由表正常转发
    

    策略优先级高于路由表优先级

    tracert 1.1.1.1
    在这里插入图片描述

    在这里插入图片描述

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • 路由策略 & 策略路由

    万次阅读 2019-08-29 11:45:43
    策略路由PBR(Policy-Based Routing)是一种依据用户制定的策略进行路由选择的机制,分为本地策略路由、接口策略路由和智能策略路由SPR(Smart Policy Routing)。 策略路由具有如下优点: 可以根据用户实际需求...

    一、策略路由

            策略路由PBR(Policy-Based Routing)是一种依据用户制定的策略进行路由选择的机制,分为本地策略路由、接口策略路由和智能策略路由SPR(Smart Policy Routing)。

    策略路由具有如下优点:

    • 可以根据用户实际需求制定策略进行路由选择,增强路由选择的灵活性和可控性。
    • 可以使不同的数据流通过不同的链路进行发送,提高链路的利用效率。
    • 在满足业务服务质量的前提下,选择费用较低的链路传输业务数据,从而降低企业数据服务的成本。

            本地策略路由仅对本机下发的报文进行处理,对转发的报文不起作用。

            一条本地策略路由可以配置多个策略点,并且这些策略点具有不同的优先级,本机下发报文优先匹配优先级高的策略点。

    实现原理:

            本机下发报文时,根据本地策略路由节点的优先级,依次匹配各节点绑定的匹配规则,本地策略路由支持基于ACL或报文长度的匹配规则。

    接口策略路由:

            接口策略路由只对转发的报文起作用,对本地下发的报文(比如本地的Ping报文)不起作用。

    实现原理:

            接口策略路由通过在流行为中配置重定向实现,只对接口入方向的报文生效。缺省情况下,设备按照路由表的下一跳进行报文转发,如果配置了接口策略路由,则设备按照接口策略路由指定的下一跳进行转发。

            在按照接口策略路由指定的下一跳进行报文转发时,如果设备上没有该下一跳IP地址对应的ARP表项,设备会触发ARP学习,如果一直学习不到下一跳IP地址对应的ARP表项,则报文按照路由表指定的下一跳进行转发。如果设备上有或者学习到了此ARP表项,则按照接口策略路由指定的下一跳IP地址进行报文转发。

    二、路由策略

    定义:

            路由策略主要实现了路由过滤和路由属性设置等功能,它通过改变路由属性(包括可达性)来改变网络流量所经过的路径。

    目的:

            路由协议在发布、接收和引入路由信息时,根据实际组网需求实施一些策略,以便对路由信息进行过滤和改变路由信息的属性,如:

    • 控制路由的接收和发布

      只发布和接收必要、合法的路由信息,以控制路由表的容量,提高网络的安全性。

    • 控制路由的引入

      在一种路由协议引入其它路由协议发现的路由信息丰富自己的路由信息时,只引入一部分满足条件的路由信息。

    • 设置特定路由的属性

      修改通过路由策略过滤的路由的属性,满足自身需要。

    路由策略的实现分为两个步骤:

    1、定义规则:首先要定义将要实施路由策略的路由信息的特征,即定义一组匹配规则,可以以路由信息中的不同属性作为匹配依据进行设置,如目的地址、AS号等;

    2、应用规则:根据设置的匹配规则,再将它们应用于路由的发布、接收和引入等过程中。

            目前提供了如下几种过滤器供路由协议引用: 访问控制列表; 地址前缀列表; AS路径过滤器; 团体属性过滤器; 扩展团体属性过滤器; 路由标识属性过滤器。

    前缀列表的组成及匹配规则:

            前缀过滤列表由IP地址和掩码组成,IP地址可以是网段地址或者主机地址,掩码长度的配置范围为0~32。

            IP-Prefix List中的每一条IP-Prefix都有一个序列号index,匹配的时候将根据序列号从小到大进行匹配。 如果不配置IP-Prefix的index,那么对应的index在上次配置的同名IP-Prefix的index的基础上,以步长为10进行增长。如果配置的IP-Prefix的名字与index都和已经配置了的一项IP-Prefix List的相同,仅仅只是匹配的内容不同,则该IP-Prefix List将覆盖原有的IP-Prefix List。 当所有前缀过滤列表均未匹配时,缺省情况下,存在最后一条默认匹配模式为deny。 当引用的前缀过滤列表不存在时,则默认匹配模式为permit。

            前缀掩码长度范围: 前缀过滤列表可以进行精确匹配或者在一定掩码长度范围内匹配,并通过配置关键字greater-equal和less-equal来指定待匹配的前缀掩码长度范围。如果没有配置关键字greater-equal或less-equal,前缀过滤列表会进行精确匹配,即只匹配掩码长度为与前缀过滤列表掩码长度相同的IP地址路由;如果只配置了关键字greater-equal,则待匹配的掩码长度范围为从greater-equal指定值到32位的长度;如果只匹配了关键字less-equal,则待匹配的掩码长度范围为从指定的掩码到关键字less-equal的指定值。

    策略路由与路由策略(Routing Policy)存在以下不同:

    • 策略路由的操作对象是数据包,在路由表已经产生的情况下,不按照路由表进行转发,而是根据需要,依照某种策略改变数据包转发路径。
    • 路由策略的操作对象是路由信息。路由策略主要实现了路由过滤和路由属性设置等功能,它通过改变路由属性(包括可达性)来改变网络流量所经过的路径。
    • 策略路由的查找优先级比路由策略高,当路由器接收到数据包并进行转发时,会优先根据策略路由的规则进行匹配,如果能匹配上,则根据策略路由进行转发,否则按照路由表中的路由条目来进行转发。
    • 其中策略路由不改变路由表中的任何内容,它可以通过预先设置的规则来影响数据报文的转发。
    展开全文
  • 本文介绍网络技术中策略路由与路由策略的原理及区别,详细介绍策略路由与路由策略具体的配置命令及实验案例演示。
  • 路由策略与策略路由知识总结
  • 路由策略和策略路由

    千次阅读 2020-03-14 16:43:59
    2.策略路由策略路由是一种比基于目标网络进行路由更加灵活的数据包路由转发机制。应用了策略路由,路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器。 操作对象...

    概念简述

    1.路由策略:路由策略是为了改变网络流量所经过的途径而修改路由信息的技术,主要通过改变路由属性(包括可达性)来实现。

    操作对象:路由条目

    2.策略路由:策略路由是一种比基于目标网络进行路由更加灵活的数据包路由转发机制。应用了策略路由,路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器。

    操作对象:数据包


    路由策略

    使用相应的技术将路由条目分离、打标签、独立出来,然后针对路由条目做控制,做过滤,或者做条目属性的更改。路由重分发、分发列表是典型的路由策略。

    重分布

    注意:
    1.所有的重分布都是在各协议的边界上进行相关配置
    2.进行重分布的两个区域必须相邻。
    在这里插入图片描述
    RIP与EIRGP的重分布:

    R2(config)#router eigrp 100
    //将RIP的路由条目重分布进EIGRP中,5K值如下所示
    R2(config-router)#redistribute rip metric 10000 100 255 1 1500
    R2(config-router)#exit
    R2(config)#router rip
    //将EIGRP的路由条目重分布进RIP中,并为其设置跳数
    R2(config-router)#redistribute eigrp 100 metric 1
    R2(config-router)#exit
    

    EIGRP与OSPF的重分布:

    R3(config)#router eigrp 100
    //将OSPF的路由条目重分布到EIGRP中
    R3(config-router)#redistribute ospf 100 metric 10000 100 255 1 1500
    R3(config-router)#exit
    R3(config)#router ospf 100
    //将EIGRP的路由条目重分布到OSPF中
    R3(config-router)#redistribute eigrp 100 subnets 
    

    RIP与OSPF的重分布:

    R1(config)#router ospf 100
    //将RIP的路由条目重分布进OSPF中
    R1(config-router)#redistribute rip subnets 
    R1(config-router)#exit  
    R1(config)#router rip 
    //将OSPF的路由条目重分布进RIP中
    R1(config-router)#redistribute ospf 100 metric 1
    R1(config-router)#exit  
    

    分发列表
    1.对于距离矢量路由协议,如RIP,EIGRP
    在这里插入图片描述
    路由器之间,传递的是路由信息,分发列表对路由信息是有绝对的控制权。因此如果是in方向,那么通过部署分发列表,可以过滤特定的路由,使得执行分发列表的本地路由路由表发生变化,同时,本地路由器在更新路由信息给下游路由器的时候,实际上更新的内容是受分发列表影响之后的条目。同时在out方向,也是没有问题的。
    在这里插入图片描述

    //抓取路由前缀并进行匹配
    R2(config)#access-list 2 permit 3.3.3.0
    R2(config)#route-map AA deny 10
    R2(config-route-map)#match ip address 2
    R2(config-route-map)#exit
    R2(config)#route-map AA permit 20
    R2(config-route-map)#exit
    R2(config)#router eigrp 100
    R2(config-router)#redistribute ospf 100 metric 10000 100 255 1 1500 route-map AA
    R2(config-router)#exit
    
    

    2.对于链路状态路由协议,如OSPF
    在这里插入图片描述
    值得注意的是,对于OSPF这样的链路状态路由协议,路由器之间传递的消息不再是路由信息了,而是LSA,而分发列表是无法对LSA进行过滤的。因此,在链路状态协议中部署分发列表,就需要留意了:

    in方向,分发列表只能在本地收到LSA后,生成路由的那一刹那进行路由的过滤,执行分发列表的路由器自己路由表会被分发列表影响(但是本地LSDB仍然是有LSA的),而且该路由器仍会将LSADB中的LSA发送给邻居,因此本地被过滤的路由,邻居还会有。

    out方向,分发列表只能工作在执行路由重分发动作的那个ASBR上,且只能针对外部引入的路由起作用。因为OSPF执行重发布时,其实这些外部路由是以路由的形式引入进来的,因此分发列表在这个场合下能够正常工作,但是如果不是本地始发的外部路由,或者是内部的OSPF路由,out方向的分发列表均束手无策。

    实验模拟
    在这里插入图片描述
    基本配置完成后,R2上的路由表如下所示

    R2(config-router)#do show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         1.0.0.0/32 is subnetted, 1 subnets
    O       1.1.1.1 [110/2] via 100.1.1.1, 00:06:04, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback0
         100.0.0.0/24 is subnetted, 1 subnets
    C       100.1.1.0 is directly connected, FastEthernet0/0
         3.0.0.0/24 is subnetted, 1 subnets
    D       3.3.3.0 [90/156160] via 101.1.1.2, 00:01:56, FastEthernet1/0
         101.0.0.0/24 is subnetted, 1 subnets
    C       101.1.1.0 is directly connected, FastEthernet1/0
    

    现要使R2不再接收1.1.1.1的路由条目,则需要在R2上进行如下配置

    //ACL抓取感兴趣数据流
    R2(config)#access-list 1 permit 1.1.1.1  
    //定义route-map名称及拒绝的编号
    R2(config)#route-map A deny 10
    //匹配ACL抓取的数据流
    R2(config-route-map)#match ip address 1 
    R2(config-route-map)#exit
    //定义允许通过的数据流编号
    R2(config)#route-map A permit 20
    R2(config-route-map)#exit
    

    配置完成后,R2的路由表如下所示,拒绝访问要求完成:

    R2(config-router)#do show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback0
         100.0.0.0/24 is subnetted, 1 subnets
    C       100.1.1.0 is directly connected, FastEthernet0/0
         3.0.0.0/24 is subnetted, 1 subnets
    D       3.3.3.0 [90/156160] via 101.1.1.2, 00:14:08, FastEthernet1/0
         101.0.0.0/24 is subnetted, 1 subnets
    C       101.1.1.0 is directly connected, FastEthernet1/0
    R2(config-router)#do show run | section access-list
    access-list 1 permit 1.1.1.1
    

    策略路由

    在路由的基础之上,针对数据层面做控制,可以精确把控数据的走向,策略优先于路由,先匹配策略,再匹配路由。

    在这里插入图片描述
    GW

    //抓取感兴趣数据流
    GW(config)#access-list 100 permit tcp host 192.168.1.10 host 130.1.1.1 eq telnet 
    GW(config)#access-list 101 permit tcp host 192.168.1.20 host 130.1.1.1 eq telnet
    GW(config)#access-list 102 permit icmp host 192.168.1.10 host 130.1.1.1 echo
    GW(config)#access-list 103 permit icmp host 192.168.1.20 host 130.1.1.1 echo
    //进行匹配并设置下一跳地址
    GW(config)#route-map AA permit 10
    GW(config-route-map)#match ip address 100
    GW(config-route-map)#set ip next-hop 100.1.1.1
    GW(config-route-map)#exit
    GW(config)#route-map AA permit 20
    GW(config-route-map)#match ip address 101
    GW(config-route-map)#set ip next-hop 200.1.1.1
    GW(config-route-map)#exit
    GW(config)#route-map AA permit 30
    GW(config-route-map)#set ip next-hop 200.1.1.1
    GW(config-route-map)#exit
    GW(config)#route-map AA permit 40
    GW(config-route-map)#set ip next-hop 100.1.1.1
    GW(config-route-map)#exit
    //在接口下进行挂接
    GW(config)#interface f0/0
    GW(config-if)#ip policy route-map AA
    GW(config-if)#exit
    

    查看已配置的策略

    GW(config)#do show run | section route-map
    route-map AA permit 10
     match ip address 100
     set ip next-hop 100.1.1.1
    route-map AA permit 20
     match ip address 101
     set ip next-hop 200.1.1.1
    route-map AA permit 30
     match ip address 102
     set ip next-hop 200.1.1.1
    route-map AA permit 40
     match ip address 103
     set ip next-hop 100.1.1.1
    

    实验验证:

    telnet验证
    在这里插入图片描述
    在这里插入图片描述
    验证结果:telnet相关的实验要求已完成。

    ping 数据包验证:
    首先在电信和联通设备上开启DEBUG功能,然后使用两台PC ping 130.1.1.1 。
    在这里插入图片描述
    在这里插入图片描述
    验证结果:ping 数据包指定路径要求已完成。

    总结:策略优先于路由,通过策略告诉设备去往哪里要从哪走。数据包在传输过程中,先查策略,若没有策略,则查路由。

    参考资料:http://blog.sina.com.cn/s/blog_5ec353710101ebbr.html

    展开全文
  • 策略路由与路由策略

    千次阅读 2019-08-01 17:29:52
    PBR策略路由 通过流量策略来执行选路的手段,直接针对流量,在路由表已经出来的情况下,让某些通信的流量不按路由表中的选路执行。 路由策略 在控制层面,在正常的路由策略之上,根据某种规则,通过改变一些参数,...
  • 策略路由以及使用 ip route , ip rule , iptables 配置策略路由实例.pdf
  • 策略路由策略路由规则匹配

    千次阅读 2019-08-18 12:26:05
    这篇笔记来看看路由查询过程中,到底是如何根据策略路由规则引导最终的路由数据库查询的。
  • 路由策略与策略路由
  • 路由策略仅仅影响路由信息的发布、接收或选择,从而...策略路由是作用于报文转发的时候,它可以通过设置的规则直接影响数据报文的转发。 路由策略与策略路由的工作层面以及面向的对象均不同。我们应该掌握二者的区别。
  • 策略路由:一般情况下,数据包的转发是根据目的地址查路由表确定转发路径,如下图,RTA和RTB访问RTF的流量都会被RTC转发给RTD。如果用户要求RTB访问RTF的流量经RTE转发,那么,可以通过在RTC上部署策略路由来实现。...
  • 路由策略与策略路由的区别这两中方案都是为了控制网络流量的可达性或调整网络流量的路径:一、路由策略。(Route-Policy)路由策略是通过修改路由表的路由条目来控制数据流量的可达性。即对接受和发布的路由进过滤。...
  • Linux策略路由.pdf

    2021-08-26 14:51:43
    Linux策略路由.pdf
  • 文章目录前言控制网络流量可达性路由策略路由策略的应用方式ACL应用IP-Prefix List应用Filter-Policy工具介绍Route-Policy工具介绍策略路由 前言   在企业网络的设备通信中,常面临一些非法流量访问的安全性及...
  • 策略路由配置

    千次阅读 2019-11-04 17:53:37
    策略路由:通过配置数据包下一跳决定数据路径,可以实现源地址或目的地址(IP或网段)路由出口所走的路由器进出口; 策略路由具体配置可以分为3个部分: 1、配置acl,用作配置允许访问列表; acl number 3000 //...
  • 2.通过策略路由,使得总部PC6通过AR2-AR3-AR4访问财务部,总部PC5通过AR2-AR1-AR4访问财务部。 涉及到的内容:路由策略、策略路由、OSPF、地址前缀列表、访问控制列表等 首先我们先配置好各个端口及主机的IP地址、...
  • 策略路由

    2014-03-04 13:46:42
    只有策略路由所使用的接口出现down后,路由比表中配置的路由才起作用。 3 配置举例 组网需求 图1为2条链路负载分担的典型组网。 路由器以太网口ETH2/0连接到ISP1,网络地址为142.1.1.0/30,以太网口ETH3/0连接到...
  • 策略路由,是一种比基于目标网络进行路由更加灵活的数据包路由转发机制。路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器。
  • 可能很多人对策略路由原理还不是特别的了解,这里我们主要分析了策略路由原理的详细知识。传统的策略路由原理都是使用从路由协议派生出来的路由表,根据目的地址进行报文的转发。在这种机制下,路由器只能根据报文的...
  • 联通策略路由

    2012-11-07 14:14:49
    联通策略路由,2011年底前整理,仅作参考
  • 简单介绍虚拟局域网(VLAN)及策略路由的概念,详细介绍在Linux下VLAN及策略路由的实现,根据具体问题并结合实例详细介绍在Linux下如何将二者结合解决实际问题。
  • 策略路由(转发策略):(先执行策略,不行再执行路由) 路由表已产生的情况下,不按照现有路由表进行转发;通过流量策略来执行选路的转发手段; 传统的路由表转发只能通过数据的目标地址提供路由,而策略路由...
  • 先说策略路由也就是PBR: 它不会影响路由表的生成,设备的路由表是已经存在而且稳定的。 举个例子: 用TCP/IP路由技术一书的表述就是:策略路由就是一个复杂的静态路由。 总结:策略路由是一个基于路由表的影响特定...
  • 这两中方案都是为了控制网络流量的可达性...(Traffic-Policy)策略路由是通过用户制定的策略进行转发,且该策略优于路由表的转发。这种方式称为策略路由。由此可知,路由策略是基于路由表进行流量的转发,而策略路...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 145,212
精华内容 58,084
关键字:

策略路由