精华内容
下载资源
问答
  • 路由器原理

    2019-01-20 22:11:07
    路由器 路由器是网络传输的枢纽,有两种相当重要的机制,即路由与转发。 如图,路由是在控制层面完成的,转发则是在数据层面完成的。

    路由器

    	路由器是网络传输的枢纽,路由与转发可以说是其最重要的两个机制。
    

    如图,路由是在控制层面完成的,转发则是在数据层面完成的。
    路由指路由器cpu运行路由选择协议,计算出数据包从源到目标的路径,并将结果加入到路由表中。在拥有cef机制的路由器中还会进一步优化路由表并生成一张转发表(FIB),这种交换方式是基于硬件的ASIC芯片,远比原始的包交换优越。
    高性能的路由器都基于硬件来转发,CAM/TCAM就是两种优异的存储器,无论表大小如何,都会在一个时钟周期内检索出地址。
    在这里插入图片描述 CAM执行的是如图所示的二元匹配,只匹配0和1,这种匹配方式非常适合交换机查找MAC。
    在这里插入图片描述TCAM执行的是如上图所示的三元匹配,匹配0,1和不在乎,这种方式相当适合路由器查找路由。
    交换结构是⼀台路由器的核⼼组件,它的作用就是根据转发表对分组进⾏处理,将某个输入端⼝进⼊的分组从一个合适的输出端⼝转发出去。交换结构本身就是⼀种⽹络,但这种⽹网络完全包含在路由器中,因此交换结构又可看成是”在路由器中的网络”
    路由器的发展史
    第一代:集成式
    主要功能是通过软件实现的,cpu既要路由也要转发,非常麻烦。

    第二代:模块化
    一次查表多次路由。接口被赋予了更多功能。

    第三代:分布式软件转发
    将路由和转发已经分开。

    第四代:基于ASIC芯片
    在路由与转发分开的基础上,硬件已经采用了ASIC芯片,转发能力大大提升。

    第五代:np芯片
    其特点是有编程性,可以同时对很多业务进行硬件处理,如qos,ipv6,,MPLS VPN等。

    NP与ASIC比较之前 性能更高:对新的增 值业务(MPLS、QOS、组播等等)迅速⽀持;

    展开全文
  • NAT路由器原理及其应用中需要注意的事项。
  • 路由器原理-实验

    2019-08-26 20:05:46
    原理: 规划网段(路由是隔离网段的) 思科路由器 静态路由协议缺点: 1、配置麻烦 2、在下一跳找不准 静态路由协议优点: 不占用CPU和内存资源 静态路由配置 拓扑图: ...

    路由器

    • 原理:
      • 规划网段(路由是隔离网段的)
      • 思科路由器
        • 静态路由协议缺点:
          • 1、配置麻烦
          • 2、在下一跳找不准
        • 静态路由协议优点:
          • 不占用CPU和内存资源
        • 静态路由配置
          • 拓扑图:
          • 1、配置每个节点的IP地址
            • R0:
              • Router(config)#interfacef0/0
              • Router(config-if)#noshutdown
              • Router(config-if)#ipaddress 192.168.10.1 255.255.255.0
              • Router(config-if)#exit
              • Router(config)#interfacef0/1
              • Router(config-if)#ipaddress 192.168.20.1 255.255.255.0
              • Router(config-if)#noshutdown
            • R1:
              • Router(config)#interfacef0/0
              • Router(config-if)#noshutdown
              • Router(config-if)#ipaddress 192.168.20.2 255.255.255.0
              • Router(config-if)#exit
              • Router(config)#interfacef0/1
              • Router(config-if)#noshutdown
              • Router(config-if)#ipaddress 192.168.30.1 255.255.255.0
              • Router(config-if)#exit
            • R2:
              • Router(config)#interfacef0/0
              • Router(config-if)#noshut
              • Router(config-if)#ipaddress 192.168.30.2 255.255.255.0
              • Router(config-if)#exit
              • Router(config)#interfacef0/1
              • Router(config-if)#noshutdown
              • Router(config-if)#ipaddress 192.168.40.1 255.255.255.0
          • 增加下一跳地址
            • R0:
              • ip route 192.168.30.0255.255.255.0 192.168.20.2
              • ip route 192.168.40.0 255.255.255.0 192.168.20.2
            • R1:
              • ip route 192.168.10.0255.255.255.0 192.168.20.1
              • ip route 192.168.40.0 255.255.255.0 192.168.30.2
            • R3:
              • ip route 192.168.10.0255.255.255.0 192.168.30.1
              • ip route 192.168.20.0 255.255.255.0 192.168.30.1
        • 动态路由协议(RIP)
          • 1、配置每个节点IP地址
            • 和静态路由第一步一致
          • 2添加rip(查看自已的路由表,然后把自已带C的网段添加rip就可以了)
            • R0:
              • Router#show ip route
              • C 192.168.10.0/24 isdirectly connected, FastEthernet0/0
              • C 192.168.20.0/24 isdirectly connected, FastEthernet0/1
              • Router#conf t
              • Router(config)#routerrip
              • Router(config-router)#network192.168.10.0
              • Router(config-router)#network192.168.20.0
            • R1:
              • Router#show ip route
              • C 192.168.20.0/24 isdirectly connected, FastEthernet0/0
              • C 192.168.30.0/24 isdirectly connected, FastEthernet0/1
              • Router#conf t
              • Router(config)#routerrip
              • Router(config-router)#network192.168.20.0
              • Router(config-router)#network192.168.30.0
            • R2:
              • Router#show ip route
              • C 192.168.30.0/24 isdirectly connected, FastEthernet0/0
              • C 192.168.40.0/24 isdirectly connected, FastEthernet0/1
              • Router#conf t
              • Router(config)#routerrip
              • Router(config-router)#network192.168.30.0
              • Router(config-router)#network192.168.40.0
      • 不管是静路由协议还是动态路由协议最终的目的都是为了让每台三层设备都有所有的网段
    • 华为路由器
      • 拓扑图:
      • 动态路由和静态路由配置:
        • 配置节点IP
          • R2:
            • [Huawei]interface e0/0/0
            • [Huawei-Ethernet0/0/0]undo shutdown
            • [Huawei-Ethernet0/0/0]ip address 10.1.1.2 255.255.255.0
            • [Huawei-Ethernet0/0/0]quit
            • [Huawei]interface e0/0/1
            • [Huawei-Ethernet0/0/1]undo shutdown
            • [Huawei-Ethernet0/0/1]ip address 192.168.10.1 255.255.255.0
          • R3:
            • [Huawei]interface e0/0/1
            • [Huawei-Ethernet0/0/1]undo shutdown
            • [Huawei-Ethernet0/0/1]ip address 10.1.2.2 255.255.255.0
            • [Huawei-Ethernet0/0/1]quit
            • [Huawei]interface e0/0/0
            • [Huawei-Ethernet0/0/0]undo shutdown
            • [Huawei-Ethernet0/0/0]ip address 192.168.20.2 255.255.255.0
          • R1:
            • [Huawei]interface e0/0/0
            • [Huawei-Ethernet0/0/0]undo shutdown
            • [Huawei-Ethernet0/0/0]ip address 192.168.10.2 255.255.255.0
            • [Huawei-Ethernet0/0/0]quit
            • [Huawei]interface e0/0/1
            • [Huawei-Ethernet0/0/1]undo shutdown
            • [Huawei-Ethernet0/0/1]ip address 192.168.20.1 255.255.255.0
            • [Huawei-Ethernet0/0/1]quit
        • 添加静态路由
          • R1:
            • ip route-static 10.1.1.0 255.255.255.0 192.168.10.1
            • ip route-static 10.1.2.0 255.255.255.0 192.168.20.2
          • R2:
            • ip route-static192.168.20.0 255.255.255.0 192.168.10.2
            • ip route-static 10.1.2.0 255.255.255.0 192.168.10.2
          • R3:
            • ip route-static192.168.10.0 255.255.255.0 192.168.20.1
            • ip route-static 10.1.1.0 255.255.255.0 192.168.20.1
        • 添加RIP(动态路由协议)
          • R1:
            • [Huawei]rip 1
            • [Huawei-rip-1]network192.168.10.0
            • [Huawei-rip-1]network192.168.20.0
          • R2:
            • [Huawei]rip 1
            • [Huawei-rip-1]network 192.168.10.0
            • [Huawei-rip-1]network 10.1.1.0
          • R3:
            • [Huawei]rip 1
            • [Huawei-rip-1]network192.168.20.0
            • [Huawei-rip-1]network 10.1.2.0
    展开全文
  • 用户的需求推动着路由技术的发展和路由器的普及,人们已经不满足于仅在本地网络上共享信息,而希望最大限度地利用全球各个地区、各种类型的网络资源。...本文就路由器原理和路由协议、算法进行详解。
  • 路由器原理与技术(张宏科);高清实书扫描版;本科教学用书
  • 路由器原理(一)

    2019-08-08 23:12:30
    路由器原理(一) 2017年11月24日 09:24:10hhthwx阅读数 14957 觉得之前对路由器的了解还不是特别清楚,继续来学习,是参考了路由器的原理及其配置(一) 一:路由器的基础知识 (1)路由器的概述: 作为网络层的...

    路由器原理(一)

    2017年11月24日 09:24:10  阅读数 14957

    觉得之前对路由器的了解还不是特别清楚,继续来学习,是参考了路由器的原理及其配置(一) 
    一:路由器的基础知识 
    (1)路由器的概述: 
    作为网络层的网络互连设备路由器在网络互连中起到了不可或缺的作用。与物理层或数据链路层的网络互连设备相比,其具有一些物理层或数据链路层的网络互连设备所没有的重要功能。它能实现异构网络的互连,在物理上拓展了网络的规模;实现网络的逻辑划分;实现VLAN之间的通信;同时,还可以实现其他一些重要的网络功能,如提供访问控制功能、优先级服务和负载平衡等。

    <span style="color:#000000"><code>  路由器是工作在网络层的设备。路由器负责将数据分组从源端主机经最佳路径传送到目的端主机。路由器主要用于同类或异类局域网以及局域网与广域网之间的互联。是连接不同逻辑子网的网络互连设备。路由器具有异构网络互连,广域网互连,和隔离广播信息的能力。
    </code></span>
    • 1

    (2)路由器工作原理 
    a)路由器的基本功能 
    1,路由选择 
    路由选择就是路由器依据目的IP地址的网络地址部分,通过路由选择算法确定一条从源结点到达目的结点的最佳路由。 
    路由器通过路由协议,网络连接的情况及网络的性能来建立网络的拓扑结构。路由算法为网络上的路由产生一个权值,路由器通过权值来选择最佳路径,权值越小,路由最佳。 
    对于一台路由器,其分组转发的任务即是在收到数据包后,根据路由表所提供的最佳路径的信息,将其转发给下一条的路由器,目的端口或是缺省路由器。缺省路由器也称缺省开关,它是与主机在同一个子网中的路由端口的IP地址。 
    路由器也有它的缺省开关。如果目标网络中没有直接显示在路由表里的时候,那么就将数据分组传送给缺省网关。它一般指向与该路由器的一个端口的直接相连接的,并且通往Interest的出口路由。 
    主机的缺省路由图: 
    这里写图片描述
    路由器的缺省路由图: 
    这里写图片描述
    分组转发的思想: 
    目的IP地址,全程不变。 
    目的MAC地址,逐跳修改。 
    分组转发的示意图: 
    (3)路由表 
    a)路由表基本结构 
    路由表通过对路由表的查询来选择最佳路径的策略,路由表中保存着各种传输路径的相关数据,供路由选择时使用。 
    b)路由表的内容主要包括: 
    1,目的网络地址及其所对应的目的端口 
    2,下一跳路由器的名字 
    3,缺省路由的信息 
    路由表可以是由系统管理员固定设置好的,也可以由系统动态修改,可以由路由器自动调整,也可以由主机控制。 
    路由表结构示意图: 
    这里写图片描述 
    c)路由表实例一 
    路由表项讨论: 
    1,“C”:直连,“S”静态,“I”:IGRP,“O”:OSPF,“R”:RIP,“i”:ISIS,“B“:BGP,“E”:EGP。 
    2,第二列是目的网络地址和掩码 
    3,第三列是目的端口或下一跳路由器地址 
    如果是直连,则这个字段为给出的目的端口 
    如果有下一跳路由器,则为下一跳路由器的IP地址 
    4,缺省路由的路由表项网络地址全是0 
    d)路由表实例二 
    路由表项讨论: 
    1,第二列表示路由类型 
    E1 OSPF外部路由类型1 
    E2 OSPF外部路由类型2 
    2,第四列,如【110/22】 
    310是管理距离,22是权值(metric)或成本 
    管理距离用于衡量路由表中给定的路由信息源的”可信度“ 
    各路由协议的管理距离表: 
    路由器常用的权值包括: 
    1)带宽:链路的数据能力 
    2)延迟:数据包从源送到目的所需的时间 
    3)负载:链路上的活动数量 
    4)可靠性:链路的差错率 
    5)跳数:通过路由器的数量 
    6)滴答数:用IBM PC的时钟滴答计数延迟 
    7)花费:花费一般由管理员指定 
    (4)路由器的结构 
    路由器的结构就像一台计算机,但它是一台具有特殊功能的计算机。路由器与计算机一样具有中央处理器、内 
    存、存储器和接口等硬件系统。同时路由器的软件主要是由路由器的操作系统——互联网络操作系统组成。硬件系统 
    和软件系统共同组成路由器。 
    路由器的硬件结构示意图: 
    a)中央处理器 
    CPU是路由器的处理核心,CPU负责实现路由协议,路径选择计算,交换路由信息,查找路由表,分发路由表和维护各种表格,以及转发数据包等功能。CPU的处理能力直接影响路由表查找时间,吞吐量和路由器的性能。 
    b)内存 
    1,只读内存(Read Only Memory ,ROM) 
    ROM中包括开机诊断程序,引导程序和操作系统软件。不能修改其中保存的内容。 
    2,随机存储器(RAM) 
    RAM是可读可写存储器。用来存储用户的数据包队列以及路由器在运行过程中产生的中间数据,如路由表,ARP缓冲区等。此外,RAM还用来存储路由器的运行配置文件。当路由器被关闭或重新启动时,RAm中的内容都将丢失。 
    3,非易失性随机存储器(NVRAM) 
    NVRAM是可读可写存储器。是用来存储路由器的启动配置文件。在路由器断电时,其内容仍能保持。 
    4,闪存(flash) 
    是可擦写的ROM。它主要负责保存操作系统的映像文件和一些微代码。在路由器断电时,其内容仍能保持。 
    c)接口 
    1)局域网接口:包括以太网,快速以太网,千兆以太网,FDDI,ATM等。 
    2)广域网接口:高速同步串行接口,异步串行接口,ISDM的PRI和BRI接口。 
    3)接口配置:有控制接口Console(RJ-45)和辅助接口(AUX)。AUX通过MODEM连接广域网,拨号的方式实现对路由器的远程管理。 
    路由器的每个接口都有自己的名字和编号,如快速以太网的名字是FastEthernet,它可以简写为f。接口编号的格式是mod/port,mod是模块号,port是端口号。如接口0/5,指的是第0模块上的第5个端口。 
    (5)路由器的工作模式 
    a)用户模式 
    当通过控制台或Telnet成功登录到路由器后,将会看到它是一种只读模式,用户可以浏览关于路由器的某些信息,但不能进行任何修改。 
    该模式默认的提示符为:router> 
    b)特权模式 
    在用户EXEC模式提示符后键入enable命令并按提示输入使能口令后将进入特权模式。可以管理系统时钟,进行错误检测,查看和保存配置文件,清除内存,处理并完成路由器的冷启动等操作。该模式不能对端口或网络协议进行配置。 
    该模式默认的提示符为:router# 
    c)全局配置模式 
    在特权EXEC模式下,通过键入configure terminal命令可以进入。全局配置模式用于配置路由器的全局性参数(主机名,口令,TFTP服务器,静态路由,访问控制列表等),更改已有配置等。 
    该模式默认的提示符为:router(config)# 
    d)其它配置模式 
    包括接口配置模式、虚拟终端配置模式、路由配置模式等。在全局配置的模式下输入相应的命令即可进入相应的配置模式。 
    接口配置模式: 
    router(config)#interface f0/12 
    router(config-if)# 
    虚拟终端配置模式: 
    router(config)#line vty 0 15 
    router(config-line)# 
    路由配置模式: 
    router(config)#router rip 
    router(config-router)# 
    e)设置模式 
    当通过console端口计入一台刚出厂的没有任何配置的路由器启动时会进入设置模式。系统以对话框提示用户设置路由器,协助用户建立第一次的配置文件。 
    f)RXBOOT模式 
    RXBOOT模式是路由器的维护模式。在密码丢失时,可以进入RXBOOT模式,以恢复密码。 
    二,路由器的基本操作和配置方法 
    (1)路由器的配置方式 
    a)使用通过远程拨号配置路由器(AUX) 
    b)使用控制端口Console配置路由器。 
    c)使用telnet配置路由器 
    1,必备条件 
    作为模拟终端的计算机与路由器都必须与网络连通,它们之间能够相互通信。 
    计算机必须有访问路由器的权限 
    路由器必须预先配置好远程登录的密码 
    2,路由器的配置 
    router (config)#line vty 0 15 
    router (config-line)#password 7 zzz307 
    3,远程登录的具体步骤 
    进入“运行窗口”,输入“telnet 202.112.7.4” 
    d)使用TFTP配置路由器 
    在网络上必须配置一台计算机作为TFTP server,且必须安装运行TFTP server软件。

    展开全文
  • 无线路由器原理

    千次阅读 2014-07-09 16:52:23
    无线路由器原理 1.无线AP与无线路由器的区别 无线AP:AP全称是AccessPoint,其功能是把有线网络转换为无线网络。形像点说,无线AP是无线网和有线网之间沟通的桥梁。其信号范围为球形,搭建的时候最好放到比较高的...

    无线路由器原理

    1.无线AP与无线路由器的区别

    无线AP:AP全称是AccessPoint,其功能是把有线网络转换为无线网络。形像点说,无线AP是无线网和有线网之间沟通的桥梁。其信号范围为球形,搭建的时候最好放到比较高的地方,可以增加覆盖范围,无线AP也就是一个无线交换机,接入在有线交换机或是路由器上,接入的无线终端和原来的网络是属于同一个子网。

    无线路由器:无线路由器就是一个带路由功能的无线AP,接入在ADSL宽带线路上,通过路由器功能实现自动拨号接入网络,并通过无线功能,建立一个独立的无线家庭组网。

    2.接口

    常见的无线路由器一般都有一个RJ45口为WAN口,也就是UPLink到外部网络的接口,其余2-4个口为LAN口,用来连接普通局域网,内部有一个网络交换机芯片,专门处理LAN接口之间的信息交换。通常无线路由的WAN口和LAN之间的路由工作模式一般都采用NAT(Network AddressTranslation)方式。所以,其实无线路由器也可以作为有线路由器使用。


    接口

    解释1:网络交换机,是一个扩大网络的器材,能为子网络中提供更多的连接端口,以便连接更多的计算机。交换机拥有一条很高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上,控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的MAC(网卡的硬件地址)的NIC(网卡)挂接在哪个端口上,通过内部交换矩阵迅速将数据包传送到目的端口,目的MAC若不存在,广播到所有的端口,接收端口回应后交换机会“学习”新的MAC地址,并把它添加入内部MAC地址表中。使用交换机也可以把网络“分段”,通过对照IP地址表,交换机只允许必要的网络流量通过交换机。通过交换机的过滤和转发,可以有效的减少冲突域,但它不能划分网络层广播,即广播域。

    解释2:NAT是将IP 数据包头中的IP 地址转换为另一个IP 地址的过程。在实际应用中,NAT 主要用于实现私有网络访问公共网络的功能。实现方式有三种,即静态转换Static Nat、动态转换Dynamic Nat和端口多路复用OverLoad。静态转换是指将内部网络的私有IP地址转换为公有IP地址,IP地址对是一对一的;动态转换是指将内部网络的私有IP地址转换为公用IP地址时,IP地址是不确定的,是随机的,所有被授权访问上Internet的私有IP地址可随机转换为任何指定的合法IP地址;端口多路复用(Port address Translation,PAT)是指改变外出数据包的源端口并进行端口转换,即端口地址转换。内部网络的所有主机均可共享一个合法外部IP地址实现对Internet的访问,从而可以最大限度地节约IP地址资源。同时,又可隐藏网络内部的所有主机,有效避免来自internet的攻击。因此,目前网络中应用最多的就是端口多路复用方式。

    3.结构


    举例结构



    电路板

    从电路框图看,外置的AC/DC电源适配器将市电变换成直流,再经过DC稳压滤波给整个电路提供5V和3.3V DC稳定工作电源。时钟电路为CPU、RAM和各种控制芯片提供7.372M、20M、25M、50M的工作时钟信号。EA-2204核心是一颗ARM7处理器,通过系统总线连接FLASHSDRAM,路由器上电后,CPU从FLASH中读取程序和配置数据进行初始化,SDRAM为程序运行和数据处理提供临时存储空间。CPU复位电路在系统上电或电源异常又恢复时使CPU自动复位,用户在必要时可通过按后面板上的复位开关来使CPU复位。CPU控制广域以太网控制芯片,通过一个RJ-45接口或RS232接口,连接国际互联网来处理数据。一个4端口交换控制器,通过四个RJ-45连接局域网集线器、交换机或连接电脑,直接进行数据交换或通过CPU控制与广域网连接进行数据处理。

    4.各项参数

    协议标准:到2013年,无线路由器产品支持的主流协议标准为IEEE 802.11n,并且向下兼容802.11g、802.11b。在无线路由器领域,除了以上两种协议外,其实还有一个IEEE802.11a标准,只是由于其兼容性不太好而未被普及。而IEEE802.11b与802.11g标准是可以兼容的,它们最大的区别就是支持的传输速率不同,前者只能支持到11M,而后者可以支持54M。802.11g+标准可以支持108M的无线传输速率,而新推出的802.11n可达到150M的无线传输速率,传输速度可以基本与有线网络持平。综上所述,如果构建一个数据传输频繁且有一定传输速率要求的无线网络,那么支持IEEE802.11g标准的无线路由器是首选;而如果是初涉无线网络,则可以选择价格相对低廉的支持IEEE802.11b的产品。

    数据传输率:指它在一定的网络标准之下接收和发送数据的能力;不过在无线网络中,该性能和环境有很大的关系。实际的情况是,无线局域网的实际传输速度只能达到产品标称最大传输速度的一半以下;比如802.11b理论最大速度为11M,通过笔者的测试,在无线网络环境较好的情况下,传输100MB的文件需要3分钟左右;而相同的环境,换为支持802.11g的产品,传输100MB的文件就只需要30秒左右。因此在选购产品时,在你需要的传输速率的基础上,还应作上浮考虑。

    信号覆盖:顾名思义也就是说只有在无线路由器的信号覆盖范围内,其他计算机才能进行无线连接。

    工作频率:我们可以这样简单的来理解:将无线路由器比作日常通讯工具--手机,手机所用的频率一般在800至2000MHz之间,而无线路由器和手机的工作频率差不多,为2.4GHz。2013年还有发展到5.8GHz的趋势。

    处理器:路由器与计算机一样,都包含了一颗中央处理器(CPU)。无论在中低端路由器还是在高端路由器中,CPU都是路由器的核心。到2013年,在无线路由器中使用的处理器普遍是ARM9类型。

    内存:路由器中有多种内存,用作存储配置、路由器操作系统、路由协议软件等内容,理论上说路由器内存越大越好,但内存并不能直接反映出一款无线路由器的性能与能力!

    在安全方面,大家多注意一下产品支持的加密类型,支持的类型越多,自然其安全性也就有更高的保障;同时支持的功能越多,其性能以及价格当然也就越高,具体的选择需求当然也就应以自己的实际而定。

    5.无线路由器的工作原理1

    为了简单地说明路由器的工作原理,现在我们假设有这样一个简单的网络。

      如图所示,A、B、C、D四个网络通过路由器连接在一起,现在我们来看一下在如图所示网络环境下路由器又是如何发挥其路由、数据转发作用的。现假设网络A中一个用户A1要向C网络中的C3用户发送一个请求信号时,信号传递的步骤如下:

      第1步:用户A1将目的用户C3的地址C3,连同数据信息以数据帧的形式通过集线器或交换机以广播的形式发送给同一网络中的所有节点,当路由器A5端口侦听到这个地址后,分析得知所发目的节点不是本网段的,需要路由转发,就把数据帧接收下来。

      第2步:路由器A5端口接收到用户A1的数据帧后,先从报头中取出目的用户C3的IP地址,并根据路由表计算出发往用户C3的最佳路径。因为从分析得知到C3的网络ID号与路由器的C5网络ID号相同,所以由路由器的A5端口直接发向路由器的C5端口应是信号传递的最佳途经。

      第3步:路由器的C5端口再次取出目的用户C3的IP地址,找出C3的IP地址中的主机ID号,如果在网络中有交换机则可先发给交换机,由交换机根据MAC地址表找出具体的网络节点位置;如果没有交换机设备则根据其IP地址中的主机ID直接把数据帧发送给用户C3,这样一个完整的数据通信转发过程也完成了。


    无线路由器工作原理2

        在只有一个网段的网络中,包可以很容易地从源主机到达目标主机,但是如果一台计算机要和非本网段的计算机进行通信,数据包可能需要经过很多路由器,如下面图所示,


    步骤阅读

    主机A和主机B所在的网段被许多路由器隔开,这是主机A与主机B的通信就要进过这些中间路由器,这就要面临一个很重要的问题,如何选择到达目的地的路径。包从A到达B有很多条路径可供选择,但是很显然,在这些路径中在某一时刻总会有一条路径是最好的。因此,为了尽可能地提高网络访问速度,就需要有一种方法来判断从源主机到达目的地主机所经过的最佳路径,从而进行数据转发,这就是路由技术。

        首先来看一下路由器是怎么工作的。对于普通用户来说,所能够接触到的只是局域网的范围,通过在PC上设置默认网关就可以是局域网的计算机与Internet进行通信,其实在计算机上所设置的默认网关就是路由器以太口的IP地址,如果局域网的计算机要和外面的计算机进行通信,只要把请求提交给路由器的以太口就可以了,接下来的工作就由路由器来完成了。因此可以说路由器就是互联网的中转站,网络中的包就是通过一个一个的路由器转发到目的网络的。那么路由器是如何进行包的转发的呢?就像一个人如果在去某个地方,一定要在他的脑海里有一张地图,在每个路由器的内部也有一张地图,这张地图就是路由表。在这个路由表中包含有该路由器掌握的所有目地网络地址,以及通过此路由器到达这些网络中最佳路径,这个最佳路径指的是路由器的某个接口或下一条路由器的地址。这是由于路由表的存在,路由器才可以依据路由表进行包的转发,如下面图所示网络为例。介绍路由器转发数据的过程。为了方便,将网段192.168.1.0/24简写为0,其他网段也做类似处理。


    主机1.1要发送数据包给主机4.1,因为IP地址不再同一网段,主机会将数据包发送给本网段的网关路由器A。路由器A接收到数据包,查看数据包IP中的目标IP地址,在查找自己的路由表,数据包的目标IP地址是4.1,属于4.0网段,路由器A在路由表中查到4。0网段转发的接口是SO接口。于是,路由表A将数据包从SO接口转发出去。网络中的每个路由器都是按这样的步骤去转发数据,直到到达了路由器B,用同样的转发方法,从EO口转发出去,4.1主机接收发哦这个数据包。在转发数据的过程中,如果在路由表中没有找到包的目的地地址,则根据路由器的配置转发到默认接口或者用户返回目标地址不可达的信息。

        路由表的形成:路由表是在路由器中维护的路由条目的集合,路由表很具路由表做路径选择。直连网段:当在路由器上配置了接口的IP地址,并且接口状态为up的时候,路由表中就出现直连路由项,如下面图所示:路由器A在接口FO/O和FO/1上分别配置了IP地址,并且在接口已经是up状态时,在路由器A的路由表中就会出现192.168.1.0和10.0.0.0这梁飞网段。非直连网段:那么对于20.0.0.0这样不直连在路由器A上的网段,路由器A应该怎么写进路由表呢?这就需要使用静态路由或动态路由来将这些网段以及如何转发写到路由表中。


    展开全文
  • 路由器原理及路由协议 本文通过阐述TCP/IP网络中路由器的基本工作原理,介绍了IP路由器的几大功能,给出了静态路由协议和动态路由协议,以及内部网关协议和外部网关协议的概念,同时简要介绍了目前最常见的RIP、...
  • 最通俗的理解路由器原理 网关 ARP dos
  • 路由器原理与设计李韬 第一讲一、课程介绍 课程关注点:互联网基础设施(router switch…)
  • 一本关于路由器原理和设计方法的书。从网上找出来不容易,所以分享下。
  • 路由器原理总结

    2019-01-20 14:45:57
    路由器是连各局域网、广域网的设备,它会根据信道的情况自动选择和设定路由,以最佳路径,路由器在网络层,路由器根据IP地址寻址,路由器可以处理TCP/IP协议,路由器可以把一个IP分配给很多个主机使用,这些主机对外...
  • 在信息网络高速发展的今天,相信大家对路由器都很熟悉了吧,本文主要介绍的是无线路由器原理和防止别人蹭网的方法,感兴趣的朋友们快来学习一下吧。
  • 路由器原理,包含(路由协议配置,设置静态路由,Ip协议配置,路由器技术,路由器性能指标,路由器基础概念解析)
  • MVC路由器原理

    2019-06-06 06:53:24
    目录 1、什么是路由 ... 3、URL的模式匹配 4、由URL到控制器 ...假如你在上大学的时候,睡觉起晚了,醒来后发现宿舍同学都走光了,你想到上午还有课,但是不记得去哪个教室去上了,这时候你会...网络中的路由器,路...
  • 路由器原理与应用

    2010-05-23 22:13:00
    路由器原理与应用一、路由的基本概念 路由器的网络层的设备,负责IP数据包的路由选择和转发。 1、路由类型 路由的类型有:直连路由、静态路由、默认路由和动态路由。 直连路由是与路由器直接相联网络的路由,...
  • AR9344路由器原理图.rar

    2020-06-19 08:21:19
    AR9344原理图设计 WIFI router 高通ar9344设计参考原理图.. 2.4g+5g

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,778
精华内容 2,711
关键字:

路由器原理